Die Möglichkeiten von Mathcad

Mathcad kombiniert die aktive Dokumentoberfläche einer Kalkulationstabelle mit der WYSIWYG-Oberfläche einer Textverarbeitung. Die Rechenfähigkeiten von Mathcad reichen vom Aufaddieren einer Zahlenspalte über die Berechnung von Integralen und Ableitungen bis hin zur Lösung von Gleichungssystemen.

Sie können Gleichungen, Text und Grafiken an jeder beliebigen Stelle des Mathcad-Arbeitsblatts platzieren. Die Gleichungen werden nach dem WYSIWYG-Prinzip und dynamisch angezeigt. Sie werden also so dargestellt, wie Sie sie von der Tafel oder aus Ihren Lehrbüchern kennen, und sobald Sie eine Änderung irgendwo im Arbeitsblatt vornehmen, aktualisiert Mathcad das Ergebnis und zeichnet die Graphen neu. Dadurch können Sie selbst äußerst komplexe Berechnungen jederzeit nachvollziehen.

Nachdem Sie ein präsentationsreifes Dokument erstellt haben, können Sie auch andere an Ihrer Arbeit teilhaben lassen, indem Sie das Arbeitsblatt ausdrucken, wobei es im Ausdruck genauso aussieht, wie auf dem Bildschirm, es per E-Mail versenden oder Ihr Arbeitsblatt im Web platzieren.


Mathcad-Desktop

Wenn Sie Mathcad starten, sehen Sie Folgendes auf dem Bildschirm:

Ein neues Mathcad-Arbeitsblatt

Die Menüleiste

Die Rechensymbolleiste

Die Standardsymbolleiste

Die Formatierungssymbolleiste

Um mehr Platz für die Anzeige des Arbeitsblatts zu erhalten, können Sie mit den Befehlen des Menüs Ansicht nicht benötigte Elemente ausblenden bzw. die benötigten Elemente wieder einblenden. Sie können sie auch um Ihr Fenster herum verschieben. Wenn Sie Mathcad beenden und erneut öffnen, befinden sich die Elemente dort, wo sie sich vor dem Beenden des Programms befanden.


Mathcad-Arbeitsblatt

Mathcad-Arbeitsblätter bestehen aus einer Sammlung von Gleichungen, Text, Grafiken und anderen Elementen. Jede Gleichung, Textstelle, Grafik und jedes andere Element, das Sie in das Arbeitsblatt aufnehmen, wird als "Bereich" bezeichnet. Mathcad erstellt für jeden Bereich ein unsichtbares Rechteck, das seine Grenzen definiert. Sie können die Bereiche sichtbar machen, indem Sie Bereiche im Menü Ansicht wählen.

Zum Erstellen eines neuen Bereichs gehen Sie folgendermaßen vor:

  1. Klicken Sie auf eine leere Stelle. Es wird ein kleiner Fadenkreuz-Cursor angezeigt, wenn Sie die Maustaste drücken.

  2. Geben Sie dann eine Gleichung oder Text ein, erstellen Sie ein Diagramm usw.

Beim Einfügen mehrerer Gleichungen, Textstellen und Grafiken in ein Arbeitsblatt können Sie sie nach Belieben anordnen und formatieren.


Lernprogramme, QuickSheets und Referenztabellen

Über die Symbolleiste Ressourcen haben Sie Zugriff auf Lernprogramme, QuickSheets und Referenztabellen in Form elektronischer Bücher. Die Lernprogramme umfassen die wichtigsten Grundlagen, ausführlichere Beschreibungen sowie einige Themen für Fortgeschrittene. Die QuickSheets stellen viele der Mathcad-Funktionen und -Programme, die Sie selbst bei der Arbeit verwenden können, in aktiven Beispielen dar. Die Referenzttabellen enthalten nützliche mathematische Formeln und Konstanten. Auf alle drei Ressourcen können Sie über das Menü Hilfe zugreifen.

Wenn Sie eines dieser elektronischen Bücher geöffnet haben, können Sie Themen durch einen Mausklick öffnen und mit den Pfeiltasten auf der Symbolleiste darin blättern.


Drucken eines Arbeitsblatts

Zum Drucken des gegenwärtig aktiven Arbeitsblatts gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl "Drucken" aus dem Menü Datei. Daraufhin öffnet sich das Dialogfeld "Drucken".

  2. Klicken Sie auf "OK".

Wenn Sie sich vor dem Drucken ansehen wollen, wie Ihr Arbeitsblatt gedruckt aussehen wird, wählen Sie den Befehl "Seitenansicht" aus dem Menü Datei.


Speichern eines Arbeitsblatts

Zum Speichern eines Arbeitsblatts gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Speichern im Menü Datei. Hierdurch wird die alte Kopie des Arbeitsblatts ersetzt.

Zum Speichern des Arbeitsblatts, ohne die alte Kopie zu ersetzen, gehen Sie wie folgt vor:

  1. Wählen Sie im Menü Datei den Befehl Speichern unter.

  2. Speichern Sie das Arbeitsblatt unter einem anderen Namen.

Mit dem Befehl Speichern unter und der Dropdown-Liste Speichern als können Sie Arbeitsblätter als RTF-Datei, HTML-Datei oder als Arbeitsblatt, das mit einer vorherigen Version kompatibel ist, speichern.

Hinweis:

Wenn Sie die Mathcad-Arbeitsblätter mit Microsoft SharePoint verwalten, können Sie Dateien direkt in der Dokumentbibliothek speichern.


Eingeben von Gleichungen

Zum Erstellen mathematischer Ausdrücke in Mathcad müssen Sie lediglich den Fadenkreuz-Cursor in das Arbeitsblatt setzen und mit der Eingabe von Buchstaben, Zahlen oder Operatoren, wie + oder -, beginnen.

  • Wenn Sie Buchstaben oder Zahlen eingeben, werden sie zwischen Bearbeitungslinien angezeigt, die darauf hinweisen, welche Zeichen ausgewählt sind. Mit der Leertaste und den Pfeiltasten können Sie verschiedene Teile eines Ausdrucks auswählen.

  • Sie können Operatoren einfügen, indem Sie auf die entsprechende Schaltfläche in den Operator-Symbolleisten klicken oder die Tastenkombination für den Operator drücken.

Mit den folgenden Schritten erstellen Sie den Ausdruck [image] und lassen anzeigen, wie Zahlen, Bearbeitungslinien und Operatoren zusammenarbeiten:

  1. Geben Sie a ein.

  2. Geben Sie [Umschalt] 6 ein, den Tastaturbefehl für Exponentialoperatoren.

  3. Geben Sie 2 im Platzhalter ein, der jetzt angezeigt wird.

  4. Drücken Sie + auf der Tastatur für den Additionsoperator, und geben Sie b im Platzhalter ein.

  5. Drücken Sie zweimal die Leertaste, damit der gesamte Ausdruck zwischen die Bearbeitungslinien gesetzt wird.

  6. Drücken Sie + auf der Tastatur, und geben Sie y im Platzhalter ein.

Mathcad setzt automatisch die verschiedenen Teile eines Ausdrucks entsprechend der geltenden Rangfolge und verschiedener weiterer Regeln zusammen, durch die die Eingabe von Nennern, Exponenten und Ausdrücken in Wurzeln vereinfacht wird. Mathcad setzt beispielsweise Ihre Eingaben neben die in den Bearbeitungslinien eingeschlossenen Zeichen.


Auswerten von Ausdrücken

Mathcad kann nicht nur für komplizierte mathematische Berechnungen eingesetzt werden, sondern auch als einfacher Rechner gute Dienste leisten. Mit den folgenden Schritten können Sie eine einfache numerische Berechnung durchführen:

  1. Klicken Sie auf eine beliebige Stelle im Mathcad-Arbeitsblatt, und geben Sie den auszuwertenden Ausdruck ein.

  2. Drücken Sie "=".

Stellen Sie sicher, dass keine der Variablen im Ausdruck links neben dem Gleichheitszeichen rot hervorgehoben sind.

Sie können Ausdrücke auch symbolisch auswerten.


Verwenden von Bereichsvariablen zur Auswertung von Ausdrücken

Auswerten eines Ausdrucks über einen Bereich

Verwenden Sie Bereichsvariablen, um einen Ausdruck wiederholt über einen Variablenbereich auszuwerten (siehe unten). Mathcad wertet den Ausdruck genau einmal für jeden Wert der Bereichsvariable aus.

Wenn Sie in einer Gleichung mehrere Bereichsvariablen verwenden, berechnet Mathcad die Gleichung einmal für jede Bereichsvariable. Dies ist bei der Definition von Matrizen von Vorteil:


Definieren von Variablen

Bevor Sie einen Ausdruck auswerten können, der statt einer Konstante eine Variable enthält, müssen Sie die Variable definieren. Gehen Sie hierzu folgendermaßen vor:

  1. Geben Sie den Variablennamen ein.

  2. Geben Sie ":" ein, um das Definitionssymbol ":=" und einen Platzhalter anzuzeigen.

  3. Geben Sie eine Nummer, einen Ausdruck oder eine Zeichenfolge in den Platzhalter ein.

Wenn Sie einen Ausdruck im Platzhalter eingeben, müssen Sie darauf achten, dass Variablen oder Funktionen in diesem Ausdruck keine rot hervorgehobenen undefinierten Variablen sind .


Definieren einer Funktion

Eine Funktion ist eine Regel, die ihre Argumente bestimmten Operationen unterzieht und als Ergebnis einen numerischen Wert zurückgibt. So definieren Sie eine Funktion:

  1. Geben Sie den Funktionsnamen gefolgt von einer linken Klammer ein.

  2. Geben Sie eine Liste von durch Kommas getrennten Argumenten gefolgt von einer rechten Klammer ein.

  3. Geben Sie ":" ein, um das Definitionssymbol ":=" und einen Platzhalter anzuzeigen.

  4. Geben Sie einen Ausdruck oder eine Zeichenfolge im Platzhalter ein.

Achten Sie darauf, dass alle Variablen, die Sie im rechten Ausdruck verwenden, entweder

  • vorher definiert oder

  • Teil der Argumentliste sind.

Wenn eine Variable im Ausdruck auf der rechten Seite diese Bedingungen nicht erfüllt, wird sie als undefinierte Variable rot dargestellt.

Wenn Sie eine Funktion definiert haben, versucht Mathcad, diese erst dann auszuwerten, wenn Sie sie zu einem späteren Zeitpunkt auf dem Arbeitsblatt verwenden.


Eingeben von Variablen- und Funktionsnamen

Variablen- und Funktionsnamen können beliebig lang sein und viele unterschiedliche Zeichen enthalten. Es gibt jedoch einige Beschränkungen:

  • In Variablen- und Funktionsnamen zugelassene Zeichen

  • Beschränkungen bei Variablen- und Funktionsnamen...

  • Eingeben von Namen mit Operatoren

  • Eingeben von Namen mit Symbolen


Vordefinierte Konstanten

Vordefinierte mathematische Konstanten

Name | Tastaturbefehl
 | Strg+Umschalt+3
e | e
 | Strg+Umschalt+p
i | 1i
j | 1j
% | %

Neudefinieren von mathematischen Konstanten...

Vordefinierte Systemkonstanten

Name | Standardwert
TOL | .001
CTOL | .001
ORIGIN | 1
PRNPRECISION | 4
PRNCOLWIDTH | 8
CWD | aktuelles Arbeitsverzeichnis, definiert in Form einer Zeichenfolge

Neudefinieren von Systemkonstanten...


Eingeben und Anzeigen von Zahlen

Eingeben von Zahlen

Mathcad interpretiert alles, was mit einer Ziffer beginnt, als Zahl. Als generelle Regel gilt, dass Zahlen durch einfaches Drücken der entsprechenden Tasten auf der Tastatur eingegeben werden können. Dabei ist darauf zu achten, dass in Mathcad bei Dezimalbrüchen stets ein Punkt anstelle des im deutschen Sprachraum üblichen Kommas verwendet wird. Wenn Sie auf eines der folgenden Themen klicken, erfahren Sie, welche Sonderregeln es für das jeweilige Thema gibt:

  • Zahlen > 999

  • Exponentialschreibweise

  • Imaginäre Zahlen

  • Komplexe Zahlen

  • Zahlen mit anderen Basen


Bearbeitungscursor

Der Bearbeitungscursor kann die drei unten gezeigten Formen haben. Wenn Sie auf das entsprechende Bild klicken, werden Angaben zur Funktion und zum Anzeigen des jeweiligen Cursors angezeigt.

Fadenkreuz

Texteinfügemarke

Bearbeitungslinien

Der Cursor entspricht nicht dem "Zeiger". Der Zeiger wird zum Platzieren des Cursors verwendet. Die Form, die der Cursor annimmt, hängt davon ab, worauf der Zeiger zeigt, wenn Sie mit der Maus klicken.


Ändern eines Namens oder einer Zahl

Hierfür gibt es zwei Verfahren. Wenn Sie nur einige Zeichen ändern müssen...

  1. Klicken Sie auf den Namen bzw. die Zahl. Verschieben Sie gegebenenfalls mit der Taste "Pfeil-nach-links" oder "Pfeil-nach-rechts" die Einfügelinie.

  2. Geben Sie Buchstaben und Zahlen ein. Mit der Rücktaste löschen Sie ein Zeichen direkt hinter der Einfügelinie.

...oder wenn Sie ganz neu beginnen möchten:

  1. Klicken Sie auf den Namen bzw. die Zahl. Drücken Sie bei Bedarf die Leertaste, um den Namen oder die Zahl vollständig zwischen den Bearbeitungslinien einzuschließen.

  2. Wählen Sie Ausschneiden im Menü Bearbeiten. Dadurch wird der Name oder die Zahl gelöscht und stattdessen ein Platzhalter eingefügt.

  3. Klicken Sie auf den Platzhalter, und geben Sie den neuen Namen oder die neue Zahl ein.


Einfügen eines Operators

Beachten Sie beim Einfügen eines Operators, dass das Zeichen zwischen den Bearbeitungslinien zum ersten Operanden des nächsten eingegebenen Operators wird. Gehen Sie beim Einfügen eines Operators daher wie folgt vor:

  1. Setzen Sie das Zeichen zwischen die Bearbeitungslinien, das Sie als Operand verwenden möchten. Drücken Sie erforderlichenfalls die Leertaste, um die Bearbeitungslinien zu verlängern.

  2. Geben Sie den Tastaturbefehl für den Operator ein.

  3. Sie fügen einen Operator vor dem ausgewählten Ausdruck ein, indem Sie vor seiner Eingabe die Einfg-Taste drücken.

Um in einen Operatorplatzhalter (der nach dem Löschen eines Operators aus einem komplexen Ausdruck erscheint) einen Operator einzusetzen, setzen Sie die vertikale Bearbeitungslinie vor oder hinter den Operatorplatzhalter und drücken dann den Tastaturbefehl für den Operator.


Löschen eines Operators

So Löschen Sie einen Operator:

  1. Setzen Sie die Einfügelinie zwischen den Operanden und den Operator.

  2. Drücken Sie entweder die Rücktaste oder die Taste Entf, je nachdem, ob sich der Operator links oder rechts der vertikalen Einfügelinie befindet.

Bei komplexeren Ausdrücken erscheint nach dem Löschen eines Operators ein Operatorplatzhalter. Zum Beispiel wurde der Subtraktionsoperator in dem folgenden Ausdruck gelöscht:

Drücken Sie die entsprechende Taste für den gewünschten neuen Operator. Beispiel:

Hinweis: In komplexen Ausdrücken (siehe obiges Beispiel) können Sie den Operatorplatzhalter nicht löschen. Sie müssen ihn durch einen Operator ersetzen. In anderen Fällen, z. B. wenn der Operatorplatzhalter zwischen zwei einfachen Zahlen liegt, können sie den Operatorplatzhalter löschen.


Einfügen von Klammern

Es ist normalerweise viel einfacher, ein Paar von Klammern mit dem folgenden Verfahren einzufügen:

  1. Setzen Sie den Ausdruck zwischen die Bearbeitungslinien.

  2. Drücken Sie die Apostrophtaste ('), um Klammern einzufügen.

Dies ist weit bequemer als das Einfügen einzelner Klammern wie in Textverarbeitungsprogrammen.


Löschen von Klammern

So löschen Sie ein Klammerpaar:

  1. Ziehen Sie die Einfügemarke rechts neben die runde Klammer "(".

  2. Drücken Sie die Rücktaste.

Es ist nicht möglich, nur eine Klammer zu löschen. Wenn Sie eine der beiden Klammern löschen, wird die andere automatisch ebenfalls gelöscht.


Einfügen eines Minuszeichens

Mit dem unten beschriebenen Verfahren wird ein Minuszeichen als negatives Vorzeichen einer Zahl eingefügt.

  1. Klicken Sie in den Ausdruck, und drücken Sie gegebenenfalls die Leertaste, sodass er zwischen die Bearbeitungslinien gesetzt wird.

  2. Drücken Sie die Einfg-Taste, um den vertikalen Zweig an die linke Seite zu setzen.

  3. Drücken Sie die Taste mit dem Minuszeichen.


Löschen eines Minuszeichens

Im nachfolgend beschriebenen Vorgang wird das Minuszeichen gelöscht, das ein negatives Vorzeichen einer Zahl ist.

  1. Klicken Sie auf den Ausdruck, und drücken Sie gegebenenfalls die Leertaste, sodass es zwischen die Bearbeitungslinien gesetzt wird.

  2. Drücken Sie die Taste EINFG, um die Einfügelinie nach links zu verschieben.

  3. Drücken Sie die Rücktaste.


Anwenden einer Funktion auf einen Ausdruck

Mit dem folgenden Verfahren können Sie einen Ausdruck zum Argument einer Funktion machen:

  1. Klicken Sie in den Ausdruck, und drücken Sie die Leertaste, bis sich der gesamte Ausdruck zwischen den Bearbeitungslinien befindet.

  2. Drücken Sie die Apostrophtaste ('), um den Ausdruck in Klammern zu setzen.

  3. Drücken Sie die Leertaste, um die Klammern zwischen die Bearbeitungslinien zu setzen.

  4. Drücken Sie die EINFG-Taste, um den vertikalen Zweig nach links zu verschieben.

  5. Geben Sie den Funktionsnamen ein.


Verschieben von Teilen eines Ausdrucks

Mit dem folgenden Verfahren verschieben Sie einen Teil eines Ausdrucks entweder in einen leeren Platzhalter oder in einen leeren Bereich des Arbeitsblatts.

  1. Setzen Sie den zu verschiebenden Ausdruck zwischen die Bearbeitungslinien.

  2. Wählen Sie aus dem Menü Bearbeiten den Befehl Ausschneiden oder Kopieren.

  3. Klicken Sie auf eine leere Stelle oder den Platzhalter, an der/dem Sie den ausgewählten Ausdruck einfügen möchten.

  4. Fügen Sie den Ausdruck mit dem Befehl Einfügen im Menü Bearbeiten ein.


Löschen von Teilen eines Ausdrucks

Mit dem folgenden Verfahren können Sie einen Teil eines Ausdrucks löschen und in die Zwischenablage verschieben:

  1. Positionieren Sie den zu löschenden Ausdruck zwischen den Bearbeitungslinien.

  2. Wählen Sie im Menü Bearbeiten die Option Ausschneiden . Dadurch wird ein leerer Platzhalter gesetzt.

Wenn Sie den Ausdruck in der Zwischenablage nicht behalten möchten, kann mit dem folgenden Verfahren ein Teil von ihm gelöscht werden:

  1. Halten Sie die Maustaste gedrückt, und ziehen Sie den Cursor über den zu löschenden Ausdruck. Er wird in der Umkehrdarstellung hervorgehoben.

  2. Drücken Sie die Taste Entf. Dadurch wird ein leerer Platzhalter gesetzt.

Hinweis:

Mit der Rücktaste wird normalerweise das Objekt gelöscht, das sich links von der Einfügelinie befindet. Wenn der zu löschende Ausdruck komplizierter ist als ein Name oder eine Zahl, wird er durch Drücken der Rücktaste jedoch wie gezeigt markiert. Wenn Sie die Rücktaste dann erneut drücken, wird er gelöscht. Dadurch ist unbeabsichtigtes Löschen eines Ausdrucks nahezu ausgeschlossen.


Suchen und Ersetzen von Zeichen

Zum Suchen nach Zeichen gehen Sie folgendermaßen vor:

  1. Wählen Sie Suchen aus dem Menü Bearbeiten. Das Dialogfeld "Suchen" wird eingeblendet.

  2. Geben Sie die gesuchten Zeichen im Textfeld Suchen nach ein.

  3. Um bestimmte Zeichen in einem Textbereich zu suchen, muss die Option In Textbereichen suchen ausgewählt sein. Um Zeichen in Rechenbereichen zu suchen, muss die Option In Rechenbereichen suchen ausgewählt sein. Sie können auch beide Bereiche gleichzeitig durchsuchen.

  4. Klicken Sie auf Weitersuchen.

Zum Suchen und Ersetzen von Zeichen gehen Sie folgendermaßen vor:

  1. Wählen Sie Ersetzen aus dem Menü Bearbeiten. Das Dialogfeld "Ersetzen" wird eingeblendet.

  2. Geben Sie die gesuchten Zeichen im Textfeld Suchen nach ein.

  3. Geben Sie im Textfeld Ersetzen durch: die Zeichen ein, die die gefundenen Zeichen ersetzen sollen.

  4. Klicken Sie auf Weitersuchen.

  5. Danach stehen drei Möglichkeiten für Sie zur Auswahl:

  • Klicken Sie auf Weitersuchen, wenn Sie die nächste Stelle mit dem gesuchten Element finden und markieren möchten.

  • Klicken Sie auf Ersetzen, wenn Sie das gefundene, markierte Element ersetzen und nach der nächsten Fundstelle suchen möchten.

  • Klicken Sie auf Alle ersetzen, wenn Sie das Element durchgängig ersetzen möchten.


Formatieren von Ergebnissen

Die Ergebnisse einer Arbeitsblattberechnung können formatiert werden. Die Art der Anzeige von Zahlen wird als Ergebnisformat bezeichnet. Sie können das Ergebnisformat für alle Ergebnisse in einem Arbeitsblatt oder für ein bestimmtes Ergebnis festlegen.

Steuern der Anzeige aller Ergebnisse

Steuern der Anzeige eines bestimmten Ergebnisses

Das Ergebnisformat wirkt sich nur auf die Anzeige eines Ergebnisses aus. Sämtliche Berechnungen werden weiterhin unabhängig von den Formatierungsoptionen mit voller Genauigkeit durchgeführt.


Gleichungsformatvorlagen

Jedem Namen bzw. jeder Zahl in einer Gleichung ist eine Gleichungsformatvorlage zugeordnet, und für jedes Schriftartattribut sind die Schriftart, der Schriftgrad und ein Format definiert. Sie können somit die Schriftartmerkmale vieler Namen gleichzeitig ändern. Klicken Sie auf eines der folgenden Themen, um Informationen zur Verwendung der Schriftarten in einem bestimmten Zusammenhang zu erhalten:

Ändern der Schriftart für alle Variablen

Ändern der Schriftart für alle Konstanten

Ändern der Schriftart einer bestimmten Variable

Einfügen griechischer Variablen


Hervorheben eines Bereichs

Gehen Sie folgendermaßen vor, wenn Sie eine Gleichung, einen Textbereich, ein Diagramm oder einen Bereich durch eine Änderung der Hintergrundfarbe deutlicher abheben möchten:

  1. Klicken Sie in den Bereich.

  2. Wählen Sie Eigenschaften im Menü Format.

  3. Klicken Sie auf die Registerkarte Anzeige.

  4. Klicken Sie auf Farbe auswählen, um eine andere Hintergrundfarbe als die Standardhintergrundfarbe festzulegen.

  5. Aktivieren Sie das Kontrollkästchen Bereich hervorheben.

  6. Klicken Sie auf OK.

Sie sehen einen Rahmen um den Bereich, der mit einer Farbe gefüllt ist, die so hell ist, dass die Gleichung weiterhin sichtbar ist. Auf die Gleichung selbst hat dies keinerlei Auswirkungen.

Zum Wiederherstellen des Hintergrunds gehen Sie folgendermaßen vor:

  1. Klicken Sie in den Bereich.

  2. Wählen Sie Eigenschaften im Menü Format.

  3. Klicken Sie auf die Registerkarte Anzeige.

  4. Aktivieren Sie das Kontrollkästchen Bereich hervorheben.


Anzeige numerischer Ergebnisse mit voller Genauigkeit

Sämtliche Arithmetik wird unabhängig von der Anzeige der Zahl im Arbeitsblatt mit voller Genauigkeit ausgeführt. Sie können ein bestimmtes Ergebnis mit voller Genauigkeit entweder permanent, durch Ändern seines Formats oder vorübergehend ändern:

  1. Klicken Sie auf die Zahl, die mit voller Genauigkeit angezeigt werden soll.

  2. Drücken Sie Strg+Umschalt+N.

Die Zahl wird daraufhin mit voller Genauigkeit in der Meldungszeile der Statusleiste am unteren Fensterrand angezeigt.

Hinweis:

Mit voller Genauigkeit können auf diese Weise nur Einzelwerte, jedoch keine Felder von Werten angezeigt werden. Soll die volle Genauigkeit eines errechneten Feldes angezeigt werden, müssen Sie seine Formateinstellungen ändern. Erhöhen Sie hierzu die angezeigte Genauigkeit im Dialogfeld "Ergebnisformat" auf 15.


Text, Überblick

Textbereiche dienen dazu, Ihr Arbeitsblatt mit Kommentaren, Erläuterungen und Anmerkungen zu versehen. Textbereiche können an jeder beliebigen Stelle eines Arbeitsblatts eingefügt, bearbeitet und formatiert werden.

Textbereiche können wie andere Bereiche auch bearbeitet werden. Sie können sie kopieren, ausschneiden und löschen. Sie können einen Textbereich auch an eine beliebige Stelle des Arbeitsblatts verschieben.

Textbereiche unterstützen viele Textformatierungsfunktionen, die auch aus Textverarbeitungsprogrammen bekannt sind. Sie können die Formatierung der Zeichen in einem Textbereich ändern und die Rechtschreibung des Textes überprüfen lassen. Auch die Absätze innerhalb von Textbereichen können formatiert werden, indem Sie deren Ausrichtung und Einzug festlegen oder ihnen Aufzählungszeichen und Numerierungen zuweisen.

Textbereiche verfügen über bestimmte Eigenschaften, die das Verhalten und Aussehen dieser Bereiche festlegen. So können Sie z. B. die Breite eines Textbereichs bestimmen. Sie können aber auch festlegen, ob die benachbarten Bereiche verschoben werden, wenn ein Textbereich bei der Eingabe von Text größer wird.

  • Text erstellen und bearbeiten: Textbereiche einfügen, ausschneiden, kopieren, aus der Zwischenablage einfügen usw.

  • Text formatieren: Schriftarten ändern, Aufzählungszeichen, Nummerierungen, Ausrichtung, Einzüge hinzufügen

  • Attribute von Textbereichen festlegen: Breite steuern, Interaktion mit anderen Bereichen festlegen


Erstellen eines Textbereichs

So erstellen Sie einen Textbereich:

  1. Klicken Sie auf die Stelle, an welcher der Bereich platziert soll.

  2. Wählen Sie im Menü Einfügen den Befehl Textbereich. Es wird ein Textfeld angezeigt.

  3. Beginnen Sie mit der Eingabe des Textes. Die Größe des Textfelds passt sich automatisch der Eingabe an. Wenn Sie außerhalb des Textbereichs klicken, wird das Textfeld nicht merh angezeigt. Die Formatierung des Textes richtet sich nach der Textformatvorlage "Normal".

Wenn Sie die Eingabe des Textes beenden wollen, müssen Sie auf eine Stelle außerhalb des Textbereichs klicken. Drücken Sie nicht die Eingabetaste, da sonst im aktiven Textbereich eine neue Zeile erstellt wird.

Tipp:

Eine andere Möglichkeit, einen Textbereich zu erstellen, besteht darin, von Mathcad automatisch einen Textbereich erstellen zu lassen. Klicken Sie dazu einfach an der gewünschten Position des Textes, und beginnen Sie mit der Eingabe. Zunächst wird alles, was Sie eingeben, als Rechenbereich betrachtet. Sobald Sie aber die Leertaste drücken, wird aus dem Rechenbereich automatisch ein Textbereich.


Importieren von Text

Zum Einfügen von Text aus einer anderen Anwendung in Ihr Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Kopieren Sie den gewünschten Text aus der anderen Anwendung in die Zwischenablage.

  2. Klicken Sie in das Arbeitsblatt, und wählen Sie den Befehl Einfügen aus dem Menü Bearbeiten.


Auswählen von Text

Zum Auswählen (Markieren) einer Gruppe von Zeichen gehen Sie folgendermaßen vor:

  1. Positionieren Sie die Einfügemarke an einem Ende des auszuwählenden Textes.

  2. Ziehen Sie die Maus an das andere Ende der gewünschten Auswahl.

  3. Wenn Sie das Ende erreicht haben, lassen Sie die Maustaste wieder los. Der ausgewählte Bereich wird andersfarbig unterlegt.

Text kann auch auf andere Art und Weise ausgewählt (markiert) werden:

  • Zum Auswählen von nur einem Wort doppelklicken Sie auf das Wort. Das Wort wird daraufhin unterlegt.

  • Zum Auswählen von nur einem Absatz klicken Sie dreimal auf ein Wort in dem entsprechenden Absatz.

  • Zum zeichenweisen, wortweisen oder zeilenweisen Auswählen von Textzeichen verwenden Sie die Pfeiltasten.

Hinweis:

  • Diese Funktion ist nur bei Text, den Sie hinzufügen, verfügbar, nicht beim bereits vorhandenen Inhalt.


Bearbeiten von Text

Zum Kopieren bzw. Ausschneiden von Text gehen Sie wie folgt vor:

  1. Markieren Sie den Text.

  2. Wählen Sie Kopieren oder Ausschneiden im Menü Bearbeiten. Der Text wird in die Zwischenablage übernommen.

Zum Einfügen von Text gehen Sie wie folgt vor:

  1. Klicken Sie in den Textbereich, in den der Text eingefügt werden soll.

  2. Verschieben Sie die Einfügemarke an die Stelle, an der der Text eingefügt werden soll.

  3. Klicken Sie auf Einfügen im Menü Bearbeiten, um den Text einzufügen.

Zum Löschen von Text aus einem bestehenden Textbereich klicken Sie in den Bereich, und gehen Sie dann folgendermaßen vor:

  • Drücken Sie die Rücktaste, um das Zeichen links neben der Einfügemarke zu löschen.

  • Drücken Sie die Taste ENTF, um das Zeichen rechts neben der Einfügemarke zu löschen.

Zum Überschreiben von Text gehen Sie folgendermaßen vor:

  1. Platzieren Sie die Einfügemarke links neben das erste Zeichen, das Sie überschreiben möchten.

  2. Drücken Sie die Taste EINFG, und beginnen Sie mit der Eingabe. Die Einfügemarke ist jetzt in der Mitte unterbrochen, um anzuzeigen, dass Sie sich im Überschreibmodus befinden. Sie kehren zum standardmäßigen Einfügemodus zurück, indem Sie abermals die Taste EINFG drücken.


Verschieben von Text

Zum Verschieben eines Textbereichs gehen Sie folgendermaßen vor:

  1. Markieren Sie den Textbereich.

  2. Gehen Sie mit dem Mauszeiger auf einen der Ränder des Auswahlrechtecks. Der Mauszeiger wechselt seine Form von einem Pfeil zu einer kleinen Hand.

  3. Ziehen Sie mit der Maus. Der ausgewählte Text bewegt sich mit dem Mauszeiger mit.

Zum Ausschneiden und Einfügen eines Textbereichs gehen Sie folgendermaßen vor:

  1. Markieren Sie den Textbereich.

  2. Wählen Sie den Befehl Ausschneiden im Menü Bearbeiten, um den Textbereich in die Zwischenablage einzufügen.

  3. Klicken Sie mit der Maus auf die Stelle, an der der Textbereich eingefügt werden soll, und wählen Sie aus dem Menü Bearbeiten den Befehl Einfügen.


Einfügen von Rechenbereichen in Textbereiche

Sie können einen Rechenbereich in einen Textbereich einfügen. Solcherart eingefügte Rechenbereiche sind weiterhin "aktiv", verhalten sich also so, als wären sie außerhalb des Textes. Zum Einfügen eines Rechenbereichs in einen Textbereich gehen Sie folgendermaßen vor:

  1. Klicken Sie in den Textbereich, in dem der Rechenbereich positioniert werden soll.

  2. Wählen Sie den Befehl Rechenbereich im Menü Einfügen, oder drücken Sie Strg+Umschalt+A, um einen leeren Platzhalter einzufügen.

  3. Geben Sie die Gleichung in diesen Platzhalter auf die gleiche Weise ein, wie Sie es an anderer Stelle Ihres Arbeitsblatts tun würden.

Klicken Sie nach der Eingabe der Gleichung auf eine andere Stelle im Textbereich, um wieder in den Textmodus zu wechseln.

Zu beachten ist, dass sich das Einfügen von Gleichungen in Text auf Berechnungen im gesamten Arbeitsblatt auswirkt. Soll die Gleichung nur Textfunktion haben und sich nicht auf Berechnungen auswirken, können Sie sie deaktivieren.


Rechtschreibprüfung

Zur Überprüfung der Rechtschreibung des Textes in Ihrem Dokument gehen Sie wie folgt vor:

  1. Markieren Sie den Text, dessen Schreibweise auf Richtigkeit überprüft werden soll. Wenn Sie keinen Text auswählen, prüft die Rechtschreibprüfung den gesamten Text im Arbeitsblatt ab dem Cursor bis zum Ende des Arbeitsblatts.

  2. Wählen Sie den Befehl Rechtschreibung im Menü Extras.

  3. Wenn die Rechtschreibprüfung ein falsch geschriebenes Wort findet, wird das Dialogfeld "Rechtschreibung" geöffnet, in dem das falsch geschriebene Wort sowie einige Ersetzungsvorschläge angezeigt werden. Die Rechtschreibprüfung betrachtet alle Wörter als fehlerhaft, die nicht im aktiven Wörterbuch gefunden werden. Im Dialogfeld "Rechtschreibung" können Sie außerdem, wenn gewünscht, Wörter in das Wörterbuch eintragen.

Hinweis:

Sie können die Sprache ändern, in der die Rechtschreibprüfung durchgeführt wird, indem Sie im Menü Extras die Option Einstellungen wählen und dann im Dialogfeld "Voreinstellungen" die Option "Rechtschreibprüfung - Dialekt" wählen.


Ändern von Schriftarteigenschaften von Text

Bei der Eingabe von Text werden dessen Eigenschaften zunächst von den Standardvorgaben für das Arbeitsblatt bzw. den Standardvorgaben für die Formatvorlage "Normal" bestimmt. Zum Ändern der Schriftart, des Stils, des Schriftgrades, der Farbe oder der Position eines bestimmten Textabschnitts gehen Sie wie folgt vor:

  1. Markieren Sie den Text.

  2. Wählen Sie Text im Menü Format.

  3. Legen Sie im Dialogfeld die Eigenschaften für die Schriftart fest, und klicken Sie dann auf "OK".

Soll der gesamte Text verändert werden, dem eine bestimmte Textformatvorlage zugrunde liegt, müssen Sie entweder die Eigenschaften der Formatvorlage ändern oder dem Text eine andere Textformatvorlage zuweisen.


Ändern der Textabsatzeinstellungen

Für die Absätze in einem Textbereich können die folgenden Einstellungen vorgenommen werden:

  • Einzüge

  • Ausrichtung

  • Nummerierungen

  • Aufzählungszeichen

  • Tabulatoren

Zum Ändern dieser Eigenschaften für einen oder mehrere Absätze in einem Textbereich gehen Sie wie folgt vor:

  1. Markieren Sie Text innerhalb der Absätze.

  2. Wählen Sie Absatz im Menü Format.

  3. Nehmen Sie im Dialogfeld "Absatzformat" die gewünschten Änderungen vor, und klicken Sie auf "OK".

Zum schnellen Ändern von Ausrichtung, Aufzählungszeichen und Nummerierungen gehen Sie wie folgt vor:

  1. Markieren Sie Text innerhalb der Absätze.

  2. Klicken Sie auf eine der Ausrichtungsschaltflächen [image], auf die Schaltfläche für Aufzählungszeichen [image] oder auf die Schaltfläche für Nummerierungen [image] in der Symbolleiste "Formatierung".

Zum schnellen Einstellen von Tabulatoren und Einzügen gehen Sie vor wie folgt:

  1. Markieren Sie Text innerhalb des Absatzes.

  2. Wählen Sie Lineal im Menü Ansicht.

  3. Klicken Sie auf das Lineal, um Tabulatoren zu setzen. Verschieben Sie die Pfeile auf dem Lineal, um die Einzüge einzustellen.

Hinweise:

  • Ein neuer Absatz beginnt immer dann, wenn ein neuer Textbereich eingefügt wird oder nachdem die Eingabetaste gedrückt wurde. Ein Absatz umfasst immer alle Zeichen bis zu dem Punkt, an dem die Eingabetaste gedrückt wird.

  • Zum Einfügen einer neuen Zeile in einen Absatz drücken Sie Umschalt+Eingabetaste.


Textformatvorlagen

Mathcad verwendet Textformatvorlagen, um den Absätzen in Textbereichen Standardeigenschaften zuzuweisen. Jedes Arbeitsblatt verfügt über eine Standardformatvorlage namens "Normal"; es sind jedoch auch andere Vorlagen verfügbar. Sie können eine Textformatvorlage einem oder mehreren Absätzen zuweisen, eine vorhandene Textformatvorlage modifizieren, eine neue Textformatvorlage erstellen oder eine Textformatvorlage löschen.

Zuweisen einer Formatvorlage

Ändern einer Formatvorlage

Erstellen einer Formatvorlage

Löschen einer Formatvorlage


Zuweisen einer Textformatvorlage

Beim Erstellen eines Textbereiches wird allen Absätzen dieses Textbereiches die Textformatvorlage "Normal" zugewiesen. Jedes Arbeitsblatt bzw. jede Arbeitsblatt-Vorlage bietet Ihnen jedoch eine oder mehrere Textformatvorlagen, die Sie den Absätzen im Text zuweisen können.

Zum Zuweisen einer anderen Textformatvorlage für einen oder mehrere Absätze gehen Sie wie folgt vor:

  1. Klicken Sie in den Absatz, um die Einfügemarke einzufügen, oder wählen Sie Text in dem oder den gewünschten Absätzen aus.

  2. Wählen Sie den Befehl Stil aus dem Menü Format, damit das Dialogfeld "Textformatvorlagen" geöffnet wird.

  3. Wählen Sie eine der verfügbaren Textformatvorlagen aus, und klicken Sie auf "Zuweisen". Der Standardtext im Bereich nimmt die Text- und Absatzeinstellungen an, die in der Formatvorlage festgelegt sind.

Hinweise:

  • Statt Stil im Menü Format zu wählen, können Sie auch einen Stil aus der äußersten linken Dropdown-Liste in der Symbolleiste "Formatierung" auswählen.

  • Wenn Sie einem Textbereich eine Textformatvorlage zuweisen, übernimmt er die Textabsatzeinstellungen der Formatvorlage.

  • Text, der durch Bearbeitung der Schriftarteigenschaften bereits zuvor ausgewählt und formatiert wurde, behält sein Erscheinungsbild bei. Wenn Sie zuvor nur andere Texteigenschaften als die Schrifteigenschaften im markierten Text geändert haben, nimmt der markierte Text die Texteigenschaften der Formatvorlage und darüber hinaus die ausgewählte Schriftart, die Schriftgröße und die zugewiesenen Effekte an.


Bearbeiten einer vorhandenen Textformatvorlage

Wenn Sie die Eigenschaften für den gesamten Text verändern möchten, dem eine bestimmte Textformatvorlage zugrunde liegt, zum Beispiel die Textformatvorlage "Normal", sollten Sie die Formatvorlage als solche verändern. Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie im Menü Format den Befehl Formatvorlage. Es werden alle verfügbaren Formatvorlagen angezeigt.

  2. Wählen Sie die Textformatvorlage aus, die Sie verändern wollen, und klicken Sie auf "Ändern". Es wird ein Dialogfeld eingeblendet, in dem alle Definitionen der ausgewählten Textformatvorlage aufgeführt sind.

  3. Klicken Sie auf "Schriftart", um Textformate, wie z. B. die in dieser Textformatvorlage verwendeten Zahlen zu ändern.

  4. Klicken Sie auf "OK", um die vorgenommenen Änderungen zu speichern.

Alle neuen Textbereiche, denen Sie die veränderte Textformatvorlage zuweisen, werden nach der neuen Definition der Textformatvorlage formatiert. Alle Textbereiche, die bereits zuvor mit der Textformatvorlage erstellt wurden, werden ebenfalls nach der veränderten Definition der Textformatvorlage neu angezeigt.


Erstellen einer neuen Textformatvorlage

So erstellen Sie eine neue Textformatvorlage:

  1. Wählen Sie im Menü Format den Befehl Formatvorlage. Im daraufhin geöffneten Dialogfeld Textformatvorlagen werden die derzeit verfügbaren Textformatvorlagen angezeigt.

  2. Klicken Sie auf "Neu".

  3. Geben Sie im Dialogfeld "Formatvorlage definieren" unter "Name" einen Namen für die neue Formatvorlage ein.

  4. Wenn die neue Formatvorlage auf einer bereits vorhandenen Vorlage basieren soll, wählen Sie aus der Dropdown-Liste "Basiert auf" eine Formatvorlage aus.

  5. Klicken Sie auf "Schriftart", um die Textformateinstellungen für die neue Formatvorlage festzulegen. Klicken Sie auf die Schaltfläche "Absatz", um die Absatzformateinstellungen für die neue Formatvorlage festzulegen.

  6. Klicken Sie auf "OK", wenn Sie die Definition der neuen Formatvorlage abgeschlossen haben.

Die von Ihnen neu erstellte Formatvorlage wird nun im Dialogfeld "Textformatvorlagen" angezeigt, und kann jedem Textabsatz zugewiesen werden. Wenn Sie Ihr Arbeitsblatt speichern, wird auch die neue Textformatvorlage gespeichert. Soll die neue Textformatvorlage auch künftig erstellten Arbeitsblättern zur Verfügung stehen, so speichern Sie Ihr Arbeitsblatt als Vorlage.


Löschen einer Textformatvorlage

Textformatvorlagen können jederzeit gelöscht werden. Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie im Menü Format den Befehl Formatvorlage. Es werden alle verfügbaren Formatvorlagen angezeigt.

  2. Wählen Sie eine der in der Liste verfügbaren Textformatvorlagen aus.

  3. Klicken Sie auf "Löschen".

Die Textformatvorlage wird aus der Liste der verfügbaren Textformatvorlagen entfernt. Text in Ihrem Arbeitsblatt, dessen Eigenschaften über diese Textformatvorlage definiert wurden, behält jedoch seine Eigenschaften unverändert bei.


Festlegen der Breite von Textbereichen

Bei der Eingabe in einen Textbereich wird der Bereich fortlaufend bis zum rechten Rand vergrößert. Anschließend wird eine zweite Zeile eingefügt. Soll die Breite eines Textbereichs geändert werden, können Sie die Größe manuell anpassen, oder Sie legen fest, dass der Textbereich automatisch die gesamte Breite der Seite einnehmen soll.

Breite eines Textbereichs manuell ändern

Sie haben zwei Möglichkeiten, die Breite eines Textbereichs manuell zu verändern:

  • mithilfe der Maus und

  • mithilfe der Tastatur.

Breite des Textbereichs auf die Gesamtbreite der Seite vergrößern

So nimmt ein Textbereich automatisch die gesamte Breite einer Seite ein:

  1. Klicken Sie in den Textbereich.

  2. Wählen Sie im Menü Format den Befehl Eigenschaften.

  3. Klicken Sie auf die Registerkarte "Text".

  4. Klicken Sie auf "Seitenbreite verwenden".

  5. Klicken Sie auf "OK".

Der Textbereich erstreckt sich nun über die gesamte Breite der Seite. Außerdem werden die anderen Bereiche so verschoben, dass es zu keinen Überlappungen kommt, wenn der Textbereich größer wird.

Hinweis:

  • Das nachträgliche Ändern des rechten Randes wirkt sich nicht mehr auf die Breite bereits vorhandener Textbereiche aus.


Verhalten von größer werdenden Textbereichen

Sie können festlegen, ob ein Textbereich andere Bereiche überlappen soll oder ob sich die anderen Bereiche automatisch verschieben, wenn der Textbereich, an dem Sie arbeiten, größer wird.

Standardmäßig überlappt ein Textbereich, der sich bei Eingabe von Text vergrößert, die Bereiche, die sich rechts oder direkt unterhalb des Textbereichs befinden. Je mehr Text Sie eingeben, desto mehr vergrößert sich der Textbereich, bis er an den rechten Rand stößt. Jetzt wird eine neue Zeile eingefügt. Befinden sich unterhalb oder rechts dieses Textbereichs andere Bereiche, werden diese einfach durch den Textbereich überlappt.

Wenn Sie stattdessen möchten, dass sich die angrenzenden Bereiche verschieben, statt überlappt zu werden, können Sie die Eigenschaften des jeweiligen Textbereichs ändern. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie in den Textbereich.

  2. Wählen Sie Eigenschaften im Menü Format.

  3. Klicken Sie auf die Registerkarte "Text".

  4. Klicken Sie auf "Bereiche bei Eingabe nach unten verschieben".

  5. Klicken Sie auf "OK".


Steuern von Berechnungen (allgemein)

Steuern von Berechnungen

Im Berechnungsmodus wird festgelegt, wie oft die Ergebnisse auf dem Bildschirm aktualisiert werden. Ein Arbeitsblatt ist immer in einem der folgenden beiden Berechnungsmodi aktiv:

  • Automatischer Modus: die Ergebnisse werden fortlaufend und automatisch aktualisiert.

  • Manueller Modus: die Ergebnisse werden durch den Benutzer aktualisiert.

In beiden Modi können Sie Gleichungen aktivieren oder deaktivieren oder eine gerade durchgeführte Berechnung unterbrechen.


Iteration und Schleifen

Bereichsvariablen

Zeigt, wie Variablen definiert werden, deren Wert einer Iteration über einen Bereich unterworfen wird.

Wiederholtes Auswerten eines Ausdrucks

Zeigt die Verwendung von Bereichsvariablen zur Auswertung von Ausdrücken bei mehreren Werten.

Iteration über einen Wertebereich

Zeigt die Verwendung von Bereichsvariablen mit Feldern und Funktionen zur Durchführung von einfachen Iterationen.

Differenzengleichungen

Rekursive Auswertung der Lösung einer Differenzengleichung mithilfe von Bereichsvariablen.

Iterierte Berechnungen

Rekursive Auswertung der Lösung eines Systems von gekoppelten Differenzengleichungen mithilfe von Bereichsvariablen.


Gleichzeitiges Ausführen von Berechnungen

Alle Berechnungen, die mit einzelnen Werten durchgeführt werden, sind auch mit Wertfeldern möglich. Dazu gibt es zwei Möglichkeiten:

  • Durch Iteration für die einzelnen Elemente mit Bereichsvariablen als unterem Index.

  • Durch Verwendung des Vektorisierungsoperators, mit dem derselbe Vorgang für alle Elemente eines Vektors oder eine Matrix effektiv durchgeführt wird.


Fehlermeldungen in numerischen Berechnungen

Wenn Mathcad Fehler in einem Arbeitsblatt erkennt, werden diese in einer Fehlermeldung angezeigt und der beanstandete Name oder Operator wird in einer anderen Farbe (normalerweise Rot) hervorgehoben.

Das Arbeitsblatt kann Ausdrücke mit Fehlern nicht verarbeiten. Ein Ausdruck kann nur verarbeitet werden, nachdem der Fehler behoben wurde.

Durch Klicken auf die Fehlermeldungen können Sie Angaben zu ihnen aufrufen:

“Suchen” und “Minfehl” muss jeweils eine entsprechende “Vorgabe” vorausgehen.

Alle Auswertungen ergaben einen Fehler oder ein komplexes Ergebnis.

Die Elemente im Vektor dürfen nicht alle gleich sein.

Argumente in Funktionsdefinitionen müssen Namen sein.

Mindestens eine Grenze muss unendlich sein.

Auswertung einer Ableitung n-ter Ordnung nur möglich, wenn n=0,1..5.

Es können nur positive Werte in Diagrammen dargestellt werden, wenn logarithmische Achsen verwendet werden.

Konvergenz gegen eine Lösung nicht möglich. Es wurden zu viele Integrationsschritte festgestellt.

Konvergenz gegen eine Lösung nicht möglich. Die Integrandfunktion weist möglicherweise eine Singularität auf, oder das Integrand ist unendlich.

Eine Variable kann in einem Ausdruck nur einmal definiert werden.

Nicht bestimmbar, welche Einheiten das Ergebnis dieser Operation haben soll.

Dieser Ausdruck kann nicht ausgewertet werden. Er hat eventuell zu einem Überlauf oder einer unendlichen Schleife geführt.

Dieser Wert kann nicht ausgewertet werden, da er zu kompliziert oder durch sich selbst definiert ist.

Diese Funktion kann nicht ausgewertet werden, wenn ihr Argument null ist.

Es kann keine Lösung gefunden werden. Zu viele Iterationen aufgetreten.

Keine Lösung für dieses Gleichungssystem gefunden. Versuchen Sie es mit einem anderen Schätzwert, oder überprüfen Sie, ob wirklich eine Lösung existiert.

Die zu verwendende Datendatei kann nicht gefunden werden.

Keine Eingabe mit Einheiten oder Dimensionen zulässig.

Ein Umrissdiagramm kann nur ein Feld enthalten.

Diese Operation kann nicht auf das ganze Feld auf einmal angewendet werden. Versuchen Sie, mit "Vektorisieren" die Operation Element für Element auszuführen.

So viele Punkte können nicht dargestellt werden.

Ein Ausdruck mit Einheiten kann nicht mit einer komplexen Zahl potenziert werden.

Ein System mit so vielen Gleichungen kann nicht aufgelöst werden.

Etwas in dieser Datendatei ist nicht verständlich. Wenn diese Datei aus einem Tabellenkalkulationsprogramm stammt, muss sie im Format "Nur Text" (ASCII-Text) gespeichert worden sein.

Name dieser Funktion ist nicht verständlich. Verwenden Sie für die Multiplikation ”*”.

Definitionsweise dieser Bereichsvariablen nicht verständlich.

Diese Zahl ist nicht verständlich.

In einem Lösungsblock kann keine Bereichsvariable verwendet werden.

Eine genaue Auswertung ist an mindestens einem der angegebenen Werte nicht möglich.

Diese Operation kann für eine Zeichenfolge nicht ausgeführt werden.

Lösung konnte nicht gefunden werden.

Wurzel nicht gefunden.

Das Vektorprodukt ist nur für Vektoren mit genau drei Elementen definiert.

Grad des Polynoms muss zwischen 1 und 99 sein.

Ein Datei-E/A-Fehler ist aufgetreten.

Ein Gleitkommafehler ist aufgetreten.

Dateiende.

Die Endpunkte dürfen nicht gleich sein.

Fehler im GDG-Block.

Beim Versuch, diesen Ausdruck auszuwerten, wurde eine Zahl mit einem Betrag größer als 10^307 gefunden.

Singularität bei Auswertung dieses Ausdrucks festgestellt. Möglicherweise dividieren Sie durch Null.

Unzulässiger Kontext. Drücken Sie F1, um die Hilfe aufzurufen.

Ungültige Dimensionen.

Ungültiger Entwicklungspunkt.

Ungültige Matrixdimension.

SmartMath nicht verfügbar.

Loess kann nicht extrapolieren.

Die Matrix ist singulär. Ihre Inverse kann nicht berechnet werden.

Die Matrix muss positiv und bestimmt sein.

Muss >= 10^-16 sein.

Muss 1 komplexe Matrix oder 2 reelle Matrizen sein.

Dies muss ein Vektor aus reellen Elementen sein.

Muss zwischen zwei Sperrbereichen liegen.

Muss kleiner als die Anzahl der Datenpunkte sein.

Muss reeller Skalar sein.

Es müssen mehr als 4 Zeilen vorhanden sein.

Must have one or two columns.

Muss 3 Vektoren oder 1 Matrix haben.

Keine Bitmaps in Arbeitsblatt gefunden.

Nicht genügend Arbeitsspeicher für diese Operation.

Keine Sperre vorhanden.

Hier sind nur positive Werte zulässig.

ORIGIN sollte eine ganze Zahl sein, deren Betrag geringer als 16 Millionen ist.

(Zeilen - 1) muss eine Potenz von 2 sein.

Es liegt ein Fehler in dem Lösungsblock vor, mit dem diese Funktion definiert wird. Möglicherweise ist ein Schätzwert erforderlich.

Die Zeichenfolge enthält die falsche Zeichenart bzw. -anzahl.

Die Elemente in diesem Vektor müssen in aufsteigender Reihenfolge sein.

Der Ausdruck links von dem Gleichheitszeichen kann nicht definiert werden.

Das Format des Vektors ist ungültig. Drücken Sie F1, um die Hilfe aufzurufen.

Die Funktionswerte an den Endpunkten mit zwei Klammern müssen entgegengesetzte Zeichen sein.

Die Anzahl der Bits pro Pixel muss 8 oder 16 sein.

Die Anzahl der Zeilen muss eine Potenz von 2 sein.

Die Anzahl an Zeilen oder Spalten stimmt nicht überein.

Die Anzahl Zeilen und/oder Spalten in diesem Feld stehen in Konflikt.

In den Einheitenplatzhalter können nur reelle Skalare ungleich null eingegeben werden.

Die Einheiten in diesem Ausdruck stimmen nicht überein.

Dieser Ausdruck enthält ein überflüssiges Komma.

Es müssen mehr Datenpunkte als Parameter vorhanden sein.

Es müssen mehr als drei Datenpunkte vorhanden sein.

Dieses Feld muss mehr als eine Zeile bzw. Spalte haben.

Dieser Ausdruck enthält nur eine “(“ aber keine “)”.

Dieser Ausdruck ist unvollständig. Sie müssen Platzhalter eingeben.

Dieser Ausdruck ist unvollständig. Sie müssen einen Operator bereitstellen.

Dieser Ausdruck ist zu kompliziert. Versuchen Sie, ihn in kleineren Einheiten zu definieren.

Diese Datei konnte nicht geöffnet werden. Vergewissern Sie sich, ob sie wirklich existiert.

Diese Funktion hat zu viele Argumente.

Diese Funktion ist an mindestens einem der von Ihnen angegebenen Punkte nicht definiert.

Diese Funktion benötigt mehr Argumente.

Dieses Bildformat wird nicht unterstützt.

Diese ganze Zahl ist zu groß.

Diese ganze Zahl ist zu klein.

Dies ist ungültig. Wenn Sie in einem Mathcad-Programm Bedingungsanweisungen verwenden, müssen diese stets nachvollziehbar sein.

Kein gültiges Intervall.

Innerhalb eines Lösungsblocks nicht erlaubt. Zum Beispiel sind innerhalb eines Lösungsblocks keine Definitionen erlaubt.

Diese Liste enthält zu viele Einträge.

Diese Matrix muss quadratisch sein. Sie sollte die gleiche Anzahl Zeilen wie Spalten haben.

Dies muss eine ganze Zahl sein. Der verwendete Ausdruck enthält eventuell einen Bruch.

Dies muss der Name einer Funktion bzw. Variable sein.

Dies muss der Name einer Zuordnungsfunktion sein.

Diese Operation kann nur für eine Funktion ausgeführt werden.

Diese Operation kann nur für ein Feld ausgeführt werden, nicht für eine Zahl.

Diese Operation kann nur für eine Zahl oder ein Feld ausgeführt werden.

Diese Operation kann nur für eine Zeichenfolge ausgeführt werden.

Dieser tiefgestellte Index ist zu groß.

Dieses Gleichungssystem weist mehr Unbekannte auf, als es Gleichungen gibt.

Dieser Wert muss eine Matrix sein.

Dieser Wert muss ein Vektor sein. Es kann weder eine Matrix noch ein Skalar sein.

Dieser Wert muss eine ganze Zahl größer als 1 sein.

Dieser Wert muss eine ungerade ganze Zahl sein.

Dieser Wert muss größer oder gleich 10.0^-16 sein.

Dieser Wert muss kleiner oder gleich 10000 sein.

Dieser Wert muss reell sein. Sein Imaginärteil muss Null sein.

Diese Variable muss eine Bereichsvariable sein.

Diese Variable bzw. Funktion ist oben nicht definiert.

Dieser Vektor hat die falsche Anzahl Elemente.

Dieser Vektor muss weniger als fünf Spalten haben.

Dieser Vektor sollte mehr Elemente haben.

Geben Sie "TOL=" ein, um zu überprüfen, welchen Wert die Variable TOL hat. Der Wert sollte ein Skalar größer als 0 und kleiner gleich 1 sein. Definieren Sie den Parameter gegebenenfalls neu.

Unterlauf

Der Wert des tief- bzw. hochgestellten Indexes ist zu groß (bzw. zu klein) für dieses Feld.

You are trying to use an array or range as a scalar. Drücken Sie F1, um die Hilfe aufzurufen.

Sie müssen diesen Operator symbolisch auswerten. Drücken Sie [Strg] [Punkt].

Sie haben einen Rechenvorgang unterbrochen. Um fortzufahren, klicken Sie hier und drücken "F9".


Symbolische Optimierung

Im Normalfall wertet Mathcad Ausdrücke genau so aus, wie Sie sie eingegeben haben. Dies geschieht ungeachtet dessen, dass oft ein klein wenig Vereinfachung dazu führen würde, dass der Ausdruck sich wesentlich leichter auswerten lässt.

Mit dem Befehl "Symbolische Optimierung" jedoch weisen Sie den numerischen Prozessor an, Ausdrücke vor den Berechnungen zu vereinfachen. Wenn Sie auf das Bild unten klicken, können Sie sehen, was dabei passiert.

Um alle Gleichungen in einem Arbeitsblatt zu optimieren, gehen Sie folgendermaßen vor:

  1. Wählen Sie den Befehl Optimieren aus dem Menü Extras.

Mathcad übergibt daraufhin alle Ausdrücke vor deren Auswertung zunächst dem symbolischen Prozessor, damit dieser sie vereinfachen kann. Wenn der symbolische Prozessor eine vereinfachte Form findet, wird der Ausdruck mit einem roten Sternchen markiert. Sie können sich den vereinfachten Ausdruck anzeigen lassen, indem Sie auf das Sternchen doppelklicken oder den Befehl Popup-Fenster anzeigen im Kontextmenü des Ausdrucks wählen. Mathcad verwendet für alle nachfolgenden Berechnungen nun stets diese vereinfachte Form des Ausdrucks.

Wenn Sie nur einen bestimmen Ausdruck und nicht das gesamte Arbeitsblatt optimieren möchten, gehen Sie wie folgt vor:

  1. Klicken Sie auf die Gleichung, und wählen Sie Eigenschaften im Menü Format.

  2. Klicken Sie auf die Registerkarte "Berechnung", und aktivieren Sie dann das Kontrollkästchen neben dem Feld "Optimierung aktivieren".

Wenn Mathcad den Ausdruck optimieren kann, wird dieser mit einem roten Sternchen markiert. Kann Mathcad den Ausdruck nicht optimieren, wird er mit einem blauen Sternchen versehen.


Auswählen von Bereichen

Zum Markieren eines einzelnen Bereichs gehen Sie wie folgt vor:

Klicken Sie auf den Bereich. Dadurch wird er in ein Markierungsrechteck eingeschlossen. Drei Haltepunkte werden eingeblendet.

Zum Markieren mehrerer Bereiche gehen Sie wie folgt vor:

  1. Klicken Sie außen neben eine Ecke der Region, die die gewünschten Bereiche enthält.

  2. Drücken Sie die Maustaste, und halten Sie sie gedrückt. Ziehen Sie die Maus bei gehaltener Taste. Es erscheint ein gestricheltes Markierungsrechteck.

  3. Wenn das Markierungsrechteck alle Bereiche enthält, die Sie auswählen möchten, lassen Sie die Maustaste los. Alle markierten Bereiche werden von Markierungsrechtecken umschlossen.

Sie können Bereiche auch mit einer der folgenden Methoden auswählen:

  • Halten Sie die Strg-Taste gedrückt, und klicken Sie nacheinander auf die auszuwählenden Bereiche.

  • Halten Sie die Umschalttaste gedrückt, um mehrere Bereiche gleichzeitig auszuwählen.

  • Zur Auswahl eines Rechenbereiches klicken Sie in den Bereich, halten Sie die Maustaste gedrückt, und ziehen Sie den Mauszeiger so, dass der Bereich invers hervorgehoben wird. Sie können den Bereich dann ausschneiden, kopieren oder löschen.

Nach der Auswahl einer oder mehrerer Bereiche können Sie die Auswahl verschieben oder löschen. Sie können außerdem auch andere Elemente statt der gerade markierten Elemente markieren, falls dies erforderlich ist.


Verschieben von Grafikbereichen

Sie können einen Bereich verschieben, indem Sie ihn ausschneiden und an einer neuen Position einfügen, ihn mit der Maus ziehen oder ihn mit den Pfeiltasten verschieben:

Ausschneiden und Einfügen

  1. Wählen Sie den oder die zu verschiebenden Bereiche aus.

  2. Wählen Sie Ausschneiden im Menü Bearbeiten.

  3. Klicken Sie auf die Position, an der Sie den oder die Bereiche einfügen möchten.

  4. Wählen Sie Einfügen im Menü Bearbeiten.

Ziehen eines Bereichs

  1. Wählen Sie den Bereich aus, indem Sie auf ihn klicken.

  2. Gehen Sie mit dem Mauszeiger auf einen der Ränder des Auswahlrechtecks. Der Mauszeiger wechselt seine Form von einem Pfeil zu einer kleinen Hand.

  3. Drücken Sie die Maustaste, und halten Sie sie gedrückt, während Sie die Maus ziehen. Der Umriss des Bereichs verschiebt sich mit der Maus.

  4. Lassen Sie die Maustaste los, wenn sich der Umriss des Bereichs an der gewünschten Stelle befindet.

Ziehen mehrerer Bereiche

  1. Wählen Sie die Bereiche mit dem gestrichelten Rechteck aus, indem Sie darüber ziehen.

  2. Setzen Sie den Mauszeiger in die Mitte eines der Bereiche. Der Mauszeiger wechselt seine Form von einem Pfeil zu einer kleinen Hand.

  3. Drücken Sie die Maustaste, und halten Sie sie gedrückt, während Sie die Maus ziehen. Der Umriss des Bereichs verschiebt sich mit der Maus.

  4. Lassen Sie die Maustaste los, wenn sich der Umriss des Bereichs an der gewünschten Stelle befindet.

Auswählen voneinander getrennter Bereiche oder einzelner Bereiche

Hinweis: Sie können einen bzw. mehrere einzelne Bereiche auswählen, indem Sie bei gedrückter [Umschalt]-Taste auf sie klicken. Durch erneutes Klicken heben Sie die Auswahl wieder auf.

Verschieben von Bereichen mit den Pfeiltasten

Sobald Sie eine Gruppe von Bereichen ausgewählt haben, können Sie diese mithilfe der Pfeiltasten auf der Tastatur nach oben, unten, links und rechts verschieben. Wenn Sie die Pfeiltasten gedrückt halten, ist die Bewegung schneller.


Einfügen und Löschen von Leerzeilen

Einfügen einer oder mehrerer Leerzeilen

Löschen einer oder mehrerer Leerzeilen


Bearbeiten von überlappenden Bereichen

In Mathcad können Sie Bereiche überlappen lassen. Um zwei Bereiche überlappen zu lassen, ziehen Sie einfach einen Bereich über einen anderen. Überlappende Bereiche können Sie wie folgt handhaben:

  • Um einen Bereich vor einen anderen zu setzen, mit dem er überlappt, klicken Sie mit der rechten Maustaste auf den Bereich, und wählen Sie im Kontextmenü Nach vorne bringen.

  • Um einen Bereich hinter einen anderen zu setzen, mit dem er überlappt, klicken Sie mit der rechten Maustaste auf den Bereich, und wählen Sie im Kontextmenü Nach hinten stellen.

Sollen sich Bereiche generell nicht überlappen, wählen Sie im Menü Format die Option Bereiche trennen, um die Bereiche zu trennen.


Ausrichten von Bereichen

Sie können Bereiche durch die Schaltflächen "Ausrichtung", durch Menübefehle, anhand des Arbeitsblattlineals oder durch Verschieben mit den Pfeiltasten ausrichten.

Vertikales Ausrichten von Bereichen

Zum Ausrichten von mehreren markierten Bereichen an einer vertikalen Linie in der Mitte zwischen dem äußeren linken und dem äußeren rechten Bereich gehen Sie vor wie folgt:

  1. Markieren Sie die Bereiche, die Sie ausrichten möchten.

  2. Wählen Sie aus dem Menü Format den Befehl Bereiche ausrichten Þunten.

Zu beachten ist, dass es bei dieser Aktion zu einer Überschneidung von Bereichen kommen kann. Wenn dies passiert, wählen Sie im Menü Format die Option Bereiche trennen, um die Bereiche voneinander zu trennen.

Einstellen von vertikalen Ausrichtungshilfen

Sie können Bereiche auch durch eine Ausrichtungshilfslinie ausrichten, die Sie im Menü Anzeige im Arbeitsblattlineal setzen . Durch Verwendung dieser Hilfslinien können Sie Bereiche über mehrere Seiten einfacher ausrichten und Sie können beliebig viele Ausrichtungshilfen einstellen.

Horizontales Ausrichten von Bereichen

Zum Ausrichten von mehreren markierten Bereichen an einer horizontalen Linie zwischen dem obersten und dem untersten Bereich gehen Sie vor wie folgt:

  1. Markieren Sie die Bereiche, die Sie ausrichten möchten.

  2. Wählen Sie aus dem Menü Format den Befehl Bereiche ausrichtenÞhorizontal.

Zu beachten ist, dass es bei dieser Aktion zu einer Überschneidung von Bereichen kommen kann. Wenn dies passiert, wählen Sie im Menü Format die Option Bereiche trennen, um die Bereiche voneinander zu trennen.

Bereiche verschieben

  1. Wählen Sie die auszurichtenden Bereiche aus, indem Sie über den Bereichen klicken und mit der Maus ziehen, um ein gepunktetes Auswahlfeld zu erhalten.

  2. Um einen einzelnen Bereich oder verschiedene Bereiche zu markieren, halten Sie die [Umschalttaste] gedrückt, während Sie auf jeden Bereich klicken.

  3. Verwenden Sie dann die Pfeiltasten, um die Bereiche in eine Richtung auszurichten oder zu verschieben.


Trennen von überlappenden Bereichen

Die Bereiche, die Gleichungen und Text in Ihrem Dokument enthalten, sind größer als sie erscheinen. Um anzuzeigen, wie groß ein Bereich eigentlich ist, gehen Sie wie folgt vor:

  • Wählen Sie Bereiche aus dem Menü Ansicht.

Falls sich die Bereiche überlappen, gehen Sie wie folgt vor:

  • Markieren Sie sie, und ziehen Sie sie auseinander oder

  • wählen Sie den Befehl Bereiche trennen aus dem Menü Format.


Eine Region des Arbeitsblatts ausblenden

Sie können Teile Ihres Arbeitsblatts ausblenden, um das Arbeitsblatt auf diese Weise besser präsentieren zu können. Die ausgeblendeten Regionen können auch gesperrt werden, sodass niemand Änderungen in Bereichen innerhalb dieser Region vornehmen kann.

Festlegen, welche Region ausgeblendet werden soll

Ausblenden der Region

Einblenden einer zuvor ausgeblendeten Region

Sperren einer ausgeblendeten Region

Löschen einer ausgeblendeten Region


Erstellen eines neuen Arbeitsblatts

So erstellen Sie ein neues Arbeitsblatt:

  1. Wählen Sie im Menü Datei den Befehl Neu. Das Dialogfeld "Neu" wird geöffnet.

  2. Wählen Sie eine Vorlage aus, das die Basis für Ihr Arbeitsblatt sein soll.

  3. Es wird ein neues Fenster ohne Namen angezeigt. Je nachdem, was für eine Vorlage Sie ausgewählt haben, enthält das neue Arbeitsblatt bereits Gleichungen, Text oder andere Bereiche, die Sie bearbeiten können.

  4. Wählen Sie im Menü Datei den Befehl Speichern, und geben Sie einen Namen für Ihr Arbeitsblatt ein. Die Dateinamenerweiterung für das Arbeitsblatt lautet ".mcd".


Öffnen eines bereits bestehenden Arbeitsblatts

Zum Öffnen eines Arbeitsblatts gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Öffnen im Menü Datei. Es erscheint eine Liste der Arbeitsblätter im aktuellen Verzeichnis. Wenn Sie sich eine Liste von Arbeitsblättern anzeigen lassen wollen, die nicht den Standarddateityp und die Standarddateierweiterung aufweisen, müssen Sie gegebenenfalls die Einstellungen unter Dateityp ändern.

  2. Doppelklicken Sie auf den Namen des Arbeitsblattes, das geöffnet werden soll. Wenn Sie das aktuelle Verzeichnis wechseln müssen, klicken Sie auf die Liste der Verzeichnisse im Dialogfeld "Öffnen". Wenn Sie ein Arbeitsblatt öffnen wollen, das sich auf einem fernen Webserver befindet, geben Sie die URL des Arbeitsblattes in das Feld Dateiname ein.

  3. Drücken Sie die Eingabetaste.

Sie können auch ein Mathcad-Arbeitsblatt öffnen, das in HTML gespeichert wurde.


Schließen eines Arbeitsblatts

Zum Schließen des aktiven Arbeitsblatts gehen Sie wie folgt vor:

  1. Wählen Sie im Menü Datei die Option Schließen.

  2. Wenn seit dem letzten Speichern des Arbeitsblatts Änderungen vorgenommen wurden, werden Sie aufgefordert, das Arbeitsblatt vor dem Schließen zu speichern.

Wenn Sie Mathcad vollständig beenden wollen, wählen Sie den Befehl Beenden im Menü Datei.


Umbenennen eines Arbeitsblatts

Zum Umbenennen eines Arbeitsblatts gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Speichern unter aus dem Menü Datei. Es wird ein Dialogfeld geöffnet.

  2. Geben Sie in das Textfeld den neuen Namen des Arbeitsblatts ein.


Verwalten von Arbeitsblatt-Fenstern

Trotz der Tatsache, dass mehrere Arbeitsblätter gleichzeitig geöffnet sein können, ist immer nur ein Arbeitsblatt das aktive Arbeitsblatt. In der folgenden Liste finden Sie einige der Dinge, die Sie mit dem aktiven Arbeitsblatt machen können:

Verschieben...

Größe ändern...

Maximieren...

Minimieren...

Schließen...

Durch ein anderes ersetzen...

Arbeitsblatt-Fenster übereinander anordnen...

Arbeitsblatt-Fenster neben- und untereinander anordnen...


Erstellen einer neuen Vorlage

Mathcad enthält eine Vielzahl von integrierten Vorlagen.Sie können die Sammlung von Vorlagen durch eigene Vorlagen erweitern. So können Sie z. B. eine Vorlage für ein Projekt anlegen, die spezifische Informationen in der Kopf- und Fußzeile sowie Diagramme und Text an bestimmten Stellen des Arbeitsblatts enthält. Ebenso können weitere Einstellungen angepasst werden.

Beachten Sie, dass sich Mathcad-Vorlagen mit einer .mct-Erweiterung von HTML-Vorlagen mit einer .mlt-Erweiterung unterscheiden. HTML-Vorlagen bestimmen die Ansicht eines Dokuments in einem Web-Browser und Mathcad-Vorlagen bestimmen das Layout innerhalb con Mathcad.

So erstellen Sie eine neue Vorlage:

  1. Erstellen Sie ein neues Arbeitsblatt mit den gewünschten Einstellungen. Das Arbeitsblatt sollte darüber hinaus alle Gleichungen, allen Text und alle Grafiken enthalten, die in der Vorlage enthalten sein sollen.

  2. Wählen Sie im Menü Datei den Befehl Speichern unter, um ein Dialogfeld zu öffnen.

  3. Doppelklicken Sie im Dialogfeld "Speichern unter" auf den Ordner "Vorlage".

  4. Wählen Sie in der Dropdown-Liste "Dateityp" die Option "Mathcad-Vorlage".

  5. Geben Sie im Feld "Dateiname" einen Namen für die Vorlage ein.

  6. Klicken Sie auf "Speichern". Standardmäßig wird die Datei als Mathcad-Vorlagendatei (mit der Erweiterung .mct) im Unterverzeichnis für Vorlagen gespeichert. Sie können aber auch einen anderen Speicherort festlegen.

Ihre Vorlage wird daraufhin im Dialogfeld in die Liste der verfügbaren Vorlagen aufgenommen. Auf diese Liste können Sie zugreifen, indem Sie im Menü Datei den Befehl Neu wählen, um ein neues Arbeitsblatt zu erstellen.


Ändern einer Vorlage

Zum Ändern einer bestehenden Arbeitsblattvorlage gehen Sie wie folgt vor:

  1. Wählen Sie im Menü Datei die Option Öffnen.

  2. Wählen Sie in der Dropdown-Liste "Dateityp" die Option "Mathcad-Vorlage".

  3. Geben Sie im Feld "Dateiname" den Namen der Vorlage ein, oder gehen Sie zum Verzeichnis "template" (bzw. zum entsprechenden Speicherort der Vorlage).

  4. Klicken Sie auf "Öffnen". Die Vorlage wird im Mathcad-Fenster geöffnet.

  5. Bearbeiten Sie die Vorlage auf die gleiche Art und Weise wie jedes andere Mathcad-Arbeitsblatt.

  6. Wählen Sie den Befehl Speichern im Menü Datei. Wenn die geänderte Vorlage einen neuen Namen erhalten soll, wählen Sie stattdessen im Menü Datei den Befehl Speichern unter, und geben Sie im Dialogfeld "Speichern unter" einen neuen Namen für die Vorlage ein.

Beachten Sie, dass die Änderungen an einer Vorlage sich nur auf die Dateien auswirken, die nach dem Ändern der Vorlage auf deren Grundlage erstellt wurden. Auf Arbeitsblätter, die auf der Grundlage einer Vorlage erstellt wurden, bevor diese geändert wurde, haben die Änderungen keinerlei Auswirkungen.


Erstellen einer neuen HTML-Vorlage

Im Verzeichnis "Vorlagen" finden Sie ein Beispiel für eine HTML-Vorlage. HTML-Vorlagen werden beim Speichern eines Dokuments als HTML-Datei verwendet. Sie können die Sammlung von Vorlagen durch eigene Vorlagen erweitern. So können Sie z. B. eine Vorlage für eine Website erstellen, die in der Kopf- und Fußzeile Navigationsschaltflächen und an bestimmten Stellen Bilder oder Daten enthält. Es ist auch möglich, im Kopfbereich aller Webdateien ein externes CSS (Cascading Style Sheet) anzuwenden.

So erstellen Sie eine neue Vorlage:

  1. Öffnen Sie eine neue Datei oder die vorhandene Beispieldatei in einem beliebigen Text- bzw. HTML-Editor.

  2. Vergewissern Sie sich, dass die Datei die folgenden Kommentarbereiche enthält:

    In den <HEAD>-Tags des Dokuments:

    <!-- #BeginEditable "MathMLheaders" -->
    Platz für META-Tag-Informationen
    <!-- #EndEditable -->

    <!-- #BeginEditable "MathMLstyles" -->
    Platz für Cascading styles
    <!-- #EndEditable -->

    In den <BODY>-Tags des Dokuments:

    <!-- #BeginEditable "MathMLcontent" -->
    Platz für MathML-Inhalt aus Mathcad-Arbeitsblatt
    <!-- #EndEditable -->

  3. Geben Sie allen weiteren HTML-Code ein, der auf allen Seiten angezeigt werden soll, die Sie ins MathML-Format exportieren.

  4. Speichern Sie die Vorlagendatei unter einem von Ihnen festgelegten Namen und mit der Erweiterung ".mlt".

Nach Ihrer Vorlage können Sie im Dialogfeld Einstellungen in der Registerkarte "HTML-Optionen" suchen.


Definieren von Kopf- und Fußzeilen

Zum Einfügen von Kopf- und Fußzeilen in das gedruckte Arbeitsblatt gehen Sie wie folgt vor:

  1. Wählen Sie Kopf-/Fußzeile im Menü Ansicht, um das Dialogfeld "Kopf- und Fußzeile" zu öffnen.

  2. Klicken Sie auf die Schaltfläche Kopfzeile oder Fußzeile.

  3. Klicken Sie in das Textfeld für die jeweilige Stelle, an der die Fuß- oder Kopfzeile erscheinen soll.

  4. Geben Sie den gewünschten Text ein. Verwenden Sie die Schaltflächen im Bereich Hilfsmittel des Dialogfelds, um Informationen, wie die Seitenzahl, das Datum oder die Uhrzeit, einzufügen. Mit der anderen Optionen in diesem Dialogfeld können Sie:

  • die Seitennummerierung mit einer anderen Zahl als 1 beginnen.

  • eine bestimmte Kopf- bzw. Fußzeile für die erste Seite des Arbeitsblatts festlegen.

  • um die Kopfzeile, die Fußzeile oder die gesamte Seite herum einen Rahmen ziehen.

  • eine Bitmap einfügen.

  • die Schrift formatieren.

  5. Wenn Sie damit fertig sind, klicken Sie auf OK.


Ränder

Einstellen der Seitenränder

Zum Einstellen der Ränder gehen Sie wie folgt vor:

  1. Wählen Sie im Menü Datei den Befehl Seite einrichten.

  2. Klicken Sie auf das Feld für die jeweilige Randeinstellung.

  3. Geben Sie die Entfernung (in Zoll) vom Rand zur Kante des Papierblattes ein, auf das Sie drucken wollen.

  4. Zum Zuweisen dieser Randeinstellungen für das aktuelle Arbeitsblatt klicken Sie auf "OK".


Versenden von Arbeitsblättern per E-Mail

Sie können diese Funktion nur dann nutzen, wenn Sie an ein kompatibles E-Mail-System angeschlossen sind.

Um das derzeit geöffnete Arbeitsblatt per E-Mail zu versenden, gehen Sie folgendermaßen vor:

  • Wählen Sie im Menü Datei die Option Senden.

Das Arbeitsblatt wird an die Nachricht angefügt, zu deren Erstellung Sie aufgefordert werden.


Exportieren nach Microsoft Word

Zum Exportieren eines Arbeitsblattes nach Microsoft Word können Sie das Arbeitsblatt als RTF-Datei speichern, oder Sie kopieren die entsprechenden Arbeitsblattbereiche und fügen Sie in Microsoft Word wieder ein.

Exportieren als RTF-Datei

Sie haben die Möglichkeit, ein ganzes Arbeitsblatt mit allen Gleichungen und Diagrammen in eine RTF-Datei umzuwandeln, die von Microsoft Word gelesen werden kann. Das Layout entspricht dem ursprünglichen Arbeitsblatt und der Text kann in Word weiter bearbeitet werden. Alle Rechenbereiche und Diagramme werden im Word-Dokument in Bilder umgewandelt.

Da sich die Standardränder in Word von denen in Mathcad unterscheiden, empfehlen wir die Verwendung der Microsoft Word-Vorlage unter Neu im Menü Datei. Sie können die Ränder aber auch im Mathcad-Arbeitsblatt so festlegen, dass sie denen von Word entsprechen. Verwenden Sie dazu in beiden Programmen den Befehl Seite einrichten im Menü Datei.

Beachten Sie, dass alles außerhalb des rechten Randes eines Mathcad-Arbeitsblattes nicht im Microsoft Word-Dokument angezeigt wird.

So speichern Sie ein Mathcad-Arbeitsblatt als RTF-Datei für Microsoft Word:

  1. Verwenden Sie in Mathcad die Microsoft Word-Vorlage, oder legen Sie die Ränder so fest, dass sie den Rändern im Word-Dokument entsprechen.

  2. Stellen Sie sicher, dass sich das zu exportierende Material innerhalb der rechten Ränder befindet.

  3. Wählen Sie den Befehl Speichern unter aus dem Menü Datei.

  4. Wählen Sie aus der Dropdown-Liste Dateityp im Dialogfeld Speichern unter die Option Rich Text Format (*.rtf).

  5. Geben Sie im Feld Dateiname für die RTF-Datei, die Sie erstellen möchten, einen Namen ein.

Wenn Sie diese RTF-Datei in Microsoft Word öffnen, sind unter Umständen alle Mathcad-Bereiche am linken Rand des Dokuments ausgerichtet. Ist dies der Fall, wechseln Sie in das Seitenlayout von Word, in dem das Erscheinungsbild Ihres Arbeitsblattes genauer definiert wird.

Kopieren und einfügen

Eine weitere Möglichkeit, ein Arbeitsblatt zu exportieren, besteht darin, einen oder mehrere Bereiche des Arbeitsblattes zu kopieren und diese in einer anderen Anwendung einzufügen. Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie Alles markieren im Menü Bearbeiten, um alle Bereiche zu kopieren. Oder wählen Sie einzelne Bereiche, indem Sie sie mit der Maus ziehen oder auf jedes einzelne mit [Umschalt]Klick darauf klicken.

  2. Wählen Sie Kopieren im Menü Bearbeiten.

  3. Öffnen Sie Microsoft Word, und fügen Sie den kopierten Text ein.

Unter Inhalte einfügen stehen folgende Optionen zur Verfügung. Wenn Sie das Mathcad-Dokumentobjekt auswählen und einen mathematischen Bereich bearbeiten, werden die Symbolleisten und Menüs von Mathcad aufgerufen. Sie können die Mathcad-Bereiche auch als Bilder, unformatierten Text oder RTF (formatierten Text) importieren.


Drucken bestimmter Seiten

Um nur bestimmte Seiten auszudrucken, gehen Sie wie folgt vor:

  1. Ermitteln Sie die Seitenzahlen anhand der Anzeige in der linken unteren Ecke des Fensters.

  2. Wählen Sie den Befehl "Drucken" aus dem Menü Datei. Daraufhin öffnet sich das Dialogfeld "Drucken".

  3. Aktivieren Sie die Option "Seiten".

  4. Geben Sie in den Feldern "Von" und "Bis" an, welche Seiten gedruckt werden sollen. Wenn nur eine Seite gedruckt werden soll, geben Sie in beiden Feldern dieselbe Seitenzahl ein.

  5. Klicken Sie auf "OK".


Drucken ausgewählter Bereiche

Teile einer Seite drucken

Zum Drucken ausgewählter Bereiche gehen Sie wie folgt vor:

  1. Drücken Sie die Strg-Taste, halten Sie sie gedrückt, und klicken Sie auf die Bereiche, die gedruckt werden sollen. Um jeden Bereich, auf den Sie auf diese Weise klicken, erscheint ein gestricheltes Rechteck. Dadurch wird angezeigt, dass der jeweilige Bereich markiert ist.

  2. Wenn ein bereits markierter Bereich doch nicht gedruckt werden soll, klicken Sie nochmals bei gedrückter Strg-Taste auf diesen Bereich. Das gestrichelte Rechteck um den entsprechenden Bereich wird entfernt.

  3. Wählen Sie den Befehl "Drucken" aus dem Menü Datei. Daraufhin öffnet sich das Dialogfeld "Drucken".

  4. Aktivieren Sie die Option "Markierung".

  5. Klicken Sie auf "OK".


Seitenansicht

Wenn Sie sich vor dem Drucken ansehen wollen, wie Ihr Arbeitsblatt gedruckt aussehen wird, gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl "Seitenansicht" im Menü Datei. In der Seitenansicht wird die aktuelle Seite Ihres Arbeitsblattes so angezeigt, wie sie im Ausdruck erscheinen wird.

  2. Mithilfe der Schaltflächen "Nächste" und "Vorherige" am oberen Rand des Bildschirms können Sie sich die anderen Seiten Ihres Arbeitsblatts anzeigen lassen.

  3. Klicken Sie auf "Schließen". Damit kehren Sie zum Haupt-Arbeitsblattfenster zurück.

Falls Sie nach der Ansicht Ihres Arbeitsblatts noch Änderungen vornehmen wollen, wählen Sie den Befehl Seite einrichten aus dem Menü Datei. Wählen Sie "Seite einrichten..." im Menü "Datei", um Ränder zu ändern oder Kopf- und Fußzeilen hinzuzufügen.


Einfügen eines Arbeitsblatts in ein anderes Arbeitsblatt

Es kann vorkommen, dass Sie Formeln und Berechnungen aus einem Arbeitsblatt in einem anderen verwenden möchten. Eine Möglichkeit, dies zu bewerkstelligen, ist die Verwendung der Befehle Kopieren und Einfügen aus dem Menü Bearbeiten.

Eine weitere Möglichkeit besteht darin, einen Verweis auf ein Arbeitsblatt einzufügen. Auf diese Art und Weise verhält sich das aktuelle Arbeitsblatt so, als ob Sie die betreffenden Bereiche des Arbeitsblatts, zu dem es einen Verweis gibt, tatsächlich in dieses aktuelle Arbeitsblatt eingefügt haben. Die Bereiche selbst sind aber nicht sichtbar. Stattdessen erscheint an den entsprechenden Stellen in Ihrem Arbeitsblatt ein Symbol.

Zum Einfügen eines Verweises auf ein Arbeitsblatt gehen Sie wie folgt vor:

  1. Wählen Sie Verweis im Menü Einfügen. Das Dialogfeld "Verweis einfügen" wird angezeigt.

  2. Klicken Sie im Dialogfeld auf Durchsuchen. Gehen Sie zum Speicherort des Mathcad-Arbeitsblatts, auf dessen Bereiche Sie in Ihrem aktiven Arbeitsblatt verweisen wollen, und wählen Sie es aus. Sie können stattdessen auch den vollständigen Pfad bzw. Internet-Adresspfad (URL) zu einem Arbeitsblatt im leeren Textfeld eingeben.

  3. Aktivieren Sie die Option Relativen Pfad für Verweis verwenden, wenn Sie einen relativen Pfad verwenden möchten.

  4. Klicken Sie auf OK.

Nach dem Ausführen dieser Schritte erscheint ein Symbol:

sowie der Name des Arbeitsblatts, auf das verwiesen wird, sodass ersichtlich wird, wo dieses Arbeitsblatt wirksam wird. Wenn Sie auf dieses Symbol doppelklicken, wird das Arbeitsblatt, auf das verwiesen wird, eingeblendet. Nachdem Sie einen Verweis auf ein Arbeitsblatt eingefügt haben, braucht das Arbeitsblatt, auf das verwiesen wird, nicht mehr geöffnet zu sein.

Um ein Arbeitsblatt zu aktualisieren, das einen Verweis enthält, nehmen Sie die Änderung in dem Arbeitsblatt vor, auf das verwiesen wird, und speichern dieses Arbeitsblatt. Kehren Sie dann zu dem Arbeitsblatt zurück, das den Verweis enthält. Klicken Sie auf den Verweis, und drücken Sie die Taste F9 (“Berechnen”). Die Berechnung nimmt die Änderung dann auf.


Erstellen von Hyperlinks zu anderen Arbeitsblättern

So fügen Sie einen Hyperlink in ein Arbeitsblatt oder in eine andere Datei ein:

  1. Wählen Sie den Bereich aus, der zu einem Hyperlink umgewandelt werden soll. Normalerweise wird Text als Hyperlink ausgewählt; Sie können jedoch auch jeden anderen Bereich als Hyperlink auswählen.

  2. Wählen Sie aus dem Menü Einfügen den Befehl Hyperlink, um das Dialogfeld Hyperlink einfügen zu öffnen.

  3. Klicken Sie im Dialogfeld auf die Schaltfläche "Durchsuchen", und wählen Sie im leeren Textfeld ein geeignetes Mathcad-Arbeitsblatt, einen Pfad oder eine Internet-Adresse (URL) zu einem Arbeitsblatt aus.

  4. Wenn Sie einen relativen Pfad festlegen möchten, klicken Sie auf das Kontrollkästchen "Relativen Pfad für Hyperlink verwenden". Soll das Ziel-Arbeitsblatt nach dem Doppelklicken auf den Hyperlink-Bereich in einem kleinen Popup-Fenster angezeigt werden, aktivieren Sie die Option "Als Popup-Dokument anzeigen".

  5. Falls in der Statuszeile unten im Mathcad-Fenster eine Meldung angezeigt werden soll, wenn sich der Mauszeiger über dem Bereich mit dem Hyperlink befindet, geben Sie im Dialogfeld "Hyperlink einfügen" unten im Textfeld einen Meldungstext ein.

  6. Klicken Sie auf "OK".

Nach diesen Schritten werden Sie sehen, dass der als Hyperlink ausgewählte Text unterstrichen und fett hervorgehoben ist. Dadurch wird angezeigt, dass ein Hyperlink erstellt worden ist. Alle anderen Stellen, die einen Hyperlink enthalten, werden auf die gleiche Weise angezeigt. Wenn Sie auf den Text bzw. den Bereich doppelklicken, wird das verknüpfte Arbeitsblatt geöffnet.


Erstellen von Hyperlinks zu einem Bereich

Bevor Sie einen Hyperlink zu einem bestimmten Bereich in einem Arbeitsblatt erstellen, müssen Sie den Bereich mit einem Tag versehen. Mit diesem Tag wird der Bereich des Arbeitsblatts eindeutig gekennzeichnet, sodass Sie direkt zu diesem Bereich gelangen können. Ein Tag kann aus mehreren Worten, Zahlen oder Leerzeichen bestehen, jedoch nicht aus Symbolen. Ein Tag darf keinen Trennungspunkt enthalten, wie beispielsweise Sec1.1. Schreiben Sie statt dessen Sec1,1 oder Sec1-1.

So erstellen Sie einen Bereichs-Tag:

  1. Klicken Sie mit der rechten Maustaste auf den Bereich Ihres Arbeitsblatts, für den Sie einen Bereichs-Tag erstellen möchten.

  2. Wählen Sie im Kontextmenü den Befehl Eigenschaften.

  3. Geben Sie im Dialogfeld "Eigenschaften" auf der Registerkarte Anzeige in das dafür vorgesehene Textfeld einen Tag ein, und klicken Sie auf "OK".

Jetzt können Sie mithilfe von Hyperlinks sowohl vom selben Arbeitsblatt als auch von einem anderen Arbeitsblatt aus direkt zu diesem Bereich gelangen.

So erstellen Sie einen Hyperlink zu einem Bereich, der mit einem Tag versehen wurde:

  1. Klicken Sie auf den entsprechenden Bereich Ihres Arbeitsblatts, und wählen Sie aus dem Menü Einfügen den Befehl Hyperlink.

  2. Klicken Sie auf "Durchsuchen", um das gewünschte Arbeitsblatt zu finden und auszuwählen, oder geben Sie den vollständigen Pfad oder die Internet-Adresse (URL) zu einem Arbeitsblatt ein. Sie müssen den Namen des Ziel-Arbeitsblatts auch eingeben, wenn Sie einen Hyperlink zu einem Bereich im selben Arbeitsblatt erstellen.

  3. Geben Sie nach dem Pfad zum Arbeitsblatt das Zeichen # ein, und fügen Sie dann den Bereichs-Tag hinzu. Der vollständige Pfad für Ihren Zielbereich sieht dann z. B. wie folgt aus: C:\Dateiname#Bereichs-Tag.

  4. Legen Sie im Dialogfeld "Hyperlink" die gewünschten Optionen fest, und klicken Sie auf "OK".

Hinweis:

Wenn Sie Hyperlinks zwischen Bereichen innerhalb eines Mathcad-Arbeitsblatts oder zwischen mehreren Arbeitsblättern einfügen, steht die Popup-Fensteroption nicht zur Verfügung.


Löschen eines Hyperlinks

So löschen Sie einen Hyperlink:

  1. Klicken Sie an eine beliebige Stelle in dem Bereich, der den Hyperlink enthält.

  2. Wählen Sie im Menü Einfügen die Option Hyperlink.

  3. Klicken Sie im Dialogfeld "Hyperlink einfügen" auf den Befehl "Verknüpfung entfernen".

Befand sich die Verknüpfung in dem ausgewählten Text, können Sie erkennen, dass der Text nicht mehr unterstrichen und fett angezeigt wird. Daraus lässt sich ersehen, dass die Verknüpfung aufgehoben worden ist.


Sperren einer Region im Arbeitsblatt

Sie können festlegen, dass ein bestimmter Teil Ihres Arbeitsblatts gesperrt werden soll. Die Bereiche innerhalb der gesperrten Region können dann nicht mehr geändert werden.

Festlegen der zu sperrenden Region

Sperren der Region

Freigeben der Region

Löschen einer zu sperrenden Region


Festlegen der Darstellung von Regionsgrenzen

Sie können die Darstellung der Regionsbegrenzungslinien und der ausgeblendeten Regionsleiste für eine eingefügte Region verändern. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie mit der rechten Maustaste auf eine der Grenzen oder auf die ausgeblendete Leiste.

  2. Wählen Sie aus dem Kontextmenü den Befehl Eigenschaften.

  3. Klicken Sie auf die Registerkarte Region, und führen Sie im Dialogfeld folgendes durch:

  • Geben Sie für die Region einen Namen (soweit vorhanden) an, und legen Sie fest, ob der Name im Bildschirm angezeigt werden soll.

  • Geben Sie an, ob eine Zeitmarkierung auf den Grenzen angezeigt werden soll.

  • Geben Sie an, ob ein Symbol auf den Grenzen angezeigt werden soll.

  • Geben Sie an, ob der Rahmen auf den Grenzen angezeigt werden soll.


Schützen des Arbeitsblatts

Statt das ganze Arbeitsblatt zu sperren, können Sie Ihr Arbeitsblatt auch ganz oder teilweise "schützen". Es gibt drei Ebenen des Arbeitsblattschutzes: "Datei", "Inhalt" und "Bearbeitung".

  • Beim Schutz auf Dateiebene kann das Arbeitsblatt nur als Datei des Typs Mathcad 2001i oder höher, RTF, als Mathcad-Vorlage (MCT) oder als HTML-Datei gespeichert werden. Geschützte Dateien, die im HTML-Format gespeichert wurden, können nicht mehr in Mathcad eingelesen werden. Für die Bereiche werden keine Einschränkungen auferlegt.

  • Beim Schutz auf Inhaltsebene kann das Arbeitsblatt nur als Datei des Typs Mathcad 2001i oder höher, RTF, als Mathcad-Vorlage (MCT) oder als HTML-Datei gespeichert werden. Die vorhandenen Bereiche sind standardmäßig geschützt und lassen sich nicht ändern. Es ist möglich, neue Bereiche zu erstellen und geschützte Bereiche zu kopieren.

  • Beim Schutz auf Bearbeitungsebene kann das Arbeitsblatt nur als Datei des Typs Mathcad 2001i oder höher, RTF, als Mathcad-Vorlage (MCT) oder als HTML-Datei gespeichert werden. Die vorhandenen Bereiche sind standardmäßig geschützt und lassen sich nicht ändern. Geschützte Bereiche können nicht bearbeitet oder kopiert werden. Im Arbeitsblatt können keine neuen Bereiche angelegt werden.

Wählen Sie im Menü Extras den Befehl Arbeitsblatt schützen..., um das Arbeitsblatt zu schützen. Um den Schutz für das Arbeitsblatt wieder zu deaktivieren, wählen Sie im Menü Extras den Befehl Arbeitsblattschutz aufheben.... Möchten Sie den Schutz für einen Bereich aufheben, klicken Sie mit der rechten Maustaste auf den betreffenden Bereich, wählen Sie im Menü den Befehl Eigenschaften und deaktivieren Sie die Option "Bereich vor Bearbeitung schützen" auf der Registerkarte "Schützen", bevor Sie das Arbeitsblatt schützen.

Bei aktiviertem Arbeitsblattschutz auf Inhalts- oder Bearbeitungsebene wird der Zugriff auf alle Bereiche verhindert, die nicht ausdrücklich ungeschützt gelassen wurden; standardmäßig wird ein Bereich für den Schutz gekennzeichnet.

Hinweis:

Bereiche, die bei aktiviertem Arbeitsblattschutz auf Inhaltsebene hinzugefügt werden, können erst dann für den Schutz gekennzeichnet werden, wenn das Arbeitsblatt nicht geschützt ist.


Arbeiten mit Feldern

Gewöhnliche Variablen enthalten einzelne Werte, Felder dagegen (der allgemeine Begriff für Matrizen und Vektoren) enthalten viele Werte. Sie können Vektoren und Matrizen erstellen und sie in Ihren Berechnungen und Variablendefinitionen verwenden, als ob sie Zahlen wären. Viele Operatoren unf Funktionen können mit Feldern verwendet werden, aber es existieren auch spezielle Feldoperatoren und Funktionen für die Bearbeitung von Feldern.

Erstellen von Vektoren und Matrizen

Anzeigen von Vektoren und Matrizen

Grafische Darstellung eines Vektors

Berechnungen mit Datenfeldern

Ändern der Größe eines Feldes

Extrahieren von Elementen, Zeilen und Spalten

Erstellen von Feldern, die bei einem anderen Element beginnen

Beschränkungen der Datenfeldgrößen

Vektor- und Matrixfunktionen

Vektor- und Matrixoperatoren

Matrixmanipulationen

Verschachtelte Felder


Erstellen von Vektoren und Matrizen

Die einfachste Art, ein Feld zu erstellen, ist, ein Feld aus leeren Platzhaltern anzulegen und diese dann auszufüllen.

Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie aus dem Menü Einfügen den Befehl Matrix. Daraufhin wird ein Dialogfeld angezeigt.

  2. Legen Sie in diesem Dialogfeld die Anzahl der Zeilen und Spalten fest.

  3. Klicken Sie auf "OK" oder "Einfügen", um ein Feld mit leeren Platzhaltern zu erstellen.

  4. Klicken Sie nacheinander auf die einzelnen Platzhalter, um diese zu markieren, und geben Sie jeweils eine Zahl, einen Ausdruck oder eine Zeichenfolge ein. Sie können den Cursor auch mit der Tabulatortaste durch die Platzhalter bewegen.

Bei Feldern mit einer Formel, die den Wert eines Feldelements auf seine Indizes bezieht, ist die Arbeit mit Bereichsvariablen und tiefgestelltem Index einfacher. Diese Technik wird im folgenden Beispiel gezeigt:

i := 0 ..9

j := 0 ..9

X[i,j := i^2+j/2

Felder können auch erstellt werden durch:

  • Importieren von Daten aus einer Datendatei

  • Definieren der einzelnen Elemente


Berechnungen mit Datenfeldern

Sie können eine Variable als Feld definieren und in Berechnungen verwenden.

  1. Klicken Sie auf einen leeren Bereich Ihres Arbeitsblatts, und geben Sie einen Variablennamen ein.

  2. Wählen Sie aus dem Menü Einfügen den Befehl Matrix. Daraufhin wird ein Dialogfeld angezeigt.

  3. Legen Sie in diesem Dialogfeld die Anzahl der Zeilen und Spalten fest.

  4. Klicken Sie auf "ERSTELLEN", und füllen Sie die Platzhalter aus.

Sie können nun in Gleichungen den Namen v anstelle des eigentlichen Vektors verwenden:

Felder sind nützlich bei der Durchführung paralleler Berechnungen.


Anzeigen eines Vektors oder einer Matrix

Es gibt zwei Möglichkeiten, einen Vektor bzw. eine Matrix anzuzeigen:

  • Wenn ein Feld weniger als zehn Zeilen und Spalten hat, wird es in Form einer Matrix angezeigt.

  • Wenn ein Feld mehr als neun Zeilen und Spalten hat, wird ein Teil von ihm als Ausgabetabelle mit Bildlaufleiste angezeigt.

So ändern Sie die Anzeige der Feldergebnisse in eine Ausgabetabelle oder in eine Matrix:

  1. Wählen Sie aus dem Menü Format den Befehl Ergebnis, um das Dialogfeld Ergebnisformat zu öffnen.

  2. Klicken Sie unter "Matrix-Anzeigeformat" entweder auf "Matrix" oder auf "Tabelle". Soll sich diese Änderung auf alle Felder in Ihrem Arbeitsblatt auswirken, klicken Sie auf "Als Standard".


Grafische Darstellung eines Vektors

Um die Elemente eines Vektors mit N-Elementen grafisch darzustellen, gehen Sie wie folgt vor:

  1. Definieren Sie eine Bereichsvariable von 1 bis N.

  2. Drücken Sie @ (Alt Gr + Q), oder wählen Sie Diagramm / X-Y-Diagramm im Menü Einfügen. Es wird ein xy-Diagramm erstellt.

  3. Setzen Sie den tiefgestellten Vektor auf eine der Achsen und die Bereichsvariable auf die andere Achse.

Die grafische Darstellung eines Vektors mit einem anderen ist für die Abbildung von Datenpunkten von Nutzen. Geben Sie die x-Werte in einen Vektor und die y-Werte in einen anderen Vektor ein. Gehen Sie nun wie folgt vor:

  1. Drücken Sie @ (Alt Gr + Q), oder wählen Sie Diagramm / X-Y-Diagramm im Menü Einfügen. Es wird ein xy-Diagramm erstellt.

  2. Geben Sie den Namen des Vektors der x-Werte auf der horizontalen Achse ein.

  3. Geben Sie den Namen des Vektors der y-Werte auf der vertikalen Achse ein.

Hinweis:

Mit ganz ähnlichen Schritten können Sie auch ein Kreisdiagramm eines Vektors erstellen. Fügen Sie dazu einfach den Kreisdiagrammoperator ein, indem Sie Diagramm / Kreisdiagramm im Menü Einfügen wählen, und füllen Sie den unteren und den linken Platzhalter aus.


Erstellen eines verschachtelteten Feldes

Die Elemente eines Feldes können selbst Felder sein. Das Erstellen eines verschachtelten Feldes geschieht auf die gleiche Art und Weise wie das Erstellen von anderen Feldern. Der einzige Unterschied besteht darin, dass Sie im Menü Einfügen den Befehl Matrix nicht verwenden können, wenn sich der gewählte Platzhalter bereits in einer Matrix befindet.

Die einfachste Möglichkeit, ein Feldelement zu definieren, das selbst ein Feld ist, ist die folgende:

  1. Weisen Sie dem Feld einem Variablennamen zu:
  2. Definieren Sie das Matrixelement mithilfe dieses Variablennamens:

Das 1,1. Element von M ist nun der Vektor v.


Ändern der Größe eines Feldes

Zum Verbinden von zwei Feldern nebeneinander gehen Sie folgendermaßen vor:

Fassen Sie mit der Funktion erweiternFelder zusammen, welche die gleiche Anzahl von Zeilen besitzen. Beispiel:

Zum Anordnen von Feldern übereinander gehen Sie folgendermaßen vor:

Fassen Sie mit der Funktion "stapeln" Felder zusammen, welche die gleiche Anzahl von Spalten besitzen. Beispiel:

Einfügen oder Löschen von Zeilen und Spalten:

  • Einfügen von Zeilen

  • Löschen von Zeilen

  • Einfügen von Spalten

  • Löschen von Spalten


Vektor- und Matrixfunktionen

Verbinden von Feldern

erweitern(A,B,C,... )

stapeln(A,B,C,...)

Lösen der Verbindung von Feldern

submatrix(M, ir, jr, ic, jc)

Erstellen von Feldern

matrix(m,n,f)

ErstellenGitter(F, s0, s1, t0, t1, sgrid, tgrid, fmap)

ErstellenRaum(F, t0, t1, tgrid, fmap)

Größe eines Feldes

spalten(A)

zeilen(A)

länge(v)

letzte(v)

einheit(n)

Extreme eines Feldes

max(A,B,C,...)

min(A,B,C,...)

Funktionen für die Suche in Feldern

verweis(z, A, B)

wverweis(z, A, r)

hverweis(z, A, c)

vergleich(z, A)

Spezielle Typen von Matrizen

diag(v)

geninv(A)

zref(A)

Spezielle Eigenschaften einer Matrix

sp(M)

rang(M)

norm1(M)

norm2(M)

norme(M)

normi(M)

cond1(M)

cond2(M)

conde(M)

condi(M)

Eigenwerte und Eigenvektoren

eigenwerte(M)

eigenvektoren(M)

eigenvek(M,z)

genwerte(M,N)

genvektoren(M,N)

Matrix-Zerlegung

cholesky(M)

qr(A)

lu(M)

svd(A)

svds(A)


Vektor- und Matrixoperatoren

Die im folgenden genannten Operatoren haben für Vektoren und Matrizen eine spezielle Bedeutung. Der größte Teil dieser Operatoren steht Ihnen zwar über die Symbolleiste "Symbolik" zur Verfügung, es gibt aber für alle einen entsprechenden Tastaturbefehl. Beachten Sie, dass für die Operatoren, die Vektoren erwarten, stets Spaltenvektoren eingegeben werden müssen, nicht Zeilenvektoren.

Operator: | Tastaturbefehl:
Addition | +
Vektorprodukt | Strg+8
Determinante | |
Division | /
Skalarprodukt (inneres Produkt) | *
Inversion | ^-1
Absoluter Betrag | |
Multiplikation | *
Matrixpotenzen | ^
Negation | -
tiefgestellter Index | [
Subtraktion | -
Summe der Elemente | Strg+4
hochgestellter Index | Strg+6
Transponieren | Strg+1
Vektorisieren | Strg+-


Extrahieren kleinerer Matrizen aus einer Matrix

submatrix(A,ir,jr,ic,jc) Gibt eine Matrix zurück, die aus den Zeilen ir bis jr und den Spalten ic bis jc des Feldes A besteht.

Argumente:

  • A ist ein Feld.

  • ir und jr sind die oberen und unteren Indizes der zu extrahierenden Zeilen.

  • ic und jc sind die oberen und unteren Indizes der zu extrahierenden Spalten.

Zum Extrahieren einer einzelnen Spalte können Sie den Operator Hochgestellt verwenden. Zum Extrahieren einer einzelnen Zeile können Sie den Operator Transponieren und den Operator Hochgestellt verwenden.


Extrahieren von Elementen, Zeilen und Spalten

Zum Zugriff auf ein Feldelement verwenden Sie den Operator Tiefstellen und geben ein Gleichheitszeichen ein. Beispiel:

Zum Zugriff auf eine ganze Spalte verwenden Sie den Operator Hochstellen wie folgt:

Zum Zugriff auf eine ganze Zeile verwenden Sie die Operatoren Transponieren und Hochstellen zusammen, wie unten gezeigt:


Arbeiten mit Zeichenfolgen

In erster Linie werden Variablen und Funktionen mit Zahlen oder mit weiteren Variablen und Funktionen definiert. Sie können sie jedoch auch als Folge von Textzeichen (Zeichenfolge) definieren. Sie können Variablen, Funktionen und Felder als Zeichenfolge definieren, indem Sie sie in doppelte Anführungszeichen setzen.

Die meisten vordefinierten Funktionen und Operatoren sind für Zeichenfolgen ungeeignet. Allerdings stehen mehrere Funktionen speziell für Zeichenfolgen zur Verfügung, mit denen Sie Zeichenfolgen zusammenfassen, Subzeichenfolgen suchen, die Länge einer Zeichenfolge bestimmen und Zeichenfolgen in Zahlen und Vektoren oder umgekehrt umwandeln können.

Definieren einer Zeichenfolgenvariable

Definieren einer Zeichenfolgenfunktion

Definieren eines Feldelements als Zeichenfolge

Integrierte Zeichenfolgefunktionen


Definieren einer Zeichenfolgenvariable

So definieren Sie eine Variable als Zeichenfolge:

  1. Geben Sie den Variablennamen ein.

  2. Geben Sie einen ":" ein, um das Zeichen ":=" mit einem Platzhalter zu erstellen.

  3. Geben Sie die Anführungszeichen (“) ein. Zwischen den beiden Anführungszeichen können Sie eine Einfügelinie erkennen.

  4. Geben Sie eine Kombination aus Buchstaben, Ziffern und/oder anderen Zeichen ein. Drücken Sie danach die Eingabetaste.

Hinweis:

Die Position des ersten Zeichens in einer Zeichenfolge hat den Positionswert Null. In der Zeichenfolge "dies ist ein Satz" ist z. B. der Buchstabe "d" das nullte Zeichen.


Definieren einer Zeichenfolgenfunktion

So definieren Sie eine Funktion mit einer Zeichenfolge:

1. Geben Sie den Funktionsnamen zusammen mit seiner Argumentliste ein.

2. Geben Sie ":" ein, um das Zeichen":=" mit einem Platzhalter zu erstellen.

3. Geben Sie die Anführungszeichen (“) ein. Zwischen den beiden Anführungszeichen können Sie eine Einfügelinie erkennen.

4. Geben Sie eine Kombination aus Buchstaben, Ziffern und/oder anderen Zeichen ein. Drücken Sie die Pfeil-nach-Rechts-Taste, um die Zeichenfolge zu verlassen.


Benutzerdefinierte Fehlermeldungen

fehl(S) Gibt S als Fehlermeldung zurück.

Argumente:

S ist eine Zeichenfolge.

Beispiel:


Verketten von Zeichenfolgen

verkett(S1, S2, S3, ...) Gibt eine Zeichenfolge zurück, die durch Anhängen der Zeichenfolge S2 an das Ende der Zeichenfolge S1, der Zeichenfolge S3 an das Ende der Zeichenfolge S2 usw. entsteht.

Argumente:

S1, S2, S3, ...sind Zeichenfolgen.

Beispiel:


Umwandeln einer Zahl in eine Zeichenfolge

zahlinzf(x) Gibt die zu x äquivalente Zahlenzeichenfolge zurück.

Argumente:

x ist eine Konstante oder ein Ausdruck, der eine Konstante zurückgibt.

Diese Funktion ist hilfreich, wenn eine Zahl als Zeichenfolge leichter verarbeitet werden kann als auf mathematische Weise.

Beispiel:


Umwandeln einer Zeichenfolge in eine Zahl

zfinzahl(S) Gibt eine Konstante zurück, die gleich der in S enthaltenen Zahl ist.

Argumente:

S ist eine Zahlenzeichenfolge oder ein Ausdruck, der eine Zahlenzeichenfolge zurückgibt.

Diese Funktion ist hilfreich, wenn Sie Berechnungen für eine aus Zahlen bestehende Zeichenfolge durchführen möchten.

Beispiel:


Umwandeln eines Vektors in eine Zeichenfolge

vekinzf(v) Gibt eine Zeichenfolge zurück, die durch Umwandeln der ASCII-Codes in v entsteht.

Argumente:

v ist ein Vektor aus ganzen Zahlen zwischen 0 und 255.

Beispiel:


Umwandeln einer Zeichenfolge in einen Vektor

zfinvek(S) Gibt einen Vektor aus ASCII-Codes zurück, der durch Umwandeln der Zeichen in S entsteht.

Argumente:

S ist ein Zeichenfolge.

Beispiel:


Extrahieren einer Subzeichenfolge

substr(S,m,n) Gibt die Suchzeichenfolge von S zurück, die aus den m-Zeichen ab der Position n bestehen.

Argumente:

  • S ist eine Zeichenfolge.

  • m ist die Position des ersten Zeichens in der gewünschten Subzeichenfolge. m muss als nicht-negative ganze Zahl angegeben werden.

  • n ist die maximal mögliche Länge der Subzeichenfolge. n muss als nicht-negative ganze Zahl angegeben werden.

Beispiel:

Hinweis:

Die Position des ersten Zeichens in einer Zeichenfolge hat den Positionswert Null. In der Zeichenfolge "Ja" ist z. B. der Buchstabe "y" das nullte Zeichen.


Ermitteln der Länge einer Zeichenfolge

zflänge(S) Gibt die Zahl der Zeichen in S zurück.

Argumente:

S ist eine Zeichenfolge bzw. ein Ausdruck, der eine Zeichenfolge zurückgibt.

Beispiel:


Suchen einer Subzeichenfolge

strtpos(S,SubS,m) Gibt die Anfangsposition von SubS in S zurück, die bei Beginn der Suche an Position m gefunden wurde. Gibt als Ergebnis -1 zurück, falls SubS nicht gefunden wurde.

Argumente:

  • S ist eine Zeichenfolge.

  • SubS ist eine Subzeichenfolge von S.

  • m ist eine nichtnegative ganze Zahl, die die Position in S angibt, an der die Suche gestartet wird.

Beispiel:

Hinweis:

Die Position des ersten Zeichens in einer Zeichenfolge hat den Positionswert Null. In der Zeichenfolge "dies ist ein Satz" ist z. B. der Buchstabe "d" das nullte Zeichen.


Vordefinierte mathematische Funktionen

Sie können beliebige der vordefinierten Funktionen aus der folgenden Liste einfügen, wenn Sie den Befehl Funktion im Menü Einfügen wählen und so das Dialogfeld "Funktion einfügen" öffnen. Sie haben außerdem die Möglichkeit, die Namen der vordefinierten Funktionen genau so einzugeben, wie sie in den Hilfeseiten gezeigt werden, die ihre Beschreibungen enthalten.

Besselfunktionen

Komplexe Funktionen

Bedingte Funktionen

Koordinatentransformation

Kurvenanpassungsfunktionen

Datenanalyse

Lösungsalgorithmen für Differentialgleichungen

Unstetige Funktionen

Diskrete Umwandlungen

Verteilungsfunktionen

Funktionen zum Lösen von Gleichungen

Fehlerfunktion sowie komplementäre Fehlerfunktion

Exponential- und logarithmische Funktionen

Ausdruckstyp

Dateizugriffsfunktionen

Finanzfunktionen

Funktionsoptimierung

Histogramm

Hyperbolische Funktionen

Interpolation

Bildlesefunktionen

Bildschreibefunktionen

Invers hyperbolisch

Invers trigonometrisch

Suchfunktionen

Verschiedene Funktionen

Optimierung

Populationsstatistik

Prognosefunktionen

Zufallszahlengenerierung

Regression

Rundungs- und Abbruchfunktionen

Datenglättung

Lösen

Sortieren

Spezielle Funktionen

Statistische Funktionen

Zeichenfolgen

Symbolische Berechnung

Trigonometrische Funktionen

Vektor- und Matrixfunktionen


Arithmetische Operatoren

Jeder Operator kann auch mithilfe der Tastatur eingegeben werden. Die meisten Operatoren sind darüber hinaus über die Symbolleiste "Taschenrechner" verfügbar.

Operator: | Tastaturbefehl:
Addition mit Zeilenumbruch | Strg+Eingabe
Addition | +
Konjugiert komplexe Zahl | "
Division | /
Lineare Division | Strg +/
Fakultät | !
Exponentialberechnung | ^
Absoluter Betrag | |
Multiplikation | *
Negation | -
N-te Wurzel | Strg +\
Produkt | Strg+Umschalt+3
Bereichsprodukt | #
Bereichssumme | $
Quadratwurzel | \
Subtraktion | -
Summierung | Strg+Umschalt+4


Operatoren für die Differential- und Integralrechnung

Jeder Operator kann auch mithilfe der Tastatur eingegeben werden. Die meisten Operatoren sind darüber hinaus über die Symbolleiste "Differential/Integral" der Symbolleiste "Standard" verfügbar.

Operator: | Tastaturbefehl:
Ableitung | ?
N-te Ableitung | Strg+?
Bestimmtes Integral | &
Unbestimmtes Integral | Strg+I
Summierung | Strg+Umschalt+4
Summation mit Bereichsvariablen | Strg+4
Iteriertes Produkt | Strg+Umschalt+3
Iteriertes Produkt mit Bereichsvariablen | Strg+3
Zweiseitiger Grenzwert | Strg+L
Linker Grenzwert | Strg+A
Rechter Grenzwert | Strg+B


Boolesche Operatoren

Boolesche Operatoren unterscheiden sich von anderen Operatoren dadurch, dass sie nur eine Null oder eine Eins zurückgeben. Trotzdem können sie sehr hilfreich sein.

Operator: | Tastaturbefehl:
Größer als | >
Kleiner als | <
Größer oder gleich | Strg+0
Kleiner oder gleich | Strg+9
Gleich | Strg+=
ungleich | Strg+3
UND | Strg+Umschalt+7
ODER | Strg+Umschalt+6
Ausschließendes ODER (xor) | Strg+Umschalt+5
Nicht | Strg+Umschalt+1


Benutzerdefinierte Operatoren

Operatoren und Funktionen entsprechen einander weitgehend. Beide werden mit "Argumenten" versehen und geben Ergebnisse aus. Mathcad ermöglicht daher die Definition eigener Operatoren ebenso, wie Sie eigene Funktionen definieren können. Sie können Operatoren definieren, die nur ein Argument oder zwei Argumente annehmen.

  • Definieren von Binäroperatoren

  • Definieren von einstelligen Operatoren

  • Verwenden von benutzerdefinierten Binäroperatoren

  • Verwenden von benutzerdefinierten einstelligen Operatoren


Lösen und Optimieren – Überblick

In Mathcad können Sie mithilfe der verschiedenen vordefinierten Funktionen eine Vielzahl von Optimierungsproblemen numerisch lösen. Wenn Sie eine einzelne Gleichung nach einem unbekannten Wert auflösen möchten, steht Ihnen die Funktion wurzel zur Verfügung. Zum Lösen eines Gleichungssystems können Sie auf die Funktion Suchen oder Minfehl zurückgreifen. Die Funktion Suchen sollten Sie verwenden, wenn Sie eine genaue Lösung haben wollen, die Funktion Minfehl dagegen, wenn Ihnen eine ungefähre Lösung reicht.

Mit den Mathcad-Funktionen Minimieren und Maximieren können Sie Optimierungsprobleme lösen, bei denen Sie nach Werten suchen, die eine Funktion minimieren bzw. maximieren. Zu diesen Problemen gehört auch das lineare Programmieren.

  • Lösen einer Gleichung mit einer Unbekannten

  • Lösen eines Gleichungssystems

  • Näherungsweises Lösen eines Gleichungssystems

  • Optimieren einer nichtlinearen Funktion

  • Optimieren einer linearen Funktion

  • Wirkungsweise der Lösungs- und Optimierungsfunktionen

  • Symbolisches Lösen von Gleichungen


Lösen einer Gleichung mit einer Unbekannten

Solche Gleichungen können folgendermaßen dargestellt werden:

f(x) = g(x)

Wird diese Gleichung vereinfacht, ergibt sich:

f(x) - g(x) = 0

Die Lösung wird durch die Funktion wurzel ermittelt:

wurzel(f(x) - g(x),x)

oder so:

wurzel(f(x) - g(x),x,a,b)

Beispiel 1:

Gegeben sei die Gleichung:

cos(x) = x + .2

Die Gleichung könnten Sie wie folgt lösen:

x := 1<--- Schätzwert

wurzel(cos(x) - x - .2,x) = .616

Beispiel 2:

In Beispiel 1 gibt der Schätzwert der Funktion wurzel an, wo mit der Suche nach einer Wurzel begonnen werden soll. In diesem Beispiel legen das dritte und das vierte Argument einen Bereich fest, in dem nach einer Wurzel gesucht werden soll.

Gegeben sei die Gleichung:

sin(x) = .2

Die Gleichung könnten Sie wie folgt lösen:

wurzel(sin(x) - .2, x, 2, 4) = 2.94


Lösen linearer Systeme

llösen(M,v) Gibt den Lösungsvektor für das lineare Gleichungssystem Mx = v zurück.

Argumente:

  • M ist eine quadratische, nichtsinguläre Matrix.

  • v ist ein Vektor, der ebenso viele Zeilen aufweist wie M.


Lösen eines Systems nichtlinearer Gleichungen

Im folgenden Beispiel wird gezeigt, wie zwei nichtlineare Gleichungen mit zwei Unbekannten mithilfe der Funktion suchen aufgelöst werden.


Näherungslösungen für ein System nichtlinearer Gleichungen

Im folgenden Beispiel wird gezeigt, wie Sie mit der Funktion minfehl die Werte finden, die einer Lösung für ein System von Gleichungen am nächsten kommen.


Suchen von Wurzeln

wurzel(f(var1, var2, ...),var1, [a, b]) Gibt den Wert von var1 zurück, der zwischen a und b liegt, und an dem die Funktion f gleich null ist.

nullstellen(v) Gibt einen Vektor zurück, der alle Wurzeln des Polynoms enthält, dessen Koeffizienten in v enthalten sind.

Argumente:

  • f ist eine skalar-wertige Funktion einer beliebigen Anzahl von Variablen.

  • var1 ist eine skalare Variable in f. var1 im zweiten Argument ist die Variable, für die die Wurzel gefunden wird.

  • a und b sind optional. Werden a und b angegeben, müssen sie reelle Zahlen sein, und es gilt a < b.

  • v ist ein Vektor mit Koeffizienten eines Polynoms, in dem das erste Element der konstante Term ist.

Hinweise:

  • Wenn Sie die Argumente a und b nicht angeben, benötigt die wurzel-Funktion einen Schätzwert, um mit der Ermittlung der Wurzel beginnen zu können. Bei Funktionen mit einer Vielzahl von Wurzeln hängt die zurückgegebene Wurzel davon ab, welcher Schätzwert eingegeben wurde. Befindet sich der Schätzwert sehr nahe an einem Minimum oder Maximum von f, kann es passieren, dass die Funktion wurzel nicht konvergiert bzw. an eine Wurzel konvergiert, die weit vom Schätzwert entfernt ist.

  • Die Klammernschreibweise der Funktion wurzel gibt nur dann eine Antwort aus, wenn f(a) und f(b) entgegengesetzte Zeichen sind.

  • Sie können zwischen zwei Algorithmen für die Funktion nullstellen wählen.

QuickSheet-Beispiel starten Für die Funktion wurzel.

QuickSheet-Beispiel starten Für die Funktion nullstellen.


Arbeiten mit den Funktionen "maximieren" und "minimieren"

Im Beispiel unten ist eine nichtlineare Optimierung mithilfe der Funktion M aximieren dargestellt:

Im Beispiel unten ist eine nichtlineare Optimierung mithilfe der Funktion Minim ieren dargestellt:


Symbolisches Lösen einzelner Gleichung

Symbolisches Lösen einzelner Gleichungen

Zum Auflösen von Gleichungen gehen Sie wie folgt vor:

  1. Geben Sie die linke Seite der Gleichung ein.

  2. Drücken Sie [Umschalt]= zur Erstellung des Gleichheitszeichens. (Soll die Wurzel eines Ausdrucks gefunden werden, können Sie diesen Schritt überspringen und mit Schritt 4 fortfahren.)

  3. Geben Sie in den verbleibenden Platzhalter die rechte Seite der Gleichung ein.

  4. Wählen Sie die Variable aus, nach der aufgelöst werden soll.

  5. Wählen Sie den Befehl Variable / Auflösen im Menü Symbolik.

Mathcad löst nach der Variable auf und fügt das Ergebnis im Arbeitsblatt ein.

Gibt es für die Gleichung mehrere Lösungen, wird ein Vektor mit je einem Element pro Lösung angezeigt. Enthält die Gleichung Dezimalzahlen, wird auch die Antwort dezimal angezeigt. Andernfalls erscheint eine genaue Lösung (soweit verfügbar).

Zur Auflösung einer Ungleichung folgen Sie obigen Anweisungen. Drücken Sie jedoch anstelle von [Umschalt]= die Tasten >, <, [Strg]( für £ bzw. [Strg]) für ³.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle das Schlüsselwort "auflösen" und die aktive symbolische Berechnung.


Differentialgleichungen

Einzelne, gewöhnliche Differentialgleichungen

Lösen einer einzelnen, gewöhnlichen Differentialgleichung zweiter Ordnung, die im höchsten Ableitungsglied linear ist, mithilfe von Gdglösen.

Einzelne, gewöhnliche Differentialgleichungen - Alternative Methode

Lösen einer einzelnen, gewöhnlichen Differentialgleichung zweiter Ordnung, die im höchsten Ableitungsglied nicht linear ist, mithilfe von rkfest.

Systeme von Differentialgleichungen

Lösen eines Systems mit n gewöhnlichen Differentialgleichungen mithilfe von rkfest.

Differentialgleichungen mit besonderen Eigenschaften

Verwenden der Funktion Bulstoer für stetige Systeme, der Funktionen Stiffb und Stiffr für steife Systeme und Rkadapt für sich langsam ändernde Systeme.

Einschränkung auf letzten Punkt

Zu verwendende Funktionen, wenn Sie nur der Lösungswert am letzten Punkt im Integrationsintervall interessiert

Zweipunkt-Randwertprobleme

Verwenden Sie grwanp und sgrwl zum Konvertieren eines Zweipunktrandwertproblems in ein Anfangswertproblem, das sich durch rkfest lösen lässt.

Teildifferentialgleichungen

Lösen von Poissonschen Gleichungen in einem quadratischen Bereich mithilfe von relax und multigit.


Überblick über Datenverwaltung

Mathcad enthält Komponenten zum Datenaustausch zwischen Mathcad und anderen Anwendungen. Eine Komponente kommuniziert mit den mathematischen Gleichungen in Mathcad, wobei die Mathcad-Berechnungen mit der restlichen Rechenumgebung verknüpft werden. Durch diese Verknüpfung können Daten dynamisch zwischen dem Mathcad-Arbeitsblatt und einer Datenquelle oder Anwendung fließen.

Einige Komponenten dienen dem Importieren, andere dem Exportieren von Daten, und Anwendungskomponenten wie Excel, Axum und MATLAB ermöglichen die Kommunikation mit anderen auf dem Computer installierten Anwendungen.

Beispiele für die verschiedenen Mathcad-Komponenten finden Sie unter dem Eintrag Using Mathcad with Other Applications (Verwendung von Mathcad mit anderen Anwendungen) im Menü "Hilfe" unter QuickSheets.

  • Einführung in Komponenten

  • Importieren von Daten

  • Exportieren von Daten

  • Datenaustausch mit anderen Anwendungen

  • Verwenden von MathConnex


Importieren von Daten

Sie können Daten in ein Arbeitsblatt übernehmen, indem Sie sie einmalig aus einer Datei importieren, die Daten aus einer Datei einlesen, die Daten aus einer Datenbank einlesen oder die Daten aus der Zwischenablage einfügen. Bei allen diesen Methoden werden Felder Ihrer Daten erstellt. Sie können die Daten natürlich auch in eine Eingabetabelle oder eine Matrix eingeben.

Importieren von Daten aus einer Datendatei

Einlesen von Daten aus einer Datendatei

Lesen von Daten aus einer ASCII-Datendatei mithilfe einer Funktion

Einlesen von Daten aus einer Datendatei

Einlesen von Daten aus einer Datenbank

Einlesen von Daten aus einem Messgerät

Erstellen einer Zahlentabelle

Erstellen einer Matrix oder eines Vektors

Einfügen von Daten aus der Zwischenablage


Importieren von Daten aus einer Datendatei

Wenn Sie Daten aus einer Datendatei einmalig in Ihr Arbeitsblatt importieren möchten, können Sie eine Datentabelle verwenden. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie im Arbeitsblatt auf eine leere Stelle, und wählen Sie Daten im Menü Einfügen.

  2. Wählen Sie im nun angezeigten Untermenü die Option Tabelle. Es wird eine Tabelle mit numerischen Zeilen- und Spaltenbeschriftungen angezeigt.

  3. Geben Sie im links angezeigten Platzhalter den Namen der Variablen ein, der diese Daten zugewiesen werden sollen.

  4. Klicken Sie mit der rechten Maustaste auf die Datentabelle, um das Kontextmenü zu öffnen.

  5. Wählen Sie Importieren.

  6. Das Dialogfeld Dateioptionen wird geöffnet. Wählen Sie im Feld Dateityp den Dateityp aus, den Sie importieren möchten. Wechseln Sie im Dialogfeld zum Verzeichnis der entsprechenden Datei, und klicken Sie auf Fertigstellen oder Nächster, wenn Sie eine Untermenge Zeilen und Spalten im Datensatz auswählen möchten.

Die Daten aus der Datendatei werden daraufhin im Arbeitsblatt in Tabellenform angezeigt und dem von Ihnen gewählten Variablennamen zugewiesen. Sie können dieses Mathcad-Feld nun wie jede andere Mathcad-Matrix oder jeden anderen Vektor bearbeiten.


Einlesen von Daten aus einer Datendatei

Sie können Daten aus einer Datendatei mithilfe der Komponente "Dateieingabe" oder "Datentabelle" in Mathcad einlesen. Mit diesen Komponenten können Sie eine Verbindung zu einer Datendatei herstellen oder Daten einmalig importieren und die Daten dann einer Variablen des Arbeitsblattes zuweisen.

Zum Einlesen von Daten mit der Komponente Datendateieingabe gehen Sie wie folgt vor:

  1. Klicken Sie auf eine leere Stelle im Arbeitsblatt.

  2. Wählen Sie den Befehl Daten aus dem Menü Einfügen.

  3. Wählen Sie aus der Liste den Eintrag Dateineingabe. Daraufhin wird der Setup-Assistent für die Dateieingabe gestartet.

  4. Wählen Sie im Assistenten aus der Dropdown-Liste "Dateiformat:" den Typ der Datei aus, aus der gelesen werden soll.

  5. Geben Sie den Pfad der Datendatei ein, aus der gelesen werden soll, oder klicken Sie auf die Schaltfläche "Durchsuchen", um sie aus dem Verzeichnisbaum auszuwählen.

  6. Klicken Sie auf "Weiter" und wählen Sie die Optionen für die Anfangs- und Endzeilen und -Spalten der Daten aus.

  7. Klicken Sie auf "Fertig stellen". Daraufhin werden das Symbol für die Komponente "Dateieingabe" und der Pfad der Datendatei angezeigt.

  8. Geben Sie im links angezeigten Platzhalter den Namen der Mathcad-Variablen ein, der diese Daten zugewiesen werden sollen.

Sobald Sie auf eine Stelle außerhalb der Komponente klicken, wird die Datendatei gelesen, und die Daten werden der Mathcad-Variablen zugewiesen, die Sie in den Platzhalter eingetragen haben. Sie können die Variable nun ganz nach Ihren Wünschen bearbeiten. Jedesmal, wenn Sie das Arbeitsblatt berechnen, liest Mathcad die Daten aus der angegebenen Datei erneut ein.


Lesen von Daten aus einer Datendatei (Funktion PRNLESEN)

Einlesen von Daten aus einer Datendatei

PRNLESEN(“datei”) Gibt ein Feld zurück, das den Inhalt von datei enthält.

Argumente:

  • datei ist entweder ein Dateiname oder der vollständige Pfad zu einer strukturierten ASCII-Datendatei.

  • datei wird als Zeichenfolge eingegeben.

Beispiele:

Mit PRNLESEN("daten.prn") wird die Datei daten.prn eingelesen, die sich im Standardverzeichnis befindet.

Mit PRNLESEN("c:\.Datendateien\final\ausgabe.prn") wird die Datei ausgabe.prn eingelesen, die sich im Verzeichnis c:\Datendateien\final befindet.

Hinweis:

Wenn Sie das Argument dieser Funktion ändern, sollten Sie es stets aktualisieren. Klicken Sie dazu auf das Argument, und wählen Sie den Befehl Berechnen im Menü Extras.


Lesen von Daten aus einer binären Datendatei (Funktion BINLESEN)

Lesen von Daten aus einer binären Datendatei

BINLESEN(“datei”, “typ”, [[endian], [spalten], [skip], maxrows]]) Gibt ein Feld zurück, das die binären Daten in der datei enthält.

Argumente:

  • datei ist entweder ein Dateiname oder der vollständige Pfad zu einer binären Datendatei und muss als Zeichenfolge eingegeben werden.

  • typ gibt das in der Datei verwendete Datenformat an und muss als Zeichenfolge eingegeben werden. BINLESEN unterstützt die folgenden Datentypen:

    • byte - 8-Bit-Ganzzahl ohne Vorzeichen.
    • double - 64-Bit-Gleitkommazahl.
    • float - 32-Bit-Gleitkommazahl.
    • int16 - 16-Bit-Ganzzahl mit Vorzeichen.
    • int32 - 32-Bit-Ganzzahl mit Vorzeichen.
    • uint16 - 16-Bit-Ganzzahl ohne Vorzeichen.
    • uint32 - 32-Bit-Ganzzahl ohne Vorzeichen.

  • endian zeigt an, ob die Daten in der Datei im Big Endian-Format (höchstwertiges Byte zuerst) oder im Little Endian-Format (geringstwertiges Byte zuerst) vorliegen. Für Big Endian steht eine 1, für Little Endian eine 0. Wenn kein Wert angegeben wird, wird für endian eine 0 gesetzt.

  • spalten ist die Anzahl der Spalten pro Zeile in der Eingabedatei. Es muss eine positive ganze Zahl sein. Wird spalten weggelassen, wird es gleich 1 gesetzt.

  • skip gibt die Anzahl von Byte an, die am Anfang der Datei ignoriert werden sollen, bevor mit dem Einlesen von Daten begonnen wird. Es muss eine nicht negative ganze Zahl sein. Wird skip weggelassen, wird es gleich 0 gesetzt.

  • maxrows ist die maximale Anzahl von Datenzeilen, die aus der Datendatei eingelesen werden soll. Es muss eine nicht negative ganze Zahl sein. Werden keine Angaben gemacht, dann wird maxrows auf 0 gesetzt. Dies wird als "unbegrenzt" interpretiert.

Beispiele:

BINLESEN(“daten.bin”, “byte”) liest in der Datei daten.bin, die sich als Spaltenvektor mit 8-Bit-Ganzzahlen ohne Vorzeichen iim Standardverzeichnis befindet.

BINLESEN(“c:\datendateien\final\ausgabe.bin”, “float”, 0, 5, 0, 10) liest in der Datei ausgabe.bin, die sich als Feld mit 5 Spalten und bis zu 10 Zeilen im Verzeichnis c:\datendateien\final befindet. Die Daten sind 32-Bit-Gleitkommazahlen im Little Endian-Format. Am Anfang der Datei werden keine Bytes ignoriert.

Hinweise:

  • Wenn Sie nicht sicher sind, ob die Daten als Big Endian (Macintosh-Standard) oder Little Endian (IBM-PC-Standard) geschrieben wurden, sehen Sie in der Systemdokumentation zu der Datenquelle nach, ehe Sie sich auf die Ergebnisse der Funktion BINLESEN verlassen.

  • Wenn Sie das Argument dieser Funktion ändern, sollten Sie es stets aktualisieren. Klicken Sie dazu auf das Argument, und wählen Sie den Befehl Berechnen im Menü Extras.


ODBC-Eingabekomponente

Mithilfe der ODBC-Eingabekomponente ("Datenbankverbindung öffnen") können Sie Informationen aus einer Datenbank abrufen, die in ihrem ODBC-Treiber SQL unterstützt.

Zum Einfügen einer ODBC-Eingabekomponente in ein Mathcad-Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Stellen Sie eine Verbindung zur Datenbank her.

  2. Klicken Sie im Arbeitsblatt auf eine leere Stelle, und wählen Sie im Menü Einfügen den Eintrag Komponente .

  3. Markieren Sie in der Liste die Option "ODBC-Eingabe", und klicken Sie auf "Weiter".

  4. Wählen Sie die Datenbank aus, aus der Daten abgefragt werden sollen. Je nach Datenquelle müssen Sie eventuell auch einen Benutzernamen und ein Kennwort eingeben. Klicken Sie auf "Weiter".

  5. Wählen Sie eine Tabelle, und geben Sie an, welche Felder Sie in der Datenbank lesen möchten. Klicken Sie auf "Fertig stellen".

  6. Geben Sie in den Platzhalter links der Komponente den Namen der Ausgabevariable ein, die definiert werden soll.

Nachdem Sie eine Verbindung zu einer bestimmten Datenbank hergestellt haben, kann es vorkommen, dass Sie die Datenquelle, die Tabelle oder die in Ihr Mathcad-Arbeitsblatt zu importierenden Datenspalten ändern möchten. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie mit der rechten Maustaste auf die Komponente, und wählen Sie im Kontextmenü den Befehl Eigenschaften.

  2. Wählen Sie im Dialogfeld "Eigenschaften" auf der Registerkarte Datenquelle die Datenbank, die Tabelle und die Spalten aus.

  3. Klicken Sie auf OK, um das Dialogfeld zu schließen und Ihr Arbeitsblatt zu aktualisieren.

Hinweise:

  • Sie können die Reihenfolge ändern, in der die Felder Ihrer Datenbank in den Spalten der Ausgabematrix in Mathcad gespeichert werden. Klicken Sie dazu mit der rechten Maustaste auf die ODBC-Komponente in Ihrem Mathcad-Arbeitsblatt, und wählen Sie im Kontextmenü den Befehl Eigenschaften. Klicken Sie im daraufhin angezeigten Dialogfeld auf die Registerkarte "Erweitert", und ändern Sie mithilfe der Schaltflächen "Nach oben" und "Nach unten" die Reihenfolge der Felder in den Spalten der Matrix.

  • Sie können Ihre Daten filtern, bevor Sie sie in einer Mathcad-Ausgabevariable verwenden.

  • Wenn Sie die Option "Felder mit nicht unterstützten Datentypen anzeigen" im Assistenten für die ODBC-Eingabekomponente oder auf der Registerkarte "Datenquelle" im Dialogfeld "Eigenschaften" aktivieren, werden alle Datenfelder angezeigt, selbst solche, die nicht von Mathcad-Variablen unterstützt werden. Zum Beispiel werden in Mathcad keinerlei Zeitdatentypen unterstützt. Sie können Zeitindizes aus Ihrer Datenbank jedoch in einer Mathcad-Ausgabevariablen auswählen und anzeigen.


Einlesen von Daten aus einem Messgerät

Die DAC-Komponente (Data Acquisition Control, Datenerfassung)

Mithilfe der DAC-Komponente (Data Acquisition Control) können Sie folgende Arbeiten durchführen:

  • Einlesen von Daten direkt von einem Messgerät

  • Senden von Daten an ein Messgerät

  • Durchführen einer "Echtzeit"-Messwerterfassung und -Analyse.

Mithilfe der DAC-Komponente ist es möglich, den Zwischenschritt des Speicherns der erfassten Daten in einer externen Datei zu umgehen – die Daten können direkt in Mathcad angezeigt und analysiert werden. Die Komponente bildet so gewissermaßen die Schnittstelle zwischen Arbeitsblatt und Messgerät.

Zum Einfügen der DAC-Komponente in ein Mathcad-Arbeitsblatt gehen Sie wie folgt vor:

  1. Klicken Sie im Arbeitsblatt auf eine leere Stelle. Wenn Sie Werte aus einer in Ihrem Arbeitsblatt definierten Mathcad-Variable an die Komponente senden möchten, müssen Sie unter oder rechts neben die Variablendefinition klicken.

  2. Wählen Sie aus dem Menü Einfügen den Befehl Komponente

  3. Wählen Sie in der Liste der verfügbaren Komponenten den Eintrag Datenerfassung, und klicken Sie auf Fertig stellen.

Die Komponente "Datenerfassung" wird für eine analoge Einzelpunkt-Datensammlung sowie mit einem Platzhalter für eine Ausgabevariable in die Arbeitsblattgruppe eingefügt. Sie können jedoch die Anzahl der Eingaben und Ausgaben verändern. Außerdem können Sie alle Standardeigenschaften ändern, indem Sie mithilfe des Fensters "Skript bearbeiten" oder mithilfe der Benutzeroberfläche für das Steuerelement die Komponente konfigurieren. Siehe Beispiel.

Hinweise:

  • Weitere Informationen über Eigenschaften und Methoden im Zusammenhang mit der Komponente "Datenerfassung" und anderen Skriptobjekt-Komponenten finden Sie ebenfalls in der Developer's Reference (Entwickler-Referenz).

  • Wenn Sie die Komponente "Datenerfassung" verwenden, um analoge "Waveform"-Daten in Mathcad in Echtzeit zu analysieren, muss sichergestellt sein, dass die Automatische Berechnung aktiviert ist.

  • Beispiel-Arbeitsblätter mit der Komponente "Datenerfassung" finden Sie im Ordner SAMPLES Ihres Mathcad-Installationsverzeichnisses.

  • Bei allen Methoden, Eigenschaften und mit der Mathcad-Komponente "Datenerfassung" verknüpften Ereignissen können Sie auf die kontextsensitive Hilfe zurückgreifen. Diese öffnen Sie, indem Sie im Visual Basic-Objektkatalog das Objekt "AnalogIO" auswählen und auf die Schaltfläche "Hilfe" klicken.


Eingeben einer Wertetabelle

Sie können Werte direkt in Ihrem Arbeitsblatt eingeben und diese mithilfe einer Datentabelle einer Variablen zuordnen. Gehen Sie dazu wie folgt vor:

  1. Klicken Sie im Arbeitsblatt auf eine leere Stelle, und wählen Sie Daten im Menü Einfügen.

  2. Wählen Sie den Befehl Data Table, und klicken Sie auf OK.

  3. Geben Sie im links angezeigten Platzhalter den Namen der Mathcad-Variablen ein, der diese Daten zugewiesen werden sollen.

  4. Klicken Sie auf die Tabelle, und geben Sie in die Zellen Daten (Zahlen) ein. Bei den eingegebenen Zahlen kann es sich um dezimale Zahlen oder Zahlen im e-Format handeln, wie z. B. 3.4, 2i oder 4e-6 .

Wenn Sie eine Datentabelle erstellen, erstellen Sie eigentlich ein Feld mit dem Namen, den Sie in den Platzhalter eingegeben haben. Nachdem Sie ein Feld mithilfe der Datentabelle erstellt haben, können Sie das Feld mit den vordefinierten Funktionen und Operatoren von Mathcad ändern.

Hinweise:

  • In eine Tabelle können nur Zahlen, aber keine mathematischen Ausdrücke eingegeben werden.

  • In jeder Zeile müssen sich gleich viele Datenwerte befinden. Wenn Sie in eine Zelle keine Zahl eingeben, erhält diese Zelle automatisch den Wert 0.

  • Sie können auch Werte, die Sie aus einer anderen Anwendung kopiert haben, in eine Datentabelle einfügen. Statt die Werte in die Zellen der Tabelle einzugeben, können Sie auch mit der rechten Maustaste auf die Tabelle klicken und im Kontextmenü den Befehl Tabelle einfügen oder Importieren wählen, um eine Datei zu importieren.

Im Arbeitsblatt erscheint eine Tabelle mit den kopierten Daten. Mathcad versucht, die Datentypen beizubehalten:

  • Reelle Zahlen werden als reelle Zahlen eingefügt.
  • Komplexe Zahlen mit nachfolgendem i oder j werden als imaginäre Zahlen eingefügt.
  • Zahlen mit e oder E und einem Exponenten werden als Notationszahlen eingefügt.
  • Zeichenfolgen werden als Mathcad-Zeichenfolgenvariablen eingefügt, die in Anführungszeichen eingeschlossen sind.


Exportieren von Daten in eine Datendatei

Zum Exportieren von Daten in eine Datendatei gehen Sie wie folgt vor:

  1. Geben Sie "=" ein, um die Ergebnisse einer Variable anzuzeigen.

  2. Wenn die Ergebnisse als Matrix erscheinen, doppelklicken Sie auf die Matrix, und ändern Sie im Dialogfeld Ergebnisformat die Anzeigeoption in Tabelle.

  3. Klicken Sie mit der rechten Maustaste auf die Ausgabetabelle. Es wird ein Kontextmenü geöffnet.

  4. Wählen Sie den Befehl Exportieren. Das Dialogfeld Daten in Datei schreiben wird geöffnet.

  5. Wählen Sie im Textfeld Dateityp das Format der Datei aus, die erstellt werden soll. Geben Sie den Ordner an, in dem die Datendatei erstellt werden soll, und geben Sie einen Namen für die zu erstellende Datendatei ein. Klicken Sie dann auf Speichern.

Die Daten werden in die von Ihnen festgelegte Datei exportiert.

Hinweis: Wenn sich die Daten ändern und die Datendatei entsprechend aktualisiert werden soll, müssen Sie die Daten erneut exportieren. Wenn die Daten automatisch aktualisiert werden sollen, können Sie eine dynamische Verbindung zwischen Ihrem Arbeitsblatt und der Datendatei herstellen. Verwenden Sie dazu die Komponente Daten in eine Datei schreiben.


Schreiben von Dateien auf Festplatte

Zum Schreiben von Werten aus Mathcad in eine Datendatei steht Ihnen die Komponente "Datei schreiben" zur Verfügung. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie im Arbeitsblatt auf eine leere Stelle.

  2. Wählen Sie den Befehl Daten aus dem Menü Einfügen.

  3. Markieren Sie in der Liste der Komponenten die Komponente "Datei schreiben", und klicken Sie auf "Weiter". Daraufhin wird der Dateiausgabe-Setup-Assistent gestartet.

  4. Wählen Sie im Assistenten aus der Dropdown-Liste "Dateiformat:" den Typ der Datendatei aus, den Sie erstellen wollen.

  5. Geben Sie den Pfad der Datendatei ein, in die geschrieben werden soll, oder klicken Sie auf die Schaltfläche "Durchsuchen", um sie aus dem Verzeichnisbaum auszuwählen.

  6. Klicken Sie auf “Weiter”, und wählen Sie die Anfangs- und Endzeilen und Spalten aus den Daten aus, die Sie in die Ausgabedatei schreiben wollen.

  7. Klicken Sie auf "Fertig stellen". Daraufhin werden das Symbol für die Komponente "Dateien lesen" oder "Datei schreiben" und der Pfad der Datendatei angezeigt.

  8. Geben Sie im Platzhalter, der unten in der Komponente angezeigt wird, den Namen der Mathcad-Variable ein, die die Daten enthält, die in die Datendatei geschrieben werden sollen.

Wenn Sie auf eine Stelle außerhalb der Komponente klicken, werden die Werte in der Mathcad-Variable in die von Ihnen angegebene Datei geschrieben.

Hinweise:

  • Wenn Sie das Arbeitsblatt neu berechnen oder F9 für die jeweilige Komponente drücken, wird die Datendatei neu geschrieben.

  • Als Mathcad-Variable für die Daten muss ein Feld verwendet werden. Wenn die Daten in einer Bereichsvariablen gespeichert sind, müssen Sie zuerst den Zahlenbereich in einen Vektor umwandeln. Hinweise hierzu finden Sie im QuickSheet "Konvertieren eines Zahlenbereichs in einen Vektor". Stammen die Daten aus einer Funktion, muss das Argument der Funktion ein Feld sein.

  • Sie können auch Datein in eine Datei schreiben und den Inhalt von verschachtelten Feldern darin einbeziehen, indem Sie die Funktionen PRNSCHREIBEN und PRNANFÜGEN verwenden.


Schreiben von Daten in eine Datendatei mithilfe einer Funktion

Schreiben von Dateien auf Festplatte

PRNSCHREIBEN(“Datei”) Schreibt ein Feld in die Datei Datei.

Argumente:

datei ist entweder der Dateiname oder der vollständige Pfad zu einer ASCII-Datendatei.

datei wird als Zeichenfolge eingegeben.

Beispiel:

PRNSCHREIBEN("c:\daten\ergebnis.prn") := A

A ist eine Matrix, deren Werte in die im Verzeichnis c:\daten befindliche Datendatei ergebnis.prn geschrieben werden.

Hinweise:

  • PRNSCHREIBEN ordnet die Daten in der ASCII-Datei entsprechend der ursprünglichen Matrix in Zeilen und Spalten an. Standardmäßig schreibt PRNSCHREIBEN vier signifikante Ziffern in Spalten mit einer Breite von acht Ziffern. Um dies zu ändern, wählen Sie den Befehl Arbeitsblattoptionen im Menü Extras, und ändern Sie in der Registerkarte Vordefinierte Variablen die Werte für GENAUIGKEITPRN und SPALTENBREITEPRN.

  • Wenn Sie das Argument dieser Funktion ändern, sollten Sie es stets aktualisieren. Klicken Sie dazu auf das Argument, und wählen Sie den Befehl Berechnen Þ Jetzt berechnen im Menü Extras.


Schreiben von Daten in eine binäre Datendatei mithilfe einer Funktion

Schreiben von Daten in eine binäre Datendatei

BINSCHREIBEN(“Datei”, “Typ”, endian) schreibt ein Datenfeld von Skalaren in eine binäre Datendatei mit der Bezeichnung Datei.

Argumente:

  • Datei ist entweder ein Dateiname oder der volle Pfad einer binären Datendatei und muss als Zeichenfolge eingegeben werden.

  • Typ gibt das Datenformat an, das die Datei verwendet und muss als Zeichenfolge eingegeben werden. BINSCHREIBEN unterstützt die folgenden Datentypen:

    • byte - 8-Bit-Ganzzahl ohne Vorzeichen.
    • double - 64-Bit-Gleitkommazahl.
    • float - 32-Bit-Gleitkommazahl.
    • int16 - 16-Bit-Ganzzahl mit Vorzeichen.
    • int32 - 32-Bit-Ganzzahl mit Vorzeichen.
    • uint16 - 16-Bit-Ganzzahl ohne Vorzeichen.
    • uint32 - 32-Bit-Ganzzahl ohne Vorzeichen.

  • endian gibt an, ob die Daten in der Datei "big-endian" (hohes Byte zuerst) oder "little-endian" (niedriges Byte zuerst) sind. Für "big-endian" steht eine 1, für "little-endian" eine 0.

Beispiele:

BINSCHREIBEN("Daten.bin", "Byte", 0) := A schreibt ein Datenfeld A in die Datei Daten.bin im Standardverzeichnis als little-endian 8-Bit-Ganzzahl ohne Vorzeichen.

BINSCHREIBEN("c:\Eigene Dateien\final\Ausgabe.bin", "float", 1) := A schreibt ein Datenfeld A in die Datei Ausgabe.bin im Ordner c:\Eigene Dateien\final\ als big-endian 32-Bit-Gleitkommazahlen.

Hinweise:

  • Wenn Sie nicht sicher sind, ob Ihre Daten in big-endian- (Macinstosh-Standard) oder little-endian- (IBM-PC-Standard)-Format geschrieben werden sollen, lesen Sie die Systemdokumentation für Ihr Datenziel, bevor Sie BINSCHREIBEN verwenden.

  • Wenn Sie das Argument dieser Funktion ändern, sollten Sie es stets aktualisieren. Klicken Sie dazu auf das Argument, und wählen Sie den Befehl Berechnen Þ Jetzt berechnen im Menü Extras.


Kopieren von Daten in die Zwischenablage

Wenn Sie die Ergebnisse Ihrer Berechnungen in Mathcad in eine andere Anwendung einfügen wollen, ohne sie als ganze Datei zu exportieren, dann können Sie die Daten in die Zwischenablage kopieren und von dort in die andere Anwendung einfügen. Gehen Sie hierzu folgendermaßen vor:

  1. Geben Sie = ein, um die Ergebnisse einer Variable anzuzeigen.

  2. Wenn die Ergebnisse als Matrix angezeigt werden, doppelklicken Sie auf die Matrix, und ändern Sie im Dialogfeld Ergebnisformat die Anzeigeoption in Tabelle.

  3. Klicken Sie mit der rechten Maustaste auf die Ausgabetabelle.

  4. Wählen Sie aus dem Popup-Menü die Option Alles markieren, um alle Werte in der Ausgabetabelle zu markieren.

  5. Drücken Sie nochmals die rechte Maustaste, und wählen Sie aus dem Popup-Menü die Option Auswahl kopieren.

  6. Öffnen Sie die andere Anwendung, und fügen Sie dort den Inhalt der Zwischenablage ein. (Dies geschieht normalerweise, indem Sie aus dem Menü Bearbeiten den Befehl Einfügen auswählen .)


Komponenten (Einführung)

Mithilfe von Komponenten können Daten dynamisch zwischen dem Mathcad-Arbeitsblatt und einer Datenquelle oder Anwendung ausgetauscht werden. Die Daten, die von Mathcad an eine Komponente übertragen werden, werden Eingabe genannt. Die Daten, die aus einer Komponente kommen, werden Ausgabe genannt. Die Übertragung von Ein- und Ausgabe zwischen dem Mathcad-Arbeitsblatt und einer Komponente erfolgt mittels Eingabevariablen und Ausgabevariablen.

Für die Verwendung einer Komponente zum Austausch von Daten mit Mathcad sind die folgenden grundlegenden Schritte erforderlich:

  1. Einfügen der Komponente in das Arbeitsblatt und Angeben der Eingabevariablen und Ausgabevariablen in den entsprechenden Platzhaltern

  2. Konfigurieren der Komponente, um ihr mitzuteilen, was mit der Eingabe geschehen soll und wohin die Ausgabe gesendet wird

Die meisten Komponenten senden Daten an eine andere Datenquelle und rufen Daten von einer anderen Datenquelle ab, einige Komponenten nehmen jedoch nur Eingaben an oder senden nur Ausgaben. Deshalb unterscheiden sich diese Schritte von Komponente zu Komponente geringfügig. Die mit diesen Schritten beschriebene Richtung weist jedoch darauf hin, wie die Komponenten funktionieren.

Nachdem Sie eine Komponente in Ihr Mathcad-Arbeitsblatt eingefügt, die entsprechenden Platzhalter mit Werten versehen und die Eigenschaften festgelegt haben, müssen Sie auf eine Stelle außerhalb des Komponentenbereichs klicken. Daraufhin beginnt die Komponente mit der Berechnung, und der Datenaustausch wird gestartet. Dies passiert, wenn Sie auf die Komponente klicken und die Taste [F9] drücken, wenn sich die Eingabevariablen ändern (falls die automatische Berechnung aktiviert ist) oder wenn Sie den Befehl Arbeitsblatt berechnen im Menü Extras wählen.


Datenaustausch mit anderen Anwendungen

Komponenten sind spezielle OLE-Objekte in Ihrem Mathcad-Arbeitsblatt. Mithilfe von Komponenten können Sie Daten mit anderen Anwendungen oder Quellen austauschen und Steuerelemente der Benutzeroberfläche, beispielsweise Schieberegler und Optionsschaltflächen erstellen.

Mit Anwendungskomponenten können Sie auf Funktionen und Daten von anderen Berechnungsanwendungen wie z.[nbsp]B. Excel, SmartSketch und MATLAB zugreifen. Im Unterschied zu anderen OLE-Objekten, die Sie in Ihr Arbeitsblatt einfügen, können Sie mit einer Komponente folgende Arbeiten durchführen:

  • Senden von Werten aus Mathcad an die Anwendung

  • Dynamisches Verändern der Daten mit der Anwendung, ohne die Mathcad-Umgebung verlassen zu müssen

  • Senden von Werten aus der Anwendung zurück an Mathcad

Wenn Sie eine Anwendungskomponente in das Mathcad-Arbeitsblatt einfügen, wird ein kleines Fenster der Anwendungsumgebung in das Mathcad-Arbeitsblatt eingebettet. Wenn Sie auf die Komponente doppelklicken, werden anstelle der Menüs und Symbolleisten von Mathcad die der anderen Anwendung angezeigt. So erhalten Sie Zugriff auf die Anwendung, ohne die Mathcad-Umgebung verlassen zu müssen.

Mathcad-Komponenten können zu folgenden Anwendungen eine Verbindung herstellen:

  • Axum

  • Excel

  • MATLAB

  • ODBC-Datenbanken (SQL-Unterstützung)

  • SmartSketch

  • SPLUS Graph

  • S-PLUS Script

Skriptfähige Komponenten

Skriptfähige Komponenten können zur Steuerung anderer OLE-Anwendungen oder zum Steuern von Prozessen in Ihrem Arbeitsblatt verwendet werden. Die Komponente "Datenerfassung" bietet eine Schnittstelle zwischen National Instruments-Datengeräten und der Mathcad-Umgebung. Mit ihr können Sie Daten von einem mit Ihrem System verbundenen Messgerät abrufen und Daten an das Gerät senden. Mit den MathSoft-Steuerelementen können Sie Schaltflächen, Kombinationsfelder, Listenfelder, Textfelder und Schieberegler erstellen, die mit Variablen in Ihrem Arbeitsblatt verbunden sind. Sie können mit der Skriptobjekt-Komponente benutzerdefinierte Skripts erstellen, die andere OLE-Anwendungen automatisieren, für die keine speziellen Anwendungskomponenten erhältlich sind.

Umfassende Informationen über das Entwickeln von Skript-Komponenten finden Sie in der Developer's Reference (Entwickler-Referenz).

Weitere Komponenten stehen in MathConnex zur Verfügung.


Einfügen von Komponenten

Zum Einfügen einer Komponente in ein Mathcad-Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Klicken Sie im leeren Bereich des Mathcad-Arbeitsblatts auf die Stelle, an der Sie die Komponente einfügen möchten.

  2. Wählen Sie den Befehl Komponente aus dem Menü Einfügen.

  3. Wählen Sie eine der Komponenten in der Liste, und klicken Sie auf Weiter.

Je nach gewählter Komponente wird sofort die Komponente mit einigen Standardeigenschaften (eingefügt in das Arbeitsblatt) oder das Dialogfeld eines Assistenten angezeigt, um Ihnen die Einrichtung der Komponente zu erleichtern.

Jede Komponente hat eine eigene Struktur, also ist auch die Anzeige auf dem Bildschirm jeweils unterschiedlich. Alle Komponenten weisen einen oder mehrere Platzhalter entweder rechts neben dem ":=" oder im unteren Bereich der Komponente auf. Zum Beispiel kann die Excel-Komponente folgendermaßen aussehen, wenn sie in das Arbeitsblatt eingefügt wird:

Die Platzhalter links von ":=" stehen für die Ausgabevariablen. Der Platzhalter unten an der Komponente steht für den Namen einer Eingabevariablen. Die Anzahl der links oder unten angezeigten Platzhalter richtet sich entweder nach den Standardeigenschaften für die Komponente oder nach den Einstellungen, die Sie im Assistenten der Komponente angegeben haben. Nach dem Ausfüllen der Platzhalter können Sie die Argumente ausblenden, falls gewünscht.


Komponente "Axum"

Wenn Sie in Ihrem System Axum installiert haben, können Sie mithilfe der Komponente "Axum" druckfertige Graphen auf der Grundlage Ihrer Mathcad-Daten anfertigen, ohne dazu die Mathcad-Umgebung zu verlassen. Die Komponente "Axum" ermöglicht Folgendes:

  • Erstellen unterschiedlicher Arten zwei- und dreidimensionaler Graphen auf der Grundlage von Mathcad-Daten

  • Umfassendes Formatieren Ihrer Graphen mithilfe von Axum.

Zum Einfügen eines Axum-Graphen in Ihr Mathcad-Arbeitsblatt gehen Sie wie folgt vor:

  1. Erstellen Sie die Felder, die die Daten für die Komponente "Axum" enthalten und die Axum im Graph darstellen soll. Informationen zur Anzahl und zum Typ der Felder, die für die einzelnen Graphtypen benötigt werden, finden Sie in der Hilfe zu Axum.

  2. Klicken Sie im Arbeitsblatt auf eine leere Stelle. Diese muss sich entweder unterhalb oder rechts der Felder befinden.

  3. Wählen Sie den Befehl Komponente aus dem Menü Einfügen.

  4. Markieren Sie in der Liste der Komponenten die Komponente "Axum", und klicken Sie auf "Weiter". Daraufhin wird der Axum-Setup-Assistent gestartet.

  5. Markieren Sie den Typ des einzufügenden Graphen, und klicken Sie auf "Weiter", um zur nächsten Seite des Assistenten zu gelangen.

  6. Wählen Sie einen Diagrammtyp aus. Welche Diagrammtypen zur Verfügung stehen, hängt davon ab, was für einen Graphtyp Sie gewählt haben.

  7. Klicken Sie auf "Fertig stellen". Daraufhin wird die Komponente "Axum" in Ihr Arbeitsblatt eingefügt.

  8. Geben Sie in die Platzhalter die entsprechenden Feld-Eingabevariablen ein.

Wenn Sie auf eine Stelle außerhalb der Komponente klicken, werden die Daten im Feld in dem von Ihnen festgelegten Axum-Diagrammtyp grafisch dargestellt. Sobald das Arbeitsblatt neu berechnet wird, werden die Daten in Axum aktualisiert.

Hinweis:

Auf Ihrem System muss Axum 5 oder höher installiert sein, um eine Axum-Komponente einfügen zu können.


Excel-Komponente

Sie haben zwar die Möglichkeit, Excel-Datendateien mit den Komponenten Dateieingabe, Dateiausgabe und Data Table zu importieren und zu exportieren, aber mit der Excel-Komponente können Sie Daten zwischen Ihrem Arbeitsblatt und Excel austauschen und die Funktionen von Excel nutzen. So können Sie z. B. Werte aus Ihrem Arbeitsblatt an Excel senden, diese mit den Excel-Funktionen verändern, die veränderten Werte an Ihr Arbeitsblatt zurücksenden und dann mit der Arbeit in Ihrem Arbeitsblatt fortfahren.

Mit der Excel-Komponente haben Sie folgende Möglichkeiten:

  • Weiterleiten von Daten aus Ihrem Arbeitsblatt in eine Excel-Datei

  • Zugreifen auf die Funktionen von Excel durch Doppelklicken auf die Excel-Komponente

  • Senden von Werten aus einer Excel-Datei an Ihr Arbeitsblatt

  • Festlegen eines Excel-Arbeitsblattes und eines Eingabe- und Ausgabebereiches

  • Steuern der Anzahl der Ein- und Ausgabevariablen

Zum Einfügen einer Excel-Komponente in ein Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Vergewissern Sie sich, dass Excel 7.0 oder höher auf Ihrem System installiert ist. Zur Verwendung dieser Komponenten muss Excel nicht ausgeführt werden.

  2. Klicken Sie im Arbeitsblatt auf eine leere Stelle. Wenn Sie Werte aus einer in Ihrem Arbeitsblatt definierten Variable an die Komponente senden möchten, müssen Sie unter oder rechts neben die Variablendefinition klicken.

  3. Wählen Sie den Befehl Komponente aus dem Menü Einfügen.

  4. Wählen Sie Excel in der Liste, und klicken Sie auf Weiter. Dadurch wird der erste Teil des Excel-Setup-Assistenten gestartet. Füllen Sie die Dialogfeldoptionen aus, und klicken Sie auf die Schaltfläche Weiter. Der Assistent zeigt weitere Dialogfelder an, deren Optionen ausgefüllt werden müssen.

  5. Wenn Sie die Schritte mit dem Assistenten abgeschlossen haben, wird im Arbeitsblatt die Excel-Komponente mit Platzhaltern für die Eingabevariablen und Ausgabevariablenangezeigt. Geben Sie in den unteren Platzhaltern die Eingabevariablen ein. Geben Sie in den Platzhaltern links neben ":=" die Ausgabevariablen ein.

Wenn Sie auf eine Stelle außerhalb der Komponente klicken, sendet Mathcad die Eingabevariablen an Excel. Excel sendet dann an Ihr Arbeitsblatt einen Zellenbereich zurück, der den Ausgabevariablen zugewiesen wird. Wenn die Ausgabevariablen definiert sind, können Sie sie beliebig verändern.


MATLAB-Komponente

Sie haben zwar die Möglichkeit, MATLAB-Datendateien mit den HREF="What_is_a_Component.html">Komponenten "Dateieingabe", "Dateiausgabe" oder "Datentabelle" zu importieren und zu exportieren, aber mit der MATLAB-Komponente können Sie Daten zwischen Mathcad und MATLAB austauschen und die Funktionen von MATLAB nutzen. Sie können beispielsweise Werte aus Mathcad an MATLAB senden, dort verändern und dann wieder an Mathcad senden.

Mit einer MATLAB-Komponente können Sie folgende Schritte durchführen:

  • Weiterleiten von in Mathcad-Variablen gespeicherten Werten an MATLAB-Variablen

  • Verarbeiten der Daten mit MATLAB durch Doppelklicken auf die MATLAB-Komponente

  • Senden von Daten aus MATLAB-Variablen in Mathcad-Variablen

Zum Einfügen einer MATLAB-Komponente in ein Mathcad-Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Klicken Sie im Arbeitsblatt auf eine leere Stelle. Wenn Sie Werte aus einer in Ihrem Arbeitsblatt definierten Mathcad-Variable an die Komponente senden möchten, müssen Sie unter oder rechts neben die Variablendefinition klicken.

  2. Wählen Sie im Menü Einfügen den Befehl Komponente .

  3. Markieren Sie in der Liste die Option "MATLAB", und klicken Sie auf "Weiter". Die MATLAB-Komponente wird in das Arbeitsblatt eingefügt.

  4. Geben Sie in dem im unteren Bereich angezeigten Platzhalter die Namen der Mathcad-Eingabevariablen ein, die an die MATLAB-Komponente weitergeleitet werden sollen. Geben Sie im Platzhalter links neben der Komponente die Namen der zu definierenden Mathcad-Ausgabevariablen ein.

Die Mathcad-Eingabevariablen werden standardmäßig an MATLAB-Variablen namens in0, in1, in2 usw. weitergegeben. Die MATLAB-Variablen out0, out1, out2 usw. definieren die Ausgabevariablen, die in Mathcad erstellt werden sollen. Zum Ändern dieser Namen gehen Sie folgendermaßen vor:

  1. Wählen Sie aus dem Kontextmenü der Komponente den Befehl Eigenschaften.

  2. Geben Sie in die entsprechenden Felder auf den Registerkarten "Eingaben" und "Ausgaben" die neuen Namen für die Eingaben und Ausgaben ein.

Hinweis:

  • Auf Ihrem System muss MATLAB Professional Version 4.2c oder höher oder MATLAB Student Version 5.0 oder höher installiert sein, damit Sie eine MATLAB-Komponente einfügen können.


Hinzufügen von Steuerelementen zu einem Arbeitsblatt

Benutzerdefinierte Steuerelemente von Mathsoft

Zum Einfügen von Schaltflächen, Textfeldern, Listenfeldern und Schiebereglern in Ihre Arbeitsblätter stehen Ihnen die MathSoft-Steuerelemente zur Verfügung. Diese Steuerelemente arbeiten ähnlich wie die MSForms-Steuerelemente von Microsoft.

Einfügen von MathSoft-Steuerelementen

Zum Einfügen eines MathSoft-Steuerelements in ein Mathcad-Arbeitsblatt gehen Sie wie folgt vor:

  1. Klicken Sie im Arbeitsblatt auf eine leere Stelle. Wenn Sie Werte aus einer Mathcad-Variablen an das Steuerelement senden möchten, klicken Sie unterhalb oder rechts neben der Variablendefinition.

  2. Wählen Sie die Option Steuerelement im Menü Einfügen oder arbeiten Sie mit der Symbolleiste Steuerelement des Menüs Ansicht. Markieren Sie das gewünschte Steuerelement; das Steuerelement erscheint im Arbeitsblatt.

  3. Geben Sie in den Platzhalter links neben dem Steuerelement den Namen der zu definierenden Mathcad-Ausgabevariablen ein.

Um dem Steuerelement Eingabe- bzw. Ausgabevariablen hinzuzufügen, klicken Sie mit der rechten Maustaste auf das Steuerelement und wählen Sie im Popup-Menü die Option Eingabevariable hinzufügen bzw. Ausgabevariable hinzufügen. Wenn Sie Eingabe- bzw. Ausgabevariablen des Steuerelements hinzufügen bzw. aufheben, müssen Sie Änderungen im Skript vornehmen. Zum Bearbeiten des Skripts eines Steuerelements klicken Sie mit der rechten Maustaste auf das eingebettete Steuerelement, und wählen Sie den Befehl Skript bearbeiten... aus dem Kontextmenü. Wenn Sie das Aussehen des Steuerelements verändern möchten, verwenden Sie die Optionen im Dialogfeld "Eigenschaften" für das Steuerelement.

Hinweise:

  • Für die meisten MathSoft-Steuerelemente werden Sie nur Ausgabevariablen festlegen. Wenn Sie z. B. ein Steuerelement TextBox haben, erhalten Sie 0 Eingaben und 1 Ausgabe, wobei die Ausgabe auf dem in das Textfeld eingegebenen Text beruht.

  • Jedes MathSoft-Steuerelement kann maximal vier Eingaben und vier Ausgaben haben.

  • Weitere Informationen über Eigenschaften und Methoden im Zusammenhang mit MathSoft-Steuerelementen und anderen Skriptobjekt-Komponenten finden Sie in der Developer's Reference (Entwickler-Referenz) .


Skriptobjekt-Komponente

Sie können Daten zwischen einem Mathcad-Arbeitsblatt und einer beliebigen anderen Anwendung, die OLE-Automatisierung unterstützt, auch dann austauschen, wenn Mathcad keine spezielle Komponente dafür enthält. Mit der Skriptobjekt-Komponente können selbstdefinierte Komponenten für folgende Zwecke erstellt werden:

  • Senden von Werten aus Mathcad an die Anwendung

  • Verwenden der Anwendung zum Bearbeiten der Daten, ohne Mathcad zu verlassen

  • Senden von Werten aus der anderen Anwendung zurück an Mathcad

Sie können ein selbstdefiniertes skriptfähiges Objekt aus jedem Objekt erstellen, das in ein Mathcad-Arbeitsblatt einfügt werden kann. Zum Beispiel haben Sie die Möglichkeit, Werte aus Mathcad an Lotus 1-2-3 zu senden, sie dort zu bearbeiten, und die Ergebnisse dann zurück in das Mathcad-Arbeitsblatt zu übertragen.

Zum Erstellen einer Komponente für skriptfähige Objekte gelten folgende Voraussetzungen:

  • Sie benötigen gute Kenntnisse in einer der unterstützten Skript-Sprachen, die im verwendeten System installiert ist.

  • Sie müssen wissen, wie OLE von der anderen Anwendung implementiert wurde.

  • Die andere Anwendung muss im System verfügbar sein.

Zum Einfügen einer Skriptobjekt-Komponente in ein Mathcad-Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Klicken Sie im Arbeitsblatt auf eine leere Stelle. Wenn Sie Werte aus einer Mathcad-Variable an das Objekt senden möchten, müssen Sie auf eine Stelle unterhalb oder rechts der Variablendefinition klicken.

  2. Wählen Sie den Befehl Komponente aus dem Menü Einfügen.

  3. Wählen Sie "Skriptobjekt" in der Liste, und klicken Sie auf "Weiter". Dadurch wird der Setup-Assistent für skriptfähige Objekte gestartet.

  4. In der folgenden Liste werden die im System verfügbaren Anwendungen angezeigt.

  5. Geben Sie an, ob die Komponente eine neue Datei sein soll oder ob Sie eine Datei einfügen möchten, die bereits existiert, und ob in Ihrem Arbeitsblatt die eigentliche Datei oder ein Symbol angezeigt werden soll. Klicken Sie auf die Schaltfläche "Weiter".

  6. Legen Sie die zu verwendende Skript-Sprache, die Art des als Skript zu erstellenden Objekts, den Namen des Objekts und die Anzahl der Ein- und Ausgaben fest, die vom Objekt akzeptiert und verfügbar gemacht werden.

Wenn Sie die Verwendung des Assistenten abgeschlossen haben, wird im Arbeitsblatt eine skriptfähige Komponente mit Platzhaltern für die Ein- und Ausgabevariablen angezeigt. Geben Sie in den unteren Platzhaltern die Eingabevariablen ein. Geben Sie in den Platzhaltern links neben ":=" die Ausgabevariablen ein.

Der letzte Schritt ist die Erstellung des Skripts für die Komponente. Dann verfügen Sie über ein Skript-Objekt im Arbeitsblatt.

Weitere Informationen zur Skriptobjekt-Komponente finden Sie in der Developer's Reference bzw. in der MathConnex-Online-Hilfe.

Sie können Daten zwischen einem Mathcad-Arbeitsblatt und einer beliebigen anderen Anwendung, die OLE-Automatisierung unterstützt, auch dann austauschen, wenn Mathcad keine spezielle Komponente dafür enthält. Die Skriptobjekt-Komponente ermöglicht Ihnen Folgendes:

  • Senden von Werten aus Mathcad an die Anwendung

  • Verwenden der Anwendung zum Bearbeiten der Daten, ohne Mathcad zu verlassen

  • Senden von Werten aus der anderen Anwendung zurück an Mathcad

Hinweis:

Mathcad kann Sie davor schützen, Code in der Skriptobjekt-Komponente zu beschädigen. Standardmäßig werden Sie beim Öffnen eines Arbeitsblattes mit skriptfähigen Komponenten aufgefordert, die Bewertung für diese zu aktivieren bzw. deaktivieren. Das Sicherheitsniveua kann auf der Registerkarte Skriptsicherheit im Dialogfeld Einstellungen festgelegt werden.


Komponente "S-PLUS-Graph"

"S-PLUS" ist eine professionelle Datenanalyse- und Statistikanwendung, die Sie über Insightful beziehen können. Bei der Komponete "S-PLUS-Graph" handelt es sich um ein eingebettetes S-PLUS-Graph-Blatt, mit dessen Hilfe Sie eine große Zahl von zwei- und dreidimensionalen Graphen in Ihr Mathcad-Arbeitsblatt integrieren können.

Zum Einfügen der Komponente "S-PLUS-Graph" in ein Mathcad-Arbeitsblatt ist folgendermaßen vorzugehen:

  1. Erstellen Sie die Felder, aus denen die Daten für die Komponente "S-PLUS-Graph" bezogen werden sollen.

  2. Klicken Sie auf eine leere Stelle Ihres Arbeitsblatts unterhalb oder rechts der Felder.

  3. Wählen Sie den Befehl Komponente aus dem Menü Einfügen.

  4. Wählen Sie aus der Liste die Option "S-PLUS-Graph", und klicken Sie auf "Fertig stellen".

  5. Die Komponente "S-PLUS-Graph" wird daraufhin in Ihr Arbeitsblatt eingefügt. Die so eingefügte Komponente verfügt standardmäßig über einen Platzhalter für eine einzelne Eingabevariable.

  6. Geben Sie in den Platzhalter den bzw. die Namen des Feldes bzw. der Felder ein.

Es wird ein Standardgraph gezeichnet. Sie können jedoch, falls gewünscht, einen anderen Graphtyp auswählen.

Hinweis:

  • Auf Ihrem System muss S-PLUS 4.5 oder höher installiert sein, um eine S-PLUS-Graph-Komponente einfügen zu können.


S-PLUS-Skript (Komponente)

"S-PLUS" ist eine professionelle Datenanalyse- und Statistikanwendung, die Sie über Insightful beziehen können. Mit der Komponente "S-PLUS-Skript" können Sie Programme in S-PLUS 4.5 oder höher schreiben und ausführen lassen und diese mit anderen Berechnungen in Mathcad verknüpfen.

Zum Einfügen der Komponente "S-PLUS-Skript" in ein Mathcad-Arbeitsblatt ist wie folgt vorzugehen:

  1. Klicken Sie auf eine leere Stelle Ihres Arbeitsblatts unterhalb oder rechts von Eingabevariable-Definitionen.

  2. Wählen Sie den Befehl Komponente aus dem Menü Einfügen.

  3. Wählen Sie aus der Liste die Option "S-PLUS-Skript", und klicken Sie auf "Fertig stellen". Die S-PLUS-Komponente wird als leerer Kasten mit der Beschriftung "S-PLUS-Skript" eingefügt.

  4. Geben Sie in den Platzhalter, der unten erscheint, den Namen der Mathcad-Eingabevariable ein, aus der die Daten für die Komponente geholt werden sollen.

  5. Geben Sie in den Platzhalter links der Komponente den Namen der Mathcad-Ausgabevariable ein, die definiert werden soll.

  6. Geben Sie das Skript ein.

Die Mathcad-Eingabevariablen werden standardmäßig als Variablen in0, in1, in2 usw. an die Komponente weitergegeben. Die S-PLUS-Variablen out0, out1, out2 usw. definieren die Ausgabevariablen, die in Mathcad erstellt werden sollen. Zum Ändern dieser Namen gehen Sie folgendermaßen vor:

  1. Wählen Sie im Kontextmenü der Komponente den Befehl Eigenschaften.

  2. Geben Sie in die entsprechenden Felder auf den Registerkarten "Eingabevariablen" und "Ausgabevariablen" die neuen Namen für die Eingabe- und die Ausgabevariablen ein.

Hinweis:

  • Auf Ihrem System muss S-PLUS 4.5 oder höher installiert sein, um eine S-PLUS-Skript-Komponente einfügen zu können.


SmartSketch-Komponente

SmartSketch ist ein von Intergraph entwickeltes Programm zur Erstellung von 2D-Zeichnungen und -Konstruktionen. Mithilfe der SmartSketch-Komponente können Sie in einem Mathcad-Arbeitsblatt SmartSketch-Zeichnungen erstellen und deren Dimensionen mit Ihren Mathcad-Berechnungen mathematisch verknüpfen. Zum Beispiel können Sie mit Ihren Mathcad-Gleichungen die Größe oder die Form einer Zeichnung steuern. Durch die SmartSketch-Komponente ist Mathcad jetzt die ideale Plattform für die Erstellung technischer Abbildungen und datengesteuerter Konstruktionen.

Zum Einfügen einer SmartSketch-Komponente in ein Mathcad-Arbeitsblatt gehen Sie wie folgt vor:

  1. Klicken Sie im Arbeitsblatt auf eine leere Stelle. Wenn Sie Werte aus einer in Ihrem Arbeitsblatt definierten Mathcad-Variable an die Zeichnung senden möchten, müssen Sie unter oder rechts neben die Variablendefinition klicken.

  2. Wählen Sie den Befehl Komponente aus dem Menü Einfügen.

  3. Markieren Sie SmartSketch in der Liste, und klicken Sie auf "Weiter". Die erste Seite des SmartSketch-Komponentenassistenten wird angezeigt.

Um eine SmartSketch-Zeichnung einzufügen, die Sie bereits erstellt haben, wählen Sie "Aus vorhandener Datei", und geben Sie dann entweder den Pfad in das Textfeld ein, oder suchen Sie mithilfe der Schaltfläche "Durchsuchen" nach der Datei, und klicken Sie dann auf "Öffnen". Wählen Sie ansonsten die Option "Neues SmartSketch-Dokument". Die nächste Seite des Assistenten erscheint.

  1. Legen Sie die Anzahl der Eingaben und Ausgaben fest. Wenn Sie eine vorhandene Datei verwenden, geben Sie außerdem die Namen der Variablen, Dimensionen oder Symbole in der Zeichnung an, in die die Eingaben übertragen bzw. aus der die Ausgaben abgerufen werden sollen. Verwenden Sie hierzu die Dropdown-Listenfelder in den Textfeldern neben den einzelnen Eingaben und Ausgaben.

  2. Wenn Sie auf "Fertig stellen" klicken, erscheint in Ihrem Arbeitsblatt die SmartSketch-Komponente mit Platzhaltern für die Eingabevariablen und Ausgabevariablen.

  3. Geben Sie die Namen der Mathcad-Eingabevariablen in die unteren Platzhalter ein. Geben Sie in den Platzhaltern links neben ":=" die Ausgabevariablen ein.

Hinweise:

  • Für Eingabewerte ohne Einheiten werden SI-Einheiten angenommen. Wenn Sie zum Beispiel den Längenwert 2.0 absenden, wird angenommen, dass es sich um 2.0 Meter handelt. SmartSketch wandelt die Werte standardmäßig in die Anzeigeeinheiten um (standardmäßig Zoll) und erstellt die Zeichnung.

  • Die SmartSketch-Komponente kann verwendet werden, wenn bei Ihnen SmartSketch LE for Mathcad (im Mathcad-Lieferumfang enthalten), SmartSketch 3 oder höher, Imagination Engineer oder Imagineer Technical 2 installiert ist.


Speichern und Weitergeben von Komponenten

Wenn Sie mit dem erstellten Skriptobjekt zufrieden sind, können Sie es zur späteren Verwendung als benutzerdefinierte Skriptobjekt-Komponente speichern. Das Skriptobjekt wird als MCM-Datei gespeichert und steht Ihnen, einmal registriert, jederzeit zur Verfügung, wenn Sie Mathcad starten. Sie können die von Ihnen erstellten MCM-Dateien an andere Mathcad-Benutzer weitergeben.

Speichern von Skriptobjekten als benutzerdefinierte Komponenten

Zum Speichern von Skriptobjekten als benutzerdefinierte Komponenten gehen Sie folgendermaßen vor:

  1. Erstellen Sie in Ihrem Mathcad-Arbeitsblatt eine Skriptobjekt-Komponente.

  2. Klicken Sie mit der rechten Maustaste auf die Komponente, und wählen Sie im Kontextmenü den Befehl Als Komponente exportieren.

  3. Geben Sie den Namen der Komponente an, wie er in der Liste "Komponente einfügen" angezeigt werden soll, und legen Sie einen Dateinamen fest. Klicken Sie auf "Weiter".

  4. Geben Sie ein Kennwort ein, wenn Sie verhindern möchten, dass andere Benutzer das Skript der Komponente bearbeiten können, und bestätigen Sie das Kennwort durch nochmalige Eingabe. Klicken Sie auf "Fertig stellen", um die Komponente zu speichern. Dieser Schritt ist optional.

Nachdem Sie Ihre Komponente exportiert (in einer MCM-Datei gespeichert) haben, steht sie Ihnen automatisch auf Ihrem System zur Verfügung. Die Komponente wird in der Liste "Komponente einfügen" angezeigt.

Verwenden benutzerdefinierter Komponenten anderer Benutzer

Zum Verwenden einer in einer MCM-Datei zur Verfügung gestellten Komponente gehen Sie folgendermaßen vor:

  1. Kopieren Sie die MCM-Datei in den MCM-Ordner Ihres Mathcad-Installationsverzeichnisses.

  2. Doppelklicken Sie auf die MCM-Datei, um sie für Mathcad zu registrieren.

  3. Starten Sie Mathcad. Die in der MCM-Datei gespeicherte benutzerdefinierte Komponente wird in Ihrer Liste "Komponente einfügen" angezeigt.

Hinweis:

  • Wenn Sie eine benutzerdefinierte Komponente verwenden, die Ihnen von jemand anderem zur Verfügung gestellt wurde, müssen Sie auch das eingebettete Steuerelement auf Ihrem Computer installiert haben. Wenn Sie beim Einfügen der benutzerdefinierten Komponente Fehlermeldungen erhalten, liegt das wahrscheinlich daran, dass Sie nicht über das eingebettete Steuerelement verfügen. Ist dies der Fall, bitten Sie die Person, von der Sie die benutzerdefinierte Komponente erhalten haben, darum, Ihnen auch die Steuerelementdatei zur Verfügung zu stellen.


MathConnex

Mit den in Mathcad verfügbaren Komponenten wird ein Mathcad-Arbeitsblatt mit anderen Datenquellen und Anwendungen verbunden. Wenn Sie diese Datenquellen und Anwendungen sowohl untereinander als auch mit Mathcad verbinden möchten, können Sie die Anwendung "MathConnex" verwenden.

Zusätzlich zu den in Mathcad verfügbaren Komponenten enthält MathConnex eine Reihe anderer Komponenten zum Verarbeiten von Daten, zum Beispiel eine Mathcad-Komponente zur Herstellung einer Verbindung mit einem Mathcad-Arbeitsblatt. In der MathConnex-Umgebung lassen sich die verfügbaren Komponenten beliebig mit anderen Komponenten verbinden. Sie können visuell Datenflusssysteme erstellen, um Projekte zu analysieren, in denen unterschiedliche Anwendungen und Datenquellen verwendet werden.

Sie können MathConnex wie jede andere Anwendung auch starten. Doppelklicken Sie einfach auf die ausführbare Datei (MathConx.exe) von Ihrer MathConnex-Installation aus, oder gehen Sie über das Startmenü zu dieser Anwendung.


Mathcad als OLE-Automatisierungsserver

Mathcad als Automatisierungsserver

Mit der Automatisierungsschnittstelle von Mathcad können Sie Mathcad von einer anderen Windows-Anwendung aus als OLE-Automatisierungsserver verwenden. Die Automatisierungsschnittstelle von Mathcad ermöglicht Folgendes:

  • Dynamisches Übertragen von Daten zwischen einer anderen Anwendung und Mathcad

  • Verwenden von Mathcad für die Durchführung von Berechnungen oder anderen Manipulationen an Daten

  • Senden der Ergebnisse an die ursprüngliche Anwendung

Um Mathcad als OLE-Automatisierungsserver zu verwenden, sind die folgenden Grundschritte erforderlich:

  1. Einfügen eines Mathcad-Dokuments als OLE-Objekt in einen Automatisierungs-Client

  2. Festlegen, welche Daten an Mathcad weitergegeben werden sollen und/oder der Orte, an denen die aus Mathcad übermittelten Daten platziert werden sollen

  3. Schreiben eines Programms unter Verwendung der Client-Anwendung, um die Variablen im Mathcad-Dokument-Objekt zu definieren und zu erfassen

Hinweise:

  • Die Automatisierungsschnittstelle tritt an die Stelle der DDE-Schnittstelle, die in den Versionen 5 und 6 unterstützt wurde.

  • Weitere Informationen zur Automatisierungsschnittstelle finden Sie in der Developer's Reference (Entwickler-Referenz) im Menü Hilfe.


Statistik und Datenanalyse

Datenanalysefunktionen

Beschreibt Datenanalysefunktionen wie mittelwert, var (Varianz), stdev (Standardabweichung), kurt (Kurtosis) und korr (Korrelation).

Verteilungsfunktionen

Beschreibt die integrierte Gammafunktion, die Fehlerfunktion (fehlf) und die kumulative Normalverteilung sowie viele andere Wahrscheinlichkeitsverteilungsfunktionen.

Zufallszahlen

Beschreibt, wie Zufallszahlen generiert werden und wie man mit ihnen Zufallszahlen mit den verschiedensten Verteilungen generieren kann.

Histogramme

Beschreibt, wie man die Häufigkeitsverteilung von Datenstichproben erhalten kann.

Kombinatorische Analyse

Funktionen zum Zählen von Permutationen und Kombinationen.

Interpolation und Prognose

Beschreibt die lineare und die kubische Spline-Interpolation sowie die lineare Prognose.

Datenglättung

Beschreibt die verschiedenen Wege zur Glättung von verrauschten Daten.

Kurvenanpassung

Beschreibt lineare und nicht lineare Regressionstechniken.


Datenanalysefunktionen

cvar(A,B)

Kovarianz der Elemente in den beiden aus m x n bestehenden Feldern A und B.

korr(A,B)

Pearsonscher Korrelationskoeffizient für die beiden aus m x n bestehenden Felder A und B.

gcd(A,B,C,...)

Größter gemeinsamer Teiler von A, B, C, ...

gmean(A,B,C,...)

Geometrisches Mittel von A, B, C, ...

hmean(A,B,C,...)

Harmonisches Mittel von A, B, C, ...

kurt(v)

Häufigkeitsgrad der Elemente in v.

lcm(A,B,C,...)

Kleinstes gemeinsames Vielfaches von A, B, C, ...

mittelwert(A,B,C,...)

Arithmetisches Mittel von A, B, C, ...

median(A,B,C,...)

Medianwert von A, B, C, ...

mode(A,B,C,...)

Modalität von A, B, C, ...

skew(v)

Asymmetrie der Elemente von v.

qwbspv(A,B,C,...) oder Qwbspv(A,B,C,...)

Standardabweichung einer Population der Werte A,B,C,...

var(A,B,C,...) oder Var(A,B,C,...)

Abweichung einer Population der Werte A,B,C,...


Dichte- und Verteilungsfunktionen

Funktionen für die Arbeit mit allgemeinen Wahrscheinlichkeitsdichten gehören zu folgenden Kategorien:

Wahrscheinlichkeitsdichten

Gibt die Wahrscheinlichkeit an, mit der eine Zufallsvariable einen bestimmten Wert annimmt.

Kumulative Wahrscheinlichkeitsverteilungen

Diese geben die Wahrscheinlichkeit, dass eine Zufallsvariable einen Wert annimmt, der kleiner oder gleich einem festgelegten Wert ist. Diese ergeben sich aus der einfachen Integration (oder gegebenenfalls Summierung) der entsprechenden Wahrscheinlichkeitsdichte über einen geeigneten Zeitraum.

Umgekehrte kumulative Wahrscheinlichkeitsverteilungen

Diese Funktionen haben eine Wahrscheinlichkeit als Argument und geben einen Wert zurück, der angibt, dass die Wahrscheinlichkeit, mit der eine Zufallsvariable kleiner oder gleich diesem Wert ist, der als Argument angegebenen Wahrscheinlichkeit entspricht.

Wählen Sie eine der folgenden Verteilungen:

Beta-Verteilung

Binomialverteilung

Cauchy-Verteilung

Chi-Quadrat-Verteilung

Exponentialverteilung

F-Verteilung

Gammaverteilung

geometrische Verteilung

Hypergeometrische Verteilung

Logarithmische Normalverteilung

Logistische Verteilung

Negative Binomialverteilung

Normalverteilung

Poisson-Verteilung

Studentsche Verteilung (t-Verteilung)

Gleichverteilung

Weibull-Verteilung


Zufallszahlengeneratoren

Die unten aufgeführten Zufallszahlengeneratoren erzeugen aus einem Rekursivwert eine Folge von Quasi-Zufallszahlen. Um eine unterschiedliche Folge von Zufallszahlen zu erzeugen, klicken Sie im Menü Extras auf Arbeitsblattoptionen und ändern Sie auf der Registerkarte Vordefinierte Variablen den Rekursivwert. Sie können auch im Arbeitsblatt die Funktion Rekursivwert aufrufen.

Jede der aufgeführten Verteilungen weist eine Wahrscheinlichkeitsdichte, eine kumulative Wahrscheinlichkeitsverteilug und eine inverse kumulative Wahrscheinlichkeitsverteilung sowie einen der Verteilung zugehörigen Zufallszahlengenerator auf.

Beta-Verteilung

Binomialverteilung

Cauchy-Verteilung

Chi-Quadrat-Verteilung

Exponentialverteilung

F

Gammaverteilung

geometrische Verteilung

Hypergeometrische Verteilung

Lognormalverteilung

logistische Verteilung

negative Binomialverteilung

Normalverteilung

Poisson-Verteilung

Studentsche T-Verteilung

Gleichverteilung

Weibull-Verteilung


Kurvenanpassungsfunktionen

Regression - Kurvenanpassungsfunktionen

Lineare Regression

neigung(vx,vy) und achsenabschn(vx,vy)

Mit diesen Funktionen ermitteln Sie die Steigung und den Achsenabschnitt einer Reihe von Datenpunkten.

line(vx,vy)

Ermittelt die Koeffizienten für eine Linie, die die Daten in den Vektoren vx und vy am besten darstellt.

medanpt(vx,vy)

Ermittelt die Koeffizienten für eine Linie, die die Daten in den Vektoren vx und vy am besten darstellt, mithilfe der Median-Median-Regression.

Polynomregression

regress(vx,vy,k)

Ermittelt das Polynom, das bestimmten Datenpunkten am ehesten entspricht.

loess(vx,vy,span)

Ermittelt die Polynome zweiten Grades, die bestimmten Umgebungen von Datenpunkten am ehesten entsprechen.

Multivariable Polynomregression

regress(Mxy,vz,k)

Ermittelt die Polynomfläche, die bestimmten Datenpunkten am ehesten entspricht.

loess(Mxy,vz,span)

Ermittelt die Polynome zweiten Grades, die bestimmten Umgebungen von Datenpunkten am ehesten entspechen.

Spezielle Regression

expanp(vx,vy,[vg])

Ermittelt die Koeffizienten für eine Exponentialkurve, die die Daten in den Vektoren vx und vy am besten darstellt. vg (optional) enthält Schätzwerte für die drei Koeffizienten.

lgsanp(vx,vy,vg)

Ermittelt die Koeffizienten für eine logistische Kurve, die die Daten in den Vektoren vx und vy am besten darstellt. vg enthält Schätzwerte für die drei Koeffizienten.

sinanp(vx,vy,vg)

Ermittelt die Koeffizienten für eine Sinuskurve, die die Daten in den Vektoren vx und vy am besten darstellt. vg enthält Schätzwerte für die drei Koeffizienten.

loganp(vx,vy,vg)

Ermittelt die Koeffizienten für eine logarithmische Kurve, die die Daten in den Vektoren vx und vy am besten darstellt. vg enthält Schätzwerte für die drei Koeffizienten.

lnfit(vx, vy)

Ermittelt die Parameterwerte für eine logarithmische Kurve, die die Daten in den Vektoren vx und vy am besten darstellt. Ein Vektor der Ansatzwerte wird nicht benötigt.

potanp(vx,vy,vg)

Ermittelt die Koeffizienten für eine Potenzkurve, die die Daten in den Vektoren vx und vy am besten darstellt. vg enthält Schätzwerte für die drei Koeffizienten.

Generalisierte Regression

linamp(vx,vy,F)

Ermittelt die Koeffizienten, bei denen eine lineare Kombination von Funktionen einer Gruppe bestimmter Datenpunkte am ehesten entspricht.

genanp(vx,vy,vg,F)

Ermittelt die Parameter, bei denen eine von Ihnen festgelegte Funktion bestimmten Datenpunkten am ehesten entspricht.


Datenglättung

Bei der Datenglättung wird auf der Grundlage eines Satzes von y- und möglicherweise x-Werten ein neuer Satz von y-Werten ausgegeben, der im Vergleich zum ursprünglichen Satz glatter ist.

medgltt(vy,n)

Gibt einen aus m Elementen bestehenden Vektor zurück, der durch Glätten von vy mit gleitenden Mittelwerten über einem Fenster der Breite n erstellt wird.

kgltt(vx,vy,b)

Gibt einen aus m Elementen bestehenden Vektor zurück, der durch Glätten mithilfe eines Gaußschen Kerns erstellt wird, um gewichtete Mittel der Elemente in vy zurückzugeben.

strgltt(vx,vy)

Gibt einen aus m Elementen bestehenden Vektor zurück, der durch die stückweise Ausführung eines symmetrischen linearen MKQ-Anpassungsverfahrens unter Berücksichtigung des k am nächsten stehenden Nachbarn erstellt wird, wobei k der jeweiligen Situation angepasst wird.


Interpolation und Prognose

In Mathcad stehen Ihnen vier Interpolationsverfahren und ein Verfahren für die lineare Prognose zur Verfügung:

  • Lineare Interpolation: Verbinden von Punkten mit einer geraden Linie

  • Kubische Spline-Interpolation: Verbinden von Punkten mit einem kubischen Abschnitt

  • B-Spline-Interpolation: Verbinden von Punkten mit Polynomen eines bestimmten Grades an gegebenen Knoten

  • Multivariable kubische Spline-Interpolation: Erstellen einer Fläche durch ein Punktgitter

  • Lineare Prognose: Bestimmen von Werten über einen bestimmten Datensatz hinaus


X-Y-Diagramme

X-Y-Diagramme sind optimal zum Abbilden von Funktionen, mathematischen Ausdrücken und Datensätzen (gespeichert in Vektoren) geeignet.

Wenn Sie ein X-Y-Diagramm erstellt haben, können Sie es beliebig formatieren. Mathcad ermöglicht außerdem das Vergrößern von Teilen eines X-Y-Diagramms oder die Extrahierung der Koordinaten aus einem bestimmten Punkt.

Weitere Informationen:

Erstellen eines Diagramms

Grafisches Darstellen von mehreren Ausdrücken

Darstellen von Daten in Diagrammen

Ändern der Größe eines Diagramms

Achsenbegrenzungen

Achseneinstellungen

Achsenbeschriftungen

Spureinstellungen

Legenden

Vergrößern

Ablesen von Koordinaten

Titel in Diagrammen

Standardeinstellungen

Animieren eines X-Y-Diagramms


Kreisdiagramme

Mit den Kreisdiagrammen von Mathcad können Sie winkelabhängige mathematische Ausdrücke, Funktionen und Datensätze (gespeichert in Vektoren) abbilden. Wenn Sie ein Kreisdiagramm erstellt haben, können Sie es nach Wunsch formatieren. Mathcad ermöglicht außerdem die Vergrößerung von Teilen eines Kreisdiagramms oder das Ablesen der Koordinaten eines bestimmten Punkts.

Erstellen eines Diagramms

Grafisches Darstellen von mehreren Ausdrücken

Grafisches Darstellen von Daten

Ändern der Größe eines Diagramms

Achsenbegrenzungen

Achseneinstellungen

Spureinstellungen

Legenden

Vergrößern

Ablesen von Koordinaten

Titel in Diagrammen

Standardeinstellungen

Animieren eines Kreisdiagramms


3D-Diagramme (Überblick)

Sie können für die Darstellung dreidimensionaler Daten die folgenden Arten von Diagrammen erstellen:

Fläche

Parametrische Fläche

Umriss

3D-Streuung

3D-Säulendiagramm

Vektorfeld

Diese können nach Wunsch formatiert und bearbeitet werden. Sie können außerdem mehrere 3D-Diagramme kombinieren oder beliebige der einheitlichen Polyeder darstellen.


Flächendiagramme

Bei der Erstellung eines Flächendiagramms setzt Mathcad eine Datenmatrix als Fläche in einem dreidimensionalen Diagramm um. Sie haben viele Formatierungsmöglichkeiten zum Verändern der Darstellung des Diagramms. Außerdem können Sie Flächendiagramme in einen anderen dreidimensionalen Diagrammtyp umwandeln.

Weitere Informationen:

    • Erstellen eines Flächendiagramms

    • Parametrische Flächendiagramme

    • Farbeinstellungen

    • Linieneinstellungen

    • Punkteinstellungen

    • Achseneinstellungen

    • Hintergrundebeneneinstellungen

    • Beleuchtungseinstellungen

    • Erweiterte Ansichtseinstellungen

    • Zoom

    • Rotieren oder Drehen eines Bilds...

    • Anmerkungen zu einem 3D-Diagramm


Umrissdiagramme

Für Umrissdiagramme muss eine Matrix aus Werten vorliegen, die von Mathcad linear interpoliert werden, um daraus Niveaulinien zu erstellen. Bei diesen Niveaulinien kann es sich z. B. um Isotherme, Isobare, Äquipotentialkurven, Stromlinien und viele andere physikalische Phänomene handeln. Sie können die Darstellungsweise eines Umrissdiagramms über die Formatierung gestalten. Darüber hinaus besteht die Möglichkeit, ein Umrissdiagramm in ein anderes 3D-Diagramm umzuwandeln.

Weitere Informationen:

  • Erstellen eines Umrissdiagramms

  • Anzeigen der x- oder y-Umrisse

  • Farbeinstellungen

  • Linieneinstellungen

  • Punkteinstellungen

  • Achseneinstellungen

  • Hintergrundebeneneinstellungen

  • Beleuchtungseinstellungen

  • Erweiterte Ansichtseinstellungen

  • Zoom

  • Rotieren oder Drehen eines Bildes...

  • Anmerkungen zu einem 3D-Diagramm


3D-Säulendiagramme

Mit dreidimensionalen Säulendiagrammen können Sie eine Matrix von Daten in Form von Balken unterschiedlicher Höhe darstellen. Die Darstellungsweise des Diagramms kann durch verschiedene Formatierungen bestimmt werden. Sie können ein 3D-Säulendiagramm auch in einen anderen Typ von 3D-Diagramm umwandeln.

Weitere Informationen:

  • Erstellen eines 3D-Säulendiagramms

  • Säulenlayouteinstellungen

  • Farbeinstellungen

  • Linieneinstellungen

  • Punkteinstellungen

  • Achseneinstellungen

  • Hintergrundebeneneinstellungen

  • Beleuchtungseinstellungen

  • Erweiterte Ansichtseinstellungen

  • Zoom

  • Rotieren oder Drehen eines Bilds...

  • Anmerkungen zu einem 3D-Diagramm


3D-Streuungsdiagramme

Mit dreidimensionalen Streuungsdiagrammen können Sie x-, y- und z-Koordinaten räumlich abbilden. Deshalb sind sie hervorragend dazu geeignet, parametrische Kurven zu zeichnen oder Datengruppen im dreidimensionalen Raum darzustellen. Sie können das Symbol und die Farbe festlegen, das bzw. die für die Darstellung der Datenpunkte verwendet wird bzw. werden, und Sie können bestimmen, ob die Punkte mit einer Linie verbunden werden. Sie können auch ein dreidimensionales Streuungsdiagramm in einen anderen Typ von 3D-Diagramm ändern.

Weitere Informationen:

  • Erstellen eines 3D-Streuungsdiagramms aus einer Funktion

  • Erstellen eines 3D-Streuungsdiagramms aus 3 Datenvektoren

  • Erstellen eines 3D-Streuungsdiagramms aus einer Matrix von Datenwerten

  • Erstellen einer räumlichen Kurve

  • Punkteinstellungen

  • Linieneinstellungen

  • Achseneinstellungen

  • Hintergrundebeneneinstellungen

  • Beleuchtungseinstellungen

  • Erweiterte Ansichtseinstellungen

  • Zoom

  • Rotieren oder Drehen eines Bildes...

  • Anmerkungen zu einem 3D-Diagramm


Vektorfelddiagramme

Ein Vektorfeld ist mit einer Funktion vergleichbar, von der einem Punkt in der Ebene ein Vektor zugewiesen wird, der an einem bestimmten Punkt beginnt. Sie können ein zweidimensionales Vektorfelddiagramm in Mathcad über eine Matrix mit komplexen Zahlen erstellen. Die Ausgangspunkte der einzelnen Vektoren liegen auf den x- und y-Werten entsprechend den Zeilen und Spalten der Matrix. Die Größe und Richtung jedes Vektors richtet sich nach den reellen und imaginären Teilen der Matrixelemente.

Weitere Informationen:

    • Erstellen eines Vektorfelddiagramms

    • Farbeinstellungen

    • Linieneinstellungen

    • Punkteinstellungen

    • Achseneinstellungen

    • Hintergrundebeneneinstellungen

    • Beleuchtungseinstellungen

    • Erweiterte Ansichtseinstellungen

    • Zoom

    • Rotieren oder Drehen eines Bilds...

    • Anmerkungen zu einem 3D-Diagramm


Abbilden mehrerer 3D-Diagramme

Zum Abbilden mehrerer 3D-Diagramme in einem Diagramm gehen Sie folgendermaßen vor:

  1. Definieren Sie die Argumente (Matrizen oder Vektoren), die für die abzubildenden Diagramme erforderlich sind.

  2. Wählen Sie den Befehl Diagramm aus dem Menü Einfügen. Wählen Sie die Art von 3D-Diagrammen, die Sie zuerst erstellen möchten.

  3. Geben Sie im Platzhalter des 3D-Diagrammoperators die Argumente für das erste 3D-Diagramm ein.

  4. Geben Sie ein Komma ein.

  5. Geben Sie die Argumente für das nächste 3D-Diagramm ein.

  6. Geben Sie weitere durch Kommas abgetrennte Argumente ein. Wenn für 3D-Diagramme mehrere Argumente erforderlich sind, müssen sie in Klammern gesetzt werden.

  7. Drücken Sie die [Eingabetaste], oder klicken Sie auf eine Stelle außerhalb des Diagrammbereichs.

  8. Doppelklicken Sie auf das Diagramm, damit das Dialogfeld 3D-Diagrammformat geöffnet wird. Geben Sie über den Abschnitt Darstellungsart und die Registerkarten Diagramm 1, Diagramm 2 usw. an, wie die Argumentsätze angezeigt werden sollen.


Übersicht über das symbolische Rechnen

Über symbolisches Rechnen erhalten Sie eine Antwort nichtnumerischer Natur auf ein Problem. So können Sie z. B. eine Gleichung nach der Variable x in Bezug auf y auflösen, ohne y numerisch zu definieren.

Symbolische Berechnungen können auf zweierlei Arten durchgeführt werden:

  1. Sie verwenden das symbolische Gleichheitszeichen, sodass die Ergebnisse ständig aktualisiert werden.

  2. mithilfe der Menübefehle im Menü Symbolik.

Die Entscheidung, welches Verfahren Sie verwenden sollten, hängt davon ab, ob Sie ständig aktualisierte Ergebnisse benötigen. Wenn Mathcad einen Ausdruck mithilfe der in Ihrem Arbeitsblatt verwendeten numerischen Definitionen symbolisch auswerten soll, verwenden Sie das symbolische Gleichheitszeichen. In allen anderen Fällen verwenden Sie die Menübefehle aus dem Menü Symbolik.

Folgende Berechnungen können symbolisch ausgeführt werden:

  • Algebra

  • Symbolleiste "Differential/Integral"

  • Lösen

  • Matrixmanipulationen

  • Transformationen

  • Die meisten Operationen mit einem Operator oder einer Funktion


Symbolisches Auswerten mit Menübefehlen

Zum symbolischen Auswerten eines Ausdrucks stehen Ihnen u. a. die Befehle im Menü Symbolik zur Verfügung. Bei der Arbeit mit dem Menü Symbolik funktionieren alle algebraischen Transformationen grundsätzlich nach dem gleichen Muster:

  1. Wählen Sie den Ausdruck aus (entweder ganz oder nur Teile davon).

  2. Wählen Sie den entsprechenden Befehl im Menü Symbolik.

Danach wird der transformierte Ausdruck im Arbeitsblatt angezeigt. Je nachdem, welches Auswertungsformat Sie eingestellt haben, ersetzt der transformierte Ausdruck entweder den gewählten Ausdruck, oder er wird unterhalb oder rechts neben den bisherigen Ausdruck eingefügt. Verläuft die symbolische Transformation erfolglos, bleibt der neue Ausdruck mit dem alten identisch.

Hinweis:

  • Für alle Variablen und Ausdrücke wird angenommen, dass sie reelle Werte enthalten. Soll jedoch davon ausgegangen werden, dass es sich um komplexe Zahlen handelt, verwenden Sie die aktive symbolische Auswertung mit dem Schlüsselwort "komplex".

  • Zu beachten ist, dass beim symbolischen Rechnen mit Menübefehlen keine automatische Aktualisierung der Transformation erfolgt, wenn Sie Änderungen am Arbeitsblatt vornehmen. Sollen beim symbolischen Rechnen Transformationen aktualisiert werden, müssen Sie daher mit der aktiven symbolischen Auswertung arbeiten.


Symbolische Auswertung mithilfe des symbolischen Gleichheitszeichens

Zur symbolischen Auswertung von Ausdrücken müssen Sie das symbolische Gleichheitszeichen verwenden. Gehen Sie hierzu folgendermaßen vor:

  1. Geben Sie den Ausdruck ein, der symbolisch ausgewertet werden soll.

  2. Drücken Sie Strg+Punkt, um den Pfeil nach rechts einzufügen, der das symbolische Gleichheitszeichen darstellt.

  3. Drücken Sie die Eingabetaste.

Standardmäßig übergibt das symbolische Gleichheitszeichen zwar denselben Ausdruck wie die Option Symbolisch auswerten im Menü Symbolik, es berücksichtigt jedoch andere Definitionen im Arbeitsblatt. Sie können jedoch die Bedeutung des symbolischen Gleichheitszeichens ändern, indem Sie es mit einem Schlüsselwort modifizieren.


Ändern des symbolischen Auswertungsoperators

Wenn Sie einen Ausdruck auf die eine oder andere Weise symbolisch auswerten möchten, stellen Sie dem Auswertungsoperator ein Schlüsselwort voran. Gehen Sie hierzu folgendermaßen vor:

  1. Geben Sie den Ausdruck ein, der symbolisch ausgewertet werden soll.

  2. Drücken Sie [Strg]+[Umschalt]+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie ein Schlüsselwort in den Platzhalter ein oder wählen Sie ein Schlüsselwort aus der Symbolleiste "Symbolik" aus. Wird für das Schlüsselwort ein weiteres Argument benötigt, geben Sie ein Komma und dann das Argument ein. Trennen Sie mehrere Argumente durch Kommas voneinander ab.

  4. Drücken Sie die Eingabetaste.

Der symbolische Prozessor gibt ein Ergebnis aus, das vom eingegebenen Schlüsselwort abhängt. Sie können dieses Ergebnis weitergehend symbolisch auswerten, indem Sie mehrere Schlüsselwörter verwenden.


Symbolische Algebra

Vereinfachen

Entwickeln von Ausdrücken

Faktorisieren

Zusammenfassen von Termen

Ermitteln der Koeffizienten eines Polynoms

Reihen

Partialbruchzerlegung

Symbolische Summen und Produkte


Symbolische Differential- und Integralrechnung

Symbolische Ableitungen

Symbolische Integrale

Grenzwerte


Symbolisches Lösen von Gleichungen

Symbolisches Lösen einzelner Gleichung

Symbolisches Lösen von Gleichungssystemen


Symbolische Matrizenalgebra

Matrizenalgebra

Transponieren von Matrizen

Invertieren von Matrizen

Ermitteln der Determinante einer Matrix


Symbolische Transformationen

Übersicht

Fourier-Transformationen

Laplace-Transformationen

z -Transformationen

Fourier invers

Laplace invers

Z invers


Umgang mit Funktionen und Variablen bei symbolischen Berechnungen

Vordefinierte Funktionen

Die meisten vordefinierten Funktionen behalten ihre Bedeutung in symbolischen Berechnungen bei. Einige integrierte Funktionen haben im Zusammenhang mit symbolischen Berechnungen keine vernünftige Bedeutung und werden daher auch nicht ausgewertet. Dies trifft z. B. auf die statistischen Funktionen wie linterp oder rnd zu.

Vordefinierte Konstanten

Der symbolische Prozessor erkennt p, e und [image] , da diese Konstanten eine allgemein anerkannte mathematische Bedeutung haben. Andere vordefinierte Konstanten, wie z. B. TOL und ORIGIN, haben keine solche Bedeutung und werden daher nicht ausgewertet.

Benutzerdefinierte Funktionen und Variablen

Der symbolische Prozessor erkennt benutzerdefinierte Funktionen und Variablen nur dann, wenn Sie sie mit dem symbolischen Gleichheitszeichen auswerten.


Einheiten und Dimensionen (Übersicht)

Einheiten und Dimensionen

Eine vollständige Reihe von Einheiten steht für Ihre Berechnungen zur Verfügung. Sie können Ihren Variablen diese vordefinierten Einheiten zuweisen oder eigene Einheiten definieren und zuweisen. Mathcad überprüft die Einheitlichkeit der Dimensionen und zeigt die Ergebnisse automatisch in den Einheiten des gewählten Einheitensystems an.

    • Liste der vordefinierten Einheiten

    • Einfügen vordefinierter Einheiten

    • Zuweisen von Einheiten zu einer Variable

    • Umrechnen von Einheiten

    • Formatieren von Einheiten

    • Vereinfachen von Einheiten

    • Festlegen des Einheitensystems

    • Umbenennen von Dimensionen

    • Definieren neuer Einheiten


Liste der vordefinierten Einheiten

Vordefinierte Einheiten

Dies ist die vollständige Liste der verfügbaren integrierten Einheiten. Mit Ausnahme der unterstrichenen Einheiten sind alle Einheiten in mindestens einem der Systeme SI, MKS, CGS oder US verfügbar. Eine Liste der derzeit verfügbaren Einheiten finden Sie im Dialogfeld "Einheit einfügen", wenn Sie den Befehl "Einheit" aus dem Menü Einfügen wählen.

A

acre

amp

atm

bhp

Bq

BTU

BTU15

c

C

cal

cal15

cal20

CBTU

cd

cm

coul

day

dcal

grad

dyn

Ehp

Erg

F

farad

fl_oz

ft

g

gal

galUK

Gauss

GHz

gm

Gy

H

hectare

henry

hhp

hp

hpUK

hr

Hz

Hza

IBTU

in

in_Hg

J

joule

K

K

kA

KA

kcal

kg

kgf

kHz

KHz

km

kmph

kV

KV

kW

L

lb

lbf

liter

lm

lx

m

mBTU

mcal

mA

mg

mH

mho

MHz

mi

min

mL

mm

Mol

mph

mV

N

Newton

nF

W

Oe

oersted

ohm

oz

Pa

pF

poise

psi

R

rad

S

s

sec

siemens

slug

statamp

statcoul

statfarad

stathenry

statohm

statsiemens

stattesla

statvolt

statweber

stokes

str

Sv

T

tBTU

tcal

tesla

tons

tonne

torr

V

volt

W

watt

Wb

weber

yd

yr


Einfügen von vordefinierten Einheiten

Eine einfache Möglichkeit zum Einfügen einer vordefinierten Einheit steht mit dem Dialogfeld Einheit einfügen zur Verfügung. Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie den Befehl Einheit aus dem Menü Einfügen, um das Dialogfeld Einheit einfügen zu öffnen.

  2. Suchen Sie die gewünschte Einheit aus der Einheiten-Auswahlliste rechts heraus. Sollen nur die Einheiten angezeigt werden, die für eine bestimmte physikalische Menge gelten, verwenden Sie die Auswahlliste auf der linken Seite.

  3. Doppelklicken Sie auf den Namen der gewünschten Einheit.


Verbinden einer Einheit mit einer Variablen oder Konstanten

Zum Verbinden einer Einheit mit einer Variablen oder Konstanten müssen Sie die Variable oder Konstante nur mit der Einheit multiplizieren. Klicken Sie auf die Schaltflächen unten, um ein Beispiel Schritt für Schritt durchzugehen:

  1. Klicken Sie auf die Variable oder Konstante.

  2. Drücken Sie die Taste "*", um das Multiplikationszeichen und einen Platzhalter einzufügen.

  3. Geben Sie in den Platzhalter den Namen einer Einheit ein, oder wählen Sie den Befehl "Einheit" aus dem Menü Einfügen.

Wenn Sie eine Einheit in den Einheitenplatzhalter eingeben, dividiert Mathcad den Wert, der angezeigt werden soll, durch die Eingabe im Platzhalter. Dadurch wird gewährleistet, dass das gesamte angezeigte Ergebnis (also die Zahl multipliziert mit dem Ausdruck, der für den Platzhalter eingegeben wurde) den korrekten Wert für die Gleichung angibt.


Umrechnen von Einheiten

Mathcad zeigt Ergebnisse automatisch in den Grundeinheiten des gewählten Einheitensystems an. Allerdings können Sie die Ergebnisse auch in den vordefinierten Einheiten von Mathcad anzeigen lassen.

Das Beispiel unten zeigt, wie Sie ein Einzelergebnis in Einheiten umwandeln, die keine Grundeinheiten sind. Dabei wird davon ausgegangen, dass dem Ergebnis bereits eine Einheit zugewiesen ist. Ist dies nicht der Fall, bleibt eine Umwandlung von Einheiten völlig wirkungslos. Sie müssen den Ausdruck, der das Ergebnis ausgibt, Einheiten zuweisen. Wenn Sie auf die Schaltflächen unten klicken, wird Schritt für Schritt ein Beispiel für die Umwandlung von Einheiten angezeigt.

  1. Klicken Sie in das Ergebnis, damit der Einheitenplatzhalter angezeigt wird.

  2. Klicken Sie auf den Einheitenplatzhalter.

  3. Geben Sie eine Kombination von Einheiten in den Einheitenplatzhalter ein, oder wählen Sie den Befehl Einheit aus dem Menü Einfügen, und klicken Sie in der angezeigten Liste auf eine Einheit.

  4. Klicken Sie auf eine Stelle außerhalb des Ausdrucks, um das Ergebnis in den ausgewählten Einheiten neu anzeigen zu lassen.


Formatieren angezeigter Einheiten

Soll das Ergebnis als Bruch angezeigt werden, gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf die Einheit, um das Dialogfeld Ergebnisformat zu öffnen.

  2. Klicken Sie auf die Option Einheiten formatieren, um sie zu aktivieren.

  3. Klicken Sie auf OK.

Beispiel:

wird beim Formatieren folgendermaßen umgeformt:

Hinweis: Sollen alle Einheiten in einem Arbeitsblatt automatisch vereinfacht werden, klicken Sie im Dialogfeld Ergebnisformat zuerst auf Als Standard, bevor Sie auf Einheiten formatieren klicken.


Festlegen des Einheitensystems

Soweit nicht anders vorgegeben, werden die Ergebnisse in den grundlegenden SI-Einheiten, m, kg, s, K, A, cd und mol wiedergegeben. Zum Festlegen eines anderen Einheitensystems gehen Sie vor wie folgt:

  1. Wählen Sie den Befehl Arbeitsblattoptionen im Menü Extras, und klicken Sie im Dialogfeld auf die Registerkarte "Einheitensystem".

  2. Klicken Sie auf das gewünschte standardmäßige Einheitensystem.

Wenn Sie die Option Kein für das Einheitensystem festlegen, können Sie Ihre eigenen Einheiten definieren und verwenden. Hierzu legen Sie die gewünschten Einheiten in Form von speziellen integrierten Konstanten (1L, 1M, 1T, 1Q, 1K, 1C und 1S) fest, die für die Dimensionen Länge, Masse, Zeit, Ladung oder Strom, absolute Temperatur, Leuchtstärke und Stoff stehen. Zum Beispiel können Sie die Definitionen kg:=1M, sek:=1T und m:=1L festlegen.


Definieren einer Einheit

Da bereits zahlreiche vordefinierte Einheiten vorhanden sind, kommt es nur selten vor, dass Sie eigene Einheiten definieren müssen. Sie können jedoch bei Bedarf Einheiten auf die gleiche Weise wie eine Variable definieren:

1. Geben Sie den Namen der Einheit ein, die Sie definieren möchten. Beispiel:

2. Drücken Sie die Taste ":", um das Zeichen ":=" einzufügen.

3. Geben Sie im Platzhalter die Einheit oder Einheitenkombination ein, die für Ihre neue Einheit gelten soll. Beispiel:

Danach steht die neue Einheit unterhalb und rechts ihrer Definition überall zur Verfügung.


Umbenennen von Dimensionen

Standardmäßig werden Ergebnisse als m, kg, s, A, K, cd und mol wiedergegeben. Sollen die Angaben als meter, kilogramm, s und Grad ausgeschrieben werden, gehen Sie folgendermaßen vor:

  1. Wählen Sie den Befehl Arbeitsblattoptionen aus dem Menü Extras, und klicken Sie auf die Registerkarte "Dimensionen".

  2. Klicken Sie auf das Kontrollkästchen “Dimensionen anzeigen”.

  3. Überschreiben Sie die Namen in den entsprechenden Textfeldern mit den gewünschten Dimensionsnamen, und klicken Sie auf OK.

Das Umbenennen der Dimensionen kann sinnvoll sein, wenn Sie für Ihre Arbeit andere Einheiten benötigen. Ein Autohändler könnte so LKW und PKW anstellen von Länge und Masse definieren. Eine Dimension ist also einfach eine Möglichkeit, Zahlen mit Bezeichnungen zu versehen, damit sie leichter zugeordnet werden können.


Was ist ein Programm?

Als Programm wird ein Ausdruck bezeichnet, der aus mehr als einer Anweisung besteht. Unten ist ein einzelner Ausdruck und derselbe Ausdruck als Programm geschrieben dargestellt:

Trotz der grundlegenden Äquivalenz zwischen Programmen und einfachen Ausdrücken bieten Programme zwei entscheidende Vorteile:

  • Wenn Sie Strukturen wie Schleifen und bedingte Verzweigungen kontrollieren, können Sie ein Programm weit flexibler gestalten, als dies bei einem Ausdruck möglich wäre.

  • Ein aus mehreren einfachen Schritten bestehendes Programm ist oft leichter zu erstellen als ein entsprechender, aber weit komplexerer Ausdruck mit vielen Klammern.


Bedingungsanweisungen

Mit einer bedingten Anweisung können Sie immer dann eine Programmanweisung ausführen, wenn bestimmte Bedingungen erfüllt sind. Zum Einfügen einer Bedingungsanweisung gehen Sie wie folgt vor:

  1. Klicken Sie auf den Platzhalter, in den Sie die Bedingungsanweisung einfügen möchten.

  2. Klicken Sie auf [image] auf der Symbolleiste "Rechnen", um die Symbolleiste "Programmierung" zu öffnen, welche die Programmierungsoperatoren enthält.

  3. Klicken Sie auf die Schaltfläche if, oder drücken Sie [Umschalt] + ]. Geben Sie nicht einfach "if" ein.

  4. Geben Sie in den rechten Platzhalter einen Booleschen Ausdruck ein.

  5. Fügen Sie mit der Schaltfläche +1 Zeile gegebenenfalls Platzhalter für weitere Anweisungen ein.

  6. Klicken Sie auf den anderen Platzhalter, und klicken Sie auf die Schaltfläche otherwise. Geben Sie nicht einfach "otherwise" ein.

  7. Geben Sie in den verbleibenden Platzhalter den Wert ein, den das Programm ausgeben soll, wenn die Bedingung den Wert "falsch" aufweist.

Hinweis:

Wenn Sie vor einer "otherwise"-Anweisung mehrere "if"-Anweisungen einfügen, wird die "otherwise"-Anweisung nur dann ausgeführt, wenn alle Bedingungen den Wert "falsch" aufweisen.


"break"-Anweisung

Fügen Sie die "break"-Anweisung in eine Schleife ein, wenn Sie die Ausführung der Schleife an einem bestimmten Punkt abbrechen möchten. Kommt es zu einem "break" in einem oberen Bereich des Programms, ist dies ähnlich wie eine Rückgabe, mit dem Unterschied, dass der Wert des letzten ausgeführten Satzes zurückgegeben wird.

Zum Einfügen einer "break"-Anweisung gehen Sie wie folgt vor:

  1. Klicken Sie in den Platzhalter, in den Sie die "break"-Anweisung setzen möchten.

  2. Klicken Sie in der Symbolleiste "Rechnen" auf [image], um die Symbolleiste "Programmierung" zu öffnen, die die Programmieroperatoren enthält.

  3. Klicken Sie auf die Schaltfläche "break", oder drücken Sie Strg+{. Geben Sie nicht nur das Wort "break" ein.


Programmschleifen

Eine Schleife ist eine Programmanweisung, mit der eine Anweisung oder mehrere Anweisungen (Hauptteil der Schleife) wiederholt ausgeführt werden können, bis eine bestimmte Bedingung eintritt. Es gibt zwei verschiedene Arten von Schleifen:

  • "For"-Schleifen sind dann empfehlenswert, wenn Sie genau wissen, wie oft der Hauptteil der Schleife ausgeführt werden soll.

  • "While"-Schleifen sind empfehlenswert, wenn Sie die Ausführung bei Eintritt einer Bedingung beenden möchten, ohne dass Sie im voraus wissen, wann diese Bedingung eintreten wird.

Bei der Verwendung von Schleifen kann es notwendig sein, sie zu unterbrechen oder bestimmte Durchläufe zu steuern.


Ausgeben eines Wertes aus einem Programm

Standardmäßig wird von Programmen der Inhalt der letzten Zeile ausgegeben. Sie können mithilfe des return-Operators jedoch auch einen Wert aus einem anderen Programmbereich ausgeben lassen.

Zum Einfügen eines return-Operators gehen Sie wie folgt vor:

  1. Klicken Sie auf den Platzhalter, der den return-Operator enthalten soll.

  2. Klicken Sie auf [image] auf der Symbolleiste "Rechnen", um die Symbolleiste "Programmierung" zu öffnen, die die Programmierungsoperatoren enthält.

  3. Klicken Sie auf die Schaltfläche return, oder drücken Sie [Strg] + |. Geben Sie nicht einfach das Wort "return" ein.

  4. Geben Sie im Platzhalter rechts neben "return" den Ausdruck ein, der ausgegeben werden soll.

"Return"-Anweisungen werden verwendet, wenn ein Wert aus einer bestimmten Schleife zurückgegeben werden soll oder in einem Programm nach Fehlern gesucht wird.


Zurückverfolgen von Fehlern in einem Programm

Wenn Sie beim Erkennen eines Fehlers in einem Ausdruck einen Alternativwert ausgeben möchten, verwenden Sie den Programmieroperator on error:

  1. Klicken Sie auf den Platzhalter, in den Sie die on error-Anweisung einfügen möchten.

  2. Klicken Sie auf [image] auf der Symbolleiste "Rechnen", um die Symbolleiste "Programmierung" zu öffnen, die die Programmierungsoperatoren enthält.

  3. Klicken Sie auf die Schaltfläche on errror, oder drücken Sie [Strg] + '. Geben Sie nicht einfach die Worte "on error" ein.

  4. Geben Sie im Platzhalter rechts neben "return" den Ausdruck ein, der ausgegeben werden soll.

  5. Geben Sie im Platzhalter links neben "on error" den Ausdruck ein, der ausgegeben werden soll, wenn der Standardausdruck für die Ausgabe nicht ausgewertet werden kann. Fügen Sie mit der Schaltfläche + 1 Zeile gegebenenfalls Platzhalter für weitere Anweisungen ein.

  6. Der Ausdruck auf der rechten Seite wird ausgewertet und, soweit kein Fehler auftritt, ausgegeben. Tritt ein Fehler auf, wird das Argument auf der linken Seite ausgegeben.


Symbolisches Auswerten eines Programms

Gehen Sie folgendermaßen vor, wenn Sie ein Programm definiert haben, das Sie symbolisch auswerten möchten:

  1. Geben Sie den Namen der programmspezifisch definierten Funktion oder Variablen ein.

  2. Drücken Sie Strg +Punkt, um den nach rechts gerichteten Pfeil einzufügen, der das symbolische Gleichheitszeichen darstellt.

Hinweis:

Ein Programm kann nur dann symbolisch ausgewertet werden, wenn keine Einheiten verwendet werden. Wenn ein Programm zur Auswertung Einheiten verwendet, sollte es nicht symbolisch ausgewertet werden.


Animationen (allgemein)

Animationen stellen ein sehr nützliches Instrument für die direkte und visuelle Überprüfung der numerischen Ausgabe dar. In Mathcad erstellen Sie Animationen mithilfe einer FRAME genannten Variable in Ihren Gleichungen. Mathcad erstellt daraufhin ein Video, indem eine Sequenz aus einzelnen "Momentaufnahmen" ("Bilder" oder "Frames" genannt) aufgezeichnet wird. Für jeden Wert von FRAME im angegebenen Bereich wird der Reihe nach ein solches Bild generiert.

Erstellen von Animationen

Wiedergeben von Animationen

Speichern von Animationen


Erstellen von Animationen

Sie können beliebige Bereiche animieren, die von der Variablen FRAME abhängen. Gehen Sie hierzu folgendermaßen vor:

  1. Erstellen Sie einen Bereich, dessen Aussehen von FRAME abhängt.

  2. Stellen Sie sicher, dass sich das Arbeitsblatt im automatischen Modus befindet.

  3. Wählen Sie Animation aus dem Menü Extras, um das Dialogfeld "Animieren" zu öffnen.

  4. Umschließen Sie die Bereiche, die animiert werden sollen, mit einem Markierungsrechteck.

  5. Geben Sie im Dialogfeld die Anfangs- und Endwerte für FRAME ein.

  6. Klicken Sie auf "Animieren".

Im Dialogfeld wird eine Miniaturvorschau der Animation angezeigt. Mathcad zeichnet diese für jeden FRAME-Wert neu. Diese Vorschau-Animation entspricht nicht zwingend der Wiedergabegeschwindigkeit, da Sie zu diesem Zeitpunkt die Animation lediglich erstellen, sie aber noch nicht wiedergeben.

Hinweis:

Bei der Animation von Diagrammen empfiehlt es sich, die Achsenbegrenzungen selbst festzulegen und auf eine automatische Festlegung zu verzichten. Werden die Achsenbegrenzungen automatisch festgelegt, erfolgt für jedes Bild der Animation ein Rücksetzen der Werte. Auf diese Weise ändert sich in Ihrer Animation nicht das Diagramm von Bild zu Bild, sondern es ändern sich nur die Achsenbegrenzungen.


Wiedergeben von Animationen

Nachdem Sie die Animation erstellt haben, wird im Dialogfeld "Wiedergeben" das erste Bild der Animation angezeigt. Jetzt können Sie die folgenden Schritte ausführen:

  • Wiedergeben der gesamten Animation durch Klicken auf die Wiedergabeschaltfläche

  • Anzeigen von Einzelbildern mithilfe des Schiebereglers.


Speichern von Animationen

Nachdem Sie eine Animation erstellt haben, können Sie sie speichern. Sie können die Animation zu einem späteren Zeitpunkt wiedergeben lassen, ohne sie dazu zuvor noch einmal aufzeichnen zu müssen. Zum Speichern der Animation als Windows-AVI-Datei ist wie folgt vorzugehen:

  1. Das Dialogfeld "Animieren" muss geöffnet sein. (Sie öffnen das Dialogfeld mithilfe des Befehls Animation aus dem Menü Extras.)

  2. Stellen Sie sicher, dass das erste Bild der Animation, die gespeichert werden soll, im Dialogfeld angezeigt wird.

  3. Ändern Sie erforderlichenfalls die Komprimierungsmethode für das Speichern der Dateien, indem Sie auf die Schaltfläche Optionen klicken.

  4. Klicken Sie auf die Schaltfläche "Speichern unter".


Wiedergeben einer zuvor gespeicherten Animation

Gehen Sie zum Wiedergeben einer zuvor gespeicherten Animation (bzw. einer Windows AVI-Datei) wie folgt vor:

  1. Wählen Sie Animation aus dem Menü Extras, um das Wiedergabefenster zu öffnen.

  2. Klicken Sie auf die Schaltfläche [image] .

  3. Wählen Sie Öffnen aus dem eingeblendeten Menü.

  4. Doppelklicken Sie auf den Namen der Animation, die geöffnet werden soll.

  5. Geben Sie die gesamte Animation durch Klicken auf die Wiedergabeschaltfläche wieder oder

  6. zeigen Sie die Einzelbilder nacheinander mithilfe des Schiebereglers an.


Importieren von Grafiken

Importieren von Grafiken (Übersicht)

Sie können zwar keine Bilder in Mathcad zeichnen, aber so gut wie alle Grafiken, die in anderen Anwendungen erstellt wurden, in ein Mathcad-Arbeitsblatt importieren. Grafiken können entweder als Bitmaps oder als OLE-Objekte importiert werden. Mithilfe der Bildverarbeitungsfunktionen können Sie die Grafik-Bilder als Matrix importieren, bearbeiten und dann wieder als Grafik-Bilddatei exportieren.

Arbeiten mit Bitmaps

Importieren eines Objekts aus der Zwischenablage

Importieren von Bitmaps aus einer Datei

Arbeiten mit Bildern

Einrahmen von Bitmaps

Ändern der Bitmap-Größe

Wiederherstellen der ursprünglichen Größe einer Bitmap

Arbeiten mit OLE-Objekten

Importieren von Grafiken mit der Maus

Importieren eines Objekts aus der Zwischenablage

Direktes Einfügen von Objekten

Bearbeiten von Grafikobjekten

Bildverarbeitung

Übersicht über die Bildverarbeitung


Bildverarbeitung

Die Bildverarbeitung lässt sich in vier Schritte unterteilen:

Einlesen des Bilds in eine Matrix

Durchführen mathematischer Transformationen für die Matrix

Anzeigen des Bilds

Speichern des Bilds


Elektronische Bücher und Erweiterungspakete für Mathcad

Mit der Mathsoft-Reihe elektronischer Bücher und Erweiterungspakete erhalten Sie einen dynamischen, interaktiven Zugang zu Informationen und zusätzlichen Funktionen. Sie behandeln spezifische Themen aus unterschiedlichen Bereichen, vom Bauwesen über Elektrotechnik, Signalverarbeitung und Bildverarbeitung bis hin zu mathematischen Themen.

Die elektronischen Bücher und Erweiterungspakete zu Mathcad sind besonders nützlich, wenn sie zusammen mit Mathcad verwendet werden:

  • Jede Seite ist ein dynamisches Arbeitsblatt, in dem Sie z. B. Werte und Gleichungen berechnen können.

  • Sie können Daten und Formeln in den Mathcad-Arbeitsblättern, die Sie erstellen, kopieren und einfügen.

  • Wenn Sie auf eine Überschrift oder einen Indexeintrag doppelklicken, wird der entsprechende Abschnitt geöffnet. Sie können das Buch auch seiten- oder abschnittsweise durchsuchen.

  • Sie können elektronisch nach Text suchen.

  • Sie können den Inhalt verändern und die Änderungen gegebenenfalls speichern.

Wenn Sie mehr über die vielen elektronischen Bücher und Erweiterungspakete von Mathsoft erfahren wollen, besuchen Sie den Mathsoft-Webstore unter http://webstore.mathsoft.com oder laden Sie sich einige der kostenlosen elektronischen Bücher in der Mathcad-Bibliothek unter http://www.mathcad.com/library/ herunter.


Öffnen von elektronischen Büchern

So öffnen Sie ein Elektrionisches Buch oder Erweiterungspaket:

  1. Wählen Sie im Menü Datei die Option Öffnen.

  2. Wählen Sie im Listenfeld "Dateityp" die Option "Mathcad-Bücher (*.hbk)".

  3. Suchen Sie im Dialogfeld nach einem der verfügbaren elektronischen Bücher oder Erweiterungspakete, oder geben Sie den Namen eines elektronischen Buchs oder Erweiterungspakets ein.

Das elektronische Buch bzw. Erweiterungspaket wird in einem eigenen Fenster geöffnet. Mit der Symbolleiste können Sie sich im Fenster bewegen.

Hinweis:

Sie können die Funktionen des Erweiterungspakets auch dann nutzen, wenn es nicht geöffnet ist. Sobald ein Erweiterungspaket installiert ist, sind seine Funktionen jederzeit verfügbar.


Symbolleiste "E-Books"

Mit den Schaltflächen auf der Symbolleiste für elektronische Bücher (E-Books) können Sie Seiten in einem elektronischen Buch verschieben, suchen, kopieren, drucken und speichern. Außerdem können Sie beliebige Dateien aus dem World Wide Web abrufen.

Sie können sehen, wozu die einzelnen Schaltflächen dienen, wenn Sie den Cursor über die Schaltfläche setzen, bis

  • eine QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche erscheint, und

  • in der Meldungszeile der Statusleiste eine Beschreibung der Schaltfläche angezeigt wird.


Durchblättern eines Elektronischen Buchs

Sie können sich in einem elektronischen Buch auf zweierlei Weise orientieren:

  • Mit den Pfeil-Schaltflächen der Buch-Symbolleiste oben im Fenster. Mithilfe der blauen Pfeil-Schaltflächen können Sie durch das Buch navigieren. Die gelben Schaltflächen zeigen die zuletzt geöffneten Dateien an. Die Schaltfläche "Haus" öffnet die Startseite des Buchs, oftmals eine Inhaltsangabe. Mit der Schaltfläche "Suchen" (Fernglas) können Sie das Buch nach bestimmten Wörtern durchsuchen.

  • Klicken Sie auf die Hyperlink-Bereiche, um ein Popup-Fenster zu öffnen oder zu einer anderen Datei zu wechseln. Mit Hyperlinks versehener Text ist unterstrichen. Der Cursor wird zu einer kleinen Hand, wenn Sie über einem Hyperlink verweilen.


Durchsuchen eines elektronischen Buchs

Sie können auf das Inhaltsverzeichnis eines elektronischen Buchs zugreifen, indem Sie auf die Schaltfläche "Haus" in der Symbolleiste "E-Books" im oberen Teil des Buchfensters klicken.

Außerdem können Sie nach jedem Vorkommen einer Textzeichenfolge suchen:

  1. Klicken Sie auf die Schaltfläche "Suchen" in der Symbolleiste "E-Books".

  2. Geben Sie den Text im Textfeld "Suchen" ein. In der Auswahlliste werden Wörter angezeigt, die die eingegebenen Zeichen enthalten.

  3. Klicken Sie auf die Schaltfläche "Suchen". Mathcad zeigt Ihnen die Abschnitte, in denen diese Wörter auftauchen.

  4. Um einen Abschnitt zu öffnen, klicken Sie auf seinen Namen in der Liste "Treffer" und dann auf die Schaltfläche "Gehe zu".

  5. Mit der Schaltfläche "Weiter" können Sie zum nächsten Treffer im Text gelangen. Die Schaltfläche wird abgeblendet, wenn der letzte Eintrag erreicht ist.

  6. Wenn Sie auf die Schaltfläche "Vorheriger" klicken, gelangen Sie zu den vorherigen Einträgen.


Kopieren von Angaben aus einem E-Book

So kopieren Sie eine Seite aus einem E-Book in Ihr Arbeitsblatt:

  1. Klicken Sie in der E-Book-Symbolleiste auf die Schaltfläche "Kopieren".

  2. Klicken Sie in das Hauptfenster des Arbeitsblatts.

  3. Wählen Sie im Menü Bearbeiten den Befehl Einfügen.

So ziehen Sie einen Bereich aus einem E-Book in das Arbeitsblatt:

  1. Wählen Sie den oder die zu verschiebenden Bereiche aus.

  2. Verschieben Sie den Mauszeiger in einen der Bereiche, die von einem gestrichelten Markierungsrechteck umrahmt sind. Der Zeiger nimmt die Form einer kleinen Hand an.

  3. Halten Sie die Maustaste gedrückt und ziehen Sie die Abschnitte des E-Books in das Arbeitsblatt.

  4. Wenn sich die Bereiche an den gewünschten Positionen befinden, lassen Sie die Maustaste wieder los.


Versehen eines Elektronischen Buchs mit Anmerkungen

Sie können im Elektronischen Buch ebenso Änderungen vornehmen wie in einem gewöhnlichen Mathcad-Arbeitsblatt. Diese Änderungen gehen aber verloren, wenn Sie das Buch schließen.

Um Änderungen zu speichern, wählen Sie im Menü Buch die Option Anmerkungen in Buch. Daraufhin geschieht Folgendes:

  • Alle Änderungen werden in einer anderen Farbe hervorgehoben.

  • Beim Schließen des Buchs werden Sie zum Speichern der Änderungen aufgefordert. Sie können die Änderungen abschnittsweise oder alle zusammen speichern.

Wenn Sie die Änderungen speichern, erstellt Mathcad eine mit Anmerkungen versehene Kopie Ihres elektronischen Buchs, die nun stets anstelle des Originals geöffnet wird, wenn Sie das elektronische Buch öffnen. Das Buch wird auch im ursprünglichen Zustand gespeichert, sodass Sie es jederzeit wiederherstellen können.


Durchsuchen des Web mit einem Fenster eines elektronischen Buches

Sie können das Fenster "E-Book" oder "Ressourcen" zum Durchsuchen des Webs verwenden. Gehen Sie hierzu folgendermaßen vor:

  • Klicken Sie in der Symbolleiste "E-Book" auf die Schaltfläche "WWW-Symbolleiste". Daraufhin wird eine weitere Symbolleiste mit einer Adresszeile eingeblendet:

  • Geben Sie im Feld "Adresse" einen URL für ein Dokument im Web ein.

Mit den Schaltflächen links neben dem Feld "Adresse" können Sie eine Seite für einen späteren Besuch markieren, die aktuelle Seite neu laden oder die derzeitige Dateiübertragung unterbrechen.


Erstellen eines E-Books

Mathcad ist dafür bekannt, dass dynamische Gleichungen, Text und Grafiken problemlos in einem einzigen Dokument kombiniert werden können. Für Autoren und Verlage stellen die E-Books von Mathcad ein hervorragendes Online-Medium dar. In einem E-Book werden Formeln und Zahlen zu dynamischen Mathcad-Bereichen.. Graphen von Gleichungen werden zu dynamischen Mathcad-Diagrammen, die der Leser verkleinern, vergrößern, neu berechnen und verändern kann.

Die QuickSheets und Lernprogramme in Mathcad sind solche elektronischen Bücher, die Sie als Orientierungshilfen für Ihre eigene Arbeit verwenden können. Werfen Sie einen Blick auf weitere elektronische Mathcad-Bücher, die Sie aus der Mathcad-Web-Bibliothek herunterladen können, um die vielfältigen Möglichkeiten kennenzulernen.

Es gibt verscheidene Schritte, ein E-Book zu erstellen:

  1. Erstellen einzelner Mathcad-Dateien

  2. Vorbereiten eines Inhaltsverzeichnisses

  3. Hinzufügen von Hyperlinks zu anderen Dateien

  4. Erstellen einer HBK-Datei, um die Reihenfolge der Dateien im Buch anzugeben

  5. Anlegen eines Index (optional).

  6. Überprüfen von Index, HBK-Datei und Arbeitsblättern auf Fehler

Klicken Sie auf die obigen Hyperlinks. Diese führen Sie direkt zur Author's Reference. Dort finden Sie Tipps und Hilfestellungen zum Erstellen von elektronischen Büchern außerhalb Ihres Arbeitsblatt.

Es wird empfohlen, dass Sie sich vor dem Erstellen eines elektronischen Buches zunächst alle Schritte des Vorgangs durchlesen.


Mathcad E-Books

MathSoft bietet eine ständig wachsende Bibliothek Elektronischer Bücher an.

Weitere Informationen erhalten Sie von Mathsoft unter der Telefonnummer 1-800-MATHCAD. Sie können auch eine E-Mail an sales-info@mathsoft.com oder int-info@mathsoft.co.uk senden. Informationen zu den neuesten Produkten finden Sie im Mathsoft-Webstore unter http://webstore/www.mathsoft.com.

Bestimmte Mathcad E-Books können Sie auch von der Mathcad Web Library herunterladen.

Für registrierte Mathcad-Benutzer stehen auf der Downloadsite von Mathcad.com weitere Bücher zur Verfügung.


Verwenden der Collaboratory-Benutzerforen

Bei den Collaboratory-Benutzerforen handelt es sich um einen interaktiven World Wide Web-Dienst, über den Sie mit der Benutzergemeinde von Mathcad in Kontakt treten können. Die Collaboratory-Foren bestehen aus einer Gruppe von Foren, die Ihnen die folgenden Möglichkeiten bieten:

  • Nachrichten senden und Mathcad-Dateien sowie andere Dateien übermitteln

  • Dateien herunterladen und Nachrichten lesen, die andere Mathcad-Benutzer beigetragen haben

  • Die Collaboratory-Foren nach Nachrichten durchsuchen, die ein Stichwort oder eine bestimmte Wortfolge enthalten

  • eine Vielzahl weiterer nützlicher Funktionen aufrufen.

Die Collaboratory-Foren kombinieren einige der besten Funktionen von virtuellen schwarzen Brettern (Bulletin Boards) und Online-Newsgroups mit der Möglichkeit, Arbeitsblätter und weitere mit Mathcad entwickelte Dateien mit Anderen auszutauschen. Zur Nutzung der Collaboratory-Foren wird ein Zugang zum Internet benötigt.

Um auf die Collaboratory-Foren zugreifen zu können, ist wie folgt vorzugehen:

  1. Wählen Sie die Option Collaboratory im Menü Hilfe, und klicken Sie auf die Schaltfläche Collaboratory. Daraufhin wird das Anmeldefenster für das Collaboratory geöffnet.

  2. Melden Sie sich beim Collaboratory-Forum an.

  3. Nachdem Sie sich angemeldet haben, sehen Sie das Collaboratory-Fenster.


Anmeldung bei den Collaboratory-Benutzerforen

In den Collaboratory-Benutzerforen können Sie sich als neuer Benutzer, als eingetragener Benutzer oder als Gast anmelden. Zum Anmelden als neuer Benutzer gehen Sie wie folgt vor:

  1. Klicken Sie auf die Schaltfläche "New User".

  2. Das Anmeldeformular für neue Benutzer wird angezeigt. Folgen Sie exakt den Anleitungen zum Ausfüllen des Formulars. Nachdem Sie dies ausgeführt haben, klicken Sie unten im Formular auf die Schaltfläche "Erstellen". MathSoft verarbeitet diese Informationen ausschließlich, um Ihnen die Benutzung der Collaboratory-Benutzerforen zu ermöglichen.

  3. Nach einigen Minuten finden Sie in Ihrem E-Mail-Konto eine E-Mail, die Ihren Zugangsnamen und Ihr Kennwort enthält.

  4. Sie haben Ihr neues Benutzerprofil erfolgreich erstellt. Sie können jetzt zum Anmeldefenster der Collaboratory-Foren zurückkehren und sich als eingetragener Benutzer anmelden.

Um sich als eingetragener Benutzer anzumelden, geben Sie Ihren Zugangsnamen und Ihr Kennwort ein, und klicken Sie auf "Log In".

Um sich als Gast anzumelden, klicken Sie auf "Gast". Als Gast haben Sie ausschließlich Lesezugriff auf die Collaboratory-Foren. Sie können also alle Nachrichten lesen, aber keine eigenen Nachrichten verfassen.

Hinweise:

  • MathSoft verwendet Ihre Daten ausschließlich für Ihre Teilnahme an den Collaboratory-Benutzerforen.

  • In den Collaboratory-Foren können Sie Ihr Benutzerprofil jederzeit ändern.


Lesen von Nachrichten in den Collaboratory-Benutzerforen

Wenn Sie die Collaboratory-Benutzerforen öffnen,wird angezeigt, wie viele neue Nachrichten vorhanden sind und wie viele dieser Nachrichten direkt an Sie gerichtet sind. Sie können alle Nachrichten oder nur die seit Ihrem letzten Besuch neu eingegangenen Nachrichten anzeigen. Klicken Sie auf die Verknüpfungen im Text, um diese Nachrichten aufzurufen, oder gehen Sie die Liste der Nachrichten rechts auf dem Bildschirm durch. So können Sie Nachrichten in jedem Forum lesen:

  1. Klicken Sie auf das Pluszeichen neben dem Forum, oder klicken Sie auf den Namen des Forums.

  2. Klicken Sie auf eine Nachricht, um sie zu lesen, oder klicken Sie auf das Pluszeichen links neben der Nachricht, um darunter die Antworten anzeigen zu lassen.

  3. Die Nachricht wird rechts im Fenster angezeigt.

Nachrichten, die Sie noch nicht gelesen haben, werden kursiv dargestellt. Möglicherweise wird auch das Symbol "new" neben den neuen Nachrichten angezeigt.


Senden von Nachrichten in den Collaboratory-Benutzerforen

In den Collaboratory-Benutzerforen können Sie in ein beliebiges Forum eintreten und dort eine Nachricht oder eine Antwort auf eine andere Nachricht versenden. Zum Senden einer neuen Nachricht oder einer Antwort auf eine andere Nachricht gehen Sie wie folgt vor:

  1. Entscheiden Sie, in welchem Forum Sie die Nachricht versenden möchten. Klicken Sie auf den Namen des Forums, um die enthaltenen Nachrichten anzuzeigen.

  2. Zum Senden einer neuen Nachricht wählen Sie aus der Menüleiste oben im Fenster "Collaboratory-Benutzerforen" die Option Senden. Zum Senden einer Antwort gehen Sie wie folgt vor:

    • Klicken Sie auf die Nachricht, auf die Sie antworten möchten.

    • Klicken Sie oben in der Nachricht, die jetzt rechts im Fenster gezeigt wird, auf "Antwort senden".

  3. Geben Sie den Titel Ihrer Nachricht in das Feld "Thema" ein.

  4. Wählen Sie die gewünschten Optionen aus den Kontrollkästchen unter dem Titel.

  5. Geben Sie Ihren Text in das Nachrichtenfeld ein. Sie können in Ihre Nachrichten auch Hyperlinks aufnehmen. Hierzu müssen Sie den kompletten URL eingeben, zum Beispiel http://www.myserver.com/main.html oder auf Wunsch auch anderen HTML-Code.

  6. Wenn Sie die Nachricht fertig gestellt haben, klicken Sie unten im Fenster auf "Senden". Je nach den gewählten Optionen wird die Nachricht sofort an die Collaboratory-Foren versendet oder eine Vorschau der Nachricht angezeigt.

  7. Wenn Sie eine Datei anhängen, erscheint eine neue Bildschirmseite. Geben Sie dort den Dateityp und die Datei an, und klicken Sie auf "Upload Now".

Zum Löschen einer Nachricht, die Sie versendet haben, klicken Sie auf die Nachricht, um sie zu öffnen, und klicken Sie dann in der kleinen Menüleiste direkt über der Nachricht rechts im Fenster auf Löschen.

Weitere Informationen zum Versenden und Lesen von Nachrichten und zu anderen Funktionen in den Collaboratory-Foren erhalten Sie, indem Sie in der Menüleiste der Collaboratory-Foren auf Hilfe klicken.


Suchen in Collaboratory-Benutzerforen

Um in den Collaboratory-Benutzerforen zu suchen, klicken Sie in der Menüleiste oben im Fenster "Colaboratory-Foren" auf "Suchen". Rechts im Fenster "Collaboratory-Foren" wird das Dialogfeld "Search Messages" angezeigt. Ihnen stehen zwei Suchmethoden zur Verfügung:

  • "Stichwortsuche" zum Suchen von Nachrichten, welche die angegebenen Stichwörter enthalten,

  • und die "Datenbereichssuche", bei der die Nachrichten aufgelistet werden, die im angegebenen Zeitraum verfasst wurden.

Beide Optionen werden im Fenster angezeigt. Zum Ausführen einer Stichwortsuche gehen Sie wie folgt vor:

  1. Geben Sie das Stichwort bzw. die Stichwörter ein, nach denen Sie suchen.

  2. Legen Sie fest, ob nur Nachrichten gesucht werden sollen, die alle Stichwörter enthalten, oder ob alle Nachrichten gesucht werden sollen, die mindestens eines der angegebenen Stichwörter enthalten.

  3. Wählen Sie die Foren aus, in denen gesucht werden soll. Sie können ein einzelnes Forum, mehrere Foren oder alle Foren wählen.

  4. Wählen Sie die Daten für den Zeitraum aus, der bei der Suche berücksichtigt werden soll.

  5. Wählen Sie die Kategorie aus, nach der die angezeigten Nachrichten sortiert werden sollen.

  6. Wählen Sie, ob das Ergebnis detailliert oder im Standardformat angezeigt werden soll.

  7. Klicken Sie auf die Schaltfläche "Suchen". Daraufhin werden die Nachrichten angezeigt, die Ihren Suchkriterien entsprechen.

Eine Datumsbereichssuche wird auf die gleiche Weise durchgeführt. Jedoch geben Sie dabei keine Stichwörter ein.

Oben im Dialogfeld "Search Messages" finden Sie die beiden Optionen "Today's Messages" und "Search Users". Klicken Sie auf "Today's Messages", wenn alle Nachrichten angezeigt werden sollen, die am heutigen Tag geschrieben wurden. Klicken Sie auf "Search Users", um nach Benutzern zu suchen, die aus einer bestimmten Stadt oder einem bestimmten Land kommen oder eine bestimmte E-Mail-Adresse oder Homepage besitzen.


Ändern Ihrer Benutzerdaten in den Collaboratory-Benutzerforen

Bei Ihrer ersten Anmeldung in den Collaboratory-Benutzerforen haben Sie Ihren Namen, Ihre Anschrift und weitere Daten in ein Anmeldeformular für neue Benutzer eingetragen. Diese Daten werden als Ihr persönliches Benutzerprofil gespeichert. Um die Informationen oder die Standardeinstellungen für die Collaboratory-Benutzerforen zu ändern, müssen Sie Ihr Profil wie folgt ändern:

  1. Klicken Sie in der Menüleiste oben im Fenster auf Weitere Optionen.

  2. Klicken Sie auf die Funktion "Edit Your Profile".

  3. Nehmen Sie die entsprechenden Änderungen im Profil vor.

  4. Klicken Sie unten in der Seite auf "Speichern".

Sie können Informationen wie beispielsweise Anmeldename und Kennwort ändern. Um Ibeim Versenden von Nachrichten hre Privatsphäre zu schützen, können Sie Ihre E-Mail-Adresse unsichtbar machen oder Ihren Zugangsnamen ändern, indem Sie das Profil bearbeiten.


Zusätzliche Funktionen in den Collaboratory-Benutzerforen

In den Collaboratory-Benutzerforen stehen Funktionen zur Verfügung, mit denen Sie auf einfache Weise Informationen suchen oder Informationen an die Mathcad-Gemeinde übermitteln können. Für Aktivitäten wie das Erstellen eines Adressbuchs, die Markierung von Nachrichten als gelesen, die Anzeige bestimmter Nachrichten, das Anfordern automatischer E-Mail-Benachrichtigungen, wenn bestimmte Foren neue Nachrichten enthalten, oder die Bearbeitung Ihrer Benutzerdaten wählen Sie Weitere Optionen aus der Menüleiste der Collaboratory-Benutzerforen.

Die Collaboratory-Benutzerforen unterstützen außerdem eine Teilnahme über E-Mail oder über eine News-Group. Weitere Informationen zu diesen und weiteren Funktionen in den Collaboratory-Benutzerforen erhalten Sie, indem Sie Sie in der Menüleiste der Collaboratory-Benutzerforen auf "Hilfe" klicken.


Verzeichnis der Tastaturbefehle

In dieser Liste finden Sie alle Tastaturbefehle nach ihrer Funktion geordnet. Wenn Sie wissen möchten, was ein bestimmter Tastaturbefehl bewirkt, können Sie auf der Registerkarte Suchen nach dem Tastaturbefehl suchen.

Standardmäßig übernimmt Mathcad die üblichen Windows-Tastaturbefehle für die meisten gängigen Operationen. Wenn Sie zuvor mit einer älteren Version von Mathcad gearbeitet haben, ziehen Sie eventuell die klassischen Mathcad-Tastaturbefehle vor. In diesem Fall wählen Sie Einstellungen aus dem Menü Extras und klicken auf die Option Standardmäßige Windows-Tastaturbefehle verwenden, um sie zu deaktivieren.

Griechische Buchstaben

Operatoren

Arbeitsblätter und Fenster

Bearbeiten

Richtungs- und Bewegungstasten

Erstellen von Bereichen


Griechische Buchstaben

Zum Einfügen griechischer Buchstaben gehen Sie wie folgt vor:

  1. Geben Sie den entsprechenden Buchstaben aus der unten stehenden Tabelle ein.

  2. Drücken Sie Strgl+G.

Sie können stattdessen auch auf den gewünschten Buchstaben in der Symbolleiste Symbolleiste "Griechisch" klicken. Den griechischen Buchstaben p können Sie auch eingeben, indem Sie Strg+Umschalt+p drücken.


Tasten zum Erstellen von Operatoren

Mit den folgenden Tasten werden Operatoren eingefügt. Mit einer Ausnahme, der Taste ", entspricht ihre Funktion in der freien Fläche der in einer Gleichung.

Tastaturbefehl | Operator
! | Fakultät
" | Konjugiert komplexe Zahl
# | Bereichsprodukt
$ | Bereichssumme
& | Integration
' | Paar von Klammern
( | Linke Klammer
) | Rechte Klammer
* | Multiplikation oder inneres Produkt (Skalarprodukt)
+ | Addition
, | Trennt Argumente in einer Funktion Trennt abzubildende Ausdrücke auf derselben Achse; steht vor der zweiten Zahl im Bereich
; | Steht vor der letzten Zahl im Bereich
 | Negation oder Subtraktion
/ | Division
[Strg] / | Inline-Division
[Strg] + | Operator "Gemischte Zahl"
< | Kleiner als
> | Größer als
? | Differentiation
[Strg] ? | n-te Ableitung
[ | Feldindex
\ | Quadratwurzel
[Strg] \ | n-te Wurzel
^ | Potenzieren
| | Betrag oder Determinante
[Strg] 1 | Transponieren
[Strg] 3 | Ungleich
[Strg] 4 | Summe der Elemente im Vektor
[Strg] 9 | Kleiner gleich
[Strg] 0 | Größer gleich
[Strg] 8 | Vektorprodukt
[Strg] | Vektorisieren
[Strg] = | Gleich
[Strg] 6 | Hochgestellter Index
[Strg] $ | Summation
[Strg] # | Produkt
[Strg][Eingabetaste] | Addition mit Zeilenumbruch
[Strg] I | Unbestimmtes Integral
[Strg] L | Grenzwert
[Strg] A | Rechter Grenzwert
[Strg] B | Linker Grenzwert
[Strg] & | Boolesches UND
[Strg] ! | Boolesches NICHT
[Strg] ^ | Boolesches ODER
[Strg] % | Boolesches XOR
[Strg] . | Symbolische Auswertung
[Strg] > | Symbolische Auswertung mit Schlüsselwörtern


Tastaturbefehle für das Bearbeiten

Eingabetaste Fügt eine Leerzeile ein. Innerhalb von Text wird ein neuer Absatz eingefügt.

Entf Löscht eine Leerzeile. Innerhalb von Text oder Rechenbereichen wird das Zeichen rechts neben der Einfügelinie gelöscht.

Umschalt+Eingabetaste Innerhalb von Text wird eine neue Zeile im gleichen Absatz eingefügt.

Strg+Eingabetaste Fügt einen Seitenumbruch ein. Innerhalb von Text wird die Breite des Textbereichs bestimmt. In Rechenbereichen wird eine Addition mit dem Zeilenumbruch-Operator eingefügt.

Strg+A Innerhalb von Text wird der gesamte Text im Textbereich ausgewählt.

Strg+A In einer leeren Fläche werden alle Bereiche im Arbeitsblatt ausgewählt.

Strg+Umschalt+Eingabetaste In einem Bereich wird der Cursor nach außen unter den Bereich verschoben.

Strg+F Sucht ein Zeichen oder eine Zeichenfolge.

Strg+H Ersetzt ein Zeichen oder eine Zeichenfolge.

Strg+Z Macht den letzten Bearbeitungsschritt rückgängig.

Strg+Y Wiederherstellen. Stellt die rückgängig gemachte Aktion wieder her.

Strg+C Kopiert die Auswahl in die Zwischenablage.

Strg+V Fügt den Inhalt der Zwischenablage in das Arbeitsblatt ein.

Strg+X Schneidet die Auswahl aus und fügt sie in die Zwischenablage ein.

Strg+E Öffnet das Dialogfeld Funktion einfügen.

Strg+U Öffnet das Dialogfeld Einheit einfügen.

Strg+Umschalt+J Ermöglicht die Eingabe von Zeichen in eckigen Klammern wie bei der chemischen Notation.

Strg+Umschalt+K Ermöglicht die Eingabe von Zeichen, mit denen normalerweise Operatoren eingefügt werden.

Einfg Wechselt in den Einfügemodus.


Richtungs- und Bewegungstasten

Pfeil-nach-oben

Pfeil-nach-unten

Pfeil-nach-links

Pfeil-nach-rechts

Umschalt + Pfeil-nach-oben

Umschalt + Pfeil-nach-oben

Umschalt + Pfeil-nach-oben

Umschalt + Pfeil-nach-oben

Strg + Pfeil-nach-oben

Strg + Pfeil-nach-oben

Strg + Pfeil-nach-oben

Strg + Pfeil-nach-oben

Tabulator

Umschalt + Tabulator

Pos1

Ende

Strg + Pos1

Strg + Ende

Eingabe

Leerzeichen

Strg + Eingabetaste Fügt in leeren Bereichen einen Seitenumbruch ein.

Bild-auf Verschiebt die Fensteranzeige um etwa 80 % nach oben.

Bild-ab Verschiebt die Fensteranzeige um etwa 80 % nach unten.

Umschalt+Bild-auf Zeigt den vorhergehenden Seitenumbruch an.

Umschalt+ Bild-ab Zeigt den nächstfolgenden Seitenumbruch an.


Tastaturbefehle für die Erstellung von Bereichen

@ Erstellt ein X-Y-Diagramm.

Strg+7 Erstellt ein Kreisdiagramm.

Strg+2 Erstellt ein Flächendiagramm.

Strg+G Ändert das vorhergehende Zeichen von "griechisch" in "lateinisch" und umgekehrt.

Strg+M Erstellt eine Matrix oder einen Vektor.

Strg+Umschalt+A (In Textbereich) Fügt Rechendaten in Text ein.

Strg+Umschalt+A (Nicht in Textbereich) Fügt den Operator für den linken Grenzwert ein.

Strg+Umschalt+B Fügt den Operator für den rechten Grenzwert ein.

Strg+Umschalt+J Stellt auf chemische Notation um. Das heißt: Erstellen Sie z. B. einen Bereich, in dem jeder eingegebene Ausdruck als einzelner Variablenname behandelt wird.

Strg+Umschalt+P Fügt den griechischen Buchstaben pi ein.

Strg+Umschalt+Z Fügt das Zeichen für Unendlichkeit ein.

Entf (In Bereich) Löscht den Bereich.


Tastaturbefehle für die Arbeitsblatt- und Fensterverwaltung

Die folgenden Tastaturbefehle ermöglichen die Arbeit mit Fenstern und Arbeitsblättern als Ganzes.

Strg+F4 Schließt das Arbeitsblatt.

Strg+F6 Aktiviert das nächste Fenster.

Strg+K Fügt einen Hyperlink ein oder ermöglicht seine Bearbeitung.

Umschalt+Eingabe Verlässt einen Textbereich.

Strg+N Erstellt ein neues Arbeitsblatt.

Strg+O Öffnet das Arbeitsblatt.

Strg+P Druckt ein Arbeitsblatt.

Strg+S Speichert ein Arbeitsblatt.

Alt+F4 Beenden.

Strg+R Zeichnet den Bildschirm neu.

F1 Öffnet das Hilfefenster.

F9 Berechnet die ausgewählte Region neu.

Strg+F9 Berechnet das gesamte Arbeitsblatt neu.

Umschalt+F1 Schaltet die kontextsensitive Hilfe ein bzw. aus.

Esc Schließt die kontextsensitive Hilfe oder unterbricht eine Berechnung.


Technische Unterstützung

Einzelbenutzer von Mathcad können auf die kostenlose Technische Unterstützung durch MathSoft zurückgreifen. Besuchen Sie den Bereich "Support" der Mathsoft-Website unter: http://support.mathsoft.com.

Wenn Sie außerhalb der USA und Kanada wohnen, kontaktieren Sie bitte Ihren örtlichen, autorisierten Mathcad-Vertreiber, um technische Unterstützung zu erhalten. Sie finden die Kontaktdaten unter: http://www.mathcad.com/buy/International_Contacts.asp.

Wenn Sie keinen Internetzugang haben, können Sie MathSoft International direkt um Unterstützung bitten unter:

  • E-Mail: help@mathsoft.co.uk

  • Fax: +44 1276 475552 ("Attn: Tech Support")

  • Telefon: +44 (0)1276 450850

Informationen zur Technischen Unterstützung für Standortlizenzen erhalten Sie über Mathsoft oder den für Sie zuständigen lokalen Distributor.


Verwenden des Hilfesystems

Die Mathcad-Hilfe öffnen Sie, indem Sie Mathcad-Hilfe aus dem Menü Hilfe wählen oder [F1] drücken. Mit den drei Registerkarten im Hilfefenster bewegen Sie sich durch die Mathcad-Themen wie folgt:

  • enthält ein Inhaltsverzeichnis, das Ihnen eine Übersicht über die vorhandenen Themen und einen roten Faden durch die Hilfe bietet.

  • führt Sie durch einzelne Themen. Verwenden Sie den Index, wenn Sie bereits wissen, nach welchem Thema Sie suchen.

  • durchsucht das gesamte Hilfesystem nach einem Wort oder einer Wortfolge. Die Volltextsuche ist nützlich, wenn Sie nur nach einem bestimmten Wort oder einem Satz suchen und nicht nach einem Thema.

Wenn Sie auf eine Themenüberschrift klicken, wird die Themenseite rechts im Fenster geöffnet.


So erreichen Sie MathSoft, Inc:

So erreichen Sie MathSoft Engineering & Education, Inc:

USA und Kanada

Postanschrift:

Mathsoft Engineering & Education, Inc.
101 Main St.
Cambridge, MA 02142
USA

Tel.: 1-800-MATHCAD oder 617-444-8000
Fax: 617-444-8001
E-Mail: sales-info@mathsoft.com
Website: http://www.mathsoft.com

Alle anderen Länder

Postanschrift:

Mathsoft Engineering & Education, Inc.
Knightway House
Park Street
Bagshot, Surrey
GU19 5AQ
United Kingdom

Telefon: +44 1276 450850
Fax: +44 1276 475552
E-Mail: int-info@mathsoft.co.uk
Website: http://www.mathsoft.com

Webseite mit Informationen zur weltweiten Kontaktaufnahme mit MathSoft

Um eine aktuelle Liste der internationalen Händler für Ihr Land oder Ihre Region zu erhalten, gehen Sie auf folgende Webseite: www.mathcad.com/buy/international_contacts.asp


Aktualisieren von Mathcad

Neue Versionen von Mathcad stehen Ihnen in regelmäßigen Abständen zum Downloaden auf der Mathcad-Website zur Verfügung. Wählen Sie Mathcad-Update im Menü Hilfe, um zu überprüfen, ob Sie die neueste Version von Mathcad verwenden. Mathcad überprüft automatisch, ob eine Aktualisierung verfügbar ist. Falls das der Fall ist, wird Ihr Standard-Browser gestartet und Sie werden auf den Download-Bereich der Mathcad-Website geleitet.

Hinweis:

  • Sie müssen mit dem Internet verbunden sein, um diese Funktion verwenden zu können.

  • Während des Aktualisierungsvorgangs werden keinerlei Informationen von Ihrem Computer an die Mathcad-Website gesendet.


Weitere Informationsquellen

Das Mathcad-Hilfesystem bietet umfassende Informationen zu den Mathcad-Funktionen. Zusätzlich gibt es jedoch weitere Informationsquellen, die für Sie von Interesse sein könnten:

Online-Lernprogramme im Menü "Hilfe", die Grundlagen für den Einstieg und ausführlichere Beschreibungen enthalten.

QuickSheets im Menü "Hilfe", die funktionsfähige Beispiele für die meisten Mathcad-Funktionen und -Programme enthalten und Ihren Bedürfnissen entsprechend abgeändert werden können.

Die Collaboratory-Benutzerforen von Mathcad bringen Sie mit anderen Mathcad-Benutzern in Verbindung.

Elektronische Bücher und Erweiterungspakete

Die elektronischen Mathcad-Bücher sind mit Hyperlinks verknüpfte Sammlungen von Mathcad-Arbeitsblättern zu den verschiedensten Themenbereichen. Erweiterungspakete erweitern die Funktionalität von Mathcad von der Signalverarbeitung bis hin zum Lösen von Gleichungen und der Optimierung von Funktionen. Sie können die elektronischen Bücher von der Download-Site und Web-Bibliothek unter Mathcad.com herunterladen oder im Mathsoft Webstore online Mathcad-Bibliotheken und Erweiterungspakete erwerben.

Mathcad.com

Mathcad.com enthält umfassende Ressourcen, darunter Hunderte angewandter Benutzerdateien und elektronischer Bücher in der Web-Bibliothek, Artikel mit Ratschläge zu Mathcad, Downloads sowie Informationen zu Anwendungen für Mathcad.

Technische Unterstützung

Die technische Unterstützung hält in einer Suchdatenbank im Bereich "Support" der Mathcad-Website oder direkt unter Mathsoft Technical Support Lösungen für zahlreiche Fragen bereit.


Dialogfeld "3D-Diagrammformat" : Registerkarte "QuickPlot-Daten"

Bereich

Legt die Bereichsgrenzen fest, in denen die Funktion ausgegeben wird. "Bereich 1" und "Bereich 2" entsprechen dabei jeweils der ersten bzw. zweiten unabhängigen Variable (im Koordinatensystem x bzw. y).

Start

Die Untergrenze für die unabhängige Variable, die berechnet und im Diagramm ausgegeben werden soll. Der Standardstartwert ist -5.

Ende

Die Obergrenze für die unabhängige Variable, die berechnet und im Diagramm ausgegeben werden soll. Der Standardendwert ist 5.

Hinweis: Die für die unabhängigen Variablen eingestellten Bereiche bestimmen nicht unbedingt die Achsenbegrenzungen der Ausgabe, es sei denn, Sie geben eine einzelne Funktion von zwei Variablen im Koordinatensystem aus. In allen anderen Fällen werden die Achsenbegrenzungen von den Daten für x, y und z bestimmt, die Mathcad für Ihre Funktionen generiert.

Schrittweite

Dies ist die Anzahl der Gitterlinien oder Punkte, die von Mathcad für die betreffende Funktion generiert und zur Erstellung der Fläche verwendet werden. Die Standardeinstellung ist eine Schrittweite von 20 x 20.

Koordinatensystem

Mit dieser Option können Sie das Koordinatensystem bestimmen, in dem das Diagramm erstellt werden soll.

Im kartesischen Koordinatensystem werden die Werte von x und y als unabhängige Variablen betrachtet, und z wird als die abhängige Variable berechnet.

Im sphärischen System werden ein Wert für r und der Winkel phi als unabhängige Variablen behandelt. Der Winkel Theta wird als abhängige Variable berechnet.

Im zylindrischen System werden ein Wert für r und der Winkel phi als unabhängige Variablen behandelt. Der Wert von z wird als abhängige Variable berechnet.


Dialogfeld "3D-Diagrammformat": Registerkarte "Erweitert"

Nebel aktivieren

Schattiert das Diagramm so, als ob es von Nebel umgeben wäre. Weiter entfernte Teile des Diagramms werden verschwommen dargestellt, sodass der Eindruck von Tiefe entsteht. Diagramme werden bei aktiviertem Nebel langsamer gezeichnet.

Perspektive

Das Diagramm wird so dargestellt, als würde es aus einer Distanz betrachtet. Die Teile des Diagramms, die sich weiter weg befinden, werden kleiner dargestellt als die näher gelegenen Teile gleicher Größe. Geben Sie den Abstand im Textfeld "Sichtweite" ein.

Entfernung anzeigen

Gibt den Abstand an, wenn "Perspektive" aktiviert ist.

Vertikale Skalierung

Ist die vertikale Skalierung auf einen niedrigen Wert eingestellt, sind die Unterschiede in der Höhe kaum erkennbar. Bei 100 sind die Unterschiede so groß, dass das Diagramm den gesamten Rahmen einnimmt.

Farbschema - Ansteigend X, Ansteigend Y, Ansteigend Z

Ordnet die Werte in dem ausgewählten Farbschema entsprechend den x-Werten, y-Werten oder z-Werten zu.

Farbschema auswählen

Bestimmt die Farbzuordnung, die für Füllungen, Linien und Punkte verwendet werden soll, wenn "Farbschema" für alle drei Aspekte auf der Seite "Darstellung" aktiviert ist.

Glanz

Durch höhere Werte erscheint das Diagramm glänzender, wenn die Beleuchtung auf der Seite Beleuchtung aktiviert und die Oberfläche des Diagramms auf der Seite Darstellung gefüllt ist. Durch eine glänzendere Oberfläche wird mehr Glanzlicht reflektiert.

% Transparenz

Bei hohen Werten ist das Diagramm transparenter, sodass hindurchgesehen werden kann.

Polygonausgleich

Hiermit werden Linien und eine gefüllte Oberfläche abgesetzt, wenn Linien gezogen und die Flächen eines Diagramms gefüllt sind. Ist hierfür Null festgelegt, können die Linien so dargestellt werden, als verliefen sie hinter der Fläche. Es entsteht der Eindruck von "Nähten".

Drucken mit hoher Qualität

Erzwingt die Ausgabe des 3D-Diagramms in der jeweils eingestellten Druckerauflösung. Anderenfalls wird das Diagramm mit 150 dpi gedruckt.

Als Standard

Bestimmt den Druckstandard für alle neuen 3D-Diagramme. Prüfen Sie, ob "Drucken mit hoher Qualität" aktiviert ist (soweit gewünscht), und aktivieren Sie dann das Kontrollkästchen "Als Standard". Die Druckinformationen werden in die Systemregistrierung geschrieben. (Beachten Sie, dass diese Option nie aktiviert bleibt.)


Dialogfeld "3D-Diagrammformat": Registerkarte "Darstellung"

Fläche füllen

Füllt die Diagrammfläche mit einem Farbschema oder mit einer im Abschnitt "Farboptionen" festgelegten Volltonfarbe.

Umrisse füllen

Füllt die Diagrammfläche entsprechend den x-, y- oder z-Umrissen. Standardmäßig wird entsprechend den z-Werten gefüllt. Mit den Umrissoptionen auf der Seite Spezial können Sie die Füllung in eine andere Umrissrichtung vornehmen lassen: Wählen Sie eine Umrissrichtung im Dropdown-Menü, und klicken Sie auf "Füllen", um diese Option zu aktivieren.

Hinweis:Sie können jeweils in bis zu 2 Umrissrichtungen füllen.

Keine Füllung

Die Oberfläche des Diagramms wird nicht gefüllt. Sie spiegelt kein Licht und hat keine Farbe.

Anderes Gitter

Füllt die Fläche des Diagramms mit zur Hälfte gefüllten Rechtecken.

Gouraud-Schattierung

Mischt die Farben in einem ausgefüllten Diagramm von Rechteck zu Rechteck, sodass die Farbgebung gleichmäßig wird. Diagramme werden langsamer gezeichnet, wenn "Gouraud-Schattierung" aktiviert ist.

Drahtmodell

Zeichnet Linien im Diagramm, sodass auf dem Diagramm ein Rahmen entsteht.

Umriss

Zeichnet Linien nur in Richtung der x-, y- oder z-Umrisse. Standardmäßig werden z-Umrisse gezeichnet. Mit den Umrissoptionen auf der Seite Spezial können Sie Linien in einer anderen Umrissrichtung zeichnen.

Keine Linien

Im Diagramm werden keine Linien gezeichnet.

Linien ausblenden

Blendet Linien aus, die in einem nicht transparenten Diagramm nicht sichtbar wären.

Stärke

Bestimmt die Stärke der im Diagramm gezeichneten Linien.

Punkte zeichnen

Zeichnet Punkte bei den Datenwerten, aus denen das Diagramm besteht.

Symbol

Bestimmt das Symbol, das an die einzelnen Punkte gesetzt werden soll.

Größe

Bestimmt die Größe des Symbols an den einzelnen Punkten.

Farbschema

Färbt die Fläche (Füllung) des Diagramms, der Linien oder der Punkte entsprechend den Werten in der Farbzuordnung, die in der Seite Erweitert festgelegt ist.

Volltonfarbe

Färbt die Fläche (Füllung) des Diagramms, der Linien oder der Punkte mit der Farbe, die im rechten Feld festgelegt ist.


Dialogfeld "3D-Diagrammformat": Registerkarte "Achsen"

Klicken Sie zum Formatieren der X-, Y- oder Z-Achse auf die entsprechende Registerkarte für die Achse im Dialogfeld.

Linien zeichnen

Zeichnet Linien bei jeder Gitterunterteilung auf der ausgewählten Achse.

Hinweis:Die Gitterlinien werden auch durch die Optionen auf der Seite "Hintergrundebenen" gesteuert. Wenn Sie die Gitterlinien für eine Achse auf der Registerkarte "Achsen" festlegen, gilt dies für die beiden Hintergrundebenen der Achse. Wenn Sie die Gitterlinien auf der Registerkarte "Hintergrundebenen" festlegen, gilt dies nur für eine Hintergrundebene.

Teilstriche zeichnen

Zeichnet Teilstriche bei allen Gittern auf der ausgewählten Achse. Die Farbe der Teilstriche richtet sich nach der "Achsenfarbe".

Hinweis: Die Teilstriche werden auch durch die Optionen auf der Seite "Hintergrundebenen" bestimmt. Wenn Sie die Teilstriche für eine Achse auf der Registerkarte "Achsen" festlegen, gilt dies für die beiden Hintergrundebenen der Achse. Wenn Sie die Teilstriche auf der Registerkarte "Hintergrundebenen" festlegen, gilt dies nur für eine Hintergrundebene.

Autom. Gitterweite

Bestimmt automatisch die Anzahl der Gitterunterteilungen.

Linienfarbe

Bestimmt die Farbe der Gitterlinien.

Anzahl

Bestimmt die Anzahl der Gitterlinien, die verwendet werden soll, wenn "Autom. Gitterweite" nicht aktiviert ist.

Linienstärke

Bestimmt die Dicke der Gitterlinien.

Beschriftung

Wenn dieses Kontrollkästchen aktiviert ist, erscheint der im Textfeld vorgegebene Text an den Achsen.

Achsenfarbe

Bestimmt die Farbe der Achse und der Teilstriche.

Nummeriert

Zeigt an allen Gitterunterteilungen auf der ausgewählten Achse Zahlen an.

Achsenstärke

Bestimmt die Dicke der Achse.

Autom. Skalierung

Wählt die Achsenbegrenzungen automatisch aus.

Jedes Diagramm, das Sie erstellen, wird standardmäßig automatisch skaliert.

Wenn "Autom. Skalierung" aktiviert ist, wird für jede Achsenbegrenzung die erste Hauptskalenmarkierung hinter dem Ende der Daten festgelegt.

Ist das Kontrollkästchen "Autom. Skalierung" nicht aktiviert, endet die Achse direkt mit dem letzten Datenpunkt.

Um die automatische Skalierung zu deaktivieren und um das Diagramm bis zu den Grenzen des Diagrammbereichs zu zeichnen, klicken Sie auf Diagrammformat und deaktivieren Sie das Kontrollkästchen "Autom. Skalierung" der entsprechenden Achse.

Mindestwert

Bestimmt die untere Achsenbegrenzung, wenn "Autom. Skalierung" nicht aktiviert ist.

Höchstwert

Bestimmt die obere Achsenbegrenzung, wenn "Autom. Skalierung" nicht aktiviert ist.


Dialogfeld "3D-Diagrammformat": Registerkarte "Hintergrundebenen"

Klicken Sie zum Formatieren der X-Y-, Y-Z- oder X-Z-Hintergrundebene auf die entsprechende Registerkarte im Dialogfeld.

Hintergrundebene füllen, Farbe

Füllt die Hintergrundebene mit der im Feld neben "Farbe" festgelegten Farbe.

Rahmen für Hintergrundebene

Zieht einen Rahmen um die Hintergrundebene.

Linien zeichnen

Zeichnet Gitter- oder Untergitterlinien auf einer bestimmten Achse.

HINWEIS: Die Gitterlinien werden auch durch die Optionen auf der Seite "Achsen" bestimmt. Wenn Sie die Gitterlinien für eine Achse auf der Registerkarte "Achsen" festlegen, gilt dies für die beiden Hintergrundebenen der Achse. Wenn Sie die Gitterlinien auf der Registerkarte "Hintergrundebenen" festlegen, gilt dies nur für eine Hintergrundebene.

Teilstriche zeichnen

Zeichnet Teilstriche an den Gitter- oder Untergitterunterteilungen auf einer bestimmten Achse.

HINWEIS: Die Teilstriche werden auch durch die Optionen auf der Seite "Achsen" bestimmt. Wenn Sie die Teilstriche für eine Achse auf der Registerkarte "Achsen" festlegen, gilt dies für die beiden Hintergrundebenen der Achse. Wenn Sie die Teilstriche auf der Registerkarte "Hintergrundebenen" festlegen, gilt dies nur für eine Hintergrundebene.

Linienfarbe

Bestimmt die Farbe der Gitter- oder Untergitterlinien.

Linienstärke

Bestimmt die Stärke der Gitter- oder Untergitterlinien.


Dialogfeld "3D-Diagrammformat": Registerkarte "Allgemein"

Drehung

Gibt den Drehungswinkel (in Grad) um die z-Achse an. Muss eine ganze Zahl zwischen -360 und 360 sein.

Drehung = 0
Sie schauen direkt auf die erste Spalte der Matrix herab. Die erste Zeile zeigt nach rechts.

Drehung = 90
Sie schauen direkt auf die erste Zeile der Matrix herab. Die erste Spalte zeigt nach links.

Sie können auch mit der Maus drehen.

Neigung

Bestimmt den Drehungswinkel (in Grad) um die x-Achse, der nach dem Drehen des Diagramms gebildet wird. Muss eine ganze Zahl zwischen 0 und 180 sein.

Sie können auch mit der Maus neigen.

Verdrehung

Bestimmt den Drehungswinkel (in Grad) um die z-Achse, der nach dem Drehen und Neigen des Diagramms gebildet wird. Muss eine ganze Zahl zwischen -360 und 360 sein.

Sie können auch mit der Maus verdrehen.

Zoom

Bestimmt den Vergrößerungsfaktor des Diagramms. Je höher der Vergrößerungsfaktor, desto näher befinden Sie sich am Diagramm. Dies muss ein Wert zwischen .01 und 100 sein.

Sie können auch mit der Maus zoomen.

Achsenformat

Bestimmt, ob die Achsen im Vordergrund des Diagramms (Rundum) sichtbar sind, ob sie sich hinten links im Diagramm (Ecke) überschneiden, oder ob sie überhaupt angezeigt werden.

Gleiche Skalierung

Legt für alle Achsen eine bestimmte Skalierung fest.

Rahmen anzeigen

Zeichnet ein Rechteck um das gesamte Diagramm. Im Feld auf der rechten Seite wird die Farbe des Rahmens angegeben.

3D-Rahmen

Zeichnet einen Kasten um das Diagramm. Im Feld auf der rechten Seite wird die Farbe des Rahmens angegeben.

Darstellungsart

Fläche - Wandelt das Diagramm in ein Flächendiagramm um, in dem eine dreidimensionale Abbildung der Ebenenkurven einer Matrix angezeigt wird.

Umrissdiagramm - Wandelt das Diagramm in ein Umrissdiagramm um, in dem eine dreidimensionale Abbildung der auf eine Hintergrundebene projizierten Ebenenkurven einer Matrix dargestellt wird. Standard ist die xy-Hintergrundebene. Über die Dropdown-Liste "Umrissoptionen" auf der Seite "Spezial" können Sie eine Projektion auf eine andere Hintergrundebene durchführen.

Datenpunkte - Wandelt das Diagramm in Punkte ohne Verbindung um.

Säulendiagramm - Wandelt das Diagramm in ein 3D-Säulendiagramm um, das eine Matrix in Form von Balken mit unterschiedlicher Höhe darstellt.

Vektorfeld - Wandelt das Diagramm in ein auf die xy-Hintergrundebene projiziertes Vektorfelddiagramm um.

Patch-Diagramm - Zeichnet bei allen Datenpunkten gleich ausgerichtete, nicht verbundene Stücke.


Dialogfeld "3D-Diagrammformat": Registerkarte "Beleuchtung"

Mithilfe der Optionen links im Dialogfeld können Sie die allgemeine Beleuchtung steuern. Sie können ein gerichtetes Licht formatieren, indem Sie im Dialogfeld auf die entsprechende Registerkarte wie z. B. "Licht 1" oder "Licht 2" klicken.

Beleuchtung aktivieren

Aktiviert alle Optionen auf der Registerkarte "Beleuchtung".

Umgebungslichtfarbe

Bestimmt die Farbe des Umgebungslichts.

Beleuchtungsschema

Zeigt eine Liste von integrierten Beleuchtungsschemen an.

Ein/Aus

Schaltet ein gerichtetes Licht ein bzw. aus.

Farbe streuen

Bestimmt die Farbe des Bereichs des gestreuten Lichts eines gerichteten Lichts.

Glanzfarbe

Bestimmt die Farbe (normalerweise Weiß) des Bereichs des Glanzlichts eines gerichteten Lichts. Dies ist von Nutzen, wenn der Glanz auf der Seite "Erweitert" festgelegt wird.

Lichtposition - X, Y, Z

Bestimmt die allgemeine Position eines gerichteten Lichts auf der X-, Y- und Z-Achse.

Unendliche Lichtquelle

Positioniert ein gerichtetes Licht in unendlicher Entfernung.


Dialogfeld "3D-Diagrammformat": Registerkarte "Spezial"

Füllen

Füllt die Oberfläche des Diagramms in der Umrissrichtung, die im Dropdown-Menü unten im Abschnitt "Umrissoptionen" angegeben wird (standardmäßig Z-Umrisse).

Linien zeichnen

Zeichnet Linien in der Umrissrichtung, die im Dropdown-Menü unten im Abschnitt "Umrissoptionen" angegeben wird (standardgemäß Z-Umrisse).

Autom. Umrisse

Bestimmt automatisch die Anzahl der Umrisslinien, die in der Umrissrichtung gezeichnet werden sollen, die im Dropdown-Menü unten im Abschnitt "Umrissoptionen" angegeben sind (standardmäßig Z-Umrisse).

Nummeriert

Zeigt Nummern auf den Umrisslinien an.

Anzahl

Bestimmt die Anzahl der Umrisslinien, die in der Umrissrichtung gezeichnet werden sollen, die im Dropdown-Menü unten im Abschnitt "Umrissoptionen" angegeben ist (standardgemäß Z-Umrisse). Dies ist nur verfügbar, wenn "Autom. Umrisse" nicht aktiviert ist.

Z-Umrisse, X-Umrisse, Y-Umrisse

Bestimmt eine Umrissrichtung. Legen Sie nach dem Wählen einer Richtung die anderen Optionen im Abschnitt "Umrissoptionen" fest.

Säulendiagramm-Layout

Matrix

Gestapelt

Nebeneinander

Abstand

Bestimmt den Abstand zwischen Säulen.

Interpoliertes Gitter (Zeilen, Spalten)

Auf die Einstellungen in diesem Feld kann nur zugegriffen werden, wenn das Flächendiagramm durch Umwandeln eines Streuungsdiagramms entstanden ist. In diesem Fall ist das Diagramm eigentlich eine interpolierte Fläche, die annähernd den Streuungsdaten entspricht.

Um die Dichte des für die Interpolation verwendeten Gitters zu ändern, können Sie in den entsprechenden Feldern die Anzahl der Zeilen und Spalten ändern. Werden die Daten nicht ausreichend gut durch die Fläche approximiert, ist es u. U. möglich, eine sinnvolle Interpolation zu erstellen. In diesem Fall erscheint in der Meldungszeile eine entsprechende Meldung.

Verbindungsart

Bestimmt, wie die Punkte miteinander verbunden werden, wenn auf der Registerkarte "Allgemein" die Option "Datenpunkte" aktiviert ist und auf der Registerkarte "Darstellung" die Option "Linien" aktiviert ist. Klicken Sie dazu auf eine der folgenden Optionen:

Zeilenfolge - Die Reihenfolge der Punkte auf den Vektoren.

Ansteigend X - Mit ansteigenden x-Werten.

Ansteigend Y - Mit ansteigenden y-Werten.

Ansteigend Z - Mit ansteigenden z-Werten.

Mit "Linienvorlage" bestimmen Sie die Art der Linie, welche die Punkte miteinander verbindet (durchgängig, gestrichelt, gepunktet oder gepunktet/gestrichelt).


Dialogfeld "3D-Diagrammformat": Registerkarte "Titel"

Graphtitel

Text zur Verwendung als Titel für das Diagramm.

Oben

Positioniert den Titel über das Diagramm.

Unten

Positioniert den Titel unter das Diagramm.

Ausblenden

Blendet den Titel des Diagramms aus.


3D-Diagrammassistent

Zum Erstellen eines 3D-Diagramms können Sie die Befehle unter Diagramm im Menü Einfügen verwenden. Präziser können Sie die Formateinstellungen eines Diagramms beim Einfügen festlegen, wenn Sie den 3D-Diagrammassistenten verwenden.

So arbeiten Sie mit dem 3D-Diagrammassistenten:

  1. Klicken Sie auf die Position im Arbeitsblatt, an der das Diagramm eingefügt werden soll. Stellen Sie sicher, dass das Fadenkreuz angezeigt wird.

  2. Wählen Sie Diagramm \ 3D-Diagrammassistent im Menü Einfügen. Die erste Seite des 3D-Diagrammassistenten wird angezeigt.

  3. Wählen Sie den anzuzeigenden Typ von 3D-Diagramm aus, und klicken Sie auf "Weiter".

  4. Nehmen Sie die Auswahl für die Darstellung und Farbgebung des Diagramms auf den nachfolgenden Seiten des Assistenten vor. Klicken Sie auf &ldquo;Fertig stellen&rdquo;, damit ein Diagramm mit korrekten Achsen und einem leeren Platzhalter in das Arbeitsblatt eingefügt wird.

  5. Geben Sie Argumente in den Platzhalter ein.

  6. Klicken Sie auf eine Stelle außerhalb des Diagramms.

  7. Das Diagramm wird mit den im Assistenten festgelegten Einstellungen erstellt.


"Suchen" und "Minfehl" muss eine "Vorgabe" vorausgehen

"Suchen" und "Minfehl" muss jeweils eine entsprechende "Vorgabe" vorausgehen.

Mit dieser Fehlermeldung werden die Funktionen Suchen und Minfehl versehen, wenn ihnen keine entsprechende "Vorgabe" vorausgeht. Jeder Lösungsblock, der mit Suchen oder Minfehl endet, muss mit einem Bereich beginnen, der nur den Namen "Vorgabe" enthält.


Öffnen der mit einer Komponente verbundenen Anwendung

Nachdem Sie eine Anwendungskomponente in Ihr Mathcad-Arbeitsblatt eingefügt haben, können Sie mithilfe der Komponente Berechnungen in der mit ihr verbundenen Anwendung durchführen. Gehen Sie hierzu folgendermaßen vor:

  1. Doppelklicken Sie auf die Komponente im Mathcad-Arbeitsblatt. Die Komponente wird entweder an Ort und Stelle oder in einem eigenen Bearbeitungsfenster geöffnet.

  2. Bearbeiten Sie die Komponente Ihren Wünschen entsprechend.

  3. Klicken Sie auf das Mathcad-Arbeitsblatt, damit die Komponente die Werte neu berechnen kann und Sie in Mathcad weiterarbeiten können.

Wenn Sie auf eine Stelle außerhalb der Komponente klicken, werden die Eingabevariablen an die Komponente übertragen und den Ausgabevariablen in Mathcad-Feldern zugeordnet. Nachdem die Ausgabevariablen in Mathcad erstellt worden sind, können Sie sie mithilfe der vordefinierten Mathcad-Funktionen und -Operatoren für Felder Ihren Wünschen entsprechend ändern.


Genauigkeit und Ordnung der Ableitung

Die Genauigkeit sinkt, je höher die Ordnung der Ableitung ist. Dabei gilt im Allgemeinen, dass eine höhere Ordnung der Ableitung mit dem Sinken der Genauigkeit um eine Stelle einhergeht.


Aktivierung von Mathcad

Mathsoft hat für die Käufer von Einzelversionen von Mathcad einen Aktivierungsvorgang implementiert, um sicherzustellen, dass der Käufer eine lizenzierte Kopie der Software erworben hat.

Die Aktivierung schreibt die Mathcad-Installation durch die Identifizierung von Schlüsselmerkmalen Ihrer Hardwarekonfiguration auf Ihrem System fest. Wenn wesentliche Änderungen an der Hardwarekonfiguration Ihrer Workstation vorgenommen wurden, muss dieser Aktivierungsvorgang möglicherweise wiederholt werden. Sie müssen keine zusätzliche Lizenz erwerben, wenn Sie Mathcad deinstallieren und anschließend wieder neu installieren. Wenn der Installationsvorgang erneut ausgeführt werden muss, startet Mathcad einen Aktivierungsassistenten, der Sie durch den weiteren Vorgang führt.

Beim Aktivieren Ihrer Mathcad-Insatllation werden keine persönlichen Informationen an Mathsoft übermittelt, außer wenn dies für die Durchführung der Aktivierung nötig ist. Wenn Sie die Aktivierung beispielsweise per E-Mail durchführen möchten, müssen Sie eine E-Mail-Adresse angeben, damit Ihre Anfrage beareitet weden kann. Der Aktivierungsvorgang ist darauf ausgelegt, so anonym wie möglich zu sein, und wird lediglich für die Authentifizierung Ihrer Installation verwendet.


Aktives Arbeitsblatt

Das aktive Arbeitsblatt ist das Arbeitsblatt, auf das sich die meisten Menübefehle, Symbolleistenschaltflächen und Tastatureingaben auswirken. Welches Arbeitsblatt aktiv ist, erkennen Sie an der Titelleiste des jeweiligen Arbeitsblatt-Fensters. Die Titelleiste des aktiven Arbeitsblattfensters ist farblich hervorgehoben.


Mathcad-Add-Ins

Für verschiedene Anwendungen wurden spezielle Mathcad-Add-Ins erstellt. Mithilfe eines Add-In können Sie ein Mathcad-Objekt in eine andere Anwendung wie Visio, Excel, AutoCAD und VisSim einfügen. Im Bereich "Download" der Mathcad-Website (http://www.mathcad.com/) finden Sie eine vollständige Liste der erhältlichen Mathcad-Add-Ins sowie Informationen zum Herunterladen der Liste.


Operator "+1 Zeile"

Tastaturbefehl: ]

Erstellt eine neue Zeile innerhalb eines Programms bzw. erstellt ein Unterprogramm, wenn "+1 Zeile" in den Platzhalter eines Operators wie beispielsweise if eingefügt wird.


Hinzufügen eines Bereichs zu oder Entfernen eines Bereichs aus einer Markierung

Zum Hinzufügen eines Bereichs zu oder Entfernen eines Bereichs aus einer Gruppe von bereits markierten Bereichen gehen Sie wie folgt vor:

  1. Positionieren Sie den Mauszeiger auf den Bereich.

  2. Halten Sie die Taste Strg gedrückt, und klicken Sie auf den Bereich.

Beim Klicken müssen Sie unbedingt Strg gedrückt halten. Anderenfalls wird die Markierung der zuvor markierten Bereiche wieder aufgehoben.


Hinzufügen eines Titels zu einem Kreisdiagramm

Zum Hinzufügen eines Titels zu einem Kreisdiagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf das Diagramm, oder wählen Sie Diagramm / Kreisdiagramm im Menü Format, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte Beschriftungen.

  3. Geben Sie den Titel für das Diagramm in das Textfeld ein. Der Titel kann sowohl Groß- als auch Kleinbuchstaben enthalten.

  4. Klicken Sie auf die Schaltfläche "Oben" bzw. "Unten".

  5. Klicken Sie auf "Titel anzeigen". Lassen Sie dann durch Klicken auf "OK" den Titel des Diagrammbereichs anzeigen.

Zum Ausblenden des Titels deaktivieren Sie das Kontrollkästchen "Titel anzeigen". Um den Titel vollständig zu löschen, verwenden Sie die Rücktaste.


Einfügen eines Titels in ein X-Y-Diagramm

Zum Einfügen eines Titels in ein Diagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte Beschriftungen.

  3. Geben Sie den Titel für das Diagramm in das Textfeld ein. Der Titel kann sowohl Groß- als auch Kleinbuchstaben enthalten.

  4. Klicken Sie auf die Schaltfläche "Oben" bzw. "Unten".

  5. Klicken Sie auf "Titel anzeigen". Lassen Sie dann durch Klicken auf "OK" den Titel des Diagrammbereichs anzeigen.

Um den Titel aus dem Textfeld zu entfernen, klicken Sie auf "Abbrechen", damit der ursprüngliche Zustand des Textfelds für den Titel wiederhergestellt wird.

Zum Ausblenden des Titels deaktivieren Sie das Kontrollkästchen "Titel anzeigen". Um den Titel vollständig zu löschen, verwenden Sie die Rücktaste.


Hinzufügen und Entfernen von Eingabe- und Ausgabevariablen

Wenn Sie eine Anwendungskomponente einfügen, möchten Sie vielleicht Eingabevariablen oder Ausgabevariablen hinzufügen oder entfernen. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie einmal auf die Komponente, damit sie ausgewählt wird.

  2. Wenn Sie eine weitere Ausgabevariable hinzufügen möchten, wählen Sie im Kontextmenü den Befehl Ausgabevariable hinzufügen. Links neben ":=" wird ein neuer Platzhalter angezeigt .

  3. Wenn Sie eine weitere Eingabevariable hinzufügen möchten, wählen Sie im Kontextmenü den Befehl Eingabevariable hinzufügen. Am unteren Rand der Komponente wird ein neuer Platzhalter angezeigt.

  4. Wenn Sie eine Ausgabevariable löschen möchten, wählen Sie im Kontextmenü den Befehl Ausgabevariable entfernen. Der Ausgabeplatzhalter oder die Variable links neben ":=" wird daraufhin ausgeblendet. Wenn mehrere Ausgaben vorhanden waren, wird der letzte Ausgabeplatzhalter bzw. die letzte Variable nicht mehr angezeigt.

  5. Wenn Sie eine Eingabevariable löschen möchten, wählen Sie im Kontextmenü den Befehl Eingabevariable entfernen. Die Eingabevariable oder der Platzhalter im unteren Bereich der Komponente wird daraufhin nicht mehr angezeigt. Wenn mehrere Eingaben vorhanden waren, wird der Platzhalter ganz rechts nicht mehr angezeigt.

Wenn Sie Ein- oder Ausgabevariablen in die Excel-Komponente einfügen, müssen Sie festlegen, in welchen Zellen der Komponente die neue Eingabe gespeichert wird, und wo die neue Ausgabe erscheinen soll. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie einmal auf die Komponente, damit sie ausgewählt wird.

  2. Wählen Sie Eigenschaften im Kontextmenü.

  3. Klicken Sie entweder auf die Registerkarte "Eingaben" oder auf die Registerkarte "Ausgaben", und legen Sie für jede Ein- bzw. Ausgabe einen Zellenbereich fest.


Operator "Addition"

Tastaturbefehl: +

x + y

Gibt die Summe von x und y zurück.

Ist der Ausdruck so lang, dass er über den rechten Bildschirmrand hinausgeht, sollten Sie stattdessen Strg+Eingabe drücken. Daraufhin wird Folgendes eingefügt:

Operanden:

x und y sind Skalare.

x und y müssen von identischer Dimension sein.


Operator "Addition mit Zeilenumbruch"

Addition mit Zeilenumbruch

Tastaturbefehl: Strg+Eingabe

Wie "Addition", wobei jedoch die beiden Glieder in verschiedenen Zeilen stehen.

Operanden:

x und y sind Skalare.

x und y müssen von identischer Dimension sein.

Mit diesem Operator können Sie vermeiden, dass die Darstellung von Ausdrücken über den rechten Bildschirmrand hinausreicht und damit unübersichtlich wird.

Zum Umbrechen eines Ausdrucks mit diesem Operator gehen Sie wie folgt vor:

  1. Klicken Sie unmittelbar rechts neben dem Glied, das vor dem Pluszeichen steht, an dem der Ausdruck umgebrochen werden soll.

  2. Drücken Sie die Leertaste, bis alle Glieder, vom ersten bis zum ausgewählten Glied, sich zwischen den beiden Bearbeitungslinien befinden.

  3. Drücken Sie die Taste Entf. Das Pluszeichen unmittelbar nach den Bearbeitungslinien verschwindet.

  4. Drücken Sie jetzt Strg+Eingabe, um das Pluszeichen mit dem Zeilenumbruch einzugeben.

  5. Diesen Vorgang können Sie überall dort wiederholen, wo mehrere durch Pluszeichen verbundene Glieder vorhanden sind.


Dialogfeld "Erweiterte Optionen"

Im Dialogfeld "Erweiterte Optionen" finden Sie die folgenden Optionen und Schaltflächen:

Ableitungsschätzung

Damit wird das Verfahren zum näherungsweisen Berechnen der ersten partiellen Ableitungen gesteuert.

  • Wählen Sie "Nach vorne", um sich die Ergebnisse in einer Richtung vom aktuellen Punkt aus anzeigen zu lassen.

  • Wählen Sie "Zentral", um sich die Ergebnisse in zwei gegenläufigen Richtungen vom aktuellen Punkt aus anzeigen zu lassen. Dies kann zwar länger dauern, führt aber u. U. zu besseren Ergebnissen mit insgesamt weniger Iterationen.

Variablenschätzung

Damit wird das Verfahren zum Schätzen der Anfangswerte zu Beginn einer jeden Suche gesteuert.

  • Wählen Sie "Tangente", um von der Linientangente zur reduzierten Zielfunktion zu extrapolieren.

  • Wählen Sie "Quadratisch", um zum Minimum oder zum Maximum einer quadratischen Funktion zu extrapolieren, die der reduzierten Zielfunktion an deren jeweiligem Punkt angepasst ist.

Lineare Variablenprüfung

Die lineare Variablenprüfung erspart Ihnen Zeit, indem davon ausgegangen wird, dass alle unbekannten Variablen in allen Nebenbedingungen linear auftreten und dass die ersten partiellen Ableitungen in Bezug auf diese Variablen konstant sind.

Verwenden Sie diese Option nur, wenn Sie sicher sind, dass nichtlinear erscheinende Variablen sich nicht in lineare ändern werden.

Multistart

Der nichtlineare Lösungsalgorithmus versucht, anstelle einer lokalen Extremstelle, ein globales Maximum bzw. Minimum innerhalb des in Frage kommenden Bereichs zu finden.

Evolutionary

Findet gute, wenn auch nicht notwendigerweise optimale, Lösungen für Aufgabenstellungen, für die "klassische" Gradienten-Verfahren nicht ausreichen. Diese Verfahren setzen voraus, dass die zu lösenden Funktionen (Zielkoeffizienten und Nebenbedingungen) gleichförmige Funktionen der Variablen sind (beispielsweise sind die Gradienten dieser Funktionen an jedem Punkt stetig). Die Fähigkeit, zu einem lokalen Optimum zu konvergieren, hängt von dieser Annahme ab. Diese Funktionen haben bei Problemstellungen mit nicht gleichmäßigen oder gar nichtstetigen Funktionen Schwierigkeiten, eine Lösung zu erzielen. Bei solchen Problemen kann die Option "Evolutionary", die keine Annahmen bezüglich der zu lösenden Funktionen trifft, oftmals eine gute Lösung finden.

Sogar bei gleichmäßigen, nichtlinearen Aufgabenstellungen finden die "klassischen" Gradientenmethoden nur ein lokales Optimum und können möglicherweise eine bessere Lösung, die vom angegebenen Startpunkt weiter entfernt liegt, nicht erfassen. Die Option "Evolutionary" bietet Ihnen eine erheblich bessere Möglichkeit, die globale Optimalstelle in solchen Aufgabenstellungen zu finden.

Hinweise:

  • Diese erweiterten Optionen stehen für das Verfahren konjugierter Gradienten bzw. für Quasi-Newton-Verfahren zur Verfügung.

  • Diese Optionen richten sich an erfahrene Benutzer. Solche Optionen sollten Sie erst verwenden, wenn mit den Standardoptionen keine Lösung gefunden werden konnte bzw. wenn eine genaue Einflussnahme auf das Lösungsverfahren gewünscht wird.


Erweiterte Ansichtseinstellungen für ein 3D-Diagramm

Zum Steuern der Darstellungsweise eines 3D-Diagramms mit erweiterten Optionen gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Erweitert". Die Seite Erweitert enthält Optionen zum Formatieren der Ansicht und zum Festlegen der Details eines bestimmten Diagramms.

  3. Mit den Optionen auf der Seite haben Sie folgende Möglichkeiten:

    • Nebel in das Diagramm einfügen

    • Das Diagramm so anzeigen lassen wie bei der Ansicht aus der Distanz

    • Die Unterschiede bei der Höhe eines Diagramms festlegen

    • Das zu verwendende Farbschema wählen

    • Die Verwendung eines Farbschemas festlegen

    • Die glänzende Darstellung eines Diagramms festlegen

    • Die Transparenz eines Diagramms festlegen

    • Die Ausrichtung der Diagrammoberfläche mit den Diagrammlinien abstimmen

  4. Rufen Sie anschließend durch Klicken auf "Zuweisen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


Vorteile des automatischen Modus

Im automatischen Modus sind die im Fenster angezeigten numerischen Ergebnisse und Diagramme immer aktuell.


Vorteile der Verknüpfung mit einer Datei

  • Verweisen mehrere Arbeitsblätter auf dasselbe Bild, ist nur ein Exemplar dieses Bilds erforderlich.

  • Wenn Sie ein in mehreren Arbeitsblättern vorhandenes Bild verändern möchten, brauchen Sie nur eine einzige Bilddatei zu ändern. Änderungen an jedem einzelnen Arbeitsblatt sind nicht erforderlich.


Vorteile des manuellen Modus

Im manuellen Modus können Sie Arbeitsblätter schneller durchblättern, da während des Blätterns keine zeitaufwändigen Berechnungen durchgeführt werden müssen.


Algebraische Transformation

Dies ist das einfache Umwandeln eines mathematischen Ausdrucks in einen anderen, äquivalenten mathematischen Ausdruck.


Aliasing

Da die Fourier-Transformation eine diskrete Näherung einer kontinuierlichen Transformation ist, treten u. U. versetzte Oberwellen auf. Dieser Effekt wird Aliasing genannt. Um Aliasing zu vermeiden, gehen Sie wie folgt vor:

  • Stellen Sie sicher, dass das Signal eine endliche Bandbreite hat.

  • Stellen Sie sicher, dass die Messfrequenz mindestens das Doppelte der Bandbreite beträgt (Nyquist-Frequenz).


Ausgerichtete Ausgabetabellen

Ausgabetabelle mit Ausrichtung "Mitte":

Ausgabetabelle mit Ausrichtung "Oben":

Ausgabetabelle mit Ausrichtung "Unten":

Ausgabetabelle mit Ausrichtung "Über":

Ausgabetabelle mit Ausrichtung "Unter":


Ausrichten einer Ausgabetabelle

Zum Festlegen, wie eine Ausgabetabelle zu der angezeigten Variable oder dem Ausdruck ausgerichtet wird, gehen Sie wie folgt vor:

  1. Klicken Sie auf die Ausgabetabelle, um sie zu markieren.

  2. Klicken Sie mit der rechten Maustaste nochmals auf die Ausgabetabelle.

  3. Wählen Sie den Befehl Ausrichtung im Kontextmenü.

  4. Wählen Sie Oben, Mitte, Unten, Unter oder Über.


Ausrichtung

Textabsätze können entweder am linken oder am rechten Rand des Textbereichs ausgerichtet oder im Textbereich zentriert werden.

Zum Festlegen der Ausrichtung im Dialogfeld "Absatzformat" gehen Sie wie folgt vor:

  1. Markieren Sie Text innerhalb der Absätze.

  2. Wählen Sie Absatz im Menü Format.

  3. Nehmen Sie im Dialogfeld "Absatzformat" die gewünschten Änderungen vor, und klicken Sie auf "OK".

Stattdessen können Sie auch die drei Ausrichtungsschaltflächen [image] ganz rechts in der Symbolleiste "Formatierung" verwenden.


Alle Auswertungen ergaben einen Fehler oder ein komplexes Ergebnis.

Mathcad kann keine Punkte darstellen, weil keine reellen Werte zum Darstellen vorhanden sind. Diese Fehlermeldung kann angezeigt werden, wenn ein Fehler vorliegt oder wenn alle Werte imaginär sind.


Buchstaben

Bei Namen wird nach Groß-/Kleinschreibung und nach der Schriftart unterschieden. Auch die Schriftgröße sowie der Schriftgrad sind Kriterien. Zum Beispiel beziehen sich ein fettgedrucktes F und ein kursives F auf unterschiedliche Variablen.

Alle Zeichen in einem Namen müssen dieselbe Schriftart haben. Lateinische und griechische Buchstaben können jedoch im selben Namen verwendet werden.


Umgebungslicht

Das "Umgebungslicht" ist allgemeines Licht, das gleichmäßig auf den Bereich um ein Diagramm verteilt ist.


UND

Tastaturbefehl: Strg+Umschalt+7

x [image] yErgibt 1, wenn sowohl x als auch y ungleich null (wahr) sind. Anderenfalls wird 0 zurückgegeben.

Operanden:

x und y können reelle oder komplexe Skalare sein.

Hinweise:

  • Der Wert 0 steht für FALSCH, alle Werte ungleich Null stehen für WAHR.

  • UND berechnet zuerst x. Wird x als wahr betrachtet (Wert ungleich null), wird auch y berechnet. Daher können folgende Annahmen zu verschiedenen Ergebnissen führen:

0 [image] (2/0) = 0 (2/0 wird nie berechnet)

(2/0) [image] 0 ergibt einen Fehler (2/0 ergibt Singularitätsfehler)


Dialogfeld "Animation aufzeichnen"

Im Dialogfeld "Animation aufzeichnen" finden Sie die folgenden Optionen und Schaltflächen:

Von

Dient zur Eingabe des ersten Wertes für die integrierte Variable FRAME. Jeder Wert von FRAME erzeugt ein separates Bild in der Animationssequenz.

Bis

Dient zur Eingabe des letzten Wertes für die integrierte Variable FRAME. Jeder Wert von FRAME erzeugt ein separates Bild in der Animationssequenz.

Mit

Ermöglicht das Festlegen der Standardgeschwindigkeit, mit der die Animation wiedergegeben wird.

Da Sie die Wiedergabegeschwindigkeit auch während der Wiedergabe der Animation ändern können, ist dieser Wert nur dann von Bedeutung, wenn Sie Ihre Animation mit einer Tonspur versehen möchten.

Animieren

Durch Klicken auf diese Schaltfläche können Sie die Aufzeichnung der Animation starten. Diese Schaltfläche ist so lange abgeblendet, bis Sie in Ihrem Dokument einen Bereich für die Animation ausgewählt haben.

Speichern unter

Durch Klicken auf diese Schaltfläche können Sie eine aufgezeichnete Animation in einem für die meisten anderen Multimedia-Anwendungen geeigneten Format speichern.

Diese Schaltfläche steht nur dann zur Verfügung, wenn es etwas zu speichern gibt.

Optionen

Da Animationen in der Regel sehr viel Speicherplatz beanspruchen, speichert Mathcad sie in einem komprimierten Format. Wenn Sie auf diese Schaltfläche klicken, öffnet sich ein Dialogfeld mit einer Anzahl von Optionen, in dem Sie das zu verwendende Komprimierungsverfahren festlegen können.

FRAME (Zähler)

Zeigt den Wert der integrierten Variable FRAME entsprechend dem Bild im darüberliegenden Feld (Bildvorschau) an.

Bildvorschau

Zeigt die Bilder (Frames) Ihrer Animationssequenz an, während sie aufgezeichnet werden. Beim ersten Mal kann es einen Moment dauern, bis die einzelnen Bilder erscheinen. Nach Beendigung der Aufzeichnung können Sie diese jedoch wesentlich schneller abspielen.

Dieses Feld ist leer, bis Sie den zu animierenden Bereich auswählen und auf die Schaltfläche "Animieren" klicken.


Bildvorschau

Hier wird das erste Bild der Animation angezeigt, die wiedergegeben werden soll. Wenn keine Animation zur Wiedergabe verfügbar ist, wird dieses Feld nicht angezeigt.

Damit eine Animation verfügbar ist, müssen Sie entweder eine AVI-Datei öffnen oder im Dialogfeld "Animieren" eine Animation erstellen.


Anmerkungen zu einem 3D-Diagramm

Zum Einfügen von Anmerkungen in ein 3D-Diagramm gehen Sie folgendermaßen vor:

  1. Fügen Sie Text ein, oder importieren Sie eine Grafik in das Arbeitsblatt.

  2. Markieren Sie den Text, damit er hervorgehoben wird.

  3. Halten Sie die Maustaste gedrückt, und ziehen Sie den Cursor auf die Stelle im Diagramm, an der Sie die Anmerkung einfügen möchten.

  4. Lassen Sie die Maustaste los.

Zum Einfügen einer Anmerkung in ein 3D-Diagramm durch Positionieren einer Bitmap gehen Sie folgendermaßen vor:

  1. Kopiereren Sie die Bitmap aus einer anderen Anwendung in die Zwischenablage.

  2. Klicken Sie mit der rechten Maustaste auf das Diagramm.

  3. Wählen Sie Inhalte einfügen im Popup-Menü.

Zum Bearbeiten einer Anmerkung gehen Sie folgendermaßen vor:

  1. Wählen Sie die Anmerkung aus.

  2. Ziehen Sie die Anmerkung aus dem Diagramm

  3. Bearbeiten Sie die Anmerkung.

  4. Ziehen Sie die Anmerkung wieder in das Diagramm.

Zum Einfügen eines Titels in ein Diagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Titel", damit die Seite "Titel" aufgerufen wird.

  3. Geben Sie Text für den Titel in das Textfeld "Titel" ein.

  4. Klicken Sie auf "Oben" bzw. "Unten".

  5. Rufen Sie dann durch Klicken auf "Zuweisen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


Antisymmetrische Tensor-Funktion

(i,j,k) Diese Funktion gibt den vollständigen antisymmetrischen Tensor dritter Ordnung zurück. Falls zwei Argumente identisch sind, ist das Ergebnis 0. Das Ergebnis lautet 1 für gerade Permutationen und -1 für ungerade Permutationen.

Argumente:

i, j, und k müssen ganze Zahlen zwischen 0 und 2 (oder ORIGIN und ORIGIN+2) sein.

Hinweis:

Der antisymmetrische Tensor dritter Ordnung bestimmt, wie viele Male zwei Zahlen zu vertauschen sind, um wieder die Reihenfolge [0,1,2] aus einer beliebigen Reihenfolge [i,j,k] zu erhalten, die der Funktion übergeben wurde. Falls diese Anzahl gerade ist, gibt die Funktion den Wert 1 zurück, ist die Anzahl ungerade, ergibt diese Funktion eine -1.

Beispiel: Bei dem Tripel (2,0,1) lautet das Ergebnis 1, da in [2,0,1] zweimal (eine gerade Zahl) Zahlen vertauscht werden müssen, um [0,1,2] zu erhalten. Bei dem Tripel (0,2,1) lautet das Ergebnis -1, da in [0,2,1] nur einmal (eine ungerade Zahl) Zahlen vertauscht werden müssen, um [0,1,2] zu erhalten.


Anfügen von Daten an eine bereits vorhandene Datei (Funktion "ANFÜGEN")

Anfügen von Daten an eine bereits vorhandene Datei

ANFÜGEN("datei") Fügt eine einzelne Zahl an die Datei datei an.

Argumente:

datei ist der Pfad zu einer ASCII-Datendatei.

datei wird als Zeichenfolge eingegeben.

Die Funktion ANFÜGEN wird normalerweise zusammen mit einem durch eine Bereichsvariable beschriebenen Vektor verwendet, wie z. B. in:

i := 1 bis N

ANFÜGEN(&ldquo;datei.dat&rdquo;) :=

Im Beispiel oben wird die Liste der Zahlen im Vektor v an die bereits in datei.dat vorhandenen Zahlen angehängt.

ANFÜGEN funktioniert nur, wenn die Datei, an die Daten angefügt werden sollen, bereits vorhanden ist. Mithilfe von ANFÜGEN kann keine Datei angelegt werden. Die Funktion kann nur Daten an eine bereits vorhandene Datei anhängen.

WARNUNG: Diese Funktion dient lediglich zur Sicherstellung der Kompatibilität mit früheren Mathcad-Versionen. Die Funktion ist jedoch veraltet und sollte nicht mehr verwendet werden. Zum Anhängen von Daten an eine Datei sollte die Funktion PRNANFÜGEN verwendet werden.


Anfügen von Daten an eine bereits vorhandene Datei (Funktion "PRNANHÄNGEN")

Anhängen von Daten an eine bereits vorhandene Datei

PRNANHÄNGEN("datei") Hängt ein Feld an die Datei datei an.

Argumente:

datei ist entweder der Dateiname oder der vollständige Pfad zu einer strukturierten ASCII-Datendatei.

datei wird als Zeichenfolge eingegeben.

Die Anzahl der Spalten in datei muss mit der Anzahl der Spalten im Feld übereinstimmen.

Wenn die Datei datei noch nicht vorhanden ist, wird diese von PRNANHÄNGEN erstellt.

Beispiel:

PRNANHÄNGEN("c:\daten\ergebnis.prn") := A

A ist eine Matrix, deren Werte zu den Werten addiert werden, die bereits in der Datei ergebnis.prn im Verzeichnis c:\daten vorhanden sind.

Hinweise:

  • PRNANHÄNGEN ordnet die Daten in der ASCII-Datei entsprechend der ursprünglichen Matrix in Zeilen und Spalten an. Standardmäßig hängt PRNANHÄNGEN vier signifikante Ziffern in Spalten mit einer Breite von acht Ziffern an. Um dies zu ändern, wählen Sie den Befehl Arbeitsblattoptionen im Menü Extras, und klicken Sie im Dialogfeld auf die Registerkarte "Vordefinierte Variablen". Ändern Sie die Werte für GENAUIGKEITPRN und SPALTENBREITEPRN.

  • Wenn Sie das Argument dieser Funktion ändern, sollten Sie es stets aktualisieren. Klicken Sie dazu auf das Argument, und wählen Sie den Befehl Berechnen im Menü Extras.


Zuweisen einer anderen Gleichungsformatvorlage

Zum Ändern der mit einem bestimmten Namen oder einer bestimmten Zahl verknüpften Gleichungsformatvorlage gehen Sie wie folgt vor:

  1. Klicken Sie auf den Namen bzw. die Zahl.

  2. Wählen Sie Gleichungaus dem Menü Format.

  3. Wählen Sie im Dialogfeld "Gleichungsformat" ein Format aus der Dropdown-Liste. Sie finden hier mehrere vordefinierte Gleichungsformatvorlagen. Sie können aber auch mithilfe der verschiedenen "Benutzer"-Formatvorlagen eine neue Vorlage erstellen.

  4. Falls erforderlich, ändern Sie die Schriftattribute, die zu diesen Vorlagen gehören, indem Sie auf "Ändern..." klicken.

  5. Klicken Sie auf "OK", um die gewählte Formatvorlage dem gewünschten Namen zuzuweisen.

Bei Variablennamen müssen Sie auf die Schriftart achten. Wenn Sie z. B. eine Anweisung wie "x := 1" in Ihrem Dokument haben und Sie das Format in "x := 1" ändern, sind die x im weiteren Verlauf des Dokuments nicht definiert. Sie müssen diese dann mit dem gleichen Format verknüpfen, damit sie folgendermaßen aussehen: "x".


Näherungslösungen

Minfehl(var1, var2, ...) Gibt die Werte von var1, var2... zurück, die den Lösungen der Gleichungen und Ungleichungen in einem Lösungsblock am nächsten kommen.

Argumente:

var1, var2,... sind skalare Variablen im Gleichungssystem.

Verwenden Sie die Funktion wie folgt:

So ermitteln Sie mithilfe der Funktion minfehl die Näherungslösung eines Gleichungssystems:

  • Definieren Sie Schätzwerte für die unbekannten Variablen.

  • Geben Sie das Wort Vorgabe ein, um den Lösungsblock zu starten.

  • Geben Sie unter Vorgabe mithilfe Boolescher Operatoren Gleichungen und Ungleichungen ein.

  • Verwenden Sie die Funktion minfehl.

Hinweise:

  • Der Unterschied zwischen minfehl und suchen besteht darin, dass minfehl auch dann einen Wert zurückgibt, wenn der Lösungsalgorithmus die Lösung nicht weiter verbessern kann. Die Funktion suchen dagegen gibt eine Fehlermeldung aus, aus der hervorgeht, dass keine Lösung gefunden werden konnte.

  • Übergibt einen Skalar. Anderenfalls gibt die Funktion einen Vektor mit var1 als erstem Element, var2 als zweitem Element usw. zurück.

  • Der Algorithmus der Funktion Minfehl beinhaltet einen speziellen Lösungsprozess, bei dem aus mehreren verfügbaren Methoden eine geeignete Methode ausgewählt wird.

  • Hat das System mehrere Lösungen, hängt die zurückgegebene Lösung davon ab, welche Schätzwerte eingegeben wurden. Auch mit zusätzlich eingefügten Ungleichungen können Sie Mathcad zur Suche nach anderen Lösungen zwingen.

  • Wenn Sie das Erweiterungspaket "Solving and Optimization"(Expert Solver) erwerben und installieren, unterstützt die Funktion Minfehl die gemischte Integerprogrammierung, mit der Sie ganze oder binäre Zahlen als Lösungen erzwingen können.

Beispiel:

Näherungslösung an ein System nichtlinearer Gleichungen


Argumentliste

Dies ist die Liste der Variablen zwischen den Klammern in einer Funktion. Beispiel:

f(x, y, z) := x + y + z + w

Die Argumentliste wäre in diesem Fall:

x, y, z


Argument einer Funktion

Dieser Begriff bezieht sich auf alles, was zwischen den Klammern erscheint, wenn Sie eine Funktion verwenden oder definieren. Beispiel:


Argument zu groß

  • Argument zu groß

  • Ganze Zahl hier zu groß

  • Objekt zu groß

Im Allgemeinen das Ergebnis der Auswertung eines Ausdrucks mit einem Gleitkommawert, der größer ist als ca. 10 hoch 10.000.000.000.


Argumente in Funktionsdefinitionen müssen Namen sein.

Die markierte Funktionsdefinition enthält eine unzulässige Argumentliste. Eine gültige Funktionsdefinition beginnt wie folgt:

Funktionsname(Argumentliste) := ...

Die Argumentliste muss ein Name oder eine Liste von durch Kommas getrennten Namen sein. Jeder andere Ausdruck ist unzulässig.

Diese Fehlermeldung erscheint auch, wenn Sie eine ungültige Liste in einem anderen Zusammenhang erstellen, wie z. B. in der Liste der y-Achsenausdrücke für ein Diagramm.


Operator "Feldaddition"

Feldaddition

Tastaturbefehl: +

A + B

Addiert die Elemente von A zu den entsprechenden Elementen von B.

A + x

Addiert x zu jedem Element in A.

Operanden:

  • A und B sind Felder mit derselben Anzahl von Zeilen und Spalten.

  • Die Elemente von A und B müssen dieselben Dimensionen haben.

  • x ist ein beliebiger Skalar, reell oder komplex.

  • x muss dieselben Dimensionen haben wie die Elemente von A.


Feldursprung

Diese Konstante stellt den Anfangsindex aller Felder dar. Der Standardwert für ORIGIN ist 0. Um dies zu ändern, wählen Sie den Befehl Arbeitsblattoptionen im Menü Extras, und klicken Sie im Dialogfeld auf die Registerkarte "Vordefinierte Variablen".

Sie können ORIGIN auf eine beliebige ganze Zahl (positiv oder negativ) festlegen. Der Wert, den Sie für ORIGIN festlegen, wirkt sich auf alle Felder im Arbeitsblatt aus.


Anzeigen von Feldergebnissen in einer Ausgabetabelle

Eine Möglichkeit, Feldergebnisse anzeigen zu lassen, ist die Ausgabetabelle:

Ausgabetabellen verfügen über die folgenden Eigenschaften:

  • Sofern sich die Ergebnisse über einen Rand der Tabelle hinaus erstrecken, wird am entsprechenden Rand eine Bildlaufleiste angezeigt.

  • Damit alle Werte sichtbar werden, können Sie die Größe einer Ausgabetabelle ändern.

  • Sie können Werte aus einer Ausgabetabelle kopieren und an einem freien Platz auf Ihrem Arbeitsblatt, in einen Platzhalter oder in eine andere Anwendung einfügen.

  • Werte, die in einer Ausgabetabelle angezeigt werden, können Sie auch in eine externe Datendatei exportieren.

  • Andere Aspekte einer Ausgabetabelle, wie z. B. die Art und Weise, in der die Werte angezeigt werden, können Sie festlegen, wenn Sie auf die entsprechende Ausgabetabelle klicken und den Befehl Ergebnis im Menü Format wählen.

  • Wenn Sie auf eine Zelle mit der Notation für verschachtelte Felder klicken, wird das verschachtelte Feld temporär in einer Ausgabetabelle angezeigt.

  • Die Ausrichtung einer Ausgabetabelle in Bezug auf den Variablennamen links können Sie ebenfalls selbst festlegen.

  • Wenn Sie die Schriftart ändern wollen, in der die Werte in der Tabelle angezeigt werden, klicken Sie mit der rechten Maustaste auf die Tabelle, wählen Sie den Befehl Eigenschaften im Kontextmenü, und klicken Sie auf "Schriftart".

  • Um die Zeilen- und Spaltenbeschriftungen ein- bzw. auszublenden, klicken Sie mit der rechten Maustaste auf die Tabelle, wählen Sie den Befehl Eigenschaften im Kontextmenü, und klicken Sie auf "Spalten-/Zeilenbeschriftungen anzeigen".

  • Verwandte Themen: Ausgabetabelleneigenschaften: Dialogfeld "Anzeige"


Anzeigen von Feldergebnissen in Form einer Matrix

Eine Möglichkeit, Vektor- bzw. Matrixergebnisse anzeigen zu lassen, ist die Matrixform:

Wenn Sie einen großen Vektor oder eine große Matrix statt in einer Ausgabetabelle als Feld anzeigen lassen, werden lediglich die ersten 200 Zeilen und Spalten angezeigt. Mathcad weist mit einer Ellipse darauf hin, dass Zeilen und Spalten intern gespeichert sind, aber nicht angezeigt werden.


Operator "Tiefgestelltes Feld"

Tastaturbefehl: [

Gibt das n-te Element von v zurück. Wenn v kein ntes Element hat, erscheint eine entsprechende Fehlermeldung.

Gibt das mn-te Element von M zurück.Wenn M kein mntes Element hat, erscheint eine entsprechende Fehlermeldung.

Operanden:

v ist ein Spaltenvektor.

M ist ein Feld.

m und n müssen dimensionslose Zahlen sein.

Denken Sie daran, dass alle Zeilen und Spalten der Felder standardmäßig bei 0 beginnen. Um dies zu ändern, wählen Sie den Befehl Arbeitsblattoptionen im Menü Extras, und klicken Sie im Dialogfeld auf die Registerkarte "Vordefinierte Variablen".

Hinweis:

Verwenden Sie beim Zeichnen von Vektoren Indizes.


Operator "Feldsubtraktion"

Feldsubtraktion

Tastaturbefehl: -

A - B

Subtrahiert die Elemente von B von den entsprechenden Elementen von A. A und B müssen dieselbe Anzahl von Zeilen und Spalten haben.

A - x

Wenn A ein Feld und x ein Skalar ist, dann ist A - x ein Feld, das durch Subtrahieren von x von jedem Element in A gebildet wird.

Operanden:

A und B sind Matrizen mit derselben Anzahl von Zeilen und Spalten.

x ist ein Skalar.


Pfeilzeiger

Wenn der Mauszeiger als Pfeil dargestellt wird, bewirkt ein Mausklick Folgendes:

  • Sobald Sie in einen Leerraum klicken, wird ein Fadenkreuz an die betreffende Stelle gesetzt.

  • Wenn Sie in Text klicken, wird eine Einfügemarke in den Text gesetzt.

  • Wenn Sie in einen Rechenbereich klicken, wird ein Bearbeitungslinienpaar eingefügt.


ASCII-Datei

Eine ASCII-Datei ist eine einfache Textdatei, die Sie in einem einfachen Texteditor, wie z. B. dem Editor von Windows oder SimpleText auf dem Macintosh, öffnen können. Die Datei enthält nur Buchstaben, Zahlen, Leerzeichen, Tabulatoren und Zeilenschaltungen. Viele Anwendungen können ihre Dokumente in dieser Form speichern. Im Normalfall wird zum Speichern von Informationen in einer ASCII-Datei der Befehl Speichern unter gewählt und die entsprechende Option aus der Liste der Dateitypen ausgewählt.


Seitenverhältnis

Verhältnis zwischen Länge und Breite.


Mindestens eine Grenze muss unendlich sein.

Wenn die Integrationsroutine "Unendlich an der Integrationsgrenze" verwendet wird, muss mindestens ein Grenzwert des Integrals als unendlich oder minus unendlich definiert sein. Um das Unendlich-Zeichen einzugeben, drücken Sie Strg+Umschalt+Z.

Um eine andere Integrationsroutine als "Unendlich an der Integrationsgrenze" festzulegen, klicken Sie mit der rechten Maustaste auf das Integral, und wählen Sie eine andere Routine aus dem Popup-Menü.


Automatischer Berechnungsmodus

Wenn Sie Mathcad starten, ist der automatische Modus eingestellt. Dies bedeutet, dass Mathcad Ergebnisse im Arbeitsblattfenster automatisch aktualisiert.

Vorteile des automatischen Modus...

Nachteile des automatischen Modus...

Merkmale des automatischen Modus...

Aktivieren des automatischen Modus...


Nur in CGS verfügbar.

Nur in CGS verfügbar.

In SI, MKS und US nicht verfügbar.


Nur in MKS, SI und US verfügbar.

Nur in MKS, SI und US verfügbar.

Nicht in CGS verfügbar.


Nur in MKS und US verfügbar.

Nur in MKS und US verfügbar.

Nicht in CGS oder SI verfügbar.


Nur in SI verfügbar.

Nur in SI verfügbar.

Nicht in MKS, CGS oder US verfügbar.


Verfügbare Textformatvorlagen

Welche Textformatvorlagen verfügbar sind, hängt von der Arbeitsblattvorlage ab, aus der Sie Ihr Arbeitsblatt erstellen. Im Dialogfeld unten sehen Sie die Formatvorlagen, die in der Vorlage NORMAL.MCT enthalten sind, mit der Sie neue, leere Arbeitsblätter erstellen.


Vermeiden von nicht definierten Ausdrücken

Stellen Sie vor dem Verwenden einer Variable oder Funktion sicher, dass sie im Arbeitsblatt bereits früher definiert wurde.


Registerkarte "Achsen" für Kreisdiagramme

Auf der Registerkarte "Achsen" des Dialogfelds "Gerade markiertes Kreisdiagramm wird formatiert" finden Sie die folgenden Optionen und Schaltflächen:

Logarithmusskala

Ist diese Option aktiviert, verfügt die Kreisdiagrammachse über eine logarithmische Einteilung. Die Achsenbegrenzungen müssen positiv sein.

Gitterlinien

Wenn diese Option aktiviert ist, werden die Skalenmarkierungen auf der entsprechenden Achse durch Gitterlinien ersetzt.

Nummeriert

Wenn dieses Kontrollkästchen aktiviert ist, werden die Skalenmarkierungen auf der jeweiligen Achse nummeriert.

Markierungen anzeigen

Mit dieser Option können Sie Ihr Kreisdiagramm mit radialen Hilfslinien versehen. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie auf das Kontrollkästchen "Markierungen anzeigen". Oben links im Diagramm werden zwei weitere Platzhalter angezeigt.

  2. Klicken Sie auf einen der Platzhalter, und geben Sie den Wert ein, an dem eine Linie erscheinen soll. Wiederholen Sie diese Schritte für den anderen Platzhalter, um eine zweite radiale Hilfslinie hinzuzufügen.

Autom. Gitterweite

Wenn dieses Kontrollkästchen aktiviert ist, wird die Anzahl der Skalenmarkierungen automatisch ausgewählt.

Anzahl Gitterlinien

Mit dieser Option können Sie angeben, wie viele Gitterlinien erscheinen sollen, wenn "Autom. Gitterweite" nicht aktiviert ist. Geben Sie eine ganze Zahl zwischen 2 und 99 ein. Achten Sie darauf, dass Sie keine zu große Zahl eingeben. Ist die Zahl der Teilstriche zu groß, kann es passieren, dass die Beschriftungen der einzelnen Teilstriche zu dicht beieinander liegen.

Gitterfarbe

Legt die Farbe der Gitterlinien im Graph fest. Diese Option wird verfügbar, wenn Sie für die x-Achse, die y-Achse oder beide die Option "Gitterlinien" aktivieren. Klicken Sie auf die Schaltfläche "Gitterfarbe", wählen Sie eine Farbe im Dialogfeld "Farbe", und klicken Sie auf "OK".

"Achsenstil" &ndash; "Rundum", "Kreuz", "Kein"

Hiermit legen Sie fest, ob sich die Achsen in der Mitte des Diagramms schneiden sollen (Option "Kreuz") oder ob sie das Diagramm in einem Kreis umschließen sollen (Option "Rundum"). Wenn Sie "Kein" wählen, werden die Achsen nicht angezeigt.


Registerkarte "Achsen" für X-Y-Diagramme

Die folgenden X-Y-Diagramm-Optionen sind auf der Registerkarte "Achsen" verfügbar:

Logarithmusskala

Ist diese Option aktiviert, verfügt die jeweilige Achse über eine logarithmische Einteilung. Die Achsenbegrenzungen müssen positiv sein.

Gitterlinien

Wenn diese Option aktiviert ist, werden die Skalenmarkierungen auf der entsprechenden Achse durch Gitterlinien ersetzt.

Nummeriert

Wenn dieses Kontrollkästchen aktiviert ist, werden die Skalenmarkierungen auf der jeweiligen Achse nummeriert.

Autom. Skalierung

Die entsprechende Achsenbegrenzung wird auf die erste Hauptskalenmarkierung hinter dem Ende der Daten festgelegt. Ist die automatische Skalierung nicht aktiviert, werden die Achsengrenzen mit den Datengrenzen übereinstimmend festgelegt. Jedes X-Y-Diagramm wird standardmäßig automatisch auf beiden Achsen skaliert.

Um "Autom. Skalierung" zu deaktivieren und das Diagramm bis zum Rand des Diagrammbereichs zu zeichnen, klicken Sie mit der rechten Maustaste auf das Diagramm und wählen Format im Kontextmenü. Klicken Sie auf das Kontrollkästchen "Autom. Skalierung" für eine Achse, wenn Sie sie deaktivieren möchten.

Markierungen anzeigen

Ermöglicht es Ihnen, Ihr Diagramm mit einer oder zwei horizontalen oder vertikalen Linien zu versehen. Wenn diese Option aktiviert ist, erscheinen auf der Achse zwei zusätzliche Platzhalter. Eine vertikale Linie fügen Sie hinzu, indem Sie auf einen der Platzhalter unter der x-Achse klicken und eingeben, an welcher Stelle die Linie gezeichnet werden soll. Für eine horizontale Linie führen Sie diesen Schritt in einem der Platzhalter links neben der y-Achse aus. Wählen Sie dann den Befehl Berechnen im Menü Extras, um das Diagramm neu zeichnen zu lassen.

Autom. Gitterweite

Wenn dieses Kontrollkästchen aktiviert ist, wird die Anzahl der Skalenmarkierungen automatisch ausgewählt. Ist die Option nicht aktiviert, müssen Sie im Feld "Anzahl Gitterlinien" die Anzahl der Teilstriche eingeben.

Anzahl Gitterlinien

Mit dieser Option können Sie angeben, wie viele Teilstriche (Haupt- und Hilfsstriche) erscheinen sollen, wenn "Autom. Gitterweite" nicht aktiviert ist. Geben Sie eine ganze Zahl von 2 bis 99 ein. Achten Sie darauf, dass Sie keine zu große Zahl eingeben. Ist die Zahl der Teilstriche zu groß, kann es passieren, dass die Beschriftungen der einzelnen Teilstriche zu dicht beieinander liegen.

Gitterfarbe

Legt die Farbe der Gitterlinien im Graph fest. Diese Option wird verfügbar, wenn Sie für die x-Achse, die y-Achse oder beide die Option "Gitterlinien" aktivieren. Klicken Sie auf die Schaltfläche "Gitterfarbe", wählen Sie eine Farbe im Dialogfeld "Farbe", und klicken Sie auf "OK".

"Achsenformat" – "Kasten", "Kreuz", "Kein"

Mit dieser Option legen Sie fest, wo im Diagramm, wenn überhaupt, sich die Achsen kreuzen sollen. Zur Wahl stehen die Option "Kreuz" (Achsen schneiden sich in der Mitte des Diagramms), "Kasten" (Achsen schneiden sich in der linken unteren Ecke des Diagramms) und "Kein" (Achsen werden gar nicht angezeigt).

Gleiche Skalierung

Wenn diese Option aktiviert ist, haben die x- und die y-Achse die gleiche Skaleneinteilung. Dies bedeutet, dass dann, wenn ein Zentimeter auf der x-Achse für 2 Einheiten steht, ein Zentimeter auf der y-Achse ebenfalls 2 Einheiten entspricht.

Ist diese Option nicht aktiviert, verfügen x- und y-Achse über nicht voneinander abhängige Skaleneinteilungen.


Achseneinstellungen für ein 3D-Diagramm

Zum Auswählen der Eigenschaften der Achse für ein 3D-Diagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Achsen". Auf der Seite "Achsen" werden drei Registerkarten zum Formatieren der drei Achsen angezeigt.

  3. Klicken Sie zum Formatieren einer Achse auf das entsprechende Achsenregister. Mit den Optionen auf der Seite haben Sie folgende Möglichkeiten:

    • Zeichnen von Gitterlinien oder Teilstrichen

    • Festlegen der Farbe und der Stärke der Gittelinien

    • Anzeigen von Zahlen auf den Rastern

    • Festlegen eigener Achsenbegrenzungen durch Deaktivieren von Autom. Skalierung und Eingeben von Mindestwerten und Höchstwerten

    • Festlegen der Farbe und der Stärke der Achsen

    • Beschriftungen für Achsen hinzufügen

    • Festlegen eines eigenen Gitters durch Deaktivieren von Autom. Gitterweite und Angeben der Anzahl der Gitterlinien.

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.

Achsenstil

Zum Festlegen der Achsenanordnung gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Allgemein", damit die Seite "Allgemein" geöffnet wird. Geben Sie mit den Optionen im Abschnitt Achsenformat die Werte für "Rundum", "Ecke" oder "Gleiche Skalierung" ein. Klicken Sie auf "Keine", um die Achsen zu verbergen.

  3. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


Achseneinstellungen in Kreisdiagrammen

Zum Auswählen der Merkmale jeder Achse gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf das Diagramm, oder wählen Sie Diagramm Þ Kreisdiagramm im Menü Format, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Achsen".

  3. Nehmen Sie die erforderlichen Änderungen vor.

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


Achseneinstellungen für X-Y-Diagramme

Zum Auswählen der Merkmale jeder Achse gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf das Diagramm, oder wählen Sie Diagramm Þ X-Y-Diagramm im Menü Format, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte X-Y-Achsen.

  3. Nehmen Sie die erforderlichen Änderungen vor.

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


Axum

Axum ist eine Mathsoft-Software für die Erstellung von technischen Graphen und die Analyse von Daten. Mit Axum haben Sie Zugriff auf mehr als 50 zwei- und dreidimensionale Graphtypen. Sie können mit der Komponente "Axum" Axum-Diagramme in Ihr Arbeitsblatt einfügen, die auf Mathcad-Variablen basieren.


Eigenschaften der Axum-Komponente: Graph

Eigenschaften der Axum-Komponente: Graph-Eigenschaften

Mithilfe der Optionen auf der Registerkarte "Graphtyp" können Sie festlegen, welche Art von Graph mit der Komponente "Axum" erstellt wird.

Achsentyp

Zeigt den aktuellen Axum-Achsentyp an.

Diagrammtyp

Zeigt den aktuellen Axum-Diagrammtyp an.

Achsen-/Diagrammtyp auswählen

Öffnet das Dialogfeld "Achsen-/Diagrammtyp auswählen", in dem Sie den gewünschten Achsentyp und den Diagrammtyp aus Listenfeldern auswählen können, zum Beispiel "Log Y Line" und "Streuung".

Anzahl der Eingaben

Sie können die Anzahl der Eingaben der Graph-Komponente verändern. Die Axum-Komponente ist auf vier Eingaben beschränkt.

Für Bedingungsvariablen letzte Eingabe verwenden

Sie können die letzte Eingabe in der Eingabeliste als Bedingungsvariable festlegen.


Hintergrundebeneneinstellungen für ein 3D-Diagramm

Zum Festlegen der Darstellung von Hintergrundebenen in einem 3D-Diagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Hintergrundebenen". Die Seite "Hintergrundebenen" enthält drei Registerkarten zum Formatieren der drei Hintergrundebenen.

  3. Klicken Sie auf die Registerkarte der Hintergrundebene, die Sie formatieren möchten. Mit den Optionen auf der Seite haben Sie folgende Möglichkeiten:

    • Zeichnen von Gitterlinien oder Untergitterlinien

    • Zeichnen von Teilstrichen oder Unterteilstrichen

    • Bestimmen der Farbe und der Stärke der Gitterlinien und der Untergitterlinien

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


Rücktaste, Binäroperation


Säulenlayouteinstellungen (für 3D-Säulendiagramme)

Zum Festlegen des Layouts der Säulen in einem 3D-Säulendiagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Spezial".

  3. Die Seite "Spezial" enthält im Abschnitt "Säulendiagramm-Layout" folgende Optionen:

Matrix

Gestapelt

Nebeneinander

Abstand

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


Vermeiden Sie Endlosschleifen.

Achten Sie darauf, dass sich der Wert des Testausdrucks irgendwo in der Iteration tatsächlich ändert. Andernfalls geraten Sie in eine Endlosschleife. Sollten Sie in diese Situation geraten, können Sie die Berechnung mithilfe der Esc-Taste abbrechen.


Erstellen von Feldern, die bei einem anderen Element als Null beginnen

Standardmäßig beginnen Felder bei Element Eins. Sie können dies ändern, indem Sie den Wert der vordefinierten Variable ORIGIN mit einem der folgenden Schritte ändern:

  • Wählen Sie den Befehl Arbeitsblattoptionen im Menü Extras, und klicken Sie im Dialogfeld auf die Registerkarte "Vordefinierte Variablen".

oder

  • Legen Sie im Arbeitsblatt eine globale Definition für ORIGIN fest (dabei sind nur Großbuchstaben zulässig).

Wenn Sie ORIGIN in etwas anderes als Null ändern, sind manche Elemente möglicherweise dann nicht mehr vorhanden. Wenn Sie zum Beispiel ORIGIN in Eins ändern, weist Mathcad nicht mehr ein Element Null für Vektoren oder eine nullte Zeile und Spalte für Matrizen auf. Es wird eine Fehlermeldung angezeigt, wenn Sie versuchen, auf ein Element zuzugreifen, das nicht mehr vorhanden ist.


Besselfunktionen

Mathcad unterstützt alle Besselfunktionen für komplexe Argumente und in fraktionellen oder negativen Ordnungen. Diese werden untenstehend zusammengefasst. Alle Besselfunktionen, außer der Airyschen Funktion und der sphärischen Besselfunktion, werden nach der Eingabe von .sc nach dem Funktionsnamen skaliert wiedergegeben. Der Maßstab der skalierten Darstellung wird unterhalb des Tabelleneintrags angegeben.

Argumente:

In jedem Fall gilt, wenn nicht anders angegeben:

z ist ein dimensionsloser komplexer Skalar.

m ist eine reelle Zahl.

Besselfunktionen erster und zweiter Art

J0(z) Gibt J0(z), die nullte Ordnung der Besselfunktion der ersten Art, zurück.

J1(z) Gibt J1(z), die erste Ordnung der Besselfunktion der ersten Art, zurück.

Jn(m, z) Gibt Jm(z), die m-te Ordnung der Besselfunktion der zweiten Art, zurück.

Y0(z) Gibt Y0(z), die nullte Ordnung der Besselfunktion der zweiten Art, zurück.

Y1(z) Gibt Y1(z), die erste Ordnung der Besselfunktion der zweiten Art, zurück.

Yn(m, z) Gibt Jm(z), die m-te Ordnung der Besselfunktion der zweiten Art, zurück.

Der Faktor des Maßstabs der skalierten Versionen beträgt exp(-|Im(z)|).

Modifizierte (hyperbolische) Besselfunktionen

I0(z) Gibt I0(z), die nullte Ordnung der modifizierten Besselfunktion der ersten Art, zurück.

I1(z) Gibt I1(z), die erste Ordnung der modifizierten Besselfunktion der ersten Art, zurück.

In(m, z) Gibt Im(z), die m-te Ordnung der modifizierten Besselfunktion der zweiten Art, zurück.

K0(z) Gibt K0(z), die nullte Ordnung der modifizierten Besselfunktion der zweiten Art, zurück.

K1(z) Gibt K1(z), die erste Ordnung der modifizierten Besselfunktion der zweiten Art, zurück.

Kn(m, z) Gibt Km(z), die m-te Ordnung der modifizierten Besselfunktion der zweiten Art, zurück.

Der Faktor des Maßstabs skalierter modifizierter Besselfunktionen der ersten Art (I) beträgt exp(-|Re(z)|). Der Faktor des Maßstabs skalierter modifizierter Besselfunktionen der zweiten Art (K) beträgt exp(z).

Hankelfunktionen

H1(m, z) Gibt die Hankelfunktion der ersten Art (Besselfunktion der dritten Art) zurück.

H2(m, z) Gibt die Hankelfunktion der zweiten Art (Besselfunktion der dritten Art) zurück.

Der Faktor des Maßstabs der skalierten Versionen beträgt exp(-|Im(z)|).

Airysche Funktionen

Ai(z) Gibt die Airysche Funktion der ersten Art zurück.

Bi(z) Gibt die Airysche Funktion der zweiten Art zurück.

In diesem Fall sind keine skalierten Versionen verfügbar.

Bessel-Kelvin-Funktionen

bei(m,x) Gibt den Wert der imaginären Bessel-Kelvin-Funktion m-ter Ordnung zurück.

ber(m,x) Gibt den Wert der reellen Bessel-Kelvin-Funktion m-ter Ordnung zurück.

In diesem Fall muss das Argument x reell und m eine ganze, nicht negative Zahl sein.

Sphärische Besselfunktionen

js(m,z) Gibt den Wert der sphärischen Besselfunktion erster Art, m-ter Ordnung zurück.

ys(m,z) Gibt den Wert der sphärischen Besselfunktion zweiter Art, m-ter Ordnung zurück.

In diesem Fall sind keine skalierten Versionen verfügbar.

Hinweis:

Sehr große positive oder negative Werte von z oder m können möglicherweise Überlauf- oder Unterlauffehler verursachen. Wenn Ihre Berechnungen diese Werte benötigen, können Sie möglicherweise anstelle dessen die skalierten Versionen der Funktionen verwenden.


Beta-Verteilung

Verteilungsgeneratoren für die Beta-Verteilung:

dbeta(x,s1,s2) Gibt die Wahrscheinlichkeitsdichte zurück.

pbeta(x,s1,s2) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qbeta(x,s1,s2) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rbeta(m,s1,s2) Gibt einen Vektor aus m Zufallszahlen zurück, die die Beta-Verteilung aufweisen.


Binäroperator

Ein Operator mit zwei Operanden. Beispielsweise gilt "+" als Binäroperator, da er stets zwei Operanden miteinander verbindet, also "x + y". Hier sind x und y die beiden Operanden.


Binomial-Verteilung

Verteilungsgeneratoren für die Binomial-Verteilung:

dbinom(k,n,p) Gibt die Wahrscheinlichkeitsdichte zurück.

pbinom(k,n,p) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qbinom(p,n,r) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rbinom(m,n,p) Gibt einen Vektor aus m Zufallszahlen zurück, die die Binomial-Verteilung aufweisen.


Wiederherstellen der ursprünglichen Größe einer Bitmap

Wenn Sie die Größe einer Bitmap geändert haben, können Sie die ursprüngliche Größe und das Seitenverhältnis folgendermaßen wiederherstellen:

  1. Klicken Sie auf das Bild.

  2. Wählen Sie Eigenschaften aus dem Menü Format, und klicken Sie auf die Registerkarte "Anzeige".

  3. Klicken Sie auf die Option "In Originalgröße anzeigen".

  4. Klicken Sie auf "OK".


Bitmap-Grafiken

Ein im Windows-Standard-Grafikformat gespeichertes Bild.

Viele Windows-Anwendungen, beispielsweise Paintbrush, das im LIeferumfang von Windows enthalten ist, können Bitmap-Grafiken erstellen.

Gespeicherte Bitmap-Grafiken haben normalerweise die Erweiterung .BMP.


Bearbeiten eines importierten Grafikbildes

Zum Bearbeiten eines Grafikbildes nach dem Einfügen in das Arbeitsblatt gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf die Grafik.

  2. Stammt die Grafik aus einer Anwendung, die die Aktivierung in Fremdanwendungen unterstützt, wird das Grafikobjekt in einem gestrichelten Rahmen dargestellt und in Mathcad werden anstelle der eigenen Menüs und Symbolleisten die der Quellanwendung angezeigt. Stammt die Grafik hingegen aus einer Anwendung, die die Aktivierung in Fremdanwendungen nicht unterstützt oder handelt es sich um ein verknüpftes Objekt, so wird ein eigenes Fenster für die Bearbeitung geöffnet.

  3. Nehmen Sie die erforderlichen Änderungen vor.

Hinweis:

Wenn Sie eine Bitmap mit dem Befehl "Bild" einfügen oder ein Bild als Bitmap einfügen, können Sie die Bearbeitung nicht mit den obigen Schritten vornehmen.


Importieren von Grafiken mit der Maus

Zum Importieren eines veknüpften Objekts direkt aus einer anderen Anwendung gehen Sie folgendermaßen vor:

  1. Öffnen Sie die Quellanwendung.

  2. Ordnen Sie das Mathcad-Fenster und das Fenster der Quellanwendung nebeneinander auf dem Bildschirm an.

  3. Wählen Sie die Grafik in der Quellanwendung aus.

  4. Halten Sie die Maustaste gedrückt, und ziehen Sie den Cursor auf das Mathcad-Arbeitsblatt.

  5. Lassen Sie die Maustaste los, um die Grafik im Arbeitsblatt abzulegen.


Importieren eines Grafikbildes aus der Zwischenablage

Zum Importieren eines Grafikbildes aus einer anderen Anwendung über die Zwischenablage gehen Sie folgendermaßen vor:

  1. Kopieren Sie das Bild in die Zwischenablage.

  2. Klicken Sie mit der Maus auf die gewünschte Bildposition.

  3. Wählen Sie den Befehl Einfügen oder Inhalte einfügen aus dem Menü Bearbeiten, um das Bild in das Arbeitsblatt einzufügen.

Hinweis:

Wenn Sie Einfügen wählen, wird das Bild aus der Zwischenablage anhand der Standardinformationen eingefügt, die zusammen mit dem Bild in der Zwischenablage gespeichert sind. Soll das Bild als bestimmte Art von Objekt eingefügt werden (Bitmap, verknüpftes Objekt oder eingebettetes Objekt), wählen Sie den Befehl Inhalte einfügen.


Ändern der Größe von Grafikbereichen

Zum Ändern der Länge und der Breite eines Grafikbereichs gehen Sie wie folgt vor:

  1. Klicken Sie in den Grafikbereich. Dadurch wird er in ein Markierungsrechteck eingeschlossen. Drei Haltepunkte werden eingeblendet.

  2. Setzen Sie den Zeiger auf einen der Haltepunkte am unteren oder rechten Rand des Bereichs. Die Form des Cursors ändert sich zu einem Doppelpfeil.

  3. Verschieben Sie die Maus bei gedrückter Maustaste. Der Grafikbereich wird in Richtung der Mausbewegung erweitert.

  4. Lassen Sie die Maustaste los, wenn der Grafikbereich die gewünschte Größe hat.


Menü "Buch"

Anmerkungen in Buch

Änderungen hervorheben

Abschnitt speichern

Alle Änderungen speichern

Originalabschnitt einsehen

Geänderten Abschnitt einsehen

Abschnitt wiederherstellen

Alles wiederherstellen


Boolescher Ausdruck

Dies ist ein Ausdruck, dessen Ergebnis entweder "wahr" oder "falsch" ist. Beispiel:

"1 > 2" ist ein Boolescher Ausdruck, weil sein Wert "FALSCH" ist.

"x = 2" ist ein Boolescher Ausdruck, weil er je nach dem Wert von "x", entweder "WAHR" oder "FALSCH" sein kann.

"1 + 1" ist KEIN Boolescher Ausdruck, weil er weder "WAHR" noch "FALSCH", sondern einfach nur "2" ist.


Symbolleiste "Boolesche Operatoren"

Mit den Schaltflächen der Symbolleiste "Boolesche Operatoren" haben Sie schnellen Zugriff auf Boolesche und logische Operatoren. Sie können sehen, wozu die einzelnen Schaltflächen dienen, wenn Sie den Cursor im Haupt-Arbeitsblattfenster über die Schaltfläche setzen, bis:

  • eine QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche angezeigt wird.

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion angezeigt wird.


Unterer Rand

Dabei handelt es sich um den Abstand zwischen dem unteren Rand des Papierblatts und dem unteren Rand des Druckbereichs. Wenn Ihr Arbeitsblatt mit einer Fußzeile versehen ist, erscheint diese innerhalb des Randbereichs an dessen oberer Grenze.


Kästchenzeiger

Wenn der Zeiger so aussieht, können Sie einen ausgewählten mathematischen Ausdruck an eine neue Stelle kopieren. Folgendermaßen erhalten Sie diesen Zeiger:

  • Klicken Sie auf einen Ausdruck.

  • Halten Sie die Strg-Taste und die Maustaste gedrückt.

Ziehen Sie den Zeiger in einen leeren Bereich oder auf einen Platzhalter, und lassen Sie die Maustaste los, damit der ausgewählte Ausdruck abgelegt wird.


Übernehmen von Daten aus Excel in Mathcad

Übernehmen von Daten aus Excel in ein Arbeitsblatt

Sie können Daten aus Excel in Mathcad übernehmen, um dort anhand der Daten Berechnungen anzustellen.

Wie möchten Sie die Daten übernehmen?

  • Nur einmal, über Kopieren und Einfügen

  • Nur einmal, über eine Datendatei

  • Ich möchte eine dynamische Verknüpfung zur Excel-Datei anlegen, damit eventuelle Änderungen in der Excel-Kalkulationstabelle automatisch in Mathcad übernommen werden.

  • Ich möchte eine dynamische Verknüpfung zur Excel-Datei anlegen, um bessere Kontrolle über gänderte Daten zu haben und um die Funktionen von Excel nutzen zu können.

Nur einmal, über Kopieren und Einfügen

Diese Methode ist sinnvoll, wenn der Umfang der zu übernehmenden Daten nur gering ist. Zum Kopieren von Daten aus Excel und Einfügen in Mathcad befolgen Sie die Anweisungen zum Einfügen von Daten aus der Zwischenablage.

Nur einmal, über eine Datendatei

Wenn Sie eine Excel-Kalkulationstabelle besitzen, in der Daten enthalten sind, können Sie die Daten in Mathcad importieren und als Feld speichern. Hierzu befolgen Sie die Anweisungen zum Importieren von Daten aus einer Datendatei.

Ich möchte eine dynamische Verknüpfung zur Excel-Datei anlegen, damit eventuelle Änderungen in der Excel-Kalkulationstabelle automatisch in Mathcad übernommen werden.

Wenn Sie eine Excel-Kalkulationstabelle besitzen, in der Daten enthalten sind, können Sie die Daten mit der Komponente "Dateieingabe" in Mathcad einlesen. Die Komponente übernimmt Daten nach Mathcad und speichert sie als Feld. Außerdem stellt sie eine dynamische Verknüpfung zwischen Mathcad und der Kalkulationstabelle her. Sobald sich die Daten in der Excel-Kalkulationstabelle ändern, werden die Änderungen von Mathcad übernommen. Zum dynamischen Übernehmen von Daten aus Excel befolgen Sie die Anweisungen zum Lesen von Daten aus einer Datendatei.

Ich möchte eine dynamische Verknüpfung zur Excel-Datei anlegen, um bessere Kontrolle über gänderte Daten zu haben und um die Funktionen von Excel nutzen zu können.

Mit der Excel-Komponente können Sie die Excel-Funktionen in Ihrem Mathcad-Arbeitsblatt verwenden. Zudem werden mehr Optionen zur Verfügung gestellt, welche Daten mit Excel ausgetauscht werden sollen.


B-Spline-Interpolation

bspline(vx,vy,u,n) Gibt einen Vektor mit den Koeffizienten einer B-Spline vom Grad n für die Daten in vx und vy zurück, wobei die Knoten, die durch die Werte in u angezeigt werden, gegeben sind. Der zurückgegebene Vektor wird zum ersten Argument der Funktion interp.

interp(vs,vx,vy,x) Gibt einen B-Spline-interpolierten Wert von vy an einem Punkt x zurück, wobei vs das Ergebnis der Funktion bspline ist.

Argumente:

vx ist ein Vektor aus reellen Datenwerten in aufsteigender Reihenfolge. Diese entsprechen den x-Werten.

vy ist ein Vektor aus reellen Datenwerten. Diese entsprechen den y-Werten. Enthält ebenso viele Elemente wie vx.

u ist ein reeller Vektor mit n-1 weniger Elementen als vx (wobei n 1, 2 oder 3 ist). Die Elemente in u müssen in aufsteigender Reihenfolge angeordnet sein. Die Elemente enthalten die Werte der Knoten für die Interpolation. Das erste Element in u muss kleiner gleich dem ersten Element in vx sein. Das letzte Element in u muss kleiner gleich dem letzten Element in vx sein.

n ist eine ganze Zahl gleich 1, 2 oder 3 und gibt den Grad der individuellen stückweisen linearen (n=1), quadratischen (n=2) oder kubischen (n =3) Polynomanpassungen an.

vs ist ein Vektor, der von bspline generiert wird.

x ist der Wert der unabhängigen Variable, an der das Ergebnis interpoliert werden soll. Dieser Wert sollte innerhalb des von vx angegebenen Bereichs liegen.

Mit der B-Spline-Interpolation können Sie eine Kurve durch eine Reihe von Punkten laufen lassen. Diese Kurve wird berechnet, indem drei nebeneinander liegende Punkte als Grundlage genommen werden, durch die ein Polynom vom Grad n geführt wird. Diese Polynome werden dann an den Knoten miteinander verbunden, sodass sie die endgültige Kurve bilden.


Von B-Spline zurückgegebener Vektor

Die Elemente im Vektor werden durch Bspline wie folgt zurückgegeben:

  • Das erste Element ist 4 und gibt an, dass der Vektor das Ergebnis der Funktion Bspline ist.

  • Das zweite Element ist die Koeffizientenmatrix für die B-Spline-Anpassung.

  • Das dritte Element ist die Intervallmatrix, die der Anpassung entspricht.

Der von Bspline zurückgegebene Vektor sollte stets an interp weitergegeben werden.


Zeichenfolgefunktionen

Die folgenden Funktionen eignen sich für die Arbeit mit Zeichenfolgen:

verkett(S1,S2)

Hängt die Zeichenfolge S2 an das Ende von S1 an. Gibt eine Zeichenfolge zurück.

fehl(S)

Gibt die Zeichenfolge S als Fehlermeldung zurück.

IsScalar(x)

Gibt 1 zurück, wenn x eine reelle oder komplexe Zahl ist, andernfalls 0.

IsString(x)

Gibt 1 zurück, wenn x eine Zeichenfolge ist, andernfalls 0.

zflänge(S)

Bestimmt die Zahl der Zeichen in der Zeichenfolge S. Gibt eine ganze Zahl zurück.

subzf(S,n,m)

Extrahiert eine Subzeichenfolge von S, die mit dem Zeichen an Position n beginnt und höchstens m Zeichen aufweist. Die Argumente m und n müssen ganze Zahlen sein.

strtpos(S,SubS,x)

Sucht die Startposition der Subzeichenfolge SubS in S, die an Position x in S beginnt.

zfinzahl(S)

Wandelt eine Zahlen-Zeichenfolge S in eine Konstante um.

zahlinzf(x)

Wandelt die Zahl x in eine Zeichenfolge um.

zfinvek(S)

Wandelt eine Zeichenfolge S in einen Vektor aus ASCII-Codes um.

vekinzf(v)

Wandelt einen Vektor aus ASCII-Codes in eine Zeichenfolge um.


Aufzählungszeichen

Sie können Absätzen innerhalb eines Textbereiches runde schwarze Aufzählungszeichen zuweisen. Im Beispiel unten sind die drei Absätze mit Aufzählungszeichen versehen:

  • Zeile 1

  • Zeile 2

  • Zeile 3


Deaktivieren der automatischen Auswahl der Integrationsmethode

Deaktivieren der automatischen Auswahl

Bei der Auswertung eines Integrals wird automatisch eine geeignete Integrationsmethode verwendet. Wenn Sie stattdessen jedoch selbst festlegen möchten, welche Integrationsmethode zum Einsatz kommt, müssen Sie die Option Autom. Auswahl deaktivieren und anschließend eine andere Integrationsmethode auswählen. Gehen Sie dazu wie folgt vor:

  1. Geben Sie das Integral ein, und lassen Sie von "Autom. Auswahl" ein Ergebnis zurückgeben.

  2. Klicken Sie mit der rechten Maustaste auf das Integral.

  3. Wählen Sie Autom. Auswahl im Kontextmenü, um diese Option zu deaktivieren.

  4. Klicken Sie nochmals mit der rechten Maustaste auf das Integral.

  5. Wählen Sie aus dem Kontextmenü die gewünschte Integrationsmethode aus.

Das Integral wird automatisch neu ausgewertet, und zwar mit der von Ihnen ausgewählten Methode. Diese Integrationsmethode wird von nun an so lange angewendet, bis Sie eine andere Methode auswählen oder wieder die Option Autom. Auswahl aktivieren.


Symbolleiste "Taschenrechner"

Über die Symbolleiste "Taschenrechner" können Sie schnell auf grundlegende mathematische Operatoren und Funktionen zugreifen. Sie können sehen, wozu die einzelnen Schaltflächen dienen, wenn Sie den Cursor im Haupt-Arbeitsblattfenster über die Schaltfläche setzen, bis:

  • eine QuickInfo (ein kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche angezeigt wird und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion angezeigt wird.


Symbolleiste "Differential/Integral"

Über die Symbolleiste "Differential/Integral" haben Sie schnellen Zugriff auf diese Operatoren. Sie können sehen, wozu die einzelnen Schaltflächen dienen, wenn Sie den Cursor im Haupt-Arbeitsblattfenster über die Schaltfläche setzen, bis:

  • Eine QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche angezeigt wird.

  • In der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion angezeigt wird.


Keine Lösung für dieses Gleichungssystem gefunden.

Keine Lösung für dieses Gleichungssystem gefunden. Versuchen Sie es mit einem anderen Schätzwert, oder überprüfen Sie, ob wirklich eine Lösung existiert.

In manchen Fällen kann eine Lösung nicht einwandfrei ermittelt werden. Dies ist der Fall, wenn der Unterschied zwischen aufeinander folgenden Annäherungen an die Lösung größer als TOL ist, und Folgendes der Fall ist:

  • Der Integrallöser kann den Fehler nicht weiter reduzieren.

  • Der Integrallöser befindet sich an einem Punkt, an dem es keine vorzuziehende Richtung gibt. Darum besteht für den Lösungsalgorithmus keine Basis für weitere Iterationen.

  • Der Integrallöser erreicht die Grenze seiner Rechengenauigkeit. Dies ist oft der Fall, wenn Sie für TOL einen Wert unter 10^-15 festlegen.

Stellen Sie sicher, dass eine Lösung möglich ist. Versuchen Sie dann Folgendes:

  • Erhöhen Sie den Wert von TOL,

  • Verwenden Sie die Funktion minfehl statt der Funktion Suchen,

  • Verwenden Sie einen anderen Schätzwert,

  • Fügen Sie eine Ungleichheit hinzu, um einen unerwünschten Haltepunkt zu vermeiden, bzw.

  • Ändern Sie die Parameter des Lösungsalgorithmus oder das Lösungsverfahren.


Keine Eingabe mit Einheiten oder Dimensionen zulässig.

In diesem Ausdruck werden dort Einheiten verwendet, wo Einheiten nicht zulässig sind.

Einheiten sind nicht zulässig in:

  • den Argumenten der meisten Funktionen,

  • in Exponenten und

  • in hoch- und tiefgestellten Indizes.

Wenn Sie einen Ausdruck verwenden möchten, der Einheiten enthält, dividieren Sie ihn erst durch EinhVon(ausdruck), damit die Einheiten aus dem Ausdruck gekürzt werden.


So viele Punkte können nicht dargestellt werden.

Sie haben versucht, mehr Punkte darzustellen, als in einem Diagramm möglich sind. Versuchen Sie, die Anzahl der Punkte auf maximal 150.000 zu beschränken.


Ein Ausdruck mit Einheiten kann nicht mit einer komplexen Zahl potenziert werden.

Dieser Ausdruck enthält Einheiten, und Sie versuchen, ihn mit einer komplexen Zahl zu potenzieren. Sie können Ausdrücke mit Einheiten nur mit einer reellen Zahl potenzieren.

Wenn Sie einen Ausdruck, der Einheiten enthält, mit einer komplexen Zahl potenzieren möchten, dividieren Sie ihn erst mithilfe von EinhVon(ausdruck) durch seine Einheiten, damit sie aus dem Ausdruck gekürzt werden.


Diese Zahl ist nicht verständlich.

Dieser Ausdruck enthält eine Ziffer oder ein Dezimalzeichen an einer Stelle, wo dies nicht zugelassen ist. Wenn Sie beispielsweise versehentlich ".452." eingeben, wird diese Fehlermeldung angezeigt.


Auswertung einer Ableitung n-ter Ordnung nur möglich, wenn n=0,1..5.

Die Ordnung ist nicht eine der folgenden Zahlen: 0,1,2...5. Wenn Sie eine höhere Ordnung auswerten möchten, tun Sie dies symbolisch.


Es können nur positive Werte in Diagrammen dargestellt werden, wenn logarithmische Achsen verwendet werden.

Dieses xy- bzw. Kreisdiagramm hat eine logarithmische Achse, in der entweder die Begrenzungen oder einige der Werte nicht positiv sind.

Negative Zahlen und Null können nirgendwo auf eine logarithmische Achse gesetzt werden.


Konvergenz gegen eine Lösung nicht möglich. Zu viele Integratorschritte aufgetreten.

Vom Algorithmus für diese Differentialgleichungsberechnung wurde keine Lösung gefunden. Ändern Sie Ihre Schätzwerte für die unbekannten Anfangsbedingungen. Möglicherweise ist jedoch für die von Ihnen angegebenen Grenzwerte keine Lösung vorhanden.


Keine Konvergenz gegen eine Lösung möglich. Die Integrandfunktion weist möglicherweise...

Keine Konvergenz gegen eine Lösung möglich. Die Integrandfunktion weist möglicherweise eine Singularität auf, oder das Integral ist unendlich.

Ergebnisse mit Integralen, Ableitungen und den Funktionen wurzel, suchen oder minfehl erfordern Wiederholung. Falls nach vielen Wiederholungen aufeinanderfolgende Schätzungen weiterhin um mehr als die erforderliche Toleranz abweichen, wird diese Fehlermeldung angezeigt.

Versuchen Sie, eine größere TOL festzulegen. Wenn Sie mit den Funktionen wurzel, suchen und minfehl arbeiten, können Sie es auch mit einem anderen Schätzwert versuchen.


Eine Variable kann in einem Ausdruck nur einmal definiert werden.

Sie haben versucht, dieselbe Variable zweimal in derselben Definition auszuwerten. Diese Fehlermeldung wird z. B. angezeigt, wenn Sie einen Vektor auf der linken Seite eines := erstellen und denselben Namen in mehr als einem Element verwenden.


Nicht bestimmbar, welche Einheiten das Ergebnis...

Nicht bestimmbar, welche Einheiten das Ergebnis dieser Operation haben soll.

Sie haben einen Ausdruck mit Einheiten mit einem Element potenziert, das eine Bereichsvariable oder einen Vektor enthält. Daher haben Sie keine Möglichkeit, die Dimensionen des Ergebnisses zu bestimmen. Wenn ein Ausdruck mit Einheiten definiert ist, kann er nur mit einer festen reellen Zahl potenziert werden.


Stapelüberlauf

Dieser Ausdruck kann nicht ausgewertet werden, da er zu kompliziert oder durch sich selbst definiert ist.

Diese Fehlermeldung wird normalerweise angezeigt, wenn Sie versuchen, eine durch sich selbst definierte Funktion zu definieren. Dies ergibt eine rekursive Funktionsdefinition ohne Abschlussbedingung. Sie können diesen Fehler vermeiden, indem Sie einen neuen Funktionsnamen verwenden. Zum Beispiel ergibt "f(x):=f(x) + 5" den Fehler "Stapelüberlauf", kann aber in f2(x):=f(x)+2 geändert werden.

Generell sollte auf beiden Seiten eines ":=" nur dann derselbe Funktionsname verwendet werden, wenn die Funktion rekursiv definiert werden soll.


Dieser Ausdruck kann nicht ausgewertet werden. Möglicherweise verursacht er einen Überlauf...

Dieser Ausdruck kann nicht ausgewertet werden. Möglicherweise verursacht er einen Überlauf oder eine Endlosschleife.

Diese Funktionsdefinition enthält vermutlich zu viele verschachtelte Funktionen. Falls die Funktion durch sich selbst definiert ist, kann sie auch in einer Endlosschleife gefangen sein. Wenn Sie zum Beispiel eine Funktion wie f(x):=x definieren und anschließend f(x):=f(x)+5, wird diese Meldung angezeigt. Eine Lösung wäre es, der zweiten Funktion einen anderen Namen zuzuweisen. Sie können zum Beispiel die Definition g(x):=f(x)+5 festlegen.


Diese Funktion kann nicht ausgewertet werden, wenn ihr Argument Null ist.

Diese Funktion ist bei Null nicht definiert.


Die gewünschte Datendatei kann nicht gefunden werden.

Mathcad konnte die Datendatei bzw. einen anderen Dateityp, auf den Sie verweisen, nicht finden. Sorgen Sie dafür, dass die Datei am angegebenen Speicherort wirklich vorhanden ist.

Wenn Sie eine Funktion wie READPRN oder WRITEPRN verwenden, stellen Sie sicher, dass Sie das Argument als einen Pfadnamen zur Datendatei eingegeben haben.


Ein Umrissdiagramm kann nur ein Feld enthalten.

Sie haben mehrere Felder in den Platzhalter eines Umriss- oder Flächendiagramms eingegeben. In diesem Platzhalter ist jeweils nur ein Feld möglich, weil Umriss- und Flächendiagramme jeweils nur eine einzelne Fläche darstellen können.


Operation kann nicht auf das ganze Feld angewendet werden

Diese Operation kann nicht auf das ganze Feld auf einmal angewendet werden. Versuchen Sie, mit "Vektorisieren" die Operation Element für Element auszuführen.

Eine der Funktionen oder Skalare.

Diese Fehlermeldung wird z. B. angezeigt, wenn Sie versuchen, einen Vektor durch einen anderen zu dividieren.

Wenn Sie eine Funktion oder einen Operator allen Elementen in einem Vektor oder einer Matrix zuweisen möchten, verwenden Sie den Operator "Vektorisieren".


Ein System mit so vielen Gleichungen kann nicht aufgelöst werden.

So viele Gleichungen dürfen nicht im Gleichungssystem vorkommen. Sie können nichtlineare Gleichungssysteme mit bis zu 200 Variablen und lineare Systeme mit bis zu 500 Variablen lösen. Mit dem Extension Pack "Solving and Optimization" (Expert Solver) für Mathcad können Sie nichtlineare Systeme mit bis zu 250 Variablen, lineare Systeme mit bis zu 1.000 Variablen und quadratische Systeme mit bis zu 1000 Variablen lösen.


Etwas in dieser Datendatei ist nicht verständlich.

Etwas in dieser Datendatei ist nicht verständlich. Wenn diese Datei aus einem Tabellenkalkulationsprogramm stammt, muss sie im Format "Nur Text" (ASCII-Text) gespeichert worden sein.

Die Datei, auf die Sie mit LESEN bzw. PRNLESEN zugreifen wollen, hat nicht das benötigte Format.

  • Die Datei muss eine ASCII -Datei sein, wobei die einzelnen Zahlen durch Leerzeichen oder Tabulatoren voneinander getrennt sein müssen.

  • Wenn Sie PRNLESEN verwenden, müssen alle Zeilen in der Datendatei über die gleiche Anzahl von Werten verfügen. (Zeilen ohne Werte werden ignoriert.)

Falls die Datei das erforderliche Format aufweist und diese Fehlermeldung weiterhin angezeigt wird, sollten Sie Text aus der Datei entfernen.


Name dieser Funktion ist nicht verständlich.

Name dieser Funktion ist nicht verständlich. Verwenden Sie für die Multiplikation "*".

Folgender Fall ist eingetreten:

  • Sie haben einen Ausdruck verwendet, als wäre er eine Funktion, und

  • dieser Ausdruck bildet einen ungültigen Funktionsnamen.


Definitionsweise dieser Bereichsvariable nicht verständlich.

Sie haben eine Bereichsvariable mit einem nicht verständlichen Bereich definiert. Wenn Sie einen Bereich definieren, müssen Sie eine der folgenden Formen verwenden:

Bvar := n1 ..n2 (Eingabe: Bvar:n1;n2)

Bvar := n1,n2 ..n3 (Eingabe: Bvar:n1,n2;n3)

Die Definition eines Bereichs für eine Bereichsvariable darf höchstens 1 Komma und 1 Semikolon enthalten. Wenn Sie die zweite Form benutzen, muss der Wert von n2 zwischen den Werten von n1 und n3 liegen, darf aber nicht gleich n1 sein.


In einem Lösungsblock kann keine Bereichsvariable verwendet werden.

Diese Meldung wird angezeigt, wenn Sie eine Bereichsvariable an falscher Stelle verwenden, zum Beispiel in einem Lösungsblock.

Wenn Sie Iterationen mit einem Lösungsblock ausführen wollen, sollten Sie versuchen, die Funktion in Abhängigkeit von dem Lösungsblock zu definieren und diese Funktion zur Iteration zu verwenden.


Eine genaue Auswertung ist an mindestens einem der angegebenen Werte nicht möglich.

Diese Fehlermeldung besagt, dass Sie versucht haben, eine Funktion für einen Wert zu berechnen, der über den Genauigkeitsbereich der Funktion hinausgeht.

Eine solche Meldung wird z. B. angezeigt, wenn Sie versuchen, sin(10^100) auszuwerten. Da sich der Wert von sin(10^100) nach der Einerstelle von 10^100 richtet, hätte ein von Mathcad zurückgegebener Wert keine signifikanten Stellen. Anstelle eines sehr ungenauen Wertes wird eine solche Fehlermeldung angezeigt.


Catalansche Konstante


Cauchy-Verteilung

Verteilungsgeneratoren für die Cauchy-Verteilung:

dcauchy(x,l,s) Gibt die Wahrscheinlichkeitsdichte zurück.

pcauchy(x,l,s) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qcauchy(p,l,s) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rcauchy(m,l,s) Gibt einen Vektor aus m Zufallszahlen zurück, die die Cauchy-Verteilung aufweisen.


Ändern der Begrenzungen der Achse von Kreisdiagrammen

Ändern der Begrenzungen der radialen Achse von Kreisdiagrammen

Zum Deaktivieren der standardgemäßen Begrenzungen der radialen Achse gehen Sie folgendermaßen vor:

  1. Klicken Sie auf das Kreisdiagramm, damit es ausgewählt wird. Es werden zwei weitere Zahlen rechts neben dem Kreisdiagramm angezeigt.

  2. Legen Sie den Ursprung des Kreisdiagramms fest, indem Sie auf die untere Zahl klicken und eine neue Zahl eingeben.

  3. Legen Sie eine Achsenbegrenzung für den Umfang des Diagramms fest, indem Sie auf die Zahl im oberen Platzhalter klicken und eine neue Zahl eingeben.

  4. Klicken Sie auf eine Stelle außerhalb des Diagrammbereichs.

Es ist nicht möglich, die standardgemäßen Winkelachsenbeschränkungen außer Kraft zu setzen. Für sie sind immer 0 Grad und 360 Grad festgelegt.


Ändern der Achsenbegrenzungen von X-Y-Diagrammen

Zum Ersetzen der standardgemäßen Achsenbegrenzungen gehen Sie folgendermaßen vor:

  1. Klicken Sie in das Diagramm, damit es ausgewählt wird. Es werden vier Zahlen angezeigt, für jede Achsenbegrenzung eine.

  2. Legen Sie die Achsenbegrenzung auf der horizontalen Achse fest, indem Sie auf die Zahl unter der entsprechenden x-Achsenbegrenzung klicken und sie durch die Zahl ersetzen, bei der die Achse enden soll.

  3. Führen Sie für die vertikale Achse dieselben Schritte bei der Zahl links neben der entsprechenden Achsenbegrenzung durch.

  4. Klicken Sie auf eine Stelle außerhalb des Diagrammbereichs, damit das Diagramm mit den Zahlen neu angezeigt wird, die Sie als Achsenbegrenzung festgelegt haben.


Wechseln der Drucker

Wenn die Druckausgabe für das Arbeitsblatt in eine Datei oder auf einen anderen Drucker umgeleitet werden soll, gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Drucken aus dem Menü Datei. Daraufhin öffnet sich das Dialogfeld "Drucken".

  2. Klicken Sie auf "Druckereinrichtung", um das Dialogfeld "Druckereinrichtung" zu öffnen. Geben Sie den gewünschten Drucker an. Klicken Sie anschließend auf "OK".

  3. Soll der Ausdruck in eine Datei umgeleitet werden, aktivieren Sie das Kontrollkästchen "Ausgabe in Datei".


Ändern der Darstellung eines Steuerelements

Zum Ändern der Darstellung eines MathSoft-Steuerelements gehen Sie wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf das Steuerelement, und wählen Sie im Kontextmenü den Befehl Mathsoft (Steuerelement) Objekt Þ Eigenschaften.

  2. Im Dialogfeld Eigenschaften stehen Ihnen verschiedene Optionen zur Verfügung, mit deren Hilfe Sie die Darstellung des Steuerelements verändern können. So können Sie hier z. B. den Typ des MathSoft-Steuerelements vom Standardtyp "Kontrollkästchen" in den Typ "Schaltfläche" ändern. Treffen Sie Ihre Auswahl.

Abbildung 1: Dialogfeld "Steuerelement Schaltfläche &ndash; Eigenschaften"

  3. Klicken Sie auf "Zuweisen", um das Dialogfeld "Steuerelement Schaltfläche &ndash; Eigenschaften" offen zu lassen und eine Vorschau auf die Änderungen in Ihrem Arbeitsblatt zu erhalten. Klicken Sie auf "OK", um das Dialogfeld "Steuerelement Schaltfläche &ndash; Eigenschaften" zu schließen und zu Ihrem Arbeitsblatt zurückzukehren.

Hinweis:

  • Wenn Sie eine Schaltfläche schnell mit einem bestimmten Bild versehen möchten, erstellen Sie das Bild, und kopieren Sie es in die Zwischenablage. Klicken Sie mit der rechten Maustaste auf das MathSoft-Steuerelement, und wählen Sie im Kontextmenü den Befehl Mathsoft (Steuerelement) Objekt Þ Bitmap einfügen. Stattdessen können Sie auch auf der Registerkarte "Bilder" im Dialogfeld "Eigenschaften" nach einer Bitmap- oder einer Symboldatei suchen.


Ändern der Farbe für die Hervorhebung von Gleichungen oder Text

Standardmäßig ist die Hintergrundfarbe direkt unter einem hervorgehobenen Bereich gelb. Soll dies für alle hervorgehobenen Bereiche geändert werden, gehen Sie wie folgt vor:

  1. Wählen Sie Farbe / Hervorhebung im Menü Format.

  2. Wählen Sie eine Farbe im aufgerufenen Dialogfeld, oder klicken Sie auf "Farben definieren", wenn Sie eine eigene Farbe mischen möchten.

Dies wirkt sich auf alle hervorgehobenen Bereiche im Arbeitsblatt aus. Zum Ändern der Hervorhebungsfarbe für nur einen Bereich gehen Sie folgendermaßen vor:

  1. Klicken Sie auf einen ausgewählten Bereich.

  2. Wählen Sie "Eigenschaften" im Menü Format.

  3. Klicken Sie auf die Registerkarte "Anzeige".

  4. Klicken Sie auf "Farbe auswählen", um eine andere Hintergrundfarbe als die Standardhintergrundfarbe festzulegen.

  5. Klicken Sie auf "OK".


Ändern der Farbe für hervorgehobene Änderungen in einem E-Buch

Ändern der Farbe für hervorgehobene Änderungen in einem E-Book

Standardmäßig werden alle an einem E-Book vorgenommenen Änderungen in einer anderen Farbe hervorgehoben.

Sie können diese Farbe wie folgt ändern:

  • Wählen Sie Farbe / Anmerkung im Menü Format.

Mathcad zeigt eine Palette mit verfügbaren Farben an.


Ändern der Darstellung eines Operators

Wenn Sie einen Operator in ein Arbeitsblatt einfügen, hat er ein bestimmtes, standardmäßiges Aussehen. Sie können jedoch das Aussehen bestimmter Operatoren selbst bestimmen. Dazu gehören:

Definitionssymbol
Globales Definitionssymbol
Multiplikation
Ableitung
Tiefgestellter Literalindex
Gleich

Zum Ändern der Darstellung dieser Operatoren im ganzen Arbeitsblatt gehen Sie wie folgt vor:

  1. Wählen Sie Arbeitsblattoptionen im Menü Extras.

  2. Klicken Sie auf die Registerkarte Anzeige. Wählen Sie dann aus dem Listenfeld neben dem jeweiligen Operator die gewünschte Anzeigeoption.

  3. Klicken Sie auf "OK".

Zum Ändern der Darstellung eines Operators in einem oder mehreren einzelnen Ausdrücken gehen Sie wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf den Operator.

  2. Wählen Sie [Operatorname] anzeigen als aus dem Popup-Menü.


Ändern der Schriftart für alle Konstanten

Zum gleichzeitigen Ändern der Schriftart für alle Konstanten im Arbeitsblatt gehen Sie wie folgt vor:

  1. Wählen Sie Gleichung aus dem Menü Format.

  2. Stellen Sie sicher, dass im Dialogfeld die Option Konstanten gewählt ist.

  3. Klicken Sie auf "Ändern", und wählen Sie die gewünschten Schriftattribute aus.

  4. Klicken Sie auf "OK", um die Schriftattribute allen Konstanten im Arbeitsblatt zuzuweisen.

  5. Aus optischen Gründen sollten Sie sich überlegen, ob Sie die Schriftart für alle Variablen ändern möchten.

Wenn Sie die Schriftart nur für eine bestimmte Konstante ändern wollen, und nicht für alle Konstanten gleichzeitig, müssen Sie der betreffenden Konstanten eine eigene benutzerdefinierte Formatvorlage zuweisen.


Ändern der Schriftart für alle Variablen

Zum gleichzeitigen Ändern der Schriftart für alle Variablen im Arbeitsblatt gehen Sie wie folgt vor:

  1. Wählen Sie Gleichung aus dem Menü Format.

  2. Stellen Sie sicher, dass im Dialogfeld die Option Variablen gewählt ist.

  3. Klicken Sie auf "Ändern", und wählen Sie die gewünschten Schriftattribute aus.

  4. Klicken Sie auf "OK", um die Schriftattribute allen Variablen im Arbeitsblatt zuzuweisen.

  5. Aus optischen Gründen sollten Sie überlegen, ob Sie die Schriftart für alle Konstanten ändern möchten.

Wenn Sie die Schriftart für eine bestimmte Variable ändern wollen, und nicht für alle Variablen gleichzeitig, müssen Sie der entsprechenden Variable eine eigene benutzerdefinierte Formatvorlage zuweisen.


Ändern der Schriftart für eine bestimmte Variable oder Konstante

Zum Ändern der Schriftart für eine bestimmte Variable oder Konstante muss deren Formatvorlage geändert werden. Dieses Verfahren besteht aus zwei Schritten. Der erste Schritt ist obligatorisch, der zweite optional.

Zuweisen einer anderen Gleichungsformatvorlage zu einer markierten Variablen oder Konstanten

Ändern der mit der Gleichungsformatvorlage verknüpften Schriftartattribute

Bei Variablennamen müssen Sie auf die Schriftart achten. Wenn Sie z. B. eine Anweisung wie "x := 1" in Ihrem Dokument haben und Sie das Tag in "x := 1" ändern, sind die x im weiteren Verlauf des Dokuments nicht definiert. Sie müssen diese dann mit einem neuen Attribut verknüpfen, damit sie folgendermaßen aussehen: x.


Besonderheiten des symbolischen Rechnens

Wenn ein algebraischer Ausdruck zurückgegeben werden soll, verwenden Sie symbolisches Rechnen. Wenn eine Zahl zurückgegeben werden soll, verwenden Sie numerisches Rechnen.

Das symbolische Rechnen bietet unter anderem folgende Vorzüge:

  • Die Beziehungen zwischen Variablen werden explizit wiedergegeben.

  • Die Ergebnisse sind unabhängig von Rundungsfehlern, numerischer Instabilität und anderen Problemen bei der numerischen Berechnung.

Folgende Nachteile können beim symbolischen Rechnen auftreten:

  • Die entstehenden Ausdrücke können sehr kompliziert werden.

  • Die genaue Form der Antwort ist oft schwer zu beeinflussen.


In Variablen- und Funktionsnamen zugelassene Zeichen

Variablen- und Funktionsnamen können folgende Zeichen enthalten:

  • Groß- und Kleinbuchstaben
  • Ziffern 0 bis 9
  • das Symbol für Unendlich
  • das Primzeichen ` (Tastaturbefehl Strg+F7)
  • Griechische Buchstaben
  • Unterstrich ( _ )
  • Prozentzeichen ( % )
  • Literalindizes


Zeichen suchen und ersetzen

Mit den Dialogfeldern zum Suchen und Ersetzen können Sie zahlreiche Ziffern, Buchstaben und andere Zeichen in einem Arbeitsblatt suchen und gegebenenfalls ändern. Ziffern und Buchstaben können in jedem Bereich eines Arbeitsblatts vorkommen. Andere Zeichen, zum Beispiel runde Klammern, finden Sie nur in Textbereichen und Zeichenfolgen. Aus der folgenden Tabelle können Sie ersehen, welche Zeichen Sie in welchen Bereichen suchen können.

Unterstütztes Zeichen: | Eingabe im Dialogfeld: | Durchsuchte Bereiche:
Buchstaben und Ziffern | Buchstaben und Ziffern | Alles
Griechische Buchstaben | Eingabe von "\" gefolgt vom entsprechenden lateinischen Zeichen | Rechnen
Punkt | Eingabe von "." | Alles (sucht im Rechenbereich nach dem Operator für tiefgestellter Literalindizes)
Runde Klammern | Eingabe von "(" bzw. ")" | Text und Zeichenfolgen
Komma | Eingabe von "," | Text und Zeichenfolgen
Leerzeichen | Drücken der Leertaste | Text und Zeichenfolgen
Plus und Minus | Eingabe von "+" bzw. "-" | Text und Zeichenfolgen
Tabulator | Eingabe von "^t" | Text
Absatzzeichen | Eingabe von "^p" | Text
Winkelzeichen | Eingabe von "^" | Text und Zeichenfolgen
Zeilenumbruch | Eingabe von "^L" | Text
Umgekehrter Schrägstrich | Eingabe von "^\" | Text


Tschebyscheffsche Polynomfunktionen

Tcheb(n,x) Gibt den Wert des Tschebyscheffschen Polynoms vom Grad n der ersten Art bei x zurück.

Ucheb(n,x) Gibt den Wert des Tschebyscheffschen Polynoms vom Grad n der zweiten Art bei x zurück.

Argumente:

n ist eine nicht negative ganze Zahl.

x ist ein reeller Skalar.

Das Tschebyscheffsche Polynom der ersten Art ist eine Lösung für die folgende Differentialgleichung:

Das Tschebyscheffsche Polynom der zweiten Art ist eine Lösung der folgenden Differentialgleichung:


Dialogfeld "Rechtschreibung"

Wenn die Rechtschreibprüfung ein falsch geschriebenes Wort findet, wird das Dialogfeld "Rechtschreibung" geöffnet. Die Rechtschreibprüfung betrachtet alle Wörter als fehlerhaft, die sie nicht in ihrem Wörterbuch findet.

Im Dialogfeld "Rechtschreibung" finden Sie die folgenden Felder und Schaltflächen:

Nicht gefunden

Das Wort in diesem Feld wurde im Wörterbuch nicht gefunden. Es ist möglicherweise falsch geschrieben.

Ändern in

In diesem Feld werden Ersetzungsvorschläge für das falsch geschriebene Wort angezeigt. Wählen Sie einen Ersetzungsvorschlag aus, und klicken Sie auf "Ändern", um das falsch geschriebene Wort zu ersetzen.

Ignorieren

Mit der Schaltfläche "Ignorieren" geben Sie an, dass das Wort unverändert bleiben soll. Im Unterschied zur Schaltfläche "Hinzufügen" wird das Wort jedoch nicht ins Wörterbuch aufgenommen.

Ändern

Mit dieser Schaltfläche wird das falsch geschriebene Wort durch den im Feld "Ändern in" ausgewählten Ersetzungsvorschlag ersetzt.

Hinzufügen

Mit dieser Schaltfläche geben Sie an, dass das Wort unverändert bleiben soll. Die Rechtschreibprüfung wird fortgesetzt. Das bisher nicht im Wörterbuch enthaltene Wort wird in das Wörterbuch aufgenommen. Die Rechtschreibprüfung betrachtet das Wort dann bei künftigen Durchgängen als richtig geschrieben.

Vorschlagen

Zeigt weitere, jedoch nicht mehr so wahrscheinliche Ersetzungsvorschläge an.


Überprüfung der Plausibilität von Ergebnissen

Bei einfachen Berechnungen reicht meist eine kurze Überprüfung, ob das Ergebnis sinnvoll ist. Bei komplizierteren Berechnungsvorgängen sollten Sie in Ihre Dokumente Redundanzüberprüfungen aufnehmen, mit denen Sie überschlagen können, ob das Ergebnis annähernd stimmt.


Chemische Notation

Soll ein Variablenname einen Operator enthalten (zum Beispiel Hoch- oder Tiefstellungen), müssen Sie in einem besonderen Modus arbeiten, der sonst in erster Linie bei der chemischen Notation Verwendung findet:

  1. Drücken Sie Strg+Umschalt+J. Hierdurch wird ein in eckige Klammern gesetzter Platzhalter eingefügt.

  2. Geben Sie die Buchstaben, Ziffern und Operatoren für den Namen ein.

Beispiel:

Sie können Variablendefinitionen wie die folgende erstellen:


Chi-Quadrat-Verteilung

Verteilungsgeneratoren für die Chi-Quadrat-Verteilung:

dchisq(x,d) Gibt die Wahrscheinlichkeitsdichte zurück.

pchisq(x,d) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qchisq(p,d) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rchisq(m,d) Gibt einen Vektor von m Zufallszahlen zurück, die die Exponentialverteilung aufweisen.


Cholesky-Zerlegung

cholesky(M) Gibt die untere Dreiecksmatrix L zurück, sodass gilt: .

Argumente:

  • M muss symmetrisch sein.

  • Diese Funktion verwendet nur den oberen dreieckigen Teil von M.


So geben Sie das Gleichheitszeichen für die Definition (:=) ein

Klicken Sie in den Ausdruck, und drücken Sie : (die Doppelpunkttaste).


Zwischenablage

Die Zwischenablage ist ein temporärer Speicherbereich des Betriebssystems.

Wenn Sie Daten oder Objekte in der Zwischenablage ablegen wollen, müssen Sie diese zunächst markieren und dann im Menü Bearbeiten einen der folgenden Befehle wählen:

  • Mit Ausschneiden löschen Sie den markierten Teil aus dem Arbeitsblatt, und legen ihn in der Zwischenablage ab.

  • Mit Kopieren kopieren Sie den markierten Teil in die Zwischenablage, ohne dass er aus dem Arbeitsblatt gelöscht wird.

Wenn Sie in die Zwischenablage kopieren oder ausschneiden, wird der bisherige Inhalt der Zwischenablage gelöscht.

Sie können den jeweiligen Inhalt der Zwischenablage mit den Befehlen Einfügen und Inhalte einfügen aus dem Menü Bearbeiten in das Arbeitsblatt einfügen.


Schließen

Schließt das Fenster "Druckvorschau". Es erscheint wieder das Arbeitsblatt-Fenster.


Schließen eines Arbeitsblattfensters

Wählen Sie im Menü Datei die Option Schließen.


Hilfe - Benutzerforen

Für Benutzer von Mathcad unterhält Mathsoft spezielle Mathcad-Collaboratory-Benutzerforen. In den Collaboratory-Benutzerforen können Sie mit anderen Benutzern von Mathcad, die ähnliche Interessen und Probleme bearbeiten, Kontakt aufnehmen. Sie können Fragen stellen, Mathcad und andere Dateien hoch- oder herunterladen und weltweit eine Verbindung zu anderen Benutzern von Mathcad herstellen. Nehmen Sie an interessanten Diskussionen zu einer Vielzahl von Fachgebieten und Themenbereichen teil.

Den Zugang zu den Collaboratory-Benutzerforen erhalten Sie unter http://collab.mathsoft.com/~mathcad2000.


Ausblenden bestimmter Regionen

Nach dem Einfügen einer Region können Sie diese Region ausblenden, um die Bereiche in der Region unsichtbar zu machen. Gehen Sie hierzu folgendermaßen vor:

1. Klicken Sie mit der rechten Maustaste auf eine der Begrenzungslinien der Region.

2. Wählen Sie im Kontextmenü den Befehl Ausblenden. Die Begrenzungslinien der Region und die Bereiche zwischen diesen Begrenzungslinien erscheinen daraufhin als ein einfacher Balken.

Die Bereiche, die sich unterhalb der ausgeblendeten Region befinden, verschieben sich entsprechend nach oben.

Hinweise:

  • Der Balken, der eine ausgeblendete Region repräsentiert, kann ausgewählt (markiert) und mit der Maus an eine andere Position gezogen bzw. in seinem Aussehen geändert werden, das Löschen oder Kopieren des Balkens ist jedoch nicht möglich.

  • Die Bereiche innerhalb der ausgeblendeten Region werden weiterhin berechnet, aber sie erscheinen nicht auf dem Bildschirm. Um die Bereiche wieder sichtbar zu machen, müssen Sie die Region wieder einblenden.

  • Um das Einblenden einer ausgeblendeten Region durch andere Benutzer zu verhindern, können Sie die Region sperren.


Zusammenfassen von Termen

Zum Ausdrücken einer Summe von Termen in einer bestimmten Variable als Polynom gehen Sie folgendermaßen vor:

  1. Wählen Sie einen Variablennamen oder den Namen einer Funktion zusammen mit ihrem Argument aus, indem Sie den Namen zwischen die Bearbeitungslinien platzieren.

  2. Wählen Sie Zusammenfassen im Menü Symbolik.

Dadurch wird die Summe zu einem Polynom in der Variablen bzw. Funktion umgeformt.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle das Schlüsselwort "Zusammenfassen" und die aktive symbolische Berechnung.


Collections

  • Inputs und Outputs sind vordefinierte Collections von DataValue-Objekten, die die Eingaben bzw. Ausgaben des skriptfähigen Objekts enthalten.

  • Mithilfe der Eigenschaft Count kann abgefragt werden, wie viele Elemente die Collection enthält. So lässt sich mit Outputs.Count die Anzahl der Ausgabevariablen ermitteln.

  • Die Methode Item wird verwendet, um ein bestimmtes Element in der Collection anzugeben. Der Bezug auf eine bestimmte Eingabe oder Ausgabe erfolgt mithilfe von Inputs.Item(n) bzw. Outputs.Item(n), wobei n der Index der Ein- bzw. Ausgabe ist. Der Index n beginnt stets bei 0. Item ist die Standardmethode, sodass Sie bei Sprachen wie VBScript und JScript den Namen der Methode weglassen können. Wird keine Methode angegeben, wird automatisch die Standardmethode verwendet. Daraus folgt, dass Inputs(0)0 mit Inputs.Item(0)0 identisch ist.

Hinweis: Im Gegensatz zu VBScript ist in JScript bei der Angabe von Funktionen, Methoden, Objekten und Eigenschaften auf die Groß- und Kleinschreibung zu achten.


Farbeinstellungen (3D-Säulendiagramme)

Zum Festlegen der Farbe eines 3D-Säulendiagramms gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Darstellung".

  3. Mit den Optionen auf der Seite "Darstellung" haben Sie folgende Möglichkeiten:

    • Füllen der Säulen mit einer Volltonfarbe oder entsprechend eines Farbschemas

    • Füllen der Säulen mit einer Farbe aus einem Farbschema entsprechend den x-, y- oder z-Werten.

    • Entfernen sämtlicher Füllfarben

    • Festlegen gleichmäßiger Übergänge für die Farben auf der Fläche

  4. Rufen Sie dann durch Klicken auf "Zuweisen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


Farbeinstellungen (Umrissdiagramme)

Zum Festlegen der Schattierung eines Umrissdiagramms gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Darstellung".

  3. Mit den Optionen auf der Seite Darstellung haben Sie folgende Möglichkeiten:

    • Füllen des Diagramms mit Farbe entsprechend eines Farbschemas

    • Entfernen von Farbe

    • Füllen der Umrisse mit zur Hälfte gefüllten verbundenen Oberflächen

    • Festlegen gleichmäßiger Farbübergänge im Diagramm

  4. Rufen Sie anschließend durch Klicken auf "Zuweisen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


Farbeinstellungen (Flächendiagramme)

Zum Festlegen der Farbe eines Flächendiagramms gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Darstellung".

  3. Mit den Optionen auf der Seite Darstellung haben Sie folgende Möglichkeiten:

    • Füllen der Fläche mit einer Volltonfarbe oder entsprechend eines Farbschemas

    • Füllen der Umrisse der Fläche entsprechend eines Farbschemas

    • Entfernen sämtlicher Füllfarben

    • Zeichnen der Fläche mit zur Hälfte gefüllten verbundenen Flächen

    • Festlegen gleichmäßiger Übergänge für die Farben auf der Fläche

  4. Rufen Sie anschließend durch Klicken auf "Zuweisen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


Farbeinstellungen (Vektorfeld-Diagramme)

Zum Festlegen der Farbe der Pfeilspitzen in einem Vektorfeld-Diagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Darstellung".

  3. Mit den Optionen auf der Seite Darstellung haben Sie folgende Möglichkeiten:

    • Füllen der Pfeile mit einer Volltonfarbe oder entsprechend eines Farbschemas

    • Entfernen der Farbe von den Pfeilen

  4. Rufen Sie anschließend durch Klicken auf "Zuweisen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


Farbschema

Ein Farbschema ist eine Datei, die Daten enthält, mit denen verschiedenen Stufen eines Diagramms unterschiedliche Farben zugeordnet werden können. Mathcad bietet eine Reihe möglicher Farbschemen, mit denen Sie Regenbogenfarben oder graue, rote, blaue und grüne Schattierungen zuweisen können. Sie haben außerdem die Möglichkeit, eigene Farben zu erstellen.

Eine Farbschemadatei ist eine *.CMP-Datei, die drei Spalten von Werten enthält, die für Stufen von Rot (Spalte 1), Grün (Spalte 2) und Blau (Spalte 3) stehen.

Normalerweise enthält ein Farbschema 256 Zeilen. Jede Zeile von Werten entspricht einer aus Rot, Grün und Blau zusammengesetzten Farbe, der ein Graustufenwert zugeordnet ist. Wenn ein Farbschema weniger als 256 Zeilen enthält, interpoliert Mathcad linear über 256 Werte.

Jeder Wert in einem Farbschema muss eine ganze Zahl zwischen 0 und einschließlich 255 sein. Werte, die keine ganzen Zahlen sind, werden abgeschnitten. Werte, die nicht zwischen 0 und 255 liegen, werden auf 0 erhöht oder auf 255 verringert.

Standardmäßig prüft Mathcad den CMAPS-Ordner im Mathcad-Ordner auf *.CMP-Dateien. Sie können eine Farbschemadatei einem 3D-Diagramm zuordnen, indem Sie sie im Dialogfeld "3D-Diagrammformat" auswählen. Der CMAPS-Ordner enthält einige Farbschemen. Sie können auch eigene Farbschemen mit der Funktion SpeichernFarbwerte anlegen.

Hinweis:

Bestimmte integrierte Farbzuordnungen wie Regenbogen oder Graustufen erscheinen nicht als *.CMP-Dateien im Ordner "CMAPS".


Kombinationen

combin(n,k) Gibt die Anzahl Teilmengen zurück, die aus n Objekten gebildet werden können, wenn jede Teilmenge die Größe k hat. Jede dieser Teilmengen wird als eine Kombination bezeichnet.

Argumente:

n und k sind ganze Zahlen größer oder gleich 0.

n muss größer als oder gleich k sein.

Hinweise:

  • Kombinationen und Permutationen ähneln sich, da es sich in beiden Fällen um Teilmengen einer Menge handelt. Im Unterschied zu einer Kombination ist aber bei einer Permutation die interne Reihenfolge von entscheidender Bedeutung.

  • Die Anzahl der Kombinationen wird üblicherweise wie folgt angegeben [image]:

Die Definition einer Kombination lautet:


Kombinatorische Funktionen

combin(n,k)

Gibt die Anzahl der Kombinationen von n Objekten bei Auswahl von k Objekten zurück.

permut(n,k)

Gibt die Anzahl der Permutationen von n Objekten bei Auswahl von k Objekten zurück.


Kompatibles E-Mail-System

Ein E-Mail-Programm ist kompatibel, wenn es dem MAPI-Standard entspricht. Beispiele für kompatible E-Mail-Systeme sind Microsoft Exchange, Microsoft Mail und Eudora.


Komplexe Argumente

Komplexe Argumente für die Exponentialfunktion werden vorgegeben durch:

Komplexe Argumente für die natürliche Logarithmusfunktion geben Folgendes zurück:


Konjugiert-komplexe Zahl (Operator)

Konjugiert komplexe Zahl

Tastaturbefehl: "

Gibt die konjugiert-komplexe Zahl von x zurück:

Re(x) - i Im(x)

Operanden:

x muss ein reeller Skalar sein.


Funktionen für komplexe Zahlen

Re(Z) Realteil von Z

Im(Z) Imaginärteil von Z

arg(z) Argument von z, zwischen -p und p, einschließlich p.

Argumente:

  • Z kann ein reeller oder komplexer Skalar oder eine Matrix sein.

  • z kann ein reeller oder komplexer Skalar sein.

Verwandte Themen: Felder als Argumente


Funktionen für komplexe Zahlen

Re(Z)

Gibt den Realteil von Z zurück.

Im(Z)

Gibt den Imaginärteil von Z zurück.

arg(z)

Gibt das Argument von z, zwischen -p und p , zurück.

csign(z)

Gibt 0 zurück, wenn z=0 ist. Ist Re(z)>0 oder (Re(z)=0 und Im(z)>0), wird 1 zurückgegeben, in allen anderen Fällen -1.

signum(z)

Gibt 1 zurück, wenn z=0 ist, anderenfalls z/|z|.


fft/ifft oder cfft/icfft

Verwenden Sie das Funktionspaar fft/ifft, wenn beide der folgenden Aussagen wahr sind:

Die Zeitbereichsdaten sind reell.

Der Datenvektor hat [image] Elemente (m>2).

Verwenden Sie das Funktionspaar cfft/icfft, wenn eine der folgenden Aussagen zutrifft:

Die Zeitbereichsdaten sind komplex.

Der Datenvektor hat keine [image] Elemente.

Die Daten liegen in Matrixform, nicht in Vektorform vor.

Bei reellen Daten im Zeitbereich weist die Fourier-Transformation Konjugationssymmetrie auf. Aus diesem Grund lässt fft die redundante zweite Hälfte des Ergebnisses weg, um die Rechengeschwindigkeit zu erhöhen. Daher ist der Vektor, der durch fft zurückgegeben wird, nur halb so groß wie der Originalvektor.

Die Funktion ifft stellt diese redundante Hälfte wieder her. Daher sollten Sie die Funktionen fft und ifft stets zusammen verwenden.

Beim Funktionspaar cfft/icfft wird keine solche Symmetrie vorausgesetzt. Diese Funktionen sind zwar für reelle Daten weniger effizient, können aber trotzdem verwendet werden.

Dasselbe gilt für die Funktionen FFT/IFFT und CFFT/ICFFT, die durch 1/n anstelle von 1/wurzel(n) normalisiert werden.


Komponentenassistenten

Wenn Sie eine der folgenden Komponenten einfügen, wird ein Setup-Assistent angezeigt. Mit dem Setup-Assistenten können Sie einige Eigenschaften der Komponente festlegen, bevor sie eingefügt wird.

  • Klicken Sie auf die Schaltfläche "Weiter", um mit dem Assistenten fortzufahren.

  • Klicken Sie auf die Schaltfläche "Zurück", um zu einer vorherigen Seite zurückzukehren.

  • Klicken Sie auf die Schaltfläche "Fertig stellen", um die Komponente in das Arbeitsblatt einzufügen.


Bedingungszahl einer Matrix

cond1(M) Gibt die Bedingungszahl der Matrix M auf der Basis der [image] Norm zurück.

cond2(M) Gibt die Bedingungszahl der Matrix M auf der Basis der [image] Norm zurück.

conde(M) Gibt die Bedingungszahl der Matrix M auf der Basis der euklidischen Norm zurück.

condi(M) Gibt die Bedingungszahl der Matrix M auf der Basis der infiniten Norm zurück.

Argumente:

  • M muss eine Quadratmatrix sein.


Konfigurieren einer Komponente

Nachdem Sie eine Komponente in Ihr Arbeitsblatt eingefügt haben, müssen Sie im Normalfall die Komponente konfigurieren, um festzulegen, wie sie mit den Eingaben aus Mathcad umgehen und was als Ausgabe gesendet werden soll. Zum Konfigurieren der Eigenschaften einer Komponente gehen Sie wie folgt vor:

  1. Klicken Sie einmal auf die Komponente, um sie zu markieren.

  2. Klicken Sie mit der rechten Maustaste auf die Komponente, um das Kontextmenü zu öffnen. Welche Optionen in diesem Kontextmenü zur Verfügung stehen, hängt von der markierten Komponente ab. In den meisten Fällen enthält das Kontextmenü jedoch mindestens die Befehle Ausschneiden, Kopieren und Eigenschaften.

  3. Wählen Sie Eigenschaften im Kontextmenü.

Welche Optionen im Dialogfeld "Eigenschaften" angezeigt werden, hängt von der markierten Komponente ab.


Konfluente hypergeometrische Funktion

mhyper(a,b,x)Gibt den Wert der konfluenten hypergeometrischen Funktion, 1F1(a;b;x) oder M(a,b,x) zurück.

Argumente:

a und b sind reelle Skalare.

x ist ein reeller Skalar.

Die konfluente hypergeometrische Funktion ist die Lösung der folgenden Differentialgleichung:

Viele Funktionen sind Sonderfälle der konfluenten hypergeometrischen Funktion. Beispiel:

exp(x)=mhyper(1,1,x)

exp(x).sinh(x)=x.mhyper(1,2,2.x)


Lösen mit dem Verfahren konjugierter Gradienten

Das Verfahren konjugierter Gradienten ist ein nichtlineares Verfahren, das bei den Funktionen Suchen, minfehl, minimieren und maximieren verwendet werden kann.

Weitere Informationen zum Verfahren konjugierter Gradienten finden Sie in den Abschnitten zu den Lösungsalgorithmen.


Format von Konstanten

Dies ist das standardmäßige Rechenformat, das jeder Konstanten beim Eingeben in das Arbeitsblatt zugewiesen wird.


Kontextsensitive Hilfe

Bei der Arbeit mit Mathcad steht eine kontextsensitive Hilfe zur Verfügung:

  • Klicken Sie bei Menübefehlen auf den Befehl. Die Hilfe wird in der Meldungszeile am unteren Fensterrand angezeigt

  • Bei Schaltflächen in Symbolleisten oder Paletten lassen Sie den Zeiger kurz über der Schaltfläche stehen. Daraufhin wird ein QuickInfo angezeigt.

  • Bei Fehlermeldungen, integrierten Funktionen und Variablen oder Operatoren klicken Sie auf das betreffende Element, und drücken Sie dann die Taste F1.

  • Zum Aufrufen der Hilfe zu den Menüoptionen drücken Sie Umschalt F1. Wird als Mauszeiger ein Fragezeichen angezeigt, können Sie auf die betreffende Menüoption klicken. Sie können mit der Bearbeitung fortfahren, indem Sie Esc drücken, sodass der Mauszeiger wieder als Pfeil angezeigt wird.


Umrissdiagramme auf anderen Ebenen

Wenn Sie ein Umrissdiagramm erstellen, sehen Sie standardmäßig die auf die XY-Hintergrundebene projizierten z-Umrisse. Wenn Sie ein Umrissdiagramm abbilden und mindestens eine weitere Art von Diagramm erstellen, können Sie jedoch die x- oder y-Umrisslinien auf den XY- oder YZ-Hintergrundebenen anzeigen. Gehen Sie hierzu folgendermaßen vor:

  1. Doppelklicken Sie auf die Darstellung mehrerer Diagramme, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Öffnen Sie durch Klicken auf die Registerkarte "Spezial" die Seite Spezial. Klicken Sie auf das Register, das dem Umrissdiagramm entspricht. (D. h., klicken Sie auf Diagramm 1, Diagramm 2, usw.)

  3. Wählen Sie am unteren Rand des Abschnitts "Umrissoptionen" aus dem Dropdown-Menü eine Umrissrichtung aus. Wählen Sie "X-Umrisse", wenn die Umrisse auf der XZ-Hintergrundebene angezeigt werden sollen. Mit "Y-Umrisse" werden die Umrisse auf der YZ-Hintergrundebene angezeigt werden sollen.

  4. Klicken Sie in den Umrissoptionen auf "Linien zeichnen", und/oder klicken Sie auf "Füllen", um die Umrisse mit Farbe zu füllen.

  5. Rufen Sie anschließend durch Klicken auf "Zuweisen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.

Hinweis:

Wenn Sie andere Umrisse als die z-Umrisse formatieren, dann müssen Sie im Dropdown-Menü die Umrissrichtung wählen, bevor Sie andere Formatoptionen festlegen.


Steuern der Schreibweise von Daten mithilfe der Dateizugriffsfunktionen

Steuern der Schreibweise von Daten

Signifikante Stellen:

PRNSCHREIBEN verwendet zum Schreiben standardmäßig 4 signifikante Stellen. Diese Vorgabe können Sie ändern, indem Sie den Wert für PRNPRECISION ändern. Wählen Sie dazu im Menü Extras den Befehl Arbeitsblattoptionen, und klicken Sie im Dialogfeld auf die Registerkarte Vordefinierte Variablen.

Spaltenbreite:

PRNSCHREIBEN schreibt Daten standardmäßig in Spalten mit einer Breite von 8 Zeichen. Diese Vorgabe können Sie ändern, indem Sie den Wert für PRNCOLWIDTH ändern. Wählen Sie dazu im Menü Extras den Befehl Arbeitsblattoptionen, und klicken Sie im Dialogfeld auf die Registerkarte Vordefinierte Variablen.


Steuern von Iterationen in einer Schleife

Programmschleifen sind dafür konzipiert, so lange fortgesetzt zu werden, bis eine bestimmte Bedingung erfüllt ist oder eine festgelegte Anzahl von Iterationen abgeschlossen wurde. Sie haben jedoch die Möglichkeit, eine Schleife während einer bestimmten Iteration anzuhalten und mit der nächsten Iteration fortzufahren. Dazu verwenden Sie eine continue-Anweisung.

So fügen Sie eine continue-Anweisung ein:

  1. Klicken Sie auf den Platzhalter, in den Sie die continue-Anweisung eingeben möchten.

  2. Klicken Sie auf der Symbolleiste Rechnen auf [image], um die Symbolleiste Programmierung mit den Programmierungsoperatoren zu öffnen.

  3. Klicken Sie auf die Schaltfläche continue, oder drücken Sie [Ctrl] +[. Geben Sie nicht nur das Wort "continue" ein.

  4. Wenn das Programm eine continue-Anweisung erkennt, unterbricht es die aktuelle Iteration und fährt mit der nächsten Iteration fort.


Steuern der Berechnungsgenauigkeit mittels TOL

TOL (STANDARD = 0.001)

Diese Konstante stellt die Genauigkeit dar, mit der Integrale und Ableitungen berechnet werden. Sie bestimmt außerdem, wie lange eine Iteration in Lösungsblöcken und in der Wurzel-Funktion fortdauert.

Festlegen von TOL auf niedrige Werte

Wenn Sie TOL auf einen sehr niedrigen Wert einstellen, werden alle Ergebnisse mit weitaus höherer Genauigkeit berechnet. Abhängig von den numerischen Eigenschaften des Ausdrucks kann dies zu erhöhter Berechnungszeit führen.

Außerdem kann es vorkommen, dass die Fehlermeldung Konnte Lösung nicht ermitteln angezeigt wird, wenn die numerischen Eigenschaften des Ausdrucks dazu führen, dass sich eine Lösung asymptotisch an eine Zahl annähert, die außerhalb des von TOL festgelegten Schwellenwerts liegt.

Festlegen von TOL auf hohe Werte

Hohe Werte für TOL verringern die Berechnungszeit; dies geht jedoch auf Kosten der Genauigkeit.


Steuern der Genauigkeit von Nebenbedingungen mittels CTOL

CTOL (Standard = 0.001)

Mit diesem Wert wird bestimmt, wie genau eine Nebenbedingung in einem Lösungsblock erfüllt sein muss, damit eine Lösung als akzeptabel gilt. Ein Lösungsblock, der von CTOL gesteuert wird, besteht aus dem Wort Vorgabe, mindestens einer Nebenbedingung, die erfüllt werden muss, sowie einer Optimierungsfunktion: minimieren, maximieren, suchen oder minfehl. Damit die Funktion eine Lösung ausgibt, müssen die Nebenbedingungen im Lösungsblock erfüllt sein. Beispielsweise kann die Nebenbedingung x<2 festgelegt werden; sie muss erfüllt werden, damit eine Lösung ausgegeben wird. Bei CTOL=0.001 gilt die Nebenbedingung als erfüllt, wenn x<2.001.

Sie können die Genauigkeit der Lösung bestimmen, indem Sie den Wert für CTOL einstellen. Je größer der Wert von CTOL ist, desto ungenauere Lösungen werden zugelassen. Je kleiner der Wert von CTOL ist, desto genauer sind die gefundenen Lösungen. Allerdings kann sich die Rechenzeit verlängern, die zur Erstellung der Lösung erforderlich ist.

Neudefinieren von CTOL...


Festlegen der Optionen für die Anzeige eines bestimmten Ergebnisses

Zum Festlegen der Anzeige einer bestimmten Zahl müssen Sie das lokale Ergebnisformat ändern. Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie aus dem Menü Format den Befehl Ergebnis, oder doppelklicken Sie auf das Ergebnis, um das Dialogfeld Ergebnisformat aufzurufen.

  2. Vergewissern Sie sich, dass die Option "Als Standard" NICHT aktiviert ist.

  3. Nehmen Sie im Dialogfeld Ergebnisformat die erforderlichen Änderungen vor, und klicken Sie auf "OK".

Wenn Sie "Als Standard" aktivieren, wirken sich die Änderungen auf alle Ergebnisse im Arbeitsblatt aus.


Festlegen der Optionen für die Anzeige aller Ergebnisse

Formatieren numerischer Ergebnisse

Wenn Sie die Standardanzeige der numerischen Ergebnisse in einem Arbeitsblatt ändern möchten, müssen Sie das Standardformat für das Arbeitsblatt ändern. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie in eine Gleichung.

  2. Wählen Sie aus dem Menü Format den Befehl Ergebnis, um das Dialogfeld Ergebnisformat zu öffnen.

  3. Nehmen Sie im Dialogfeld Ergebnisformat die erforderlichen Änderungen vor, und klicken Sie auf "OK".


Steuern der Bearbeitungslinien

Mit den Pfeiltasten können Sie die Bearbeitungslinien in die vom Pfeil angezeigte Richtung verschieben.

So ändern Sie die Elemente zwischen den Bearbeitungslinien:

Drücken Sie die Leertaste, um die verschiedenen Teile des Ausdrucks durchzugehen, die entsprechend ihrer aktuellen Position zwischen die Bearbeitungslinien gesetzt werden könnten.

Wenn Sie alle Teile des Ausdrucks durchgegangen sind, ohne dass der rechte Teil des Ausdrucks markiert werden konnte, klicken Sie auf einen Namen oder eine Ziffer an einer anderen Stelle im Ausdruck, und versuchen Sie es erneut. Durch jede neue Anfangsposition für die Bearbeitungslinien entsteht ein vollständiger neuer Ablauf, in dessen Übergangsstadien unterschiedliche Teile des Ausdrucks eingeschlossen werden.


Steuern des Hilfefensters

Standardmäßig enthält der linke Bereich im Hilfefenster die Registerkarten zum Zugriff auf ein Inhaltsverzeichnis, einen Index und ein Modul zur Volltextsuche. Sie können jedoch das Fenster auch ausblenden. Außerdem können Sie das Inhaltsverzeichnis und den Index anweisen, nur bestimmte Themenkategorien anzuzeigen.

So blenden Sie das linksseitige Fenster aus:

  • Klicken Sie auf die Schaltfläche [image].

Zum Einblenden des Fensters klicken Sie auf die Schaltfläche [image].


Partialbruchzerlegung

Generiert eine Partialbruchzerlegung für einen Ausdruck. Wird eine solche Zerlegung gefunden, so sind die Nenner in der ausgewählten Variable linear oder Zweierpotenzen.


Umwandeln von zylindrischen in Kartesische Koordinaten

zylinxyz(r,q,z) Wandelt die zylindrischen Koordinaten eines Punktes (r,q,z) in Kartesische Koordinaten (x,y,z) um. Gibt einen Vektor zurück, dessen Elemente x, y und z sind.

Argumente:

(r, q, z) sind die zylindrischen Koordinaten eines Punktes im Raum.

Beispiele:

Die Winkelangaben im obigen Beispiel sind in Grad. Für Winkelangaben in Radiant geben Sie die Werte ohne die Einheit "Grad" ein.


Umwandeln von Polarkoordinaten in Kartesische Koordinaten

polinxy(r,q) Wandelt die Polarkoordinaten eines Punktes (r,q) in Kartesische Koordinaten (x,y,z) um. Gibt einen Vektor zurück, dessen Elemente x und y sind.

Argumente:

(r, q) sind die Polarkoordinaten für einen Punkt in der Ebene.

Die Winkelangabe im obigen Beispiel ist in Grad. Für Winkelangaben in Radiant geben Sie die Werte ohne die Einheit "Grad" ein.


Umwandeln von Kartesischen Koordinaten in zylindrische bzw. Kugelkoordinaten

xyzinzyl(x,y,z) Wandelt die Kartesischen Koordinaten eines Punktes (x,y,z) in zylindrische Koordinaten (r, q, z) um. Gibt einen Vektor zurück, dessen Elemente r, q und z sind.

xyzinsph(x,y,z) Wandelt die Kartesischen Koordinaten eines Punktes (x,y,z) in Kugelkoordinaten (r, q, f) um. Gibt einen Vektor mit den Elementen r, q und f zurück.

Argumente:

(x,y,z) sind die Kartesischen Koordinaten eines Punktes im Raum.

Beispiele:

Die Winkelangaben im obigen Beispiel sind in Grad. Für Winkelangaben in Radiant geben Sie die Werte ohne die Einheit "Grad" ein.


Umwandeln von Kartesischen Koordinaten in Polarkoordinaten

xyinpol(x,y) Wandelt die Kartesischen Koordinaten eines Punktes (x,y) in Polarkoordinaten (r, q) um. Gibt einen Vektor mit den Elementen r und q zurück.

Argumente:

(x,y) sind die Kartesischen Koordinaten für einen Punkt in der Ebene.

Die Winkelangabe im obigen Beispiel ist in Grad. Für Winkelangaben in Radiant geben Sie die Werte ohne die Einheit "Grad" ein.


Umwandeln von Kugelkoordinaten in Kartesische Koordinaten

sph2xyz(r,q,f) Wandelt die Kugelkoordinaten eines Punktes (r,q,f) in Kartesische Koordinaten (x,y,z) um. Gibt einen Vektor mit den Elementen x, y und z zurück.

Argumente:

(r, q, f) sind die Kugelkoordinaten eines Punktes im Raum.

Beispiele:

Die Winkelangaben im obigen Beispiel sind in Grad. Für Winkelangaben in Radiant geben Sie die Werte ohne die Einheit "Grad" ein.


Umwandeln in Grad

Von den inversen trigonometrischen Funktionen und der Winkelfunktion werden alle Winkel in Radiant zurückgegeben. Sie können stattdessen mit dem Platzhalter für Einheiten am Ende der Gleichung das Ergebnis in Grad umwandeln. Siehe dazu das folgende Beispiel:


Funktionen des Koordinatensystems

Polarkoordinaten und Kartesische Koordinaten

xyinpol(x,y)

Wandelt die Kartesischen Koordinaten eines Punktes (x,y) in Polarkoordinaten (r, q) um.

polinxy(r,q)

Wandelt die Polarkoordinaten eines Punktes (r, q) in Kartesische Koordinaten (x,y) um.

Kugelkoordinaten und Kartesische Koordinaten

sphinxyz(r,q, f)

Wandelt die Kugelkoordinaten eines Punktes (r, q, f) in Kartesische Koordinaten (x,y,z) um.

xyzinsph(x,y,z)

Wandelt die Kartesischen Koordinaten eines Punktes (x,y,z) in Kugelkoordinaten (r, q, f) um.

Zylindrische und Kartesische Koordinaten

zylinxyz(r,q, z)

Wandelt die zylindrischen Koordinaten eines Punktes (r, q, z) in Kartesische Koordinaten (x,y,z) um.

xyzincyl(x,y,z)

Wandelt die Kartesischen Koordinaten eines Punktes (x,y,z) in zylindrische Koordinaten (r, q, z) um.


Kopieren einer Matrix mit numerischen Ergebnissen

Wenn das Ergebnis rechts des Gleichheitszeichens eine Matrix oder ein Vektor ist, müssen Sie die gesamte Matrix bzw. den gesamten Vektor auf einmal kopieren. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie auf das Ergebnis, um es zwischen die Bearbeitungslinien zu setzen.

  2. Wählen Sie im Menü Bearbeiten den Befehl Kopieren. Dadurch wird das numerische Ergebnis mit der angezeigten Genauigkeit in die Zwischenablage kopiert.

Nach dem Kopieren einer Matrix oder eines Vektors können Sie diese/n an eine andere Stelle im Arbeitsblatt oder in die meisten anderen Anwendungen kopieren.

Hinweis:Wollen Sie nur Teile eines Feldes kopieren, muss dieses erste als Ausgabetabelle angezeigt werden.


Kopieren eines numerischen Ergebnisses

So kopieren Sie ein einzelnes numerisches Ergebniss:

  1. Klicken Sie auf das Ergebnis. Dadurch wird es zwischen die Bearbeitungslinien gesetzt.

  2. Wählen Sie im Menü Bearbeiten den Befehl Kopieren. Dadurch wird das numerische Ergebnis mit der angezeigten Genauigkeit in die Zwischenablage kopiert.

Nach dem Kopieren eines numerischen Ergebnisses können Sie es an einer anderen Stelle im Arbeitsblatt oder in eine andere Anwendung einfügen.


Kopieren aus dem Hilfesystem

So kopieren Sie Text aus dem Hilfesystem:

  1. Wählen Sie den Text aus, indem Sie die Maustaste gedrückt halten und die Maus über den Text ziehen.

  2. Klicken Sie mit der rechten Maustaste auf den ausgewählten Text.

  3. Wählen Sie aus dem Kontextmenü den Befehl Kopieren.


Kopieren von Berechnungsergebnissen (allgemein)

Kopieren von Berechnungsergebnissen

Kopieren eines numerischen Ergebnisses

Kopieren einer Matrix

Kopieren von Werten aus einer Ausgabetabelle mit Bildlaufleiste

Einschränkungen für das Kopieren numerischer Ergebnisse


Kopieren von Werten aus einer Ausgabetabelle

So kopieren Sie einen oder mehrere Werte aus einer Ausgabetabelle:

  1. Wählen Sie eine Gruppe von Werten aus.

  2. Klicken Sie mit der rechten Maustaste auf die Auswahl, und wählen Sie aus dem Kontextmenü den Befehl Kopieren von Daten. Dadurch wird das numerische Ergebnis mit der angezeigten Genauigkeit in die Zwischenablage kopiert.

Nachdem Sie einen oder mehrere Werte aus einer Ausgabetabelle kopiert haben, können Sie diese in Ihr Arbeitsblatt oder in die meisten anderen Anwendungen einfügen.


Korrelationsfunktion

Korrelation

korr(A,B) Gibt den Pearsonschen Korrelationskoeffizienten (r) der Elemente in A und B zurück.

Argumente:

A und B sind m x n Felder.

Weitere Funktionen für die Datenanalyse...


Kosinusintegral


Lösung konnte nicht gefunden werden, da Wurzel nicht gefunden.

Für Ergebnisse von Lösungsalgorithmen für Differentialgleichungen wie sgrw (eine Funktion zum Ermitteln von fehlenden Anfangsbedingungen) sind Iterationen erforderlich. Wenn sich die Schätzungen nach vielen aufeinanderfolgenden Iterationen weiterhin beträchtlich unterscheiden, wird diese Fehlermeldung angezeigt. Versuchen Sie es mit anderen Schätzwerten.


Kovarianzfunktion

Kovarianz

Argumente:

A und B sind m x n Felder.

Beachten Sie, dass diese Funktion bei der Berechnung der Kovarianz durch mn und nicht durch mn-1 dividiert. Sie können die Kovarianz, die dem Nenner mn-1 entspricht, dadurch berechnen, dass Sie das Ergebnis dieser Funktion mit mn/(mn-1) multiplizieren.

Weitere Funktionen für die Datenanalyse...


ErstellenGitter (Funktion)

ErstellenGitter(F (oder G oder f1, f2, f3), s0, s1, t0, t1, sgrid, tgrid, fmap)

Gibt ein verschachteltes Feld mit drei Matrizen zurück, welche die x-, y- und z-Koordinaten einer parametrischen Fläche darstellen, die durch die Funktion F, G oder den Funktionssatz f1, f2 und f3 definiert ist . Mit Ausnahme des Funktionsarguments sind alle Argumente optional.

Klicken Sie hier, um ein Anwendungsbeispiel für ErstellenGitter anzuzeigen.

Argumente:

  • F ist eine aus drei Elementen bestehende vektorwertige Funktion mit zwei Variablen, u and v.

  • G ist eine skalarwertige Funktion mit zwei Variablen, u and v.

  • f1 ist eine skalarwertige Funktion mit zwei Variablen, u and v.

  • f2 ist eine skalarwertige Funktion mit zwei Variablen, u and v.

  • f3 ist eine skalarwertige Funktion mit zwei Variablen, u and v.

  • s0 ist die reelle untere Grenze der unabhängigen Variablen u. Der Standardwert ist -5.

  • s1 ist die reelle obere Grenze der unabhängigen Variablen u. Der Standardwert ist 5.

  • t0 ist die reelle untere Grenze der unabhängigen Variablen v. Der Standardwert ist -5.

  • t1 ist die reelle obere Grenze der unabhängigen Variablen v. Der Standardwert ist 5.

  • sgrid ist die ganzzahlige Anzahl der Gitterpunkte in u. Der Standardwert ist 20. sgrid>0

  • tgrid ist die ganzzahlige Anzahl der Gitterpunkte in v. Der Standardwert ist 20. tgrid>0

  • fmap ist eine aus drei Elementen bestehende reelle vektorwertige Funktion mit drei Variablen, die eine Abbildung aus einem beliebigen Koordinatensystem in das Kartesische Koordinatensystem definiert (Der Standard ist die Einheitsabbildung, d.h. fmap_default(e1, e2, e3) := c(e1, e2, e3)).

Hinweise:

  • Zulässig sind nur reellwertige Funktionen.

  • Die Anzahl der Zellen im erstellten Gitter beträgt (sgrid-1).(tgrid-1).

  • ErstellenGitter wird von Mathcad bei der Erstellung von 3D QuickPlots aus Funktionen mit zwei Variablen intern verwendet.

  • Eine typische Funktion F wäre zum Beispiel:

    Die Funktion F muss aus drei Elementen bestehen.

  • Eine typische Funktion G wäre zum Beispiel:

  • Typische Funktionenf1, f2 und f3 wären zum Beispiel:

  • Werden s0 und s1 explizit angegeben, so müssen t0 und t1 ebenfalls angegeben werden, und umgekehrt.

  • Es gibt zwei integrierte Zuordnungsfunktionen, die im Argument fmap verwendet werden können: sph2xyz und cyl2xyz. Diese Funktionen wandeln Kugel- oder Zylinderkoordinatensysteme in Kartesische Koordinaten um. Sie können auch im Arbeitsblatt aufgerufen werden, um eine Koordinatensystemtransformation durchzuführen.

  • fmap kann entweder als Funktion mit drei Skalaren oder als Funktion mit einem einzelnen Vektor definiert werden. Hierzu zwei Beispiele:


ErstellenRaum (Funktion)

ErstellenRaum(F (oder f1, f2, f3), t0, t1, tgrid, fmap) Gibt ein verschachteltes Feld von drei Vektoren zurück, welche die x-, y- und z-Koordinaten einer durch die Funktion F definierten räumlichen Kurve darstellen . Mit Ausnahme des Funktionsarguments sind alle Argumente optional.

Klicken Sie hier, um ein Anwendungsbeispiel für ErstellenRaum anzuzeigen.

Argumente:

  • F ist eine aus drei Elementen bestehende vektorwertige Funktion mit einer Variable, t.

  • f1 ist eine skalarwertige Funktion mit einer Variable, t.

  • f2 ist eine skalarwertige Funktion mit einer Variable, t.

  • f3 ist eine skalarwertige Funktion mit einer Variable, t.

  • t0 ist die reelle untere Grenze des Bereichs für t. Der Standardwert ist -5.

  • t1 ist die reelle obere Grenze des Bereichs für t. Der Standardwert ist 5.

  • tgrid ist die ganzzahlige Anzahl der Gitterpunkte in t. Der Standardwert ist 20.tgrid>0

  • fmap ist eine aus drei Elementen bestehende relle vektorwertige Funktion mit drei Variablen, die eine Abbildung aus einem beliebigen Koordinatensystem in das Kartesische Koordinatensystem definiert (Der Standard ist die Einheitsabbildung, d.h.. fmap_default(e1, e2, e3) := c(e1, e2, e3)).

Hinweise:

  • Zulässig sind nur reellwertige Funktionen. Wenn ein Aufruf mit komplexwertigen Funktionen erfolgt, wird eine Fehlermeldung ausgegeben.

  • Die Anzahl der Zellen im erstellten Gitter beträgt tgrid -1.

  • ErstellenRaum wird von Mathcad bei der Erstellung von 3D QuickPlots aus Funktionen mit einer Variable intern verwendet.

  • Eine typische Funktion F wäre zum Beispiel:

    Die Funktion F muss aus drei Elementen bestehen.

  • Typische Funktionenf1, f2 und f3 wären zum Beispiel:

  • Es gibt zwei integrierte Zuordnungsfunktionen, die im Argument fmap verwendet werden können: sph2xyz und cyl2xyz. Diese Funktionen wandeln Kugel- oder Zylinderkoordinatensysteme in Kartesische Koordinaten um. Sie können auch im Arbeitsblatt aufgerufen werden, um eine Koordinatensystemtransformation durchzuführen.

  • fmap kann entweder als Funktion mit drei Skalaren oder als Funktion mit einem einzelnen Vektor definiert werden. Hierzu zwei Beispiele:


ErstellenRaum (Beispiel)

Angenommen sei die folgende Funktion:

Sie erstellen einen Graphen für die Funktion F, indem Sie den Funktionsnamen unter der Funktionsdefinition eingeben und im Menü Einfügen den Befehl Graph / 3D-Streuungsdiagramm auswählen. Dadurch wird ein 3D-Streuungsdiagramm der Funktion erstellt, für das die folgenden Standardeinstellungen gelten: ein Bereich von -5 bis 5 für t mit 20 Punkten und Kartesischem Koordinatensystem.

Angenommen, Sie möchten den Bereich für t in diesem Diagramm auf -10 bis +10 erweitern und die Anzahl der Gitterlinien in t erhöhen. Sie können dazu die Funktion ErstellenRaum wie folgt verwenden:

Die Änderungen im Graphen sind deutlich zu erkennen. Durch die höhere Zahl der Punkte im Streuungsdiagramm, den größeren Bereich und die leichte Drehung des Graphen wird die Helixstruktur des Diagramms noch deutlicher herausgearbeitet.

Es ist zwar nicht erforderlich, jedes Argument von ErstellenRaum einer Variable zuzuweisen, es verbessert jedoch die Übersichtlichtlichkeit der Struktur.


Erstellen eines 3D-Säulendiagramms

So erstellen Sie ein 3D-Säulendiagramm einer Funktion (auch als QuickPlot bezeichnet):

  1. Definieren Sie die Funktion bzw. den Funktionssatz.

  2. Wählen Sie im Menü Einfügen den Befehl Diagramm / 3D-Säulendiagramm, um ein Flächendiagrammbereich zu erstellen.

  3. Geben Sie den Namen der Funktion(en) in den Platzhalter ein. Wenn Sie einen Satz von Funktionsnamen eingeben, müssen die Namen in runde Klammern eingeschlossen werden.

Mathcad erstellt ein 3D-Säulendiagramm der Funktion mit den Standardbereichen und Gittern für die unabhängigen Variablen. Zum Ändern der Vorgaben doppelklicken Sie auf den Graphen, und verwenden Sie im Dialogfeld 3D-Diagrammformat die Optionen in der Registerkarte QuickPlot-Daten.

So erstellen Sie ein 3D-Säulendiagramm aus Daten:

  1. Definieren Sie die Matrix der abzubildenden Elemente. Die Matrix muss aus mindestens zwei Zeilen und zwei Spalten bestehen.

  2. Wählen Sie im Menü Einfügen die Option Diagramm / 3D-Säulendiagramm, um einen 3D-Säulendiagrammbereich zu erstellen.

  3. Geben Sie im Platzhalter den Namen der abzubildenden Matrix ein.

  4. Klicken Sie auf eine Stelle außerhalb des Diagrammbereichs.

Mathcad zeichnet eine perspektivische Ansicht der Matrix als waagerecht gelagertes, zweidimensionales Raster im dreidimensionalen Raum. Die einzelnen Matrixelemente werden als Spalten mit einer bestimmten Höhe ober- bzw. unterhalb dieses Gitters dargestellt.

Hinweise:

  • Komplexe oder imaginäre Punkte werden nicht abgebildet. Verwenden Sie zum Abbilden des reellen oder komplexen Teils eines Punkts die Funktionen "Re" und "Im", welche die reellen oder imaginären Teile herausziehen.

  • Für die Erstellung eines 2D-Säulendiagramms erstellen Sie ein X-Y-Diagramm und ändern Sie den "Typ" der Spureneinstellungen auf "Säulen".


Erstellen einer Farb-BMP-Datei

RGBSCHREIBEN("datei") Schreibt ein Feld in eine Datei. Das Feld muss aus ganzen Zahlen zwischen 0 und einschließlich 255 bestehen und 3n Spalten enthalten. Die ersten n/3 Spalten stehen für den Rotanteil des Bildes in der datei.bmp im aktuellen Verzeichnis. Die zweite und dritte Folge von n/3 Spalten steht für den Grün- und den Blauanteil desselben Bildes.

Argumente:

datei ist der Pfad zu einer BMP-Datei.

datei wird als Zeichenfolge eingegeben.


Erstellen eines Umrissdiagramms

So erstellen Sie ein Umrissdiagramm einer Funktion (auch als QuickPlot bezeichnet):

  1. Definieren Sie die Funktion bzw. den Funktionssatz.

  2. Wählen Sie im Menü Einfügen den Befehl Diagramm / Umrissdiagramm, um ein Flächendiagrammbereich zu erstellen.

  3. Geben Sie den Namen der Funktion(en) in den Platzhalter ein. Wenn Sie einen Satz von Funktionsnamen eingeben, müssen die Namen in runde Klammern eingeschlossen werden.

Mathcad erstellt ein Umrissdiagramm der Funktion mit den Standardbereichen und Standardgittern für die unabhängigen Variablen. Zum Ändern der Vorgaben doppelklicken Sie auf den Graphen, und verwenden Sie die Optionen im Dialogfeld 3D-Diagrammformat in der Registerkarte QuickPlot-Daten.

So erstellen Sie ein Umrissdiagramm:

  1. Definieren Sie die Matrix der abzubildenden Werte. Die Matrix muss mindestens zwei Zeilen und zwei Spalten aufweisen. Die besten Ergebnisse erzielen Sie, wenn die Zeilen und Spalten gleichmäßig voneinander entfernte Intervalle auf den Achsen darstellen.

  2. Wählen Sie im Menü Einfügen den Befehl Diagramm / Umrissdiagramm, um einen Umrissdiagrammbereich zu erstellen.

  3. Geben Sie den Namen der Matrix in den Platzhalter ein.

Mathcad interpoliert die Werte der Matrix linear, um auf diese Weise Niveaulinien zu bilden, die sich an keiner Stelle überschneiden. Mathcad stellt die Matrix im Diagramm dar, indem es sie so dreht, dass sich das Element (0,0) in der linken unteren Ecke befindet. Die Zeilen der Matrix entsprechen daher den Werten auf der x-Achse (nach rechts ansteigend), während die Spalten den Werten entlang der y-Achse entsprechen (nach oben ansteigend).

Hinweise:

  • Komplexe oder imaginäre Punkte werden nicht abgebildet. Verwenden Sie zum Abbilden des reellen oder komplexen Teils eines Punkts die Funktionen "Re" und "Im", welche die reellen oder imaginären Teile herausziehen.

  • Sie können ein Umrissdiagramm auch mithilfe von x-, y- und z-Datenpunkten anlegen. Erstellen Sie zunächst drei Vektoren: ein Vektor enthält die x-Werte, der zweite die y-Werte und der dritte die z-Werte. Erstellen Sie dann einen Umrissdiagrammbereich, und geben Sie die Namen der x-, y- und z-Vektoren in den Platzhalter ein (durch Kommas voneinander getrennt). Das daraufhin von Mathcad gezeichnete Umrissdiagramm entspricht einem 3D-Streuungsdiagramm, das in ein Umrissdiagramm umgewandelt wurde.


Erstellen einer Graustufen-BMP-Datei

BMPSCHREIBEN("datei") Schreibt ein Feld in die Datei datei. Das Feld muss aus ganzen Zahlen zwischen 0 und einschließlich 255 bestehen.

Argumente:

datei ist der Pfad zu einer BMP-Datei.

datei wird als Zeichenfolge eingegeben.


Erstellen einer neuen SmartSketch-Zeichnung

Wenn Sie beim Einfügen der SmartSketch-Komponente die Option "Neues SmartSketch-Dokument" wählen, müssen Sie nach dem Öffnen der Komponente eine neue SmartSketch-Zeichnung erstellen. Gehen Sie hierzu folgendermaßen vor:

  1. Doppelklicken Sie auf die Komponente, und erstellen Sie mithilfe der Menüs und Symbolleisten von SmartSketch eine Zeichnung. Fügen Sie mithilfe der Symbolleiste "Dimensionen" Dimensionen hinzu.

  2. Wählen Sie im Menü Extras den Befehl Variablen, um Variablen zu definieren oder Dimensionen zu bearbeiten. Schließen Sie die Variablentabelle, bevor Sie wieder zurück in das Mathcad-Arbeitsblatt klicken.

  3. Als nächstes müssen Sie Variablen, Dimensionen oder Symbole mit den Eingaben oder Ausgaben verbinden. Klicken Sie hierzu mit der rechten Maustaste auf die Komponente, und wählen Sie aus dem Kontextmenü den Befehl Eigenschaften . Legen Sie im Dialogfeld "Eigenschaften" Folgendes fest:

  • Eingabenamen: Die Namen der Dimensionen, Symbole oder Variablen in der SmartSketch-Zeichnung, die durch die Eingaben in die SmartSketch-Komponente bestimmt werden. Wählen Sie eine Dimension oder eine Variable aus der Dropdown-Liste.

  • Ausgabenamen: Die Namen der Dimensionen, Symbole oder Variablen in der SmartSketch-Zeichnung, durch welche die Ausgabevariablen in Mathcad definiert werden. Wählen Sie eine Dimension oder eine Variable aus der Dropdown-Liste.

Wenn Sie auf eine Stelle außerhalb der Komponente klicken, werden die Eingabewerte aus Mathcad an die SmartSketch-Zeichnung übertragen, und es werden Werte als Ausgabe an Mathcad zurückgegeben.

Hinweise:

  • Ist die Zeichnung so groß, dass sie nicht in das Komponentenfenster passt, klicken Sie mit der rechten Maustaste auf die Komponente, wählen Sie aus dem Kontextmenü Eigenschaften, und klicken Sie dann auf das Kontrollkästchen "Automatisches Ändern der Größe".

  • Wenn die Größe der Dimensionen in der Zeichnung an tatsächliche Größenänderungen angepasst werden soll, muss im SmartSketch-Menü Extras die Option Beibehalten von Seitenverhältnissen aktiviert sein. Zum Überprüfen doppelklicken Sie auf die Komponente, und wählen Sie in der Menüleiste die Option Extras.

  • Weitere Informationen zu SmartSketch finden Sie in der Einführung und der Dokumentation zu SmartSketch, die Sie über das SmartSketch-Menü "Hilfe" aufrufen. Mathcad-Beispieldateien mit SmartSketch-Komponenten finden Sie im Ordner SAMPLES\CAD unter QuickSheets im Hilfemenü, wenn diese von der CD installiert wurden.


Erstellen eines Kreisdiagramms

So erstellen Sie ein Kreisdiagramm:

  1. Wählen Sie im Menü Einfügen den Befehl Diagramm / Kreisdiagramm, um einen Kreisdiagrammbereich zu erstellen.

  2. Geben Sie in den Platzhalter unten in der Mitte eine Winkelvariable ein, nach der abgebildet werden soll. Geben Sie beispielsweise "A" ein, wenn Sie zuvor "A" als Bereichsvariable definiert hatten. (Definieren Sie ‘A’ nicht, wenn Sie ein Quickplot erstellen möchten.)

  3. Fügen Sie in den linken Platzhalter einen abzubildenden radialen Ausdruck ein. Geben Sie beispielsweise "cos(A)" ein, wenn Sie den Kosinus der Variable A abbilden möchten.

Mathcad erstellt ein Kreisdiagramm, indem es r und q mit den folgenden Standardtransformationen x und y zuordnet:

x=r*cos( q ) und y=r*sin( q ),

wobei r und q positive oder negative Werte sein können.

Hinweise:

  • Komplexe oder imaginäre Punkte werden nicht abgebildet. Verwenden Sie zum Abbilden des reellen oder komplexen Teils eines Punkts die Funktionen "Re" und "Im", welche die reellen oder imaginären Teile herausziehen.

  • Sie können mehrere Kreiskurven in einem Diagramm abbilden.


Erstellen eines 3D-Streuungsdiagramms aus einer Funktion

Erstellen eines Streuungsdiagramms aus einer Funktion

So erstellen Sie ein Streuungsdiagramms einer Funktion (auch als QuickPlot bezeichnet):

  1. Definieren Sie die Funktion bzw. den Funktionssatz.

  2. Wählen Sie im Menü Einfügen den Befehl Diagramm / Streuungsdiagramm, damit ein Flächendiagrammbereich erstellt wird.

  3. Geben Sie den Namen der Funktion(en) in den Platzhalter ein. Wenn Sie einen Satz von Funktionsnamen eingeben, müssen die Namen in runde Klammern eingeschlossen werden.

Mathcad erstellt ein Streuungsdiagramm der Funktion mit den Standardbereichen und Gittern für die unabhängigen Variablen. Zum Ändern der Vorgaben doppelklicken Sie auf den Graphen, und verwenden Sie im Dialogfeld 3D-Diagrammformat die Optionen in der Registerkarte QuickPlot-Daten.


Erstellen eines 3D-Streuungsdiagramms aus einer Matrix aus Datenwerten

S erstellen Sie ein 3D-Streuungsdiagramm mit einer Matrix aus Datenwerten:

  1. Definieren Sie die Matrix der abzubildenden Werte.

  2. Wählen Sie im Menü Einfügen den Befehl Diagramm / 3D-Streuungsdiagramm .

  3. Geben Sie den Namen der Matrix in den Platzhalter ein.


Erstellen eines 3D-Streuungsdiagramms aus 3 Datenvektoren

So erstellen Sie ein 3D-Streuungsdiagramm mithilfe der x-, y- und z- Koordinaten aus drei Vektoren:

  1. Definieren Sie drei Vektoren, von denen jeder so viele Elemente aufweist, wie abzubildende Punkte vorhanden sind.

  2. Wählen Sie im Menü "Einfügen" den Befehl Diagramm / 3D-Streuungsdiagramm.

  3. Geben Sie ( in den Platzhalter ein.

  4. Geben Sie die Namen der Vektoren durch Kommas getrennt ein.

  5. Geben Sie ) ein.

Komplexe oder imaginäre Punkte werden von Mathcad nicht abgebildet. Verwenden Sie zum Abbilden des reellen oder komplexen Teils eines Punkts die Funktionen "Re" und "Im", welche die reellen oder imaginären Teile herausziehen.


Erstellen einer räumlichen Kurve

So erstellen Sie ein räumliche Kurve einer Funktion (auch als QuickPlot bezeichnet):

  1. Definieren Sie die Funktion bzw. den Funktionssatz. Weitere Informationen finden Sie unter Funktionen für die Erstellung einer räumlichen Kurve.

  2. Wählen Sie im Menü Einfügen den Befehl Diagramm / Streuungsdiagramm, damit ein Flächendiagrammbereich erstellt wird.

  3. Geben Sie den Namen der Funktion(en) in den Platzhalter ein. Wenn Sie einen Satz von Funktionsnamen eingeben, müssen die Namen in runde Klammern eingeschlossen werden.

Mathcad erstellt eine räumliche Kurve der Funktion mit den Standardbereichen und Gittern für die unabhängigen Variablen. Zum Ändern der Vorgaben doppelklicken Sie auf den Graphen, und verwenden Sie im Dialogfeld 3D-Diagrammformat die Optionen in der Registerkarte QuickPlot-Daten.


Erstellen einer Zeichenfolge

So erstellen Sie eine Zeichenfolge:

  1. Klicken Sie in einem mathematischen Ausdruck auf einen Platzhalter, oder klicken Sie auf eine leere Stelle im Arbeitsblatt, und wählen Sie aus dem Menü Einfügen den Befehl Rechenbereich.

  2. Geben Sie die Anführungszeichen (“) ein. Zwischen den beiden Anführungszeichen können Sie eine Einfügelinie erkennen.

  3. Geben Sie eine Kombination aus Buchstaben, Ziffern und/oder anderen Zeichen ein.

Beispiele für Zeichenfolgen:

"Guten Morgen!"

"5.67e-2" (Zahlenzeichenfolge)

"-4.3 - 6.7i" (Zahlenzeichenfolge)


Erstellen eines Flächendiagramms

So erstellen Sie ein Flächendiagramm einer Funktion (auch als QuickPlot bezeichnet):

  1. Definieren Sie die Funktion bzw. den Funktionssatz.

  2. Wählen Sie im Menü Einfügen den Befehl Diagramm / Flächendiagramm, um ein Flächendiagrammbereich zu erstellen.

  3. Geben Sie den Namen der Funktion(en) in den Platzhalter ein. Wenn Sie einen Satz von Funktionsnamen eingeben, müssen die Namen in runde Klammern eingeschlossen werden.

Mathcad erstellt ein Flächendiagramm der Funktion mit den Standardbereichen und Standardgittern für die unabhängigen Variablen. Zum Ändern der Vorgaben doppelklicken Sie auf den Graphen, und verwenden Sie im Dialogfeld 3D-Diagrammformat die Optionen in der Registerkarte QuickPlot-Daten.

So erstellen Sie ein Flächendiagramm aus Daten:

  1. Definieren Sie die Matrix der abzubildenden Elemente. Die Matrix muss aus mindestens zwei Zeilen und zwei Spalten bestehen.

  2. Wählen Sie im Menü Einfügen den Befehl Diagramm / Flächendiagramm, um ein Flächendiagrammbereich zu erstellen.

  3. Geben Sie den Namen der Matrix in den Platzhalter ein.

Mathcad zeichnet eine perspektivische Ansicht der Matrix als waagerecht gelagertes, zweidimensionales Raster im dreidimensionalen Raum. Die einzelnen Matrixelemente werden als ein Punkt mit einer bestimmten Höhe ober- bzw. unterhalb dieses Gitters dargestellt.

Hinweis:

  • Komplexe oder imaginäre Punkte werden nicht abgebildet. Verwenden Sie zum Abbilden des reellen oder komplexen Teils eines Punkts die Funktionen "Re" und "Im", welche die reellen oder imaginären Teile herausziehen.

  • Alternativ hierzu können Sie ein Flächendiagramm aus den Datenpunkten x, y und z erstellen. Erstellen Sie zunächst drei Vektoren: ein Vektor enthält die x-Werte, der zweite die y-Werte und der dritte die z-Werte. Erstellen Sie einen Flächendiagrammbereich, und geben Sie die Namen der Vektoren x, y und z, jeweils durch Komma getrennt, in den Platzhalter ein. Das von Mathcad generierte Flächendiagramm entspricht genau einem 3D-Streuungsdiagramm, das in ein Flächendiagramm umgewandelt wurde.


Erstellen eines Vektorfelddiagramms

So erstellen Sie eine grafische Darstellung eines zweidimensionalen Vektorfelds:

  1. Definieren Sie eine Matrix, die so viele Elemente enthält wie abzubildende Vektoren vorhanden sind.

  2. Jedes Matrixelement ist ein zweidimensionaler Vektor, der durch eine komplexe Zahl dargestellt wird. Der Realteil dieser Zahl ist die x-Komponente des Vektors. Der Imaginärteil ist die y-Komponente.

  3. Die Position eines Elements in einer Matrix richtet sich nach der Positition des entsprechenden Vektors in der xy-Ebene.

  4. Wählen Sie im Menü "Einfügen" den Befehl Diagramm / Vektorfelddiagramm.

  5. Geben Sie den Namen der Matrix in den Platzhalter ein.

Sie können auch zwei reelle Matrizen mit dergleichen Anzahl an Zeilen und Spalten verwenden. Die entsprechenden Elemente dieser Matrizen stellen die x- und y-Komponenten eines bestimmten Vektors dar. Geben Sie die Namen dieser Matrizen durch Kommas getrennt und in Klammern in den Platzhalter ein.

Komplexe oder imaginäre Punkte werden nicht abgebildet. Verwenden Sie zum Abbilden des reellen oder komplexen Teils eines Punkts die Funktionen "Re" und "Im", welche die reellen oder imaginären Teile herausziehen.


Erstellen eines Feldes mithilfe einer Funktion

Erstellen von Feldern

matrix(m,n,f) Erstellt eine Matrix, in der das ij-te Element die Funktion f(i,j) enthält, wobei gilt: i= 0,1..m-1 und j=0,1.. n-1.

Argumente:

m ist die Anzahl der Zeilen der Matrix.

n ist die Anzahl der Spalten der Matrix.

f ist eine Funktion mit zwei Variablen


Erstellen eines X-Y-Diagramms

So eerstellen Sie ein X-Y-Diagramm:

  1. Wählen Sie im Menü Einfügen den Befehl Diagramm / X-Y-Diagramm, um einen Diagrammbereich zu erstellen.

  2. Geben Sie im mittleren Platzhalter unter der x -Achse (horizontale Achse) die Variable oder den Ausdruck ein, für die das Diagramm erstellt werden soll.

    Diese Variable ist normalerweise eine vorher definierte Bereichsvariable. Wenn diese Variable nicht bereits definiert wurde, erstellt Mathcad das Diagramm mit den Werten -10 bis 10. Dies wird als QuickPlot bezeichnet.

  3. Geben Sie im mittleren Platzhalter neben der y-Achse (vertikale Achse) den abzubildenden Ausdruck ein.

  4. Klicken Sie auf eine Stelle außerhalb des Diagramms oder drücken Sie die Eingabetaste. Mathcad zeichnet für alle Werte der x-Achsenvariable je einen Punkte und verbindet sie mit geraden Linien, wenn Sie nichts anderes festlegen.

Hinweise:

  • Sie können beliebige Ausdrücke gegen andere Ausdrücke abbilden, wenn ihre unabhängigen Variablen gleich sind. Sie können auch mehrere Kurven in einem Diagramm abbilden.

  • Komplexe oder imaginäre Punkte werden nicht abgebildet. Verwenden Sie zum Abbilden des reellen oder komplexen Teils eines Punkts die Funktionen "Re" und "Im", welche die reellen oder imaginären Teile herausziehen.

  • Wenn Ihnen die Darstellung eines Diagramms zu abrupt erscheint, können Sie für die Bereichsvariable, die beim Erstellen des Diagramms verwendet wird, kleinere Schrittweiten verwenden.


Erstellen und Bearbeiten von Text

Erstellen von Text

Importieren von Text aus einer anderen Anwendung

Verschieben eines Textbereichs

Bearbeiten von Text

Einfügen von Rechenbereichen in Textbereiche

Erstellen eines Hyperlinks in Text


Erstellen und Laden von Farbschemen

SpeichernFarbwerte("datei", M) Erstellt eine Farbschemadatei mit den Werten in M. Gibt die Anzahl der Zeilen in der Datei zurück.

LadeFarbwerte("datei") Gibt ein Feld mit den Werten in der Farbschemadatei zurück.

Argumente:

datei ist der Name eines Farbschemas , das sich im Unterordner CMAPS des Mathcad-Ordners befindet.

datei wird als Zeichenfolge eingegeben.

M ist eine Matrix mit drei Spalten, deren Elemente ganze Zahlen zwischen 0 und 255 sind. Die Werte sind so angeordnet, dass sie für die Erstellung eines Farbschemas geeignet sind.

Beispiele:

Wenn gbmap eine 2x3-Matrix ist, gilt:

SpeichernFarbwerte("graublau", gbmap) = 2

A := LadenFarbwerte("graublau")

Hinweise:

  • Nach der Verwendung der Funktion SpeichernFarbwerte ist das Farbschema im Dialogfeld "3D-Diagrammformat" auf der Registerkarte "Erweitert" verfügbar.

  • LadenFarbwerte ist dann von Nutzen, wenn Sie ein Farbschema bearbeiten oder auf seiner Grundlage ein neues Farbschema erstellen möchten.

  • Alle Werte in der Matrix M, die keine ganzen Zahlen sind, werden verkürzt.

  • Alle Werte in der Matrix M, die nicht zwischen 0 und 255 liegen, werden auf 0 erhöht oder auf 255 verringert.


Erstellen benutzerdefinierter DLLs

Erstellen eigener Funktionen

Sie können die Leistungsfähigkeit von Mathcad erweitern, indem Sie eigene Funktionen in C oder C++ schreiben. Angepasste Funktionen können komplexe Skalare oder Felder akzeptieren und ausgeben. Außerdem können angepasste Funktionen beispielsweise über Fehlermeldungen, Unterbrechungs- und Ausnahmeverarbeitung verfügen.

Zur Erstellung angepasster Funktionen müssen Sie zunächst mithilfe der in MathSoft verfügbaren Strukturen und Funktionen einen Quellcode erstellen. Als nächstes kompilieren und verknüpfen Sie den Code, um eine DLL-Treiberdatei zu erzeugen.

Informationen zu den Strukturen und Funktionen, den Schritten zur Erzeugung einer DLL und weitere Einzelheiten finden Sie in der Datei Erstellen einer Benutzer-Dll.pdf auf der Mathcad CD-ROM. Überprüfen Sie auch von Zeit zu Zeit die MathSoft Web-Site (www.mathsoft.com), auf der Sie stets die aktuellsten Informationen erhalten.


Das Vektorprodukt ist nur für Vektoren mit drei Elementen definiert

Das Vektorprodukt ist nur für Vektoren mit genau drei Elementen definiert.

Das Vektorprodukt ist nur für Vektoren mit drei Elementen definiert.


Vektorprodukt (Operator)

Vektorkreuzprodukt

Tastaturbefehl: Strg+8

Gibt das Vektorkreuzprodukt von u und v zurück.

Operanden:

  • Sowohl u als auch v sind Spaltenvektoren mit drei Elementen.

ist ein Vektor mit den folgenden Eigenschaften:

  • Seine Richtung verläuft orthogonal zu u und v in der nach der Regel mit der rechten Hand bestimmten Richtung.

  • Sein absoluter Betrag ist | u || v |sin( [image]) wobei [image] der Winkel zwischen u und v ist.


Fadenkreuz

Das rote Fadenkreuz (+) zeigt an, wo das Zeichen, das Sie als nächstes eingeben, oder der Inhalt, den Sie aus der Zwischenablage einfügen, angezeigt werden wird.

Sie können das Fadenkreuz auch durch Klicken der Maustaste über der gewünschten Cursorstellung positionieren.Das Fadenkreuz kann mit Hilfe der Pfeiltasten, der Eingabetaste, der Leertaste oder der Bildab- bzw. der Bildauf-Taste verschoben werden.


Fadenkreuz-Cursor

Wo kann er angezeigt werden?

Wie kann er angezeigt werden?

Wie wird er verschoben?

Was ist seine Funktion?


Strg + Pfeil-nach-unten

In leeren Bereichen...

Verschiebt das Fadenkreuz um eine Stelle nach unten.

In Rechenbereichen...

Inaktiv.

In Textbereichen...

Verschiebt die Einfügemarke an das Ende der aktuellen Zeile. Wenn sich die Einfügemarke bereits am Zeilenende befindet, springt sie zum Ende der nächsten Zeile. Befindet sich die Einfügemarke bereits am Ende der letzten Zeile, springt sie aus dem Text und erscheint als Fadenkreuz direkt unterhalb des Textes.


Strg + Ende

In leeren Bereichen...

Verschiebt das Fadenkreuz neben den letzten Bereich im Arbeitsblatt. Wenn sich das Fadenkreuz bereits am letzten Bereich befindet, ist dieser Tastaturbefehl unwirksam.

In Rechenbereichen...

Verschiebt die Bearbeitungslinien an das Ende des Ausdrucks. Wenn sich die Bearbeitungslinien bereits dort befinden, ist dieser Tastaturbefehl unwirksam.

In Textbereichen...

Verschiebt die Texteinfügemarke an das Ende der letzten Textzeile im aktuellen Textbereich. Wenn sich die Einfügemarke bereits dort befindet, ist dieser Tastaturbefehl unwirksam.


Strg + Pos1

In leeren Bereichen...

Verschiebt das Fadenkreuz neben den ersten Bereich im Arbeitsblatt. Wenn sich das Fadenkreuz bereits am ersten Bereich befindet, ist dieser Tastaturbefehl unwirksam.

In Rechenbereichen...

Verschiebt die Bearbeitungslinien an den Anfang des Ausdrucks. Wenn sich die Bearbeitungslinien bereits dort befinden, ist dieser Tastaturbefehl unwirksam.

In Textbereichen...

Verschiebt die Texteinfügemarke an den Anfang der ersten Textzeile im aktuellen Textbereich. Wenn sich die Einfügemarke bereits dort befindet, ist dieser Tastaturbefehl unwirksam.


Strg + Pfeil-nach-links

In leeren Bereichen...

Verschiebt das Fadenkreuz um eine Stelle nach links.

In Rechenbereichen...

Setzt die vertikale Bearbeitungslinie links neben die horizontale Bearbeitungslinie, soweit noch nicht geschehen.

In Textbereichen...

Verschiebt die Einfügemarke an den Anfang des vorhergehenden Wortes. Wenn sich die Einfügemarke bereits am Textanfang befindet, springt sie aus dem Text und wird als Fadenkreuz im links davon befindlichen leeren Bereich angezeigt.


Strg + Pfeil-nach-rechts

In leeren Bereichen...

Verschiebt das Fadenkreuz eine Stelle nach rechts.

In Rechenbereichen...

Setzt die vertikale Bearbeitungslinie rechts neben die horizontale Bearbeitungslinie, soweit noch nicht geschehen.

In Textbereichen...

Verschiebt die Einfügemarke zum Ende des nächsten Wortes. Wenn sich die Einfügemarke bereits am Textende befindet, springt sie aus dem Text und wird als Fadenkreuz im rechts davon befindlichen leeren Bereich angezeigt.


Strg + Pfeil-nach-oben

In leeren Bereichen...

Verschiebt das Fadenkreuz um eine Stelle nach oben.

In Rechenbereichen...

Inaktiv.

In Textbereichen...

Verschiebt die Einfügemarke an den Anfang der aktuellen Zeile. Wenn sich die Einfügemarke bereits am Zeilenanfang befindet, wird sie am Anfang der vorhergehenden Zeile angezeigt. Wenn sich die Einfügemarke bereits am Anfang der ersten Zeile befindet, springt sie aus dem Text und wird als Fadenkreuz im über dem Text befindlichen leeren Bereich angezeigt.


Kubische Spline-Interpolation

kspline(vx,vy) Gibt einen Vektor der zweiten Ableitungen für die Datenvektoren vx und vy zurück. Dieser Vektor wird als das erste Argument der Funktion interp verwendet. Die sich dabei ergebende Spline-Kurve ist an den Endpunkten kubisch.

pspline(vx,vy) Wie kspline, jedoch ist die sich ergebende Spline-Kurve an den Endpunkten parabolisch.

lspline(vx,vy) Wie kspline, jedoch ist die sich ergebende Spline-Kurve an den Endpunkten linear.

interp(vs,vx,vy,x) Führt eine Spline-Interpolation von vy am Punkt x aus und gibt den sich dabei ergebenden Wert zurück.

Argumente:

  • vx ist ein Vektor aus reellen Datenwerten in aufsteigender Reihenfolge. Diese entsprechen den x-Werten.

  • vy ist ein Vektor aus reellen Datenwerten. Diese entsprechen den y-Werten. Die Anzahl der Elemente entspricht vx.

  • vs ist ein Vektor, der von kspline, pspline oder lspline generiert wird.

  • x ist der Wert der unabhängigen Variable, an der das Ergebnis interpoliert werden soll. Dieser Wert sollte innerhalb des von vx angegebenen Bereichs liegen, um optimale Ergebnisse zu erzielen.

Durch kubische Spline-Interpolation können Sie eine Kurve so über eine Reihe von Punkten legen, dass die erste und die zweite Ableitung der Kurve an jedem Punkt stetig ist. Die Kurve wird zusammengesetzt, indem ein kubisches Polynom über jeweils drei benachbarten Punkten konstruiert wird. Diese kubischen Polynome werden dann zusammengesetzt und ergeben die vollständige Kurve.

Das folgende Beispiel zeigt die Verwendung der kubischen Spline-Interpolation:


Kumulative Zinsen

kumzins(zsatz, nper, gw, start, ende, [typ]) Gibt die kumulativen Zinsen zurück, die zwischen einer Anfangs- und einer Endverzinsungsperiode bei festem Zinssatz für ein Darlehen gezahlt wurden, sowie die Gesamtzahl der Verzinsungsperioden und den derzeitigen Wert des Darlehens.

Argumente:

zsatz ist der feste Zinssatz für die Verzinsungsperiode. zsatz ist ein reeller Skalar. zsatz kann als Dezimalzahl, z. B. 0.0825 oder als Prozentzahl, z. B. 8.25%, ausgedrückt werden. zsatz ³ 0.

Hinweis: Gegebenenfalls müssen Sie den Zinssatz für die jeweilige Verzinsungsperiode berechnen. Für die Berechnung des monatlichen Zinssatzes aus dem jährlichen Zinssatz zum Beispiel gilt die Formel zsatz = jährl_zsatz /12.

nper ist die Gesamtzahl der Verzinsungsperioden. nper ist eine positive ganze Zahl.

pv ist der gegenwärtige Wert des Darlehens. pv [image] 0.

start ist die erste Verzinsungsperiode start ist eine positive ganze Zahl.

ende ist die letzte Verzinsungsperiode ende ist eine positive ganze Zahl. start [image] end.

typ (optional) beträgt bei Zahlungen, die am Ende der Periode vorgenommen wurden, 0, bei Zahlungen zu Beginn der Periode 1. Falls keine Angabe gemacht wird, gilt typ = 0.

Beispiel:

Eine Baudarlehen von € 150.000 wird mit 8.3% p.a. verzinst. Das Baudarlehen hat eine Laufzeit von 30 Jahren. Insgesamt werden im ersten Jahr die folgenden Zinsen gezahlt:

kumzins (.006917,360,150000,1,12) = 12406,37


Kumulativer Tilgungsbetrag

kumtilg(zsatz, nper, gw, start, ende, [typ]) Gibt die kumulative Tilgung zurück, die zwischen einer Anfangs- und einer Endverzinsungsperiode bei festem Zinssatz für ein Darlehen gezahlt wurde, sowie die Gesamtzahl der Verzinsungsperioden, und den derzeitigen Wert des Darlehens.

Argumente:

zsatz ist der feste Zinssatz für die Verzinsungsperiode. zsatz ist ein reeller Skalar. zsatz kann als Dezimalzahl, z. B. 0.0825 oder als Prozentzahl, z. B. 8.25%, ausgedrückt werden. zsatz ³ 0.

Hinweis: Gegebenenfalls müssen Sie den Zinssatz für die jeweilige Verzinsungsperiode berechnen. Für die Berechnung des monatlichen Zinssatzes aus dem jährlichen Zinssatz zum Beispiel gilt die Formel zsatz = jährl_zsatz /12.

nper ist die Gesamtzahl der Verzinsungsperioden. nper ist eine positive ganze Zahl.

pv ist der gegenwärtige Wert des Darlehens. pv [image] 0.

start ist die erste Verzinsungsperiode. start ist eine positive ganze Zahl.

ende ist die letzte Verzinsungsperiode ende ist eine positive ganze Zahl. start [image] end.

typ (optional) beträgt bei Zahlungen, die am Ende der Periode vorgenommen wurden, 0, bei Zahlungen zu Beginn der Periode 1. Falls keine Angabe gemacht wird, gilt typ = 0.


Kumulative Wahrscheinlichkeitsverteilung

Diese geben die Wahrscheinlichkeit, dass eine Zufallsvariable einen Wert annimmt, der kleiner oder gleich einem festgelegten Wert ist. Die Berechnung erfolgt durch einfaches Integrieren (bzw. Summieren, wo erforderlich) der jeweiligen Wahrscheinlichkeitsdichte über einen entsprechenden Bereich.


Aktuelles Arbeitsverzeichnis

CWD-Standard = eine Verzeichniszeichenfolge

Diese Zeichenfolgenvariable gibt das Arbeitsverzeichnis an, mit dem Mathcad gegenwärtig arbeitet. Als Arbeitsverzeichnis gilt das Verzeichnis, in dem Dateien gespeichert werden und Mathcad nach Datendateien sucht.

Standardmäßig wird CWD als Wert das Verzeichnis zugewiesen, in dem Sie Mathcad installiert haben (in der Regel c:\Programme\Mathsoft\Mathcad). So ändern Sie den Standardwert von CWD:

Erstellen Sie ein Mathcad-Symbol auf dem Desktop Ihres Betriebssystems, wenn es nicht bereits vorhanden ist.

Legen Sie als Arbeitsverzeichnis bzw. "start in"-Verzeichnis das Verzeichnis fest, das Mathcad standardmäßig verwenden soll.


Symbolleiste anpassen (Dialogfeld)

Im Dialogfeld "Symbolleiste anpassen" finden Sie die folgenden Optionen:

Verfügbare Schaltflächen

Zeigt die Schaltflächen an, die der Symbolleiste hinzugefügt werden können.

Aktuelle Schaltflächen

Zeigt die Schaltflächen in der Reihenfolge an (von links nach rechts), wie sie in der Symbolleiste im aktiven Fenster angezeigt werden.

Hinzufügen

Fügt die in der Liste "Verfügbare Schaltflächen" markierte Schaltfläche in die Liste "Schaltflächen der Symbolleiste" ein. Sie können die Schaltfläche auch direkt aus der Liste "Schaltflächen der Symbolleiste" in die Liste "Verfügbare Schaltflächen" ziehen.

Entfernen

Verschiebt die in der Liste "Schaltflächen der Symbolleiste" markierte Schaltfläche in die Liste "Verfügbare Schaltflächen". Sie können die Schaltfläche auch direkt aus der Liste "Schaltflächen der Symbolleiste" in die Liste "Verfügbare Schaltflächen" ziehen.

Nach oben

Verschiebt die markierte Schaltfläche eine Zeile nach oben. Auf der Symbolleiste rückt die Schaltfläche eine Position nach links. Sie können die Schaltfläche auch mit der Maus nach oben ziehen.

Nach unten

Verschiebt die markierte Schaltfläche eine Zeile nach unten. Auf der Symbolleiste rückt die Schaltfläche eine Position nach rechts. Sie können die Schaltfläche stattdessen auch mit der Maus nach unten ziehen.

Zurücksetzen

Stellt den ursprünglichen Zustand des Dialogfelds wieder her.


Anpassen einer Symbolleiste

Sie können die Schaltflächen ändern, die in der Standardsymbolleiste und in der Formatsymbolleiste angezeigt werden.

So fügen Sie Schaltflächen in eine der Symbolleisten ein, entfernen diese oder stellen sie um:

  1. Klicken Sie mit der rechten Maustaste auf die Symbolleiste.

  2. Wählen Sie aus dem Kontextmenü die Option Anpassen. Das Dialogfeld "Symbolleiste anpassen" wird geöffnet.

  3. Klicken Sie in der Liste "Verfügbare Schaltflächen" auf die gewünschte Schaltfläche.

  4. Klicken Sie dann entweder auf "Hinzufügen", oder ziehen Sie die Schaltfläche in den Bereich "Schaltflächen der Symbolleiste" des Dialogfelds.

So entfernen Sie eine Schaltfläche aus der Symbolleiste:

  1. Klicken Sie mit der rechten Maustaste auf die Symbolleiste.

  2. Wählen Sie aus dem Kontextmenü die Option Anpassen. Das Dialogfeld "Symbolleiste anpassen" wird geöffnet.

  3. Klicken Sie in der Liste "Schaltflächen der Symbolleiste" auf die zu entfernende Schaltfläche.

  4. Klicken Sie entweder auf "Entfernen", oder ziehen Sie die Schaltfläche in den Dialogfeldbereich "Verfügbare Schaltflächen".

So ordnen Sie Schaltflächen in einer Symbolleiste mithilfe des Dialogfelds "Symbolleiste anpassen" um:

  1. Klicken Sie auf eine Schaltfläche.

  2. Klicken Sie auf "Nach oben" oder "Nach unten", oder ziehen Sie die Schaltfläche nach oben oder unten.

Hinweise:

  • Zum Aus- oder Einblenden einer Symbolleiste wählen Sie aus dem Menü Ansicht den Befehl Symbolleisten.

  • Für die schnelle Entfernung einer Schaltfläche aus einer Symbolleiste halten Sie die Alt-Taste gedrückt, und ziehen Sie die Schaltfläche aus dem Mathcad-Fenster, sodass sie nicht mehr sichtbar ist.

  • Zum schnellen Verschieben einer Schaltfläche aus einer Symbolleiste in eine andere halten Sie die Alt-Taste gedrückt, und ziehen Sie sie zu einer anderen Symbolleiste.

  • Zum schnellen Ausblenden einer Symbolleiste klicken Sie mit der rechten Maustaste auf eine angezeigte Symbolleiste, und wählen Sie dann aus dem Kontextmenü die Option Ausblenden.


Vordefinierte Funktion cyl2xyz

cyl2xyz ist eine vordefinierte Funktion, die Kreiszylinderkoordinaten in kartesische Koordinaten umwandelt. Beispiel:

Sie können cyl2xyz als fmap-Argument von ErstellenGitter oder ErstellenRaum verwenden.


Datenaustausch

Daten werden von der Eingabevariable an die Komponente übertragen, und die Ausgabevariable wird mit der Ausgabe definiert werden.


Spaltenbreite in Datendatei

Druckbare Spaltenbreite

PRNCOLWIDTH (Standard = 8)

Diese Konstante stellt die Spaltenbreite in ASCII-Dateien dar, die mit der Funktion PRNSCHREIBEN erstellt wurden.

Für die Änderunge wählen Sie im Menü Extras den Befehl Arbeitsblattoptionen, und klicken Sie im Dialogfeld auf die Registerkarte Vordefinierte Variablen.


Datenbanken und SQL-Unterstützung

Die ODBC-Komponente erfordert, dass die Datenbank, aus der Sie Informationen abrufen, in ihrem ODBC-Treiber SQL unterstützen. Dies ist z.B. bei Microsoft Access oder FoxPro der Fall. Einige Programme unterstützen SQL zwar innerhalb ihrer Anwendungen, aber nicht in ihren ODBC-Treibern. Dazu gehört z. B. Microsoft Excel.


DataValue-Objekte

  • Die Eigenschaft Value greift auf den Realteil eines DataValue zu. So gibt in VBScript oder JScript Inputs(0).Value den Realteil der ersten Eingabe zurück.

  • Die Eigenschaft IValue greift dagegen auf den Imaginärteil eines DataValue zu. So gibt in VBScript oder JScript Outputs(1).IValue den Imaginärteil der zweiten Eingabe zurück. Ist kein Imaginärteil vorhanden, gibt IValue "NIL" zurück.

  • Die Eigenschaft IsComplex gibt "TRUE" zurück, wenn ein DataValue über einen gültigen Imaginärteil verfügt; andernfalls wird "FALSE" zurückgegeben. So gibt der Ausdruck (inputs(0).IsComplex) "FALSE" zurück, wenn die erste Eingabe nur über einen Realteil verfügt.

  • Die Eigenschaften Rows und Cols ergeben die Anzahl der Zeilen und Spalten.

Hinweis: Im Gegensatz zu VBScript ist in JScript bei der Angabe von Funktionen, Methoden, Objekten und Eigenschaften auf die Groß- und Kleinschreibung zu achten.


Dialogeld "Standardformate für Kreisdiagramme festlegen": Registerkarte "Achsen"

Auf der Registerkarte "Achsen" des Dialogfelds "Standardformate für Kreisdiagramme werden festgelegt" finden Sie die folgenden Optionen:

Logarithmusskala

Bei Aktivierung verfügt die Kreisdiagrammachse über eine logarithmische Einteilung. Die Achsenbegrenzungen müssen positiv sein.

Gitterlinien

Bei Aktivierung werden die Teilstriche auf der ausgewählten Achse durch Gitterlinien ersetzt.

Nummeriert

Bei Aktivierung werden die Teilstriche auf der ausgewählten Achse nummeriert.

Markierungen anzeigen

Mit dieser Option können Sie Ihr Kreisdiagramm mit radialen Hilfslinien versehen. Gehen Sie hierzu folgendermaßen vor:

  • Klicken Sie in der Spalte "Radialachse" auf das Kontrollkästchen "Markierungen anzeigen". Oben links im Diagramm werden zwei weitere Platzhalter angezeigt.

  • Klicken Sie auf einen der Platzhalter, und geben Sie den Wert ein, an dem eine Linie angezeigt werden soll. Wiederholen Sie diese Schritte für den anderen Platzhalter, um eine zweite radiale Hilfslinie hinzuzufügen.

Autom. Gitterweite

Bei Aktiverung wird die Anzahl der Teilstriche automatisch ausgewählt.

Anzahl Gitterlinien

Bei Deaktivierung können Sie eine ganze Zahl zwischen 2 und 99 eingeben, um die Anzahl der zu zeichnenden Gitterlinien zu kennzeichnen. Achten Sie darauf, dass die Anzahl nicht zu groß ist, sodass die Beschriftungen der einzelnen Teilstriche zu dicht beieinander liegen.

Achsenstil &ndash; Rundum, Kreuz, Kein

Hiermit legen Sie fest, ob sich die Achsen in der Mitte des Diagramms schneiden sollen (Option "Kreuz"), oder ob sie das Diagramm in einem Kreis umschließen sollen (Option "Rundum"). Wenn Sie "Kein" wählen, werden die Achsen nicht angezeigt.


Standardachsenbegrenzungen der radialen Achse

Bei linearer Skalierung:

  • Als Obergrenze gilt der höchstmögliche radiale Wert der abgebildeten Funktion.

  • Die Untergrenze auf einer linearen Skala ist Null.

Bei logarithmischer Skalierung:

  • Als Obergrenze gilt die nächste Ganzzahlpotenz von Zehn über dem Höchstwert der Daten.

  • Als Untergrenze gilt die nächste Ganzzahlpotenz von Zehn unter dem Mindestwert der Daten.


Standardeinstellungen (Kreisdiagramme)

Standardeinstellungen für Kreisdiagramme

Zum Wiederherstellen der Standardeinstellungen in einem Diagramm gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie gegebenenfalls auf die Registerkarte Standardwerte.

  3. Klicken Sie auf die Schaltfläche "Standardwerte wiederherstellen".

Damit die aktuellen Einstellungen als Standardwerte für ein bestimmtes Diagramm übernommen werden, gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie gegebenenfalls auf die Registerkarte Standardwerte.

  3. Klicken Sie auf das Kontrollkästchen "Als Standard verwenden".

Zum Festlegen von Standardwerten ohne Verwendung eines Diagramms gehen Sie wie folgt vor:

  1. Vergewissern Sie sich, dass keine Diagramme ausgewählt sind.

  2. Wählen Sie DiagrammÞ Kreisdiagramm im Menü Format, um das Dialogfeld "Standardformate für Kreisdiagramme festlegen" aufzurufen.

  3. Ändern Sie die erforderlichen Einstellungen auf den Seiten Achsen und Spuren.

  4. Klicken Sie auf "OK", um die Änderungen zu bestätigen und das Dialogfeld zu schließen.


Standardeinstellungen (X-Y-Diagramme)

Zum Wiederherstellen der Standardeinstellungen in einem Diagramm gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie gegebenenfalls auf die Registerkarte Standardwerte.

  3. Klicken Sie auf die Schaltfläche "Standardwerte wiederherstellen".

Damit die aktuellen Einstellungen als Standardwerte für ein bestimmtes Diagramm übernommen werden, gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie gegebenenfalls auf die Registerkarte Standardwerte.

  3. Klicken Sie auf das Kontrollkästchen "Als Standard verwenden".

Zum Festlegen von Standardwerten ohne Verwendung eines Diagramms gehen Sie wie folgt vor:

  1. Vergewissern Sie sich, dass keine Diagramme ausgewählt sind.

  2. Wählen Sie DiagrammÞ X-Y-Diagramm im Menü Format, damit das Dialogfeld mit den Registerkarten geöffnet wird.

  3. Ändern Sie gegebenenfalls Einstellungen auf den Seiten X-Y-Achsen und Spuren.

  4. Klicken Sie auf "OK", um die Änderungen zu bestätigen und das Dialogfeld zu schließen.


Registerkarte "Standard" für Kreisdiagramme"

Das Dialogfeld "Gerade markiertes Kreisdiagramm wird formatiert" verfügt auf der Seite "Standardwerte" über die folgenden Optionen:

Standardwerte wiederherstellen

Ändert alle Einstellungen im Dialogfeld in die Standardeinstellungen des Arbeitsblattes.

Als Standard verwenden

Wenn diese Option aktiviert ist, werden die Einstellungen im Dialogfeld als Standardeinstellung für neue Kreisdiagramme übernommen. Bestehende Kreisdiagramme werden dabei nicht verändert.


Registerkarte "Standard" für X-Y-Diagramme

Auf der Registerkarte "Standard" des Dialogfelds "Gerade markiertes X-Y-Diagramm wird formatiert" finden Sie die folgenden Optionen:

Standardwerte wiederherstellen

Ändert alle Einstellungen im Dialogfeld in die Standardeinstellungen des Arbeitsblattes.

Als Standard verwenden

Wenn diese Option aktiviert ist, werden die Einstellungen im Dialogfeld als Standardeinstellung für neue Diagramme übernommen. Bestehende Diagramme werden dabei nicht verändert.


Definieren von benutzerdefinierten Binäroperatoren

Wenn ein bestimmter Operator in Mathcad nicht enthalten ist, können Sie diesen auf dieselbe Art definieren wie eine Funktion. Zum Definieren eines Binäroperators gehen Sie wie folgt vor:

  1. Geben Sie den Namen des Operators ein.

  2. Geben Sie "(", danach zwei durch ein Komma voneinander getrennte Operanden und schließlich ")"

     ein.

  3. Geben Sie ":" ein.

  4. Geben Sie im Platzhalter einen Ausdruck ein, der die Operanden enthält.


Definieren von benutzerdefinierten einstelligen Operatoren

Wenn ein bestimmter Operator in Mathcad nicht enthalten ist, können Sie diesen auf dieselbe Art definieren wie eine Funktion. Zum Definieren eines einstelligen Operators gehen Sie wie folgt vor:

Geben Sie den Namen des Operators ein.

Geben Sie "(" ein, dann den Operanden und wieder ")".

Geben Sie ":" ein.

Geben Sie in den Platzhalter einen Ausdruck ein, der den Operanden enthält.


Definieren von Programmen

Im Folgenden wird die Definition eines Beispielprogramms illustriert:

  1. Geben Sie den linken Teil einer Funktionsdefinition, gefolgt vom Zuweisungsoperator ": ", ein.

  2. Klicken Sie auf [image] auf der Symbolleiste "Rechnen", um die Symbolleiste "Programmierung" mit den Programmierungsoperatoren zu öffnen.

  3. Klicken Sie auf die Schaltfläche Zeile hinzufügen, oder drücken Sie ]. Dadurch wird eine vertikale Leiste mit einem Platzhalter für eine weitere Programmanweisung erstellt (ein Programm kann beliebig viele Anweisungen enthalten).

  4. Klicken Sie auf den oberen Platzhalter, geben Sie "z" ein, und klicken Sie auf die Schaltfläche für lokale Zuweisung. (Beachten Sie, dass die Definition von z programmspezifisch ist und außerhalb des Programms nicht gilt.)

  5. Schließen Sie die lokale Zuweisung ab, indem Sie in den Platzhalter rechts neben dem Pfeil "x/w" eingeben.

  6. Der letzte Platzhalter muss stets den Wert enthalten, der vom Programm ausgegeben wird. Geben Sie in diesen Platzhalter "log(z)" ein.

Sie können nun beim Verwenden dieser Funktion ebenso vorgehen wie bei anderen Funktionen oder sie symbolisch auswerten.


Definieren eines Bereichs - Schritt 1


Definieren eines Bereichs - Schritt 2


Definieren eines Bereichs - Schritt 3


Definieren eines Bereichs - Schritt 4


Definieren eines Bereichs - Schritt 5


Definieren eines Bereichs - Schritt 6


Definieren einer Bereichsvariable

Eine Bereichsvariable steht für eine Folge von Werten. So definieren Sie eine Bereichsvariable:

Geben Sie den Namen der Variablen mit einem Doppelpunkt (:) ein. (Doppelpunkt).

Geben Sie im Platzhalter die erste Zahl aus der Folge von Werten ein.

Geben Sie ein Komma ein. (Bei der Definition von Wertefolgen, die in Einserschritten nach oben oder unten fortgesetzt werden, können Sie diesen und den nächsten Schritt überspringen.)

Geben Sie die zweite Zahl der Wertefolge ein.

Geben Sie einen Semikolon (;) ein. Es wird mit zwei Punkten dargestellt: ".."

Geben Sie im verbleibenden Platzhalter die letzte Zahl der Wertefolge ein.


Definieren von Feldelementen

Zur Definition einzelner Feldelemente werden Indizes verwendet. Geben Sie beispielsweise folgendes ein:

v[3:6

So definieren Sie das vierte Element des Vektors v.

Beim Definieren von Feldelementen können Sie im Vektor auch Lücken lassen. Wenn beispielsweise v nicht definiert ist und Sie das dritte Element definieren, ist das erste und das zweite Element nicht definiert. Mathcad fügt für die undefinierten Elemente Nullen ein. Achten Sie darauf, nicht zu große Felder zu erstellen, indem Sie Elemente einzeln definieren.


Definitionssymbol

:=

Dies ist der am häufigsten verwendete Zuordnungsoperator. Er wertet alles aus, was sich auf seiner rechten Seite befindet, und ordnet es dem Variablennamen auf der linken Seite zu.

Auf der linken Seite kann entweder ein Variablenname oder ein Funktionsname stehen, jedoch kein Ausdruck. Auf der rechten Seite muss ein Ausdruck stehen, dessen Ergebnis eine Zahl oder eine Funktionsdefinition ist. Alle Variablen oder Funktionen auf der rechten Seite müssen bereits definiert sein.


Grad des Polynoms muss zwischen 1 und 99 sein

Der an die Funktion nullstellen weitergeleitete Vektor muss mindestens zwei und kann höchstens 99 Elemente enthalten.


Löschen einer Leerzeile

So löschen Sie eine Leerzeile:

  1. Klicken Sie auf eine leere Stelle über der Zeile, die gelöscht werden soll.

  2. Drücken Sie die Entf-Taste so oft, bis die zu löschenden Leerzeilen entfernt worden sind.

Sie können eine bestimmte Anzahl an Zeilen auch löschen, indem Sie auf eine leere Stelle klicken und dann mit der rechten Maustaste einen Popup-Dialog aufrufen.

Wählen Sie Zeilen löschen und geben Sie dann die Anzahl der zu löschenden Zeilen ein.


Löschen eines ausgeblendeten Bereichs

Wenn Sie eine Region ausgeblendet haben, können Sie die Linie, die die ausgeblendete Region darstellt, genau wie jeden anderen Bereich löschen. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie auf die Linie, die die ausgeblendete Region darstellt.

  2. Drücken Sie Strg + D, oder wählen Sie im Menü Bearbeiten den Befehl Löschen.


Löschen einer sperrbaren Region

Wenn Sie eine Region freigegeben haben, können Sie diese ebenso löschen wie andere Bereiche. Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie eine der Regionsgrenzen aus.

  2. Wählen Sie im Menü Bearbeiten die Option Ausschneiden.


Löschen eines Negativwerts (a+b)


Löschen von Spalten

So Löschen Sie eine oder mehrerer Spalten in einer Matrix:

  1. Klicken Sie auf ein Element in der zu entfernenden Spalte bzw. in der Spalte, die sich links von den zu entfernenden Spalten befindet.

  2. Wählen Sie aus dem Menü Einfügen den Befehl Matrix. Daraufhin wird sich ein Dialogfeld angezeigt.

  3. Legen Sie die Anzahl der zu löschenden Spalten fest.

  4. Klicken Sie auf "Löschen".

Dadurch wird die Spalte mit dem ausgewählten Element und die angegebene Anzahl von Spalten rechts von ihr gelöscht.


Löschen von Bereichen

So löschen Sie einen oder mehrere Bereiche:

  1. Markieren Sie die zu löschenden Bereiche.

  2. Wählen Sie aus dem Menü Bearbeiten den Befehl Ausschneiden oder Löschen.


Löschen von Zeilen

So löschen Sie eine oder mehrere Zeilen in einem Vektor bzw. in einer Matrix:

  1. Klicken Sie auf ein Element in der ersten Zeile, die gelöscht werden soll.

  2. Wählen Sie aus dem Menü Einfügen den Befehl Matrix. Daraufhin wird ein Dialogfeld angezeigt.

  3. Legen Sie die Anzahl der zu löschenden Zeilen fest.

  4. Klicken Sie auf "Löschen".

Dadurch wird die Zeile mit dem ausgewählten Element zusammen mit der angegebenen Anzahl von darunterliegenden Zeilen gelöscht.


Ableitungen von Ordnungen größer als 5

Obwohl der Ableitungsoperator von Mathcad keine Ableitungen von Ordnungen höher als 5 berechnet, können Sie Ableitungsoperatoren ineinander verschachteln und so Ableitungen höherer Ordnungen berechnen.


Definieren einer zu sperrenden oder auszublendenden Region

So definieren Sie eine zu sperrende oder auszublendende Region:

1. Klicken Sie auf eine leere Stelle in der Nähe der Region, die gesperrt werden soll. Es wird ein Fadenkreuz angezeigt.

2. Wählen Sie aus dem Menü Einfügen den Befehl Region. Mathcad fügt zwei Regionsbegrenzungslinien ein:

3. Markieren Sie diese Begrenzungslinien, und ziehen Sie sie gegebenenfalls mit der Maus, um ihre Größe anzupassen.

4. Erstellen Sie zwischen den Grenzen die zu sperrenden Bereiche, oder verschieben Sie Bereiche von anderen Positionen im Arbeitsblatt zwischen die Begrenzungslinien.

Nach dem Einfügen einer Region können Sie diese sperren und/oder ausblenden, sodass die enthaltenen Bereiche ausgeblendet werden.

Hinweise:

  • Das Arbeitsblatt kann beliebig viele Regionen enthalten; Sie können jedoch die Regionen nicht ineinander verschachteln.

  • Sie können das Erscheinungsbild der Regionsbegrenzungslinien ändern.


Determinante (Operator)

Tastaturbefehl: |

| M |

Gibt die Determinante einer quadratischen Matrix zurück.

Operanden:

  • M ist eine quadratische Matrix.

So ermitteln Sie den Betrag jedes Elements in einer Matrix:

  • Platzieren Sie | M | zwischen die Bearbeitungslinien .

  • Wenden Sie den Operator "Vektorisieren" an (Strg+-).

Statt der numerischen Bestimmung von Determinanten können Sie die Determinanten auch symbolisch suchen.


Diagonalmatrix (Funktion)

diag(v) Gibt eine Diagonalmatrix zurück, die auf ihrer Diagonalen die Elemente von v enthält.

Argumente:

v muss ein Vektor sein.


Komponenteneigenschaften von Excel: Eingaben

Im Dialogfeld für Excel-Eigenschaften können Sie mithilfe der Registerkarte "Eingaben" angeben, in welchen Zellen in der Komponente "Excel" die einzelnen Eingabedaten gespeichert werden sollen. Handelt es sich bei der Eingabe um einen einzelnen Wert, geben Sie die Zelle an, in welcher der Wert gespeichert werden soll. Besteht die Eingabe aus mehreren Werten, ist die Anfangszelle für die Werte einzugeben.

Jede Eingabevariable überträgt Werte aus Mathcad an die Zellen in einem Excel-Arbeitsblatt. Geben Sie einen gültigen Excel-Zellenbereich ein. Für die Zellen C2 bis L11 zum Beispiel geben Sie C2:L11 ein. Sie können auch benannte Zellen eingeben.

Für einen bestimmten Zellenbereich in einem bestimmten Excel-Arbeitsblatt geben Sie den Namen des Arbeitsblatts, dann ein Anführungszeichen und dann den Zellbereich ein. Geben Sie zum Beispiel Sheet2!B2:C2 ein.


Komponenteneigenschaften von Excel: Ausgaben

Im Dialogfeld für Excel-Eigenschaften können Sie mithilfe der Registerkarte "Ausgaben" angeben, aus welchen Zellen in der Komponente "Excel" die einzelnen Ausgabedaten abgerufen werden sollen. Beispiel: Wenn als erste Ausgabe die Werte in den Zellen A1, A2, B1 und B2 verwendet werden sollen, ist für "A1:B2" anzugeben. Sie können auch benannte Zellen eingeben.

Für einen bestimmten Zellenbereich in einem bestimmten Excel-Arbeitsblatt geben Sie den Namen des Arbeitsblatts, dann ein Anführungszeichen und dann den Zellbereich ein. Geben Sie zum Beispiel Sheet2!B2:C2 ein.


Eingabe und Ausgabe von Datendateien: Optionen

Eingabe und Ausgabe von Dateien: Registerkarte "Optionen"

Wählen Sie im Menü Einfügen die Option Dateieingabe oder Dateiausgabe von Daten. In der der Komponente "Dateieneingabe" bzw. "Dateienausgabe" können Sie im Dialogfeld "Eigenschaften" mithilfe der Registerkarte "Dateioptionen" festlegen, dass nur bestimmte Zeilen oder Spalten einer Datendatei eingelesen werden. Sie können die Beschriftung und Kopfzeilen beim Einlesen von Daten überspringen.

  1. Beginn bei Zeile: Geben Sie die Nummer der Zeile an, die den ersten einzulesenden Wert enthält.

  2. Beginn bei Spalte: Geben Sie die Nummer der Spalte an, die den ersten einzulesenden Wert enthält.

Standardmäßig ist sowohl für die Zeilen als auch für die Spalten die Option Stopp bei Datenende aktiviert. Auf diese Weise liest die Komponente "Dateieingabe" bzw. "Dateiausgabe" alle Werte vom Anfangswert bis zum Ende der Datei ein. Sie können aber die Option Stopp bei Datenende auch durch Klicken deaktivieren, und durch Eingabe eines Wertes in das Feld Stopp bei Zeile oder/und Stopp bei Spalte ein anderes Ende festlegen.


Komponenteneigenschaften von MATLAB: Eingaben

Komponenteneigenschaften von MATLAB: Eingabevariablen

Im Dialogfeld "MATLAB-Eigenschaften" können Sie mithilfe der Registerkarte "Eingabevariablen" Namen für die Eingabevariablen für die Komponente "MATLAB" festlegen.


Komponenteneigenschaften von MATLAB: Ausgaben

Komponenteneigenschaften von MATLAB: Ausgabevariablen

Im Dialogfeld "MATLAB-Eigenschaften" können Sie mithilfe der Registerkarte "Ausgabevariablen" Namen für die Ausgabevariablen für die Komponente "MATLAB" festlegen.


Absatzformat (Dialogfeld)

Das Dialogfeld "Absatzformat" enthält die folgenden Elemente:

Einzug – Links, Rechts

Ermöglicht die Festlegung, um wieviel der Absatz vom linken bzw. rechten Rand des Textbereichs aus eingerückt werden soll (auf der Basis der im Betriebssystem festgelegten Einheit).

Extra

Ermöglicht spezielle Formen des Einrückens.

  • Wählen Sie Erste Zeile, um nur die erste Zeile des markierten Absatzes einzurücken. Geben Sie im Feld "um:" an, um wieviel eingerückt werden soll.

  • Wählen Sie Hängend, wenn alle Zeilen außer der ersten eingerückt werden sollen. Geben Sie im Feld "um:" an, um wieviel eingerückt werden soll.

Um

Mithilfe dieses Feldes können Sie bei Absätzen, für die im Feld "Extra" die Option "Erste Zeile" oder "Hängend" gewählt wurde, festlegen, um wieviel der Absatz vom linken Rand des Textbereichs aus eingerückt werden soll (auf der Basis der im Betriebssystem festgelegten Einheit).

Tabulatoren

Öffnet das Dialogfeld "Tabulatoren", in dem Sie Tabulatoren setzen können.

Aufzählungszeichen

Hier finden Sie eine Liste der Symbole, die den markierten Absätzen vorangestellt werden können.

  • Wählen Sie Aufzählungszeichen, wenn runde, schwarze Punkte verwendet werden sollen.

  • Wählen Sie Numerierung, wenn die Absätze durchnummeriert werden sollen (1, 2, 3 usw.).

Ausrichtung – Links, Rechts, Zentriert

Ermöglicht die Festlegung, ob der Text in den markierten Absätzen innerhalb des Textbereichs linksbündig, rechtsbündig oder zentriert dargestellt werden soll.


Komponenteneigenschaften von S-PLUS: Graphtyp

Mithilfe der Optionen auf der Registerkarte "Graphtyp" können Sie festlegen, welche Art von Graph mit der Komponente "S-PLUS Graph" erstellt wird. Wählen Sie eine Optionen aus, um ein Liniendiagramm, GUI-Diagramm oder ein S-PLUS-Diagramm auf der Basis der Befehle (Graph Script) zu erstellen.

GUI-Diagramm

Mit dieser Schaltfläche erstellen Sie in Ihrem Mathcad-Arbeitsblatt ein S-PLUS GUI-Diagramm.

Achsentyp

Zeigt den aktuellen S-PLUS-Achsentyp an.

Diagrammtyp

Zeigt den aktuellen S-PLUS-Diagrammtyp an.

Achsen-/Diagrammtyp auswählen

Öffnet das Dialogfeld "Achsen-/Diagrammtyp auswählen", in dem Sie aus Listenfeldern den gewünschten Achsentyp und den Diagrammtyp auswählen können, zum Beispiel "Log Y Line" und "Streuung".

Graphskript aufrufen

Wählen Sie diese Optionsfläche, um einen S-PLUS-Diagramm mit herkömmlichen Befehlszeilen-Grafikfunktionen zu erstellen. Zur Eingabe von Befehlen müssen Sie den Skripteditor öffnen. Wählen Sie dazu im Kontextmenü der Komponente den Befehl "Skript bearbeiten". Das Skript kann jeden beliebigen S-PLUS-Code mit Aufrufen von plot(), points() usw. zur Erstellung eines oder mehrerer Graphen enthalten.


Komponenteneigenschaften von S-PLUS: Eingabevariablen

Im Dialogfeld "S-PLUS-Eigenschaften" können Sie mithilfe der Registerkarte "Eingabevariablen" Namen für die Eingabevariablen für die Komponente "S-PLUS-Graph" oder die Komponente "S-PLUS-Skript" festlegen.

Variable

(schreibgeschützt) Bezeichnet die Eingabevariablen 1 bis 4.

Zugewiesener Name

Geben Sie die gewünschten Namen für jede einzelne Eingabevariable ein. Die Standardnamen sind in0, in1, in2, in3.

Standardwerte

Klicken Sie auf diese Option, um alle zugewiesenen Namen auf die Standardwerte zurückzusetzen.

Aktivieren Sie die Eingabevariablen, um sie als Bedingungsvariablen in GUI-Graphen zu verwenden: Aktivieren Sie die einzelnen Eingabevariablen, die für das Diagramm Bedingungsvariablen bereitstellen sollen.

Statische Variablennamen

Fügen Sie statische Variablennamen durch Kommas getrennt hinzu. In der Komponente "S-PLUS-Skript" sind statische Variablen die Variablen, deren Werte bei den verschiedenen Aufrufen des Skripts erhalten bleiben. Zu beachten ist dabei, dass alle statischen Variablen zurückgesetzt werden, sobald das Skript selbst geändert wird.


Komponenteneigenschaften von S-PLUS: Ausgabevariablen

Im Dialogfeld "S-PLUS-Eigenschaften" können Sie mithilfe der Registerkarte "Ausgabevariablen" Namen für die Ausgabevariablen für die Komponente "S-PLUS-Graph" oder die Komponente "S-PLUS-Skript" festlegen.

Variable

(schreibgeschützt) Bezeichnet die Ausgabevariablen 1 bis 4.

Zugewiesener Name

Geben Sie die gewünschten Namen für jede einzelne Ausgabevariable ein. Die Standardwerte sind out0, out1, out2, out3.

Standardwerte

Klicken Sie auf diese Option, um alle zugewiesenen Namen auf die Standardwerte zurückzusetzen.


Die Jacobische Matrix


Differenzengleichungen

Sie können Bereichsvariablen in Verbindung mit Feldern verwenden, um eine Differenzengleichung auszuwerten. Das folgende Beispiel zeigt, wie ein Feld mit Fibonaccischen Zahlen ausgefüllt wird.


Lösungsalgorithmen für Differentialgleichungen

Mathcad enthält eine Reihe von Funktionen zum numerischen Lösen von gewöhnlichen Differentialgleichungen (GDG), partiellen Differentialgleichungen (PDG) und Systemen aus GDGs und PDGs. Lösungsalgorithmen für GDGs lösen Gleichungen mit einer Unbekannten und Lösungsalgorithmen für PDGs lösen Gleichungen mit zwei Unbekannten (so genannte 1-D-PDGs). Die Funktionen Gdglösen und Pdglösen werden innerhalb von Lösungsblöcken verwendet, ermöglichen natürliche Notation und sind die am einfachsten zu verwendenden und auszuwertenden Funktionen. Diese Funktionen mit Befehlszeile können innerhalb von Programmen für iterative Berechnungen verwendet werden.

Lösen von gewöhnlichen Differentialgleichungen

Gdglösen(x,b,schritt)

rkfest(y,x1,x2,npunkte,D)

Spezielle GDG-Befehlszeilenalgorithmen

Bulstoer(y,x1,x2,npunkte,D): besondere Genauigkeit für sich langsam verändernde Systeme

Radau(y,x1,x2,npunkte,D), Stiffb(y,x1,x2,npunkte,D,J) oder Stiffr(y,x1,x2,npunkte,D,J): besondere Genauigkeit bei steifen Systemen

Rkadapt(y,x1,x2,npunkte,D): schneller und genauer für Systeme mit sowohl sich schnell als auch sich langsam verändernden Intervallen.

Für jede dieser Lösungsalgorithmen gilt, dass bei Verwendung des Funktionsnamen in Kleinbuchstaben anstelle von Großbuchstaben nur der letzte Punkt des Integrationsintervalls gelöst wird. Dies kann Berechnungszeit und Speicherplatz einsparen. Anders als bei den Funktionen, die mit Großbuchstaben geschrieben werden, geben Sie hier nicht die Anzahl der Punkte im Ergebnis an. stattdessen müssen Sie den Genauigkeitsgrad angeben. Die Funktionen generieren dann eine Lösung mit der benötigten Anzahl von Elementen.

Lösungsalgorithmen für Zweipunkt-Randwertprobleme

grwanp(v1,v2,x1,x2,xf,D,lad1,lad2,entspr)

sgrwl(v,x1,x2,D,lad,entspr)

Partielle Differentialgleichungen

Mathcad enthält eine Reihe von Funktionen zum numerischen Lösen mehrerer Arten von partiellen Differentialgleichungen (PDG) und Systemen aus PDGs. Lösungsalgorithmen für PDGs lösen Gleichungen mit zwei Unbekannten (so genannte 1-D-PDGs). Die Funktion Pdglösen wird innerhalb eines Lösungsblocks verwendet, ermöglicht natürliche Notation und ist die am einfachsten zu verwendende und auszuwertende Funktion. Diese Funktionen mit Befehlszeile können innerhalb von Programmen für iterative Berechnungen verwendet werden.

Pdglösen(u, x, xbereich, t, tbereich, xpts, tpts): Lösungsalgorithmus für ein Gleichungssystem aus hyperbolischen und parabolischen Systemen aus 1-D-PDGs, auch verknüpften GDGs und algebraischen Nebenbedingungen.

numol(x_endpts, xpts, t_endpts, tpts, num_pde, num_pae, pde_func, pinit, bc_func): Befehlszeilen-Lösungsalgorithmus für hyperbolische und parabolische Systeme aus 1-D-PDGs.

relax(a,b,c,d,e,f,u,rjac): Befehlszeilen-Lösungsalgorithmus für elliptische Poisson/Laplace-PDG.

multigit(M,nzyklus): : Befehlszeilen-Lösungsalgorithmus für elliptische Poisson/Laplace-PDG mit Null- oder konstanten Randbedingungen..


Differentialgleichungen mit besonderen Eigenschaften

Folgen Sie dabei dem Beispiel für die Funktion rkfest für eine oder mehrere Differentialgleichungen, verwenden Sie jedoch anstelle von rkfest eine der untenstehenden Funktionen.

  • Verwenden Sie für stetige Systeme die Funktion Bulstoer.

  • Verwenden Sie für steife Systeme die Funktionen Radau, Stiffb oder Stiffr.

  • Verwenden Sie für sich langsam verändernde Systeme die Funktion Rkadapt.


Differentiation (Operator)

Ableitung

Tastaturbefehl: ?

Gibt die Ableitung von f(t) am Punkt t zurück.

Operanden:

f(t) ist eine Funktion mit einem Skalarwert.

t ist der Punkt, an dem die Ableitung ausgewertet werden soll.

Zunächst muss festgelegt werden, an welchem Punkt die Ableitung ausgewertet werden soll. Beispiel:

Hinweise:

  • Im obigen Beispiel ist das Ergebnis die Abteilung von f mit Bezug auf t bei Auswertung an dem oder den Punkten, an denen t zuvor definiert wurde.

  • Das Beispiel zeigt zwar eine Funktion nur einer Variablen, f kann aber eine Funktion jeder beliebigen Anzahl von Variablen sein.

  • Wenn f mehrere Terme hat, müssen diese in Klammern angegeben werden, damit sie innerhalb des Ableitungsoperators bleiben.

  • Beim Ableitungsalgorithmus von Mathcad kann davon ausgegangen werden, dass die erste Ableitung innerhalb von 7 oder 8 signifikanten Ziffern genau ist, vorausgesetzt, dass der Wert, an dem die Ableitung ausgewertet wird, sich nicht zu sehr in der Nähe einer Singularität der Funktion befindet.

  • Sie können dieses Operatorsymbol in der Anzeige durch ein partielles Ableitungssymbol ersetzen, falls gewünscht.


Gestreutes Licht

Gestreutes Licht kommt aus einer bestimmten Richtung, aber es wird von einer Fläche gleichmäßig in unterschiedliche Richtungen gespiegelt. Durch gestreutes Licht wird ein Objekt hell dargestellt. Leuchtstofflampen sind hierfür ein gutes Beispiel.

Umgebungslicht und gestreutes Licht haben bei der Bestimmung der Farbe eines Diagramms die größte Wirkung.


Digammafunktion


Dilogarithmusfunktion


Dimensionen

Eine Dimension ist eine physikalische Größe, die mit einer Zahl, einem Feld oder einer eine Zahl oder ein Feld darstellenden Variable verknüpft ist. Die folgenden Grunddimensionen können beliebig miteinander kombiniert werden:

Länge

Zeit

Masse

Ladung

Temperatur

Beachten Sie, dass eine Dimension keine Einheit ist. Eine Einheit gibt das Maß einer Dimension an. Die Dimension "Länge" kann z. B. in den folgenden drei Einheiten gemessen werden: Meter (m), Zentimeter (cm) und Millimeter (mm).


Dimensionen einer Matrix

zeilen(A) Gibt die Anzahl der Zeilen in A zurück.

spalten(A) Gibt die Anzahl der Spalten in A zurück.

Argumente:

  • A kann sowohl ein Vektor als auch eine Matrix sein.

Wenn A weder ein Vektor noch eine Matrix ist, geben sowohl zeilen als auch spalten 0 zurück.


Delta-Funktion von Dirac (Einheitenimpuls)

Die Delta-Funktion von Dirac wird von Maple als D(x) zurückgegeben, wobei

  • D(0) = 1 und
  • D(x) = 0 überall sonst ist.
Das Integral der Delta-Funktion von Dirac von -unendlich bis +unendlich ist 1.


Gerichtetes Licht

Ein gerichtetes Licht geht von einer bestimmten Quelle aus und leuchtet in einer bestimmten Richtung. Man kann sich gerichtetes Licht wie einen Scheinwerfer vorstellen, der von einer festen Position aus das Diagramm anleuchtet. Ein gerichtetes Licht besteht aus gestreutem Licht und Glanzlicht.


Deaktivieren von Gleichungen

Aktivieren bzw. Deaktivieren von Gleichungen

So verhindern Sie, dass ein Bereich, zum Beispiel eine Gleichung oder ein Diagramm, berechnet wird:

  1. Klicken Sie in die Gleichung.

  2. Wählen Sie aus dem Menü Format die Option Eigenschaften, und klicken Sie auf die Registerkarte "Berechnen".

  3. Klicken Sie auf das Kontrollkästchen "Auswertung deaktivieren".

  4. Klicken Sie auf OK.

Durch ein kleines Feld neben der Gleichung wird angezeigt, dass sie ausgeschaltet (deaktiviert) ist. Beispiel:

Sie aktivieren die Gleichung wieder, indem Sie die Schritte erneut durchführen.

Hinweise:

  • Sie können eine deaktivierte Gleichung ebenso bearbeiten wie andere Gleichungen. Eine deaktivierte Gleichung wirkt sich jedoch nicht auf andere Berechnungen aus, und in ihr werden auch keine Änderungen berücksichtigt, die Sie an anderen Gleichungen im Arbeitsblatt vornehmen.

  • Wenn Sie eine deaktivierte Gleichung verschieben, die ein Ergebnis zeigt, wird das Ergebnis aus der Anzeige gelöscht. Wenn Sie ein deaktiviertes Diagramm verschieben, wird der Inhalt des Diagramms aus der Anzeige gelöscht.


Nachteile des automatischen Modus

Wenn das Arbeitsblatt viele berechnungsintensive Gleichungen enthält, kann das Durchblättern längere Zeit in Anspruch nehmen.


Nachteile des manuellen Modus

Die Ergebnisse im Arbeitsblatt sind möglicherweise nicht aktuell. Wenn dies der Fall ist, wird in der Meldungszeile das Wort "calc" angezeigt.


Verwerfen zu langer Ergebnisse

Die Antwort ist für die Anzeige als formatierter Rechenbereich zu groß. Sie können die Antwort in der Zwischenablage ablegen.


Unstetige oder bedingte Funktionen

wenn(cond, wwert, fwert)

Gibt wwert zurück, wenn cond zutrifft, sonst wird fwert ausgegeben.

(m, n)

Kronecker-Delta-Funktion. Gibt 1 zurück, wenn m = n, andernfalls 0.

sign(x)

Vorzeichen einer Zahl. Gibt 0 zurück, wenn x=0. Ist x>0, wird 1 zurückgegeben, andernfalls -1.

(i,j,k)

Total antisymmetrischer Einheitstensor.

(x)

Heavisidesche Stufenfunktion. Gibt 0 zurück, wenn x<0, andernfalls 1.


Diskrete Transformationsfunktionen

fft(v) und FFT(v)

Gibt die Schnelle Fourier-Transformation reeller Daten in Vektor v zurück. Die in Kleinbuschstaben geschriebene Funktion fft wird durch 1/wurzel(n) normalisiert, die in Großbuchstaben geschriebene Funktion FFT wird durch 1/n normalisiert. Diese Funktionen nehmen Vektoren der Länge 2 m an.

ifft(u) und IFFT(u)

Gibt die inverse Fourier-Transformation unter Annahme eines Vektors u der Länge 1+2m-1 zurück. Gibt v zurück, wenn u=fft(v). Die in Kleinbuschstaben geschriebene Funktion ifft wird durch 1/wurzel(n) normalisiert, die in Großbuchstaben geschriebene Funktion IFFT wird durch 1/n normalisiert. Diese Funktionen nehmen Vektoren der Länge 2 m an.

cfft(A) und CFFT(A)

Gibt die Diskrete Fourier-Transformation reeller oder komplexen Daten in Vektor oder Feld A in beliebiger Größe zurück. Wenn A ein Feld ist, wird die 2-D-Fourier-Transformation zurückgegeben. Die in Kleinbuschstaben geschriebene Funktion cfft wird durch 1/wurzel(n) normalisiert, die in Großbuchstaben geschriebene Funktion CFFT wird durch 1/n normalisiert. Diese Funktionen nehmen Vektoren der Länge 2 m an.

icfft(B) und ICFFT(B)

Gibt die inverse Diskrete Fourier-Transformation eines Feldes in beliebiger Größe zurück. Gibt A zurück, wenn B=cfft(A). Die in Kleinbuschstaben geschriebene Funktion icfft wird durch 1/wurzel(n) normalisiert, die in Großbuchstaben geschriebene Funktion ICFFT wird durch 1/n normalisiert. Diese Funktionen nehmen Vektoren der Länge 2 m an.

wave(v)

Diskrete Wavelet-Transformation reeller Daten im Vektor v.

iwave(u)

Umkehrung von "wave". Gibt v zurück, wenn u=wave(v).


Anzeigeoptionen für ein 3D-Diagramm

Wenn Sie ein 3D-Diagramm erstellen, können Sie es als 3D-Diagramm eines anderen Typs anzeigen lassen, ohne das Diagramm neu zu erstellen. Gehen Sie hierzu folgendermaßen vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Allgemein", damit die Seite Allgemein geöffnet wird.

  3. Mit den Optionen im Abschnitt Darstellungsart können Sie beliebige 3D-Diagramme (außer parametrische Flächendiagramme und Vektorfelddiagramme) in andere 3D-Diagrammtypen umwandeln.

  4. Rufen Sie dann durch Klicken auf "Zuweisen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


Anzeigen eines verschachtelten Feldes

Wenn Sie ein verschachteltes Feld mithilfe des Gleichheitszeichen anzeigen, werden nicht alle Elemente in jedem verschachtelten Feld dargestellt. Eine solche Darstellung kann recht hinderlich sein, vor allem, wenn man bedenkt, dass ein Feld innerhalb eines Feldes selbst weitere Felder enthalten kann.

Stattdessen wird Folgendes angezeigt:

  • eine Zahl, wenn es sich bei dem Feldelement um einen Skalarwert handelt.

  • ein geordnetes Paar "{m,n}", wenn es sich bei dem Feldelement um ein m x n Elemente großes Feld handelt.

Dies wird im folgenden Beispiel veranschaulicht:

Im obigen Beispiel wird das Feld in Form einer Matrix angezeigt. Das vollständige Feld, das durch die Notation repräsentiert wird, können Sie anzeigen, wenn Sie auf das Feld doppelklicken, um das Dialogfeld Ergebnisformat zu öffnen. Klicken Sie dort auf das Feld neben "Geschachtelte Felder erweitern".

Wenn Sie stattdessen das Feld in einer Ausgabetabelle anzeigen, sehen Sie dieselbe Notation in einer Zelle der Tabelle. Soll das durch die Notation repräsentierte Feld vorübergehend in einer Zelle einer Ausgabetabelle angezeigt werden, doppelklicken Sie auf die Zelle, die die Notation enthält. Beispiel:


Anzeigen eines Graustufenbildes

Wenn Sie eine Matrix, die das Graustufenbild enthält, mit BMPLESEN erstellt haben, können Sie das Bild folgendermaßen anzeigen:

  1. Klicken Sie auf die gewünschte Position des Bildes, und wählen Sie aus dem Menü Einfügen den Befehl Bild.

  2. Geben Sie in den Platzhalter den Namen der Matrix ein.

Es wird eine 256-Graustufendarstellung der Daten in der Matrix angezeigt. Jedes Element der Matrix entspricht dabei einem Bildpunkt im Bild.


Anzeigen eines Farbbildes

Wenn Sie eine Matrix, die das Farbbild enthält, mit RGBLESEN erstellt haben, zeigen Sie das Bild wie folgt an:

  1. Teilen Sie die Matrix in ihre Rot-, Grün- und Blau-Anteile auf, wie im folgenden Beispiel gezeigt:

    Sie haben drei gleich große Matrizen definiert, die jeweils die roten, grünen und blauen (RGB) Komponenten, die Komponenten Farbton, Sättigung und Wert (HSV-Farbmodell von Smith) oder die Komponenten Farbton, Helligkeit und Sättigung (HLS-Farbmodell von Otswald) jedes Bildpunktes beschreibt.

  2. Klicken Sie auf die gewünschte Position des Bildes, und wählen Sie aus dem Menü Einfügen den Befehl Bild.

  3. Geben Sie in den Platzhalter im unteren Bildbereich die Namen der drei Matrizen durch Kommas getrennt ein. Soll nur eine Farbkomponente, zum Beispiel der Rotanteil, angezeigt werden, müssen nach wie vor alle drei Matrizen angegeben werden, wobei jedoch die Matrizen für Grün und Blau nur Nullwerte enthalten dürfen.

Standardmäßig erstellt Mathcad eine Dreischicht-, 256-Farb- oder eine RGB-Darstellung der Daten in der Matrix.

Wenn Sie die drei Untermatrizen später wieder kombinieren möchten, erstellen Sie die folgende Funktion, die auf der Funktion erweitern aufbaut, und wenden Sie sie an: erweitern(X,Y,Z):=erweitern(X,erweitern(Y,Z))

Hinweis:

Der Bildbereich nimmt ein 256-Farbmodell an, wobei 0 für schwarz und 255 für weiß steht. Zahlen außerhalb des Bereichs von 0 bis 255 gelten als reduziertes Modulo von 256. Gebrochene Zahlen werden behandelt, als ob ihre Dezimalstellen entfernt wurden.


Anzeigen symbolischer Ergebnisse

Symbolisches Anzeigeformat

Große Antworten

Numerische Ergebnisse mit Symboliken

Spezielle Funktionen

Fehlermeldungen bei symbolischen Berechnungen


Anzeigen des Bildes

Für die Anzeige des Bildes gibt es zwei Optionen. Welche Möglichkeit Sie wählen, hängt davon ab, ob Sie das Bild mit der Funktion BMPLESEN oder RGBLESEN in eine Matrix einlesen:

  • Wenn Sie zum Erstellen der Graustufen-Bildmatrix die Funktion BMPLESEN oder eine mit dieser Funktion in Beziehung stehenden Funktion verwendet haben...

  • Wenn Sie zum Erstellen der Farb-Bildmatrix die Funktion RGBLESEN oder eine mit dieser Funktion in Beziehung stehenden Funktion verwendet haben...


Division (Operator)

Division

Tastaturbefehl: /

Gibt y dividiert durch x zurück. Wenn x=0, wird eine Fehlermeldung angezeigt, die darauf hinweist, dass eine Singularität vorliegt. Wenn es sich bei y um ein Feld handelt, teilt der Divisionsoperator jedes Element des Feldes durch x.

Operanden:

x und y sind Skalarwerte.

x muss ungleich Null sein.

Beachten Sie, dass die unbestimmte Form 0/0 stets 0 ergibt.


Doppelpfeilzeiger

Wenn der Mauszeiger als Doppelpfeil dargestellt wird, können Sie die Größe oder Form des ausgewählten Bereichs ändern. So erhalten Sie diesen Zeiger:

  • Wählen Sie einen Bereich aus.

  • Verschieben Sie den Mauszeiger auf einen der drei Haltepunkte am Rand des Bereichs.

Wenn Sie nun die Maus ziehen, sehen Sie, wie sich die Größe des ausgewählten Bereichs ändert.


Pfeil-nach-unten

In leeren Bereichen

Verschiebt das Fadenkreuz um eine Stelle nach unten. Wenn sich ein anderer Bereich unmittelbar darunter befindet, wird das Fadenkreuz in diesem Bereich angezeigt, und wird entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen

Verschiebt die Bearbeitungslinien nach unten. Wenn sie sich bereits ganz unten im Ausdruck befinden, werden sie aus dem Rechenausdruck in den leeren Bereich unmittelbar darunter versetzt.

In Textbereichen

Verschiebt die Texteinfügemarke in die nächste Zeile. Befindet sie sich bereits in der letzten Zeile, so wird sie ganz aus dem Text in den leeren Bereich versetzt.

Bereiche verschieben

Verschiebt den/die ausgewählten Bereich(e) nach rechts. Bei dauerhaft gedrückter Taste wird schneller nach rechts verschoben.


Ziehen von Bereichen

Wenn Sie einen Bereich oder mehrere Bereiche markiert haben, können Sie diese entweder in einen anderen Teil Ihres Arbeitsblatts oder in ein anderes Arbeitsblatt ziehen. Gehen Sie hierzu folgendermaßen vor:

  1. Verschieben Sie den Mauszeiger in einen der Bereiche, die von einem gestrichelten Markierungsrechteck umrahmt sind. Der Mauszeiger wechselt seine Form von einem Pfeil zu einer kleinen Hand.

  2. Drücken Sie die Maustaste, und halten Sie sie gedrückt.

  3. Verschieben Sie den Mauszeiger bei gedrückter Maustaste. Auf diese Weise können die Umrisse aller markierten Bereiche verschoben werden.

  4. Wenn sich die Umrisse an den gewünschten Positionen befinden, lassen Sie die Maustaste wieder los.

Sollen sich zwei Bereiche überschneiden, können Sie einen Bereich einfach mit der Maus über den anderen ziehen. Falls erforderlich, können Sie die überlappenden Bereiche bearbeiten.


Ziehen von Bereichen in ein anderes Arbeitsblatt

Beim Ziehen von Bereichen in ein anderes Arbeitsblatt muss sehr vorsichtig vorgegangen werden. Wenn Sie den Cursor länger in der Nähe des Fensterrahmens belassen, wird stattdessen das Bild automatisch weitergeblättert.


Ziehen der Maus

So ziehen Sie die Maus:

  1. Drücken Sie die Maustaste, und halten Sie sie gedrückt

  2. Verschieben Sie die Maus bei gedrückter Maustaste.


e (Basis des natürlichen Logarithmus)

Basis des natürlichen Logarithmus

Tastaturbefehl: e

Beschreibung: In numerischen Berechnungen der Wert von e auf 15 Dezimalstellen genau.

Der genaue Wert von e in symbolischen Berechnungen.


Extras - Rechtschreibung

Rechtschreibprüfung für den ausgewählten Text. Wurde kein Text markiert, wird der gesamte Text im aktuellen Textbereich geprüft. Wird ein falsch geschriebenes Word gefunden, wird das Dialogfeld Rechtschreibung mit Vorschlägen für die richtige Schreibweise angezeigt.

Beachten Sie, dass diese Option nur Text überprüft. Die Rechtschreibung in Gleichungen wird nicht überprüft.


Bearbeiten - Kopieren

Kopiert den markierten Bereich in die Zwischenablage. Zum Einfügen des Bereichs wählen Sie im Menü Bearbeiten den Befehl Einfügen.


Bearbeiten - Ausschneiden

Löscht den markierten Bereich und setzt ihn in die Zwischenablage.

Zu beachten ist, dass die Zwischenablage immer nur das zuletzt ausgeschnittene Element enthält.


Bearbeiten - Löschen

Löscht den markierten Bereich, ohne ihn in die Zwischenablage zu verschieben.


Bearbeiten / Suchen...

Öffnet das Dialogfeld "Suchen", in dem Sie Buchstaben, Zahlen oder andere unterstützte Zeichen eingeben können, die gesucht werden sollen. Mit diesem Befehl können Sie nach Zeichen in Text sowie in Variablen- und Funktionsnamen suchen. Bestimmte Zeichen (wie z. B. Kommas) werden aber nur innerhalb von Text oder Zeichenfolgen gesucht.


Bearbeiten / Gehe zu Seite...

Wechselt zu einer bestimmten Seite. Der obere Seitenrand der gewünschten Seite erscheint oben im Fenster.


Bearbeiten / Verknüpfungen

Bearbeitet OLE-Verknüpfungen im Arbeitsblatt. Verknüpfungen können Sie erstellen, indem Sie den Befehl Inhalte einfügen im Menü Bearbeiten wählen. Befinden sich im Arbeitsblatt keine verknüpften Objekte, steht diese Option nicht zur Verfügung.


Bearbeiten / Objekt

Mit diesem Befehl können Sie ein OLE-Objekt bearbeiten oder öffnen, das in ein Arbeitsblatt eingefügt wurde. Sie müssen einmal auf das Objekt klicken, damit dieser Menübefehl verfügbar wird.


Bearbeiten / Einfügen

Fügt den Inhalt der Zwischenablage in das Arbeitsblatt ein. Mathcad versucht, den Inhalt in dem Format einzufügen, das dem Informationstyp am meisten entspricht.

  1. Wenn Sie Mathcad-Bereiche ausschneiden und einfügen, bleiben diese als Mathcad-Bereiche erhalten.
  2. Wenn der Inhalt aus einer anderen Windows-Anwendung stammt und in einen leeren Bereich des Arbeitsblatts eingefügt wird, wird er als OLE-Objekt eingefügt.
  3. Wenn Sie in einen Gleichungsplatzhalter mehrere Zahlen oder Zeichenfolgen einfügen, werden sie als Matrix eingefügt.
  4. Wenn Sie Text aus einer anderen Anwendung in einen Textbereich einfügen, wird er als unformatierter Text eingefügt.

Wenn Sie mit der Art und Weise, wie ein Objekt in Mathcad eingefügt wird, nicht zufrieden sind, verwenden Sie stattdessen den Befehl Bearbeiten/Inhalte einfügen....

Dabei bleibt der Inhalt der Zwischenablage unverändert, sodass er weiterhin zur Verfügung steht.


Bearbeiten / Inhalte einfügen

Öffnet das Dialogfeld "Inhalte einfügen", mit dem der Inhalt der Zwischenablage in einem entsprechend angegebenen Format in das Arbeitsblatt eingefügt werden kann. Soll z. B. ein Bild von einem OLE-Server nicht als eingebettetes oder verknüpftes Objekt, sondern als Bitmap eingefügt werden, öffnen Sie mit dem Befehl Inhalte einfügen das gleichnamige Dialogfeld, und wählen Sie dort die Option Bitmap aus.


Bearbeiten / Wiederholen

Hebt den letzten Rückgängig-Befehl wieder auf. Die Anzahl der Aktionen, die Sie rückgängig machen können, wird im Dialogfeld Einstellungen festgelegt. Der Standardwert lautet 100.


Bearbeiten / Ersetzen...

Öffnet das Dialogfeld "Ersetzen", in dem Sie die Buchstaben, Zahlen oder andere unterstützte Zeichen eingeben können, die gesucht und ersetzt werden sollen. Geben Sie die Zeichenfolge oder die Gruppe von Zeichen, die Sie suchen möchten, im Textfeld Suchen nach ein. Geben Sie die Zeichenfolge, durch die diese ersetzt werden soll, im Textfeld Ersetzen durch ein. Es stehen jetzt drei Möglichkeiten zur Verfügung:

  • Weitersuchen: Sucht nach der nächsten Stelle, an der die gesuchte Zeichenfolge auftritt, und markiert diese.

  • Ersetzen: Ersetzt die jeweils markierte Zeichenfolge.

  • Alle ersetzen: Ersetzt die jeweils markierte Zeichenfolge und sucht nach dem nächsten Auftreten dieser Zeichenfolge.


Bearbeiten / Alles markieren

Markiert bestimmte oder alle Bereiche. Welche Bereiche markiert werden, hängt von der jeweiligen Position des Cursors ab:

  • Schließt alle Bereiche in gestrichelten Rechtecken ein, wenn sich der Mauszeiger an einer leeren Stelle im Arbeitsblatt befindet.

  • Markiert den gesamten Text in einem Textbereich, wenn sich der Mauszeiger in einem Textbereich befindet.

  • Hebt einen Bereich hervor, wenn sich der Mauszeiger in einem Ausdruck oder in einem anderen Rechenbereich befindet.

Nachdem Sie einen oder mehrere Bereiche auf diese Art markiert (ausgewählt) haben, können Sie sie kopieren, ausschneiden oder löschen.


Bearbeiten / Rückgängig

Macht den zuletzt gewählten Bearbeitungsbefehl bzw. Tastenanschlag rückgängig. Der Standardwert für rückgängig gemachte Aktionen lautet 100. Dieser Wert kann im Dialogfeld Einstellungen geändert werden.


Menü "Bearbeiten"

Rückgängig

Wiederholen

Ausschneiden

Kopieren

Einfügen

Inhalte einfügen...

Löschen

Alle auswählen

Suchen

Ersetzen...

Gehe zu Seite...

Verknüpfungen...

Objekt...


Bearbeiten eines Ausdrucks - Beispiel 1

Entnehmen Sie den Informationen unten, was mit dem Ausdruck oben passiert, wenn Sie eine bestimmte Taste drücken.

Mit Entf löschen Sie das Element, das sich unmittelbar rechts neben der Einfügemarke befindet. In diesem Fall wird der Exponent-Operator gelöscht.

Mit der Rücktaste löschen Sie das Element, das sich unmittelbar links neben der Einfügemarke befindet, in diesem Fall die Variable "b". Das schwarze Rechteck ist ein Platzhalter, durch den angezeigt wird, wo Sie eine Eingabe vornehmen müssen, damit die Exponentialberechnung korrekt durchgeführt werden kann.

Durch Drücken der Leertaste verlängern Sie die Bearbeitungslinien, sodass ein größerer Teil des Ausdrucks zwischen sie passt.

Wenn Sie die Pfeil-nach-rechts-Taste drücken, wird die Einfügemarke nach rechts verschoben.

Wenn Sie die Pfeil-nach-links-Taste drücken, wird die Einfügemarke nach links verschoben.

Durch Drücken der Pfeil-nach-oben-Taste werden die Bearbeitungslinien nach oben versetzt.

Mit der Pfeil-nach-unten-Taste werden die Bearbeitungslinien nach unten versetzt. Da die Bearbeitungslinien nicht weiter nach unten versetzt werden können, werden sie aus dem Ausdruck herausverschoben und unter dem Ausdruck als Fadenkreuz angezeigt.

Normalerweise wird der Inhalt zwischen den Bearbeitungslinien zum ersten Operator Ihrer Eingabe.

In diesem Beispiel haben Sie den Operator "plus" eingegeben. Zwischen den Bearbeitungslinien befand sich das "b". Daher wurde das "b" der erste Operand von "plus".

Normalerweise wird der Inhalt zwischen den Bearbeitungslinien zum ersten Operator Ihrer Eingabe.

In diesem Beispiel ist der Operator "Quadratwurzel", und zwischen den Bearbeitungslinien befand sich das "b". Daher wurde das "b" in die Quadratwurzel aufgenommen.

Mit der EINFG-Taste versetzen Sie die Einfügemarke auf die andere Seite. Mit der EINFG-Taste versetzen Sie die Einfügemarke jeweils von einer Seite auf die andere.


Bearbeiten eines Ausdrucks - Beispiel 2

Entnehmen Sie den Informationen unten, was mit dem Ausdruck oben passiert, wenn Sie eine bestimmte Taste drücken.

Durch Drücken der ENTF-Taste wird gelöscht, was sich rechts neben der Einfügemarke befindet. Da dort nichts vorhanden ist, hat das Drücken der ENTF-Taste keine Wirkung.

Mit der Rücktaste wird normalerweise gelöscht, was sich links von der Einfügemarke befindet. Wenn der zu löschende Ausdruck komplizierter ist als ein Name oder eine Zahl, wird er durch Drücken der Rücktaste jedoch wie gezeigt markiert. Wenn Sie die Rücktaste dann erneut drücken, wird er gelöscht. Dadurch ist das unbeabsichtigte Löschen eines Ausdrucks nahezu ausgeschlossen.

Durch Drücken der Leertaste werden die Bearbeitungslinien so weit verlängert, dass sie nun den gesamten Nenner einschließen.

Da sich das "c" direkt links neben der Einfügemarke befindet, wird von den Bearbeitungslinien durch Drücken der Pfeil-nach-links-Taste nur das "c" ausgewählt.

Da rechts von der Einfügemarke keine Elemente vorhanden sind, werden die Bearbeitungslinien durch Drücken der Pfeil-nach-rechts-Taste vollständig aus dem Ausdruck herausverschoben. Die Bearbeitungslinien werden rechts neben dem Ausdruck als Fadenkreuz angezeigt.

Durch Drücken der Pfeil-nach-oben-Taste werden die Bearbeitungslinien nach oben versetzt.

Mit der Pfeil-nach-unten-Taste werden die Bearbeitungslinien nach unten versetzt. Da die Bearbeitungslinien nicht weiter nach unten versetzt werden können, werden sie aus dem Ausdruck herausverschoben und unter dem Ausdruck als Fadenkreuz angezeigt.

Normalerweise wird der Inhalt zwischen den Bearbeitungslinien zum ersten Operator Ihrer Eingabe.

In diesem Beispiel lautet der Operator "plus", und die Einfügemarke schloss den gesamten Ausdruck "b zu c" ein. Deshalb wurde der ganze Ausdruck "b zu c" der erste Operand von "plus".

Normalerweise wird der Inhalt zwischen den Bearbeitungslinien zum ersten (und in diesem Fall einzigen) Operator Ihrer Eingabe.

In diesem Beispiel ist der Operator die Quadratwurzel.

Die EINFG-Taste versetzt die Einfügemarke auf die andere Seite. Durch diese Taste wird die Einfügemarke jeweils von einer Seite auf die andere versetzt.


Bearbeiten eines Ausdrucks - Beispiel 3

Entnehmen Sie den Informationen unten, was mit dem Ausdruck oben passiert, wenn Sie eine bestimmte Taste drücken.

Durch Drücken der ENTF-Taste wird gelöscht, was sich rechts neben der Einfügemarke befindet. Da dort nichts vorhanden ist, hat das Drücken der ENTF-Taste keine Wirkung.

Mit der Rücktaste wird gelöscht, was sich links von der Einfügemarke befindet.

Durch Drücken der Leertaste werden die Bearbeitungslinien so verlängert, dass sie nun den nächsten größeren Ausdruck einschließen, in diesem Fall "b zu c".

Mit der Pfeil-nach-rechts-Taste verschieben Sie die Einfügemarke nach rechts. Da rechts neben der Einfügemarke nichts vorhanden ist, wird die Einfügemarke durch Drücken der Pfeil-nach-rechts-Taste ganz aus dem Ausdruck herausverschoben. Die Einfügemarke nimmt die Form eines Fadenkreuzes rechts neben dem Ausdruck an.

Wenn die Einfügemarke ein Variablenname ist, wird sie durch Drücken der Pfeil-nach-links-Taste um ein Zeichen nach links versetzt.

Durch Drücken der Pfeil-nach-oben-Taste wird die Einfügemarke nach oben versetzt.

Durch Drücken der Pfeil-nach-unten-Taste wird die Einfügemarke nach unten versetzt. Da sich die Einfügemarke oben im Exponent befindet, bedeutet "nach unten" weg vom Exponent und zu "b".

Normalerweise wird der Inhalt zwischen den Bearbeitungslinien zum ersten Operator Ihrer Eingabe.

In diesem Beispiel lautet der Operator "plus", und die Einfügemarke schloss lediglich den gesamten Ausdruck "c" ein. Deshalb wurde der Ausdruck "c" der erste Operand von "plus". Beachten Sie den Platzhalter, für den Sie den zweiten Operanden des Plus eingeben müssen.

Normalerweise wird der Inhalt zwischen den Bearbeitungslinien zum ersten (und in diesem Fall einzigen) Operator Ihrer Eingabe.

In diesem Beispiel ist der Operator die Quadratwurzel.

Die EINFG-Taste versetzt die Einfügemarke auf die andere Seite. Mit der EINFG-Taste versetzen Sie die Einfügemarke jeweils von einer Seite auf die andere. Da die Länge des Variablennamens nur ein Zeichen beträgt, hat dies die gleiche Wirkung wie die Pfeil-nach-links-Taste.


Bearbeiten eines Ausdrucks - Beispiel 4

Entnehmen Sie den Informationen unten, was mit dem Ausdruck oben passiert, wenn Sie eine bestimmte Taste drücken.

Durch Drücken der ENTF-Taste wird gelöscht, was sich rechts neben der Einfügemarke befindet. Da dort nichts vorhanden ist, hat das Drücken der ENTF-Taste keine Wirkung.

Mit der Rücktaste wird normalerweise gelöscht, was sich links von der Einfügemarke befindet. Wenn der zu löschende Ausdruck komplizierter ist als ein Name oder eine Zahl, wird er durch Drücken der Rücktaste jedoch wie gezeigt markiert. Wenn Sie die Rücktaste abermals drücken, wird er gelöscht. Dadurch ist das unbeabsichtigte Löschen eines Ausdrucks nahezu ausgeschlossen.

Durch Drücken der Leertaste werden die Bearbeitungslinien so verlängert, dass sie den nächsten größeren Ausdruck einschließen. Da die Bearbeitungslinien bereits den gesamten Nenner umfassen, muss der nächste größere Ausdruck der ganze Bruch sein.

Da rechts neben der Einfügemarke nichts vorhanden ist, wird die Einfügemarke durch Drücken der Pfeil-nach-rechts-Taste ganz aus dem Ausdruck herausverschoben. Die Einfügemarke nimmt die Form eines Fadenkreuzes rechts neben dem Ausdruck an.

Durch Drücken der Pfeil-nach-links-Taste wird die Einfügemarke um ein Zeichen nach links versetzt. Das links angrenzende Zeichen ist das "c", daher schließt die Einfügemarke nun das "c" ein.

Durch Drücken der Pfeil-nach-oben-Taste wird die Einfügemarke nach oben versetzt.

Durch Drücken der Pfeil-nach-unten-Taste wird die Einfügemarke nach unten versetzt. Da sich die Einfügemarke so weit unten wie möglich befindet, wird sie unter dem Ausdruck als Fadenkreuz angezeigt.

Normalerweise wird der Inhalt zwischen den Bearbeitungslinien zum ersten Operator Ihrer Eingabe.

In diesem Beispiel ist der Operator "plus", und die Einfügemarke schloss den gesamten Nenner ein. Daher wird der ganze Nenner zum ersten Operanden von "plus". Beachten Sie den Platzhalter, für den Sie den zweiten Operanden des Plus eingeben müssen.

Normalerweise wird der Inhalt zwischen den Bearbeitungslinien zum ersten (und in diesem Fall einzigen) Operator Ihrer Eingabe.

In diesem Beispiel ist der Operator die Quadratwurzel, und die Einfügemarke schloss den gesamten Nenner ein. Demzufolge wird der gesamte Nenner zum Operanden der Quadratwurzel. Daher wird er, wie abgebildet, in die Quadratwurzel verschoben.

Mit der EINFG-Taste versetzen Sie die Einfügemarke jeweils von einer Seite auf die andere. Da sich der vertikale Zweig auf der rechten Seite befand, wird er durch Drücken der EINFG-Taste nach links versetzt.


Bearbeiten eines Ausdrucks (allgemein)

Bearbeiten eines Ausdrucks

Beim Bearbeiten eines Ausdrucks werden zwei Schritte durchgeführt:

Setzen des rechten Teils des Ausdrucks zwischen die Bearbeitungslinien.

Drücken der korrekten Taste.

Die Funktionen der einzelnen Tasten richten sich danach, was sich zwischen den Bearbeitungslinien befindet. Klicken Sie unten auf den entsprechenden Ausdruck, um Beschreibungen der Funktionen der am häufigsten verwendeten Tastenkombinationen anzuzeigen, wenn sich die Bearbeitungslinien an der gezeigten Position befinden.


Bearbeitungslinien

Wo können sie angezeigt werden?

Wie werden sie angezeigt?

Wie werden sie verschoben?

Was ist ihre Funktion?


Bearbeiten von Verknüpfungen

Wenn Sie ein Objekt mit dem Befehl Objekt einfügen oder Inhalte einfügen mit einem Arbeitsblatt verknüpft haben, können Sie die Verknüpfung aktualisieren, verändern oder entfernen. Gehen Sie hierzu folgendermaßen vor:

Wählen Sie Verknüpfungen im Menü Bearbeiten. Daraufhin wird das Dialogfeld "Verknüpfungen" geöffnet.


Bearbeiten der Komponenten "S-PLUS-Skript"

Zum Eingeben bzw. Bearbeiten des S-PLUS-Code in die/der Komponente "S-PLUS-Skript" ist wie folgt vorzugehen:

  1. Öffnen Sie den Skripteditor, indem Sie mit der rechten Maustaste auf die Komponente klicken und im Kontextmenü der Komponente den Befehl Skript bearbeiten wählen.

  2. Bearbeiten Sie den Skriptcode.

  3. Wählen Sie den Befehl Schließen und Zurückkehren im Menü Datei des Skripteditors.

Das Skript wird ausgeführt, sobald Sie auf eine Stelle außerhalb der Komponente klicken. Wenn die Syntax eines S-PLUS-Programms nicht analysiert werden kann (weil der Text z. B. eine ungerade Zahl von Klammern enthält), oder wenn bei der Ausführung des Programms ein Fehler auftritt, erscheint ein Popup-Fenster.


Bearbeiten des Skripts eines Steuerelements

Zum Bearbeiten des Skripts eines MathSoft-Steuerelements gehen Sie wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf das Steuerelement, und wählen Sie im Kontextmenü Skript bearbeiten.

  2. Nehmen Sie Ihre Änderungen vor, und schließen Sie den Skripteditor.

  3. Zum Aktualisieren der Komponente in Ihrem Mathcad-Arbeitsblatt wählen Sie Arbeitsblatt berechnen im Menü Extras, oder klicken Sie auf die Komponente, und drücken Sie die Taste [F9].

Hinweis:

  • Sie können keine Zeichenfolge als Eingabe an ein MathSoft-Steuerelement senden. Skalare, Vektoren und Matrizen sind die einzigen zugelassenen Typen von Eingabevariablen. Sie können jedoch eine Ausgabevariable als Zeichenfolge in einem MathSoft-Steuerelement definieren. Weitere Informationen finden Sie unter "Programmierung" in den QuickSheets, die mehrere Beispiele von MathSoft-Steuerelementen enthalten.

  • Weitere Informationen zu Eigenschaften, Methoden und Ereignissen im Zusammenhang mit MathSoft-Steuerelementen finden Sie in der Developer's Reference (Entwickler-Referenz) .


Effektiver Zinssatz

eff(rate, nper) Gibt den effektiven jährlichen Zinssatz (JZS) zurück, der sich aus dem nominalen Zinssatz und der Anzahl der jährlichen Verzinsungsperioden ergibt.

Argumente:

zsatz ist der nominale Zinssatz, der jeweils für eine Verzinsungsperiode berechnet wird. zsatz muss eine reelle skalare Zahl sein. Er kann als Dezimalzahl (z.B. 0.0825) oder als Prozentsatz (z.B. 8.25%) ausgedrückt werden.

nper ist die Gesamtzahl der Verzinsungsperioden. nper>0.


Eigenwerte und Eigenvektoren

Eigenwerte und Eigenvektoren (Funktionen)

eigenvec(M,z)

Gibt einen Eigenvektor zurück, der mit dem Eigenwert z der Matrix M verbunden ist.

eigenvals(M)

Gibt die Eigenwerte von M zurück.

eigenvecs(M)

Ermittelt normalisierte Eigenvektoren, die den Eigenwerten der Matrix M entsprechen.

genvals(M,N)

Ermittelt generalisierte Eigenwerte.

genvecs(M)

Ermittelt generalisierte Eigenvektoren.


Eigenwertegleichung


E-Books

Ein elektronisches Mathcad-Buch ist eine Sammlung von mit Hyperlinks versehenen, interaktiven Mathcad-Arbeitsblättern zu bestimmten Fachgebieten.


Eingebettete Schriftartcodes

Eingebettete Schriftartcodes wie "MFNT_03_" vor Variablennamen stehen für die Schriftart, in der der Variablenname angezeigt werden soll.


Eingebettetes Objekt

Ein Objekt, das die Anwendung, mit der es erstellt wurde, und eine Kopie seiner selbst im Anwendungsfenster öffnet, sobald Sie darauf doppelklicken. Wenn die Anwendung die Aktivierung an Ort und Stelle unterstützt, werden statt der Mathcad-Menüs und -Symbolleisten die Menüs und Symbolleisten der anderen Anwendung angezeigt, und um das Objekt erscheint eine gestrichelte Linie.

Jegliche Änderungen, die Sie am Objekt vornehmen, wirken sich nur auf das Objekt in Mathcad aus. Dies ist ungefähr so, als würden Sie eine Fotokopie anfertigen und Änderungen nur auf der Kopie vornehmen, während das Original unverändert bleibt.


Leerer Raum

Dies ist der Raum zwischen Bereichen. Wenn Sie im leeren Raum klicken, erscheint ein Fadenkreuz.

Leerstellen, die Variablen und Operatoren in einer Gleichung voneinander trennen, werden nicht als leerer Raum bezeichnet.


Ein Datei-E/A-Fehler ist aufgetreten.

Mathcad konnte keine Daten aus einer Datendatei ordnungsgemäß einlesen. Vergewissern Sie sich, dass Sie keine Datenpunkte lesen, die in der Datei nicht existieren.


Ende

In leeren Bereichen...

Verschiebt das Fadenkreuz neben den nächsten Bereich. Wenn sich das Fadenkreuz bereits am letzten Bereich befindet, ist dieser Tastaturbefehl unwirksam.

In Rechenbereichen...

Verschiebt die Bearbeitungslinien zum Ende des Ausdrucks. Wenn sich die Bearbeitungslinien bereits dort befinden, ist dieser Tastaturbefehl unwirksam.

In Textbereichen...

Verschiebt die Texteinfügemarke an das Zeilenende. Wenn sich die Einfügemarke bereits dort befindet, ist dieser Tastaturbefehl unwirksam.


Dateiende

Sie haben versucht, mehr Datenwerte aus einer Datendatei abzulesen, als Werte in dieser Datei enthalten sind. Nehmen wir an, die Datei enthält zehn Zahlen, und Sie geben Folgendes ein:

i:1;100

x[i:READ(file)

Es wird diese Meldung angezeigt.


Endpunkte müssen sich unterscheiden.

Die Endpunkte des Intervalls, in denen die Lösung ausgewertet wird, müssen unterschiedlich sein. Diese Meldung erscheint häufig im Zusammenhang mit den Lösungsalgorithmen für Differentialgleichungen.


Erhöhen des Bildkontrasts


Eingabe

In leeren Bereichen...

Verschiebt das Fadenkreuz eine Stelle nach unten und zum linken Rand des Arbeitsblatts.

In Rechenbereichen...

Entfernt die Bearbeitungslinien aus dem Ausdruck und setzt sie als Fadenkreuz in den leeren Bereich darunter.

In Textbereichen...

Beginnt eine neue Zeile in einem neuen Absatz.


Eingeben von binären Zahlen

Zum Eingeben einer binären Zahl gehen Sie wie folgt vor:

  1. Geben Sie die Ziffern für die Zahl ein. Gültig sind die Ziffern 0 und 1.

  2. Geben Sie direkt hinter der letzten Ziffer in der Zahl den Buchstaben "b" (oder "B ") ein.

Beispiel:

    1101b

Hinweis:

Wegen der angedeuteten Multiplikation fügt Mathcad möglicherweise ein kurzes Leerzeichen zwischen der letzten Ziffer und dem "b" ein. Sie müssen dieses Leerzeichen löschen, indem Sie die Einfügemarke rechts davon positionieren und die Rücktaste drücken. Die binäre Zahl darf keine Leerzeichen aufweisen.


Eingeben von komplexen Zahlen

Zum Eingeben einer komplexen Zahl gehen Sie wie folgt vor:

  1. Geben Sie den Realteil ein.

  2. Geben Sie "+" (oder "-") ein.

  3. Geben Sie den Imaginärteil ein.

  4. Geben Sie i oder j ein. Zwischen dem Imaginärteil und dem i oder j darf es keine Leerstelle geben.

Beispiel:

1 + 2i 1 - 33.4j

3 + 1i 2 -1j

Bei der Arbeit mit komplexen Zahlen sind oft die speziellen Funktionen und Operatoren von Mathcad zu empfehlen.


Eingeben von hexadezimalen Zahlen

Zum Eingeben einer hexadezimalen Zahl gehen Sie wie folgt vor:

  1. Wenn es sich bei der ersten Ziffer der Zahl um einen der Buchstaben a bis f handelt, müssen Sie vor der Zahl eine "0" eingeben. Wenn Sie dies versäumen, wird der von Ihnen eingegebene Wert als Variable und nicht als Zahl interpretiert.

  2. Geben Sie die Ziffern für die Zahl ein. Sie können dazu die Zahlen 0 bis 9 und die Buchstaben a bis f verwenden.

  3. Geben Sie den Buchstaben "h" (oder "H ") direkt hinter der letzten Ziffer in der Zahl ein.

Beispiel:

  1. 2b3ch

  2. 0a32H

Hinweis:

Wegen der angedeuteten Multiplikation fügt Mathcad möglicherweise ein Leerzeichen zwischen der letzten Ziffer und dem "h" ein. Das Arbeitsblatt versucht außerdem, ein Leerzeichen zwischen die Hexadezimalzeichen (a - f) und Zahlenwerte (0-9) einzufügen. Sie müssen dieses Leerzeichen löschen, indem Sie die Einfügemarke rechts davon positionieren und die Rücktaste drücken. Hexadezimale Zahlen dürfen keine Leerzeichen aufweisen.


Eingeben von imaginären Zahlen

Um eine Zahl imaginär zu machen, muss ihr unmittelbar ein i oder j nachfolgen. Beispiel:

i -33.4j

1i

1j

Wenn Sie entweder i oder j separat eingeben, wird es als Variablenname und nicht als die imaginäre Einheit angesehen. Um die imaginären Zahlen i und j in Ihr Dokument einzufügen, müssen Sie "1i" bzw. "1j" eingeben. Die Ziffer "1" wird nicht mehr angezeigt, wenn Sie auf eine Stelle außerhalb der Zahl klicken.

Sie können zwar imaginäre Zahlen eingeben, auf die entweder i oder j folgt, das Arbeitsblatt zeigt jedoch hinter diesen Zahlen normalerweise i an. Damit imaginäre Zahlen mit j angezeigt werden, müssen Sie durch Wählen von Ergebnis im Menü Format das Dialogfeld Ergebnisformat aufrufen.


Eingeben von Zahlen > 999

Beim Eingeben von Zahlen größer als 999 dürfen keine Trennungspunkte, Kommas oder Leerzeichen zwischen den einzelnen Hundertern, Tausendern usw. verwendet werden. Geben Sie die Ziffern einfach hintereinander ein.

Für Zehntausend ist die Eingabe beispielsweise "10000". Geben Sie nicht "10,000" oder "10.000" ein.

Kommas werden nur im Zusammenhang mit Bereichsvariablen und zur Eingabe von Indizes für Felder verwendet. Der Punkt darf nur als Dezimalkomma oder für die Eingabe von Literalindizes Verwendung finden.


Eingeben von Zahlen in wissenschaftlicher Schreibweise

Zum Eingeben einer Zahl in wissenschaftlicher Schreibweise gehen Sie wie folgt vor:

  1. Geben Sie die Zahl ein, die zu einer Potenz von 10 erhoben werden soll.

  2. Geben Sie "*10^" ein.

  3. Geben Sie im leeren Platzhalter die korrekte Potenz von 10 ein.


Eingeben von Zahlen mit anderen Basen

Sie können Zahlen in binärer, oktaler oder hexadezimaler anstelle von dezimaler Form eingeben. Informationen dazu, wie Sie nichtdezimale Zahlen eingeben können, erhalten Sie, wenn Sie auf das entsprechende Thema klicken:

Eingeben von binären Zahlen

Eingeben von hexadezimalen Zahlen

Eingeben von oktalen Zahlen


Eingeben von oktalen Zahlen

Zum Eingeben einer oktalen Zahl gehen Sie wie folgt vor:

  1. Geben Sie die Ziffern für die Zahl ein, die reell sein muss. Sie können dazu die Ziffern 0 bis 7 verwenden.

  2. Geben Sie den Buchstaben "o" (oder "O ") direkt hinter der letzten Ziffer in der Zahl ein.

Beispiel:

    32o

Hinweis:

Wegen der angedeuteten Multiplikation fügt Mathcad möglicherweise ein kurzes Leerzeichen zwischen der letzten Ziffer und dem "o" ein. Sie müssen dieses Leerzeichen löschen, indem Sie die Einfügemarke rechts davon positionieren und die Rücktaste drücken. Oktale Zahlen dürfen keine Leerzeichen aufweisen.


Gleichheitszeichen für die Definition (:=)

Eingabe...

Funktion...

Beschränkungen links von ":="...

Beschränkungen rechts von ":="...

Ändern der Darstellungsweise


Gleichheitszeichen für die Auswertung (=)

Eingabe...

Funktion...

Beschränkungen links von "="...

Beschränkungen rechts von "="...


Gleich (Operator)

Tastaturbefehl: Strg+=

x [image] y

Gibt 1 zurück, wenn x = y, andernfalls 0.

Operanden:

  • x and y können reelle oder komplexe Skalare bzw. Felder sein.

Sie können diesen Operator ändern zu "=", falls gewünscht.


Gleichheitszeichen

Es gibt zwei grundsätzlich unterschiedliche Arten von Gleichheitszeichen. Diese sind:

Das Auswertungsgleichheitszeichen

Das Zuweisungsgleichheitszeichen

Beachten Sie, dass durch keines dieser Gleichheitszeichen wirklich angegeben wird, dass die beiden Seiten eines Ausdrucks gleich sind. Beachten Sie außerdem, dass es nicht möglich ist, Ausdrücke symbolisch auszuwerten und nicht numerische, falls Sie die Antwort als Variablen wünschen.


Gleichungsformat (Dialogfeld)

Dialogfeld "Gleichungsformat"

Im Dialogfeld "Gleichungsformat" finden Sie die folgenden Optionen und Schaltflächen:

Name der Vorlage

Liste der Formatvorlagen mit den folgenden Einträgen:

"Variablen" - Formatvorlage für alle Variablen im Arbeitsblatt
"Konstanten" - Formatvorlage für alle Zahlen im Arbeitsblatt
"Benutzer 1", "Benutzer 2" usw. - Formatvorlagen, die geändert, mit einem Namen versehen und einzelnen Konstanten oder Variablen zugewiesen werden können.

Neuer Name der Vorlage

Geben Sie in dieses Feld einen neuen Namen ein, wenn die markierte Formatvorlage umbenannt werden soll. Dies ist im Normalfall nur für die Formatvorlagen "Benutzer 1", "Benutzer 2" usw. erforderlich.

Ändern

Klicken Sie hierauf, wenn Sie die Schriftart, den Schriftstil, die Schriftgröße oder die Schriftfarbe der ausgewählten Formatvorlage ändern wollen.

Standardfarbe für Gleichungen

Ermöglicht die Festlegung der Standardfarbe für Variablen und Konstanten.


Die Variable ERR

Die vordefinierte Variable ERR gibt die Größe des Fehlervektors für die näherungsweise Lösung an.

Zur Bestimmung der Fehlergröße einzelner Lösungen von Unbekannten ist keine vordefinierte Variable verfügbar.


Die Funktionswerte müssen entgegengesetzte Zeichen sein.

Die Funktionswerte an den Endpunkten mit zwei Klammern müssen entgegengesetzte Zeichen sein.

Wenn Sie die Klammerversion der Funktion wurzel verwenden, bilden die "Klammern" das dritte bzw. das vierte Argument. Mathcad sucht zwischen den beiden Klammern nach einer Lösung. Die Funktion, die an der ersten Klammer ausgewertet wird, muss ein anderes Vorzeichen aufweisen als die Funktion, die an der zweiten Klammer ausgewertet wird. Beispiel:

f(x):=sin(x+10)

x:=1

wurzel(f(x),x,1,8)

ergibt einen Fehler, da f(1)=-1 and f(5)=-.751. Versuchen Sie, die Funktion in einem Diagramm darzustellen, um abzuschätzen, wo in etwa die Wurzel liegen könnte. Verwenden Sie dann Werte links und rechts der vermuteten Wurzel als Klammern. Im obigen Beispiel könnten Sie stattdessen wurzel(f(x),x,1,5) verwenden.


Kein gültiges Intervall.

Für bestimmte Funktionen sind zwei Argumente erforderlich, die den Start und das Ende eines Intervalls festlegen. Der Startwert muss kleiner sein als der Endwert.

Für die runif-Funktion zum Beispiel sind die beiden Argumente a und b erforderlich, wobei a und b die Endpunkte repräsentieren und a kleiner als b sein muss.


Ungültiges Vektorformat.

Ungültiges Vektorformat. Drücken Sie F1, um die Hilfe aufzurufen.

Bestimmte Funktionen benötigen ein Argument, das ein Ergebnis einer anderen Funktion ist. Auch wenn es sich bei diesem Argument nur um einen Vektor handelt, muss er ein spezielles Format aufweisen, das nur von einer anderen Funktion erstellt werden kann.

Zum Beispiel ist als erstes Argument für interp ein Vektor erforderlich, der von einer spline-Funktion generiert wird.


Es müssen mehr Datenpunkte als Parameter vorhanden sein.

Die Funktion regress erfordert drei Argumente:

  • vx ist ein Vektor aus reellen Datenwerten.

  • vy ist ein Vektor aus reellen Datenwerten.

  • k ist eine positive ganze Zahl, die die Ordnung des Polynoms angibt, das Sie an die Daten anpassen möchten.

Diese Fehlermeldung wird ausgegeben, wenn k größer oder gleich der Anzahl der Werte in vx und vy ist. Um herauszufinden, wieviele Werte in vx oder vy enthalten sind, geben Sie Zeilen(vx) bzw. Zeilen(vy) ein.

Für die Funktion genfit müssen mehr Datenpunkte als unbekannte Parameter vorhanden sein. Weitere Informationen zu genfit erhalten Sie, wenn Sie auf den Funktionsnamen in Ihrem Arbeitsblatt klicken und dann F1 drücken.


Die Anzahl der Zeilen muss eine Potenz von 2 sein.

Diese Fehlermeldung betrifft eine Wavelet-Transformation, deren Argument die falsche Anzahl von Elementen enthält. Das Argument muss ein Vektor mit 2n-Elementen sein.


Dieses Bildformat wird nicht unterstützt.

Die speziellen Funktionen zum Lesen von Bildern, wie READ_IMAGE, READ_RED usw. können nur Dateien der folgenden Formate lesen: BMP, JPG, GIF, PCX und TGA.


Die Matrix muss positiv und bestimmt sein.

Dieser Fehler tritt auf, wenn das Matrixargument für eine Funktion positiv sein müsste, jedoch nicht positiv ist. Eine Matrix ist positiv und bestimmt, wenn ihre sämtlichen Eigenwerte reelle, positive Zahlen sind und umgekehrt. Beispiel:

R ist positiv und bestimmt, M jedoch nicht.


Fehlerfunktion und komplementäre Fehlerfunktion

Zwischen der Fehlerfunktion und der komplementären Fehlerfunktion besteht die folgende Beziehung:

erfc(x) := 1 - fehlf(x)

Argumente:

x ist ein dimensionsloser komplexer Skalar.


Fehlerfunktion in symbolischen Ergebnissen

Für |Z| < 4 ist ein Bereich von N=0 TO 100 zu verwenden.


Fehler im GDG-Block.

In Mathcad ist für den Lösungsblock der gewöhnlichen Differentialgleichung (GDG) ein Fehler aufgetreten. Dieser Fehler könnte durch einen von mehreren Faktoren verursacht worden sein:

  • Ihr Lösungsblock weist Ableitungen von mehreren Funktionen auf, als es Gleichungen gibt (n Gleichungen in n unbekannten Funktionen).

  • Für die Anzahl unbekannter Funktionen sind Ihre Bedingungen unzureichend oder zu restriktiv. Die Anzahl der Bedingungen muss der Summe der Ordnungen der GDGs entsprechen.

  • Das Lösungsprogramm konnte das GDG-System nicht interpretieren: Sie sollten die Funktionsnamen prüfen und überprüfen, ob alle Funktionen mit der Variable (x(t), nicht nur x) angegeben sind, ob alle Anfangsbedingungen von Ableitungen unter der Verwendung der Primärnotation [Strg F7] angegeben sind und ob die GDGs in den Ableitungen höchster Ordnung linear sind. Weitere Informationen finden Sie in der Beschreibung von Gdglösen.


Fehlermeldungen in symbolischen Berechnungen

Die Fehlermeldungen, die bei symbolischen Berechnungen angezeigt werden, sind u. a.:

Argument zu groß.

Zu langes Ergebnis

Erwartet Feld oder Liste.

Ausdruck enthält nicht-symbolische Operatoren.

Gleitkommawerte werden nicht verarbeitet.

Ungültige Funktionssyntax.

Ganze Zahl zu groß

Ungültige Argumente.

Bereichsfehler.

Stapelgrenze erreicht. Keine Antwort gefunden.

Keine Antwort gefunden.

Keine geschlossene Form gefunden für . . .

Objekt zu groß.

Syntaxfehler.


Euler-Konstante


Eulersche Gammafunktion

InG(x) Gibt ln(G(x)) zurück, und kann bei sehr großem x erfolgreich ausgewertet werden, wobei G(x) zu Überlauffehlern führt.

Argumente:

z ist ein dimensionsloser komplexer Skalar.

x ist ein dimensionsloser reeller Skalar.


Gammafunktionen

G(z) Gibt den Wert der Eulerschen Gammafunktion von z zurück.

G(a,x) Gibt den Wert der unvollständigen Gammafunktion von x mit dem Parameter a zurück.

InG(z) Gibt den natürlichen Logarithmus der Eulerschen Gammafunktion, berechnet mit z, zurück.

Argumente:

z ist ein reeller oder komplexer Skalar. z kann nicht 0, -1, -2... sein.

a ist ein positiver reeller Skalar.

x ist ein positiver reeller Skalar.

Die Eulersche Gammafunktion ist gegeben durch:

Die unvollständige Gammafunktion ist gegeben durch:

Folgende Beziehungen mit Gammafunktionen können sich als nützlich erweisen:

(a,0) = [image] (a)

(z + 1) = z [image] (z)

(z). (1 [image] - z) = p . csc(p . z)

(n + 1) = n!

Hinweise:

  • Bei komplexen z ist [image] (z) die analytische Fortsetzung der reellen Funktion.

  • Für z = 0, -1, -2... ist [image] (z) nicht definiert.


Die Rolle des Gleichheitszeichens für die Definition

Die Rolle des Gleichzeitszeichens für die Definition

Wertet aus, was rechts vom ":=" steht und weist das Ergebnis den Zeichen zu, die links von ":=" stehen.


Auswerten von Ausdrücken mit "="

Wertet aus, was sich links von "=" befindet und zeigt die Antwort rechts von "=" an.


Auswerten einer Funktion

Zum Auswerten einer benutzerdefinierten Funktion gehen Sie wie folgt vor:

  1. Positionieren Sie das Fadenkreuz durch Klicken unterhalb der Definition der Funktion, und geben Sie den Funktionsnamen gefolgt von einer linken Klammer ein.

  2. Geben Sie eine Liste von durch Kommas abgetrennten Argumenten gefolgt von einer rechten Klammer ein.

  3. Drücken Sie “=”


Auswerten eines Ausdrucks über einen Bereich

Mathcad kann wiederholte Berechnungen ebenso einfach durchführen wie einzelne, indem es eine Bereichsvariable verwendet. Eine Bereichsvariable steht für eine Folge von Werten.

Zum Berechnen von Gleichungen für einen Wertebereich gehen Sie folgendermaßen vor:

  1. Definieren Sie eine Bereichsvariable.

  2. Bewerten Sie einen Ausdruck mit der Bereichsvariablen.


Schritt 1 beim Durchlaufen eines Arbeitsblatts

Von ":=" wird der Wert "1" der Variable "x" zugewiesen. Sie fügen das ":=" ein, indem Sie die Doppelpunkttaste (:) drücken.

Der schwarze Punkt auf der linken Seite ist der "Ankerpunkt". Durch diesen Punkt ist die Position der Definition präzise festgelegt. Sie können die Ankerpunkte sichtbar machen, indem Sie Bereiche im Menü Ansicht wählen.


Schritt 2 beim Durchlaufen eines Arbeitsblatts

Hiermit wird eine f(z)-Funktion definiert. Beachten Sie, dass z nicht festgelegt werden muss, da es nur als Scheinargument verwendet wird. z muss nicht unbedingt bekannt sein, um eine Funktion damit definieren zu können.


Schritt 3 beim Durchlaufen eines Arbeitsblatts

Das "=" verwendet den aktuellen Wert von x und zeigt ihn auf der rechten Seite an.


Schritt 4 beim Durchlaufen eines Arbeitsblatts

Hiermit wird die Funktion f am aktuellen Wert von x ausgewertet.


Schritt 5 beim Durchlaufen eines Arbeitsblatts

Hiermit wird x neu definiert. Über diesem Punkt ist für x weiterhin "1" festgelegt. Unter diesem Punkt gilt "33" für x.


Schritt 6 beim Durchlaufen eines Arbeitsblatts

Hiermit wird die Funktion f am aktuellen Wert von x ausgewertet. Da x nun 33 ist, gilt: f(x) = 3x = 99.


Schritt 7 beim Durchlaufen eines Arbeitsblatts

Dieses Diagramm hat eine falsche Position, weil sich der Ankerpunkt (der schwarze Punkt auf der linken Seite) über dem Ankerpunkt befindet, an dem u definiert ist. Daher ist u noch nicht definiert, wenn dieses Diagramm ausgewertet wird. Nicht definierte Variablen werden rot angezeigt.


Schritt 8 beim Durchlaufen eines Arbeitsblatts

Hiermit wird u als Bereichsvariable definiert, indem ihm die Abfolge 1, 2, 3...10 zugeordnet wird. Bereichsvariablen sind für die Erstellung von Diagrammen unerlässlich.

Sie fügen das ".." ein, indem Sie die Semikolontaste (;) drücken.


Schritt 9 beim Durchlaufen eines Arbeitsblatts

Dieses Diagramm ist korrekt positioniert. Sowohl die Bereichsvariable u als auch die Funktion f sind vor dem Ankerpunkt in der oberen linken Ecke dieses Diagramms definiert.


Symbolleiste "Auswertung"

Über die Symbolleiste "Auswertung" haben Sie schnellen Zugriff auf die Auswertungsoperatoren und die angepassten Operatoren. Sie können sehen, wozu die einzelnen Schaltflächen dienen, wenn Sie den Cursor im Haupt-Arbeitsblattfenster über die Schaltfläche setzen, bis:

  • eine QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche erscheint, und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


Sortieren von Daten in einer Matrix nach den Werten in einer bestimmten Spalte

csort(A, n) Gibt ein Feld zurück, das sich dadurch ergibt, dass die Zeilen von A so umgeordnet werden, bis die Werte in Spalte n in aufsteigender Reihenfolge angeordnet sind.

Argumente:

A ist eine Matrix.

Denken Sie daran, dass die Numerierung von Matrizen stets mit Zeile Eins und Spalte Eins beginnt, sofern Sie nicht den Wert der vordefinierten Variable ORIGIN ändern. Der Standardwert ist 1.


Beispiel für hervorgehobenen Text


Sortieren von Daten in umgekehrter Reihenfolge

umkehren(v) Gibt einen Vektor zurück, in dem sich die Elemente von v in umgekehrter Reihenfolge befinden.

Argumente:

v ist ein Vektor.


Sortieren von Daten in einer Matrix nach den Werten in einer bestimmten Zeile

rsort(A, n) Gibt ein Feld zurück, das sich dadurch ergibt, dass die Spalten von A so umgeordnet werden, bis die Werte in Zeile n in aufsteigender Reihenfolge angeordnet sind.

Argumente:

A ist eine Matrix.

Denken Sie daran, dass die Numerierung von Matrizen stets mit Zeile Null und Spalte Null beginnt, sofern Sie nicht den Wert der vordefinierten Variable ORIGIN ändern.


Beispiel für markierten Text


Sortieren von Daten in auf- bzw. absteigender Reihenfolge

sort(v) Gibt einen Vektor mit den Werten von v in aufsteigender Reihenfolge zurück.

Argumente:

v ist ein Vektor.

Denken Sie daran, dass die Numerierung von Matrizen stets mit Zeile Null und Spalte Null beginnt, sofern Sie nicht den Wert der vordefinierten Variable ORIGIN ändern.

Um einen Vektor in absteigender Reihenfolge zu sortieren, verwenden Sie die Funktion umkehren(v) wie folgt:

umkehren(sort(v))


Beispiele für die Umrissdiagrammformatierung

Ein Umrissdiagramm, das entsprechend eines Farbschemas mit Farbe gefüllt wurde:

Ein Umrissdiagramm ohne Füllung:

Ein Umrissdiagramm mit einem Graustufenfarbschema:

Ein Umrissdiagramm mit 8 Umrissen:

Ein Umrissdiagramm mit nummerierten Umrissen:


Beispiele für Flächendiagrammformatierung

Ein Flächendiagramm mit Farben entsprechend eines Farbschemas:

Ein Flächendiagramm mit Farben entsprechend eines Graustufenfarbschemas:

Ein Flächendiagramm mit einem Drahtmodell (links) und ohne Linien (rechts):


Eigenschaften der Komponente "Excel": Eingaben

Mithilfe der Registerkarte Eingaben im Dialogfeld für Excel-Eigenschaften können Sie angeben, in welchen Zellen in der Komponente "Excel" die einzelnen Eingabedaten gespeichert werden sollen. Handelt es sich bei der Eingabe um einen einzelnen Wert, geben Sie die Zelle an, in der der Wert gespeichert werden soll. Besteht die Eingabe aus mehreren Werten, ist die Anfangszelle für die Werte einzugeben.

Jede Eingabevariable überträgt Werte aus Ihrem Arbeitsblatt an die Zellen in einem Excel-Arbeitsblatt. Geben Sie einen gültigen Excel-Zellenbereich ein. Für die Zellen C2 bis L11 geben Sie beispielsweise C2:L11 ein. Sie können auch benannte Zellen eingeben.

Für einen bestimmten Zellenbereich in einem bestimmten Excel-Arbeitsblatt geben Sie den Namen des Arbeitsblatts, dann ein Ausrufezeichen und dann den Zellbereich ein. Geben Sie beispielsweise Sheet2!B2:C2 ein.


Eigenschaften der Komponente "Excel": Ausgaben

Mithilfe der Registerkarte Ausgaben im Dialogfeld für Excel-Eigenschaften können Sie angeben, aus welchen Zellen in der Komponente "Excel" die einzelnen Ausgabedaten abgerufen werden sollen. Beispiel: Wenn als erste Ausgabe die Werte in den Zellen A1, A2, B1 und B2 verwendet werden sollen, ist für Ausgabe 1 "A1:B2" anzugeben. Sie können auch benannte Zellen eingeben.

Für einen bestimmten Zellenbereich in einem bestimmten Excel-Arbeitsblatt geben Sie den Namen des Arbeitsblatts, dann ein Ausrufezeichen und dann den Zellenbereich ein. Geben Sie zum Beispiel Sheet2!B2:C2 ein.


Andere Seiten des Excel-Setup-Assistenten

Auf den Seiten des Excel-Setup-Assistenten können Sie Folgendes festlegen:

  • Die Anzahl der Ein- und Ausgabevariablen. Sie können eine Reihe von Eingabe- und Ausgabevariablen angeben.

  • Eingaben

  • Ausgaben


Erste Seite des Excel-Setup-Assistenten

So verwenden Sie die erste Seite des Excel-Setup-Assistenten:

  • Wenn Sie eine Verbindung mit einer Datei herstellen wollen, die bereits existiert, wählen Sie Aus Datei erstellen, und geben Sie in das Textfeld den Namen des Pfades ein. Mithilfe der Schaltfläche Durchsuchen können Sie nach der Datei suchen. Klicken Sie dann auf Öffnen. Soll keine Verbindung zu einer bereits existierenden Datei hergestellt werden, wählen Sie Leeres Excel-Arbeitsblatt erstellen.

  • Klicken Sie auf Als Symbol, wenn statt eines Teils der Excel-Datei lediglich ein Symbol in Ihrem Arbeitsblatt erscheinen soll.


Operator "Ausschließendes Oder" (XOR)

Tastaturbefehl: Strg+Umschalt+5

x [image] y Gibt 1 zurück, wenn x oder y, jedoch nicht beide zugleich, einen Wert ungleich 0 (wahr) aufweisen. Andernfalls wird 0 zurückgegeben.

Operanden:

  • x und y sind reelle oder komplexe Skalare.

Hinweis:

Der Wert Null steht für FALSCH, alle Werte ungleich Null für WAHR.


Beenden des Programms

Wählen Sie den Befehl Beenden im Menü Datei, um Mathcad vollständig zu beenden.

Wenn seit dem letzten Speichern des Arbeitsblatts Änderungen vorgenommen wurden, werden Sie aufgefordert, das Arbeitsblatt vor dem Schließen zu speichern.


Symbolik / Erweitern

Erweitert alle Potenzen und Summenprodukte im ausgewählten Ausdruck.


Reihenerweiterung

Leitet eine Potenzreihe für einen Ausdruck in Bezug auf eine Variable ab, die Sie im Ausdruck markieren. In einem Dialogfeld können Sie die Reihenfolge der Reihe bestimmen.


Erweitern eines ausgeblendeten Bereichs

Wenn Sie einen Bereich ausgeblendet und damit die in ihr enthaltenen Bereiche unsichtbar gemacht haben, können Sie den Bereich auch wieder erweitern, sodass die unsichtbar gemachten Bereiche wieder sichtbar werden. So erweitern Sie einen Bereich ein:

1. Klicken Sie auf die Linie, die den ausgeblendeten Bereich repräsentiert.

2. Wählen Sie den Befehl Bereich / Erweitern im Menü Format.

Statt der einzelnen Linie erscheinen nun wieder zwei Begrenzungslinien, zwischen denen die zuvor unsichtbar gemachten Bereiche angezeigt werden.

Die Bereiche, die sich unterhalb der Linie befunden haben, die den ausgeblendete Bereich repräsentierte, werden entsprechend nach unten verschoben.

Hinweis: Wenn ein ausgeblendeter Bereich gesperrt ist, müssen Sie ihn freigeben, bevor Sie ihn erweitern können.


Erweitern von Ausdrücken

Zum Ausmultiplizieren von Potenzen und Produkten von Polynomen gehen Sie folgendermaßen vor:

  1. Setzen Sie den zu erweiternden Ausdruck (oder Teilausdruck) zwischen die Bearbeitungslinien.

  2. Wählen Sie den Befehl Erweitern im Menü Symbolik.

Besonderheiten beim Erweitern von Ausdrücken:

  • Wenn es sich bei dem Ausdruck um einen Bruch handelt, wird der Zähler erweitert und der Ausdruck in eine Summe von Funktionen umgeformt.

  • Sinus, Kosinus und Tangens der Summen von Variablen sowie ganzzahlige Vielfache von Variablen werden so weit wie möglich in Ausdrücke erweitert, die lediglich Sinus und Cosinus für einzelne Variablen enthalten.

  • Wenn der Ausdruck nicht weiter erweitert werden kann, wird er von diesem Befehl unverändert zurückgegeben.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle das Schlüsselwort "erweitern" und die aktive symbolische Berechnung.


Erwartet Feld oder Liste

Die Operatoren in dem Ausdruck, den Sie vereinfachen oder auswerten, benötigen Vektor- oder Matrixoperanden.


Exponentialverteilung

Verteilungsgeneratoren für die Exponentialgleichung:

dexp(x,r) Gibt die Wahrscheinlichkeitsdichte zurück.

pexp(x,r) Gibt die kumulative Wahrscheinlichkeit zurück.

qexp(p,r) Gibt die inverse kumulative Wahrscheinlichkeit zurück.

rexp(m,r) Gibt einen Vektor von m Zufallszahlen zurück, die die Exponentialverteilung aufweisen.


Numerische Probleme bei Exponentialfunktionen

Exponentialfunktionen - numerische Probleme

Da Funktionen unter Verwendung von Gleitkommazahlen mit doppelter Genauigkeit ausgewertet werden, kommt es unweigerlich zu Rundungsfehlern, die sich auf die Berechnungen auswirken. Dies gilt vor allem dann, wenn das Argument der Funktion extreme Werte annimmt.

exp und e^x

Die Funktion exp verwendet einen Algorithmus, der nicht einfach einen Näherungswert für e in eine Potenz erhebt. Bei sehr großen oder kleinen Werten im Exponenten ist die Funktion exp robuster.

Die genauesten Werte bei sehr großen Argumenten lassen sich mithilfe der symbolischen Auswertung von exp(x) mit einem dezimalen Argument für x erreichen. Beispiel: exp(300000).


Exponentialintegral


Exponentialregression

expfit(vx, vy, [vg]) Gibt einen Vektor mit den Koeffizienten einer Sinuskurve der Form ae(bx)+c zurück, die die Daten in vx und vy am besten darstellt. vg enthält Schätzwerte für die drei Koeffizienten.

Argumente:

  • vx ist ein Vektor aus reellen Datenwerten. Die Werte in vx entsprechen den x-Werten.

  • vy ist ein Vektor aus reellen Datenwerten. Die Werte in vy entsprechen den y-Werten.

  • vg ist ein dreidimensionaler Vektor mit reellen Schätzwerten für die Parameter a, b und c in der Exponentialgleichung:

Hinweis: vx und vy müssen jeweils die gleiche Anzahl von Elementen enthalten.


Operator "Potenzieren"

Potenzieren

Tastaturbefehl: ^

Gibt y hoch x zurück.

Operanden:

x und y sind Skalare.

x muss dimensionslos sein.


Exportieren von Daten

Nachdem Sie Berechnungen in Mathcad vorgenommen haben, können Sie die Ergebnisse in eine Datendatei exportieren oder schreiben bzw. die Ergebnisse in die Zwischenablage stellen, von wo aus sie in andere Anwendungen eingefügt werden können.

Einmaliges Exportieren von Daten in eine Datendatei

Interaktives Schreiben von Daten in eine Datendatei unter Verwendung von Komponenten

Interaktives Schreiben in eine Datendatei an der Befehlszeile, unter Verwendung der WRITEPRN- oder APPENDPRN-Funktionen.

Schreiben von binären Daten in eine Datendatei

Verschieben von Daten in die Zwischenablage


Exportieren von Daten in eine Datei (Definition)

Exportieren von Daten in eine Datei

Die in einem Durchgang erfolgende Übertragung von Daten aus einem Mathcad-Arbeitsblatt in eine externe Datendatei.


Ausdruck enthält nicht-symbolische Operatoren

Sie versuchen, eine symbolische Operation auf einen Ausdruck anzuwenden, der Operator- oder Variablenplatzhalter enthält.


Ausdruckstyp

IsScalar(x)

Gibt 1 zurück, wenn x ein Skalar ist, andernfalls 0.

IsArray(x)

Gibt 1 zurück, wenn x ein Vektor oder eine Matrix ist, andernfalls 0.

IsString(x)

Gibt 1 zurück, wenn x eine Zeichenfolge ist, andernfalls 0.

UnitsOf(z)

Gibt die Einheit von z zurück. Gibt 1 zurück, wenn für z keine Einheiten definiert sind.


Erweiterungspakete

Die Erweiterungspakete von Mathcad sind, wie die Elektronischen Bücher, eine Sammlung von mehreren Hundert mit Hyperlinks versehenen interaktiven Mathcad-Arbeitsblättern. Im Gegensatz zu einem Elektronischen Buch fügt das Erweiterungspaket Mathcad zusätzliche Funktionen hinzu. So wird Mathcad z. B. mit dem Erweiterungspaket für Signalverarbeitung um Funktionen für das Anlegen von digitalen Filtern erweitert.


F-Verteilung

Verteilungsgeneratoren für die F-Verteilung:

dF(x,d1,d2) Gibt die Wahrscheinlichkeitsdichte zurück.

pF(x,d1,d2) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qF(p,d1,d2) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rF(m,d1,d2) Gibt einen Vektor aus m Zufallszahlen zurück, die die F-Verteilung aufweisen.


Symbolik / Faktorisieren

Faktorisiert den ausgewählten Ausdruck zu einem Produkt, wenn der gesamte Ausdruck als Produkt notiert werden kann. Soll ein Teilausdruck eines größeren Ausdrucks faktorisiert werden, so markieren Sie den Teilausdruck. Mit diesem Befehl können Sie eine Summe von Brüchen zu einem einzigen Bruch zusammenfassen.


Operator "Fakultät"

Fakultät

Tastaturbefehl: !

n!

Gibt n(n-1)(n-2)...1 zurück.

Operanden:

n muss als nicht-negative ganze Zahl angegeben werden.

Fakultäten für n>170 führen bei numerischer Auswertung zu einem Überlauf. Zum Auswerten von großen Fakultäten steht Ihnen jedoch der Symbolprozessor zur Verfügung.

Für Bruchfakultäten ist die Gamma-Funktion zu verwenden, wobei folgende Beziehung gilt:

G(n+1) = n!


Faktorisieren von Polynomen

Zum Umformen eines Ausdrucks in ein Produkt von Termen gehen Sie folgendermaßen vor:

  1. Setzen Sie den zu faktorisierenden Ausdruck (oder Teilausdruck) zwischen die Bearbeitungslinien.

  2. Wählen Sie Faktorisieren im Menü Symbolik.

Hinweise:

  • Zu beachten ist, dass mit diesem Befehl keine Ausdrücke faktorisiert werden können, die Konstanten mit Dezimalkomma enthalten.

  • Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle das Schlüsselwort "factor" und die aktive symbolische Berechnung.


Fourier-Transformation komplexer Daten (cfft/CFFT-Funktionen)

Fourier-Transformationen komplexer Daten

cfft(A) Gibt die Diskrete Fourier-Transformation eines Vektors oder einer Matrix zurück. Das Ergebnis hat dieselbe Anzahl von Zeilen und Spalten wie A. Wenn A ein Vektor ist, wird das Ergebnis mit der folgenden Gleichung berechnet:

wobei n die Anzahl der Elemente in v darstellt. Bei Matrixargumenten gibt cfft die zweidimensionale Fourier-Transformation zurück.

CFFT(A) Gibt die Diskrete Fourier-Transformation eines Vektors oder einer Matrix zurück. Das Ergebnis hat dieselbe Anzahl von Zeilen und Spalten wie A. Wenn A ein Vektor ist, wird das Ergebnis mit der folgenden Gleichung berechnet:

Argumente:

  • A kann sowohl ein Vektor als auch eine Matrix beliebiger Größe sein, obwohl die Funktion schneller ist, wenn die Anzahl Elemente im Vektor 2m ist. Ein Vektor, dessen Länge eine große Primzahl ist, verlangsamt den diskreten Fourier-Transformationsalgorithmus.

Hinweise:

  • Wenn A ein Vektor mit reellem Wert ist, der 2m Elemente (m>2) hat, verwenden Sie stattdessen fft/FFT. Bei solchen Vektoren ist die zweite Hälfte des Spektrums die komplexe Konjugation der ersten und braucht daher nicht berechnet zu werden.

  • Die mit dem k-ten Element verknüpfte Frequenz im berechneten Fourier-Tranformationsspektrum wird dargestellt durch

    , wobei fs die Abtastfrequenz des ursprünglichen Signals und n die Anzahl der Messungen angibt. Da k eine ganze Zahl sein muss, findet die Verteilung im Spektrum folglich nur dann statt, wenn die Abtastfrequenz so ausgewählt wurde, dass

    immer für eine beliebige Periode 1/T einer ganzen Zahl im Signal entspricht.

  • Die Abtastfrequenz unterscheidet sich von der Frequenz bzw. den Frequenzen des ursprünglichen Zeitbereichssignals.

  • Wenn Sie cfft verwenden, um zum Frequenzbereich zu gelangen, können Sie nur mit cifft zum Zeitbereich zurückkehren. Wenn Sie CFFT verwenden, müssen Sie eine inverse Transformation mit CIFFT durchführen.


Fourier-Transformationen reeller Daten (fft/FFT-Funktionen)

Fourier-Transformationen reeller Daten

fft(v) Gibt die Schnelle Fourier-Transformation eines Vektors zurück. Das Ergebnis ist ein aus [image] -Elementen bestehender Vektor, dessen k-tes Element gegeben ist durch:

Dabei gibt n die Anzahl von Elementen in v an, und i ist die imaginäre Einheit.

FFT(v) Gibt die Fourier-Transformation eines Vektors zurück. Das Ergebnis ist ein aus [image] -Elementen bestehender Vektor, dessen k-tes Element gegeben ist durch:

Argumente:

  • v ist ein aus [image] -Elementen (m>2) bestehender Vektor mit reellem Wert.

Hinweise:

  • Die mit dem k-ten Element verknüpfte Frequenz im berechneten Fourier-Tranformationsspektrum wird dargestellt durch

    , wobei fs die Abtastfrequenz des ursprünglichen Signals und n die Anzahl der Messungen angibt. Da k eine ganze Zahl sein muss, findet die Verteilung im Spektrum folglich nur dann statt, wenn die Abtastfrequenz so ausgewählt wurde, dass

    immer für eine beliebige Periode 1/T einer ganzen Zahl im Signal entspricht.

  • Die Abtastfrequenz unterscheidet sich von der Frequenz bzw. den Frequenzen des ursprünglichen Zeitbereichssignals.

  • Wenn Sie fft verwenden, um zum Frequenzbereich zu gelangen, können Sie nur mit ifft zum Zeitbereich zurückkehren. Wenn Sie FFT verwenden, müssen Sie eine inverse Transformation mit IFFT durchführen.

  • Die fft/ifft-Funktionen nutzen den Voteil der komplexen Konjugationssymmetrie der Fourier-Transformation, die nur für reelle Eingabedaten gilt. Mathcad ignoriert die zweite Hälfte des Frequenzspektrums und spart dadurch Zeit und Speicherplatz. Für Vektoren mit komplexen Werten oder einer beliebigen anderen Anzahl von Elementen sollten Sie stattdessen cfft oder CFFT verwenden. Bei zweidimensionalen Fourier-Transformationen sollten Sie ebenfalls stattdessen cfft/CFFT verwenden.


Datei - Schreibfreigabe

Hiermit können Sie die Änderungen speichern, die Sie an einem in einem SharePoint-Datenspeicher gespeicherten Arbeitsblatt vorgenommen haben. Diese Option steht nur dann zur Verfügung, wenn für das aktive Arbeitsblatt in SharePoint eine Schreibfreigabe erteilt wurde.


Datei - Schreibzugriff

Hiermit können Sie eine Datei eines SharePoint-Datenspeichers öffnen und haben die Möglichkeit, Ihre Änderungen in den Datenspeicher zu übernehmen. Diese Option steht nur dann zur Verfügung, wenn das aktive Arbeitsblatt in SharePoint als schreibgeschützt geöffnet wurde. Sobald für ein Arbeitsblatt Schreibzugriff erteilt wurde, wird diese Menüoption durch eine Option für die Schreibfreigabe Ihres Arbeitsblattes ersetzt.


Datei / Schließen

Schließt das aktive Arbeitsblatt.

Wurde das Arbeitsblatt nach dem letzten Speichern noch verändert, werden Sie gefragt, ob die Änderungen im aktuellen Arbeitsblatt gespeichert werden sollen.


Datei / Schließen und Zurückkehren

Schließt das aktive Arbeitsblatt, das ein eingebettetes Objekt anzeigt. Wurde das Arbeitsblatt nach dem letzten Speichern noch verändert, werden Sie gefragt, ob die Änderungen im aktuellen Arbeitsblatt gespeichert werden sollen. Dieser Befehl ist nur dann verfügbar, wenn Sie ein Mathcad-Objekt bearbeiten, das in eine andere Anwendung eingebettet ist, und die Bearbeitung in einem eigenen Fenster, nicht in der Anwendung selbst erfolgt.


Datei / Beenden

Beendet das Programm.

Wenn Sie nur das aktuelle Arbeitsblatt schließen, aber mit dem Programm weiterarbeiten möchten, ist stattdessen der Befehl Schließen im Menü Datei zu wählen.


Datei / Neu

Mit dem Befehl Neu im Menü Datei können Sie ein Dialogfeld mit einer Liste von auswählbaren Vorlagen öffnen. Wenn Sie ein leeres, unbenanntes Arbeitsblatt erstellen möchten, wählen Sie Normal.

Wenn Sie ein neues Arbeitsblatt auf der Grundlage der Vorlage Normal erstellen möchten, klicken Sie auf die erste Schaltfläche in der Standard-Symbolleiste. Um eine neue Vorlage zu erstellen, wählen Sie Speichern unter...Vorlage im Menü Datei.


Datei / Öffnen...

Zeigt eine Liste der Arbeitsblätter an, die im aktuellen Verzeichnis gespeichert sind. Sie können das gewünschte Arbeitsblatt öffnen, indem Sie auf den entsprechenden Listeneintrag doppelklicken. Wenn Ihr Arbeitsblatt in einem anderen Verzeichnis auf dem Computer oder im Netzwerk gespeichert ist, können Sie in dieses Verzeichnis wechseln, indem Sie die Auswahl in der Dropdown-Liste Suchen in ändern oder manuell den vollständigen Pfad der Datei im Feld Dateiname angeben.

Verwenden Sie das Feld Dateityp, um eine Datei anderen Typs zu öffnen.

Wenn Sie in Ihrer Netzwerkumgebung ein Verzeichnis erstellt haben, das auf einen Webserver mit Windows 2000- oder XP WebDAV-Unterstützung verweist, können Sie über dieses Dialogfeld Dateien auf dem Server suchen und öffnen. Sie können auch direkt im Feld Dateiname URLs eingeben.


Datei / Seite einrichten...

Öffnet ein Dialogfeld, in dem Sie Folgendes einstellen können:

  • die vier Seitenränder.

  • ob auch die Bereiche (bzw. Teile von Bereichen), die über den rechten Rand hinausreichen, mitgedruckt werden sollen.

  • Papierformat, Zufuhr und Ausrichtung.


Datei / Drucken

Öffnet ein Dialogfeld, in dem Sie Folgendes wählen können:

  • Den zu druckenden Bereich, also das gesamte Arbeitsblatt, einen Seitenbereich oder nur die aktuelle Markierung. Die aktuelle Seite ist die Seite, auf der das rote Fadenkreuz angezeigt wird, und nicht notwendigerweise die Seite, die derzeit im Anwendungsfenster sichtbar ist.

  • Den zu druckenden Seitenbereich.

Wenn Sie einen Plotter als Ausgabegerät gewählt haben, können Sie jeweils nur eine Seite drucken.

Die gewählten Einstellungen gelten nur für den aktuellen Druckauftrag.


Datei / Seitenansicht...

Verändert die Bildschirmdarstellung, sodass Sie das genaue Druckbild der aktuellen Arbeitsblattseite erkennen können. Sie können das Arbeitsblatt mit den Schaltflächen Nächste Seite und Vorherige Seite oben am Bildschirm durchblättern oder das Arbeitsblatt mit der Schaltfläche Drucken drucken.


Datei / Vorherige Dateien

Am unteren Ende des Menüs Datei werden die zuletzt geöffneten Arbeitsblätter aufgelistet. Wenn Sie auf eines dieser Arbeitsblätter klicken, wird es geöffnet.


Datei / Speichern

Ist das aktuelle Arbeitsblatt neu erstellt worden, werden Sie nach diesem Befehl zur Eingabe eines Namens aufgefordert. Wurde das Arbeitsblatt jedoch bereits gespeichert, so wird die gespeicherte Kopie auf dem Datenträger durch den aktuellen Fensterinhalt ersetzt.

Sie haben hier die Möglichkeit, eine Datei als Arbeitsblatt, als Arbeitsblatt einer älteren Version, als RTF (Rich Text Format)-Datei oder als HTML/MathML-Datei zu speichern.


Datei / Speichern unter...

Fordert Sie zur Eingabe eines neuen Namens auf, unter dem das aktuelle Arbeitsblatt gespeichert wird. Sie können Ihre Datei in einem der folgenden Formate speichern:

  • Als Mathcad 11-Arbeitsblatt (*.mcd)

  • Als Mathcad 2001i-Arbeitsblatt (*.mcd)

  • Als Mathcad 2001-Arbeitsblatt (*.mcd)

  • Als Mathcad 2000-Arbeitsblatt (*.mcd)

  • Als Mathcad 8-Arbeitsblatt (*.mcd)

  • Als Mathcad 7-Arbeitsblatt (*.mcd)

  • Als Mathcad 6-Arbeitsblatt (*.mcd)

  • Als Vorlage (ein Dokument, in dem die Formate für neue Mathcad-Arbeitsblätter festgelegt werden)

  • Als RTF (Rich Text Format)-Datei für Microsoft Word

  • Als HTML/MathML-Datei


Datei / Als Web-Seite speichern...

Fordert Sie zur Eingabe eines neuen Namens auf, unter dem das aktuelle Arbeitsblatt mit der Erweiterung .htm gespeichert wird. Der aktuelle Name des Arbeitsblattes ist die Standardeinstellung. Sobald Sie auf Speichern geklickt haben, wird ein zweites Dialogfeld mit Einstellungen aufgerufen, in dem Sie Folgendes festlegen können:

  • Das Format, das für den Export des Rechenbereichs (Bilder, MathML) verwendet werden soll

  • Das Format, das für Bilddateien (.jpg, .png) verwendet werden soll

  • Das Format, das für das Layout (absolute, relative Positionierung) verwendet werden soll

  • Vorlagen-Wrapper-Datei, falls gewünscht

  • Seitentitel, falls gewünscht

  • Option zum unmittelbaren Öffnen der gespeicherten Seite mit Ihrem Standardbrowser.

Alle in Mathcad gespeicherten HTML-Dateien können von Mathcad aufgrund des im Code gespeicherten MathML-Inhalts weiterhin von Mathcad berechnet werden. Diese Informationen werden unabhängig vom Darstellungsmechanismus gespeichert, der für die Rechenbereiche (Bilder, MathML-Präsentation) ausgewählt wurde. Die einzige Ausnahme bilden geschützte Dateien. In diesem Fall können lediglich die Darstellungsinformationen gespeichert werden.

Weitere Informationen finden Sie unter Creating Mathcad Files for MathML Export in Author's Reference.


Datei / Kopie speichern unter...

Fordert Sie zur Eingabe eines neuen Namens auf, unter dem das aktuelle Arbeitsblatt gespeichert wird. Sie haben hier die Möglichkeit, eine Datei als Arbeitsblatt, als Arbeitsblatt einer älteren Version oder als RTF (Rich Text Format)-Datei zu speichern. Dieser Befehl ist nur dann verfügbar, wenn Sie ein Mathcad-Objekt bearbeiten, das in eine andere Anwendung eingebettet ist, und die Bearbeitung in einem eigenen Fenster, nicht in der Anwendung selbst erfolgt.


Datei / Senden...

Versendet das aktive Arbeitsblatt per E-Mail über ein beliebiges kompatibles E-Mail-System. Damit Sie diesen Befehl nutzen können, müssen Sie mit einem E-Mail-Server verbunden sein.


Datei / Aktualisieren

Kopien des Arbeitsblatts, die in anderen Anwendungen enthalten sind, werden anhand der vorgenommenen Änderungen aktualisiert. Dieser Befehl ist nur verfügbar, wenn Sie ein Objekt bearbeiten, das in einer anderen Anwendung eingebettet ist, und die Bearbeitung in einem eigenen Fenster, nicht in der Anwendung selbst erfolgt.


Dateizugriffsfunktionen

Importieren und Exportieren von Dateien

PRNLESEN("Datei")

Liest ein aus mehreren Werten bestehendes Feld aus einer Datendatei.

PRNSCHREIBEN("Datei")

Schreibt ein aus mehreren Werten bestehendes Feld in eine Datendatei.

PRNANHÄNGEN("Datei")

Fügt einer bereits bestehenden Datendatei ein aus mehreren Werten bestehendes Feld hinzu.

BINLESEN("Datei", "Typ", [[endian], [cols], [skip], [maxrows]])

Liest ein aus mehreren Werten bestehendes Feld aus einer Datendatei.

BINSCHREIBEN("Datei", "Typ", endian)

Schreibt ein aus mehreren Werten bestehendes Feld in eine Datendatei.

RGBLESEN("Datei")

Liest eine Farbbilddatei.

BMPLESEN("Datei")

Liest eine Bilddatei als Graustufenbild.

RGBSCHREIBEN("Datei")

Erstellt eine Farbbilddatei.

BMPSCHREIBEN("Datei")

Erstellt eine Graustufenbilddatei.


Die Datei konnte nicht geöffnet werden. Bitte überprüfen Sie, ob die Datei existiert.

Die Datendatei oder eine andere externe Datei, die Sie importieren möchten, wurde nicht gefunden, oder die Datendatei, in die Sie versuchen zu schreiben, ist schreibgeschützt.

Überprüfen Sie, ob Sie den Dateipfad richtig angegeben haben und ob sich die Datei im entsprechenden Verzeichnis befindet. Stellen Sie außerdem sicher, dass die Datei nicht schreibgeschützt ist. Beachten Sie, dass Sie den vollständigen Pfad zur Datei angeben müssen, sofern sie sich nicht im Programmordner befindet.


Menü "Datei"

Neu

Öffnen

Aktualisieren

Schließen

Schließen und Zurückkehren

Speichern

Speichern unter...

Als Web-Seite speichern...

Senden...

Seite einrichten...

Seitenansicht

Drucken...

Liste zuletzt geöffneter Arbeitsblätter

Beenden


Dateiname

Dateiname (Definition)

Ein Dateiname ist der Name für eine Datei einschließlich der jeweiligen Dateinamenerweiterung.

Beispiel: tuba.txt.


Filtern von Daten

Zum Filtern der Daten vor dem Einlesen aus einer ODBC-Komponente können Sie Ihre Datenbank unter Verwendung einer SQL-"where"-Anweisung direkt über die ODBC-Komponente abfragen.

Gehen Sie dazu wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf die Komponente, und wählen Sie im Kontextmenü den Befehl Eigenschaften.

  2. Aktivieren Sie auf der Registerkarte Erweitert die Option Use SQL, und geben Sie in das Textfeld eine "where"-Anweisung ein.

  3. Klicken Sie auf OK, um das Dialogfeld zu schließen und Ihr Arbeitsblatt zu aktualisieren.

Die Abbildung unten zeigt ein Beispiel für die Verwendung einer SQL-"where"-Anweisung:


Finanzfunktionen

verzper(zsatz, gw, zw)

Berechnet die Anzahl der Verzinsungsperioden, die zum Erzielen eines bestimmten Wertes aus einer Kapitalanlage erforderlich sind.

fzins(nper, gw, zw)

Berechnet den festen Zinssatz pro Periode, der erforderlich ist, damit eine Kapitalanlage einen bestimmten Wert erzielt.

kumzins(zsatz, nper, gw, start, ende, [typ])

Berechnet die gezahlten kumulativen Zinsen für ein Darlehen.

kumtilg(zsatz, nper, gw, start, ende, [typ])

Berechnet die kumulative Tilgung für ein Darlehen.

eff(zsatz, nper)

Berechnet den effektiven Jahreszins.

zw(zsatz, nper, zrate, [[gw], [typ]])

Berechnet den künftigen Wert einer Kapitalanlage.

zwzz(prin, sched)

Berechnet den zukünftigen Wert eines Anfangskapitals, nachdem eine Reihe von Zinseszinssätzen angewendet wurde.

zwz(zsatz, liste)

Berechnet den zukünftigen Wert von Zahlungen, die einen bestimmten Zinssatz erzielen.

gesverz(zsatz, per, nper, gw, [[zw], [typ]])

Berechnet die Zinszahlung zu einer Kapitalanlage für einen gegebenen Zeitraum.

izf(liste, [schätzwert])

Berechnet den internen Zinsfuß für eine Reihe von Zahlungen.

mizf(liste, finanzrate, reinvestitionsrate)

Berechnet den modifizierten internen Zinsfuß für eine Reihe von Zahlungen.

nom(zsatz, nper)

Berechnet den nominalen Zinssatz pro Jahr.

nper(zsatz, zrate, gw, [[zw], [typ]])

Berechnet die Anzahl der Verzinsungsperioden für eine Kapitalanlage oder ein Darlehen auf der Basis regelmäßiger Zahlungen und eines konstanten Zinssatzes.

gnw(zsatz, liste)

Berechnet den gegenwärtigen Nettowert einer Kapitalanlage auf der Basis eines Abzinsungsfaktors und einer Reihe von Zahlungen.

zrate(zsatz, nper, gw, [[zw], [typ]])

Berechnet die Zahlungen pro Periode für ein Darlehen.

trate(zsatz, per, nper, gw, [[zw], [typ]])

Berechnet die Tilgungsrate für die Rückzahlung eines Kapitalbetrags für eine bestimmte Periode.

gw(zsatz, nper, zrate, [[zw], [typ]])

Berechnet den gegenwärtigen Wert einer Kapitalanlage auf der Basis regelmäßiger Zahlungen und eines festen Zinssatzes.

zsatz(nper, zrate, gw, [[zw], [typ], [schätzwert]])

Berechnet den Zinssatz pro Verzinsungsperiode eines Jahres.


Dialogfeld "Suchen"

Im Dialogfeld "Suchen" finden Sie die folgenden Optionen und Schaltflächen:

Suchen nach:

Geben Sie die gesuchten Zeichen ein.

Nur ganzes Wort suchen

Markieren Sie dieses Kontrollkästchen, wenn die Zeichen im Feld Suchen nach nur als ganzes Wort und nicht als Bestandteil längerer Wörter gesucht werden sollen.

Groß-/Kleinschreibung beachten

Wenn diese Option aktiviert ist, wird nur nach Text gesucht, der genau der Groß- bzw. Kleinschreibung der Zeichen im Feld Suchen nach entspricht.

In Textbereichen suchen

Markieren Sie dieses Kontrollkästchen, wenn die Zeichen nur in den Textbereichen gesucht werden sollen.

In Rechenbereichen suchen

Markieren Sie dieses Kontrollkästchen, wenn die Zeichen nur in den Textbereichen gesucht werden sollen.

Aufwärts

Mit dieser Schaltfläche können Sie angeben, dass Mathcad oberhalb der Position des Fadenkreuzes nach dem angegebenen Text suchen soll.

Abwärts

Mit dieser Schaltfläche können Sie angeben, dass Mathcad unterhalb der Position des Fadenkreuzes nach dem angegebenen Text suchen soll.

Weitersuchen

Sucht die nächste bzw. vorangegangene Stelle, an der die Zeichen aus dem Textfeld Suchen nach: vorkommen.


Suchen nach einem einzelnen Eigenvektor

eigenvec(M,z) Gibt einen Eigenvektor zurück, der mit dem Eigenwert z der Matrix M verbunden ist. Der Eigenvektor ist entsprechend der Einheitenlänge normalisiert.

Argumente:

M muss eine Quadratmatrix sein.

z muss ein Eigenwert von M sein.

z muss komplex sein.


Suchen nach Eigenwerten

eigenwerte(M) Gibt einen Vektor zurück, dessen Elemente die Eigenwerte von M sind.

Argumente:

M muss eine Quadratmatrix sein.

z muss ein Eigenwert von M sein.

z muss komplex sein.


Suchen nach Eigenvektoren

Suchen nach allen Eigenvektoren einer Matrix

eigenvektoren(M) Gibt eine Matrix aus, in der die normalisierten Eigenvektoren enthalten sind, die den Eigenwerten der Matrix M entsprechen. Die n-te Spalte der ausgegebenen Matrix ist ein Eigenvektor, der mit dem n-ten Eigenwert übereinstimmt, der von eigenwerte zurückgegeben wird.

Argumente:

M muss eine Quadratmatrix sein.

z muss ein Eigenwert von M sein.

z muss komplex sein.


Ermitteln der Koeffizienten eines Polynoms

Zum Umwandeln eines Ausdrucks in ein Polynom in einer bestimmten Variable oder bezüglich eines Unterausdrucks gehen Sie wie folgt vor:

  1. Wählen Sie den Teilausdruck aus, in dem der Ausdruck als Polynom behandelt werden soll.

  2. Wählen Sie den Befehl Polynom / Koeffizienten bestimmen aus dem Menü Symbolik.

Es wird ein Vektor angezeigt, der die Koeffizienten des entsprechenden Polynoms enthält. Das erste Element des Vektors entspricht dem konstanten Term.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle das Schlüsselwort "coeffs" und die aktive symbolische Berechnung.


Beliebige Funktionen an Daten anpassen

genfit(vx,vy,vg,F) Ein Vektor mit den Parametern, mit denen sich eine Funktion f von x und n Parametern u1...un am ehesten den Daten in vx und vy annähert.

Argumente:

  • vx ist ein Vektor aus Datenwerten. Diese entsprechen den x-Werten.

  • vy ist ein Vektor aus reellen Datenwerten, die den y-Werten entsprechen. Die Anzahl der Elemente entspricht der von vx.

  • vg ist entweder ein aus n Elementen bestehender Vektor mit Schätzwerten für die n Parameter oder ein Skalar (wenn n=1 ist).

  • F ist eine Funktion, die einen aus n + 1 Elementen bestehenden Vektor zurückgibt, der die Funktion f und deren partielle Ableitungen bezüglich ihrer n Parameter enthält. Wenn n=1, ist F ein Skalar.

  • n ist eine ganze Zahl.

Hinweise:

  • Diese Funktion erweist sich als nützlich, wenn Sie verschiedene gemessene x- und y-Werte haben und eine beliebige Funktion an Ihre Daten anpassen möchten.

  • Der Vektor der Schätzwerte wird für die Initialisierung benötigt.

Das folgende Beispiel zeigt die Verwendung von genfit:


Beheben von Fehlern

Wenn Ihr Arbeitsblatt mehrere fehlerhafte Ausdrücke enthält, gehen Sie wie folgt vor:

  1. Ermitteln Sie, welcher der fehlerhaften Ausdrücke der erste im Arbeitsblatt ist (am weitesten oben steht). Dieser Fehler ist wahrscheinlich der Grund für viele der anderen Fehler. (Wenn eine benutzerdefinierte Funktion als fehlerhaft gekennzeichnet ist, bestimmen Sie die tatsächliche Fehlerquelle anhand der Funktionsdefinition.)

  2. Drücken Sie Umschalt + F1, und klicken Sie auf die Fehlermeldung, um nähere Informationen zur möglichen Ursache des Fehlers zu erhalten. Eine andere Möglichkeit wäre, den Fehler in der Fehlerliste der Hilfe nachzuschlagen.

Oft liegt die Ursache eines Fehlers nicht in dem Ausdruck, in dem er auftritt, sondern in einem vorausgegangenen Ausdruck. Mit der Fehlersuchfunktion können Sie die Fehlerquelle herausfinden.

Wenn Sie den Ausdruck und den Grund herausgefunden haben, durch den der Fehler ausgelöst wurde, können Sie ihn durch Bearbeiten dieses Ausdrucks beheben. Wenn Sie in den Ausdruck klicken und mit der Bearbeitung beginnen, wird die Fehlermeldung entfernt. Wenn Sie auf eine Stelle außerhalb des Ausdrucks klicken, wird sie neu verarbeitet.


Gleitkommafehler

Sie werten eine Funktion an einer Stelle aus, an der dies nicht zugelassen ist. So kann z. B. das fünfte Argument der Funktion relax in Mathcad keine Nullen an den nicht zur Grenze gehörenden Positionen der Koeffizientenmatrix haben.


Gleitkommawerte werden nicht verarbeitet

Der Befehl Faktorisieren wurde auf einen Ausdruck angewendet, der Dezimalbrüche enthält.


Schriftart

Die Schriftart bezeichnet die Schriftartfamilie, in der der Text dargestellt ist.


"For"-Schleifen

Verwenden Sie eine "for"-Schleife, wenn Sie genau wissen, wie oft der Hauptteil der Schleife ausgeführt werden soll. Zum Einfügen einer "for"-Schleife gehen Sie wie folgt vor:

  1. Klicken Sie auf den Platzhalter, in den Sie die "for"-Schleife eingeben möchten.

  2. Klicken Sie [image] auf die Symbolleiste "Rechnen", um die Symbolleiste "Programmierung" zu öffnen, die die Programmierungsoperatoren enthält.

  3. Klicken Sie auf die Schaltfläche for, oder drücken Sie [Strg] + ". Geben Sie nicht einfach "for" ein.

  4. Geben Sie in den Platzhalter links von Î die Iterationsvariable ein.

  5. Geben Sie in den Platzhalter rechts von Î den Wertebereich für die Iterationsvariable ein. (In der Regel wird hier eine Bereichsvariable verwendet; Sie können jedoch auch einen Vektor oder eine Liste mit Skalaren und durch Kommata getrennte Vektoren verwenden.)

  6. Fügen Sie mit der Schaltfläche +1 Zeile gegebenenfalls Platzhalter für weitere Anweisungen ein.

Wenn der Hauptteil der Schleife ausgeführt werden soll, bis eine Bedingung erfüllt ist, aber Sie nicht genau wissen, nach wie vielen Durchläufen dies der Fall sein wird, sollten Sie stattdessen eine while-Schleife verwenden.


Format / Bereiche ausrichten / Horizontal

Richtet markierte Bereiche an einer horizontalen Linie in der Mitte zwischen dem höchsten und dem tiefsten Bereich aus.

Hinweis: Zu beachten ist, dass es bei dieser Aktion zu einer Überschneidung von Bereichen kommen kann. Wählen Sie in diesem Fall Bereiche trennen im Menü Format.


Format / Bereiche ausrichten / Vertikal

Richtet markierte Bereiche an einer vertikalen Linie in der Mitte zwischen dem äußeren linken und dem äußeren rechten Bereich aus.

Zu beachten ist, dass es bei dieser Aktion zu einer Überschneidung von Bereichen kommen kann. Wählen Sie in diesem Fall Bereiche trennen im Menü Format.


Format / Region / Ausblenden

Blendet einen Bereich aus, der über den Befehl Region aus dem Menü Einfügen erstellt wurde. Die Begrenzungslinien der Region sowie die Bereiche dazwischen erscheinen daraufhin als eine Linie, die sich zwar verschieben, nicht aber löschen oder kopieren lässt. Die Bereiche, die sich unterhalb der ausgeblendeten Region befinden, verschieben sich entsprechend nach oben.

Soll eine ausgeblendete Region erweitert werden, um so verborgene Bereiche anzuzeigen, wählen Sie Region - Erweitern aus dem Menü Format.


Format / Region / Erweitern

Erweitert eine ausgeblendete Region, die über den Befehl Region / Ausblenden im Menü Format ausgeblendet wurde. Aus der Linie, die die ausgeblendete Region repräsentierte, werden zwei Begrenzungslinien, zwischen denen die zuvor ausgeblendeten Bereiche angezeigt werden. Die Bereiche, die sich unterhalb der Linie befunden haben, die die ausgeblendete Region repräsentierte, werden entsprechend nach unten verschoben.


Format / Region / Sperren

Sperrt eine Region, die über den Befehl Region aus dem Menü Einfügen eingefügt wurde. Klicken Sie in den Bereich, bevor Sie diesen Befehl wählen.

Sie können gesperrten Bereichen ein Kennwort zuweisen, sodass eine Freigabe nur nach Eingabe des Kennworts möglich ist. Wenn Sie ein Kennwort festlegen, dürfen Sie es keinesfalls vergessen.


Format / Region / Freigeben

Gibt eine Region frei, die über den Befehl Region aus dem Menü Einfügen eingefügt wurde. Wurde die Region mit einem Kennwort gesperrt, werden Sie vor der Freigabe aufgefordert, dieses Kennwort einzugeben.


Format / Farbe / Anmerkung...

Öffnet eine Symbolleiste mit Farben, mit der Sie die Farbe festlegen können, in der Ihre Änderungen an einem Arbeitsblatt hervorgehoben werden.


Format / Farbe / Hintergrund...

Öffnet eine Symbolleiste mit Farben, mit der Sie die Hintergrundfarbe des Haupt-Arbeitsblattfensters ändern können.


Format / Farbe / Hervorhebung...

Öffnet eine Symbolleiste mit Farben, mit der Sie die Farbe ändern können, die zur Hervorhebung eines Bereichs verwendet wird.


Format / Farbe / Palette optimieren

Optimiert die Standardfarbpalette, sodass alle Bitmaps im Arbeitsblatt mit der bestmöglichen 256-Farben-Palette dargestellt werden. Damit die neue Standardpalette aktiviert wird, muss die Option Farbe - Standardpalette verwenden im Menü Format aktiviert sein.


Format / Farbe / Standardpalette verwenden

Ist diese Option aktiviert, zeigt Mathcad den Inhalt des Arbeitsblatts mit einer einzigen Standardfarbpalette aus 256 Farben an, sofern der Bildschirmtreiber 256 Farben unterstützt.

Ist diese Option nicht aktiviert, wird zur Anzeige der einzelnen Bilder im Arbeitsblatt die jeweils am besten geeignete Farbpalette verwendet. Dadurch kann der Bildschirm beim Bewegen durch das Arbeitsblatt mittels Bildlaufleisten ("Rollen" bzw. "Scrollen") flackern, da für jede 256-Farben-Bitmap eine neue Palette geladen wird.


Format / Gleichung

Zeigt eine Liste der verfügbaren Gleichungsformatvorlagen an. Gleichungsformatvorlagen sind Zusammenstellungen von Schrifteigenschaften wie Größe, Farbe, Schriftart usw. Um eine Schriftart zu ändern, klicken Sie auf einen Namen oder eine Zahl und wählen eine Gleichungsformatvorlage aus der Liste.

Sie können auch die Schriftart für eine vorhandene Gleichungsformatvorlage ändern, indem Sie die Vorlage auswählen und auf Ändern klicken. Zu beachten ist hierbei, dass sich durch die Veränderung der Gleichungsformatvorlage die Schriftart sämtlicher Variablen ändert, denen die Vorlage zugewiesen ist.


Format / Diagramm / 3D-Diagramm

Ermöglicht die Festlegung der Standardeigenschaften des ausgewählten 3D-Diagramms. Sie können Folgendes bestimmen:

  • den Diagrammtyp (Umriss-, Flächen-, Streuungs- oder Säulendiagramm)

  • die Farben

  • die Benennungen

  • die Anzeige von Gitterlinien und die Zahlen auf den Achsen

Umriss- und Vektorfelddiagramme ausgenommen, können Sie Folgendes bestimmen:

  • den Betrachtungswinkel

  • die vertikale Skalierung (starke oder weniger starke Wiedergabe von Wertdifferenzen)

  • Hintergrundebenen (bei 3D-Diagrammen)

Die restlichen Diagrammeigenschaften hängen jeweils vom Typ des 3D-Diagramms ab.


Format / Diagramm / Kreisdiagramm

Ermöglicht die Festlegung der Standardeigenschaften aller Kreisdiagramme. Sie können Folgendes bestimmen:

  • Skalenmarkierungen

  • Gitterlinien

  • Kurventyp (Balken, Linien usw.)

  • Symbole zur Darstellung der Punkte auf den einzelnen Kurven (keine, + usw.)

  • Kurvenfarbe

  • Linienstärke

  • Legenden

  • Typ der Radialachse (linear oder logarithmisch)


Format / Diagramm / Koordinaten ablesen...

Ermöglicht das Ablesen der Koordinaten direkt aus dem ausgewählten Diagramm. Dieser Befehl ist nur dann im Menü enthalten, wenn Sie zuvor auf ein X-Y- oder ein Kreisdiagramm geklickt haben.


Format / Diagramm / X-Y-Diagramm

Ermöglicht die Festlegung der Standardeigenschaften aller X-Y-Diagramme im Arbeitsblatt. Sie können Folgendes bestimmen:

  • Skalenmarkierungen

  • Gitterlinien

  • Kurventyp (Balken, Linien usw.)

  • Symbole zur Darstellung der einzelnen Punkte (+, x, usw.)

  • Kurvenfarbe

  • Linienstärke

  • Legenden

  • Achsentyp (linear oder logarithmisch)


Format / Diagramm / Zoom

Ermöglicht die vergrößerte Darstellung im ausgewählten Diagramm. Dieser Befehl ist nur dann im Menü enthalten, wenn Sie zuvor auf ein X-Y- oder ein Kreisdiagramm geklickt haben.


Ansicht / Kopf- und Fußzeile

Öffnet ein Dialogfeld, in dem Sie Kopf- und Fußzeilen definieren können. Kopf- und Fußzeilen können nicht nur Text, sondern auch Seitenzahlen, das aktuelle Datum und die Uhrzeit sowie den Namen der gerade bearbeiteten Datei enthalten.


Format / Absatz....

Öffnet ein Dialogfeld, in dem Sie Absatzattribute von Text, wie z. B. die Ausrichtung und Einzüge, ändern können. Hier können Sie auch festlegen, ob der Absatz mit Aufzählungszeichen oder Nummerierungen versehen werden soll.


Format / Eigenschaften

Dieser Befehl öffnet ein Dialogfeld mit mehreren Registerkarten. Mit den darin enthaltenen Optionen können Sie, je nach der Art des markierten Bereichs, folgende Einstellungen vornehmen:

  • Hervorheben eines Bereichs in einer Farbe Ihrer Wahl

  • Einfügen oder Entfernen eines Rahmens um ein Bild herum

  • Anzeigen eines Bildes in seiner Originalgröße

  • Aktivieren oder Deaktivieren einer Berechnung durch Klicken auf Auswertung deaktivieren

  • Aktivieren oder Deaktivieren der Optimierung

  • Festlegen der Eigenschaften von Textbereichen, um die Breite und das Verhalten eines Textbereichs zu steuern

  • Schützen eines Bereichs vor der Bearbeitung, wenn Ihr Arbeitsblatt geschützt ist.

Hinweis:

Sie können in Ihrem Arbeitsblatt mehrere Bereiche auswählen, u. a. sowohl Rechen- als auch Textbereiche, und für diese Bereiche im Dialogfeld Eigenschaften allgemeine Eigenschaften festlegen.


Extras / Arbeitsblatt schützen

Blendet ein Dialogfeld ein, mit dem Sie Ihr Arbeitsblatt schützen können. Wenn Ihr Arbeitsplatz geschützt ist, wird stattdessen Arbeitsblattschutz aufheben angezeigt.


Format / Seiten jetzt neu umbrechen

Bricht die Seiten automatisch so um, dass Bereiche im Arbeitsblatt nicht auf zwei Seiten erscheinen. Sie können diesen Befehl jederzeit wählen. Denken Sie aber daran, dass alle noch nicht berechneten Bereiche berechnet werden, wenn Sie diesen Befehl wählen.

Mathcad bricht ein Arbeitsblatt automatisch neu um, bevor dieses gedruckt bzw. in der Seitenansicht angezeigt wird, um so zu gewährleisten, dass sich kein Bereich über einen Seitenumbruch hinweg erstreckt und auf zwei separaten Seiten ausgedruckt wird.


Format / Ergebnis...

Öffnet das Dialogfeld "Ergebnisformat", in dem Sie festlegen können, wie numerische Ergebnisse angezeigt werden sollen.

Wenn Sie auf ein bestimmtes Ergebnis klicken und diese Option wählen, formatieren Sie ein Einzelergebnis, d. h., die Änderungen gelten nur für dieses eine Ergebnis.


Format / Bereiche trennen

Trennt alle Bereiche voneinander, die sich im Arbeitsblatt überschneiden.

Hinweis: Dieser Befehl kann nicht rückgängig gemacht werden.


Format / Formatvorlage

Öffnet das Dialogfeld "Textformatvorlagen", in dem Sie eine Textformatvorlage erstellen oder bearbeiten können. Wenn Sie auf einen Textbereich klicken und diesen Befehl wählen, können Sie dem Textbereich mit diesem Dialogfeld eine Formatvorlage zuweisen.

Statt Formatvorlage im Menü Format zu wählen, können Sie einem Textbereich auch eine Formatvorlage zuweisen, indem Sie einfach in den Textbereich klicken und aus der äußersten linken Dropdown-Liste in der Symbolleiste Formatierung eine Formatvorlage auswählen.


Format / Tabulatoren

Öffnet das Dialogfeld Tabulatoren, in dem Sie für das Arbeitsblatt Tabulatoren setzen können. Sie können diese Tabulatoren auch mit dem Arbeitslineal ausrichten.


Format / Text

Öffnet ein Dialogfeld, in dem Sie die Schriftart, die Schriftgröße, die Farbe und den Schriftstil des markierten Textes ändern können.

Dieser Befehl wirkt sich nur auf Text aus. Soll die Schriftart einer Gleichung geändert werden, müssen Sie Gleichung aus dem Menü Format wählen.


Menü "Format"

Gleichung...

Ergebnis...

Text...

Absatz...

Tabulatoren...

Formatvorlage...

Eigenschaften...

Diagramm / X-Y-Diagramm...

Diagramm / Kreisdiagramm...

Diagramm / 3D-Diagramm...

Diagramm / Koordinaten ablesen...

Diagramm / Zoom...

Farbe / Hintergrund...

Farbe / Hervorhebung...

Farbe / Anmerkung...

Farbe / Standardpalette verwenden

Farbe / Palette optimieren

Bereiche trennen

Bereiche ausrichten / Horizontal

Bereiche ausrichten / Vertikal

Region / Sperren

Region / Freigeben

Region / Ausblenden

Region / Erweitern

Seiten jetzt neu umbrechen


Formatieren von Text

Ändern der Schriftarten

Ändern der Absatzattribute

Arbeiten mit Textformatvorlagen


Formatieren eines 3D-Diagramms

Wenn Sie ein 3D-Diagramm mit einem oder mehreren Diagrammen erstellt haben, haben Sie verschiedene Möglichkeiten, deren Darstellungsweise zu ändern.

Allgemein gehen Sie zum Formatieren eines 3D-Diagramms folgendermaßen vor:

  1. Doppelklicken Sie auf das Diagramm.

  2. Formatieren Sie das Diagramm mit den Optionen im Dialogfeld mit mehreren Registerkarten.

Auf 3D-Diagrammen können Sie die Darstellung der Achsen, der Hintergrundebenen und die Position des Diagramms festlegen. Es gibt außerdem Optionen für erweiterte Ansicht und für Beleuchtung, mit denen sich die Gesamtdarstellung des Diagramms bestimmen lässt. Schließlich können Sie einen Titel oder eine andere Anmerkung in das Diagramm einfügen.

Jedes 3D-Diagramm kann auch mit verschiedenen Optionen zum Festlegen seiner Farben, Linien und Punkte formatiert werden. Die Methode der Formatierung eines Diagramms richtet sich nach der Art des Diagramms. Durch Klicken auf die Diagrammtypen unten können Sie weitere Angaben zu den möglichen Einstellungen aufrufen:

  • Fläche

  • Umriss

  • 3D-Streuung

  • 3D-Säulendiagramm

  • Vektorfeld


Formatieren einer Datentabelle

Wenn Sie eine Eingabetabelle einfügen, erscheint diese mit den Standardeinstellungen.

Zum Ändern der Art und Weise, wie Zahlen in einer Datentabelle angezeigt werden, gehen Sie wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf die Tabelle.

  2. Wählen Sie Eigenschaften im Popup-Menü.

  3. Gehen Sie zur Registerkarte Format, und legen Sie die Optionen wie gewünscht fest. Über die Schaltfläche Schriftart können Sie die Schriftart festlegen, in der die Zahlen in der Tabelle angezeigt werden.

Zum Einfügen von Zeilen und Spalten in eine Eingabetabelle gehen Sie wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste in die Tabelle.

  2. Wählen Sie im Kontextmenü den Befehl Zellen einfügen bzw. Zellen löschen.

  3. Klicken Sie auf Zeile bzw. Spalte, und klicken Sie anschließend auf OK.

Zum Vergrößern oder Verkleinern einer Tabelle gehen Sie wie folgt vor:

  1. Klicken Sie auf die Tabelle.

  2. Positionieren Sie den Mauszeiger über einem der Haltepunkte. Der Mauszeiger verwandelt sich in einen Doppelpfeil.

  3. Drücken Sie die Maustaste, und halten Sie sie gedrückt.

  4. Ziehen Sie den Cursor so lange mit der Maus, bis Sie die gewünschte Größe erreicht haben.


Zahl mit einem Betrag größer als...

Beim Versuch, diesen Ausdruck auszuwerten, wurde eine Zahl mit einem Betrag größer als 10^307 gefunden.

Aufgrund von Beschränkungen bei der Darstellung von Zahlen in einem Computer können zu große Zahlen nicht dargestellt werden. Wenn ein Ausdruck eine solche Zahl enthält, wird diese Fehlermeldung angezeigt.

Speziell in komplizierten Berechnungen können Zwischenergebnisse für die Darstellung zu groß sein.


Singularität bei Auswertung dieses Ausdrucks festgestellt.

Singularität bei Auswertung dieses Ausdrucks festgestellt. Möglicherweise dividieren Sie durch Null.

Die Auswertung einer Funktion bzw. die Ausführung einer Operation erfolgte bei einem unzulässigen Wert. Diese Fehlermeldung wird z. B. angezeigt, wenn Sie durch Null dividieren oder versuchen, eine singuläre Matrix umzukehren.


Fourier-Transformation (symbolisch)

Fourier-Transformation

Zur Auswertung der Fourier-Transformation einer Funktion gehen Sie wie folgt vor:

  1. Geben Sie den zu transformierenden Ausdruck ein.

  2. Klicken Sie auf die Transformationsvariable.

  3. Wählen Sie Transformation / Fourier aus dem Menü Symbolik:

Mathcad gibt bei Fourier-Transformationen eine Funktion in der Variable w zurück. Wenn der zu transformierende Ausdruck bereits ein w enthält, wird stattdessen eine Funktion in der Variable ww zurückgegeben, um jegliche Zweideutigkeit zu vermeiden. Mit dem Befehl Variable / Ersetzen können Sie w durch eine andere Variable oder einen Ausdruck ersetzen.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle das Schlüsselwort "Fourier" und die aktive symbolische Auswertung.


Variable FRAME

Diese integrierte Variable führt Animationen aus. Definieren Sie diese Variable nicht in Ihrem Arbeitsblatt. Sie sollten sie nur im Dialogfeld Animieren definieren.


Bilder mit Rahmen versehen

Wenn Sie ein Bild, das mit dem Befehl Bild aus dem Menü Einfügen importiert wurde, mit einem Rahmen versehen möchten, gehen Sie wie folgt vor:

  1. Klicken Sie auf das Bild.

  2. Wählen Sie im Eigenschaften aus dem Menü Format, und wechseln Sie auf die Registerkarte Anzeige im Dialogfeld Eigenschaften.

  3. Aktivieren Sie auf der Registerkarte Anzeige die Option Rahmen anzeigen.

  4. Klicken Sie auf OK.

Sie können auch das Argument ausblenden, mit dem festgelegt wird, dass der Rahmen nur um die Bildgrenzen herum erscheint. Klicken Sie dazu mit der rechten Maustaste auf das Bild, und wählen Sie im Kontextmenü den Befehl Argumente ausblenden.


Fresnelsches Kosinusintegral


Fresnelsches Sinusintegral


Funktionen zum Erstellen eines 3D-Diagramms

Bevor Sie ein 3D-Flächendiagramm, Säulendiagarmm, Streuungsdiagramm oder Umrissdiagramm einer Funktion erstellen können, müssen Sie in Ihrem Arbeitsblatt eine Funktion eines der folgenden Typen definieren:

Eine einzelne Funktion mit zwei Variablen

Bei diesem Funktionstyp liegen die x- und y-Koordinaten des Diagramms standardmäßig in einem Bereich von -5 bis +5 bei einer Schrittweite von 0,5. Die einzelnen z-Koordinaten werden von der Funktion anhand dieser x- und y-Werte bestimmt.

Eine einzelne, vektorwertige Funktion

Bei diesem Funktionstyp liegen die unabhängigen Variablen u und v standardmäßig in einem Bereich von -5 bis +5 bei einer Schrittweite von 0,5. Die x-, y- und z-Koordinaten werden anhand der u- und v-Werte gemäß den Definitionen der drei Elemente des Vektors parametrisch abgebildet.

Drei Funktionen mit zwei Variablen

Bei diesem Funktionstyp liegen die unabhängigen Variablen u und v standardmäßig in einem Bereich von -5 bis +5 bei einer Schrittweite von 0,5. Die x-, y- und z-Koordinaten werden anhand der u- und v-Werte gemäß den Definitionen der drei Funktionen parametrisch abgebildet.

Hinweis:

Für die genannten Funktionsbeschreibungen wird angenommen, dass Sie mit einem kartesischen Koordinatensystem arbeiten. Wird die Funktion mit sphärischen oder zylindrischen Koordinaten anstelle des kartesischen Systems dargestellt, können Sie die Funktion automatisch in kartesische Koordinaten konvertieren. Doppelklicken Sie auf das Diagramm, öffnen Sie die Registerkarte "QuickPlot Data" des Dialogfelds "3D-Diagrammformat", und klicken Sie im Bereich Koordinatensystem auf Sphärisch oder Zylindrisch.


Funktionen für die Erstellung einer räumlichen Kurve

Bevor Sie eine räumliche Kurve erstellen können, müssen Sie in Ihrem Arbeitsblatt eine Funktion eines der folgenden Typen definieren:

Eine einzelne vektorwertige Funktion einer Variablen

Bei diesem Funktionstyp liegt die unabhängige Variable u standardmäßig in einem Bereich von -5 bis +5 bei einer Schrittweite von 0,5. Die x-, y-, und z-Koordinaten des Diagramms werden anhand dieser u-Werte von den Funktionen in den einzelnen Vektorelementen bestimmt.

Drei Funktionen mit einer Variablen

Bei diesem Satz dreier Funktionen liegt die unabhängige Variable u standardmäßig in einem Bereich von -5 bis +5 bei einer Schrittweite von 0,5. Die x-, y- und z-Koordinaten werden anhand der u-Werte gemäß den Definitionen der drei Funktionen abgebildet.

Hinweis:

Für die genannten Funktionsbeschreibungen wird angenommen, dass Sie mit einem kartesischen Koordinatensystem arbeiten. Wird die Funktion mit sphärischen oder zylindrischen Koordinaten anstelle des kartesischen Systems dargestellt, können Sie die Funktion automatisch in kartesische Koordinaten konvertieren. Doppelklicken Sie auf das Diagramm, öffnen Sie die Registerkarte "QuickPlot Data" des Dialogfelds "3D-Diagrammformat", und klicken Sie im Bereich Koordinatensystem auf Sphärisch oder Zylindrisch.


Funktionsoptimierung

minimieren(f, var1, var2,...)

Ermittelt die Werte, an denen eine Funktion ihren Mindestwert annimmt.

maximieren(f, var1, var2,...)

Ermittelt die Werte, an denen eine Funktion ihren Mindestwert annimmt.


Funktionen zur Lösung von Gleichungen

suchen(x,y,...)

Lösen von Gleichungssystemen.

minfehl(x,y,...)

Näherungsweises Lösen von Gleichungssystemen.

wurzel(f(x),x,a,b)

Lösen genau einer Gleichung für genau eine Unbekannte.

llösen(M,v)

Lösen von Gleichungssystemen.

nullstellen(v)

Löst nach den Wurzeln des Polynoms auf, dessen Koeffizienten durch v definiert sind.


Symbolisch verwendete Funktionen

Die folgenden vordefinierten Funktionen behalten auch bei symbolischer Verwendung ihre Bedeutung bei:

  • Trigonometrische und hyperbolische Funktionen und ihre Inversen.

  • Logarithmus- und Exponentialfunktionen.

  • Die Funktion Re und Im.

  • Die Funktion erf.

  • Gammafunktion.

  • Die Funktion mod.

  • Heaviside-Funktion.

  • Die Funktionen min und max.

  • Die Funktionen einheit und eigenwerte.

Im Allgemeinen stimmt die Bedeutung dieser Funktionen bei numerischen Berechnungen und bei symbolischen Transformationen überein. In drei Punkten gibt es jedoch Unterschiede:

  • Im Unterschied zur numerischen Funktion mod benötigt die symbolische Funktion mod einen ganzzahligen absoluten Betrag und akzeptiert ein Polynom als erstes Argument.

  • Bestimmte symbolische inverse trigonometrische Funktionen verwenden in der komplexen Ebene unterschiedliche Zweige.

  • Mit der Funktion eigenwerte können sowohl komplexe als auch reelle Matrizen symbolisch ausgewertet werden.


Lösungsalgorithmen für gewöhnliche Endwert-Differentialgleichungen

bulstoer(y, x1, x2, acc, D, kmax, s) (stetige Systeme)
rkadapt(y, x1, x2, acc, D, kmax, s): Systeme mit sich ändernden Eigenschaften

stiffb(y, x1, x2,acc, D, J, kmax, s): Steife Systeme
stiffr(y, x1, x2,acc, D, J, kmax, s): Steife Systeme
radau(y, x1, x2, acc, D, kmax, s): Steife Systeme

Diese Lösungsalgorithmen geben den Endwert der GDG-Lösung am Endpunkt des Integrationsbereichs zurück. Die Eigenschaften dieser Lösungsalgorithmen sind mit den entsprechenden Funktionen, die in Großbuchstaben geschrieben werden identisch.

Argumente:

y muss entweder ein Vektor aus n Anfangswerten oder ein Skalar sein.

x1, x2 sind Endpunkte des Intervalls, an dem die Lösung für Differentialgleichungen ausgewertet wird. Anfangswerte in y sind die Werte bei x1.

gen bestimmt die Genauigkeit der Lösung. Ein kleiner Wert für gen zwingt den Algorithmus, kleinere Schritte entlang der Trajektorie auszuführen, wodurch die Genauigkeit der Lösung erhöht wird. Werte für gen um 0,001 ergeben gewöhnlich exakte Lösungen.

D ist eine vektorwertige Funktion mit n Elementen, die erste Ableitungen der unbekannten Funktionen enthält.

J ist eine Funktion, die eine aus n x (n+1) Elementen bestehende Matrix zurückgibt, deren erste Spalte Ableitungen enthält und deren andere Zeilen und Spalten die Jacobische Matrix für das System der Differentialgleichungen bilden.

kmax ist die Höchstzahl von Zwischenpunkten, die für die näherungsweise Lösung verwendet werden. Der Wert für kmax legt eine obere Grenze für die Anzahl der Zeilen der von diesen Funktionen zurückgegebenen Matrix fest.

s ist der kleinste, zulässige Abstand zwischen den Werten, an denen die Lösungen angenähert werden sollen. Hierdurch wird eine untere Grenze für die Differenz zwischen zwei beliebigen Zahlen in der ersten Spalte der von der Funktion zurückgegebenen Matrix festgelegt.


Grundeinheiten

Die Grundeinheiten werden für die Grunddimensionen der Länge, Masse, Zeit, Ladung, Temperatur, Leuchtstärke (SI-Einheitensystem) und Stoff (SI-Einheitensystem) verwendet. Die Grundeinheiten sind in jedem Einheitensystem unterschiedlich.

Einheitensystem Grundeinheiten

MKS Meter (m), Kilogramm (kg), Sekunden (sec), Coloumb (coul), Kelvin (K)

CGS Zentimeter (cm), Gramm (gm), Sekunden (sec), Coloumb (coul), Kelvin (K)

US Fuß (ft), Pfund (lb), Sekunden (sec), Coloumb (coul), Kelvin (K)

SI Meter (m), Kilogramm (kg), Sekunden (s), Ampere (A), Kelvin (K), Candella (cd), Mol (mol)


Zukünftiger Wert

zw(zsatz, nper, zrate, [[gw], [typ]]) Gibt den zukünftigen Wert einer Kapitalanlage bzw. eines Darlehens über eine angegebene Anzahl von Verzinsungsperioden bei regelmäßigen Zahlungen und festem Zinssatz zurück.

Argumente:

zsatz ist der feste Zinssatz für die Verzinsungsperiode. zsatz ist ein reeller Skalar. zsatz kann als Dezimalzahl (z. B. 0.0825) oder als Prozentsatz (z. B. 8.25 %) ausgedrückt werden. zsatz [image] 0.

Hinweis: Gegebenenfalls müssen Sie den Zinssatz für die jeweilige Verzinsungsperiode berechnen. Für die Berechnung des monatlichen Zinssatzes aus dem jährlichen Zinssatz zum Beispiel gilt die Formel zsatz = jährl_zsatz/12.

nper ist die Gesamtzahl der Verzinsungsperioden. nper ist eine positive Ganzzahl.

zrate ist die Zahlung, die pro Periode entrichtet oder eingenommen wird. Sie umfasst in der Regel Tilgungs- und Zinszahlungen, jedoch keine weiteren Abgaben und Gebühren.

gw (optional) ist der gegenwärtige Wert des Darlehens. Erfolgt keine Angabe, so gilt gw = 0.

typ (optional) beträgt bei Zahlungen, die am Ende der Periode vorgenommen wurden, 0, bei Zahlungen zu Beginn der Periode 1. Falls keine Angabe gemacht wird, gilt typ = 0.

Hinweis:

  • Zahlungen, die Sie leisten, zum Beispiel Einlagen in einem Sparkonto oder Rückzahlungen bei einem Darlehen, müssen als negative Zahlen eingegeben werden. Zahlungen, die Sie einnehmen, zum Beispiel Dividenden, müssen als positive Zahlen eingegeben werden.


Zukünftiger Wert von Zahlungen

zwz(zsatz, v) Gibt den zukünftigen Wert einer Reihe von regelmäßigen Zahlungen zurück, die einen bestimmten Zinssatz einbringen.

Argumente:

zsatz ist der feste Zinssatz für die Verzinsungsperiode. zsatz ist ein reeller Skalar. zsatz kann als Dezimalzahl (z. B. 0.0825) oder als Prozentsatz (z. B. 8.25 %) ausgedrückt werden.

v ist ein Vektor für regelmäßig anfallende Zahlungen.

Hinweis: Für zwz wird davon ausgegangen, dass die Zahlung am Ende der Verzinsungsperiode erfolgt.


Zukünftiger Wert (variabler Zinssatz)

zwzz(prin, v) Gibt den zukünftigen Wert eines Anfangskapitals zurück, nachdem eine Reihe von Zinseszinssätzen angewendet wurde.

Argumente:

prin ist der erste Tilgungsbetrag.

v ist ein Vektor von Zinssätzen, die über denselben Zeitraum angewendet werden.

Hinweis: Verwenden Sie zwzz, um den zukünftigen Wert einer Kapitalanlage mit einer Variable oder einem variablen Zinssatz zu berechnen.


Gamma-Verteilung

Verteilungsgeneratoren für die Gamma-Gleichung:

dgamma(x,s) Gibt die Wahrscheinlichkeitsdichte zurück.

pgamma(x,s) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qgamma(p,s) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rgamma(m,s) Gibt einen Vektor aus m Zufallszahlen zurück, die die Gamma-Verteilung aufweisen.


Gaußsche hypergeometrische Funktion

fhyper(a,b,c,x) Gibt den Wert der Gaußschen hypergeometrischen Funktion zurück, 2F1(a,b;c;x).

Argumente:

a, b und c sind reelle Skalare.

x ist ein reeller Skalar.

x liegt zwischen -1 und 1.

Die Gaußsche hypergeometrische Funktion ist die Lösung der folgenden Differentialgleichung:

Viele Funktionen sind Sonderfälle der Gaußschen hypergeometrischen Funktion. Beispiel:

ln(1+x)=x.fhyper(1,1,2,-x)

asin(x)=x.fhyper(0,5,.5,1,5,x2)


Verallgemeinerte Eigenwerte und Eigenvektoren

genwerte(M,N) Gibt einen Vektor v mit berechneten Eigenwerten zurück, die alle dem verallgemeinerten Eigenwertproblem entsprechen.

genvektoren (M,N) Gibt eine Matrix mit den normalisierten Eigenvektoren zurück, die den Eigenvektoren in v entsprechen, also dem Vektor, der von genwerte zurückgegeben wird. Die i-te Spalte dieser Matrix bildet den Eigenvektor x, der dem verallgemeinerten Eigenwertproblem entspricht.

Argumente:

M und N müssen Quadratmatrizen sein.

Die Elemente von M und N müssen reell sein.

M und N müssen dieselbe Anzahl von Spalten haben.

Mit diesen Funktionen finden Sie verallgemeinerte Eigenwerte und Eigenvektoren. Zur Ermittlung einzelner Eigenwerte und Eigenvektoren verwenden Sie die Funktionen eigenwerte und eigenvek.


Generalisierte hypergeometrische Funktion


Generieren von Berichten

Wenn Sie einen Lösungsblock zum Lösen eines Gleichungssystems verwenden und das Solving and Optimization Extension Pack (Expert Solver) installiert ist, können Sie Berichte über die Lösung generieren.

Zum Anzeigen eines Berichts gehen Sie wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf die Funktion "suchen", "minfehl", "maximieren" oder "minimieren" im Lösungsblock.

  2. Wählen Sie Bericht im Popup-Menü.

Welche Informationen der Bericht enthält, hängt von der Art des Problems ab:

Nichtlineare Probleme:

Der Bericht gibt die Zahl der Iterationen an, die für die Lösung erforderlich sind.

Lineare Probleme:

Der Bericht enthält Informationen zu der Kostensenkung, dem Schattenpreis (Shadow Price), den Zielkoeffizienten einschließlich zulässiger Schwankungen sowie Bereichsnebenbedingungen auf der rechten Seite.

Hinweise:

Die angegebene zulässige Schwankungsbreite ("Zulässige Erhöhung" und "Zulässige Reduzierung") für eine Variable definiert einen Bereich, in dem sich der Koeffizient der Variable in der Zielfunktion bewegen kann, ohne dass sich dies auf den Punkt für den angenommenen optimalen Zielwert auswirkt. Bei einer Variablen, deren optimaler Wert null ist, ist "Reduzierte Kosten" ein Schätzwert der Rate, in dem der Zielwert sinkt, wenn sich die Variable von null weg bewegt.

Zulässige Erhöhung und Zulässige Reduzierung geben für eine Nebenbedingung einen Bereich von Werten für die rechte Seite der Nebenbedingung an. Bei einer Änderung des Werts auf der rechten Seite der Nebenbedingung, die innerhalb dieses Bereichs bleibt,ändert sich der optimale Zielwert um eine Rate, die dem Schattenpreis der Nebenbedingung entspricht.

Der fiktive Wert einer Nebenbedingung ist die Differenz zwischen der linken und der rechten Nebenbedingungsseite am optimalen Lösungspunkt.


Geometrische Verteilung

Mit einer geometrischen Gleichung verknüpfte Verteilungen:

dgeom(k,p) Gibt die Wahrscheinlichkeitsdichte zurück.

pgeom(k,p) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qgeom(p,r) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rgeom(m,p) Gibt einen Vektor aus m Zufallszahlen zurück, die die geometrische Verteilung aufweisen.


Geometrischer Mittelwert

Argumente:

  • A, B, C, ... sind m x n Felder oder Skalare.

  • A, B, C, ...müssen reelle, positive Werte sein. Die Elemente eines Feldes müssen reelle, positive Werte aufweisen.

Hinweise:

  • Der geometrische Mittelwert kann zur Berechnung von Wachstumsraten verwendet werden.

  • hmean(A, B, C, ...) < gmean(A, B, C, ...) < mittelwert(A, B, C, ...)

Weitere Funktionen für die Datenanalyse...


Ablesen von Kreisdiagrammkoordinaten

Um die Diagrammkoordinaten eines beliebigen Punktes im Diagramm anzuzeigen, gehen Sie wie folgt vor:

  1. Klicken Sie auf das Diagramm, damit es markiert wird, und wählen Sie dann Diagramm / Koordinaten ablesen im Menü Format, damit das Dialogfeld Kreisdiagrammdaten ablesen aufgerufen wird.

  2. Klicken Sie in den Diagrammbereich, und ziehen Sie die Maus entlang der Spur, deren Koordinaten Sie sehen möchten. Ein gepunkteter Fadenkreuz-Cursor springt von einem Punkt zum nächsten, während Sie ihn entlang der Spur ziehen.

  3. Die Koordinaten der jeweiligen Position des Fadenkreuz-Cursors werden in den Feldern Radius und Winkel angezeigt. Diese Koordinaten ändern sich entsprechend der Verschiebung der Maus.

  4. Wenn Sie die Maustaste loslassen, sehen Sie die Radius- und Winkelwerte des zuletzt ausgewählten Punkts im Dialogfeld.

Kopieren eines Koordinatenwerts in die Zwischenablage:

Klicken Sie auf die Schaltfläche Radius kopieren oder Winkel kopieren, um die entsprechende Koordinate in die Zwischenablage einzufügen.


Ablesen der X-Y-Diagrammkoordinaten

Zum Anzeigen der Koordinaten eines Punkts in einem Diagramm gehen Sie folgendermaßen vor:

  1. Klicken Sie in das Diagramm, damit es ausgewählt wird.

  2. Wählen Sie Diagramm / Koordinaten ablesen im Menü Format, damit das Dialogfeld X-Y-Koordinaten ablesen geöffnet wird.

  3. Klicken Sie in den Diagrammbereich, und ziehen Sie die Maus entlang der Spur, deren Koordinaten Sie sehen möchten. Ein gepunkteter Fadenkreuz-Cursor springt von einem Punkt zum nächsten, während Sie ihn entlang der Spur ziehen.

  4. Sie sehen die Koordinaten entsprechend der Position des Fadenkreuz-Cursors in den Feldern X-Wert und Y-Wert. Diese Koordinaten ändern sich entsprechend der Mausbewegung.

  5. Wenn Sie die Maustaste loslassen, sehen Sie die x und y-Werte des zuletzt ausgewählten Punkts im Dialogfeld.

So kopieren Sie einen Koordinatenwert in die Zwischenablage:

  • Klicken Sie auf die Schaltfläche X kopieren oder Y kopieren, um die entsprechende Koordinate in die Zwischenablage einzufügen.


Globales Definitionssymbol

Tastaturbefehl ist ~ (die Tildetaste).

Das Zeichen erscheint als Gleichheitszeichen mit drei Strichen.

Mit diesem Operator definieren Sie eine Variable oder Funktion global. Variablen, die mit diesem Operator definiert werden, werden vor denen ausgewertet, die mit dem Definitionssymbol definiert wurden.


Globale Methoden

  • Die Funktion alert nimmt einen einzelnen Zeichenfolge-Parameter an, der beim Benutzer als Standard-Windows-Meldung mit einer OK-Schaltfläche angezeigt wird.

  • Die Funktion errmsg nimmt einen einzelnen Zeichenfolge-Parameter als erstes Argument an, der vom Skript als Fehlermeldung angezeigt wird, und sorgt dafür, dass die Ausführung des Skripts beendet wird. Der zweite, optionale Parameter ist ebenfalls eine Zeichenfolge. Mit ihm kann die Fehlerquelle angezeigt werden.

Hinweis: Im Gegensatz zu VBScript ist in JScript bei der Angabe von Funktionen, Methoden, Objekten und Eigenschaften auf die Groß- und Kleinschreibung zu achten.


Hinweis zu globalen Definitionen

Globale Definitionen erkennen keine lokalen Definitionen. Beispiel für eine globale Definition, die eine lokale Definition überstimmt:


Globales Definieren von Variablen oder Funktionen

Wenn Sie eine Variable oder Funktion definieren, gilt diese für alles, was sich im Arbeitsblatt rechts und unterhalb von ihr befindet. Wird die Variable oder Funktion jedoch global definiert, gilt sie für alle lokalen Definitionen ohne Rücksicht auf deren Position im Arbeitsblatt. Mit globalen Definitionen können Sie also die übliche Reihenfolge, in der Ihr Arbeitsblatt ausgewertet wird, außer Kraft setzen.

Zum globalen Definieren einer Variable oder Funktion gehen Sie wie folgt vor:

  1. Geben Sie einen Variablennamen oder eine Funktion ein, der/die definiert werden soll.

  2. Geben Sie das Prioritätsgleichheitszeichen ein, indem Sie die Tilde-Taste (~) drücken.

  3. Geben Sie einen Ausdruck mit Zahlen oder anderen global definierten Variablen oder Funktionen ein.


Symbolleiste "Diagramm"

Mit der Schaltflächen der Symbolleiste Diagramm können Sie zwei- und dreidimensionale Diagramme einfügen. Sie können sehen, wozu die einzelnen Schaltflächen dienen, wenn Sie den Cursor im Haupt-Arbeitsblattfenster über die Schaltfläche setzen, bis:

  • eine QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche erscheint, und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


Grafikbereich

Ein Grafikbereich ist ein Bereich, der die folgenden Diagramme oder Bilder enthalten kann:

  • X-Y-Diagramm

  • Kreisdiagramm

  • Flächendiagramm

  • Umrissdiagramm

  • 3D-Säulendiagramm

  • Vektorfeld-Diagramm

  • Streuungsdiagramm

  • Grafikbild

Zum Erstellen von Grafikbereichen stehen Ihnen verschiedene Befehle im Menü Einfügen zur Verfügung.


Grafische Darstellung eines mathematischen Ausdrucks

Zum grafischen Darstellen eines mathematischen Ausdrucks gehen Sie folgendermaßen vor:

  1. Definieren Sie eine Bereichsvariable für den Wertebereich, über dem der Ausdruck abgebildet werden soll.

  2. Wählen Sie Diagramm / X-Y-Diagramm im Menü Einfügen, um den X-Y-Diagrammoperator einzufügen.

  3. Klicken Sie auf den Platzhalter auf der x-Achse. Geben Sie die Bereichsvariable ein.

  4. Klicken Sie auf den mittleren Platzhalter auf der y-Achse. Geben Sie den mathematischen Ausdruck ein.

  5. Klicken Sie auf eine Stelle außerhalb des Diagramms.

Mathcad bildet für jeden Wert der Bereichsvariable einen Punkt ab und verbindet sie mit geraden Linien, wenn Sie nichts anderes festlegen.

Hinweise:

  • Wenn Mathcad Werte für die Abbildung zuweisen soll, müssen Sie keine Bereichsvariable definieren. Geben Sie einfach den undefinierten Variablennamen im x-Achsen-Platzhalter ein. Mathcad verwendet -10 bis 10 als Standardbereich für das Diagramm. Wenn Sie Mathcad den Standardbereich wählen lassen, erstellen Sie ein QuickPlot.

  • Sie können jeden Ausdruck im Vergleich zu einem anderen Ausdruck abbilden, solange ihre Bereichsvariablen gleich sind. Sie können auch ein Diagramm mit mehreren Kurven erstellen .


Grafisches Darstellen einer Reihe von Datenpunkten

So stellen Sie eine Reihe von Datenpunkten grafisch dar:

  1. Erstellen Sie zwei Vektoren. Geben Sie die x-Werte in einen Vektor und die y-Werte in einen anderen Vektor ein.

  2. Drücken Sie @ (Alt Gr + Q), oder wählen Sie Diagramm / X-Y-Diagramm im Menü Einfügen. Es wird ein xy-Diagramm erstellt.

  3. Geben Sie den Namen des Vektors der x-Werte auf der horizontalen Achse ein.

  4. Geben Sie den Namen des Vektors der y-Werte auf der vertikalen Achse ein.

Hinweis:

Auf ähnliche Weise können Sie auch ein Kreisdiagramm aus Vektoren erstellen. Fügen Sie dazu einfach den Kreisdiagrammoperator ein, indem Sie Diagramm / Kreisdiagramm im Menü Einfügen wählen, und füllen Sie den unteren und den linken Platzhalter aus.


Grafisches Darstellen von mehreren Ausdrücken

Sie können mehrere Kurven in einem Diagramm abbilden, wenn Sie ein Komma zwischen den Argumenten auf jeder Achse eingeben. Dies ist entweder für ein XY- oder ein Kreisdiagramm möglich.

Zum grafischen Darstellen mehrerer Ausdrücke in einem XY-Diagramm gehen Sie folgendermaßen vor:

  1. Wählen Sie Diagramm / X-Y-Diagramm im Menü Einfügen, um einen Diagrammbereich zu erstellen.

  2. Geben Sie im mittleren Platzhalter unter der horizontalen Achse den ersten abzubildenden Ausdruck oder die erste abzubildende Variable ein.

  3. Geben Sie ein Komma ein. Rechts wird ein Platzhalter angezeigt.

  4. Geben Sie den zweiten Ausdruck ein. Sie können insgesamt bis zu 10 durch Kommas abgetrennte Ausdrücke einfügen.

  5. Geben Sie im mittleren Platzhalter neben der vertikalen Achse den ersten Ausdruck ein, der abgebildet werden soll.

  6. Geben Sie ein Komma ein, und fügen Sie den zweiten Ausdruck hinzu.

  7. Sie können noch weitere durch Kommas abgetrennte Ausdrücke hinzufügen; die Anzahl der Ausdrücke auf den einzelnen Achsen muss jedoch übereinstimmen.

Mathcad gleicht die Ausdrücke paarweise ab. Dann zeichnet es eine Spur für jedes Paar. Für jedes übereinstimmende Paar von Ausdrücken muss dieselbe Bereichsvariable verwendet werden, aber die Bereichsvariable für ein Paar muss nicht mit den Bereichsvariablen für die anderen Paare übereinstimmen.

Beispiel:

So erstellen Sie ein XY-Diagramm von sin(x) und cos(y) gegen x und y:

  1. Wählen Sie Diagramm / X-Y-Diagramm im Menü Einfügen.

  2. Geben Sie im mittleren Platzhalter unter der horizontalen Achse "x" ein.

  3. Geben Sie ein Komma ein. Rechts wird ein Platzhalter angezeigt.

  4. Geben Sie "y" ein.

  5. Geben Sie im mittleren Platzhalter unter der vertikalen Achse "sin(x)" ein.

  6. Geben Sie ein Komma und "cos(y)" ein.

Sie werden Folgendes bemerken:

Hinweise:

  • Um mehrere Ausdrücke der y-Achse (oder Radialachse in einem Kreisdiagramm) gegen einen Ausdruck der x-Achse (oder Winkelachse in einem Kreisdiagramm) abzubilden, geben Sie einen Ausdruck auf der x-Achse (oder Winkelachse) und mehrere Ausdrücke getrennt durch Kommas auf der y-Achse (oder Radialachse) ein. Sie können bis zu 16 y-Achsenargumente abbilden.


Abbilden einheitlicher Polyeder

Polyeder(S1) Generiert das einheitliche Polyeder, dessen Name, Nummerncode oder Wythoff-Symbol S1 ist.

PolyInfo(n) Gibt einen Vektor mit dem Namen, dem dualen Namen und dem Wythoff-Symbol für das Polyeder, dessen Nummerncode n ist, zurück.

Argumente:

S1 ist eine Zeichenfolge.

S1 ist der Name eines Polyeders, seines Nummerncodes oder seines Wythoff-Symbols.

n ist der Nummerncode für ein Polyeder, der Name in Form einer Zeichenfolge oder das Wythoff-Symbol in Form einer Zeichenfolge.

Arbeiten mit Polyedern:

Zum Erstellen eines Polyeders mit der Funktion "Polyeder" gehen Sie folgendermaßen vor:

  1. Klicken Sie auf eine leere Stelle im Arbeitsblatt.

  2. Wählen Sie Diagramm / Flächendiagramm im Menü Einfügen.

  3. Geben Sie in den Platzhalter die Polyeder-Funktion ein. Das Argument ist entweder ein Name, das #-Zeichen gefolgt von einer Nummer oder ein Wythoff-Symbol. Beispielsweise können Sie Polyeder("würfel") oder Polyeder("#6") oder Polyeder("3|2 4") eingeben.

  4. Klicken Sie auf eine Stelle außerhalb des Diagramms.

Beispiel für die Arbeit mit PolyInfo:


Diagramme, die mit der Axum-Komponente erstellt werden können

Zweidimensionale Diagramme

Streuung

Linie

Spline

Lowess

Gewichtete Fehlerquadrate

Säulen

Fehler - Säulen

Kurvenanpassung natürlicher Logarithmus

Kurvenanpassung exponential

Fläche

Histogramm

Kommentar

Dreidimensionale Diagramme

Streuung

Linie

Regression

Dünne Fläche

Spline

Andere

Torte

Smith


Operator "Größer als"

Tastaturbefehl: >

x >y

Gibt 1 zurück, wenn x > y, andernfalls 0.

Operanden:

  • x und y müssen reelle oder imaginäre Skalare, Vektoren oder Zeichenfolgen sein.


Operator "Größer gleich"

Tastaturbefehl: Strg+0

x [image] y

Gibt 1 zurück, wenn x [image] y, andernfalls 0.

Operanden:

  • x und y müssen reelle oder imaginäre Skalare, Vektoren oder Zeichenfolgen sein.


Größter gemeinsamer Teiler

gcd(A, B, C) Gibt den größten gemeinsamen Teiler zurück: die größte ganze Zahl, die alle Werte A, B, C... gleich teilt.

Argumente:

A, B, C, ... müssen jeweils reelle, positive, dimensionslose ganze Zahlen oder Felder sein, deren Elemente reelle, positive, dimensionslose ganze Zahlen sind.

Beispiele:


Symbolleiste "Griechisch"

Mit der Symbolleiste Griechisch können Sie griechische Buchstaben einfügen. Den Namen des griechischen Buchstabens, der mit einer bestimmten Schaltfläche eingefügt wird, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • eine QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche erscheint, und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


Schätzwerte

Für das numerische Lösen von Gleichungen müssen Werte definiert sein, von denen aus der Lösungsalgorithmus seine Suche nach einer Lösung beginnen kann.

Zur Angabe eines solchen Schätzwerts müssen Sie nur eine Variable definieren. Der von Ihnen gewählte Variablenname sollte mit den Variablenargumenten der Lösungsfunktion übereinstimmen.

Hinweise:

  • Wenn Sie die Funktion wurzel bei Ausdrücken mit mehreren Wurzeln verwenden, hängt es vom Schätzwert ab, auf welche Wurzel konvergiert wird.

  • Wenn Sie mit den Funktionen wurzel, suchen, minfehl, minimieren oder maximieren arbeiten, müssen Sie, wenn Sie eine komplexe Lösung erwarten, einen komplexen Schätzwert definieren.


Haltepunkte in einem Diagramm


Hängender Einzug

Als hängender Einzug wird die erste Zeile eines Absatzes bezeichnet, wenn sie links über alle anderen Zeilen des Absatzes hinausragt.


Manuelle Seitenumbrüche

Ein manueller Seitenumbruch wird auf dem Arbeitsblatt als durchgehende Linie dargestellt. Alles, was sich unter dieser Linie befindet, wird auf der nächsten Seite gedruckt.

Zum Einfügen eines manuellen Seitenumbruchs gehen Sie wie folgt vor:

  1. Klicken Sie auf die Stelle, an der ein Seitenumbruch eingefügt werden soll. Stellen Sie sicher, dass die Linie keine Rechen- oder Textbereiche schneidet.

  2. Wählen Sie den Befehl Seitenumbruch aus dem Menü Einfügen.

Zum Löschen eines Seitenumbruchs gehen Sie wie folgt vor:

  1. Drücken Sie die Umschalttaste, und klicken Sie etwas rechts vom Knick der Seitenumbruchlinie am linken Rand des Fensters.

  2. Wenn ein kleines, aus gestrichelten Linien bestehendes Feld neben dem Knick erscheint, wählen Sie den Befehl Ausschneiden aus dem Menü Bearbeiten.

Die manuellen Seitenumbrüche (dargestellt durch durchgehende Linien) dürfen nicht mit den automatischen Seitenumbrüchen (dargestellt durch gepunktete Linien) verwechselt werden. Wo automatische Seitenumbrüche eingefügt werden, hängt davon ab, welchen Drucker Sie als Standarddrucker für Ihr Betriebssystem festgelegt haben.


Harmonischer Mittelwert

Argumente:

  • A, B, C, ... sind m x n Felder oder Skalare.

  • A, B, C, ... müssen reelle, positive Werte sein. Bei einem Feld müssen die Elemente reell und positiv sein.

Hinweise:

  • Der harmonische Mittelwert ist das Reziproke des arithmetischen Mittelwerts der Reziproken.

  • hmean(A, B, C, ...) < gmean(A, B, C, ...) < mittelwert(A, B, C, ...

Weitere Funktionen für die Datenanalyse...


Dialogfeld "Kopfzeile/Fußzeile"

Zum Formatieren der Kopf- bzw. Fußzeile Ihres Arbeitsblatts steht Ihnen das Dialogfeld Kopfzeile/Fußzeile mit den Registerkarten Kopfzeile und Fußzeile zur Verfügung. Auf den Registerkarten finden Sie die folgenden Optionen und Schaltflächen:

Textfelder "Links", "Zentriert", "Rechts"

Diese Felder zeigen Text oder Symbole an, aus dem bzw. denen Sie ersehen können, was in Ihrer Kopf- bzw. Fußzeile erscheinen wird. Das genaue Aussehen der Kopf- bzw. Fußzeile können Sie sich anzeigen lassen, indem Sie den Befehl Seitenansicht im Menü Datei wählen. Klicken Sie auf Für jeden Abschnitt volle Breite, wenn Sie im linken, mittleren oder rechten Feld lange Zeilen wünschen.

Hilfsmittel

Fügt den Namen Ihres Arbeitsblatts ein. Erscheint in den Textfeldern Links, Zentriert und Rechts als {f}.

Fügt den Pfad zu Ihrem Arbeitsblatt ein. Erscheint im markierten Textfeld als {p}.

Fügt die Seitenzahl ein. Erscheint im markierten Textfeld als {n}.

Fügt die Gesamtzahl der Seiten in Ihrem Arbeitsblatt ein. Erscheint im markierten Textfeld als {nn}.

Fügt das Datum ein, an dem Ihr Arbeitsblatt zuletzt gespeichert wurde. Erscheint im markierten Textfeld als {fd}.

Fügt die Uhrzeit ein, an der Ihr Arbeitsblatt zuletzt gespeichert wurde. Erscheint im markierten Textfeld als {ft}.

Fügt die aktuelle Tabelle ein. Erscheint im markierten Textfeld als {d}.

Fügt die aktuelle Uhrzeit ein. Erscheint im markierten Textfeld als {t}.

Format

Mit dieser Schaltfläche öffnen Sie ein weiteres Dialogfeld, in dem Sie die Schriftart für die Kopf- bzw. Fußzeile ändern können.

Bild

Mit dieser Schaltfläche können Sie eine Bitmap-Datei in die Kopf- bzw. Fußzeile einfügen. Erscheint im markierten Textfeld als {image}.

Seitenzählung beginnen mit

Mit dieser Option können Sie festlegen, welche Seitennummer auf der ersten Seite erscheinen soll.

Unterschiedliche Kopf- und Fußzeile auf erster Seite

Zeigt zwei zusätzliche Registerkarten im Dialogfeld an. Verwenden Sie diese Registerkarte, um eine andere Kopf- bzw. Fußzeile für die erste Seite des Arbeitsblatts festzulegen.

Seite

Hiermit legen Sie fest, dass jede Seite mit einem Rahmen versehen werden soll.

Kopfzeile

Hiermit legen Sie fest, dass die Kopfzeile mit einem Rahmen versehen werden soll.

Fußzeile

Hiermit legen Sie fest, dass die Fußzeile mit einem Rahmen versehen werden soll.


Heaviside-Funktion oder Unit-Funktion

(x) Gibt 0 zurück, wenn x negativ ist, andernfalls wird 1 zurückgegeben.

Argumente:

  • x muss ein reeller Skalar sein.

Da diese Funktion bei 0 eine Unstetigkeit aufweist, sollten Sie Ausdrücke, die diese Funktion einschließen, nicht über ein Intervall mit 0 integrieren. Stattdessen empfiehlt es sich, den Integrationsbereich in zwei Teilbereiche aufzuteilen, über jeden Bereich einzeln zu integrieren und die Ergebnisse dann zu addieren.

Aus demselben Grund ist die Ableitung dieser Funktion bei 0 nicht definiert.


Hilfe / Info über Mathcad...

Zeigt die Nummer Ihrer Mathcad-Version an.


Menü "Hilfe" - Befehl "Author's Reference" (Autorenreferenz)

Die Autorenreferenz (Author's Reference) ist eine separate Hilfedatei, die Folgendes umfasst:

  1. Anweisungen zum Erstellen von elektronischen Büchern in Mathcad.
  2. Speichern von Mathcad-Dateien für das Web mit MathML, damit die Dateien in Mathcad zurückgelesen werden können.


Hilfe - Developer's Reference (Entwickler-Referenz)

Die Entwickler-Referenz (Developer´s Reference) ist eine separate Hilfedatei, die Folgendes umfasst:

  • Anpassen der MathSoft-Steuerkomponente,

  • Datenerfassungskomponente,

  • Erstellen einer Benutzer-DLL,

  • Verwenden von Mathcad als Automation Server-Anwendung, und

  • Erstellen von benutzerdefinierten Mathcad-Komponenten.


Hilfe / Quicksheets

Öffnet das Fenster Ressourcen mit einer Liste von Beispielarbeitsblättern, die die Verwendung von benutzerdefinierten Steuerelementen, Skriptobjekt-Komponenten, Benutzer-DLLs und der Automatisierungsschnittstelle darstellen.


Hilfe / Mathcad-Hilfe

Öffnet ein Fenster mit einem Index, einem Inhaltsverzeichnis und einer Volltext-Suchfunktion für die Online-Hilfe.


Menü "Hilfe" - Befehl "Mathcad-Aktualisierung"

Überprüft Mathcad.com auf relevante Service-Releases. Wird ein Service-Release gefunden, öffnet Mathcad ein Suchfenster für den Download-Bereich. Um auf den Download-Bereich von Mathcad.com zugreifen zu können, müssen Sie sich anmelden.


Hilfe / Mathcad.com

Ruft das Dialogfeld Ressourcen auf, in dem Sie zur Mathcad-Website gelangen, auf der Sie Service-Updates abrufen, die Online-Bibliothek mit Mathcad-Dateien durchsuchen und sich mit anderen Mathcad-Benutzern austauschen können.


Hilfe / E-Books / Buch öffnen...

Ruft das Dialogfeld Öffnen auf, in dem Sie ein Elektronisches Buch öffnen können. Wechseln Sie in diesem Dialogfeld zu einer der *.hbk-Dateien (*.hbk ist das Dateiformat für elektronische Bücher).


Hilfe / Verweistabellen

Öffnet das Dialogfeld Ressourcen, das eine Reihe Verweistabellen für Physik, Differential/Integral, Geometrie und andere Themen enthält.


Hilfe / Tipps und Tricks...

Öffnet das Dialogfeld Tipps und Tricks, das einen von vielen Tipps und Tricks anzeigt. Mit der Schaltfläche Nächster Tipp können Sie alle verfügbaren Tipps und Tricks durchblättern.

Soll das Dialogfeld Tipps und Tricks nicht mehr beim Starten von Mathcad angezeigt werden, deaktivieren Sie die Option Tipps bei Programmstart anzeigen.


Hilfe / Lernprogramme

Öffnet im Fenster Ressourcen eine Übersicht über Mathcad mit einer Beschreibung der neuen Funktionen und mehreren Einführungslernprogrammen für neue Benutzer.


Hilfe / Was ist das?

Ruft das kontextspezifische Hilfesystem auf, mit dem Sie die Hilfe zu einem bestimmten Menübefehl oder den Symbolleistenschaltflächen aufrufen können.


Menü "Hilfe"

Mathcad-Hilfe

Was ist das?

Developer's Reference (Entwickler-Referenz)

Author's Reference (Autorenreferenz)

Lernprogramme

Quicksheets

Verweistabellen

Tipps und Tricks...

E-Books Þ Buch öffnen...

Benutzerforen

Mathcad.com

Mathcad-Aktualisierung...

Info über Mathcad...


Hermitesche Polynomfunktion

Her(n,x) Gibt den Wert des Hermiteschen Polynoms vom Grad n an der Stelle x zurück.

Argumente:

n ist eine nicht-negative ganze Zahl.

x muss ein Skalar sein.

Das Hermitsche Polynom ist eine Lösung der folgenden Differentialgleichung:


Ausblenden von Komponentargumenten

Zum Ausblenden von Eingabevariablen oder Ausgabevariablen für eine Komponente gehen Sie wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf die Komponente.

  2. Wählen Sie Argumente ausblenden im Kontextmenü.


Hervorheben von Anmerkungen in einem E-Book

Standardmäßig werden alle an einem Elektronischen Buch vorgenommenen Änderungen in einer anderen Farbe dargestellt.

Sie können diese Funktion wie folgt deaktivieren:

  • Wählen Sie die Option Änderungen hervorheben aus dem Kontextmenü Buch.

Mathcad entfernt das Häkchen neben dem Menübefehl und zeigt jetzt auch Ihre Änderungen in der gewöhnlichen Textfarbe an.

Erneutes Aktivieren der Funktion:

  • Wählen Sie die Option Änderungen hervorheben aus dem Kontextmenü Buch.

Mathcad setzt ein Häkchen neben den Menübefehl und zeigt Ihre Änderungen in einer anderen Farbe an.


Hinweise zur Verwendung der Wurzelfunktion

Die Funktion wurzel beginnt die Suche nach den Wurzeln einer Funktion, indem sie sich schrittweise dem Wurzelwert nähert. Sobald der Betrag der Funktion an der vorgegebenen Wurzel unter dem Wert von TOL liegt, gibt die Funktion wurzel ein Ergebnis zurück. Andernfalls wird ein Fehler zurückgegeben.

Im Folgenden finden Sie einige Tipps für die effiziente Nutzung der Funktion wurzel:

Sie können die Genauigkeit der Funktion wurzel ändern, indem Sie einen anderen Wert für TOL einstellen. Um eine genauere Wurzel zu ermitteln, senken Sie den Wert von TOL. Wurde keine Wurzel gefunden, erhöhen Sie den Wert von TOL.

Enthält der Ausdruck mehrere Wurzeln, sollten Sie unterschiedliche Schätzwerte ausprobieren oder das optionale 3. und 4. Argument der Funktion wurzel verwenden, um das Intervall anzugeben, in dem die gewünschte Wurzel liegt.

Bei einem Ausdruck f(x) mit einer bekannten Wurzel a entspricht die Suche nach weiteren Wurzeln von f(x) dem Lösen nach Wurzeln der Gleichung h(x) = f(x) / (x-a). Das Ausdividieren solcher bekannter Wurzeln ist für die Auflösung zweier Wurzeln nützlich, die möglicherweise eng beieinander liegen. Oft findet man die Lösung für Wurzeln von h(x) wie hier definiert leichter als weitere Wurzeln von f(x) mithilfe unterschiedlicher Schätzwerte.

Die Funktion wurzel bietet sich an, wenn Sie nach der Wurzel eines Ausdrucks suchen, während Sie einen seiner Parameter variieren. Die einfachste Möglichkeit besteht dabei in der Definition einer Funktion mit der Funktion wurzel.


Histogramme

hist(intvls,daten) Gibt ein Histogramm von Daten zurück; einen Vektor, der die Häufigkeiten repräsentiert, mit denen Werte in daten auf die von intvls repräsentierten Intervalle fallen.

histogramm(Intervalle,Daten) Gibt eine Matrix mit zwei Spalten zurück. Die erste Spalte enthält Mittelpunkte der n Teilintervalle des Bereichs min(A) £ Wert £ max(A) gleicher Länge. Die zweite Spalte ist identisch mit hist(n, A), und die resultierende Matrix hat demzufolge n Zeilen. Mit histogramm sparen Sie sich gegenüber hist den zusätzlichen Schritt der Definition von Horizontalachsendaten beim grafischen Darstellen.

Argumente:

intvls ist entweder:

  • Ein Vektor von Intervallen, die reelle Werte in absteigender Ordnung sind, sodass das i-te Element des zurückgegebenen Vektors der Anzahl der Daten entspricht, die auf das i-te und das (i+1)-te Element von intvls fallen.

  • Eine ganze Zahl größer null, die die Anzahl der Teilintervalle gleicher Länge angibt.

daten ist ein Feld reeller Datenwerte.


Pos1

In leeren Bereichen...

Verschiebt das Fadenkreuz neben den vorhergehenden Bereich. Wenn sich das Fadenkreuz bereits am ersten Bereich befindet, ist dieser Tastaturbefehl unwirksam.

In Rechenbereichen...

Verschiebt die Bearbeitungslinien an den Anfang des Ausdrucks. Wenn sich die Bearbeitungslinien bereits dort befinden, ist dieser Tastaturbefehl unwirksam.

In Textbereichen...

Verschiebt die Texteinfügemarke an den Anfang der Zeile. Wenn sich die Einfügemarke bereits dort befindet, ist dieser Tastaturbefehl unwirksam.


Wechseln in den manuellen oder automatischen Modus

Wählen Sie Berechnen im Menü Extras.

  • Ist die Option Automatische Berechnung aktiviert, werden die Berechnungen im automatischen Modus durchgeführt.

  • Ist die Option Automatische Berechnung nicht aktiviert, erfolgen die Berechnungen im manuellen Modus.


Merkmale des automatischen Modus

Im automatischen Modus sehen Sie Folgendes:

  • Das Wort "auto" wird in der Meldungszeile angezeigt.

  • Links von Automatische Berechnung im Menü Extras wird ein Häkchen angezeigt.


Merkmale des manuellen Modus

Im manuellen Modus sehen Sie Folgendes:

  • Das Wort "auto" wird nicht in der Meldungszeile angezeigt.

  • Das Wort "calc" kann in der Meldungszeile angezeigt werden.

  • Links von Automatische Berechnung im Menü Extras wird kein Häkchen angezeigt.


HTML-Vorlage

In einer Vorlagendatei sind die HTML-, Javascript- und andere, von Webbrowsern lesbare Bereiche festgelegt, mit denen ein Mathcad-Arbeitsblatt gestaltet werden kann, wenn es als MathML gespeichert wird. Vorlagendateien werden über die Registerkarte "HTML-Optionen" im Menü "Einstellungen" ausgewählt oder im zweiten Dialogfeld von Als Web-Seite speichern.

Web-Vorlagendateien werden mit der Erweiterung .mlt gespeichert und müssen zusätzlich zu den HTML-Tags, die im fertigen Dokument enthalten sein sollen, über die folgenden vier Kommentar-Tags verfügen. In den <HEAD>-Tags des Dokuments:

<!-- #BeginEditable "Title" -->
<title>Platz für Beispieltitel</title>
<!-- #EndEditable -->

<!-- #BeginEditable "MathMLheaders" -->
Platz für META-Tag-Informationen
<!-- #EndEditable -->

<!-- #BeginEditable "MathMLstyles" -->
Platz für Cascading Styles
<!-- #EndEditable -->

Zwischen den Titel-Tags müssen Sie unbedingt einen Titel einfügen. Dieser Titel wird nur dann überschrieben, wenn Sie im Dialogfeld Als Web-Seite speichern einen neuen Titel angeben. Wenn Sie keinen neuen Titel angeben, werden die Tags der Vorlagendatei verwendet. Je nachdem, wo das Mathcad-Arbeitsblatt in der Vorlage erscheinen soll, fügen Sie zwischen die <BODY>-Tags des Dokuments die folgenden Zeilen ein:

<!-- #BeginEditable "MathMLcontent" -->
HTML/MathML-Inhalt des Mathcad-Arbeitsblattes wird hier überschrieben
<!-- #EndEditable -->

Beachten Sie, dass sich diese Vorlagen von den Style-Vorlagen des Mathcad-Arbeitsblattes unterscheiden.


Hyperbolisches Kosinusintegral


Hyperbolische Funktionen

sinh(z) | cosh(z)
tanh(z) | csch(z)
sech(z) | coth(z)

Argumente:

z muss in Radiant angegeben werden.

z muss ein Skalar sein.

z muss dimensionslos sein.

Verwandte Themen

Felder als Argumente

Rundungsfehler bei numerischen Angaben

Beziehung zu trigonometrischen Funktionen

Definitionen für hyperbolische Funktionen


Numerische Probleme bei hyperbolischen trigonometrischen Funktionen

Da Funktionen unter Verwendung von Gleitkommazahlen mit doppelter Genauigkeit ausgewertet werden, kommt es unweigerlich zu Rundungsfehlern, die sich auf die Berechnungen auswirken. Dies gilt vor allem dann, wenn das Argument der Funktion extreme Werte annimmt.

Rundungsfehler bei hyperbolischen Funktionen treten in den folgenden Fällen auf:

Große Argumente

Bei sehr großen Argumenten kommt es zu kleinen Genauigkeitsfehlern.

Singularitäten

Sowohl cosh(x) als auch sinh(x) weisen keinerlei Begrenzungen auf, wenn das Argument in Richtung + bzw. - unendlich geht.


Hyperbolisches Sinusintegral


Hypergeometrische Verteilung

Verteilungen in Beziehung zur hypergeometrischen Gleichung:

dhypergeom(m,a,b,n) Gibt die Wahrscheinlichkeitsdichte für die hypergeometrische Verteilung zurück.

phypergeom(m,a,b,n) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qhypergeom(p,a,b,n) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rhypergeom(m,a,b,n) Gibt einen Vektor von m Zufallszahlen zurück, die eine hypergeometrische Verteilung aufweisen.


Hyperlink (Definition)

Als Hyperlink wird ein Bereich oder eine Gruppe von ausgewähltem Text bezeichnet, mit dem ein anderes Arbeitsblatt oder eine andere Datei durch Doppelklicken geöffnet wird oder mit dem man zu einem anderen Bereich desselben Arbeitsblattes oder eines anderen Arbeitsblattes springen kann.

Standardmäßig kennzeichnet fett hervorgehobener, unterstrichener Text eine Hyperlink-Verknüpfung. Liegt die Hyperlink-Verknüpfung jedoch in einem Bereich, der keinen Text enthält, gibt es keinen Anhaltspunkt, an dem man diese Verknüpfung erkennen kann. Daher sollten Sie die Hyperlinks stets mit ausgewähltem Text erstellen.


Hyperlinks aus Nichttext-Bereichen

Grundsätzlich können Sie von jeder Stelle aus Hyperlinks erstellen; allerdings müssen Sie zwei entscheidende Nachteile in Kauf nehmen, wenn Sie als Gateway der Verknüpfung keinen ausgewählten Text verwenden.

  • Wenn Sie einen Hyperlink mit Text als Gateway erstellen, setzt Mathcad den Text automatisch fett und unterstrichen, um anzuzeigen, dass es sich um einen Hyperlink handelt. Bei anderen Gateways ist diese Kennzeichnung nicht möglich.

  • Durch die Hyperlink-Verknüpfung wird die gewöhnliche Reaktion auf den Doppelklick aufgehoben. Wenn Sie zum Beispiel ein Diagramm als Gateway festlegen, können Sie durch Doppelklicken kein Formatierungsdialogfeld mehr öffnen.

Daher wird empfohlen, dass Sie zum Erstellen von Hyperlinks nur ausgewählten Text verwenden.


Hyperlinks zu Mathcad-fremden Dateien

Sie können nicht nur zu anderen Mathcad-Arbeitsblättern Hyperlinks erstellen, sondern auch von einem Mathcad-Arbeitsblatt zu anderen Dateitypen, z. B. einer AVI-Datei. In diesem Fall können Sie die verknüpfte Datei nicht in einem Popup-Fenster darstellen lassen.


Einheitsmatrix

einheit(n) Gibt eine n x n große Einheitsmatrix (Matrix aus Nullen mit Einsen entlang der Diagonalen) zurück.

Argumente:

  • n muss eine positive ganze Zahl sein.


Verzweigungsfunktion

if(cond, x, y) Gibt x zurück, wenn die logische Bedingung cond wahr (ungleich null) ist; andernfalls y.

Argumente:

cond ist im Normalfall ein Ausdruck, der einen logischen oder booleschen Operator einschließt. So sind z. B. die folgenden Verwendungen möglich:

(i < 2)

(x<1) [image] (x>0) oder (x<1)*(x>0) für ein “und”-Gate

(x>1) [image] (x<0) oder (x>1)+(x<0) für ein “oder”-Gate

x=4 für eine Gleichheit

x ist der Wert, der zurückgegeben wird, wenn cond wahr ist.

y ist der Wert, der zurückgegeben wird, wenn cond falsch ist.

Hinweise:

if ist ein Mathcad-Operator, keine Funktion, und funktioniert nicht mit Operatoren, die Funktionen modifizieren (wie der Operator "Vektorisieren").


Ignorieren von Definitionen

Normalerweise übernimmt Mathcad alle bestehenden Definitionen, die es in Ihrem Arbeitsblatt findet, wenn Sie mit symbolischen Schlüsselwörtern arbeiten.

Um Mathcad anzuweisen, aktive symbolische Berechnungen zu verwenden und bestimmte, bereits definierte Variablen zu ignorieren, geben Sie eine rekursive Definition für die Variable an. Wenn im Arbeitsblatt zum Beispiel die Definition x:=10 enthalten ist, Mathcad jedoch beim symbolischen Auswerten annehmen soll, dass x nicht definiert ist, geben Sie Folgendes ein: x:=x.

Soll Mathcad jedoch alle bereits bestehenden Definitionen im Arbeitsblatt ignorieren, können Sie einen Ausdruck mit den Befehlen im Menü Symbolik symbolisch auswerten.


Ungültiger Kontext. Drücken Sie F1, um die Hilfe aufzurufen.

Die häufigsten Ursachen dieser Fehlermeldung sind:

  • Sie haben ein Semikolon an einer Stelle eingegeben, die keine zulässige Definition eines Bereichs ist. (Das Semikolon wird als zwei Punkte angezeigt.)

  • Sie haben einen bereits vorhandenen Funktionsnamen als Variablennamen bzw. einen bereits vorhandenen Variablennamen als Funktionsnamen verwendet. Gilt zum Beispiel f(x):=x, so erzeugt f +2 = einen unzulässigen Kontext.

  • Sie haben eine Definition mit einer Bereichsvariablen auf der rechten Seite erstellt. Die Bereichsvariable fehlt jedoch auf der linken Seite der Definition. Gilt zum Beispiel p:=0..4, so erzeugt f:=p+2 einen Fehler. Legen Sie stattdessen folgende Definition fest: f(p):=p+2 oder fp:=2.

  • Sie haben eine Funktionsdefinition mit einer Bereichsvariablen erstellt. Die Bereichsvariable muss ein Argument der Funktion sein. Beispiel:

    Dieses Beispiel erzeugt den Fehler "unzulässiger Kontext". Wenn Sie jedoch die Bereichsvariable i als Argument der Funktion f definieren, wird kein Fehler ausgegeben:


Ungültige Dimensionen

Diese Matrix enthält nicht die Zeilen oder Spalten, auf die Sie verweisen. Geben Sie den Namen der Matrix ein, und drücken Sie die Taste "=", um die Zahl der in der Matrix enthaltenen Zeilen und Spalten zu überprüfen.


Ungültige Funktionssyntax

Ein Ausdruck wie z. B. (f)(x) kann nicht symbolisch ausgewertet werden.


Name der Bilddatei

Dies ist der Name der Datei, die das Bild enthält.

Befindet sich die Datei nicht im Standardverzeichnis, müssen Sie den vollständigen Pfad zu der betreffenden Datei eingeben.


Bildtransformationen

Nach dem Einlesen des Bilds in die Matrix mit der Funktion BMPLESEN oder RGBLESEN können Sie das Bild mit allen verfügbaren Rechenhilfsmitteln verändern. Die folgenden Beispiele sollen Ihnen einige Anregungen bieten:

Drehen eines Bilds...

Invertieren eines Bilds...

Erhöhen des Bildkontrasts...


Imaginäre Einheiten

i oder j

Tastaturbefehl: 1i oder 1j

Beschreibung: Die imaginäre Einheit. Beachten Sie, dass Sie nicht i und j, sondern 1i und 1j eingeben müssen. In beiden Fällen wird der Zusatz "1" gelöscht, sobald Sie den Ausdruck verlassen.

Sie können auch Vielfache von i und j eingeben, z. B. 2i oder -2.5j.


Importieren von Bildern aus einer Datei

Statt Grafiken direkt über die Zwischenablage in Ihr Arbeitsblatt einzufügen, können Sie auch einfach einen Verweis auf die Datei einfügen, die diese Grafik enthält. Diese Vorgehensweise bietet mehrere Vorteile. Der Bildbereich kann die folgenden Grafikformate aufnehmen: BMP, GIF, JPG, PCX und TGA.

Zum Einfügen einer Grafik aus einer Bilddatei gehen Sie folgendermaßen vor:

  1. Klicken Sie auf die gewünschte Position des Bildes, und wählen Sie den Befehl Bild aus dem Menü Einfügen.

  2. Drücken Sie die Anführungszeichentaste ("), um eine Zeichenfolge zu erstellen. Es erscheinen zwei Anführungszeichen mit einer Einfügemarke dazwischen.

  3. Geben Sie den Pfadnamen der Bilddatei ein.

Das importierte Bild können Sie mit den Schaltflächen der Symbolleiste "Bild" und den Optionen im Dialogfeld "Eigenschaften" auf vielfältige Art und Weise bearbeiten. Es ist auch möglich, das Bild wie jeden anderen Bereich zu formatieren. So kann es mit einem Rahmen versehen, markiert oder die Berechnung deaktiviert werden.

Hinweise:

  • Wenn Sie die Datei auf der Festplatte ändern, müssen Sie in einen Grafikbereich klicken und Berechnen aus dem Menü Extras wählen, um das Arbeitsblatt zu aktualisieren.

  • Sie können Bitmaps auch aus einer Datei importieren, indem Sie die Datei als Datenmatrix einlesen oder die Datei als Objekt einfügen.


Importieren von Daten aus einer Datei (Definition)

Importieren von Daten aus einer Datei

Der Vorgang, bei dem Daten aus einer externen Datendatei mit einem Mal in ein Arbeitsblatt übertragen werden.


Unvollständige Betafunktion

ibeta(a,x,y) Gibt den Wert der unvollständigen Betafunktion von x und y mit dem Parameter a zurück.

Argumente:

a ist ein reeller Skalar zwischen 0 und 1.

x und y sind reelle Skalare größer null.

Die unvollständige Betafunktion tritt häufig in Wahrscheinlichkeitsberechnungen auf. Sie ist durch folgende Formel definiert:


Einzüge

Hierfür gibt es zwei Verfahren: das Dialogfeld Absatzformat oder die Verwendung des Textlineals.

Zum Ändern des Einzugs in einem Textbereich gehen Sie wie folgt vor:

  1. Markieren Sie Text innerhalb der Absätze.

  2. Wählen Sie Absatz im Menü Format.

  3. Mit den Optionen im Dialogfeld "Absatzformat" stellen Sie die Einzüge wie folgt ein:

  • Sollen alle Zeilen eines Absatzes um denselben Betrag eingezogen werden, geben Sie unter Einzug in den Textfeldern Links und Rechts einen Wert ein.

  • Soll die erste Zeile um einen anderen Betrag als die anderen Zeilen eines Absatzes eingezogen werden, wählen Sie im Feld Spezial die Option Erste Zeile, und geben Sie im Textfeld Um einen Wert ein.

  • Um einen hängenden Einzug einzustellen, wählen Sie im Dialogfeld Spezial die Option Hängender Einzug, und geben Sie im Textfeld Um einen Wert ein.

  4. Klicken Sie auf OK.

Zur Einstellung des Einzugs mit dem Textlineal gehen Sie wie folgt vor:

  1. Klicken Sie auf einen Absatz im Textbereich.

  2. Wählen Sie Lineal im Menü Ansicht. Das Textlineal müsste jetzt am oberen Fensterrand angezeigt werden.

  3. Soll für jede Zeile im Absatz der gleiche Einzug eingestellt werden, setzen Sie beide Pfeile auf dem Lineal auf dieselbe Position.

  4. Soll für die erste Zeile ein anderer Einzug als für die restlichen Zeilen eingestellt werden, schieben Sie den oberen oder unteren Pfeil auf dem Lineal an eine andere Position.


Unendlichkeit

Tastaturbefehl: Strg+Umschalt+z

Beschreibung: In numerischen Ausdrücken gilt hierfür:

In symbolischen Berechnungen steht dies für die gängige mathematische Definition von Unendlichkeit.


Infix-Notation

Mit der Infix-Notation kann ein Binäroperator angezeigt werden. Bei der Infix-Notation erscheint der Operator zwischen den Operanden. Beispiel:


Operator "Inline-Division"

Inline-Division

Tastaturbefehl: [Strg] + /

x [image] y Gibt x geteilt durch y zurück. Wenn y=0, wird eine Fehlermeldung angezeigt, die darauf hinweist, dass eine Singularität vorliegt. Wenn es sich bei x um ein Feld handelt, teilt der Divisionsoperator jedes Element des Feldes durch y.

Operanden:

x und y sind Skalare.

y muss ungleich null sein.

Beachten Sie, dass die unbestimmte Form 0/0 stets 0 ergibt.


Operator "Inneres Produkt"

Vektor "Inneres Produkt"

Tastaturbefehl: *

Gibt das Skalarprodukt von u und v (auch "inneres Produkt" genannt) zurück.

Operanden:

u und v sind beides Vektoren mit derselben Anzahl von Elementen.

Das Skalarprodukt (innere Produkt) ist ein Skalar, der durch die Multiplikation der jeweils einander entsprechenden Elemente von u und v und die anschließende Summation der Ergebnisse entsteht. Das Skalarprodukt hat die folgenden Merkmale:

=| u || v |cos(q), wobei q den Winkel zwischen u und v angibt.

Wenn u und v orthogonal sind, ist ihr inneres Produkt null.

Das innere Produkt von u mit sich selbst ist einfach das Quadrat der Länge von u.


Eigenschaften der Datentabelle: Format

Angezeigte Genauigkeit

Wählen Sie eine ganze Zahl aus, oder geben Sie sie ein. Bestimmt die Anzahl der Werte hinter dem Dezimaltrennzeichen.

Nachfolgende Nullen anzeigen

Legt fest, ob Ergebnisse rechts vom Dezimalzeichen mit Nullen aufgefüllt werden sollen, um den unter Angezeigte Genauigkeit festgelegten Wert zu erreichen.

Wenn Sie z. B. für Angezeigte Genauigkeit den Wert "3" festgelegt haben, wird "3/2" als "1.5" angezeigt, solange Nachfolgende Nullen anzeigen nicht aktiviert ist. Wird die Option aktiviert, erscheint dieselbe Zahl als "1.500".

Radix

Diese Option steht für die Datentabelle nicht zur Verfügung.

Exponentialschwelle

Wählen Sie eine ganze Zahl n aus, oder geben Sie sie ein. Werte kleiner 10^-n oder größer 10^n werden in Exponentialschreibweise angezeigt.

Komplexe Schwelle

Wählen Sie eine ganze Zahl aus, oder geben Sie sie ein. Hiermit wird festgelegt, um wieviel größer der reelle oder imaginäre Teil einer Zahl sein muss, bevor die Anzeige des kleineren Teils unterdrückt wird.

So wird die Zahl 1+0.002i bei unterschiedlichen Werten für "Komplexe Schwelle" wie folgt angezeigt:

Anzeigen von Zeilen-/Spaltenbeschriftungen

Durch Klicken auf dieses Feld können Sie die Zeilen- und Spaltennummern für die Werte in der Tabelle anzeigen.

Schriftart

Öffnet ein Dialogfeld, in dem Sie die Schriftart für die angezeigten Zahlen bestimmen können.


Eingabevariable

Eine Eingabevariable ist ein Wert, der über eine Komponente an eine andere Anwendung oder Datenquelle übergeben wird. Bei einer Eingabevariablen kann es sich um einen einzelnen Wert, ein Feld oder eine Zeichenfolge handeln.

Hinweis:

  • Zeichenfolgen und Variablen mit Einheiten sind für bestimmte Komponenten zulässig.


Einfügen / Region

Fügt Regionsbegrenzungslinien in Ihr Arbeitsblatt ein.

Platzieren Sie die Bereiche zwischen den Begrenzungslinien, und sperren Sie die Region dann. Sie können die Region auch ausblenden.


Einfügen / Komponente

Zeigt das Dialogfeld Komponente einfügen aus dem Menü Einfügen an. Wählen Sie eine einzufügende Komponente aus, und klicken Sie auf OK.

Im Menü Einfügen stehen separate Untermenüs für häufig verwendete Komponenten zur Verfügung: Daten und Steuerelement.

Diese Menüoption ist nur verfügbar, wenn Sie auf eine leere Stelle im Arbeitsblatt klicken.


Einfügen / Steuerelement

Steuerelemente sind Komponenten, mit denen Sie eine Mathcad-Berechnung mit anderen Mitteln als Variablen- oder Funktionsdefinitionen steuern können. Steuerelemente können unter Verwendung einer Skriptsprache, wie VBScript oder JScript, individuell angepasst werden.

In Mathcad stehen folgende, an Windows angelehnte Steuerelemente zur Verfügung:

  • Kontrollkästchen
  • Optionsfeld
  • Schaltfläche
  • Textfeld
  • Listenfeld
  • Schieberegler

Steuerelemente werden der Ausgabe einer oder mehrerer Variablen zugewiesen und können auf den Wert anderer Variablen im Mathcad-Arbeitsblatt zugreifen. Weitere Informationen erhalten Sie in der Developer's Reference (Entwickler-Referenz).

Hinweise:

  • Diese Menüoption ist nur verfügbar, wenn Sie auf eine leere Stelle im Arbeitsblatt und nicht in einen bereits vorhandenen Platzhalter klicken.
  • Sämtliche Steuerelemente stehen auch über die Steuerleiste zur Verfügung.


Einfügen / Daten

Mit der Menüoption Daten im Menü Einfügen stehen Ihnen drei Möglichkeiten zum Importieren oder Exportieren von Daten in einer Vielzahl von Formaten zur Verfügung.

  • Mit Dateieingabe wird eine Komponente in Ihr Arbeitsblatt eingefügt, die aus Datendateien in den folgenden Formaten Daten liest: ASCII-Text, MATLAB, Microsoft Excel, Lotus 1-2-3, Quattro Pro, dBase III und S-PLUS. Diese Komponente kann erneut berechnet werden, um Daten erneut zu lesen, wenn die Datei geändert wurde.

  • Mit Dateiausgabe wird eine Komponente in Ihr Arbeitsblatt eingefügt, die in eine Datendatei Daten in den folgenden Formaten schreibt: ASCII-Text, MATLAB, Microsoft Excel, Lotus 1-2-3, Quattro Pro, dBase III und S-PLUS. Es stehen zusätzliche Optionen zur Verwendung von Tabulatoren, Kommas oder Leerzeichen für die Textdateiausgabe zur Verfügung. Diese Komponente kann erneut berechnet werden, um Daten erneut zu schreiben, wenn sie geändert wurden.

  • Mit der Menüoption Tabelle wird eine Komponente in Ihr Arbeitsblatt eingefügt, die Daten aus denselben Typen von Datendateien liest, die von den anderen Datenkomponenten unterstützt werden. Datentabellen lesen Daten nur einmal; eine Verknüpfung mit der Datei wird nicht beibehalten.

Sie können die Anzahl der Zeilen oder Spalten mit Daten, die gelesen werden, ändern, oder, im Fall von Excel-Arbeitsblättern, benannte Bereiche oder Zellbereiche angeben. Sie können diese Einstellungen entweder ändern, wenn die Komponente erstellt wird, oder indem Sie mit der rechten Maustaste auf die Komponente klicken und im Kontextmenü Eigenschaften auswählen.

Hinweise:

  • Diese Menüoption ist nur verfügbar, wenn Sie auf eine leere Stelle im Arbeitsblatt und nicht in einen bereits vorhandenen Platzhalter klicken.
  • Sie können der Standardsymbolleiste Erstellungsschaltflächen für Datendateikomponenten hinzufügen, indem Sie mit der rechten Maustaste auf die Symbolleiste klicken.


Einfügen / Funktion

Öffnet das Dialogfeld "Funktion einfügen", in dem Sie eine Liste der vordefinierten Funktionen finden.

Sie erhalten Kurzbeschreibungen der Funktionen, indem Sie auf den Namen klicken und den Text lesen, der in dem Feld auf der rechten Seite angezeigt wird.

Zum Einfügen einer vordefinierten Funktion zusammen mit den erforderlichen Platzhaltern ist wie folgt vorzugehen:

  1. Markieren Sie den Funktionsnamen in der Liste der Funktionen.

  2. Klicken Sie auf Einfügen.


Einfügen / Diagramm / 3D-Säulendiagramm

Fügt den 3D-Diagrammoperator mit einem Platzhalter in Ihr Arbeitsblatt ein. Erstellen Sie ein dreidimensionales Säulendiagramm der Elemente in einer Matrix, indem Sie die Matrix in den Platzhalter eingeben. Die Zeilen und Spalten der Matrix entsprechen den x- und y-Werten. Die Werte der Matrixelemente selbst stellen die Höhen der Säulen über der xy-Ebene dar.

Wenn Sie das Erscheinungsbild des Diagramms (wie z. B. seine Farbe und seine Linien) beim Einfügen festlegen möchten, wählen Sie stattdessen Einfügen / Diagramm / 3D-Diagrammassistent.


Einfügen / Diagramm / 3D-Diagrammassistent

Öffnet den 3D-Diagrammassistenten, der Sie durch das Erstellen eines dreidimensionalen Diagramms, z. B. eines Flächendiagramms, Umrissdiagramms, 3D-Säulendiagramms oder 3D-Streuungsdiagramms, führt.


Einfügen / Diagramm / 3D-Streuungsdiagramm

Fügt den 3D-Diagrammoperator in Ihr Arbeitsblatt ein. Erstellen Sie ein Streuungsdiagramm einer willkürlichen Sammlung von Punkten in drei Dimensionen, indem Sie in den Platzhalter drei Vektoren eingeben. Die Zeilen der Vektoren stehen für die x-, y- und z-Koordinaten der darzustellenden Punkte.

Sie können auch die Elemente einer Matrix darstellen lassen. Geben Sie dazu die Matrix in den Platzhalter ein. Die Zeilen und Spalten entsprechen der x- und y-Achse. Der Wert des Feldelements selbst stellt die Höhe über der xy-Ebene dar. Die einzelnen Punkte werden nicht zu einer Fläche verbunden.

Wenn Sie das Erscheinungsbild des Diagramms (wie z. B. seine Farbe und seine Linien) beim Einfügen festlegen möchten, wählen Sie stattdessen Einfügen / Diagramm / 3D-Diagrammassistent.


Einfügen / Diagramm / Umrissdiagramm

Fügt den 3D-Diagrammoperator mit einem Platzhalter in Ihr Arbeitsblatt ein. Ein Umrissdiagramm der Elemente einer Matrix erstellen Sie, indem Sie die Matrix in den Platzhalter eingeben. Die Zeilen und Spalten der Matrix entsprechen den x- und y-Achsen. Die Werte der Matrixelemente selbst stellen die Umrisse über der xy-Ebene dar.

Wenn Sie das Erscheinungsbild des Diagramms (wie z. B. seine Farbe und seine Linien) beim Einfügen festlegen möchten, wählen Sie stattdessen Einfügen / Diagramm / 3D-Diagrammassistent.


Einfügen / Diagramm / Kreisdiagramm

Fügt den Kreisdiagrammoperator mit den Platzhaltern für eine Winkelvariable und einen radialen Ausdruck ein. Um ein Kreisdiagramm einer Funktion schnell zu erstellen, klicken Sie auf den Platzhalter links und geben den Funktionsausdruck ein.


Einfügen / Diagramm / Flächendiagramm

Fügt den 3D-Diagrammoperator in Ihr Arbeitsblatt ein. Ein Flächendiagramm der Elemente einer Matrix erstellen Sie, indem Sie die Matrix in den Platzhalter eingeben. Die Zeilen und Spalten der Matrix entsprechen der x- und der y -Achse. Die Werte der Matrixelemente selbst stellen die Höhe über der xy-Ebene dar.

Wenn Sie das Erscheinungsbild des Diagramms (wie z. B. seine Farbe und seine Linien) beim Einfügen festlegen möchten, wählen Sie stattdessen Einfügen / Diagramm / 3D-Diagrammassistent.


Einfügen / Diagramm / Vektorfelddiagramm

Fügt den 3D-Diagrammoperator mit einem Platzhalter in Ihr Arbeitsblatt ein. Ein zweidimensionales Vektorfelddiagramm erstellen Sie, indem Sie in den Platzhalter eine Matrix eingeben. Die Zeilen und Spalten der Matrix entsprechen den x- und y-Achsen. Die Matrixelemente selbst sind komplexe Zahlen, deren reelle und imaginäre Teile den x- und y-Komponenten eines Vektors entsprechen, der mit einem bestimmten Wert von x und y verbunden ist.

Wenn Sie das Erscheinungsbild des Diagramms (wie z. B. seine Farbe und seine Linien) beim Einfügen festlegen möchten, wählen Sie stattdessen Einfügen / Diagramm / 3D-Diagrammassistent.


Einfügen / Diagramm / X-Y-Diagramm

Fügt den X-Y-Diagrammoperator mit den Platzhaltern für die x- und y-Werte sowie für die Achsenendpunkte ein. Um ein X-Y-Diagramm einer Funktion schnell zu erstellen, klicken Sie auf den mittleren Platzhalter auf der y-Achse und geben die Funktion ein.


Einfügen / Hyperlink

Öffnet das Dialogfeld "Hyperlink einfügen", in dem Sie einen Hyperlink erstellen, bearbeiten und entfernen können.

Bevor Sie auf diesen Befehl zugreifen können, müssen Sie zunächst in einen Bereich klicken. Ein Hyperlink ist mit dem Bereich verbunden. Wenn Sie auf den Bereich doppelklicken, wird ein anderes Arbeitsblatt (das sich auf einer Festplatte oder im Internet befindet) in einem Vollbildfenster oder einem Popup-Fenster geöffnet. Mit einem Hyperlink von einem Bereich zu einem anderen Bereich können Sie direkt zu einem bestimmten Bereich im selben Arbeitsblatt oder in einem anderen Arbeitsblatt springen.


Einfügen / Rechenbereich

Fügt innerhalb von Text einen Rechenbereichsplatzhalter ein. Geben Sie einen Ausdruck, eine Variable, eine Funktion oder ein anderes Rechenelement in den Platzhalter ein.

Mit diesem Befehl können Sie auch in einem leeren Teil Ihres Arbeitsblatts einen Rechenbereichsplatzhalter erstellen. Normalerweise ist dies aber nicht nötig, da Sie Rechenelemente auch einfügen können, indem Sie einfach an der Position des Fadenkreuz-Cursors in einem leeren Teil Ihres Arbeitsblatts mit der Eingabe beginnen.

Rechenbereiche in Text verhalten sich aktiv. Das heißt, ein solcher Rechenbereich wirkt sich auf alle anderen Rechenbereiche des Arbeitsblatts aus, wie auch diese sich wiederum auf diesen Rechenbereich in Text auswirken. Sie deaktivieren einen Rechenbereich mit dem Befehl Eigenschaften im Menü Format.


Einfügen / Matrix

Öffnet das Dialogfeld "Matrix einfügen", mit dem Sie an der Stelle, an der sich der Fadenkreuz-Cursor gerade befindet, einen Vektor oder eine Matrix erstellen können.

Falls sich der Cursor in einem Vektor oder einer Matrix befindet, haben Sie mit dieser Option die Möglichkeit, eine Zeile oder eine Spalte einzufügen oder zu löschen.


Einfügen / Objekt

Zeigt ein Dialogfeld mit der Liste der OLE-Server an. Mit diesem Befehl fügen Sie ein OLE-Objekt in das Arbeitsblatt ein. Sie können ein neues Objekt erstellen oder eins aus einer vorhandenen Datei einfügen. Wählen Sie Als Symbol, wenn anstelle des Objekts im Arbeitsblatt ein Symbol angezeigt werden soll.


Einfügen / Seitenumbruch

Fügt einen Seitenumbruch an der Position des Cursors ein.

Sie löschen einen Seitenumbruch, indem Sie auf die Stelle klicken, an der die Seitenumbruchslinie den linken Rand des Arbeitsblatts berührt. Wählen Sie dann Ausschneiden im Menü Bearbeiten.


Einfügen / Bild

Fügt einen Bildbereich mit einem Platzhalter ein. Das Einfügen eines Bildes kann auf dreierlei Art und Weise erfolgen:

  • Geben Sie in den Platzhalter eine Zeichenfolge ein, die den Namen oder den Pfad zu einer Bilddatei enthält.

  • Geben Sie den Namen einer Matrix in den Platzhalter ein. Dadurch wird die Matrix mit bis zu 256 Graustufen angezeigt.

  • Geben Sie in den Platzhalter die Namen von drei Matrizen gleicher Größe (durch Kommas voneinander getrennt) ein, in denen die einem Farbbild entsprechenden Rot-, Grün- und Blauwerte enthalten sind. Dadurch wird eine RGB-Version des Bildes angezeigt. Sie können auch HSV-Versionen (Hue=Farbton, Saturation=Sättigung und Value=Farbwert) und HLS-Versionen (Hue=Farbton, Lightness=Helligkeit und Saturation=Sättigung) anzeigen lassen, sofern Ihre Matrizen diesen Farbzuweisungen entsprechen.


Einfügen / Verweis

Hiermit können Sie Platz in Ihrem Arbeitsblatt sparen, indem Sie alle Variablen- und Funktionsdefinitionen aus einem anderen Arbeitsblatt im aktuellen Arbeitsblatt verfügbar machen.

Öffnet das Dialogfeld "Verweis einfügen", in dem Sie die Datei festlegen können, auf die verwiesen werden soll. Wählen Sie ein Arbeitsblatt mit der Schaltfläche Durchsuchen aus, oder geben Sie den vollständigen Pfadnamen bzw. URL ein, und klicken Sie auf OK. Hierbei wird durch ein Symbol der Punkt gekennzeichnet, nach dem die eingefügten Definitionen verfügbar sind.

Dieser Befehl fügt den Arbeitsblattverweis an der Cursorposition ein. Sie löschen einen Verweis auf ein Arbeitsblatt, indem Sie das Symbol auswählen und Löschen im Menü Bearbeiten wählen.


Einfügen / Textbereich

Erstellt an der Position des Fadenkreuz-Cursors einen Textbereich. Der Fadenkreuz-Cursor nimmt die Form einer dünnen vertikalen Linie an. Es wird ein Feld angezeigt, durch das die Größe des Textbereichs dargestellt wird. Dieses Feld wird ausgeblendet, wenn Sie auf eine Stelle außerhalb des Bereichs klicken.

Sie können die Breite eines Textbereichs ändern, indem Sie ihn auswählen und mit der Maus den rechten Rand des Auswahlrahmens ziehen.


Einfügen / Einheit

Öffnet das Dialogfeld "Einheit einfügen", in dem Sie eine Liste der vordefinierten Einheiten finden.

Zum Formulieren eines Ergebnisses mit einer vordefinierten Einheit gehen Sie folgendermaßen vor:

  • Klicken Sie auf den Einheiten-Platzhalter rechts neben einem Ergebnis.

  • Markieren Sie in der Liste der Einheiten die gewünschte Einheit.

  • Klicken Sie auf Einfügen, damit die Einheit eingefügt wird.


Dialogfeld "Funktion einfügen"

Im Dialogfeld Funktion einfügen finden Sie die folgenden Optionen und Schaltflächen:

Funktionskategorie

Zeigt eine Liste der Kategorien der integrierten Funktionen an. Wenn Sie Alle wählen, werden alle verfügbaren Funktionen angezeigt.

Welche Kategorien angegeben werden, hängt davon ab, ob Sie zusätzliche Erweiterungspakete installiert oder eigene integrierte Funktionen geschrieben haben.

Funktionsname

Zeigt eine Liste aller integrierten Funktionen in der ausgewählten Kategorie an.

Syntax

Zeigt an, wie viele und welche Argumente für die ausgewählte Funktion erforderlich sind.

Beschreibung

Zeigt eine Beschreibung der ausgewählten Funktion an.

Schaltfläche "Einfügen"

Fügt die ausgewählte Funktion (zusammen mit Platzhaltern für ihre Argumente) in Ihr Arbeitsblatt ein.

Wenn Sie eine Funktion auf einen Ausdruck anwenden möchten, der bereits eingegeben wurde, schließen Sie den Ausdruck in Bearbeitungslinien ein, und klicken Sie dann auf diese Schaltfläche.

Schaltfläche "OK"

Fügt die ausgewählte Funktion (zusammen mit Platzhaltern für ihre Argumente) in Ihr Arbeitsblatt ein und schließt das Dialogfeld.

Schaltfläche "Hilfe"

Öffnet das Online-Hilfethema für die ausgewählte Funktion.


Dialogfeld "Hyperlink einfügen"

Im Dialogfeld Hyperlink einfügen finden Sie die folgenden Optionen und Schaltflächen:

Mit Datei oder URL verknüpfen

Geben Sie hier den Pfad zu der Datei auf dem lokalen Rechner oder einem fernen Rechner (z. B. im Netzwerk oder im Internet) ein, die sich öffnen soll, sobald Sie auf den Hyperlink doppelklicken. Der Pfad könnte z. B. so aussehen:

c:\windows\file.mcd oder http://www.mathsoft.com/text.swk

Sobald Sie einen Verweis auf das Arbeitsblatt eingefügt haben, sollte es nicht mehr in ein anderes Verzeichnis verschoben oder umbenannt werden. Wenn Sie es verschieben oder umbenennen, ist es über den Hyperlink nicht mehr auffindbar. Wenn Sie allerdings das Mathcad-Arbeitsblatt, das den Hyperlink enthält, zusammen mit dem verknüpften Arbeitsblatt verschieben möchten, achten Sie darauf, dass die relative Verzeichnisstruktur zwischen den beiden Arbeitsblättern unverändert bleibt und dass im Hyperlink selbst ein relativer Pfad angegeben wird.

Relativen Pfad für Hyperlink verwenden

Diese Option sorgt dafür, dass der Speicherort der verknüpften Datei relativ zum Speicherort des Mathcad-Arbeitsblatts angegeben wird, das die Verknüpfung enthält. Auf diese Weise bleibt der Verweis selbst dann gültig, wenn Sie die verknüpfte Datei und das Haupt-Arbeitsblatt an einen anderen Ort verschieben, ohne dabei die relative Verzeichnisstruktur zwischen beiden Dateien zu beeinträchtigen.

Damit Sie einen relativen Pfad angeben können, müssen sich die beiden Arbeitsblätter auf demselben lokalen Laufwerk bzw. demselben Netzlaufwerk befinden.

Wenn Sie einen relativen Pfad angeben, kann es vorkommen, dass er als absoluter Pfad angezeigt wird. Mathcad arbeitet intern trotzdem mit dem relativen Pfad. Wenn Sie die Dateien verschieben, ändert sich der Pfad entsprechend.

Als Popup-Dokument anzeigen

Mit dieser Option geben Sie an, dass das verknüpfte Arbeitsblatt in einem eigenen Popup-Fenster geöffnet werden soll.

Statusleistenmeldung, wenn sich Maus über Hyperlink befindet

Die hier eingegebene Meldung wird in der Statusleiste angezeigt, sobald der Mauszeiger auf den Hyperlink zeigt.

Verknüpfung entfernen

Mit dieser Schaltfläche deaktivieren Sie den mit dem ausgewählten Element verknüpften Hyperlink. So spingt Mathcad nicht mehr zu einem anderen Arbeitsblatt oder öffnet es in einem Popup-Fenster, wenn Sie auf das ausgewählte Element doppelklicken.


Dialogfeld "Matrix einfügen"

Im Dialogfeld Matrix einfügen finden Sie die folgenden Optionen und Schaltflächen:

Zeilen

Geben Sie hier die Anzahl der Zeilen ein, die eingefügt oder erstellt werden sollen.

Spalten

Geben Sie hier die Anzahl der Spalten ein, die eingefügt oder erstellt werden sollen.

Einfügen

Wenn Sie auf diese Schaltfläche klicken, wird eine Matrix mit Platzhaltern eingefügt.

  • Sollen einer bereits existierenden Matrix weitere Zeilen hinzugefügt werden, fügt Mathcad die Zeilen mit leeren Platzhaltern unterhalb des ausgewählten Elements ein.

  • Sollen einer bereits existierenden Matrix weitere Spalten hinzugefügt werden, fügt Mathcad die Spalten mit leeren Platzhaltern rechts neben dem ausgewählten Element ein.

Wenn diese Schaltfläche grau angezeigt wird, müssen Sie sicherstellen, dass Sie in den Feldern Zeilen: und Spalten: die Anzahl der Zeilen und Spalten eingegeben haben, die die neue Matrix haben soll. Außerdem muss sich der Cursor in einem Platzhalter oder an einer leeren Stelle des Arbeitsblatts befinden.

Löschen

Mit dieser Schaltfläche können Sie Zeilen und/oder Spalten aus einer Matrix löschen:

  • Beim Löschen von Zeilen beginnt Mathcad mit der Zeile, in der sich das ausgewählte Element befindet, und löscht die Zeilen von diesem Element an abwärts.

  • Beim Löschen von Spalten beginnt Mathcad mit der Spalte, in der sich das ausgewählte Element befindet, und löscht die Spalte von diesem Element an nach rechts.


Menü "Einfügen"

Diagramm / X-Y-Diagramm

Diagramm / Kreisdiagramm

Diagramm / 3D-Diagrammassistent...

Diagramm / Flächendiagramm

Diagramm / Umrissdiagramm

Diagramm / 3D-Streuungsdiagramm

Diagramm / 3D-Säulendiagramm

Diagramm / Vektorfelddiagramm

Matrix...

Funktion...

Einheit...

Bild

Region

Seitenumbruch

Rechenbereich

Textbereich

Komponente

Daten

Steuerelement

Objekt...

Verweis...

Hyperlink...


Dialogfeld "Objekt einfügen"

Im Dialogfeld Objekt einfügen finden Sie die folgenden Optionen und Schaltflächen:

Create New

Ermöglicht es, eine Grafik einzufügen, die in einer vorhandenen Datei gespeichert ist.

Aus Datei erstellen

Ermöglicht es, eine Grafik einzufügen, die in einer vorhandenen Datei gespeichert ist.

"Datei" oder "Objekttyp"

Wenn Create New markiert wurde, werden die Anwendungsprogramme aufgeführt, in denen das neue Objekt erstellt werden kann. Wenn Aus Datei erstellen gewählt wurde, können Sie hier den Dateinamen eingeben.

Durchsuchen

Ermöglicht die Suche nach der gewünschten Datei.

Verknüpfen

Verknüpft ein Objekt von einem OLE-Server mit Ihrem Arbeitsblatt. Änderungen an einer verknüpften Grafik wirken sich sowohl auf die Kopie in Mathcad als auch auf das Original aus. Diese Option ist nur verfügbar, wenn zuvor Aus Datei erstellen gewählt wurde.

Als Symbol

Zeigt das Objekt als Symbol an.


Dialogfeld "Verweis einfügen"

Im Dialogfeld Verweis einfügen finden Sie die folgenden Optionen und Schaltflächen:

Verweis auf Datei einfügen

Geben Sie hier den Namen der Datei ein, auf die verwiesen werden soll. Dabei muss es sich um ein Arbeitsblatt handeln, das entweder auf einem Ihrer Laufwerke oder im Internet gespeichert ist. Um z. B. auf eine Datei namens CONFORM.MCD zu verweisen, die sich im Mathcad-Ordner befindet, müssen Sie Folgendes eingeben:

c:\Programme\mathsoft\conform.mcd

Für einen Verweis auf eine Datei, die im World Wide Web gespeichert ist, können Sie z. B. Folgendes eingeben:

http://www.mathsoft.com/coeffs.mcd

Relativen Pfad für Verweis verwenden

Mit dieser Option sorgen Sie dafür, dass die Angabe des Speicherortes der Datei, auf die verwiesen wird, relativ zum Mathcad-Arbeitsblatt erfolgt, das den Verweis enthält. Auf diese Weise bleibt der Verweis selbst dann gültig, wenn Sie die Datei, auf die verwiesen wird, und das Haupt-Arbeitsblatt an einen anderen Ort verschieben, ohne dabei die relative Verzeichnisstruktur zwischen beiden Dateien zu beeinträchtigen.

Damit Sie einen relativen Pfad angeben können, müssen sich die beiden Arbeitsblätter auf demselben lokalen Laufwerk bzw. demselben Netzlaufwerk befinden.

Wenn Sie einen relativen Pfad angeben, kann es vorkommen, dass er als absoluter Pfad angezeigt wird. Mathcad arbeitet intern trotzdem mit dem relativen Pfad. Wenn Sie die Dateien verschieben, ändert sich der angezeigte Pfad entsprechend.


Dialogfeld "Einheit einfügen"

Im Dialogfeld Einheit einfügen finden Sie die folgenden Optionen und Schaltflächen:

Dimension

Mit dieser Option können Sie festlegen, welche Einheiten in der Liste der Einheiten erscheinen sollen. Auf diese Weise werden in der Liste der Einheiten nur die Einheiten angezeigt, die die entsprechenden Dimensionen haben. Eine vollständige Liste aller Einheiten wird angezeigt, wenn Sie die Option Dimensionslos am Anfang der Liste wählen.

Wenn Sie auf ein numerisches Ergebnis klicken, wird für dieses Ergebnis automatisch die Dimension festgelegt, die ihm entspricht.

System

Zeigt das Standard-Einheitensystem an. Das Einheitensystem können Sie ändern, indem Sie den Befehl Arbeitsblattoptionen im Menü Extras wählen und auf die Registerkarte "Einheitensystem" klicken.

Einheit

Zeigt eine Liste der Einheiten an, die für die ausgewählte Dimension verfügbar sind. Wenn Sie sich die Liste aller Einheiten anzeigen lassen möchten, gehen Sie mithilfe der Bildlaufleiste an den Anfang der Liste auf der linken Seite, und wählen Sie dort die Option Dimensionslos aus.

Durch Doppelklicken auf eine Einheit wird diese in Ihr Arbeitsblatt eingefügt.

Einfügen

Fügt die ausgewählte Einheit in Ihr Arbeitsblatt ein.


Einfügen einer Leerzeile

Zum Einfügen einer Leerzeile gehen Sie wie folgt vor:

  1. Klicken Sie an eine leere Stelle, über der Sie eine Leerzeile einfügen möchten. Es erscheint ein Fadenkreuz.

  2. Drücken Sie die Eingabetaste so oft, bis die gewünschte Anzahl an Leerzeilen eingefügt ist.

Sie können eine beliebige Anzahl leerer Zeilen einfügen, indem Sie an eine leere Stelle klicken und dann mit der rechten Maustaste klicken, um ein Popup-Dialogfeld anzuzeigen. Wählen Sie Zeilen einfügen, und geben Sie dann die gewünschte Anzahl einzufügender Zeilen an.


Einfügen von Grafikobjekten

Zum Einfügen einer neuen Grafik als Objekt in ein Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Wählen Sie Objekt aus dem Menü Einfügen. Das Dialogfeld "Objekt einfügen" wird geöffnet.

  2. Wählen Sie die Anwendung aus, in der es erstellt werden soll, und klicken Sie auf OK.

  3. Die Grafik wird als eingebettetes Objekt eingefügt.

Zum Einfügen einer Grafik, die in einer vorhandenen Datei gespeichert ist, gehen Sie folgendermaßen vor:

  1. Wählen Sie Objekt aus dem Menü Einfügen. Das Dialogfeld "Objekt einfügen" wird geöffnet.

  2. Klicken Sie auf Aus Datei erstellen, und legen Sie den Pfad zu der Datei fest, die die Grafik enthält.

  3. Klicken Sie auf Verknüpfen, wenn ein verknüpftes Objekt erstellt werden soll. Andernfalls wird das Objekt eingebettet.


Einfügen von Spalten

Zum Einfügen einer oder mehrerer Spalten in eine Matrix gehen Sie wie folgt vor:

  1. Klicken Sie auf ein Element in der ersten Spalte, die Sie löschen möchten.

  2. Wählen Sie Matrix aus dem Menü Einfügen. Es wird ein Dialogfeld geöffnet.

  3. Legen Sie die Anzahl der einzufügenden Spalten fest.

  4. Klicken Sie auf Einfügen.

Rechts neben der Spalte, die das ausgewählte Element enthält, wird die angegebene Zahl von Spalten mit leeren Platzhaltern angezeigt.


Einfügen griechischer Buchstaben

Zum Einfügen griechischer Buchstaben gehen Sie wie folgt vor:

  1. Geben Sie die lateinische Entsprechung aus der unten stehenden Tabelle ein.

  2. Setzen Sie die Einfügemarke direkt hinter den Buchstaben, der durch einen griechischen Buchstaben ersetzt werden soll.

  3. Drücken Sie Strg+G.

Mit Strg+G können Sie zwischen griechischen und lateinischen Buchstaben umschalten. Wenn Sie die Einfügemarke direkt hinter einen griechischen Buchstaben setzen und Strg+G drücken, wird der griechische Buchstabe durch den entsprechenden lateinischen ersetzt.


Einfügen von Mathcad- oder Excel-Objekten

Wenn Sie Berechnungen oder Tabellen aus Excel in das Mathcad-Arbeitsblatt aufnehmen möchten, haben Sie folgende Möglichkeiten:

  • Einfügen eines Objekts mit den Menübefehlen. Befolgen Sie die Anweisungen zum Einfügen eines Grafikobjekts.

  • Einfügen einer Excel-Komponente mit den Menübefehlen. Befolgen Sie die Anweisungen zum Einfügen einer Komponente. Sie können auch eine Komponente für die Datendateieingabe zum Lesen des Excel-Inhalts verwenden.

  • Kopieren und Einfügen. Befolgen Sie die Anweisungen zum Importieren einer Grafikbilddatei aus der Zwischenablage.

  • Klicken und Ziehen. Befolgen Sie die Anweisungen zum Importieren von Grafiken durch Klicken und Ziehen.

Sollen umgekehrt Berechnungen oder Graphen aus Mathcad in einem Excel-Arbeitsblatt erscheinen, haben Sie folgende Möglichkeiten:

  • Einfügen eines Objekts mit den Menübefehlen. Wählen Sie in Excel Objekt aus dem Menü Einfügen und dann Mathcad aus der Liste der Anwendungen.

  • Kopieren und Einfügen. Markieren Sie Mathcad-Bereiche, und wählen Sie dann in Excel Einfügen im Menü Bearbeiten.

  • Klicken und Ziehen. Markieren Sie Mathcad-Bereiche, und befolgen Sie dann die Anweisungen zum Importieren von Grafiken durch Klicken und Ziehen.


Einfügen von Zeilen

Zum Einfügen einer oder mehrerer Zeilen in einen Vektor bzw. eine Matrix gehen Sie wie folgt vor:

  1. Klicken Sie auf ein Element in der Zeile, unter der Sie weitere Zeilen einfügen möchten.

  2. Wählen Sie Matrix aus dem Menü Einfügen. Es wird ein Dialogfeld geöffnet.

  3. Legen Sie die Anzahl der einzufügenden Zeilen fest.

  4. Klicken Sie auf Einfügen.

Es werden eine oder mehrere Zeilen mit leeren Platzhaltern unter der Zeile angezeigt, in der das ausgewählte Element enthalten ist.


Einfügemarke

Die Einfügemarke wird durch eine senkrechte Linie dargestellt, an der die Zeichen oder Symbole erscheinen, die Sie eingeben. Die Einfügung erfolgt links von der senkrechten Linie. Mit den Tasten [image] und [image] können Sie die Einfügemarke verschieben. Sie können auch auf die Stelle klicken, an der Sie die Einfügemarke wünschen.


Diese ganze Zahl ist zu groß.

Dieser Wert ist für die Verarbeitung zu groß. Wenn Sie weitere Informationen beim Arbeiten mit einer vordefinierten Funktion benötigen, klicken Sie auf den Funktionsnamen und drücken F1.


Diese ganze Zahl ist zu klein.

Dieser Wert ist für die Verarbeitung zu klein. Wenn Sie weitere Informationen beim Arbeiten mit einer vordefinierten Funktion benötigen, klicken Sie auf den Funktionsnamen und drücken F1.


Integrieren von Mathcad und Excel

Integrieren von Excel in ein Mathcad-Arbeitsblatt

Wenn Sie Excel-Funktionen auch in Mathcad nutzen möchten, können Sie die Excel-Komponente in das Mathcad-Arbeitsblatt einfügen. Über die Excel-Komponente können Sie Daten mit Microsoft Excel austauschen und dabei auch die Funktionen von Excel nutzen. Voraussetzung hierfür ist, dass Microsoft Excel auf Ihrem System installiert ist. Weitere Informationen finden Sie in den Anweisungen zur Arbeit mit der Excel-Komponente.

Integrieren von Mathcad in ein Excel-Arbeitsblatt

Wenn Sie Mathcad-Funktionen auch in Excel nutzen möchten, können Sie Mathcad als OLE-Server verwenden. Hierzu müssen Sie in Excel ein Basic-Programm (Visual Basic 5.0 oder höher) schreiben. Mit dem Programm definieren Sie Variablen in Mathcad-Dokumentobjekten und rufen diese Variablen ab. So können Sie folgende Schritte durchführen:

  1. Dynamisches Übertragen von Daten aus Excel an Mathcad

  2. Verwenden von Mathcad für die Durchführung von Berechnungen oder anderen Manipulationen an Daten

  3. Übertragen der Ergebnisse an Excel


Operator "Integration"

Bestimmtes Integral

Tastaturbefehl: &

Gibt das bestimmte Integral von f(x) von a bis b zurück.

Operanden:

  • f ist eine beliebige Funktion mit skalarem Wert, definiert über das geschlossene Intervall [a,b].

  • x ist die Variable für die Integration.

  • a und b müssen reelle Skalare sein; f kann einen komplexen Wert haben.

  • Falls a und b eine Dimension haben, muss diese bei beiden übereinstimmen.

Beispiel:

Das Beispiel zeigt zwar eine Funktion nur einer Variablen, f kann aber eine Funktion jeder beliebigen Anzahl von Variablen sein.

Wenn Doppel- oder Mehrfachintegrale ausgewertet werden sollen, müssen Sie & mehrmals drücken.

Hinweise zur Integration:

Standardmäßig wird der Operator "Integration" numerisch mit der Funktion Autom. Auswahl ausgewertet. Autom Auswahl wählt den für das Integral geeignetsten Algorithmus aus. Wenn Sie wissen wollen, welche Ergebnisse durch andere Algorithmen ausgegeben werden, setzen Sie die automatische Algorithmusauswahl außer Kraft, und wählen Sie selbst einen Algorithmus aus.

Siehe: Symbolische Integration.


Intellimath

Die IntelliMath-Funktionen in Mathcad helfen Ihnen dabei, Routineaufgaben und Standardoperationen schneller auszuführen. Zu den IntelliMath-Funktionen gehören:

  • Die Mathcad-Funktion Autom. Auswahl zur Lösung und Integration, die Ihre Aufgabenstellung analysiert und den jeweils am besten geeigneten Algorithmus auswählt.

  • Optimierung, die über die integrierten numerischen und symbolischen Verarbeitungsmodule die beste Lösung für ein mathematisches Problem sucht.

  • Die Möglichkeit, Einheiten während Ihrer Arbeit automatisch festzuhalten und umzurechnen.


Zinssatz

zsatz(nper, zrate, gw, [[zw], [typ], [schätzwert]]) Gibt den Zinssatz einer Kapitalanlage bzw. eines Darlehens pro Periode über eine angegebene Anzahl von Verzinsungsperioden bei regelmäßigen, konstanten Zahlungen und gegen Angabe eines aktuellen Werts der Anlage oder des Darlehens zurück.

Argumente:

nper ist die Gesamtzahl der jährlichen Verzinsungsperioden. nper ist eine positive Ganzzahl.

zrate ist die Zahlung, die pro Periode entrichtet oder eingenommen wird. Sie umfasst in der Regel Tilgungs- und Zinszahlungen, jedoch keine weiteren Abgaben und Gebühren.

gw ist der gegenwärtige Wert der Kapitalanlage.

zw (optional) ist der zukünftige Wert der Kapitalanlage. Falls keine Angabe gemacht wird, gilt zw = 0.

typ (optional) beträgt bei Zahlungen, die am Ende der Periode vorgenommen wurden, 0, bei Zahlungen zu Beginn der Periode 1. Falls keine Angabe gemacht wird, gilt typ = 0.

schätzwert (optional) ist ein numerischer Wert, der Ihrer Einschätzung nach der Antwort nahe kommt. Falls keine Angabe gemacht wird, gilt schätzwert = 0.01 (10 %).

Hinweise:

  • Zahlungen, die Sie leisten, zum Beispiel Einlagen in einem Sparkonto oder Rückzahlungen bei einem Darlehen, müssen als negative Zahlen eingegeben werden. Zahlungen, die Sie einnehmen, zum Beispiel Dividenden, müssen als positive Zahlen eingegeben werden.

  • Kommt zsatz nach 20 Iterationen zu keinem Ergebnis, das innerhalb von 1*10-7 Prozent liegt, wird eine Fehlermeldung ausgegeben. Versuchen Sie es in diesem Fall mit einem anderen Schätzwert erneut.

Beispiel:

Berechnung des monatlichen Zinssatzes für ein Darlehen von EUR 8000 bei einer Laufzeit von fünf Jahren und monatlichen Zahlungen von EUR 150:

zsatz((12*5), -150, 8000) = 0.395 %


Zinssatz pro Periode

fzins(nper, gw, zw) Übergibt den festen Zinssatz pro Periode, der für eine Kapitalanlage zum gegenwärtigen Wert erforderlich ist, um einen angegebenen zukünftigen Wert nach einer Anzahl von Verzinsungsperioden zu erzielen.

Argumente:

nper ist die Gesamtzahl der Verzinsungsperioden. nper ist eine positive Ganzzahl. nper [image] 1.

gw ist der gegenwärtige Wert der Kapitalanlage. gw [image] 0.

zw ist der zukünftige Wert der Kapitalanlage. zw > 0.


Interner Zinsfuß

izf(v, [schätzwert]) Übergibt den internen Zinsfuß für eine Reihe regelmäßiger Zahlungen.

Argumente:

v ist ein Vektor für regelmäßig anfallende Zahlungen. v muss mindestens einen positiven und einen negativen Wert enthalten.

schätzwert (optional) ist ein numerischer Wert, der Ihrer Einschätzung nach der Antwort nahe kommt. Falls keine Angabe gemacht wird, gilt schätzwert = 0.01 (10 %).

Hinweise:

  • Zahlungen, die Sie leisten, zum Beispiel Einlagen in einem Sparkonto oder Rückzahlungen bei einem Darlehen, müssen als negative Zahlen eingegeben werden. Zahlungen, die Sie einnehmen, zum Beispiel Dividenden, müssen als positive Zahlen eingegeben werden.

  • Kommt izf nach 20 Iterationen zu keinem Ergebnis, das innerhalb von 1*10-5 Prozent liegt, wird eine Fehlermeldung ausgegeben. Versuchen Sie es in diesem Fall mit einem anderen Schätzwert erneut.

Beispiel:

Sie eröffnen ein Geschäft, das schätzungsweise EUR 50000 Startkapital erfordert und in den nächsten fünf Jahren vermutlich folgende Nettoeinkünfte erzielt: EUR 13000, EUR 14000, EUR 15000, EUR 18000 und EUR 20000. Zum Berechnen des internen Zinsfußes nach fünf Jahren gehen Sie wie folgt vor:


Funktion "interp"

Die Funktion "interp" wird in verschiedenen Anwendungen verwendet:

Kubische Spline-Interpolation

Multivariable kubische Spline-Interpolation

Polynomregression

Multivariable Polynomregression


Interpolation

Um den Wert für ein bestimmtes x zu finden, sucht das Arbeitsblatt die beiden Punkte, zwischen denen der Wert liegt, und gibt den entsprechenden y-Wert auf dem kubischen Abschnitt zwischen dem Punktepaar zurück.

Bei x-Werten vor dem ersten bekannten Datenpunkt extrapoliert das Arbeitsblatt den kubischen Abschnitt zwischen den ersten beiden Datenpunkten.

Bei x-Werten nach dem letzten bekannten Datenpunkt extrapoliert das Arbeitsblatt den kubischen Abschnitt zwischen den letzten beiden Datenpunkten.


Interpolations- und Prognosefunktionen

linterp(vx, vy, x)

Interpolierter Wert bei x, wenn die Punkte von vx und vy mit geraden Linien verbunden sind.

lspline(vx, vy)

Kubische Spline-Interpolation mit linearen Endbedingungen. Gibt den Vektor vs für die Verwendung mit der unten aufgeführten interp-Funktion zurück.

pspline(vx, vy)

Kubische Spline-Interpolation mit parabolischen Endbedingungen. Gibt den Vektor vs für die Verwendung mit der unten aufgeführten interp-Funktion zurück.

kspline(vx, vy)

Kubische Spline-Interpolation mit kubischen Endbedingungen. Gibt den Vektor vs für die Verwendung mit der unten aufgeführten interp-Funktion zurück.

interp(vs, vx, vy, x)

Gibt den interpolierten Wert von x durch Spline-Interpolation zurück. vs ist der Vektor, der durch lspline, pspline, kspline oder bspline zurückgegeben wird.


Unterbrechen der Berechnung

Zum Unterbrechen einer Berechnung gehen Sie wie folgt vor:

  • Drücken Sie Esc.

Es wird eine Fehlermeldung angezeigt, in der die unterbrochene Gleichung angegeben wird.

Zum Wiederaufnehmen der Berechnung gehen Sie wie folgt vor:

  • Wählen Sie Berechnen im Menü Extras.


Ungültige Argumente

Der symbolische Prozessor kann die angeforderte Operation für die vorgegebenen Argumente nicht durchführen. Diese Fehlermeldung erscheint z. B. dann, wenn Sie einem Feld eine Skalarfunktion zuweisen, ohne den Operator "Vektorisieren" zu verwenden, und den Befehl Vereinfachen aus dem Menü Symbolik wählen.


Ungültiger Entwicklungspunkt

Mathcad kann den Ausdruck um den von Ihnen angegebenen Punkt nicht erweitern. Stellen Sie sicher, dass das Schlüsselwort reihe für die symbolische Reihenentwicklung in Mathcad richtig verwendet wird.


Ungültige Matrixdimension.

Ungültige Matrixdimension. Die Anzahl der Zeilen ist geringer als die Anzahl der Spalten.

Das Argument der Funktion svd muss ein m x n großes Feld sein, wobei m [image] n ist.


Bereichsfehler

Bei der Suche nach einer numerischen Lösung für eine Gleichung versuchte der symbolische Prozessor, eine der vordefinierten Funktionen an einem Punkt auszuwerten, der sich außerhalb der entsprechenden Domäne befindet.


Inverse kumulative Wahrscheinlichkeitsverteilung

Diese Funktionen haben eine Wahrscheinlichkeit als Argument und geben einen Wert zurück, der angibt, dass die Wahrscheinlichkeit, mit der eine Zufallsvariable kleiner gleich diesem Wert ist, der als Argument angegebenen Wahrscheinlichkeit entspricht.


Inverse Fourier-Transformation komplexer Daten (icfft-Funktion)

Inverse Fourier-Transformation komplexer Daten

icfft(A) Gibt die inverse Fourier-Transformation entsprechend cfft zurück, erneut normalisiert durch 1/Quadratwurzel(N).

ICFFT(A) Gibt die inverse Fourier-Transformation analog zu CFFT zurück.

Argumente:

A kann sowohl ein Vektor als auch eine Matrix sein.


Inverse Fourier-Transformation

Zur Auswertung der inversen Fourier-Transformation einer Funktion gehen Sie wie folgt vor:

  1. Geben Sie den zu transformierenden Ausdruck ein.

  2. Klicken Sie auf die Transformationsvariable.

  3. Wählen Sie Transformation / Fourier invers aus dem Menü Symbolik.

Mathcad gibt bei inversen Fourier-Transformationen eine Funktion in der Variablen t zurück. Wenn der zu transformierende Ausdruck bereits ein t enthält, wird stattdessen eine Funktion in der Variablen tt zurückgegeben. Mit dem Befehl Substitute for Variable können Sie t durch eine andere Variable oder einen anderen Ausdruck ersetzen.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle das Schlüsselwort "invfourier" sowie die aktive symbolische Auswertung.


Inverse Fourier-Transformation reeller Daten (ifft-Funktion)

Inverse Fourier-Transformation reeller Daten

ifft(u) Gibt die inverse Fourier-Transformation analog zu fft zurück. Das Ergebnis ist ein aus [image] -Elementen bestehender Vektor, dessen k-tes Element gegeben ist durch:

Dabei gibt n die Anzahl von Elementen in v an, und i ist die imaginäre Einheit.

IFFT(u) Gibt die inverse Fourier-Transformation analog zu FFT zurück. Das Ergebnis ist ein aus [image] -Elementen bestehender Vektor, dessen k-tes Element gegeben ist durch:

Argumente:

  • u ist ein Vektor mit [image] -Elementen (m>2).

Hinweise:

  • Benutzen Sie diese Funktion nur, wenn die Ausgangsdaten rein reell sind. Bei komplexen Ausgangsdaten ist stattdessen icfft/ICFFT zu verwenden.

  • Diese Funktion arbeitet mit einem hocheffizienten Algorithmus für die schnelle Fourier-Transformation. Damit dies möglich ist, muss der mit ifft verwendete Vektor [image] -Elemente haben. Handelt es sich bei den Vektoren um komplexe Werte oder verfügen die Vektoren über eine andere Anzahl von Elementen, verwenden Sie stattdessen icfft.

  • Soll eine zweidimensionale Fourier-Transformation ausgeführt werden, ist stattdessen ebenfalls icfft zu verwenden.

  • Wenn Sie fft verwenden, um zum Frequenzbereich zu gelangen, können Sie nur mit ifft zum Zeitbereich zurückkehren.


Inverse hyperbolische Funktionen

asinh(z) acoth(z)

acosh(z) acsch(z)

atanh(z) asech(z)

Argumente:

z muss ein Skalar sein.

z muss dimensionslos sein.

Die zurückgegebenen Werte stammen aus dem Hauptzweig dieser Funktionen.


Inverse Laplace-Transformation

Zur Auswertung der inversen Laplace-Transformation einer Funktion gehen Sie wie folgt vor:

  • Geben Sie den zu transformierenden Ausdruck ein.

  • Klicken Sie auf die Transformationsvariable.

  • Wählen Sie Transformation / Laplace invers im Menü Symbolik.

Mathcad gibt bei inversen Laplace-Transformationen eine Funktion in der Variablen t zurück. Wenn der zu transformierende Ausdruck bereits ein t enthält, wird stattdessen eine Funktion in der Variablen tt zurückgegeben. Mit dem Befehl Substitute for Variable können Sie t durch eine andere Variable oder einen anderen Ausdruck ersetzen.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle das Schlüsselwort "invlaplace" sowie die aktive symbolische Auswertung.


Operator "Inverse"

Inverse

Tastaturbefehl: 1/

Gibt die Inverse von x zurück. Wenn x=0 wird eine Fehlermeldung angezeigt, die darauf hinweist, dass eine Singularität vorliegt.

Operand:

x muss ungleich null sein.


Inverse trigonometrische Funktionen

asin(z) acsc(z)

acos(z) asec(z)

atan(z) acot(z)

atan2(x,y)

Argumente:

z muss ein Skalar sein.

z muss dimensionslos sein.

x und y sind Skalare.

Hinweise:

  • Die Werte werden in Radiant angegeben.

  • atan2(x,y) nimmt nur reelle Argumente an und gibt einen Winkel (in Radiant zwischen -pi und pi, aber nicht -pi) von der x-Achse zu einer Linie zurück, die den Ursprung (0,0) und den Punkt (x,y) enthält.

  • Die zurückgegebenen Werte stammen aus dem Hauptzweig dieser Funktionen.


Inverse trigonometrische Funktionen

Diese Funktionen können mit den reziproken Werten und internen Funktionen wie ACOS, ASIN usw. berechnet werden.

Zum Beispiel können Sie Folgendes definieren:

ARCSEC(x) := ASEC(1/X)


Inverse z-Transformation

Zur Auswertung der inversen z-Transformation einer Funktion gehen Sie wie folgt vor:

  1. Geben Sie den zu transformierenden Ausdruck ein.

  2. Klicken Sie auf die Transformationsvariable.

  3. Wählen Sie Transformation / Z invers im Menü Symbolik.

Mathcad gibt bei inversen z-Transformationen eine Funktion in der Variablen n zurück. Wenn der zu transformierende Ausdruck bereits ein n enthält, wird stattdessen eine Funktion in der Variablen nn zurückgegeben. Mit dem Befehl Variable / Ersetzen können Sie n durch eine andere Variable oder einen Ausdruck ersetzen.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle das Schlüsselwort "invztrans" sowie die aktive symbolische Auswertung.


Invertieren eines Bildes


Funktion "IsArray"

IsArray(x) Gibt 1 zurück, wenn x eine Matrix oder ein Vektor ist. Andernfalls wird 0 zurückgegeben.

Argumente:

x ist ein Wert, ein Feld oder eine Zeichenfolge.

Beispiel:

Diese Funktion eignet sich am besten zur Verwendung in einer Bedingungsanweisung in einem Programm.


Funktion "IsScalar"

IsScalar(x) Gibt 1 zurück, wenn x ein reeller oder komplexer Skalar ist. Andernfalls wird 0 zurückgegeben.

Argumente:

x ist ein Wert, ein Feld oder eine Zeichenfolge.

Beispiel:

Diese Funktion eignet sich am besten zur Verwendung in einer Bedingungsanweisung in einem Programm.


Funktion "IsString"

IsString(x) Gibt 1 zurück, wenn x eine Zeichenfolge ist. Andernfalls wird 0 zurückgegeben.

Argumente:

x ist ein Wert, ein Feld oder eine Zeichenfolge.

Beispiel:

Diese Funktion eignet sich am besten zur Verwendung in einer Bedingungsanweisung in einem Programm.


Keine Konvergenz gegen eine Lösung

Die Integrandfunktion weist möglicherweise eine Singularität auf, oder das Integral ist unendlich.

Ergebnisse mit Integralen, Ableitungen und den Funktionen wurzel, suchen oder minfehl erfordern Wiederholung. Falls nach vielen Wiederholungen aufeinander folgende Schätzungen weiterhin um mehr als die erforderliche Toleranz abweichen, wird diese Fehlermeldung angezeigt.

Versuchen Sie, eine größere TOL festzulegen. Wenn Sie mit den Funktionen wurzel, suchen oder minfehl arbeiten, können Sie es auch mit einem anderen Schätzwert versuchen.


Iteration über einen Wertebereich

Jede einmal durchführbare Berechnung ist auch über einen Bereich von Werten möglich. Nehmen wir beispielsweise an, Sie möchten eine Liste von x- und y-Werten für Punkte auf der Kreiskurve "r=cos(q) + 1" erstellen. Die Grundidee ist hier:

  • q soll Werte zwischen 0 und 2p annehmen. Definieren Sie q als Bereichsvariable oder als Vektor.

  • Für jedes q ergibt sich das entsprechende r aus "r=cos(q) + 1".

  • Für jedes r und q gilt, dass x und y durch die Gleichungen "x=r*cos(q)" und "y=r*sin(q)" bestimmt werden.

Dies kann mit Funktionen oder durch Definition von Vektoren erreicht werden.

Verwenden von Funktionen: | Verwenden von Vektoren:


Jacobi-Polynom-Funktion

Jac(n,a,b,x) Gibt den Wert der Jacobi-Polynom-Funktion vom Grad n bei x mit den Parametern a und b zurück.

Argumente:

n ist eine nichtnegative ganze Zahl.

a und b sind reelle Skalare größer -1.

x ist ein reeller Skalar.

Das Jacobi-Polynom ist eine Lösung der folgenden Differentialgleichung:

Beachten Sie, dass das Tschebyscheff- und das Legendre-Polynom Sonderfälle des Jacobi-Polynoms sind.


Verbinden von Feldern

erweitern(A, B, C, ...) Gibt ein Feld zurück, das durch die Reihung von A, B, C, ... von links nach rechts erstellt wird.

stapeln(A, B, C, ...) Gibt ein Feld zurück, das durch die Reihung von A, B, C, ... von oben nach unten erstellt wird.

Argumente:

A, B, C, ... können jeweils Felder mit der gleichen Zeilenanzahl für erweitern oder mit der gleichen Spaltenanzahl für stapeln sein.

A, B, C, ... können Skalare und einzeilige Felder für erweitern oder Skalare und einzeilige Felder für stapeln sein.


JScript

Microsoft JScript ist ein schneller, portabler und leichter Interpreter für den Einsatz in Anwendungen, die mit ActiveX-Steuerelementen, OLE-Automatisierungsservern und Java-Applets arbeiten. JScript ist direkt mit VBScript (nicht jedoch mit Java) vergleichbar. Wie VBScript ist JScript ein reiner Interpreter, der Quellcode verarbeitet und nicht zur Erstellung von Einzel-Applets verwendet werden kann.


Schlüsselwort "annehmen"

Zur Berechnung eines Ausdrucks, der auf bestimmten Annahmen beruht, verwenden Sie das Schlüsselwort annehmen.

  • Soll Mathcad annehmen, dass eine Variable reell ist, geben Sie nach dem Schlüsselwort var=reell ein, wobei var für die Variable steht, die Sie eingeben.

  • Soll Mathcad annehmen, dass eine Variable reell ist und zwischen den reellen Zahlen a und b liegt, geben Sie nach dem Schlüsselwort var=RealRange(a,b) ein, wobei var für die Variable steht, die Sie eingeben.

Weitere Schlüsselwörter...


Schlüsselwort "koeff"

Um die Koeffizienten eines Polynoms zu suchen, verwenden Sie das Schlüsselwort koeff:

  1. Geben Sie den Ausdruck ein, dessen Koeffizienten Sie finden möchten.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort koeff ein.

  4. Geben Sie ein Komma und dann die Variable bzw. Funktion ein, für die Ihr Ausdruck als Polynom gelten soll.

  5. Drücken Sie die Eingabetaste, um sich das Ergebnis anzeigen zu lassen.

Weitere Schlüsselwörter...


Schlüsselwort "sammeln"

Sie können einen Ausdruck vereinfachen, indem Sie eine Summe von Termen als Polynom einer bestimmten Variablen angeben:

  1. Geben Sie den zu vereinfachenden Ausdruck ein.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort sammeln ein.

  4. Geben Sie ein Komma und danach die Variable bzw. den Ausdruck ein, nach der bzw. dem zusammengefasst werden soll.

  5. Drücken Sie die Eingabetaste.

Dadurch wird die Summe zu einem Polynom in der Variablen bzw. Funktion umgeformt.

Weitere Schlüsselwörter...


Schlüsselwort "komplex"

Im Normalfall gibt Mathcad symbolische Ergebnisse so weit vereinfacht wie möglich zurück. Zuweilen, vor allem bei der Arbeit mit komplexen Zahlen, ist es jedoch wünschenswert, die Ergebnisse in ihren jeweiligen Real- und Imaginärteil zerlegt zu sehen. Verwenden Sie das Schlüsselwort komplex, um Mathcad zur Ausgabe der Ergebnisse in der Form (a+i*b) anzuweisen, soweit dies möglich ist.

Weitere Schlüsselwörter...


Schlüsselwort "konvert"

Zum Umformen einer Gleichung in einen Teilbruch können Sie das Schlüsselwort konvert zusammen mit teilbruch verwenden:

  1. Geben Sie den Ausdruck ein, der umgewandelt werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie konvert,teilbruch ein.

  4. Geben Sie ein Komma und dann die Variable im Nenner des Ausdrucks ein, der umgeformt werden soll.

  5. Drücken Sie die Eingabetaste, um sich das Ergebnis anzeigen zu lassen.

Weitere Schlüsselwörter...


Schlüsselwort "entwickeln"

Verwenden Sie das Schlüsselwort entwickeln, um alle Potenzen und Produkte von Summen im markierten Ausdruck zu entwickeln. Soll ein Ausdruck in einer bestimmten Variablen entwickelt werden, geben Sie nach dem Schlüsselwort "entwickeln" ein Komma und dann die Variable ein.

Sie können außerdem einen Ausdruck entwickeln, indem Sie den Befehl Erweitern im Menü Symbolik verwenden.

Weitere Schlüsselwörter...


Schlüsselwort "faktor"

Verwenden Sie das Schlüsselwort faktor, wenn Sie einen Ausdruck in ein Produkt transformieren möchten. Auf diese Weise können Sie die folgenden Transformationen festlegen:

  • Polynom in ein Produkt aus Polynomen

  • ganze Zahl in ein Produkt aus Primzahlen

  • Summe aus rationalen Ausdrücken in einen einzigen Bruch

Soll ein Radikal faktorisiert werden, geben Sie nach dem Schlüsselwort faktor ein Komma und dann ein Radikal oder mehrere, durch Kommas getrennte Radikale ein.

Weitere Schlüsselwörter...


Schlüsselwort "gleit"

Verwenden Sie das Schlüsselwort gleit, wenn Mathcad statt eines symbolischen Ergebnisses nach Möglichkeit eine Gleitkommazahl ausgeben soll.

Durch die Angabe einer ganzen Zahl hinter dem Schlüsselwort gleit können Sie festlegen, wie viele Stellen der Gleitkommazahl angezeigt werden sollen.

Weitere Schlüsselwörter...


Schlüsselwort "fourier"

Verwenden Sie das Schlüsselwort fourier, wenn die inverse Z-Transformation einer Funktion ausgewertet werden soll:

  1. Geben Sie die Funktion ein, die ausgewertet werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort fourier ein.

  4. Geben Sie ein Komma und dann die Variable ein, in der die Transformation erfolgen soll.

  5. Drücken Sie die Eingabetaste.

Das Schlüsselwort fourier gibt eine Funktion in der Variable w aus. Wenn der zu transformierende Ausdruck bereits ein w enthält, wird stattdessen eine Funktion in der Variable ww zurückgegeben, um jegliche Zweideutigkeit zu vermeiden. Mit dem Schlüsselwort Ersetzen ersetzen Sie w durch eine andere Variable oder einen anderen Ausdruck.

Weitere Schlüsselwörter...


Schlüsselwort "invfourier"

Verwenden Sie das Schlüsselwort invfourier, wenn die inverse Z-Transformation einer Funktion ausgewertet werden soll:

  1. Geben Sie die Funktion ein, die ausgewertet werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort invfourier ein.

  4. Geben Sie ein Komma und dann die Variable ein, in der die Transformation erfolgen soll.

  5. Drücken Sie die Eingabetaste.

Das Schlüsselwort invfourier gibt eine Funktion in der Variable t aus. Wenn der zu transformierende Ausdruck bereits ein t enthält, wird stattdessen eine Funktion in der Variable tt zurückgegeben. Mit dem Schlüsselwort Ersetzen können Sie t durch eine andere Variable oder einen Ausdruck ersetzen.

Weitere Schlüsselwörter...


Schlüsselwort "invlaplace"

Verwenden Sie das Schlüsselwort invlaplace, wenn die inverse Laplace-Transformation einer Funktion ausgewertet werden soll:

  1. Geben Sie die Funktion ein, die ausgewertet werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort invlaplace ein.

  4. Geben Sie ein Komma und dann die Variable ein, in der die Transformation erfolgen soll.

  5. Drücken Sie die Eingabetaste.

Das Schlüsselwort invflaplace gibt eine Funktion in der Variable t aus. Wenn der zu transformierende Ausdruck bereits ein t enthält, wird stattdessen eine Funktion in der Variable tt zurückgegeben. Mit dem Schlüsselwort Ersetzen können Sie t durch eine andere Variable oder einen Ausdruck ersetzen.

Weitere Schlüsselwörter...


Schlüsselwort "invztrans"

Verwenden Sie das Schlüsselwort invztrans, wenn die inverse Z-Transformation einer Funktion ausgewertet werden soll:

  1. Geben Sie die Funktion ein, die ausgewertet werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort invztrans ein.

  4. Geben Sie ein Komma und dann die Variable ein, in der die Transformation erfolgen soll.

  5. Drücken Sie die Eingabetaste.

Das Schlüsselwort invztrans gibt eine Funktion in der Variable t aus. Wenn der zu transformierende Ausdruck bereits ein n enthält, wird stattdessen eine Funktion in der Variable nn zurückgegeben. Mit dem Schlüsselwort Ersetzen können Sie n durch eine andere Variable oder einen Ausdruck ersetzen.

Weitere Schlüsselwörter...


Schlüsselwort "laplace"

Verwenden Sie das Schlüsselwort laplace, wenn die Laplace-Transformation einer Funktion ausgewertet werden soll:

  1. Geben Sie die Funktion ein, die ausgewertet werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort laplace ein.

  4. Geben Sie ein Komma und dann die Variable ein, in der die Transformation erfolgen soll.

  5. Drücken Sie die Eingabetaste.

Das Schlüsselwort laplace gibt eine Funktion in der Variable s aus. Wenn der zu transformierende Ausdruck bereits ein s enthält, wird stattdessen eine Funktion in der Variable ss zurückgegeben, um jegliche Zweideutigkeit zu vermeiden. Mit dem Schlüsselwort Ersetzen können Sie s durch eine andere Variable oder einen Ausdruck ersetzen.

Weitere Schlüsselwörter...


Schlüsselwort "reihe"

Verwenden Sie das Schlüsselwort reihe, gefolgt von einer Variablen, wenn ein Ausdruck in eine Reihe entwickelt werden soll, falls diese Variable den Wert Null annimmt.

Mit dem Schlüsselwort reihe werden bei Funktionen, die bei 0 analytisch sind, Taylorsche Reihen (Reihen in nichtnegativen Potenzen der Variable) und bei Funktionen, die bei 0 einen Pol endlicher Ordnung haben, Laurentsche Reihen entwickelt. Für Reihenentwicklungen um einen anderen Punkt als Null sind logische Gleichheitszeichen zu verwenden.

Beispiel:

x+y reihe,x=2

führt eine Reihenentwicklung um den Punkt x=2 durch.

Hinweise:

  • Mit dem Schlüsselwort reihe wird eine Reihe 6. Ordnung entwickelt. Soll eine andere Ordnung für die Reihenentwicklung festgelegt werden, muss der Reihenentwicklungsvariable ein Komma und eine ganze Zahl (zur Angabe der Ordnung) nachfolgen. Bei der Ordnung handelt es sich um die Ordnung des Fehlerterms in der Reihenentwicklung. Wenn Mathcad z. B. sin(x) in eine Reihe in x entwickelt, gibt es eine Reihenentwicklung der Sinusfunktion in Potenzen von x zurück, wobei die höchste Potenz x5 ist. Der Fehler ist also O(x6).

  • Soll eine Reihe um mehr als eine Variable entwickelt werden, fügen Sie nach dem Schlüsselwort reihe ein Komma und die Variablen ein, die jeweils voneinander durch ein Komma getrennt sein müssen.

  • Durch Nutzung der Annäherungen, die Sie vom symbolischen Prozessor erhalten, kann es passieren, dass die Taylorsche Reihe bei einer Funktion nur in einem kleinen Intervall um den Mittelpunkt herum konvergiert. Hinzu kommt, dass Funktionen wie sin oder exp Reihen mit unbegrenzt vielen Termen haben, während die von Mathcad zurückgegebenen Polynome nur über einige wenige Terme verfügen (die genaue Anzahl hängt von der von Ihnen festgelegten Ordnung ab). Daher gilt für Annäherungen einer Funktion durch das von Mathcad zurückgegebene Polynom, dass die Annäherung in der Nähe des Mittelpunkts ausreichend genau ist, mit steigender Entfernung vom Mittelpunkt aber immer ungenauer werden kann.

  • Eine andere Möglichkeit, eine Reihe zu entwickeln, besteht darin, den Ausdruck einzugeben und dann auf die Variable zu klicken, für die Sie eine Reihenentwicklung finden möchten. Wählen Sie dann aus dem Menü Symbolik die OptionsfolgeVariable / Reihenentwicklung. In dem daraufhin erscheinenden Dialogfeld werden Sie aufgefordert, die Ordnung der Reihe festzulegen. Dieser Befehl steht nur für Reihen in einer einzelnen Variable zur Verfügung; alle anderen Variablen des Ausdrucks werden als Konstanten behandelt. Die Ergebnisse enthalten darüber hinaus den Fehler-Term, dargestellt mittels O-Notation. Löschen Sie diesen Fehler-Term, bevor Sie diese Reihe für weitere Berechnungen verwenden.

Weitere Schlüsselwörter...


Schlüsselwort "vereinfachen"

Verwenden Sie das Schlüsselwort vereinfachen, um eine einfache algebraische Vereinfachung durchzuführen und trigonometrische und inverse Funktionsidentität anzuwenden.

  • Wenn Sie einen Ausdruck vereinfachen möchten, bei dem anzunehmen sei, dass die Unbestimmten reell sind, fügen Sie nach dem Schlüsselwort vereinfachen den Terminus annehmen=reell ein.

  • Wenn Sie einen Ausdruck vereinfachen möchten, bei dem anzunehmen sei, dass die Unbestimmten reell sind und zwischen den Werten a und b liegen, fügen Sie nach dem Schlüsselwort vereinfachen den Terminus annehmen=ReellBereich(a,b) ein, wobei für a und b reelle Zahlen bzw. unendlich eingegeben werden muss.

  • Sie können einen trigonometrischen Ausdruck vereinfachen, indem Sie eine der folgenden Identitäten anwenden:

Geben Sie nach dem Schlüsselwort vereinfachen den Terminus trig ein.

Sie können ein Ergebnis auch mit dem Befehl Vereinfachen im Menü Symbolik vereinfachen

Weitere Schlüsselwörter...


Schlüsselwort "auflösen"

Verwenden Sie das Schlüsselwort auflösen, wenn ein Ausdruck symbolisch nach einer Variable aufgelöst werden soll:

  1. Geben Sie die Gleichung ein. Verwenden Sie für das Gleichheitszeichen Strg+=.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort auflösen ein.

  4. Geben Sie ein Komma und dann die Variable ein, nach der der Ausdruck aufgelöst werden soll.

  5. Drücken Sie die Eingabetaste, um sich das Ergebnis anzeigen zu lassen.

Zum symbolischen Lösen eines Gleichungssystems gehen Sie wie folgt vor:

  1. Erstellen Sie einen Vektor mit n Zeilen und 1 Spalte, und fügen Sie in die Elementplatzhalter die Gleichungen des Systems ein. Verwenden Sie für das Gleichheitszeichen Strg+=.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort auflösen ein.

  4. Erstellen Sie einen Vektor mit n Zeilen und 1 Spalte, und fügen Sie in die Elementplatzhalter die Variablen ein, nach denen der Ausdruck aufgelöst werden soll.

  5. Drücken Sie die Eingabetaste, um sich das Ergebnis anzeigen zu lassen.

Weitere Schlüsselwörter...


Schlüsselwort "ersetzen"

Zum Ersetzen einer Variable im gesamten Arbeitsblatt durch eine andere Variable, einen Ausdruck oder eine Zahl gehen Sie folgendermaßen vor:

  1. Geben Sie den Ausdruck ein, der die zu ersetzende Variable enthält.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort ersetzen ein.

  4. Geben Sie ein Komma und dann eine Gleichung der Form var1=var2 ein, wobei var1 die Variable ist, die durch var2 ersetzt werden soll. Verwenden Sie für das Gleichheitszeichen Strg+Ist gleich.

  5. Drücken Sie die Eingabetaste, um sich das Ergebnis anzeigen zu lassen.

Diese Operation kann einen unübersichtlichen Ausdruck ergeben. Sie können das Ergebnis jedoch mit dem Schlüsselwort vereinfachen kürzen.

Beachten Sie, dass dieser Befehl nur funktioniert, wenn Sie eine Variable durch einen Ausdruck ersetzen möchten. Dieser Befehl kann nicht verwendet werden, um einen Ausdruck durch einen anderen Ausdruck zu ersetzen. Zum Ersetzen von Ausdrücken durch andere Ausdrücke müssen Sie die Befehle Ausschneiden und Einfügen aus dem Menü Bearbeiten verwenden.

Weitere Schlüsselwörter...


Schlüsselwort "ztrans"

Mit dem Schlüsselwort ztrans werten Sie die Z-Transformation einer Funktion aus:

  1. Geben Sie die Funktion ein, die ausgewertet werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort ztrans ein.

  4. Geben Sie ein Komma und dann die Variable ein, in der die Transformation erfolgen soll.

  5. Drücken Sie die Eingabetaste.

Das Schlüsselwort ztrans gibt eine Funktion in der Variable z aus. Wenn der zu transformierende Ausdruck bereits ein z enthält, wird stattdessen eine Funktion in der Variable zz zurückgegeben, um jegliche Zweideutigkeit zu vermeiden. Mit dem Schlüsselwort Ersetzen können Sie z durch eine andere Variable oder einen Ausdruck ersetzen.

Weitere Schlüsselwörter...


Schlüsselwörter

annehmen

koeff

sammeln

komplex

konvert

entwickeln

faktor

gleit

fourier

invfourier

invlaplace

invztrans

laplace

reihe

vereinfachen

auflösen

ersetzen

ztrans


Knoten

Die "Knoten", die bei der B-Spline-Interpolation verwendet werden, sind die Werte, an denen die einzelnen Polynome aneinander angepasst sind. Im Unterschied dazu handelt es sich bei den Knoten der anderen Splines stets um die x-Werte.


Kronecker-Deltafunktion

(m,n) Gibt 1 zurück, wenn m = n. Andernfalls wird 0 zurückgegeben.

Argumente:

m und n müssen ganze Zahlen ohne Einheiten sein.

Da diese Funktion bei 0 eine Unstetigkeit aufweist, sollten Sie Ausdrücke, die diese Funktion einschließen, nicht über ein Intervall mit 0 integrieren. Stattdessen empfiehlt es sich, den Integrationsbereich in zwei Teilbereiche aufzuteilen, über jeden Bereich einzeln zu integrieren und die Ergebnisse dann zu addieren.

Aus demselben Grund ist die Ableitung dieser Funktion bei 0 nicht definiert.


Die Funktion "kgltt"

Die Funktion kgltt verwendet zur Berechnung der lokalen gewichteten Mitte des Eingabesektors vy einen Gaußschen Kern. Für jedes Element in dem aus n Elementen bestehenden Vektor vy gibt die Funktion kgltt ein neues vy-Element zurück. Dies ergibt sich aus:

und b ist hierbei die von Ihnen angegebene Bandbreite für die Funktion kgltt. Für die Bandbreite wird normalerweise ein Vielfaches des Abstands zwischen den Datenpunkten auf der X-Achse festgelegt. Dies hängt jedoch davon ab, wie groß das Fenster für die Glättung sein soll.


Wölbungsfunktion

Wölbung

Argumente:

A, B, C, ... sind Felder oder Skalare. Ein aus den Funktionsargumenten erstelltes Feld M muss mindestens vier Elemente enthalten.

Die Standardabweichung M, ein aus dem Funktionsargumenten erstelltes Feld, darf nicht gleich null sein.

Hinweise:

  • Die Wölbung bestimmter Werte zeigt an, wie flach oder gewölbt eine Verteilung im Vergleich zur Normalverteilung ist. kurt(M)>0 zeigt an, dass die Verteilung relativ stark gewölbt ist. kurt(M )>0 zeigt an, dass die Verteilung relativ flach ist.

  • kurt(M)=0 steht für eine normale Verteilung.

Weitere Funktionen für die Datenanalyse...


Beschriften der Achsen in einem X-Y-Diagramm

Zum Beschriften einer Achse in einem Diagramm gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf ein Diagramm oder wählen Sie im Menü Format den Befehl Diagramm / X-Y-Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte Beschriftungen.

  3. Geben Sie in diesem Dialogfeld eine Beschriftung für eine oder beide Achsen ein. Sie können hierbei Groß- und Kleinschreibung verwenden.

  4. Klicken Sie auf "OK", damit die festgelegten Beschriftungen angezeigt werden.

Um die Beschriftung aus den Textfeldern zu löschen, klicken Sie auf "Abbrechen", damit der Originalzustand der Textfelder für die Beschriftungen wiederhergestellt wird.

Zum vollständigen Löschen der Beschriftungen verwenden Sie die Rücktaste.


Registerkarte "Beschriftungen" für Kreisdiagramme

Auf der Registerkarte "Beschriftungen" des Dialogfelds "Gerade markiertes Kreisdiagramm wird formatiert" finden Sie die folgenden Optionen und Schaltflächen:

Titel

Geben Sie in dieses Feld einen Titel für das Diagramm ein.

Oben

Hiermit legen Sie fest, dass der Titel oberhalb des Diagramms erscheint, wenn die Option "Titel anzeigen" aktiviert wurde.

Unten

Hiermit legen Sie fest, dass der Titel unterhalb des Diagramms erscheint, wenn die Option "Titel anzeigen" aktiviert wurde.

Titel anzeigen

Wenn diese Option aktiviert ist, wird der im Feld "Titel" angegebene Titel des Diagramms angezeigt.


Registerkarte "Beschriftungen" für Kreisdiagramme

Auf der Registerkarte "Beschriftungen" des Dialogfelds "Gerade markiertes X-Y-Diagramm wird formatiert" finden Sie die folgenden Optionen und Schaltflächen:

Titel

Geben Sie in dieses Feld einen Titel für das Diagramm ein.

Oben

Hiermit legen Sie fest, dass der Titel oberhalb des Diagramms erscheint, wenn die Option "Titel anzeigen" aktiviert wurde.

Unten

Hiermit legen Sie fest, dass der Titel unterhalb des Diagramms erscheint, wenn die Option "Titel anzeigen" aktiviert wurde.

Titel anzeigen

Wenn diese Option aktiviert ist, wird der im Feld "Titel" angegebene Titel des Diagramms angezeigt.

Achsenbeschriftungen

Hier können Sie den Text eingeben, der neben den Achsen erscheinen soll. Der Text erscheint jedoch nur, wenn das Kontrollkästchen neben dem Textfeld markiert ist. Soll der Text (vorübergehend) nicht angezeigt werden, müssen Sie die Markierung des Kontrollkästchens aufheben.


Laguerre-Polynomfunktion

Lag(n,x) Gibt den Wert des Laguerre-Polynoms vom Grad n bei x zurück.

Argumente:

n ist eine dimensionslose ganze Zahl.

x muss ein Skalar sein.

Das Laguerre-Polynom ist eine Lösung der folgenden Differentialgleichung:


Lambertsche W-Funktion

Dabei handelt es sich um die Inverse von [image].

Zur Berechnung von W(A) verwenden Sie [image].


Lambertsche W-Funktion, n-ter Zweig

Dabei handelt es sich um den N-ten Zweig von W(A), der Inverse von [image].


Laplace-Transformation

Zur Auswertung der Laplace-Transformation einer Funktion gehen Sie wie folgt vor:

  1. Geben Sie den zu transformierenden Ausdruck ein.

  2. Klicken Sie auf die Transformationsvariable.

  3. Wählen Sie im Menü Symbolik die Option Transformation / Laplace.

Mathcad gibt bei Laplace-Transformationen eine Funktion in der Variable s zurück. Wenn der zu transformierende Ausdruck bereits ein s enthält, wird stattdessen eine Funktion in der Variable ss zurückgegeben. Mit dem Befehl Variable ersetzen können Sie s durch eine andere Variable oder einen Ausdruck ersetzen.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie das Schlüsselwort "laplace" in Verbindung mit der aktiven symbolischen Auswertung.


Layout-Hilfsmittel

Beim Einfügen von Gleichungen, Text, Grafiken und anderen Bereichen in ein Arbeitsblatt können Sie deren Anordnung nach Belieben festlegen. Sie können auch Bereiche hervorheben, sodass sie leichter ins Auge fallen.

Auswählen von Bereichen

Verschieben von Bereichen

Einfügen leerer Zeilen zwischen Bereichen

Bearbeiten von überlappenden Bereichen

Hervorheben von Bereichen

Ausrichten von Bereichen

Trennen von Bereichen

Sperren von Bereichen


Kleinstes gemeinsames Vielfaches

lcm(A, B, C usw.) Übergibt das kleinste gemeinsame Vielfache: die kleinste positive, ganze Zahl, die Vielfaches jedes der Werte A, B, C, ... ist.

Argumente:

A, B, C, ... sind jeweils reelle, dimensionslose, ganze Zahlen größer eins oder Felder, deren Elemente reelle, dimensionslose, ganze Zahlen größer eins sind.

Beispiele:


Pfeil-nach-links

In leeren Bereichen

Versetzt den Fadenkreuzcursor um eine Stelle nach links. Wenn sich ein anderer Bereich links daneben befindet, erscheint das Fadenkreuz in diesem Bereich und wird entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen

Versetzt die Einfügelinie um ein Zeichen nach links. Befindet sie sich bereits am Beginn des Ausdrucks, so werden die Bearbeitungslinien aus dem Ausdruck in den leeren Bereich links daneben gesetzt und dort zu einem Fadenkreuz umgewandelt.

In Textbereichen

Verschiebt die Einfügemarke um ein Zeichen nach links. Befindet sie sich bereits am Textanfang, erscheint sie links außerhalb des Textes im leeren Bereich.

Bereiche verschieben

Verschiebt den/die ausgewählten Bereich(e) nach links. Bei dauerhaft gedrückter Taste wird schneller nach links verschoben.


Funktion für linke Inverse

geninv(A) Gibt die linke inverse Matrix L von A zurück, sodass gilt: .

Argumente:

  • A muss ein aus m x n Elementen bestehendes Feld sein, wobei m [image] n ist.

  • A muss reelle Werte enthalten.


Legendeneinstellungen in Kreisdiagrammen

Zum Erstellen einer Legende zur Identifizierung einer Spur gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf ein Diagramm oder wählen Sie Diagramm / Kreisdiagramm im Menü Format, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie gegebenenfalls auf die Registerkarte Spuren.

  3. Weisen Sie den einzelnen Spuren Namen zu, indem Sie in der Spalte "Legendenname" der Liste in der Mitte des Dialogfelds auf die Standardnamen klicken. Der Name erscheint im Textfeld unter dieser Spalte.

  4. Zum Ändern des Namens der Spur geben Sie den neuen Namen in dem Textfeld unter der Spalte "Legendenname" ein.

  5. Mit dem Kontrollkästchen "Legende ausblenden" können Sie festlegen, ob die Legende angezeigt oder ausgeblendet werden soll.

  6. Mit dem Kontrollkästchen "Argumente ausblenden" können Sie festlegen, ob die Ausdrücke, mit denen das Diagramm erstellt wurde, ebenfalls angezeigt werden.

  7. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


Legendeneinstellungen (X-Y-Diagramme)

Zum Erstellen einer Legende zur Identifizierung einer Spur gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf ein Diagramm oder wählen Sie Diagramm / X-Y-Diagramm im Menü Format, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie gegebenenfalls auf die Registerkarte Spuren.

  3. Weisen Sie den einzelnen Spuren Namen zu, indem Sie in der Spalte Legendenname der Liste in der Mitte des Dialogfelds auf die Standardnamen klicken. Der Name erscheint im Textfeld unter dieser Spalte.

  4. Zum Ändern des Namens der Spur geben Sie den neuen Namen in dem Textfeld unter der Spalte "Legendenname" ein.

  5. Mit dem Kontrollkästchen "Legende ausblenden" können Sie festlegen, ob die Legende angezeigt oder ausgeblendet werden soll.

  6. Mit dem Kontrollkästchen "Argumente ausblenden" können Sie festlegen, ob die Ausdrücke, mit denen das Diagramm erstellt wurde, ebenfalls angezeigt werden.

  7. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


Legendre-Polynomtunktion

Legendre-Polynomfunktion

Leg(n,x) Gibt den Wert des Legendre-Polynoms vom Grad n an der Stelle x zurück.

Argumente:

n ist eine dimensionslose ganze Zahl.

x muss ein Skalar sein.

Das Legendre-Polynom ist eine Lösung der folgenden Differentialgleichung:


Operator "Kleiner als"

Tastaturbefehl: <

x < yGibt 1 zurück, wenn x < y, andernfalls 0.

Operanden:

  • x und y müssen reelle oder imaginäre Skalare, Vektoren oder Zeichenfolgen sein.


Operator "Kleiner gleich"

Tastaturbefehl: Strg+9

x [image] y Gibt 1 zurück, wenn x [image] y, andernfalls 0.

Operanden:

  • x und y müssen reelle oder imaginäre Skalare, Vektoren oder Zeichenfolgen sein.


Lösen mit der Levenberg-Marquardt-Methode

Levenberg-Marquardt

Die iterative Levenberg-Marquardt-Methode kann im von suchen oder Minfehl aufgerufenen Lösungsvorgang verwendet werden. Die Methode umfasst Folgendes:

Der Fehlervektor

Einzelschritte bei der Levenberg-Marquardt-Methode

Abbruchkriterien

Abweichungen von der Levenberg-Marquardt-Methode

Die Mathcad-Methode wurde dem Public Domain-Paket "MINPACK Algorithms" entnommen, das von Argonne National Laboratory in Argonne, Illinois (USA) entwickelt und veröffentlicht wurde. Weitere Informationen dazu siehe "User's Guide to Minpack I" von Jorge J. More, Burton S. Garbow und Kenneth E. Hillstrom, Argonne National Laboratory Publication ANL-80-74, 1980.


Beleuchten eines 3D-Diagramms

Übersicht

Beleuchtung ist eine Möglichkeit, die Farbe und Schattierung eines 3D-Diagramms festzulegen, genau wie sich Beleuchtung in der Realität auf die Farbe von Objekten auswirkt.

In der Realität wird die Farbe eines Objekts ebenso von seiner Farbe wie dem Umgebungslicht bestimmt. Beispielsweise kann eine gelbe Kugel in trübem Licht gräulich aussehen, während das Gelb bei hellerer Beleuchtung klarer wird. Dies liegt daran, dass ein Objekt bei Lichteinwirkung das Licht je nach Farbe spiegelt und absorbiert. Zum Beispiel wird blaues Licht von einem blauen Objekt größtenteils reflektiert, während andere Farben absorbiert werden.

Die Farbe eines Diagramms hängt in gleichem Maß von der Farbe der Füllung ab wie von dem Licht, mit dem es beleuchtet wird. Sie können einem Diagramm Farbe zuweisen, indem Sie es mit einer Volltonfarbe füllen oder ein Farbschema verwenden. Wenn Sie dann Beleuchtung aktivieren, kann sich die Farbe des Diagramms entsprechend der festgelegten Art und Farbe des Lichts ändern.

Lichteinstellungen

Licht auf einem Diagramm besteht aus:

  • Umgebungslicht

  • Gerichtetem Licht

Zum Festlegen der Beleuchtung für ein 3D-Diagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Beleuchtung", damit die Seite Beleuchtung angezeigt wird.

  3. Mit den Optionen auf dieser Seite haben Sie folgende Möglichkeiten:

    • Aktivieren von Beleuchtung

    • Festlegen der Umgebungslichtfarbe

    • Wählen eines Beleuchtungsschemas

    • Festlegen der gestreuten Farbe und Glanzfarbe eines gerichteten Lichts

    • Festlegen der Position eines gerichteten Lichts

    • Positionieren eines Lichts in großer Entfernung

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


Grenzwerte

Zur Berechnung des Grenzwerts eines Ausdrucks gehen Sie folgendermaßen vor:

  1. Drücken Sie Strg+L, um den Operator "Grenzwert" zu erstellen.

    Drücken Sie für einen Grenzwert von links Strg+Umschalt+B.

    Drücken Sie für einen Grenzwert von rechts Strg+Umschalt+A.

  2. Geben Sie den Ausdruck in den Platzhalter rechts neben "lim" ein.

  3. Geben Sie die Grenzwertvariable in den linken Platzhalter unterhalb von "lim" ein.

  4. Geben Sie den Grenzwert in den rechten Platzhalter unterhalb von "lim" ein.

  5. Drücken Sie so lange die Leertaste, bis sich der gesamte Ausdruck zwischen den Bearbeitungslinien befindet.

  6. Wählen Sie aus dem Menü Symbolik die Option Vereinfachen.

Falls der Grenzwert nicht existiert, wird eine Fehlermeldung angezeigt.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Auswertung.


Einschränkungen beim Kopieren von numerischen Ergebnissen

Wenn Sie das Ergebnis einer Berechnung in die Zwischenablage kopieren, weicht es dort in folgenden Punkten vom ursprünglichen Ergebnis des Arbeitsblatts ab:

  • Alle Zahlen in der Zwischenablage enthalten nur so viele Ziffern wie im ursprünglichen Ergebnis angezeigt wurden.

  • Mit dem Ergebnis verknüpfte Einheiten werden nicht in die Zwischenablage kopiert.

  • Nachfolgende Nullen werden nicht kopiert.

  • Verschachtelte Felder in einem Ergebnis werden als Nullen kopiert.


Beschränkungen bei Bereichsvariablen

Einige Bereichsvariablendefinitionen sind nicht zugelassen. Es gelten folgende Beschränkungen:

Die Zahl unmittelbar nach dem Komma (soweit vorhanden) muss zwischen den beiden anderen Zahlen liegen.

Alle Zahlen in der Definition müssen reelle Zahlen sein.

Die Dimensionen aller Zahlen (soweit vorhanden) im Bereich müssen übereinstimmen.

Eine Bereichsvariable kann nicht über eine andere Bereichsvariable definiert werden.

Eine Bereichsvariable kann nicht über eine Matrix oder einen Vektor definiert werden.


Beschränkungen der Datenfeldgrößen

Beschränkungen der Eingabefelder:

Wenn Sie im Menü Einfügen den Eintrag Matrix wählen, ist es nicht möglich, ein Feld mit mehr als 100 Elementen zu erstellen. Sie können jedoch größere Felder folgendermaßen erstellen:

  • Verbinden kleinerer Felder

  • Lesen aus einer Datendatei

  • Verwenden von Bereichsvariablen

  • Erstellen einer Datentabelle

Beschränkungen der Datenfeldgrößen:

  • Die jeweilige Beschränkung der Feldgröße hängt vom im System verfügbaren Speicherplatz ab. Pro Feldelement werden ca. 8 Byte Speicher benötigt. Bei den meisten Systemen liegt die Beschränkung der Feldgröße bei mindestens 1 Mio. Elemente. Mehr als 8 Millionen Elemente sind in keinem System möglich.

  • Wenn Sie ein Feldergebnis in Form einer Matrix anzeigen, zeigt Mathcad lediglich bis zu 200 Zeilen und Spalten an.


Linieneinstellungen (3D-Säulendiagramme)

Zum Festlegen der Linien in einem 3D-Säulendiagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Darstellung".

  3. Mit den Optionen auf der Seite Darstellung haben Sie folgende Möglichkeiten:

    • Zeichnen eines Rahmens aus Linien um die Säulen

    • Einfärben der Linien mit Volltonfarbe oder entsprechend eines Farbschemas

    • Entfernen von Linien aus dem Diagramm

    • Festlegen der Linienstärken

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


Linieneinstellungen (3D-Streuungsdiagramme)

Sie können Linien zeichnen, um die Punkte in einem 3D-Streuungsdiagramm zu verbinden:

  1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Darstellung".

  3. Mit den Optionen auf der Seite Darstellung haben Sie folgende Möglichkeiten:

    • Zeichnen einer Linie als Verbindung zwischen den Punkten

    • Einfärben der Linien mit Volltonfarbe oder entsprechend eines Farbschemas

    • Entfernen von Linien aus dem Diagramm

    • Festlegen der Linienstärken

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf.

Gehen Sie zum Festlegen der Methode beim Verbinden von Punkten im Diagramm folgendermaßen vor:

  1. Öffnen Sie durch Klicken auf die Registerkarte "Spezial" die Seite "Spezial".

  2. Wählen Sie im Abschnitt "Verbindungsart" der Seite "Spezial" den Eintrag Zeilenfolge, Ansteigend X, Ansteigend Y oder Ansteigend Z.

  3. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


Linieneinstellungen (Umrissdiagramme)

Zum Festlegen der Linien in einem Umrissdiagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Darstellung".

  3. Mit den Optionen auf der Seite Darstellung haben Sie folgende Möglichkeiten:

    • Zeichnen von Linien mit einem Farbschema

    • Entfernen von Linien aus dem Diagramm

    • Festlegen der Linienstärken

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf.

Klicken Sie zum Festlegen der Anzahl der Umrisse in einem Umrissdiagramm auf die Registerkarte "Spezial", um die Seite "Spezial" zu öffnen.

  1. Wählen Sie eine Umrissrichtung in dem Dropdown-Menü am unteren Rand des Abschnitts "Umrissoptionen". Verwenden Sie "Z-Umrisse" (außer Sie haben das Umrissdiagramm auf einer anderen Hintergrundebene erstellt).

  2. Mit den Optionen im Abschnitt "Umrissoptionen" haben Sie folgende Möglichkeiten:

    • Festlegen der Anzahl der Umrisse

    • Bestimmen, ob die Umrisse mit Zahlen beschriftet werden

  3. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


Linieneinstellungen (Flächendiagramme)

Zum Festlegen der Linien in einem Flächendiagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Darstellung".

  3. Mit den Optionen auf der Seite Darstellung haben Sie folgende Möglichkeiten:

    • Zeichnen eines Rahmens mit Linien in Volltonfarbe oder entsprechend eines Farbschemas

    • Zeichnen von ausschließlich Umrisslinien mit einem Farbschema

    • Entfernen von Linien aus dem Diagramm

    • Festlegen der Linienstärken

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


Linieneinstellungen (Vektorfelddiagramme)

Zum Formatieren der Linien in einem Vektorfelddiagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Darstellung".

  3. Mit den Optionen auf der Seite Darstellung haben Sie folgende Möglichkeiten:

    • Einfärben der Linien mit Volltonfarbe oder entsprechend eines Farbschemas

    • Festlegen der Linienstärken

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


Lineare Kombination von Funktionen

linanp(vx,vy,F) Gibt einen Vektor mit den Koeffizienten zurück, die verwendet wurden, um eine lineare Kombination der Funktionen in F zu erstellen, die sich am besten den Daten in vx und vy annähert.

Argumente:

  • vx ist ein Vektor aus Datenwerten. Diese entsprechen den x-Werten. Die Elemente müssen in aufsteigender Reihenfolge angeordnet sein. Sollte dies nicht der Fall sein, verwenden Sie die Funktion sort, um die Elemente entsprechend zu ordnen.

  • vy ist ein Vektor aus Datenwerten. Diese entsprechen den y-Werten. Die Anzahl der Elemente entspricht der von vx.

  • F ist eine Funktion, die einen Vektor zurückgibt, dessen Elemente Funktionen für eine lineare Funktion sind. Im Falle einer einzelnen linearen Funktion ist F ein Skalar.

Die Funktion linanp ist hilfreich, wenn Sie eine Gruppe von gemessenen x- und y-Werten haben und Sie Ihre Daten mit einer linearen Kombination beliebiger Funktionen modellieren wollen.

Das folgende Beispiel zeigt die Verwendung von linanp:


Lineare Interpolation

linterp(vx,vy,x) Gibt einen an x linear interpolierten Wert für die Datenvektoren vx und vy an.

Argumente:

  • vx ist ein Vektor aus reellen Datenwerten in aufsteigender Reihenfolge. Diese entsprechen den x-Werten.

  • vy ist ein Vektor aus reellen Datenwerten. Diese entsprechen den y-Werten. Die Anzahl der Elemente entspricht der von vx.

  • x ist der Wert der unabhängigen Variable, an der das Ergebnis interpoliert werden soll. Dieser Wert sollte innerhalb des von vx angegebenen Bereichs liegen, um optimale Ergebnisse zu erzielen.

Bei der linearen Interpolation verbindet Mathcad die vorhandenen Datenpunkte durch gerade Linien und interpoliert nach einem bestimmten Wert. Das folgende Beispiel zeigt die Verwendung von linterp:


Lösen mit der linearen Methode

Linear

Diese Option wird verwendet, wenn Sie ein lineares Programm mit der Funktion suchen, minfehl, minimieren oder maximieren lösen und dazu eine lineare Programmierungsmethode benötigen.

Hinweise:

  • Ein lineares Programm verfügt über eine lineare Zielfunktion. Eine lineare Zielfunktion hat folgende Form: c0*var1+c1*var2+...cn*varn. So ist beispielsweise die Funktion g(x,y):=x+y linear.

  • Die Nebenbedingungen in einem linearen Programm müssen entweder Gleichungen oder Ungleichungen sein, die lineare Funktionen mit Konstanten vergleichen. Eine gültige Nebenbedingung für ein lineares Programm ist z. B. x+2<5.

  • Wenn Sie die Option Linear wählen, müssen Sie im Lösungsblock Schätzwerte definieren. Die Schätzwerte sind jedoch immateriell, sodass sie sich nicht auf die Lösung auswirken, es sei denn, es wird nach einem Matrix- oder Vektorergebnis aufgelöst. In diesem Fall gibt der Schätzwert für den Vektor bzw. die Matrix die Größe des zu suchenden Vektors bzw. der zu suchenden Matrix an.

  • Die Option Linear greift bei der Lösung nicht auf die vordefinierte Variable TOL zurück.

Bei der linearen Lösung kommt ein einseitiges Verfahren mit Verzweigungen und Grenzen zum Tragen. Weitere Informationen dazu finden Sie unter Referenzmaterial zu den Lösungsalgorithmen.


Lineare Prognose

prognose(v,m,n) Gibt einen Vektor aus n prognostizierten Werten auf der Grundlage von m aufeinanderfolgenden Elementen von v zurück.

Argumente:

  • v ist ein Vektor, dessen Werte Stichproben entsprechen, die in gleichen Intervallen entnommen wurden.

  • m und n sind ganze Zahlen.

Die Funktion prognose prognostiziert anhand der vorhandenen Daten Datenpunkte, die hinter den vorhandenen liegen. Sie verwendet einen linearen Prognosealgorithmus, der von großem Vorteil ist, wenn die Daten gleichförmig und oszillierend sind (aber nicht unbedingt periodisch sein müssen). Die lineare Prognose kann als eine Art Extrapolationsverfahren angesehen werden, ist jedoch nicht mit Linear- oder Polynomextrapolation zu verwechseln.

Das folgende Beispiel zeigt, wie Sie die lineare Prognose verwenden können:


Lineare Regression

line(vx, vy) Übergibt einen Vektor mit den Koeffizienten einer Geraden der Form a+b*x, die die Daten in vx und vy am besten darstellt.

medfit(vx, vy) Übergibt einen Vektor mit den Koeffizienten einer Geraden der Form a+b*x, die die Daten in vx und vy über die Median-Median-Regression am besten darstellt.

Argumente:

vx ist ein Vektor aus reellen Datenwerten. Die Werte in vx entsprechen den x-Werten.

vy ist ein Vektor aus reellen Datenwerten. Die Werte in vy entsprechen den y-Werten.

Hinweis: vx und vy müssen jeweils die gleiche Anzahl von Elementen enthalten.


Verknüpftes Objekt

Ein Objekt, das die Anwendung, mit der es erstellt wurde, sowie eine Datei mit dem Objekt öffnet, sobald Sie darauf doppelklicken. Wenn die Anwendung die Aktivierung an Ort und Stelle unterstützt, werden statt der Mathcad-Menüs und -Symbolleisten die Menüs und Symbolleisten der anderen Anwendung angezeigt, und um das Objekt erscheint eine gestrichelte Linie.

Jegliche Änderungen, die Sie an dem Objekt vornehmen, wirken sich auf die Originaldatei aus, die das Objekt enthält.


Herstellung einer Verbindung mit einer Datenbank

Bevor Sie eine ODBC-Eingabekomponente in Ihr Arbeitsblatt einfügen können, müssen Sie zunächst eine Verbindung mit einer Datenbank auf Ihrem System oder in Ihrem Netzwerk herstellen. Gehen Sie hierzu folgendermaßen vor:

  1. Öffnen Sie in Windows 2000 und XP die Systemsteuerungsoption Verwaltung Þ Datenquellen (ODBC). Öffnen Sie in Windows 95, 98 und NT die Systemsteuerung und klicken dann auf die Option ODBC-Datenquellen.

  2. Klicken Sie auf der Registerkarte Benutzer-DSN auf "Hinzufügen", um eine Datenbank hinzuzufügen.

  3. Wählen Sie im Dialogfeld Neue Datenquelle erstellen den Treiber für die Datenbank, auf die Sie zugreifen wollen, aus. Klicken Sie auf "Fertig stellen".

  4. Geben Sie die Datenbank an, zu der Sie eine Verbindung herstellen wollen. Geben Sie den Namen der Datenquelle (den Sie später im ODBC-Eingabeassistenten auswählen) und, falls gewünscht, eine Beschreibung ein. Klicken Sie auf "OK".

Die genaue Durchführung dieses Schritts ist vom ausgewählten Treiber abhängig. Wenn Sie beispielsweise eine Verbindung zu einer Microsoft Access-Datenbank herstellen wollen, geben Sie die Datenbank an, indem Sie auf die Schaltfläche "Auswählen" klicken und zur gewünschten Access-Datei (*.mdb) navigieren. Zum Benennen der Datenbank füllen Sie das Feld Datenquellenname aus. Für andere Datenbanken werden unter Umständen Schaltflächen mit anderen Namen verwendet, doch das Verfahren zur Auswahl und Benennung der Datenbank ist dasselbe. Für die Erstellung einer Datenquelle ist es erforderlich.

  5. Klicken Sie auf "OK", um die Systemsteuerung zu schließen.

Weitere Hinweise zur ODBC- und SQL-Unterstützung finden Sie in der Dokumentation zu Ihrem Datenbankprogramm.


Dialogfeld "Verknüpfungen"

Im Dialogfeld "Verknüpfungen" finden Sie die folgenden Optionen und Schaltflächen:

Verknüpfungsliste

Zeigt die Verknüpfungen an, die das Arbeitsblatt enthält.

Jetzt aktualisieren

Aktualisiert eine Verknüpfung manuell.

Quelle öffnen

Öffnet die Anwendung, in der das verknüpfte Objekt erstellt wurde.

Quelle ändern

Verknüpft das Objekt mit einer anderen Quelldatei. Die neue Quelldatei muss in derselben Anwendung erstellt worden sein wie die ursprüngliche Quelldatei.

Verknüpfung aufheben

Hebt die Verknüpfung zwischen der ursprünglichen Quelle eines Objekts und der Objektkopie im Arbeitsblatt auf.

Aktualisieren

Wählen Sie Automatisch, um die Verknüpfung automatisch aktualisieren zu lassen, sobald Sie das Arbeitsblatt öffnen oder sobald sich die Quellinformationen im geöffneten Arbeitsblatt ändern.

Wählen Sie Manuell, wenn die Verknüpfung nur dann aktualisiert werden soll, wenn Sie "Jetzt aktualisieren" wählen.


Liste der numerischen Integrationsmethoden

Romberg - Die Integration erfolgt unter Verwendung der Romberg-Methode, die für die meisten Integranden eingesetzt werden kann.

Adaptiv - Die Integration erfolgt unter Verwendung einer adaptiven Quadraturmethode; diese Methode eignet sich für Funktionen, die sich in einem bestimmten Intervall schnell ändern.

Unendlich an der Integrationsgrenze - Die Integration erfolgt unter Verwendung eines Algorithmus, der für Integrale geeignet ist, bei denen einer oder beide Grenzwerte unendlich sind. Bei der zu integrierenden Funktion muss es sich um eine reelle Funktion handeln.

Singularität an der Integrationsgrenze - Die Integration erfolgt unter Verwendung einer offenen Romberg-Methode, die für Integrale geeignet ist, die an einer oder beiden Integrationsgrenzen nicht existierten.


Literalindexoperator

Eingabe eines Literalindex wie

vinit

  1. Geben Sie den ersten Teil des Namens (v) ein, d. h. den Teil vor der Tiefstellung.

  2. Geben Sie einen Punkt ein. Die Einfügemarke wird um eine halbe Zeile nach unten erweitert.

  3. Geben Sie die zweite Hälfte des Namens ein, also den Teil, der tiefgestellt werden soll (init).

Hinweis: Zum Eingeben tiefgestellter Literalindizes können Sie auch die Schaltfläche Tiefgestellt auf der Symbolleiste Formatierung verwenden.

Verwechseln Sie Literalindizes nicht mit Feldindizes. Sie wirken zwar ähnlich, sind jedoch grundverschieden.


Aktive Symbolik nicht verfügbar.

Der nach rechts gerichtete Pfeil ist ein "symbolisches Gleichheitszeichen" und wird bei der symbolischen Auswertung von Ausdrücken ähnlich verwendet wie bei der numerischen Auswertung mit "=".

In dieser Version der Software ist die symbolische Auswertung nicht verfügbar.


Operator "Lokale Definition" in einem Programm

Tastaturbefehl: {

Mit diesem Operator definierte Variablen sind nur innerhalb des Programms definiert.

Sie können dieses Operatorsymbol durch "=" anzeigen lassen, falls gewünscht.


Sperregion

Eine Sperregion ist der Bereich des Dokuments, der sich zwischen den unten dargestellten Vorhängeschlössern befindet. Sie können solche Regionen erstellen, sperren und freigeben, indem Sie die entsprechende Auswahl in den Befehlen unter Region im Menü Format treffen.


Sperren einer ausgeblendeten Region

Nachdem Sie eine Region ausgeblendet haben, können Sie sie sperren, um so zu verhindern, dass andere die Bereiche innerhalb dieser Region bearbeiten können. Zum Sperren einer ausgeblendeten Region ist folgendermaßen vorzugehen:

  1. Klicken Sie auf die Linie, die die ausgeblendete Region repräsentiert.

  2. Wählen Sie den Befehl Region / Sperren im Menü Format.

  3. Geben Sie, falls gewünscht, ein Kennwort ein und bestätigen Sie dieses, indem Sie es erneut eingeben. Bei der Angabe des Kennworts ist auf die Groß- und Kleinschreibung zu achten. Jedes Arbeitsblatt kann mehrere gesperrte Regionen enthalten, die jeweils mit einem eigenen Kennwort versehen werden können. Wenn Sie ein Kennwort verwenden, sollten Sie darauf achten, dass Sie das Kennwort nicht vergessen.

  4. Klicken Sie auf "OK".

Links neben der Linie, die die ausgeblendete Region repräsentiert, erscheint ein Vorhängeschloss-Symbol, das anzeigt, dass die Region gesperrt ist.


Sperren der definierten Region

Nach dem Einfügen einer Region können Sie sie sperren, damit andere Benutzer die enthaltenen Bereiche nicht verändern können. Zum Sperren einer Region gehen Sie wie folgt vor:

1. Klicken Sie zwischen die Regionsbegrenzungslinien.

2. Wählen Sie den Befehl Region / Sperren aus dem Menü Format. Daraufhin wird das Dialogfeld "Region sperren" geöffnet.

3. Wenn Sie die Sperre der Region durch ein Kennwort schützen möchten, geben Sie das gewünschte Kennwort zweimal ein. Beachten Sie, dass im Kennwort Groß- und Kleinbuchstaben voneinander unterschieden werden.

4. Klicken Sie auf "Bei Sperrung ausblenden", damit die Region gleich während des Sperrens ausgeblendet wird.

5. Klicken Sie auf "OK".

Die Darstellung der Regionsbegrenzungslinien verändert sich jetzt standardmäßig (siehe folgendes Beispiel):

Hinweise:

  • Jedes Arbeitsblatt kann über mehrere gesperrte Bereiche verfügen, die jeweils mit einem eigenen Kennwort versehen werden können. Wenn Sie ein Kennwort verwenden, sollten Sie darauf achten, dass Sie das Kennwort nicht vergessen.

  • Nach dem Sperren einer Region können Sie sie ausblenden, um die enthaltenen Bereiche unsichtbar zu machen.

  • Soll das gesamte Arbeitsblatt gesperrt werden, können Sie es schützen, anstatt eine Region zu sperren, die das ganze Arbeitsblatt enthält.


Verwenden von loess und regress in mehrdimensionalen Räumen

Mit den Funktionen loess und regress können Sie eine n-dimensionale Polynomfläche an eine Reihe von Punkten (x1, x2, ...xn, z) anpassen, indem Sie wie folgt vorgehen:

Jede zusätzliche unabhängige Variable erfordert eine weitere Spalte in Mxy.

Jede zusätzliche unabhängige Variable erfordert eine weitere Zeile in v.

Beschränkungen:

  • Die Funktion loess ist auf maximal vier unabhängige Variablen begrenzt.

  • Für die Funktion regress können beliebig viele unabhängige Variablen festgelegt werden. Bei mehr als vier unabhängigen Variablen oder bei einem Grad der Polynomfläche von mehr als vier benötigt regress jedoch wesentlich mehr Speicher und Rechenzeit.

Zudem muss die Zahl der Datenwerte m folgende Voraussetzung erfüllen:


Mit Loess kann nicht extrapoliert werden.

Sie versuchen, mit der Funktion loess eine Interpolation eines Wertes durchzuführen, der größer ist als der Höchstwert im Datensatz. Sie müssen nach Werten interpolieren, die präzise zwischen Ihren Datenpunkten liegen.


Lognormalverteilung

Der Lognormalverteilung zugeordnete Verteilungen:

dlnorm(x, m ,s) Gibt die Wahrscheinlichkeitsdichte zurück.

plnorm(x, m , s) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qlnorm(p, m , s) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rlnorm(m, m , s) Gibt einen Vektor aus m Zufallszahlen zurück, die die Lognormalverteilung aufweisen.


Exponential- und logarithmische Funktionen

exp(z) Zahl e hoch z.

log(z,b) Logarithmus von z zur Basis b. Wenn b weggelassen wird, Logarithmus von z zur Basis 10.

ln(z) Natürlicher Logarithmus von z (Basis e).

Argumente:

z muss ein Skalar sein (reell, komplex oder imaginär) oder ein Vektor mit Skalaren.

z muss dimensionslos sein.

Bei den Funktionen log und ln kann z nicht Null sein.

b ist ein optionales, positives Argument. b muss, wenn angegeben, ein Skalar sein. Wird b weggelassen, wird es gleich 10 gesetzt.

Bei komplexem z stammen die von den log-Funktionen zurückgegebenen Werte aus dem Hauptzweig dieser Funktionen. Anders ausgedrückt gilt:

ln(z) = ln(|z|) + i arg(z)


Logarithmische Regression

loganp(vx,vy,vg) Übergibt einen Vektor mit den Koeffizienten einer logarithmischen Ansatzfunktion der Form a*ln(x+b)+c, die die Daten in vx und vy am besten darstellt. vg enthält Schätzwerte für die drei Koeffizienten.

lnanp(vx,vy) Übergibt einen Vektor mit den Koeffizienten einer logaritmischen Ansatzfunktion der Form a*ln(x)+b, die die Daten in vx und vy am besten darstellt.

Argumente:

  • vx ist ein Vektor aus reellen Datenwerten. Die Werte in vx entsprechen den x-Werten.

  • vy ist ein Vektor aus reellen Datenwerten. Die Werte in vy entsprechen den y-Werten.

  • vg ist ein dreidimensionaler Vektor mit reellen Schätzwerten für die Parameter a,b und c in der logarithmischen Gleichung:

Hinweis: vx und vy müssen jeweils die gleiche Anzahl von Elementen enthalten.


Logistische Verteilung

Der logistischen Gleichung zugeordnete Verteilungen:

dlogis(x,l,s) Gibt die Wahrscheinlichkeitsdichte zurück.

plogis(x,l,s) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qlogis(p,l,s) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rlogis(m,l,s) Gibt einen Vektor aus m Zufallszahlen zurück, die die logistische Verteilung aufweisen.


Logistische Regression

lgsanp(vx,vy,vg) Übergibt einen Vektor mit den Koeffizienten einer logistischen Ansatzfunktion der Form a / (1+b*e-cx), die die Daten in vx und vy am besten darstellt. vg enthält Schätzwerte für die drei Koeffizienten.

Argumente:

  • vx ist ein Vektor aus reellen Datenwerten. Die Werte in vx entsprechen den x-Werten.

  • vy ist ein Vektor aus reellen Datenwerten. Die Werte in vy entsprechen den y-Werten.

  • vg ist ein dreidimensionaler Vektor mit reellen Schätzwerten für die Parameter a, b und c in der logistischen Gleichung:

Hinweis: vx und vy müssen jeweils die gleiche Anzahl von Elementen enthalten.


Funktionen für die Suche in Feldern

verweis(z, A, B) Sucht in einem Vektor oder einer Matrix A nach einem gegebenen Wert z und gibt die Werte an denselben Positionen (d. h. mit derselben Zeilen- und Spaltennummer) in einer anderen Matrix B zurück. Wenn mehrere Werte zurückgegeben werden, werden sie, zeilenweise geordnet, in einem Vektor angezeigt, beginnend mit der linken oberen Ecke von B, nach rechts fortschreitend.

wverweis(z, A, r) Sucht in der ersten Zeile einer Matrix A nach einem gegebenen Wert z und gibt die Werte in denselben Spalten in der angegebenen Zeile r zurück. Wenn mehrere Werte zurückgegeben werden, werden sie in einem Vektor angezeigt.

hlookup(z, A, c) Sucht in der ersten Spalte einer Matrix A nach einem gegebenen Wert z und gibt die Werte in denselben Zeilen der angegebenen Spalte c zurück. Wenn mehrere Werte zurückgegeben werden, werden sie in einem Vektor angezeigt.

vergleich(z, A) Sucht in einem Vektor oder einer Matrix A nach einem gegebenen Wert z und gibt die Indizes seiner Positionen in A zurück. Wenn mehrere Werte zurückgegeben werden, werden sie, nach Zeilen geordnet, in verschachtelten Feldern angezeigt, beginnend mit der linken oberen Ecke von A, nach rechts fortschreitend.

Der Grad der Genauigkeit, mit dem der Vergleich stattfindet, wird von der TOL-Einstellung des Arbeitsblatts bestimmt.

Argumente:

z ist eine reelle oder komplexe Zahl oder Zeichenfolge.

A und B sind relle, komplexe oder Zeichenfolge-Matrizen (m x n Elemente) oder -Vektoren.

r, c sind Ganzzahlen, URSPRUNG £r £ URSPRUNG+n-1, URSPRUNG £c £ URSPRUNG+n-1.


LU-Zerlegung

lu(M) Gibt genau eine Matrix mit den drei quadratischen Matrizen P, L und U zurück, die jeweils dieselbe Größe wie M aufweisen und seitlich miteinander verbunden sind. Mit der Funktion "submatrix" können Sie diese kleineren Matrizen extrahieren .

Diese drei Matrizen erfüllen die Gleichung [image],

wobei L und U für die untere ("lower") bzw. obere ("upper") Dreiecksmatrix stehen.

Argumente:

  • M ist eine quadratische Matrix.


LU-Zerlegungsverweise

Mathcad führt die LU-Zerlegung mithilfe des Crout-Verfahrens mit partieller Pivotierung aus. Eine vollständige Beschreibung finden Sie in Numerical Recipes in C von William H. Press, Brian P. Flannery, Saul A. Teukolosky und William T. Vetterling (Cambridge University Press, 1986), S. 31 bis 39.


M besteht aus 3 Matrizen


Operator "Betrag"

Betrag

Tastaturbefehl: |

|x| Gibt den Betrag von x zurück.

Operanden:

x muss ein Skalar sein.

Wenn Sie die absoluten Beträge der einzelnen Elemente eines Feldes benötigen, müssen Sie diesen Operator zusammen mit dem Operator "Vektorisieren" verwenden.


Vornehmen eines Durchlaufs im Arbeitsblatt

Mit einer Ausnahme werden alle mathematischen Ausdrücke in einem Arbeitsblatt so ausgewertet, wie sie auch gelesen werden: von oben nach unten und von links nach rechts. Weitere Erklärungen können Sie aufrufen, indem Sie auf die entsprechenden Ausdrücke im Bild unten klicken.


Aktivieren eines Fensters

Soll ein anderes Arbeitsblatt zum aktiven Fenster gemacht werden, klicken Sie entweder in das Arbeitsblatt, oder wählen Sie den Namen des Arbeitsblatts aus dem Menü Fenster.


Anzeigen des Fadenkreuz-Cursors

Wenn Sie auf eine leere Stelle im Arbeitsblatt klicken, wird der Fadenkreuz-Cursor angezeigt.


Anzeigen der Bearbeitungslinien

Klicken Sie in einen mathematischen Ausdruck, um die Bearbeitungslinien anzuzeigen.


Anzeigen der Texteinfügemarke

Um die Texteinfügemarke anzuzeigen, beginnen Sie mit einem Fadenkreuz-Cursor, und wählen Sie im Menü Einfügen die Option Textbereich.


Mantisse einer Zahl

Um nur den dezimalen Teil einer positiven Zahl zu erhalten, können Sie Folgendes definieren:

mantisse(x) := x - floor(x)


Manueller Rechenmodus

Beim Starten von Mathcad befinden Sie sich im automatischen Modus. Das heißt, dass Mathcad die Ergebnisse im Arbeitsblattfenster automatisch aktualisiert, wenn Sie Änderungen vornehmen.

Wenn Sie jedoch bei Ihrer Arbeit nicht auf die Berechnungen von Mathcad warten möchten, sollten Sie in den manuellen Modus wechseln.

Vorteile des manuellen Modus...

Nachteile des manuellen Modus...

Aktualisieren von Ergebnissen im manuellen Modus...

Merkmale des automatischen Modus...

Aktivieren des automatischen Modus...


Zuordnungsfunktionen

xyinpol(x,y)

Wandelt die kartesischen Koordinaten eines Punktes im zweidimensionalen Raum in Kreiskoordinaten um.

polinxy(r,q)

Wandelt die Kreiskoordinaten eines Punktes im zweidimensionalen Raum in kartesische Koordinaten um.

xyzinsph(x,y,z)

Wandelt die kartesischen Koordinaten eines Punktes im dreidimensionalen Raum in sphärische Koordinaten um.

sphinxyz(r,q,f)

Wandelt die sphärischen Koordinaten eines Punktes im dreidimensionalen Raum in kartesische Koordinaten um.

xyzincyl(x,y,z)

Wandelt die kartesischen Koordinaten eines Punktes im dreidimensionalen Raum in zylindrische Koordinaten um.

zylinxyz(r,q,z)

Wandelt die zylindrischen Koordinaten eines Punktes im dreidimensionalen Raum in kartesische Koordinaten um.

Argumente:

  • x, y, z, r, q, f sind reelle Zahlen.


Extras - Berechnen - Automatische Berechnung

Schaltet zwischen dem manuellen und dem automatischen Modus um.

Ist der Befehl aktiviert, werden alle sichtbaren Ergebnisse automatisch aktualisiert, wenn Sie Änderungen im Arbeitsblatt vornehmen.

Ist der Befehl nicht aktiviert, werden die Ergebnisse erst dann aktualisiert, wenn Sie im Menü Extras den Befehl Berechnen/Jetzt berechnen wählen.

Bei der Bearbeitung eines Arbeitsblatts mit aufwendigen Berechnungen lässt sich der manuelle Modus oft besser handhaben.


Extras - Berechnen - Jetzt berechnen

Aktualisiert alle sichtbaren Diagramme und numerischen Ergebnisse. Tastaturkurzbefehl: F9.

Mit diesem Befehl müssen Sie eigentlich nur arbeiten, wenn sich Mathcad im manuellen Berechnungsmodus befindet.

Wenn Ergebnisse aktualisiert werden müssen, können Sie dies am Wort "Rech" in der Meldungszeile am unteren Fensterrand erkennen.

Wenn Sie sämtliche Diagramme und numerischen Ergebnisse auf dem gesamten Arbeitsblatt aktualisieren wollen, wählen Sie stattdessen aus dem Menü Extras den Befehl Berechnen/Arbeitsblatt berechnen, oder drücken Sie [Strg] F9.


Extras - Berechnen - Arbeitsblatt berechnen

Aktualisiert alle Diagramme und numerischen Ergebnisse im gesamten Arbeitsblatt.

Mit diesem Befehl müssen Sie eigentlich nur arbeiten, wenn sich Mathcad im manuellen Berechnungsmodus befindet. Wenn Ergebnisse aktualisiert werden müssen, können Sie dies am Wort "Rech" in der Meldungszeile am unteren Fensterrand erkennen. Sie können stattdessen auch [Strg] F9 drücken.

Sollen nur die Diagramme und numerischen Ergebnisse aktualisiert werden, die gerade angezeigt werden, wählen Sie stattdessen im Menü Extras den Befehl Berechnen/Jetzt berechnen.


Extras - Optimieren - Gleichung/Arbeitsblatt

Aktiviert bzw. deaktiviert die symbolische Optimierung. Ob die Optimierung aktiviert ist, erkennen Sie daran, ob neben dem Befehl ein Häkchen vorhanden ist oder nicht. Sie können, falls gewünscht, nur die ausgewählte Gleichung optimieren, indem Sie auf OptimierenÞGleichung klicken. Sie können mit Mathcad aber auch das gesamte Arbeitsblatt optimieren. Wählen Sie dazu OptimierenÞArbeitsblatt.

Wenn die Optimierung aktiviert wird, versucht der symbolische Prozessor, jeden Ausdruck, der sich rechts neben ":=" oder "=" befindet, zu vereinfachen. Ist dies möglich, kennzeichnet er den Bereich mit einem Sternchen und führt die Berechnung anhand des vereinfachten Ausdrucks durch. Sie können sich die einfachere Form anzeigen lassen, indem Sie auf das Sternchen doppelklicken oder im Menü Extras auf OptimierenÞOptimierung anzeigen klicken.

Um die Optimierung wieder zu deaktivieren, wählen Sie erneut denselben Menübefehl, sodass dieser im Menü nicht mehr markiert ist.

Hinweis:

  • Die Optimierung auf Gleichungsebene hat Vorrang vor der Optimierung auf Arbeitsblattebene. Wenn Sie die Arbeitsblattoptimierung aktiviert haben, können Sie anschließend die Optimierung für einen bestimmten Bereich deaktivieren, ohne dass dies Auswirkungen auf andere optimierte Gleichungen auf dem Arbeitsblatt hat.


Extras - Arbeitsblattoptionen

Öffnet ein Dialogfeld mit mehreren Registerkarten:

  • Auf der Registerkarte "Vordefinierte Variablen" können Sie vordefinierte Variablen, wie z. B. "TOL" und "CTOL", ändern.

  • Auf der Registerkarte "Berechnungen" können Sie die Berechnungen steuern, indem Sie sie deaktivieren ode symbolisch optimieren.

  • Auf der Registerkarte "Anzeige" können Sie die Darstellung verschiedener Operatoren wie der Multiplikations-, Ableitungs- und Definitionsoperatoren bestimmen.

  • Auf der Registerkarte "Einheitensystem" können Sie ein Einheitensystem festlegen, mit dem Sie arbeiten wollen.

  • Auf der Registerkarte "Dimensionen" können Sie festlegen, welche Dimensionsnamen für die angezeigten Einheiten verwendet werden sollen.


Dialogfeld "Arbeitsblattoptionen" (Registerkarte "Berechnung")

Auf der Registerkarte "Berechnung" des Dialogfelds "Arbeitsblattoptionen" finden Sie die folgenden Optionen und Schaltflächen:

Automatisch neu berechnen

Wenn diese Option aktiviert ist, berechnet Mathcad alle sichtbaren Ergebnisse und Diagramme automatisch neu. Ist sie nicht aktiviert, dann werden Ergebnisse und Diagramme erst neu berechnet, wenn Sie im Menü Extras die Befehle Berechnen Þ Jetzt berechnen oder Berechnen Þ Arbeitsblatt berechnen auswählen. Diese Funktion lässt sich mithilfe des Befehls BerechnenÞ Automatische Berechnung im Menü Extras schnell steuern.

Bei Matrizen strikte Singularitätsprüfung durchführen

Wenn diese Option aktiviert ist, führt Mathcad eine strengere Prüfung auf Matrixsingularitäten durch als dies in früheren Versionen der Fall war. Daher kann es passieren, dass Sie die Meldung erhalten, dass eine Matrix singulär ist, obwohl Sie bisher die Matrix problemlos auswerten konnten.

Ausdrücke vor der Berechnung optimieren

Wenn diese Option aktiviert ist, ist die Optimierung eingeschaltet, d. h., der symbolische Prozessor versucht, jeden Ausdruck, der sich rechts neben ":=" oder "=" befindet, zu vereinfachen. Ist dies möglich, kennzeichnet er den Bereich mit einem Sternchen und führt die Berechnung anhand des vereinfachten Ausdrucks durch. Sie können den vereinfachten Ausdruck einsehen, wenn Sie auf das Sternchen doppelklicken.

Genaue Gleichheit für Boolesche Vergleiche verwenden

Legt das Standardverfahren für Boolesche Vergleiche fest. Wenn diese Option aktiviert ist, dürfen zwei Zahlen nur um weniger als die maximale Genauigkeit des Gleitkommaprozessors des Computers voneinander abweichen, um als gleich zu gelten. Wenn diese Option nicht aktiviert ist, muss der Betrag der Differenz zwischen zwei Zahlen geteilt durch ihren Durchschnitt < 10-12 sein, damit sie als gleich gelten. Ist die Option aktiviert, gelten Zahlen zwischen -10-307 und 10-307 als 0.

Geschwindigkeitsoptimierung

Legen Sie fest, ob bei Berechnungen die Geschwindigkeit (Mathcad 2001 und höher) oder die Rückwärtskompatibilität (Mathcad 2000 oder früher) optimiert werden soll.


Dialogfeld "Arbeitsblattoptionen" (Registerkarte "Dimensionen")

Auf der Registerkarte "Dimensionen" des Dialogfelds "Arbeitsblattoptionen" finden Sie die folgenden Optionen und Schaltflächen:

Dimensionen anzeigen

Klicken Sie hier, um Ergebnisse mit den im Abschnitt "Dimensionsnamen" gezeigten Dimensionsnamen statt mit den Standardeinheiten anzuzeigen.

Dimensionsnamen

Nachdem Sie auf das Kästchen neben der Option "Dimensionen anzeigen" geklickt haben, können Sie hier beliebige Dimensionsnamen eingeben, die dann in Ergebnissen mit Einheiten verwendet werden.


Dialogfeld "Arbeitsblattoptionen" (Registerkarte "Anzeige")

Auf der Registerkarte "Anzeige" des Dialogfelds "Arbeitsblattoptionen" finden Sie die folgenden Optionen und Schaltflächen:

An der Darstellung der im Abschnitt Darstellung der Operatoren aufgelisteten Operatoren können Sie Änderungen vornehmen. Bestimmen Sie in den Dropdown-Menüs Anzeigen als die Darstellung der Operatoren im Arbeitsblatt:

Multiplikation

Legen Sie fest, wie der Multiplikationsoperator angezeigt werden soll:

Autom. Auswahl | Die Darstellung ist vom Kontext abhängig. Beispiel: 8 z (Wenn eine Variable auf eine Konstante folgt, wird ein kleiner Abstand verwendet.) 8z.9 (Wenn eine Konstante auf eine Variable folgt, wird ein Punkt mit Leerzeichen verwendet.) 2 x 4 (Zwischen zwei Konstanten wird ein x angezeigt.)
Punkt mit Leerzeichen | z . 2
Großer Punkt | z.2
X | z x 2
Kleiner Abstand | z 2
Kein Abstand | z2
Punkt ohne Leerzeichen | z.2

Für Arbeitsblätter, die in älteren Versionen von Mathcad erstellt wurden, ist die Standardeinstellung "Punkt mit Leerzeichen" oder "Punkt ohne Leerzeichen".

Ableitung

Legen Sie fest, wie der Ableitungsoperator angezeigt werden soll:

Ableitung

Partielle Ableitung

Die Standardeinstellung ist "Ableitung".

Tiefgestellter Literalindex

Legen Sie fest, wie der tiefgestellte Literalindex dargestellt werden soll:

Groß | vinit
Klein | vinit

Die Standardeinstellung ist "Klein".

Definition

Legen Sie fest, wie das Definitionssymbol dargestellt werden soll:

Doppelpunkt Gleichheitszeichen | z:=2
Gleichheitszeichen | z=2

Die Standardeinstellung ist "Doppelpunkt Gleichheitszeichen".

Globale Definition

Legen Sie fest, wie das globale Definitionssymbol dargestellt werden soll:

Dreier-Gleichheitszeichen |
Gleichheitszeichen | z=2

Die Standardeinstellung ist "Dreier-Gleichheitszeichen".

Lokale Definition

Legen Sie fest, wie das lokale Definitionssymbol dargestellt werden soll:

Pfeil nach links |
Gleichheitszeichen | z=2

Die Standardeinstellung ist "Pfeil nach links".

Gleichheit

Legen Sie fest, wie der Gleich-Operator angezeigt werden soll:

Fettes Gleichheitszeichen |
Gleichheitszeichen | z=2

Die Standardeinstellung ist "Fettes Gleichheitszeichen".

Hinweise:

  • Wenn Sie die Darstellung einzelner Operatoren in einerm Ausdruck ändern wollen, klicken Sie mit der rechten Maustaste auf den Operator und wählen dann aus dem Kontextmenü [Operator] anzeigen als.


Dialogfeld "Arbeitsblattoptionen" (Registerkarte "Vordefinierte Variablen")

Auf der Registerkarte "Vordefinierte Variablen" des Dialogfelds "Arbeitsblattoptionen" finden Sie die folgenden Optionen und Schaltflächen:

Feldursprung

Steuert die vordefinierte Variable ORIGIN, die den Anfangsindex aller Felder im Arbeitsblatt darstellt. Der Standardwert ist 1.

Konvergenztoleranz

Steuert die vordefinierte Variable TOL, die angibt, mit welcher Genauigkeit Integrale und Ableitungen berechnet werden. Außerdem wird hierdurch die Länge der Iteration in Lösungsblöcken und in der Funktion "wurzel" gesteuert. Der Standardwert ist 0.001.

Toleranz für Nebenbedingungen

Steuert die vordefinierte Variable CTOL, die bestimmt, wie genau eine Nebenbedingung in einem Lösungsblock erfüllt sein muss, damit eine Lösung als akzeptabel gilt. Ein Lösungsblock, der von CTOL gesteuert wird, besteht aus dem Wort Vorgabe, mindestens einer Nebenbedingung, die erfüllt werden muss, sowie einer Optimierungsfunktion: minimieren, maximieren, suchen oder minfehl. Der Standardwert ist 0.001.

Rekursivwert für Zufallszahlen

Weist eine Zufallszahlengenerator-Funktion an, eine bestimmte Folge von Zufallszahlen zu verwenden. Um eine andere Folge von Zufallszahlen zu verwenden, müssen Sie den Wert ändern. Der Standardwert ist 1.

Genauigkeit

Steuert die vordefinierte Variable PRNPRECISION, die die Anzahl der signifikanten Ziffern beim Schreiben in eine ASCII-Datendatei mit der Funktion PRNSCHREIBEN oder PRNANFÜGEN darstellt. Der Standardwert ist 4.

Spaltenbreite

Steuert die vordefnierte Variable PRNCOLWIDTH, die die Breite von Spalten in mit den Funktionen PRNSCHREIBEN oder PRNANFÜGEN erstellten ASCII-Dateien darstellt. Der Standardwert ist 8.

Schaltfläche "Standardwerte wiederherstellen"

Setzt alle Werte auf die Standarwerte zurück (die Angaben in Klammern rechts neben den jeweiligen Werten).


Dialogfeld "Arbeitsblattoptionen": Registerkarte "Einheitensystem"

Auf der Registerkarte "Einheitensystem" des Dialogfelds "Arbeitsblattoptionen" finden Sie die folgenden Optionen und Schaltflächen:

SI (International)

Klicken Sie hier, wenn zur Anzeige der Ergebnisse die Einheiten Meter, Kilogramm, Sekunde, Ampere, Kelvin, Candela und Mol verwendet werden sollen, sofern nichts Anderes festgelegt wurde. Beispiel:

MKS

Klicken Sie hier, wenn zur Anzeige der Ergebnisse die Einheiten Meter, Kilogramm, Sekunde, Coulomb und Kelvin verwendet werden sollen, sofern nichts Anderes festgelegt wurde. Beispiel:

CGS

Klicken Sie hier, wenn zur Anzeige der Ergebnisse die Einheiten Zentimeter, Gramm und Sekunde verwendet werden sollen, sofern nichts Anderes festgelegt wurde. Beispiel:

US

Klicken Sie hier, wenn zur Anzeige der Ergebnisse die Einheiten Fuß, Pfund, Sekunde und Coulomb verwendet werden sollen, sofern nichts Anderes festgelegt wurde. Beispiel:

Kein

Klicken Sie hier, um alle vordefinierten Einheiten zu deaktivieren. Bei den im folgenden Bild rot dargestellten Einheiten handelt es sich um undefinierte Einheiten. Beispiel:


Rechenbereich

Als Rechenbereich gilt ein Bereich mit einem mathematischen Ausdruck oder einem Diagramm. Rechenbereiche sind "aktiv" oder "live". D. h. alle Änderungen innerhalb des Bereichs wirken sich unmittelbar auf andere Rechenbereiche im gesamten Arbeitsblatt aus.


Gleichungsformatvorlage (definiert)

Gleichungsformatvorlage

Eine Gleichungsformatvorlage enthält Angaben zur Schriftart, zur Schriftgröße und zum Schriftstil. Wenn Sie einen Variablennamen eingeben, weist Mathcad der Variable eine Gleichungsformatvorlage namens "Variablen" zu, für die eine bestimmte Schriftart, eine Schriftgröße und ein Schriftstil definiert ist. Auch wenn Sie eine Konstante eingeben, weist Mathcad dieser Konstante eine Rechenformatvorlage zu, diesmal die mit dem Namen "Konstanten", für die ebenfalls eine bestimmte Schriftart, eine Schriftgröße und ein Schriftstil definiert ist.

Wenn Sie sich anzeigen lassen möchten, welche Gleichungsformatvorlage einem bestimmten Namen oder einer bestimmten Zahl gegenwärtig zugewiesen ist, klicken Sie auf den Namen oder die Zahl, und schauen Sie sich den Namen der Rechenformatvorlage in der Schriftartleiste an. Stattdessen können Sie auch im Menü Format den Befehl Gleichung wählen.

Zum Ändern der Schriftartmerkmale einer Formatvorlage gehen Sie wie folgt vor:

  1. Wählen Sie im Menü Format den Befehl Gleichung.

  2. Wählen Sie eine Vorlage aus, und klicken Sie auf "Eigenschaften".

Wenn einem Namen oder einer Zahl eine andere Gleichungsformatvorlage zugewiesen werden soll, gehen Sie wie folgt vor:

  1. Klicken Sie auf den Namen bzw. die Zahl.

  2. Wählen Sie im Menü Format den Befehl Gleichung .

  3. Wählen Sie eine Vorlage aus, und klicken Sie auf "OK".


Symbolleiste "Rechnen"

Über die Schaltflächen auf der Symbolleiste "Rechnen" haben Sie schnellen Zugriff auf die anderen mathematischen Symbolleisten. Welche Symbolleiste mit einer bestimmten Schaltfläche geöffnet wird, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • ein QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche erscheint.

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.

Klicken Sie zum Anpassen der Symbolleiste "Rechnen" mit der rechten Maustaste auf die Schaltflächen dieser Symbolleisten und wählen Sie aus dem Kontextmenü den Befehl Anpassen.


Matrix (Definition)

Als Matrix wird eine tabellarische Anordnung von Zahlen bezeichnet.


Säulenanordnung "Matrix"

Wenn diese Option aktiviert ist, werden die Säulen in der gleichen Weise angeordnet wie die entsprechenden Zahlen in der zugrunde liegenden Matrix.


Operator "Matrixdivision"

Matrixdivision

Tastaturbefehl: /

Dividiert jedes Element von A durch z.

Operanden:

Wenn A eine Matrix ist, ist

z ein Skalar ungleich Null.

Um jedes Element einer aus m x n Elementen bestehenden Matrix A durch das jeweilige Element einer anderen aus m x n bestehenden Matrix B zu teilen, wählen Sie den gesamten Ausdruck und drücken dann Strg+-, um den Operator Vektorisieren einzufügen.


Matrixelement "Proportionale Höhe"

Die Höhe verhält sich proportional zum Wert des Matrixelements.


Operator "Matrixpotenzen"

Matrixpotenzen

Tastaturbefehl: ^

Gibt, abhängig von n, eines der folgenden Ergebnisse zurück:

Ist n = 0, wird die Einheitsmatrix zurückgegeben, deren Dimensionen mit denen von M übereinstimmen.

Ist n = 1, wird lediglich M zurückgegeben.

Ist n = -1, wird die Inverse von M zurückgegeben, falls vorhanden.

Ist n eine positive ganze Zahl, wird M n-mal mit sich selbst multipliziert.

Ist n eine negative ganze Zahl, wird die Inverse von M n-mal mit sich selbst multipliziert.

Operanden:

M ist quadratisch.

n ist eine dimensionslose ganze Zahl.

Matrixpotenzen lassen sich symbolisch auswerten. Gehen Sie hierzu folgendermaßen vor:

Wählen Sie den auszuwertenden Ausdruck aus.

Wählen Sie aus dem Menü Symbolik die Option Vereinfachen.


Matrix-Format für BMPLESEN

Dies müsste eine m x n-Matrix sein, in der jedes Element einem Pixel entspricht. Die Elemente der Matrix sind Zahlen, die den Grauanteil für das jeweilige Pixel angeben.

Die verschiedenen Zahlen haben folgende Bedeutung:

  • 0 steht für Schwarz und 255 für Weiß.

  • Zahlen zwischen 0 und 255 stehen für Graustufen.

  • Zahlen unter 0 und über 255 gelten als Modulo von 255.

  • Dezimalzahlen werden auf die nächste ganze Zahl gerundet.


Matrix für RGBLESEN

Dies müsste eine m x 3n-Matrix sein. Sie können sich eine solche Matrix als Aneinanderreihung von drei m x n-Matrizen vorstellen:

Die ersten n Spalten stehen für die rote Farbkomponente des n x m-Bildes. Die zweiten und dritten n Spalten stehen für den Grün- und Blauanteil desselben Bildes.


Operator "Inverse Matrix"

Tastaturbefehl: ^-1

Gibt die Inverse einer Matrix zurück. Wenn es für M keine Inverse gibt, erscheint eine entsprechende Fehlermeldung.

Operanden:

  • M ist eine quadratische Matrix, für die es eine Inverse gibt.


Die Matrix ist singulär, Ihre Inverse kann nicht berechnet werden.

Die Matrix ist singulär. Ihre Inverse kann nicht berechnet werden.

Diese Matrix darf weder singulär noch fast singulär sein. Eine Matrix gilt als singulär, wenn ihre Determinante gleich null ist. Eine Matrix ist annähernd singulär, wenn sie eine hohe Bedingungszahl aufweist.


Operator "Matrixmultiplikation"

Matrixmultiplikation

Tastaturbefehl: *

Gibt das Matrixprodukt von A und B zurück.

Operanden:

Ist A eine Matrix mit m x n Elementen, so ist

B eine Matrix mit n x p Elementen.

Hinweise:

  • Ist A eine Matrix und x ein Skalar, dann ist das Produkt von A und x eine Matrix, in der jedes Element von A mit x multipliziert wurde.

  • Zur Berechnung des gliedweisen Produkts von zwei gleich großen Feldern A und B wählen Sie den gesamten Ausdruck aus, und drücken Sie Strg+-, um den Operator Vektorisieren einzufügen.


Durch lu-Funktion zurückgegebene Matrix


Symbolleiste "Matrix"

Über die Symbolleiste "Matrix" haben Sie schnellen Zugriff auf die Matrix- und Vektoroperatoren. Sie können sehen, wozu die einzelnen Schaltflächen dienen, wenn Sie den Cursor im Haupt-Arbeitsblattfenster über die Schaltfläche setzen, bis:

  • eine QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche erscheint.

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


Maxima und Minima eines Feldes

max(A, B, C, ...) Übergibt den größten Wert aus A, B, C, ...

min(A, B, C, ...) Übergibt den kleinsten Wert aus A, B, C, ...

Argumente:

  • A, B, C, ... können Felder, Skalare oder Zeichenfolgen sein.

Enthält ein Wert komplexe Elemente, so gilt Folgendes:

  • max(A, B, C, ...) übergibt den größten Realteil eines Werts plus dem i-Fachen des größten imaginären Teils eines enthaltenen Werts.

  • min(A, B, C, ...) übergibt den kleinsten reellen Teil eines Werts plus dem i-Fachen des kleinsten imaginären Teils eines enthaltenen Werts.


Minimieren oder Maximieren einer Funktion

Minimieren(f, var1, var2, ...) Gibt die Werte var1, var2, ... zurück, die die Nebenbedingungen in einem Lösungsblock erfüllen und die dafür sorgen, dass die Funktion f ihren kleinsten Wert annimmt.

Maximieren(f, var1, var2, ...) Gibt die Werte var1, var2, ... zurück, die die Nebenbedingungen in einem Lösungsblock erfüllen und die dafür sorgen, dass die Funktion f ihren größten Wert annimmt.

Argumente:

  • var1, var2, ... sind skalare Variablen im Lösungsblock. Sie sind oberhalb des Lösungsblocks als Schätzwerte definiert.

  • f ist eine über dem Lösungsblock definierte Funktion. So könnte sich z. B. ein Argument g auf die Funktion g(x,y):=x/y beziehen.

Arbeiten mit den Funktionen:

Gehen Sie bei der Verwendung der Funktion minimieren bzw. maximieren wie folgt vor:

  • Definieren Sie die Funktion, die maximiert bzw. minimiert werden soll.

  • Definieren Sie Schätzwerte für die Variablen, nach denen aufgelöst werden soll.

  • Geben Sie das Wort Vorgabe ein, um den Lösungsblock zu starten.

  • Geben Sie unter Vorgabe unter Verwendung Boolescher Operatoren Gleichungen und Ungleichungen ein, die als Nebenbedingungen fungieren.

  • Geben Sie die Funktion Minimieren bzw. Maximieren mit den entsprechenden Argumenten ein.

Hinweise:

  • Diese Funktionen geben einen Skalar zurück, wenn nur eine Variable enthalten ist. Andernfalls geben Sie einen Vektor zurück, dessen erstes Element var1, dessen zweites Element var2 usw. ist.

  • Wenn es keine Nebenbedingungen gibt, muss das Wort Vorgabe nicht eingegeben werden.

  • Bei der Eingabe der Funktionen Minimieren und Maximieren brauchen Sie nicht auf die Groß- und Kleinschreibung zu achten.

Beispiele:

Lineare und nichtlineare Funktionen maximieren und minimieren


Maximieren eines Fensters

Klicken Sie auf das Symbol für Maximieren in der rechten oberen Ecke des Fensters.


Mblau


MCM-Datei

Was ist eine MCM-Datei?

Eine MCM-Datei wird erstellt, wenn Sie eine benutzerdefinierte Skriptobjekt-Komponente aus einem Mathcad-Arbeitsblatt speichern. Sobald ein Skriptobjekt in einer MCM-Datei gespeichert wurde, kann diese an andere Mathcad-Benutzer weitergegeben werden. Auf diese Weise wird ihnen die benutzerdefinierte Komponente zugänglich gemacht.


Mittelwert (Funktion)

Argumente:

A, B, C, ... sind Felder mit m x n Elementen oder Skalare.

Beispiele:

Weitere Funktionen für die Datenanalyse...


Median (Funktion)

median(A, B, C, ...) Übergibt den Median aus A, B, C, ...

Argumente:

A, B, C, ... sind Felder oder Skalare.

Hinweis:

Der Median ist der Wert in der Mitte der Gesamtanzahl der Werte (über und unter dem Median sind gleich viele Werte vorhanden). Wenn die Anzahl der Elemente gerade ist, entspricht der Median dem arithmetischen Mittel der beiden Werte im Zentrum des Feldes.

Beispiele:

Weitere Funktionen für die Datenanalyse...


Menübefehle

Datei

Bearbeiten

Ansicht

Einfügen

Format

Extras

Symbolik

Fenster

Hilfe


Beispiel für ErstellenGitter

Angenommen sei die folgende Funktion:

Sie erstellen einen Graphen für die Funktion F, indem Sie den Funktionsnamen unter den Definitionen eingeben und im Menü Einfügen den Befehl Diagramm / Flächendiagramm wählen. Das Ergebnis ist ein 3D-Flächendiagramm der Funktion mit den folgenden Standardeinstellungen: ein Bereich von -5 bis +5 für x und y, ein Punktgitter von 20x20, die Umsetzung in einem kartesischen Koordinatensystem.

Angenommen, Sie möchten den Bereich für x und y auf -10 bis +10 erweitern und die Anzahl der Gitterlinien für x erhöhen sowie für y senken. Hierzu können Sie die Funktion ErstellenGitter folgendermaßen verwenden:

Die Änderungen im Graphen sind klar zu erkennen.

Es ist zwar nicht erforderlich, jedes Argument von ErstellenGitter einer Variable zuzuweisen, es verbessert jedoch die Übersichtlichkeit der Struktur.


Methoden für Sortierfunktionen

Die Mathcad-Sortierroutine für die Sortierfunktionen sort, spsort und zsort arbeitet mit einem Stapelsortieralgorithmus. Eine vollständige Beschreibung finden Sie in Numerical Recipes in C von William H. Press, Brian P. Flannery, Saul A. Teukolosky und William T. Vetterling (Cambridge University Press, 1986).

Die Stapelsortierroutine ist keine stabile Sortierung. Wenn Sie also eine Matrix an einer Spalte sortieren, die gleiche Elemente enthält, werden die Zeilen mit diesen Elementen im sortierten Feld nebeneinander positioniert, erscheinen jedoch in zufälliger Reihenfolge.


Mgrün


Minimieren eines Fensters

Klicken Sie auf das Symbol für Minimieren in der rechten oberen Ecke des Fensters.


Verschiedene Funktionen

mod(x, y)

Gibt x mod y zurück, den Rest aus der Division von x durch y.

winkel(x,y)

Winkel von der x-Achse zum Punkt (x,y).


Gemischte Ganzzahlenprogrammierung

Programmierung mit gemischten Ganzzahlen (Mixed Integer Programming, MIP)

Bei der Programmierung mit gemischten Ganzzahlen (MIP) werden Gleichungen so gelöst bzw. Funktionen so optimiert, dass die Variablen ganzzahlige oder binäre Werte annehmen.

Wenn Sie das Extension Pack "Solving and Optimization" (Expert Solver) installiert haben, steht die gemischte Ganzzahlenprogrammierung zu Ihrer Verfügung. Sie können zum Beispiel die Gleichung y+x=1,1 lösen und dabei erzwingen, dass Mathcad entweder ganzzahlige oder binäre Werte als Ergebnis für x und y ausgibt.

  1. Erstellen Sie ein Gleichungssystem: Verwenden Sie eine der folgenden Funktionen: suchen, minfehl, minimieren oder maximieren.

  2. Geben Sie als letztes Argument der Funktion eine Zeichenfolge ein. Die Anzahl der Zeichen muss der Anzahl der Variablen entsprechen, nach denen Sie auflösen oder die Sie optimieren möchten. Wenn Sie zum Beispiel nach drei unbekannten Variablen auflösen möchten, geben Sie eine aus drei Zeichen bestehende Zeichenfolge ein. Jedes Zeichen bestimmt die Art des zu übergebenden Werts. Folgende Zeichen sind zulässig:

I (für eine ganze Zahl)

C (für eine Zahl im kontinuierlichen Bereich)

B (für eine Binärzahl)

Beispiel:

Hinweis:

  • MIP ist nur auf lineare oder quadratische Ausdrücke anwendbar.


Operator "Gemischte Zahl"

Tastaturbefehl: Strg +

Gibt den Wert von k + m/n zurück.

Operanden:

k, m und n sind Ganzzahlen.


Gemischte Zahlen

Zum Eingeben einer gemischten Zahl gehen Sie folgendermaßen vor:

  1. Fügen Sie den Operator für gemischte Zahlen ein, indem Sie Strg++ eingeben oder in der Symbolleiste "Taschenrechner" auf die entsprechende Schaltfläche klicken.

  2. Geben Sie in den Platzhalter links außen die ganze Zahl ein. Geben Sie in die beiden anderen Platzhalter die Bruchzahl ein.

Beispiel:

Zum Anzeigen eines Ergebnisses als gemischte Zahl gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf das Ergebnis, um das Dialogfeld "Ergebnisformat" anzuzeigen.

  2. Wählen Sie auf der Registerkarte "Zahlenformat" die Option "Bruch", um das Ergebnis als Bruch darzustellen.

  3. Aktivieren Sie die Option "Gemischtes Zahlenformat verwenden".


Funktion "mode"

mode(A, B, C usw.) Übergibt den Wert in A, B, C, ... , der am häufigsten auftritt.

Argumente:

A, B, C, ... sind Felder oder Skalare.

Wenn in A, B, C, ... kein Wert häufiger auftritt als ein anderer, wird eine Fehlermeldung angezeigt, aus der hervorgeht, dass es keinen häufigsten Wert gibt.

Beispiel:

Weitere Funktionen für die Datenanalyse...


Abweichungen von der Levenberg-Marquardt-Methode

Die Levenberg-Marquardt-Methode wurde in einigen Punkten zugunsten einer verbesserten Praxistauglichkeit für Mathcad verändert:

  • Bei der ersten Unterbrechung des Algorithmus an einem Punkt, der keine Lösung darstellt, addiert Mathcad einen zufällig gewählten Betrag zu allen Variablen und beginnt von neuem. Dadurch kann ein Rechenabbruch aufgrund örtlicher Minimalwerte und anderer Werte, an denen keine Vorgaberichtung festgestellt werden kann, weitgehend vermieden werden. Mathcad führt diesen Schritt in jedem Lösungsvorgang nur einmal durch, also an der ersten Stelle, an der die Routine unterbrochen wird, ohne dass eine Lösung vorliegt.

  • Wenn Sie Ungleichheitsnebenbedingungen in ein Gleichungssystem aufnehmen, löst Mathcad das nur aus den Ungleichheiten bestehende Teilsystem zuerst und bewertet erst dann die Gleichheitsnebenbedingungen für die vollständige Lösung. Dadurch werden die Schätzwerte in einen Bereich gelegt, in der alle Ungleichheitsnebenbedingungen erfüllt sind, bevor der eigentliche Algorithmus ausgeführt wird.


Modifizierter interner Zinsfuss

mizf(v, fin_satz, rein_rate) Übergibt den modifizierten internen Zinsfuß für eine Reihe von regelmäßigen Zahlungen auf der Basis eines Finanzierungssatzes, der auf die geliehenen Zahlungen anfällt, und eines Wiederanlagesatzes für die Geldzahlungen bei deren Wiederanlage.

Argumente:

v ist ein Vektor für regelmäßig anfallende Zahlungen. v muss mindestens einen positiven und einen negativen Wert enthalten.

fin_satz ist der Finanzierungssatz, der für geliehene Zahlungen anfällt.

rein_rate ist der Wiederanlagesatz für die Geldzahlungen bei deren Wiederanlage.

Beispiel:

Für die Gründung eines Unternehmens nehmen Sie ein Darlehen über EUR 10.000 mit einem Finanzierungssatz von 9.7% auf. Sie erwarten einen Gewinn von jeweils EUR 1.000, EUR 2.500, EUR 3.000 und EUR 5.000 in den ersten fünf Jahren und legen den jährlichen Gewinn bei einem Satz von 10.0% wieder an. Der modifizierte interne Zinsfuß wäre dann:


Symbolleiste "Modifikator"

Über die Schaltflächen auf der Symbolleiste "Modifikator" können Sie Modifikatoren einfügen, die für die symbolischen Schlüsselwörter auf der Symbolleiste "Symbolik" benötigt werden. Welche Funktionen die einzelnen Schaltflächen haben, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • ein QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche erscheint.

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


Ändern einer Gleichungsformatvorlage

Zum Bearbeiten von mit einer bestimmten Gleichungsformatvorlage verknüpften Schriftattributen gehen Sie wie folgt vor:

  1. Wählen Sie im Menü Format die Option Gleichung.

  2. Wählen Sie im Dialogfeld "Gleichungsformat" das Format aus, dessen Eigenschaften Sie ändern möchten. Der Name der gewählten Formatvorlage erscheint im Textfeld "Name der Vorlage". Sofern Sie nicht die Schriftart für alle Variablen bzw. alle Konstanten ändern wollen, müssen Sie die Änderungen an einer "Benutzer"-Formatvorlage vornehmen.

  3. Ändern Sie gegebenenfalls den Namen der Formatvorlage, indem Sie den neuen Namen im Textfeld "Neuer Name der Vorlage" eingeben. Eine Änderung des Namens der Vorlage ist vorteilhaft, weil man sich auf diese Weise leichter merken kann, über welche Schriftartattribute die Vorlage verfügt.

  4. Klicken Sie auf die Schaltfläche "Ändern".

  5. Wählen Sie die gewünschten Schriftattribute im Dialogfeld aus. Wenn Sie die Attributkombination nach Ihren Anforderungen bestimmt haben, wählen Sie im Schriftarten-Dialogfeld und im Dialogfeld "Gleichungsformat" jeweils "OK".

Wenn Sie die mit einer Rechenformatvorlage verknüpften Schriftartattribute ändern, ändert sich die Schriftart aller Variablen bzw. Konstanten, denen diese Formatvorlage zugewiesen ist.


Ändern der Standardvorlage

Wenn Sie ein Arbeitsblatt erstellen, wählen Sie eine Vorlage aus, auf der dieses Arbeitsblatt basieren soll. Standardmäßig verwendet Mathcad die Vorlage NORMAL.MCT. Sie haben folgende Möglichkeiten:

  • Sie können die Vorlage NORMAL.MCT wie jede andere Vorlage auch ändern, oder

  • Sie erstellen eine neue Vorlage und ersetzen die Vorlage NORMAL.MCT durch die neu erstellte Vorlage. Dieses Verfahren empfiehlt sich vor allem dann, wenn die Vorlage NORMAL.MCT unverändert erhalten bleiben soll. Gehen Sie dazu wie folgt vor:

    1. Öffnen Sie die Datei NORMAL.MCT, die sich im Ordner \template des Mathcad-Ordners befindet.

    2. Wählen Sie im Menü Datei die Option Speichern unter und geben Sie einen Namen wie z. B. NORMALOLD.MCT ein. Damit wird die Vorlagendatei gespeichert und steht Ihnen für eine eventuelle spätere Verwendung zur Verfügung.

    3. Erstellen Sie eine neue Vorlage, die als Standardvorlage fungieren soll. Benennen Sie diese Vorlage "NORMAL.MCT", und speichern Sie sie im Ordner \template des Mathcad-Ordners.


Modulusfunktion

mod(x,y) Diese Funktion gibt den Rest aus der Division von x durch y zurück. Das Ergebnis hat dasselbe Vorzeichen wie x.

Argumente:

x und y müssen beide reelle Skalare sein.

y muss ungleich Null sein.


Verschieben eines Fensters

Positionieren Sie den Mauszeiger auf der Titelleiste des Fensters, drücken Sie die Maustaste, und ziehen Sie das Fenster mit der Maus. Befindet sich das Fenster an der gewünschten Stelle, können Sie die Maustaste loslassen.


Verschieben des Fadenkreuz-Cursors

Zum Verschieben des Fadenkreuz-Cursors klicken Sie auf eine andere leere Stelle, oder drücken Sie die Pfeiltasten, um ihn in die entsprechende Richtung zu bewegen. Mit der Bild-auf-Taste und der Bild-ab-Taste können Sie ihn ca. 80% der Fensterhöhe nach oben oder unten versetzen.


Verschieben der Texteinfügemarke

Folgendermaßen können Sie die Texteinfügemarke verschieben:

Verwenden Sie die Pfeiltasten, um die Einfügemarke zeichenweise oder zeilenweise im Text zu verschieben. Durch Drücken von Strg und einer Pfeiltaste wird die Einfügemarke um ganze Wörter bzw. Absätze verschoben.

Klicken Sie in den Text.


Verschieben der Symbolleisten

Zum Verschieben einer Symbolleiste gehen Sie folgendermaßen vor:

  1. Setzen Sie den Mauszeiger an eine Stelle außerhalb von Schaltflächen oder Textfeldern.

  2. Drücken Sie die Maustaste, halten Sie sie gedrückt, und ziehen Sie die Maus.

Sie werden sehen, dass einige Symbolleisten entsprechend der Position, an die Sie sie ziehen, neu angeordnet werden. Andere behalten ihre Form unabhängig von der Verschiebung mit der Maus bei.


Mrot


Operator "Multiplikation"

Tastaturbefehl: *

Gibt das Produkt von y und x zurück.

Operanden:

x und y sind Skalare.

Mathcad unterstützt auch die implizierte Multiplikation, d. h., Sie müssen nicht unbedingt den Multiplikationsoperator zwischen Konstanten und Variablen verwenden. Wenn Sie z. B. "5x" eingeben, versteht Mathcad dies als "5*x".

Bei den Variablen o und h wird keine implizierte Multiplikation durchgeführt, da diese für die Eingabe von oktalen und hexadezimalen Zahlen reserviert sind.

Sie können die Darstellung des Operators ändern, sodass er als großer Punkt, als X, als kleiner Abstand oder als kein Abstand dargestellt wird.


Mehrwertige Funktionen und Operatoren

Als allgemeine Regel gilt, dass Mathcad bei mehrwertigen Funktionen oder Operatoren stets 0.5 + .866i zurückgibt, und das trotz der Tatsache, dass die Kubikwurzel von -1 gewöhnlich mit 1 angegeben wird.

Die einzige Ausnahme von dieser Regel ist der Operator für die n-te Wurzel. Dieser Operator gibt immer eine reelle Wurzel zurück, falls es eine solche gibt.


Multivariable kubische Spline-Interpolation

Mit der zweidimensionalen kubischen Spline-Interpolation können Sie eine Fläche so durch ein Raster von Punkten verlaufen lassen, dass die erste und die zweite Ableitung der Kurve an jedem Punkt stetig ist. Diese Fläche entspricht einem kubischen Polynom in x und y, bei dem die erste und zweite Ableitung in der entsprechenden Richtung an jedem Rasterpunkt stetig ist.

kspline(Mxy,Mz) Gibt einen Vektor aus den zweiten Ableitungen für die Datenfelder Mxy und Mz zurück. Dieser Vektor wird als das erste Argument der Funktion interp verwendet. Die sich dabei ergebende Fläche ist an den Rändern des von Mxy abgedeckten Bereichs kubisch.

pspline(Mxy,Mz) Wie kspline, die sich ergebende Fläche ist jedoch an den Rändern parabolisch.

lspline(Mxy,Mz) Wie kspline, die sich ergebende Fläche ist jedoch an den Rändern linear.

interp(vs,Mxy,Mz,v) Gibt einen Spline-interpolierten Wert von Mz an den Koordinaten x und y zurück, die in v angegeben wurden.

Argumente:

Mxy ist ein aus n x 2 Elementen bestehendes Feld mit den x- und y-Koordinaten entlang der Diagonalen des rechtwinkligen Gitters, über das interpoliert werden soll.

Mz ist ein aus n x n Elementen bestehendes Feld mit reellen Daten. Dabei handelt es sich um die z-Werte, die den x- und y-Werten in Mxy entsprechen.

vs ist ein Vektor, der von kspline, pspline oder lspline generiert wird.

v ist ein Vektor, der den x- und den y-Wert für den Punkt enthält, an dem der interpolierte Wert für z ermittelt werden soll. Zugunsten der Ergebnisgenauigkeit sollten für x und y Werte gewählt werden, die im Bereich der Gitterpunkte liegen.


Multivariable Polynomregression

regress(Mxy,vz,n) Gibt einen Vektor zurück, mit dem interp die Polynomfläche n-ter Ordnung sucht, die den Datenwerten x, y und z am ehesten entspricht.

interp(vs,Mxy,vz,v) Gibt den z-Wert zurück, der den in v angegebenen Werten für x und y entspricht.

Argumente:

Mxy ist eine aus m x 2 Elementen bestehende Matrix mit x- und y-Koordinaten.

vz ist ein aus m Elementen bestehender Vektor mit den z-Koordinaten, die den in Mxy angegebenen m Punkten entsprechen.

vs ist der von regress generierte Vektor.

n ist eine a positive positive ganze Zahl, die die Ordnung der Polynomfläche für die Datenanpassung angibt. Führ gewöhnlich gilt n < 5.

v ist ein Vektor mit zwei Elementen, die aus den x- und y-Werten bestehen, für die Sie die entsprechende z-Koordinate auf der Regressionsfläche berechnen wollen.

Hinweise:

  • Regress erweist sich als sinnvoll, wenn Sie verschiedene gemessene y-Werte haben, die x-Werten entsprechen, und ein einzelnes Polynom beliebiger Ordnung an diese y-Werte angepasst werden soll.

  • Für die Funktion regress können beliebig viele unabhängige Variablen festgelegt werden. Bei mehr als vier unabhängigen Variablen oder bei einem Grad der Polynomfläche von mehr als vier benötigt regress jedoch wesentlich mehr Speicher und Rechenzeit.

Zudem muss die Zahl der Datenwerte m folgende Voraussetzung erfüllen:

wobei k die Anzahl der unabhängigen Variablen, ausgedrückt als Anzahl der Spalten in Mxy, ist.

  • Immer, wenn Sie die Funktion regress verwendet haben, sollten Sie die Funktion interp einsetzen.

  • Da die Funktion regress versucht, alle Ihre Datenpunkte mit einem einzigen Polynom abzudecken, kommt es zu keinem sinnvollen Ergebnis, wenn sich Ihre Daten nicht wie ein Einzelpolynom verhalten.


Multivariable Polynomregression, lokalisiert

loess(Mxy,vz,bereich) Gibt einen Vektor zurück, mit dem "interp" versucht, eine Reihe von Polynomflächen zweiter Ordnung zu finden, die den Datenwerten x, y und z, die in Mxy und vz festgelegt sind, innerhalb einer Umgebung von x- und y-Datenwerten am ehesten entsprechen. Dabei bestimmt "bereich" die Größe dieser Umgebung.

interp(vs,Mxy,vz,v) Gibt den z-Wert zurück, der den in v angegebenen Werten für x und y entspricht.

Argumente:

Mxy ist eine aus m x 2 Elementen bestehende Matrix mit x- und y-Koordinaten.

vz ist ein aus m Elementen bestehender Vektor mit z-Koordinaten, die den in Mxy angegebenen m Punkten entsprechen.

vs ist der Vektor, der von loess oder regress generiert wird.

bereich ist eine positive reelle Zahl, mit der die Größe der gewünschten Umgebung angegeben wird. Für "bereich" sind große Werte zu empfehlen, wenn sich die Daten über verschiedene Bereiche von x sehr unterschiedlich verhalten. Ein geeigneter Standardwert ist "bereich=0.75".

v ist ein Vektor mit zwei Elementen, die aus den x- und y-Werten bestehen, für die Sie die entsprechende z-Koordinate auf der Regressionsfläche berechnen wollen.

Hinweise:

  • Sie können die Funktion loess verwenden, wenn Sie eine Reihe gemessener z-Werte haben, die x- und y-Werten entsprechen, und Sie eine Polynomfläche durch diese z-Werte anpassen wollen.

  • Die Funktion loess ist auf maximal vier unabhängige Variablen begrenzt.

  • Immer, wenn Sie die Funktion loess verwendet haben, sollten Sie die Funktion interp einsetzen.

  • loess versucht, unterschiedliche Polynome zweiter Ordnung in Abhängigkeit davon anzupassen, wo Sie sich auf der Kurve befinden. Dies erfolgt, indem die Daten in einer engen Umgebung des Punktes, der von Interesse ist, geprüft werden. Die Größe dieser Umgebung legen Sie über das Argument "bereich" fest. Wenn "bereich" größer wird, entspricht loess der Funktion regress mit n=2.


Muss 1 komplexe Matrix oder 2 reelle Matrizen sein.

Beim Erstellen eines Vektorfelddiagramms geben Sie entweder eine Matrix mit komplexen Zahlen oder zwei reelle Matrizen mit der gleichen Anzahl von Zeilen und Spalten an.

Wenn Sie eine komplexe Matrix verwenden, sollte sie folgende Merkmale haben:

  • Die Zeilen und Spalten stehen für die x- bzw. y-Koordinaten.

  • Der reelle Teil eines jeden Matrixelements ist die x-Komponente des zu dieser Zeile und Spalte gehörigen Vektors.

  • Der imaginäre Teil eines jeden Matrixelements ist die y-Komponente des zu dieser Zeile und Spalte gehörigen Vektors.

Wenn Sie zwei aus m x n Elementen bestehende Matrizen reeller Zahlen verwenden, gilt:

  • Die erste Matrix sollte die x-Komponenten der Vektoren enthalten, und

  • die zweite Matrix sollte die y-Komponenten der Vektoren enthalten.


Muss reeller Skalar sein.

Dieser Wert kann nicht komplex oder imaginär sein. Wenn Sie beim Arbeiten mit einer vordefinierten Funktion weitere Informationen benötigen, klicken Sie auf den Funktionsnamen und drücken Sie F1.


Dies muss ein Vektor aus reellen Elementen sein.

Dieser Vektor kann keine komplexen oder imaginären Elemente aufweisen. Der Vektor muss außerdem ein Spaltenvektor (1 Spalte, mehrere Zeilen) sein, und kein Zeilenvektor (1 Zeile, mehrere Spalten).


Muss zwischen zwei Sperrbereichen liegen.

Bevor Sie den Befehl Bereich / Sperren aus dem Menü Format aufrufen können, müssen Sie in eine gesperrte Region im Arbeitsblatt klicken.


Der Wert muss größer oder glelich 10^-16 sein.

Dieser Wert muss größer oder gleich 10^-16 sein. Wenn Sie beim Arbeiten mit einer vordefinierten Funktion weitere Informationen benötigen, klicken Sie auf den Funktionsnamen und drücken Sie F1.


Dieser Wert muss eine ganze Zahl größer als 1 sein.

Dieser Wert muss mindestens 1 betragen. Wenn Sie beim Arbeiten mit einer vordefinierten Funktion weitere Informationen benötigen, klicken Sie auf den Funktionsnamen und drücken Sie F1.


Muss kleiner als die Anzahl der Datenpunkte sein.

Der Wert dieses Arguments muss kleiner als die Zahl der vorhandenen Datenpunkte sein. Wenn Sie beim Arbeiten mit einer vordefinierten Funktion weitere Informationen benötigen, klicken Sie auf den Funktionsnamen und drücken Sie F1.


Dieser Wert muss eine ungerade ganze Zahl sein.

Dieses Argument muss eine ungerade ganze Zahl sein.

Wenn Sie beim Arbeiten mit einer vordefinierten Funktion weitere Informationen benötigen, klicken Sie auf den Funktionsnamen und drücken Sie F1.


Muss ein oder zwei Spalten haben.

Das erste Matrixargument in den Funktionen für kubische Spline-Kurven muss entweder eine oder zwei Spalten aufweisen. Für die Interpolation multivariabler kubischer Spline-Kurven sind zwei Spalten erforderlich.


Muss 3 Vektoren oder 1 Matrix haben.

Muss drei Vektoren oder eine Matrix haben.

Sie müssen die Namen von drei Vektoren (durch Kommas voneinander getrennt) oder einen Namen oder eine Matrix angeben. Zum Beispiel ist dies erforderlich, wenn Sie ein Vektorfelddiagramm erstellen.


Dimensionen müssen >4 sein.

Diese Matrix muss mindestens vier Zeilen und Spalten enthalten.


Operator "Negation"

Negation

Tastaturbefehl: -

-x

Gibt den negativen Wert des Operanden zurück.

Operanden:

x ist ein Skalar.


Operator "Negation von Feldern"

Negation von Feldern

Tastaturbefehl: –

–A

Gibt ein Feld mit derselben Größe wie A zurück, das die negativen Werte der einzelnen Elemente in A enthält. Entspricht der Multiplikation von A mit -1.

Operanden:

A ist ein Feld.


Negative Binomial-Verteilung

Der negativen Binomial-Gleichung zugeordnete Verteilungen:

dnbinom(k,n,p) Gibt die Wahrscheinlichkeitsdichte für die negative Binomial-Verteilung zurück.

pnbinom(k,n,p) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qnbinom(p,n,r) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rnbinom(m,n,p) Gibt einen Vektor aus m Zufallszahlen zurück, die die negative Binomial-Verteilung aufweisen.


Gegenwärtiger Nettowert

gnw(zsatz, v) Berechnet den gegenwärtigen Nettowert einer Kapitalanlage bei einem gegebenen Abzinsungsfaktor und regelmäßigen Zahlungen.

Argumente:

zsatz ist der feste Zinssatz einer Kapitalanlage pro Verzinsungsperiode. zsatz muss ein reeller Skalar sein. zsatz kann als Dezimalzahl (z. B. 0.0825) oder als Prozentsatz (z. B. 8.25%) ausgedrückt werden.

v ist ein Vektor für regelmäßig anfallende Zahlungen.

Hinweise:

  • Für zwz wird davon ausgegangen, dass die Zahlung am Ende der Verzinsungsperiode erfolgt.

  • Im Vektor v für die Zahlungen müssen die ausgehenden Zahlungen als negative und die eingehenden Zahlungen als positive Beträge angegeben werden.

  • Die Kapitalanlage gnw beginnt eine Periode vor dem Tag der ersten Zahlung und endet mit der letzten Zahlung in der Liste.


Nächste Seite

Zeigt die nächste Seite Ihres Arbeitsblatts in der Seitenansicht an. Wenn diese Option abgeblendet dargestellt ist, verfügt Ihr Arbeitsblatt über keine weiteren Seiten.


Keine Antwort gefunden

Bei der symbolischen Auswertung konnte keine genaue Lösung für die Gleichung gefunden werden, die Sie zu lösen versuchten.


Stapelgrenze erreicht. Keine Antwort gefunden

Bei der symbolischen Auswertung wurde die Grenze des internen Ausdrucksstapels erreicht, ohne dass die eigentlich gewünschte Auswertung oder Vereinfachung durchgeführt werden konnte.


Keine Bitmaps in Arbeitsblatt gefunden.

Diese Fehlermeldung wird angezeigt, wenn Sie im Menü Format den Eintrag Farbe / Palette optimieren wählen. Dieser Befehl sollte nur verwendet werden, wenn Bitmaps in einem Arbeitsblatt eingebettet sind.


Keine geschlossene Form für ... gefunden

Bei der symbolischen Auswertung konnte kein unbegrenztes Integral für den zu integrierenden Ausdruck bzw. keine geschlossene Form für die Summe oder das Produkt, die bzw. das ausgewertet werden sollte, gefunden werden.


Keine Lösung gefunden.

Mathcad hat keine Lösung gefunden. Klicken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, auf den Funktionsnamen, und drücken Sie dann F1, um zu sehen, ob Sie die Funktion korrekt verwenden. Es ist jedoch möglich, dass keine Lösung vorhanden ist.


Nominaler Zinssatz

nom(zatz, nper) Übergibt den nominalen Zinssatz auf der Basis des effektiven Zinssatzes und der Anzahl der Verzinsungsperioden pro Jahr.

Argumente:

zsatz ist der effektive jährliche Zinssatz. zsatz ist ein reeller Skalar. zsatz kann als Dezimalzahl, z. B. ,0825, oder als Prozentzahl, z. B. 8.25%, ausgedrückt werden. zsatz [image] -1.

nper ist die Gesamtzahl der Verzinsungsperioden pro Jahr. nper>0.

Beispiel:

Ein Darlehen oder eine Kapitalanlage mit einer Laufzeit von 30 Jahren und einem effektiven Jahreszins von 10,5014% hat einen nominalen Zinssatz von:

nom(.105014,360) = 9,987 %


Norm einer Matrix

norm1(M) Gibt die Norm [image] der Matrix M zurück.

norm2(M) Gibt die Norm [image] der Matrix M zurück.

norme(M) Gibt die Euklidische Norm der Matrix M zurück.

normi(M) Gibt die infinite Norm der Matrix M zurück.

Argumente:

  • M muss eine Quadratmatrix sein.


Normalverteilung

Der Normalgleichung zugeordnete Verteilungen:

dnorm(x, m , s) Gibt die Wahrscheinlichkeitsdichte für die Normalverteilung zurück.

pnorm(x, m , s) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

knorm(x) Gibt die kumulative Wahrscheinlichkeitsverteilung mit dem Mittelwert 0 und der Varianz 1 zurück.

qnorm(p, m , s) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rnorm(m, m , s) Gibt einen Vektor aus m Zufallszahlen zurück, die die Normalverteilung aufweisen.


Dies ist kein Skalar.

Drücken Sie F1, um die Hilfe aufzurufen.

Sie haben einen Vektor oder einen Ausdruck mit einem Bereich bzw. einen anderen Ausdruck verwendet, für den ein Skalar erforderlich ist.


Nicht genügend Speicher für diese Operation.

Es ist nicht ausreichend Arbeitsspeicher für diese Berechnung verfügbar. Versuchen Sie, etwas Speicherplatz zu schaffen, indem Sie das Feld oder die Matrix verkleinern (Mathcad belegt etwa 8 Byte Speicherplatz pro Matrixelement) oder große Bitmaps, Felder oder Matrizen löschen.


Operator "Ungleich"

Ungleich

Tastaturbefehl: Strg+3

x [image] y

Gibt 1 zurück, wenn x [image] y, andernfalls 0.

Operanden:

x und y können reelle oder komplexe Skalare bzw. Felder sein.


Operator "Nicht"

Nicht

Tastaturbefehl: Strg+Umschalt+1

x Gibt 1 zurück, falls x Null (falsch) ist. Andernfalls wird 0 zurückgegeben.

Operanden:

x ist ein reeller oder komplexer Skalar.

Hinweis:

Der Wert Null steht für FALSCH, alle Werte ungleich Null für WAHR.


Hinweise zum S-PLUS-Skriptcode

Bei der Bearbeitung der Komponente "S-Plus-Skript" wird der S-PLUS-Code, der mehrere Aussagen enthalten kann, in eine automatisch erstellte Funktion zum Ausführen der Komponente eingefügt. Dieser Code kann temporäre Variablen verwenden, die jedoch außerhalb der Komponente nicht sichtbar sind (sofern die S-PLUS-Datenbanken nicht durch den Aufruf von zuordnen geändert wurden). So könnte ein Skript beispielsweise den Code out0 <- sin(in0) enthalten, mit dem als Ausgabe der Sinus der Eingabe festgelegt wird.

Auf die folgenden Variablen kann innerhalb eines Skripts zugegriffen werden:

  • input.var.namesund output.var.names sind Vektoren von Zeichenfolgen, die die Namen der Eingabe- und Ausgabevariablen für die Komponente angeben. Mit diesen Variablen können Sie Skripts schreiben, die mit einer unterschiedliche Anzahl von Eingaben und Ausgaben arbeiten können.

  • first.call hat den Wert T, wenn das Skript zum ersten Mal ausgeführt wird.

Diese Variable kann zur Initialisierung statischer Variablen verwendet werden.

Wenn die Option "Erfasste Ergebnisse anzeigen" im Pop-up-Menü aktiviert ist, zeigt die Komponente den Text, der bei der letzten Ausführung des S-PLUS-Programms erstellt wurde, einschließlich aller vom Skript durchgeführten Druckvorgänge so an, als wäre er in der S-PLUS-Befehlszeile ausgeführt worden. Die Erfassung dieses Textes kann die Ausführung verlangsamen. Fehlermeldungen werden jedoch immer erfasst. Wenn ein Fehler aufgetreten ist, können Sie die Anzeige also umschalten und sich die Fehlermeldungen anzeigen lassen.


Keine Sperre vorhanden.

Bevor Sie den Befehl Bereich / Freigeben aus dem Menü Format aufrufen können, müssen Sie in eine gesperrte Region im Arbeitsblatt klicken.


Operator "n-te Ableitung"

n-te Ableitung

Tastaturbefehl: Strg+Umschalt+?

Gibt die n-te Ableitung von f(t), ausgewertet am Punkt t, zurück.

Operanden:

f(t) ist eine Funktion mit einem Skalarwert.

t ist der Punkt, an dem die Ableitung ausgewertet werden soll.

n=0, 1, 2, 3, 4 oder 5.

Zunächst muss festgelegt werden, an welchem Punkt die Ableitung ausgewertet werden soll. Beispiel:

Hinweise:

  • Im Beispiel oben ist das Ergebnis die n-te Abteilung von f mit Bezug auf t bei Auswertung an dem oder den Punkten, an denen t zuvor definiert wurde.

  • Das Beispiel zeigt zwar eine Funktion nur einer Variablen, f kann aber eine Funktion jeder beliebigen Anzahl von Variablen sein.

  • Wenn f mehrere Terme hat, müssen diese in Klammern angegeben werden, damit sie innerhalb des Ableitungsoperators bleiben.

  • Beim Ableitungsalgorithmus von Mathcad kann davon ausgegangen werden, dass die erste Ableitung innerhalb von 7 oder 8 signifikanten Ziffern genau ist, vorausgesetzt, dass der Wert, an dem die Ableitung ausgewertet wird, sich nicht zu sehr in der Nähe einer Singularität der Funktion befindet.


Operator "n-te Wurzel"

n-te Wurzel

Tastaturbefehl: Strg+\

Gibt die n-te Wurzel von x zurück.

Operanden:

x muss ein Skalar sein.

n muss eine positive ganze Zahl sein.

Gibt eine reelle Wurzel zurück, wenn dies möglich ist. Wenn der Hauptwert der n-ten Wurzel von x zurückgegeben werden soll, müssen Sie stattdessen x zur 1/n-ten Potenz erheben.


Anzahl der Verzinsungsperioden

verzper(zsatz, gw, zw) Übergibt die Anzahl der Verzinsungsperioden, die bei gegebenem derzeitigen Wert und bei einem bestimmten Zinssatz pro Periode für einen bestimmten künftigen Ertrag aus der Kapitalanlage erforderlich sind.

Argumente:

zsatz ist der feste Zinssatz einer Kapitalanlage pro Verzinsungsperiode. zsatz muss ein reeller Skalar sein. zsatz kann als Dezimalzahl (z.B. 0,0825) oder als Prozentsatz (z.B. 8,25%) ausgedrückt werden. zsatz > -1.

Hinweis: Gegebenenfalls müssen Sie den Zinssatz für die jeweilige Verzinsungsperiode berechnen. Für die Berechnung des monatlichen Zinssatzes aus dem jährlichen Zinssatz zum Beispiel gilt die Formel zsatz = jährl_zsatz/12.

gw ist der gegenwärtige Wert der Kapitalanlage. gw [image] 0.

zw ist der zukünftige Wert der Kapitalanlage. zw > 0.


Anzahl der Elemente in einem Vektor

länge(v) Gibt die Anzahl der Elemente im Vektor v zurück.

letzte(v) Gibt den Index des letzten Elements im Vektor v zurück.

Argumente:

  • v muss ein Vektor sein.

Zur Ermittlung der euklidischen Länge von v können Sie den Betragsoperator | verwenden.


Anzahl der Perioden

nper(zsatz, zrate, gw, [[zw], [typ]]) Übergibt die Anzahl der Verzinsungsperioden für eine Kapitalanlage oder ein Darlehen auf der Basis regelmäßiger konstanter Zahlungen mit einem festen Zinssatz und einem bestimmten gegenwärtigen Wert.

Argumente:

zsatz ist der feste Zinssatz einer Kapitalanlage pro Verzinsungsperiode.

Hinweis: Gegebenenfalls müssen Sie den Zinssatz für die jeweilige Verzinsungsperiode berechnen. Für die Berechnung des monatlichen Zinssatzes aus dem jährlichen Zinssatz zum Beispiel gilt die Formel zsatz = jährl_zsatz/12.

zrate ist die Zahlung, die pro Periode entrichtet oder eingenommen wird. Sie umfasst in der Regel Tilgungs- und Zinszahlungen, jedoch keine weiteren Abgaben und Gebühren.

gw ist der gegenwärtige Wert.

zw (optional) ist der zukünftige Wert. Werden keine Angaben gemacht, so wird zw = 0 gesetzt.

typ (optional) beträgt bei Zahlungen, die am Ende der Periode vorgenommen wurden, 0, bei Zahlungen zu Beginn der Periode1. Werden keine Angaben gemacht, so wird typ = 0 gesetzt.

Hinweise:

  • Zahlungen, die Sie leisten, zum Beispiel Einlagen in einem Sparkonto oder Rückzahlungen bei einem Darlehen, müssen als negative Zahlen eingegeben werden. Zahlungen, die Sie einnehmen, zum Beispiel Dividenden, müssen als positive Zahlen eingegeben werden. Speziell für gnw gilt: falls zrate > 0, müssen zsatz und gw unterschiedliche Vorzeichen aufweisen.


Numerierungen

Absätzen innerhalb eines Textbereichs können Sie eine fortlaufende Numerierung, wie z. 1,2,3,..., hinzufügen. So sind z. B. die folgenden drei Absätze mit einer Numerierung versehen:

  1. Zeile 1

  2. Zeile 2

  3. Zeile 3

Zum Numerieren von einem oder mehreren Absätzen in einem Textbereich gehen Sie wie folgt vor:

  1. Markieren Sie Text innerhalb der Absätze.

  2. Wählen Sie Absatz im Menü Format.

  3. Wählen Sie im Dialogfeld "Absatzformat" die Option "Zahlen" neben "Aufzählungszeichen:", und klicken Sie auf "OK".

Schnelles Numerieren (Alternativmethode):

  1. Markieren Sie Text innerhalb der Absätze.

  2. Klicken Sie auf die Numerierungsschaltfläche [image] in der Symbolleiste "Formatierung".


Ziffern in Variablennamen

Die Ziffern 0 bis 9 können außer als Anfangszeichen überall in einem Namen erscheinen. So ist z. B. der Name 'x2' zulässig, der Name '2x' dagegen nicht.


Numerische Ableitungsmethode

Der Ableitungsoperator von Mathcad berechnet Ableitungen einer Ordnung zwischen 0 und 5 (einschließlich) mit einer Abwandlung der Ridder-Methode. Sie beginnt mit der Bestimmung einer anfänglichen Schrittweite und dem Aufbau eines dreieckigen Annäherungsfelds. Dabei gilt folgende Vorgehensweise:

Mathcad berechnet den ersten Annäherungswert in der Tabelle mit einer Differenzannäherung, die am Punkt n+1 aufgeteilt wird:

Die restlichen Annäherungen in der ersten Zeile der Tabelle werden nach der aufgeteilten Differenzformel bei sinkender Schrittweite berechnet:

Die verbleibenden Elemente in dieser Annäherungstabelle werden mit gewichteten Mittelwerten früherer Elemente berechnet:

Der Fehler für eine bestimmte Annäherung des Ableitungswertes wird gegeben durch:

Angenommen, fehlmin sei das kleinste der Elemente i und j von fehl und abl sei die Annäherung des Ableitungswerts entsprechend fehlmin. Dann gelte:

Hierbei steht E für die kleinste Zahl, die von der Ordnung abhängt. Mathcad gibt abl als Wert der Ableitung aus. Andernfalls markiert Mathcad die Ableitung durch eine Fehlermeldung.

Hinweis zum Algorithmus:

Beim Ridder-Algorithmus ist für die erste Ableitung eine Genauigkeit von 7 bis 8 signifikanten Ziffern zu erwarten, vorausgesetzt, der Wert, an dem Sie die Ableitung berechnen, liegt nicht zu nahe an einer Singularität der Funktion.


Numerische Integration

Von der Vielzahl bewährter numerischer Integrationsmethoden eignen sich bestimmte Methoden für bestimmte Integrale besser als für andere. Daher wertet Mathcad standardmäßig jedes Integral numerisch mithilfe der Funktion Automatische Auswahl aus. Die Aufgabe von "Automatische Auswahl" besteht darin, die geeignetste Integrationsmethode auszuwählen. Beispiel:

  1. Klicken Sie auf [image] auf der Symbolleiste "Differential/Integral", oder geben Sie & ein, um den Integraloperator einzufügen.

  2. Geben Sie in die Platzhalter Werte für die untere und die obere Integrationsgrenze, den Integranden und die Integrationsvariable ein.

  3. Drücken Sie die Taste =. Die Funktion "Automatische Auswahl" wertet das Integral aus, wählt den geeignetsten Algorithmus aus und gibt das Ergebnis zurück.

Wenn es Sie interessiert, welches Ergebnis von einer anderen Methode zurückgegeben worden wäre, können Sie die Funktion "Automatische Auswahl" außer Kraft setzen und selbst einen Algorithmus auswählen.


Numerische Probleme in inversen trigonometrischen Funktionen

Da Funktionen unter Verwendung von Gleitkommazahlen mit doppelter Genauigkeit ausgewertet werden, kommt es unweigerlich zu Rundungsfehlern, die sich auf die Berechnungen auswirken. Dies gilt vor allem dann, wenn das Argument der Funktion extreme Werte annimmt.


Genauigkeit des numerischen Verfahrens

Da Mathcad als Allzweckrechenprogramm konzipiert ist, arbeitet es mit numerischen Methoden, die in vielen unterschiedlichen Situationen funktionieren. Ebenso wie bei allen numerischen Algorithmen lassen sich jedoch auch für die Methoden von Mathcad bestimmte Beispiele finden, deren Ergebnis falsch oder irreführend ist.

Sie können die Richtigkeit von Ergebnissen überprüfen und numerische Fehler vermeiden, wenn Sie sich an die folgenden Regeln halten:

  • Wenn Sie mit einer Funktion oder einem Operator arbeiten, der eine numerische Annäherung enthält, überprüfen Sie, ob das Ergebnis plausibel erscheint.

  • Befassen Sie sich mit den verfügbaren Informationen zu dem betreffenden Operator bzw. der Funktion. Wenn Sie glauben, dass die Mathcad-Methoden fehlschlagen könnten, formulieren Sie das Problem so um, dass es stabiler berechnet werden kann.

  • Machen Sie sich mit den numerischen Methoden vertraut, damit Sie abschätzen können, unter welchen Umständen falsche oder ungenaue Ergebnisse zustande kommen.

  • Stellen Sie die vordefinierte Variable TOL so ein, dass die gewünschte Genauigkeit und Geschwindigkeit für numerisch berechnete Antworten erzielt wird.


Numerische Methode zur Berechnung einer inversen Matrix und einer Determinante

Zur Berechnung der Determinante oder der Inversen einer quadratischen Matrix M löst Mathcad die Matrix in eine untere Dreiecksmatrix L und eine obere Dreiecksmatrix U auf, dergestalt dass:

Dies wird als LU-Zerlegung der Matrix bezeichnet. Dadurch wird die Lösung eines Systems von Gleichungen:

durch einfache Ersetzungen durch die Elemente L, U, und y durchgeführt.

  • Zur Berechnung der Inversen löst Mathcad die Gleichungen auf:

Hierbei ist e ein Vektor mit 1 im Element j und 0 in allen anderen Elementen. Die Lösungsvektoren v für jedes j bilden die Spalten der inversen Matrix.

  • Die Determinante der Ausgangsmatrix ist einfach das Produkt der diagonalen Elemente von U, also der oberen Dreiecksmatrix in der LU-Zerlegung.


Numerische Methoden

Im Folgenden werden die numerischen Methoden beschrieben, mit denen Mathcad bei bestimmten Berechnungen arbeitet.

  • Integration

  • Ableitung

  • Wurzelfunktion

  • Lösen von Gleichungen

  • Matrixdeterminanten und Inverse Matrix

  • Sortieren

  • Faktor oder Zähler gleich Null

  • Genauigkeit des numerischen Verfahrens


Numerisches Ergebnis

Ein numerisches Ergebnis wird rechts vom Gleichheitszeichen "=" angezeigt.


Numerische Ergebnisse symbolischer Berechnungen

Mithilfe symbolischer Berechnungen lassen sich oft auch numerische Ergebnisse ermitteln, vor allem in Fällen wie dem folgenden:

Die Ergebnisse der symbolischen Berechnung hängen davon ab, ob die Konstanten in Ihrer Gleichung Dezimalbrüche sind. Handelt es sich bei den Konstanten um reine rationale Zahlen wie 1/2 oder 4, versucht dieser symbolische Lösungsalgorithmus, eine exakte Lösung zu finden. Wenn Sie jedoch einen Dezimalbruch eingeben, zum Beispiel 0.5 statt 1/2, gibt der Algorithmus nur eine angenäherte numerische Antwort aus.

Sie können die numerische Berechnung durch den symbolischen Prozessor auch mit dem Befehl "Gleitkommaauswertung" im Untermenü Auswerten erzwingen.

Hinweis:

Um die Gleitkommagenauigkeit für das Arbeitsblatt auf einen anderen als den Standardwert 20 festzulegen, markieren Sie im Arbeitsblatt einen beliebigen mathematischen Ausdruck und wählen Sie im Menü Symbolik den Befehl Auswerten Þ Gleitkomma. Ändern Sie die Einstellungen, und klicken Sie dann auf "OK".


Partielle Differentialgleichungen (Lösungsalgorithmus)

numol(x_endpts, xpts, t_endpts, tpts, num_pde, num_pae, pde_func, pinit, bc_func)

Gibt eine xpte mal tpte-Matrix zurück, die die Lösungen der eindimensionalen partiellen Differentialgleichung in pde_func enthält. Jede Spalte steht für eine Lösung über einem eindimensonalen Raum zu einer einzigen Lösungszeit. Für ein Gleichungssystem wird die Lösung der einzelnen Funktionen horizontal angefügt, sodass die Matrix immer xpte Zeilen und tpte * (num_pde + num_pae) Spalten aufweist.

Argumente:

x_endpte, t_endpte sind Spaltenvektoren mit zwei Elementen, die die rellen Endpunkte der Integrationsbereiche angeben.

xpte, tpte sind die ganzzahlige Anzahl der Punkte im Integrationsbereich, dem sich der Wert der Lösung annähert.

num_pde, num_pae sind die ganzzahlige Anzahl der partiellen Differentialgleichungen und der partiellen algebraischen Gleichungen. num_pde muss mindestens 1 sein, num_pae kann 0 sein.

pde_func Vektorfunktion von x, t, u, ux und uxx der Länge (num_pde + num_pae). Enthält den rechten Teil der partiellen Differentialgleichungen/partiellen algebraischen Gleichungen. Für den linken Teil wird angenomen, dass alle Werte ut betragen.

pinit Vektorfunktion von x der Länge (num_pde + num_pae), die die Anfangsbedingungen für jede Funktion im System enthält.

bc_func ist eine num_pde mal 3-Matrix, die Zeilen der folgenden Form enthält:

  • (rb_links(t) rb_rechts(t) "D") für Dirichlet-Randbedingungen, oder
  • (rb_links(t) rb_rechts(t) "N") für Neumann-Randbedingungen.

    Falls die partielle Differentialgleichung für die zugehörige Zeile partielle zweite Ableitungen enthält, sind sowohl die linken als auch die rechten Bedingungen erforderlich

    Wenn eine bestimmte partielle Differentialgleichung nur partielle erste Ableitungen enthält, sollte eine der beiden Randbedingungen durch "n/v" ersetzt werden. Der letzte Eintrag in der Zeile ist immer "D".

    Wenn eine partielle Differentialgleichung keine partiellen Ableitungen enthält, wird diese Zeile in der Matrix ignoriert und kann mit ( "n/v" "n/v" "D") ausgefüllt werden.

Hinweise:

  • Die partiellen Differentialgleichungen und partiellen algebraischen Gleichungen werden als Glieder der Lösung "u" eingesetzt. Sie werden als Vektoren von Funktionen behandelt. Wenn Sie mit einem System von partiellen Differentialgleichungen arbeiten, verwendet jede Zeile in pde_func Vektoren als Subskripte, um "u" zu indizieren. Z. B. verweist u[0 auf die erste Funktion im System und u.x[1 auf die erste Ableitung der zweiten Funktion im System.

  • Algebraische Bedingungen wie z. B. 0 = u2(x) + v2(x) - w(x) für alle x sind zulässig.

  • Die erforderliche Anzahl an Randbedingungen entspricht der Ordnung der räumlichen Ableitung der jeweiligen partiellen Differentialgleichung. Auf diese Weise ist eine eindeutige Lösung gewährleistet.

  • Mit numol können nur hyperbolische und parabolische partielle Differentialgleichungen gelöst werden. Verwenden Sie für elliptische Gleichungen wie die Poissonsche Gleichung die Funktion multigit oder relax.


Veraltete Funktionen

Die folgenden Funktionen sind veraltet:

ANFÜGEN

LESEN

bis

SCHREIBEN

Diese Funktionen sind weiterhin in Mathcad enthalten, um die Kompatibilität mit älteren Versionen zu gewährleisten. Sie sollten jedoch nicht mehr verwendet werden.


Eigenschaften der ODBC-Eingabekomponente

Dialogfeld "Eigenschaften der ODBC-Eingabekomponente" - Registerkarte "Datenquelle"

Mithilfe der Registerkarte Datenquelle des Dialogfelds "Eigenschaften der ODBC-Eingabekomponente" können Sie festlegen, auf welche Daten die ODBC-Eingabekomponente zugreifen soll. Auf der Registerkarte "Datenquelle" stehen Ihnen die folgenden Optionen zur Verfügung:

ODBC-Datenquelle auswählen

Listet alle verknüpften Datenbanken auf Ihrem System bzw. in Ihrem Netzwerk auf. Wenn die Datenbank, auf die Sie zugreifen möchten, hier nicht aufgeführt wird, müssen Sie zunächst eine Verbindung zu ihr herstellen.

Autorisierung

Bei einigen Datenbanken müssen Sie einen Benutzernamen und ein Kennwort eingeben, um auf den Datenbestand zugreifen zu können. Damit die Komponente ODBC lesen auf Daten in einer kennwortgeschützten Datenbank zugreifen kann, müssen Sie einen gültigen Benutzernamen und ein Kennwort für diese Datenbank eingeben. Ist die Datenbank nicht kennwortgeschützt, dürfen keine Einträge in diese Felder vorgenommen werden.

Tabelle auswählen

Zeigt alle Tabellen in der ausgewählten Datenbank an. Pro ODBC-Komponente darf nur eine Tabelle ausgewählt werden.

Felder auswählen

Zeigt eine Liste der Felder in der ausgewählten Tabelle an, die an Mathcad gesendet werden. Standardmäßig werden nur von Mathcad unterstützte Feldtypen aufgeführt.

Felder mit nicht unterstützten Datentypen anzeigen

Wenn diese Option aktiviert ist, werden im Auswahlfeld alle Felder in der ausgewählten Tabelle angezeigt, einschließlich der Felder, die Mathcad nicht lesen kann.

Alle auswählen

Wählt alle Felder in der Liste Felder auswählen aus.

Nichts auswählen

Sorgt dafür, dass in der Liste Felder auswählen kein Feld ausgewählt ist.

Eigenschaften der ODBC-Eingabekomponente - Registerkarte "Erweitert"

Mithilfe der Registerkarte Erweitert des Dialogfelds "Eigenschaften der ODBC-Eingabekomponente" können Sie genauer festlegen, welche Daten von der ODBC-Eingabekomponente zurückgegeben werden sollen. Auf der Registerkarte "Erweitert" stehen Ihnen die folgenden Optionen zur Verfügung:

Datenzeilen mit einem SQL-Parameter "Where" auswählen

Ermöglicht das Filtern Ihrer Daten mithilfe einer SQL-Where-Abfrage.

Reihenfolge der Felder

Mithilfe dieser Liste können Sie die Reihenfolge festlegen, in der die ODBC-Eingabekomponente Daten an Mathcad sendet. Die Felder werden von oben nach unten gelesen und in Mathcad von links nach rechts angezeigt. Mithilfe der Schaltflächen Nach oben und Nach unten lässt sich die Position eines bestimmten Feldes in der Liste ändern.

Feldbeschriftungen in abgerufene Daten einbeziehen

Wenn diese Option aktiviert ist, fügt die ODBC-Eingabekomponente den Daten, die sie aus der Datenbank liest, eine Zeile mit Spaltenbeschriftungen hinzu. Diese Spaltenbeschriftungen erscheinen beim Zugriff auf die Daten in Mathcad in der ersten Zeile.


Lösen einer einfachen, gewöhnlichen Differentialgleichung

gdglösen(x,b,[step]) Übergibt eine Funktion von x, die eine Lösung der einzelnen, gewöhnlichen Differentialgleichung ist, abhängig von den Anfangswert- oder den Grenzwertbedingungen, die im Gleichungssystem bestimmt werden. Die gewöhnliche Differentialgleichung muss in ihrer höchsten Ableitung linear verlaufen, und die Anzahl der Bedingungen muss gleich ihrer Ordnung sein.

gdglösen(Vektor x,b,[step]) Übergibt eine Funktion von x, die eine Lösung des Systems einzelner, gewöhnlicher Differentialgleichungen ist, abhängig von den Anfangswert- oder den Grenzwertbedingungen, die im Gleichungssystem bestimmt werden. Gewöhnliche Differentialgleichungen müssen in ihrer höchsten Ableitung linear verlaufen, und die Anzahl der Bedingungen muss gleich ihrer Ordnung sein.

Argumente:

Vektor ist der explizite Vektor der Funktionsnamen (ohne Einschluss von Variablennamen), so wie sie im Gleichungssystem angezeigt werden. Bei einer einzelnen gewöhnlichen Differentialgleichung wird dieses Argument weggelassen.

x ist die Integrationsvariable. x muss reell sein.

b ist der Endpunkt des Integrationsintervalls. b muss reell sein.

step (optional) ist die intern verwendete Anzahl von Schritten bei der Berechnung der Lösung.

Verwenden Sie die Funktion wie folgt:

Schritte für die Arbeit mit der Funktion gdglösen zur Lösung einer gewöhnlichen Differentialgleichung.

Geben Sie das Wort Vorgabe ein, um das Gleichungssystem zu starten.

Geben Sie unter Vorgabe die Differentialgleichung einschließlich ihrer Nebenbedingungen ein. Verwenden Sie hierzu Boolesche Operatoren.

Geben Sie die Funktion gdglösen mit der Integrationsvariable, x, und dem Endpunkt b ein. Zum Lösen eines Systems gewöhnlicher Differentialgleichungen ist auch der Funktionsvektor Vektor erforderlich.

Hinweise:

  • Sie können die Diffentialgleichung mithilfe von Ableitungsoperatoren wie d/dx und d2/dx2 oder durch Primärnotation wie in y(x) und y'(x) eingeben. (Die Tastenkombination für den Apostroph ist Strg+F7.)

  • Die Nebenbedingungen müssen in der Form y(a)=b oder y'(a)=b angegeben werden. Mathcad akzeptiert keine komplizierteren Nebenbedingungen wie y'(a)+y(a)=b, jedoch algebraische Nebenbedingungen wie y(a) + z(a) = w(a).

  • Der Endpunkt b muss größer sein als der Anfangswert.

  • Standardmäßig verwendet gdglösen für die Lösung ein Runge-Kutta-Verfahren mit fester Schrittweite. Zur Verwendung eines adaptiven Verfahrens klicken Sie mit der rechten Maustaste auf gdglösen und wählen Sie im Kontextmenü den Befehl Adaptiv. Zur Verwendung eines steifen Verfahrens klicken Sie mit der rechten Maustaste auf Gdglösen und wählen aus dem Kontextmenü die Option Steif.

  • Zur Lösung von Differentialgleichungssystemen oder Gleichungen, die in der höchsten Ableitung nicht linear verlaufen, verwenden Sie rkfest. Wenn Sie algebraische Nebenedingungen verwenden, müssen Sie im Kontextmenü den steifen Lösungsalgorithmus auswählen.

  • Das erste Argument, Vektor, ist optional, wenn es sich um eine einzelne gewöhnliche Differentialgleichung handelt. (Das Ordnen der Funktionslösungen ist nur von Bedeutung, wenn mehrere Differentialgleichungen vorliegen.) Wenn die unbekannten Funktionen beispielsweise f, g und h sind (entsprechend den Namen im Gleichungssystem), dann muss Vektor im Gdglösen-Aufruf ausdrücklich als Spaltenvektor angegeben werden:
    f
    g
    h

    Es sollen nur die Funktionsnamen angezeigt werden, geben Sie den Vektor nicht wie folgt ein:
    f(x)
    g(x)
    h(x)

    Zur Benennung von Funktionen dürfen keine Feldindizes verwendet werden, Literalindizes sind jedoch unbedenklich. Die Kommentare zu einzelnen gewöhnlichen Differentialgleichungen lassen sich, entsprechend erweitert, auch auf Fälle mit mehreren gewöhnlichen Differentialgleichungen übertragen.


Nebenbedingungen von gewöhnlichen Differentialgleichungen und Teildifferentialgleichungen

Die Nebenbedingungen für gdglösen und tgdlösen können in beliebiger Reihenfolge eingegeben werden. Allerdings müssen für eine gewöhnliche Differentialgleichung n-ter Ordnung n unabhängige Gleichheitsnebenbedingungen festgelegt werden. Ungleichheitsnebenbedingungen sind nicht zulässig.

Bei einem Anfangswertproblem der gewöhnlichen Differentialgleichung werden die Werte für y(x) und seine ersten Ableitungen n-1-ter Ordnung an einem einzelnen Ausgangspunkt a benötigt.

Bei einem Grenzwertproblem der gewöhnlichen Differentialgleichung müssen die n Gleichheitsnebenbedingungen Werte für y(x) und einige Ableitungen an genau zwei gegebenen Punkten a und b festlegen.

Für eine Teildifferentialgleichung müssen für jede unbekannte Funktion eine Anfangsbedingung u(x,0) und n Randbedingungen gebeben sein, wobei n die Ordnung der Teildifferentialgleichung ist. Es können Dirichlet- (u(0,t) = f(t)) oder Neumann-Randbedingungen (ux(0,t)=f(t)) angegeben werden.

In beiden Fällen müssen die in den Randbedingungen verwendeten Endpunkte den in den Befehlen "gdg/tdglösen" verwendeten Endpunkten entsprechen.

Mathcad überprüft, ob Art und Zahl der Nebenbedingungen korrekt sind und gibt bei einem Fehler eine entsprechende Meldung aus.


OLE-Automatisierungs-Client

Ein OLE-Automatisierungs-Client ist ein Anwendungsprogramm, in dem Sie ein Programm oder Makro schreiben können, das mit einem Objekt in Interaktion tritt. So ist z. B. Microsoft Excel 5.0 und höher ein solcher OLE-Automatisierungs-Client.

Informationen dazu, ob ein bestimmtes Anwendungsprogramm als OLE-Automatisierungs-Client fungieren kann, finden Sie in der Dokumentation zu diesem Anwendungsprogramm.


OLE-Server

Eine Windows-Anwendung, die OLE-Objekte (Object Linking and Embedding) über die Zwischenablage exportieren kann.

Mit dieser Funktion können Sie das OLE-Objekt in derjenigen Anwendung bearbeiten, in der es erstellt wurde. Doppelklicken Sie hierzu auf das Objekt.


Hier sind nur positive Werte zulässig.

Dieser Wert muss entweder 0 betragen oder ein nicht negativer Skalar sein.

Wenn Sie beim Arbeiten mit einer vordefinierten Funktion weitere Informationen benötigen, klicken Sie auf den Funktionsnamen und drücken Sie F1.


Offene Romberg-Methode

Bei der offenen Integrationsmethode werden die vorläufigen Annäherungen über die Mittelpunkte der Teilintervalle ermittelt, sodass die Funktion nicht an den Endpunkten a und b berechnet werden muss. (Eine vollständige Beschreibung bietet der Artikel "Handheld Calculator Evaluates Integrals" von William Kahan, Ph.D., im Hewlett-Packard Journal, August 1980.)

Die Stichproben konzentrieren sich an den Enden des Integrationsintervalls, wo singuläre Integranden oder Integranden mit einer endlichen Ableitung meistens die abruptesten Veränderungen erfahren. Bei jedem Schritt verdreifacht sich die Zahl der Teilintervalle.

Bei der offenen Romberg-Methode führt Mathcad die folgenden Schritte aus:

  • Berechnen einer offenen Annäherung für das Integral durch das Summieren der einzelnen Produkte aus dem Funktionswert am Mittelpunkt des Teilintervalls und der Weite dieses Teilintervalls. Die Prozedur beginnt mit nur einem Intervall und ergibt folgende Annäherung:

Bei der nächsten Annäherung werden drei Punkte, bei der übernächsten neun Punkte usw. bewertet. Zunächst sind die ersten drei Annäherungen zu erstellen.

  • Vergleichen der beiden letzten Romberg-Annäherungen nach folgendem Test:

  • Stimmen die beiden letzten Annäherungswerte gemäß dem Test überein, wird die letzte offene Annäherung als Wert des Intergrals ausgegeben. Ist dies nicht der Fall, wird die Zahl der Teilintervalle verdreifacht, und die Prozedur wird erneut ab Schritt 1 durchgeführt.

Mathcad begrenzt die Zahl der Durchgänge für die offene Romberg-Methode. Erreicht Mathcad bei der Routine die festgelegte Begrenzung, ohne dass eine Antwort ausgegeben wird, wird die fehlgeschlagene Konvergenz am Integral als Fehler angezeigt.


Öffnen eines als RTF-Datei gespeicherten Arbeitsblattes in Microsoft Word

Wenn Sie in Microsoft Word eine RTF-Datei öffnen, die mit dem Befehl Speichern unter im Menü Datei erstellt wurde, geschieht Folgendes:

  • Die Rechen- und Grafikbereiche lassen sich nicht mehr bearbeiten. Sie lassen sich jedoch frei bewegen. Textbereiche können in Word bearbeitet werden.

  • Die Bereiche werden in der Normalansicht am linken Rand ausgerichtet und nicht mehr entsprechend der Anordnung im Originalarbeitsblatt. Wenn Sie jedoch im Menü "Ansicht" die Option Drucklayoutansicht wählen, werden sie wie im ursprünglichen Mathcad-Arbeitsblatt angezeigt.

  • Bereiche, die über den rechten Rand hinausgehen, werden überhaupt nicht angezeigt, da Microsoft Word nicht über eine derartige Funktion verfügt. Für die Ränder werden die Standardwerte von Microsoft Word verwendet.


Operand (Definition)

Operand

Ein Operand ist eine Zahl oder ein Ausdruck, die bzw. den der Operator als Grundlage für die Auswertung nimmt. Beispiel: Im Ausdruck "5! +3" sind die Zahl "3" und der Ausdruck "5!" Operanden des Operators "plus". Die Zahl "5" ist ein Operand des Fakultätsoperators (!).

In der folgenden Tabelle sind Beispiele zu Operanden aufgeführt:


Operator

Mithilfe eines Operators werden eine oder mehrere Zahlen in eine dritte Zahl umgewandelt. Beispiele für Operatoren:

  • Der Expontenoperator in " [image] "

  • Der Fakultätsoperator in "(x + z)!",

  • Das Pluszeichen in "1 + 1",

  • Das Integralzeichen in " [image] ".

Die Zahlen, auf die sich der Operator auswirkt, werden "Operanden" genannt.


Operator-Symbolleisten

Die Operator-Symbolleisten öffnen Sie, indem Sie auf die Schaltflächen direkt unter der Menüleiste klicken. Durch Klicken auf die Schaltflächen in diesen Symbolleisten werden die entsprechenden Operatoren eingefügt.


Operatoren und Funktionen für verschachtelte Felder

Viele Feldoperatoren und -funktionen haben im Zusammenhang mit verschachtelten Feldern keine sinnvolle Bedeutung. Es ist z. B. nicht klar, was Matrixmultiplikation bedeutet oder was die Inverse tun soll.

Die folgenden Operatoren und Funktionen können jedoch auch im Zusammenhang mit verschachtelten Feldern verwendet werden:

Operatoren

Transponieren

Hochgestellter Matrixindex

Vektorindex

Funktionen

erweitern

spalten

letzte

Länge

zeilen

stapeln

submatrix


In symbolischen Ergebnissen zurückgegebene Operatoren

Wenn Sie ein umfangreiches symbolisches Ergebnis in die Zwischenablage gesetzt haben, werden möglicherweise folgende Operatoren angezeigt:

ROOTOF

Ein Polynom kann in der Zwischenablage in folgender Form erscheinen:

ROOTOF(H(_Z))

Dabei ist h(_Z) ein Polynom, dessen Wurzel auch eine Wurzel des ursprünglichen Ausdrucks ist.

D

Ein "D" steht für den Teilableitungsoperator. Die n-te Ableitung ist "(D,n)". Die Teilableitung einer Funktion in Bezug auf ihr n-tes Argument ist "(D[n])".

diff

Die Ableitung von f(x) in Bezug auf x wird als "diff(f(x),x)" notiert. Die n-te Ableitung lautet "diff(f(x),x$n)".

int

Das Integral von f(x) in Bezug auf x wird als "int(f(x),x)" notiert.

@

Der Operator "@" steht für die Funktionserstellung. Zum Beispiel entspricht (sin@exp)(x) genau sin(exp(x)). "@@" steht für wiederholte Erstellung; (f@@2)(x) entspricht also f(f(x)).


Operator "Oder"

Oder

Tastaturbefehl: Strg+Umschalt+6

x [image] yGibt 1 zurück, wenn x oder y, jedoch nicht beide zugleich, einen Wert ungleich 0 (wahr) aufweisen. Andernfalls wird 0 zurückgegeben.

Operanden:

  • x und y sind reelle oder komplexe Skalare.

Hinweise:

  • Der Wert Null steht für FALSCH, alle Werte ungleich Null für WAHR.

  • Oder wertet zuerst x aus. Wird x für WAHR befunden (Wert ungleich null), wird y nicht ausgewertet, da die Funktion Oder bereits WAHR ist. Daher können folgende Annahmen zu verschiedenen Ergebnissen führen:

    • 1 [image] (2/0) = 1 (2/0 wird niemals ausgewertet.)
    • (2/0) [image] 1 erzeugt einen Fehler. (2/0 löst einen Singularitätsfehler aus.)


Reihenfolge der Operationen

Im rechten Dokument weiter unten wurde versucht, die Variable y zu verwenden, bevor sie definiert wurde. Beachten Sie die Verfärbung von y zu rot. Dies weist darauf hin, dass die Variable nicht definiert wurde.

y muss, wie im linken Dokument gezeigt, oberhalb und/oder links von der Stelle definiert werden, an der die Variable zum ersten Mal verwendet wird.


Gewöhnliche Differentialgleichung (Definition)

Gewöhnliche Differentialgleichung

Eine gewöhnliche Differentialgleichung ist eine Differentialgleichung, in der die Unbekannte eine Funktion einer Variable ist.


ORIGIN muss eine ganze Zahl sein.

ORIGIN sollte eine ganze Zahl sein, deren Betrag geringer als 16 Millionen ist.

Sie haben versucht, ORIGIN entweder als etwas anderes als eine Ganzzahl oder aber als eine ganze Zahl größer als 16.000.000 zu definieren.


Andere Funktionen für die Datenanalyse

  • Mittelwert

  • Median

  • Funktion "mode"

  • Standardabweichung bei Populationen

  • Standardabweichung bei Stichproben

  • Varianz bei Populationen

  • Varianz bei Stichproben

  • Kovarianz

  • Korrelation


Ausgabetabelleneigenschaften: Akkumulieren

Die Registerkarte "Akkumulieren" steht nur für die MathConnex -Komponente Inspector zur Verfügung.


Ausgabetabelleneigenschaften: Anzeige

Anzeigen von Zeilen-/Spaltenbeschriftungen

Durch Klicken auf dieses Feld können Sie die Zeilen- und Spaltennummern für die Werte in der Tabelle anzeigen.

Schriftart

Öffnet ein Dialogfeld, in dem Sie die Schriftart für die angezeigten Zahlen bestimmen können.


Ausgabevariable

Eine Mathcad-Variable, die über eine Komponente mit Werten aus einer anderen Anwendung oder Datenquelle definiert wurde. Eine Ausgabevariable kann ein Skalar oder ein Feld sein.


Überblick über symbolische Transformationen

Wenn Sie im Menü Symbolik den Eintrag Transformation wählen, wird ein Untermenü mit sechs weiteren Befehlen geöffnet. Mithilfe dieser Befehle können Sie Fourier-, Laplace- und z-Transformationen sowie deren Umkehrungen durchführen.

Zum Transformieren eines Ausdrucks gehen Sie wie folgt vor:

  1. Geben Sie den zu transformierenden Ausdruck ein.

  2. Klicken Sie auf die Transformationsvariable.

  3. Wählen Sie im Menü Symbolik den Befehl Transformation.

  4. Wählen Sie den entsprechenden Befehl für die gewünschte Transformation bzw. inverse Transformation.

Transformationen:

Fourier | Fourier invers
Laplace | Laplace invers
z | Z invers

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Auswertung.


Dialogfeld "Seite einrichten"

Im Dialogfeld "Seite einrichten" finden Sie die folgenden Optionen und Schaltflächen:

Schriftgrad

Ermöglicht die Angabe der Größe des Papiers in Ihrem Drucker.

Papierzufuhr

Ermöglicht die Angabe des Papierschachts, aus dem das zu bedruckende Papier entnommen werden soll.

Hochformat

Wenn diese Option aktiviert ist, wird die Seite im Hochformat gedruckt, also so, dass die längste Ausdehnung der Seite die von oben nach unten ist.

Querformat

Wenn diese Option aktiviert ist, wird die Seite im Querformat gedruckt, also so, dass die längste Ausdehnung der Seite die von links nach rechts ist. Diese Option ist dann sinnvoll, wenn Sie ein Arbeitsblatt ausdrucken lassen wollen, dass breiter als eine Seite ist.

Links

Mit dieser Option geben Sie an, wie groß der Abstand zwischen dem linken Rand des Blattes und dem linken Rand des Druckbereichs sein soll.

Rechts

Mit dieser Option geben Sie an, wie groß der Abstand zwischen dem rechten Rand des Blattes und dem rechten Rand des Druckbereichs sein soll. Der rechte Rand wird als durchgehende vertikale Linie in Ihrem Fenster dargestellt. Eventuell müssen Sie sich mithilfe der Bildlaufleiste in Ihrem Fenster nach rechts bewegen, um diese Linie sehen zu können.

Verwechseln Sie diese Linie (den rechten Rand) nicht mit der gepunkteten vertikalen Linie am rechten Rand. Diese gepunktete vertikale Linie zeigt den rechten Rand des Papierblatts an. Wo sich diese gepunktete Linie befindet, hängt davon ab, welchen Standarddrucker Sie in Ihrem Betriebssystem festgelegt haben.

Oben

Mit dieser Option geben Sie an, wie groß der Abstand zwischen dem oberen Rand des Blattes und dem oberen Rand des Druckbereichs sein soll. Wenn Ihr Arbeitsblatt mit einer Kopfzeile versehen ist, erscheint diese innerhalb des Randbereichs an dessen unterer Grenze.

Unten

Mit dieser Option geben Sie an, wie groß der Abstand zwischen dem unteren Rand des Blattes und dem unteren Rand des Druckbereichs sein soll. Wenn Ihr Arbeitsblatt mit einer Fußzeile versehen ist, erscheint diese innerhalb des Randbereichs an dessen oberer Grenze.

Breite einer Seite drucken

Wenn diese Option aktiviert ist, wird nur das gedruckt, was sich links vom rechten Rand befindet.

Drucker...

Mit dieser Schaltfläche können Sie auf das Dialogfeld zur Änderung der aktuellen Druckereinstellungen zugreifen.


Gleichzeitiges Ausführen von Berechnungen

Gleichzeitige Berechnungen

Alle Berechnungen, die Mathcad mit einzelnen Werten durchführen kann, sind auch mit Feldern von Werten möglich. Dazu gibt es zwei Möglichkeiten:

  • Durch Iteration für die einzelnen Elemente mit Bereichsvariablen als unterem Index.

  • Durch Verwendung des Vektorisierungsoperators, mit dem Mathcad denselben Vorgang für alle Elemente eines Vektors oder einer Matrix effektiv durchführen kann.


Parametrische Flächendiagramme

Parametrische Flächendiagramme heben die Bedingung auf, dass Flächen die Form z = f(x,y) haben müssen. Mit parametrischen Flächendiagrammen können Sie freie Flächen zeichnen.

  1. Definieren Sie die drei Matrizen der abzubildenden Elemente. Diese Matrizen enthalten die x-, y- und z-Koordinaten der zu zeichnenden Punkte.

  2. Wählen Sie im Menü Einfügen den Befehl Diagramm / Flächendiagramm, damit ein Flächendiagrammbereich erstellt wird.

  3. Geben Sie ( in den Platzhalter ein.

  4. Geben Sie die Namen der Matrizen durch Kommas getrennt ein.

  5. Geben Sie ) ein.

Hinweise:

  • Die drei Matrizen müssen über dieselbe Anzahl von Zeilen und Spalten verfügen.

  • Parametrische Flächendiagramme können nicht in einen anderen dreidimensionalen Diagrammtyp umgewandelt werden.


Partialbruchzerlegung

Zum Entwickeln eines rationalen Ausdrucks in eine Summe von Brüchen mit linearen oder quadratischen Nennern gehen Sie folgendermaßen vor:

  1. Markieren Sie die Variable, die zum Faktorisieren der Nenner dienen soll.

  2. Wählen Sie im Menü Symbolik den Eintrag Variable / "Partialbruchzerlegung".

Durch diesen Befehl wird versucht, den Nenner in Faktoren umzuwandeln, die in der gewählten Variable linear oder quadratisch (mit rationalen Koeffizienten) sind. Kann der Nenner nicht in der gewählten Variable faktorisiert werden, wird der Ausdruck unverändert ausgegeben.

Hinweise:

  • Mit diesem Befehl können Sie keine Ausdrücke entwickeln, die Bedingungen mit Dezimalpunkten enthalten.

  • Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung und das Schlüsselwort "konvert".


Dialogfeld "Inhalte einfügen"

Im Dialogfeld "Inhalte einfügen" finden Sie die folgenden Optionen und Schaltflächen:

Einfügen

Bettet die kopierten Daten in das Arbeitsblatt ein. Wenn ein Objekt eingebettet ist, wirken sich am Objekt vorgenommene Änderungen nur auf die Kopie im Mathcad-Arbeitsblatt aus. Das Ausgangsobjekt wird nicht verändert.

Verknüpfen

Verknüpft die kopierten Daten mit dem Arbeitsblatt. Änderungen an einem verknüpften Objekt wirken sich sowohl auf die Kopie in Mathcad als auch auf das Original aus.

Diese Option ist nur verfügbar, wenn ein Objekt aus einer gespeicherten Datei kopiert wurde.

Als

Bestimmt, wie die kopierten Daten in das Arbeitsblatt eingefügt werden. Welche Optionen verfügbar sind, hängt von den kopierten Daten ab.

Als Symbol

Zeigt die eingefügten Daten als Symbol an. Doppelklicken Sie auf das Symbol, um das Objekt zu öffnen..


Einfügen von Daten aus der Zwischenablage

Es kann vorkommen, dass Sie Daten in einer Tabellenkalkulation oder einer anderen Anwendung gespeichert haben, die nicht als Datei in das Arbeitsblatt importiert oder gelesen werden sollen. Eine Alternative zum Importieren einer Datei besteht darin, die Daten über die Zwischenablage in Ihr Mathcad-Arbeitsblatt zu einzufügen. Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie die Daten in der anderen Anwendung aus, und kopieren Sie sie in die Zwischenablage. In den meisten Fällen geschieht dies mithilfe des Befehls Kopieren im Menü Bearbeiten.

  2. Öffnen Sie das Mathcad-Arbeitsblatt, in dem die Daten verwendet werden sollen.

  3. Geben Sie im Mathcad-Arbeitsblatt eine Variablendefinition wie z. B. m:= ein.

  4. Klicken Sie auf den Platzhalter rechts neben := und wählen Sie "Einfügen" aus dem Menü Bearbeiten.

Im Arbeitsblatt erscheint eine Matrix mit den kopierten Daten. Mathcad versucht, die Datentypen beizubehalten:

  • Reelle Zahlen werden als reele Zahlen eingefügt.
  • Komplexe Zahlen mit nachfolgendem i oder j werden als imaginäre Zahlen eingefügt.
  • Zahlen mit e oder E und einem Exponenten werden als Notationszahlen eingefügt.
  • Zeichenfolgen werden als Mathcad-Zeichenfolgenvariablen eingefügt, die in Anführungszeichen eingeschlossen sind.


Einfügen von Text

Wenn Sie im Menü Bearbeiten den Eintrag Einfügen wählen, fügen Sie den zuletzt kopierten oder ausgeschnittenen Text ein. Dieser Text wird an der Position des Cursors eingefügt.


Pfad zu einer Referenz

Um z. B. auf eine Datei namens CONFORM.MCD zu verweisen, die sich im Mathcad-Ordner befindet, müssen Sie Folgendes eingeben:

c:\Programmdateien\mathsoft\Mathcad\conform.mcd

Für einen Verweis auf eine Datei, die im World Wide Web gespeichert ist, können Sie z. B. Folgendes eingeben:

http://www.mathsoft.com/coeffs.mcd


Pfadname

Ein Pfadname ist der vollständige DOS-Name für eine Datei. Wenn sich z. B. eine Datei mit dem Namen tuba.txt in einem Unterverzeichnis mit der Bezeichnung \orchester\messing auf Laufwerk A befindet, lautet der vollständige Pfadname:

A:\orchester\messing\tuba.txt.


Pfadnamen für Hyperlinks

Beispiele für Hyperlink-Pfadnamen

Mit c:\Programme\mathsoft\Mathcad\conform.mcd wird ein Hyperlink zu der Datei "conform.mcd" im Mathcad-Ordner erstellt.

Mit http://www.mathsoft.com/coeffs.mcd wird ein Hyperlink zu einer Datei im World Wide Web erstellt.


Zahlungsrate

zrate(zsatz, nper, gw, [[zw], [typ]]) Übergibt die Zahlungsrate für eine Kapitalanlage oder ein Darlehen auf der Basis regelmäßiger konstanter Zahlungen über eine gegebene Zahl von Verzinsungsperioden mit einem festen Zinssatz und einem bestimmten gegenwärtigen Wert.

Argumente:

zsatz ist der feste Zinssatz einer Kapitalanlage pro Verzinsungsperiode. zsatz muss ein reeller Skalar sein. zsatz kann als Dezimalzahl (z.B. 0,0825) oder als Prozentsatz (z.B. 8,25%) ausgedrückt werden.

Hinweis: Gegebenenfalls müssen Sie den Zinssatz für die jeweilige Verzinsungsperiode berechnen. Für die Berechnung des monatlichen Zinssatzes aus dem jährlichen Zinssatz zum Beispiel gilt die Formel zsatz = jährl_zsatz/12.

nper ist die Gesamtzahl der Verzinsungsperioden pro Jahr. nper ist eine positive ganze Zahl.

gw ist der gegenwärtige Wert.

zw (optional) ist der zukünftige Wert. Werden keine Angaben gemacht, so wird zw = 0 gesetzt.

typ (optional) beträgt bei Zahlungen, die am Ende der Periode vorgenommen wurden, 0, bei Zahlungen zu Beginn der Periode1. Werden keine Angaben gemacht, so wird typ = 0 gesetzt.

Hinweise:

  • Zahlungen, die Sie leisten, zum Beispiel Einlagen in einem Sparkonto oder Rückzahlungen bei einem Darlehen, müssen als negative Zahlen eingegeben werden. Zahlungen, die Sie einnehmen, zum Beispiel Dividenden, müssen als positive Zahlen eingegeben werden.


Verzinsung

gesverz(zsatz, per, nper, gw, [[zw], [typ]]) Übergibt die Gesamtverzinsung für eine Kapitalanlage oder ein Darlehen auf der Basis regelmäßiger konstanter Zahlungen über eine gegebene Zahl von Verzinsungsperioden mit einem festen Zinssatz und einem bestimmten gegenwärtigen Wert.

Argumente:

zsatz ist der feste Zinssatz pro Periode. zsatz ist ein reller Skalar. zsatz kann als Dezimalzahl, z. B. 0,00825, oder als Prozentzahl, z. B. 8,25%, ausgedrückt werden. zsatz ³ 0.

Hinweis: Gegebenenfalls müssen Sie den Zinssatz für die jeweilige Verzinsungsperiode berechnen. Für die Berechnung des monatlichen Zinssatzes aus dem jährlichen Zinssatz zum Beispiel gilt die Formel zsatz = jährl_zsatz/12.

per ist die Periode, für die Sie den Zinssatz ermitteln wollen. per ist eine positive Ganzzahl.

nper ist die Gesamtzahl der Verzinsungsperioden. nper ist eine positive Ganzzahl. per [image] nper.

gw ist der gegenwärtige Wert.

zw (optional) ist der zukünftige Wert. Werden keine Angaben gemacht, so wird zw = 0 gesetzt.

typ (optional) beträgt bei Zahlungen, die am Ende der Periode vorgenommen wurden, 0, bei Zahlungen zu Beginn der Periode1. Werden keine Angaben gemacht, so wird typ = 0 gesetzt.

Hinweise:

  • Zahlungen, die Sie leisten, zum Beispiel Einlagen in einem Sparkonto oder Rückzahlungen bei einem Darlehen, müssen als negative Zahlen eingegeben werden. Zahlungen, die Sie einnehmen, zum Beispiel Dividenden, müssen als positive Zahlen eingegeben werden.

Beispiel:

Bei einem Darlehen über € 8.000 mit einer Laufzeit von drei Jahren und einem jährlichen Zinssatz von 10% beträgt die Verzinsung im ersten Monat:

gesverz((,10/12),1,36,8000) = -66,67


Tilgung

trate(zsatz, per, nper, gw, [[zw], [typ]] Übergibt die Tilgungsrate bzw. Kapitalrate für eine Kapitalanlage oder ein Darlehen auf der Basis regelmäßiger konstanter Zahlungen über eine gegebene Zahl von Verzinsungsperioden mit einem festen Zinssatz und einem bestimmten gegenwärtigen Wert.

Argumente:

zsatz ist der feste Zinssatz pro Periode. zsatz ist ein reller Skalar. zsatz kann als Dezimalzahl, z. B. 0,00825, oder als Prozentzahl, z. B. 8,25%, ausgedrückt werden. zsatz ³ 0.

Hinweis: Gegebenenfalls müssen Sie den Zinssatz für die jeweilige Verzinsungsperiode berechnen. Für die Berechnung des monatlichen Zinssatzes aus dem jährlichen Zinssatz zum Beispiel gilt die Formel zsatz = jährl_zsatz/12.

per ist die Periode, für die Sie den Zinssatz ermitteln wollen. per ist eine positive Ganzzahl.

nper ist die Gesamtzahl der Verzinsungsperioden. nper ist eine positive Ganzzahl. per £ nper.

gw ist der gegenwärtige Wert.

zw (optional) ist der zukünftige Wert. Werden keine Angaben gemacht, so wird zw = 0 gesetzt.

typ (optional) beträgt bei Zahlungen, die am Ende der Periode vorgenommen wurden, 0, bei Zahlungen zu Beginn der Periode 1. Werden keine Angaben gemacht, so wird typ = 0 gesetzt.

Hinweise:

  • Zahlungen, die Sie leisten, zum Beispiel Einlagen in einem Sparkonto oder Rückzahlungen bei einem Darlehen, müssen als negative Zahlen eingegeben werden. Zahlungen, die Sie einnehmen, zum Beispiel Dividenden, müssen als positive Zahlen eingegeben werden.

Beispiel:

Eine Baudarlehen von € 100.000 mit einer Laufzeit von 10 Jahren wird mit 8,0% p.a. verzinst. Die im ersten Monat des Darlehens entrichtete Gesamttilgung beträgt:

trate((8%/12),1,120,100000) = 546.61


Lösen von Teildifferentialgleichungen

Teildifferentialgleichungen in Gleichungssystemen

tdglösen(u, x, xbereich, t, tbereich, [xpte], [tpte])) Gibt eine Funktion oder einen Funktionsvektor von x und t zurück, durch die eine eindimensionale Teildifferentialgleichung oder ein System von Teildifferentialgleichungen gelöst wird. Hyperbolische und parabolische Teildifferentialgleichungen sind zulässig. Die Werte werden unter Verwendung des numerischen Verfahrens zeilenweise aus einer Matrix mit Lösungspunkten berechnet.

Argumente:

u ist der explizite Vektor der Funktionsnamen (ohne enthaltene Variablen), genau wie im Gleichungssystem angezeigt. Bei einer einzelnen Teildifferentialgleichung wird dieses Argument zu einem Skalar.

x ist die räumliche Variable.

xbereich ist ein Spaltenvektor mit 2 Elementen, der die Grenzwerte für x enthält. Beide Werte müssen reell sein.

t ist die Zeitvariable.

tbereich ist ein Spaltenvektor mit 2 Elementen, der die Grenzwerte für t enthält. Beide Werte müssen reell sein.

xpte (optional) ist die ganzzahlige Anzahl räumlicher Diskretisierungspunkte.

tpte (optional) ist die ganzzahlige Anzahl zeitlicher Diskretisierungspunkte.

Verwenden Sie die Funktion wie folgt:

Schritte für die Arbeit mit der Funktion tdglösen zur Lösung einer Teildifferentialgleichung.

Geben Sie das Wort Vorgabe ein, um das Gleichungssystem zu starten.

Geben Sie unter Vorgabe die Differentialgleichung einschließlich ihrer Nebenbedingungen ein. Verwenden Sie hierzu Boolesche Operatoren. Unbekannte Gleichungen müssen hinsichtlich ihrer Variablen audrücklich angegeben werden, d. h. Sie müssen u(x,t) angeben, nicht nur u. Es sind Dirichlet- und Nemann-Randbedingungen sowie algebraische Nebenbedingungen und gekoppelte gewöhnliche Differentialgleichungen zulässig.

Die Tieferstellung zeigt partielle Ableitungen innerhalb des Gleichungssystems an. So ist beispielsweise uxx(x,t) die zweite partielle Ableitung von u mit Bezug auf x.

Weisen Sie die Ausgabe der Funktion tdglösen einem Funktionsnamen oder dem Namen eines Funktionsvektors zu.

Hinweise:

  • tdglösen verwendet zum Lösen von Teildifferentialgleichungen das zeilenweise numerische Verfahren. Da keine anderen Lösungsalgorithmen unterstützt werden, werden Ihnen keine alternativen Verfahren angezeigt, wenn Sie mit der rechten Maustaste auf tdglösen klicken.

  • Das zeilenweise numerische Verfahren ist nur zur Lösung hyperbolischer und parabolischer Teildifferentialgleichungen sowie partieller algebraischer Gleichungen geeignet. Wenn Sie eine elliptische Teildifferentialgleichung, etwa eine Poissonsche Gleichung, lösen wollen, müssen Sie die Funktion relax oder multigit verwenden.

  • Wenn die unbekannten Funktionen beispielsweise f, g und h sind (entsprechend den Namen im Gleichungssystem), dann muss u im Tdglösen-Aufruf ausdrücklich als Spaltenvektor angegeben werden:
    f
    g
    h

    Es sollen nur die Funktionsnamen angezeigt werden, geben Sie den Vektor nicht wie folgt ein:
    f(x,t)
    g(x,t)
    h(x,t)

    Bei der Benennung von Funktionen dürfen weder Literal- noch Feldindizies verwendet werden, damit die tiefergestellte Notation von partiellen Differentialgleichungen berücksichtigt wird.


Prozent

%

Tastaturbefehl: %

Beschreibung: Diese Konstante ist auf 0,01 festgelegt. Mithilfe dieser Konstante können Sie leicht mit Prozentzahlen arbeiten. Beispiel:


Permutationen

permut(n,k) Gibt die Anzahl der Möglichkeiten zurück, wie n Objekte bei Auswahl von k Objekten geordnet werden können. Jede dieser Reihenfolgen wird als eine Permutation bezeichnet.

Argumente:

n und k müssen ganze Zahlen größer oder gleich null sein.

n muss größer als oder gleich k sein.

Hinweise:

  • Kombinationen und Permutationen ähneln sich, da es sich in beiden Fällen um Teilmengen einer Menge handelt. Im Unterschied zu einer Kombination ist aber bei einer Permutation die interne Reihenfolge von entscheidender Bedeutung.

  • Die Anzahl der Permutationen wird üblicherweise wie folgt angegeben [image]:

Die Definition einer Permutation lautet:


pi

Tastaturbefehl: p+Strg+g oder Strg+Umschalttaste+p

Beschreibung: Der Wert von p zu 15 Dezimalstellen in numerischen Berechnungen.

Der genaue Wert von p in symbolischen Berechnungen.


Dialogfeld "Bildeigenschaften"

Im Dialogfeld "Bildeigenschaften" finden Sie die folgenden Optionen und Schaltflächen:

Bereich "Eingabe"

Ermöglicht die Festlegung eines Bildformats:

Graustufen

RGB

HSV

HLS

Option "Aus Zwischenablage importieren"

Importiert das in der Zwischenablage abgelegte Bild. Diese Position steht zur Verfügung, wenn Sie ein Bild in der Zwischenablage ablegen, indem Sie es aus einem Anwendungsprogramm kopiert haben.

Bereich "Ausgabe"

Ermöglicht die Auswahl eines Formats für den Ausschnitt des Bildes, der ausgegeben werden soll:

Graustufen

RGB

HSV

HLS

Diese Optionen stehen nur dann zur Verfügung, wenn Sie Ausgewählte Matrix ausgeben aktiviert haben.

Ausgewählte Koordinaten ausgeben

Gibt die Koordinaten für einen von Ihnen ausgewählten Ausschnitt des Bildes aus. Wenn Sie diese Option aktivieren, erscheint links neben dem Bild ein Platzhalter. Füllen Sie diesen Platzhalter mit einem Variablennamen für die Koordinaten aus.

Ausgewählte Matrix ausgeben

Gibt die Werte für einen von Ihnen ausgewählten Ausschnitt des Bildes aus. Wenn Sie diese Option aktivieren, erscheint links neben dem Bild ein Platzhalter. Füllen Sie diesen Platzhalter mit einem Variablennamen für die Ausgabematrix aus.


Platzhalter (Definition)

Platzhalter

Das kleine, schwarze Feld in einem Rechenbereich ist ein Platzhalter. Der Platzhalter zeigt an, dass der mathematische Ausdruck oder das Diagramm unvollständig ist. Um den Ausdruck bzw. das Diagramm zu vervollständigen, müssen Sie etwas Passendes in den Platzhalter eingeben.

Klicken Sie dazu auf den Platzhalter, und geben Sie das Gewünschte ein.


Schaltfläche "Wiedergeben"

Klicken Sie hierauf, um die Wiedergabe der Animation zu starten. Wenn die Animation bereits abgespielt wird, wird die Wiedergabe durch Klicken auf diese Schaltfläche gestoppt.


Schaltfläche "Wiedergeben" für Geschwindigkeit, Bildgröße etc.

Durch Klicken auf diese Schaltfläche rufen Sie ein Menü auf, mithilfe dessen Sie die Wiedergabegeschwindigkeit, die Größe des Bildes sowie verschiedene andere Konfigurationsoptionen festlegen können.

Mit diesem Menü können Sie außerdem eine vorhandene Datei öffnen.


Wiedergeben (Dialogfeld)


Wiedergeben (Fenster)

Klicken Sie auf die verschiedenen Teile des folgenden Bildes, um nähere Beschreibungen zu den einzelnen Elementen zu erhalten.


Achsenskalierung bei Diagrammen - Autom. Skalierung

Jedes Diagramm, das Sie erstellen, wird standardmäßig automatisch skaliert.

Wenn "Autom. Skalierung" aktiviert ist, wird für jede Achsenbegrenzung die erste Hauptskalenmarkierung hinter dem Ende der Daten festgelegt.

Ist das Kontrollkästchen "Autom. Skalierung" nicht aktiviert, endet die Achse direkt mit dem letzten Datenpunkt.

Deaktivieren Sie "Autom. Skalierung", wird das Diagramm bis zum Rand des Diagrammbereichs gezeichnet:

  • Wählen Sie im Menü Format den Befehl Diagramm / X-Y-Diagramm und klicken dann auf das Kontrollkästchen "Autom. Skalierung" für die jeweilige Achse, um die Option zu deaktivieren.


Diagrammperspektive für eine Matrix

In der Standardperspektive erstreckt sich die erste Zeile der Matrix von der hinteren linken Ecke des Gitters nach rechts, und die erste Spalte erstreckt sich von der hinteren linken Ecke auf den Betrachter zu.


Punktoptionen für ein 3D-Diagramm

Zum Zeichnen und Formatieren der Punkte in einem 3D-Diagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf das Diagramm, um das Dialogfeld "3D-Diagrammformat" zu öffnen.

  2. Klicken Sie auf die Registerkarte "Darstellung".

  3. Mit den Optionen im Abschnitt "Punktoptionen" der Seite "Darstellung" haben Sie folgende Möglichkeiten:

    • Zeichnen oder Entfernen von Punkten

    • Wählen von Symbolen für die einzelnen Punkte

    • Festlegen einer Größe für die Symbole

    • Einfärben der Symbole mit einer Volltonfarbe oder nach einem Farbschema

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


Zeiger

Der Zeiger oder Mauszeiger ist das Element, das sich beim Verschieben der Maus auf dem Bildschirm bewegt. Er kann viele verschiedene Formen annehmen. Klicken Sie unten auf das entsprechende Bild, wenn Sie genauere Angaben benötigen.

Setzen des Cursors

Ändern der Größe eines Bereichs

Ziehen eines Bereichs

Ziehen des mathematischen Ausdrucks


Poissonsche Verteilung

Verteilungen mit Bezug auf die Poissonsche Gleichung:

dpois(k, l ) Gibt die Wahrscheinlichkeitsdichte für die Poisson-Verteilung zurück.

ppois(k, l ) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qpois(p, l ) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rpois(m, l) Gibt einen Vektor aus m Zufallszahlen zurück, die die Poisson-Verteilung aufweisen.


Lösung von Teildifferentialgleichungen im Relaxationsverfahren

Relaxationsverfahren für Teildifferentialgleichungen

relax(a, b, c, d, e, f, u, rjac)

Gibt eine quadratische Matrix zurück, in der die Position eines Elements in der Matrix seiner Position im quadratischen Bereich entspricht und der Wert eines Elements an diesem Punkt die Lösung der Poisson-Teildifferentialgleichung am besten darstellt.

Argumente:

a, b, c, d, e sind quadratische Matrizen gleicher Größe, die die Koeffizienten der Differentialgleichung enthalten.

f ist eine quadratische Matrix, die für alle Punkte innerhalb des Quadrats den Quellterm enthält.

u ist eine quadratische Matrix, die Grenzwerte entlang der Ränder des Bereichs sowie Anfangsschätzwerte für die Lösung innerhalb des Bereichs enthält.

rjac ist ein Spektralradius der Jacobi-Iteration. Hiermit wird die Konvergenz des Relaxationsalgorithmus bestimmt. Sie kann zwischen 0 und 1 liegen, der optimale Wert hängt jedoch von den genauen Einzelheiten Ihres Problems ab.

Hinweise:

  • Diese Funktion verwendet das Relaxationsverfahren zum Ermitteln der Lösung.

  • Verwenden Sie die Funktion relax, wenn Sie den Wert kennen, den die unbekannte Funktion u(x, y) an allen vier Seiten eines quadratischen Bereichs annimmt.

  • Wenn die Randbedingung an allen vier Seiten des Gebiets für die Quadratintegration Null ist, ist stattdessen die Funktion multigit zu verwenden.

  • Die Poissonsche Gleichung

    verkürzt sich im Fall r = 0 zur Laplace-Gleichung.

  • Wenn Sie eine hyperbolische oder parabolische Teildifferentialgleichung oder ein System von Teildifferentialgleichungen lösen wollen, siehe Tdglösen.


Lösen von Teildifferentialgleichungen mit "multigit"

Multigit-Verfahren für Teildifferentialgleichungen

multigit(M, nzyklus)

Gibt eine quadratische Matrix zurück, in der die Position eines Elements in der Matrix seiner Position im quadratischen Bereich entspricht und der Wert eines Elements an diesem Punkt für den Fall, dass die Randbedingungen auf allen vier Seiten null sind, die Lösung der Poissonschen Teildifferentialgleichung am besten darstellt.

Argumente:

M ist eine quadratische Matrix mit 1+2^n Zeilen, deren Elemente dem Quellterm am entsprechenden Punkt im Quadratgebiet entsprechen.

nzyklus ist die Anzahl der Zyklen auf jeder Ebene der multigit-Iteration. Der Wert 2 gibt im allgemeinen eine gute Annäherung an die Lösung.

Hinweise:

  • Wenn u(x, y) nicht auf allen vier Seiten des Quadrats null ist, verwenden Sie die Funktion relax.

  • Die Poissonsche Gleichung

    verkürzt sich im Fall r = 0 zur Laplace-Gleichung.

  • Wenn Sie eine hyperbolische oder parabolische Teildifferentialgleichung oder ein System von Teildifferentialgleichungen lösen wollen, siehe Tdglösen.


Kreiswinkelfunktionen

Kreiswinkel

winkel(x,y) Diese Funktion gibt einen Winkel (in Radiant) zwischen der positiven x-Achse und dem Punkt (x,y) zurück. Der zurückgegebene Wert liegt stets zwischen 0 und 2p (aber nicht gleich 2p).

atan2(x,y) Gibt den Winkel (in Radiant) zwischen der x-Achse und einer Linie, die den Ursprung (0,0) und den Punkt (x,y) enthält, zurück. Der zurückgegebene Wert liegt stets zwischen -p und p (auch gleich p).

Argumente:

Sowohl x als auch y müssen reell sein.

Hinweise:

Die Funktion atan2 steht zu den Funktionen atan und arg wie folgt in Beziehung:

atan2(x,y) = atan(y/x) (obwohl atan Werte zwischen -p/2 und p/2 zurückgibt)

atan2(x,y) = arg(x + yi)

Die von atan2 zurückgegebenen Werte (in Radiant) liegen immer zwischen -p und p, einschließlich p.

Wird ein positives Ergebnis zurückgegeben, wird der Winkel von der x-Achse aus entgegen dem Uhrzeigersinn gemessen.

Wird ein negatives Ergebnis zurückgegeben, wird der Winkel von der x-Achse aus im Uhrzeigersinn gemessen.

Verwandte Themen: Umwandlung in Grad.


Polygammafunktion


Polynomregression

regress(vx,vy,k)Gibt einen Vektor zurück, mit dem interp die Polynomfläche k-ter Ordnung sucht, die den Datenwerten x und y in vx und vy am besten entspricht.

interp(vs,vx,vy,x)Gibt einen interpolierten Wert für y zurück, der x entspricht. Sie erhalten vs aus regress.

Argumente:

  • vx ist ein Vektor aus reellen Datenwerten. Diese entsprechen den x -Werten.

  • vy ist ein Vektor aus reellen Datenwerten. Diese entsprechen den y-Werten. Die Anzahl der Elemente entspricht der von vx.

  • vs ist ein Vektor, der von regress generiert wird.

  • k ist eine positive ganze Zahl, die die Ordnung des Polynoms angibt, das Sie an die Daten anpassen wollen. Für gewöhnlich gilt k < 5.

  • x ist der Wert der unabhängigen Variable, an der die Regressionskurve ausgewertet werden soll.

Hinweise:

  • Regress erweist sich als sinnvoll, wenn Sie verschiedene gemessene y-Werte haben, die x-Werten entsprechen, und ein einzelnes Polynom beliebiger Ordnung an diese y-Werte angepasst werden soll.

  • Immer, wenn Sie die Funktion regress verwendet haben, sollten Sie die Funktion interp einsetzen.

  • Da die Funktion regress versucht, alle Ihre Datenpunkte mit einem einzigen Polynom abzudecken, kommt es zu keinem sinnvollen Ergebnis, wenn sich Ihre Daten nicht wie ein Einzelpolynom verhalten. Soll eine lokalisiertere Regression vorgenommen werden, ist die Funktion loess zu verwenden.

  • Wenn Sie eine Fläche an die Daten x, y und z anpassen sollen, verwenden Sie für die multivariable Polynomregression die Funktion regress.


Polynomregression, lokalisiert

loess(vx,vy,bereich)Gibt einen Vektor zurück, mit dem interp versucht, eine Reihe von Polynomflächen zweiter Ordnung zu finden, die einer Umgebung der Datenwerte x und y in vx und vy am ehesten entpricht. bereich bestimmt die Größe der Umgebung.

interp(vs,vx,vy,x) Gibt einen interpolierten Wert für y zurück, der x entspricht. Sie erhalten vs aus loess oder regress.

Argumente:

  • vx ist ein Vektor aus reellen Datenwerten in aufsteigender Reihenfolge. Diese entsprechen den x -Werten.

  • vy ist ein Vektor aus reellen Datenwerten. Diese entsprechen den y-Werten. Die Anzahl der Elemente entspricht der von vx.

  • vs ist ein Vektor, der von loess generiert wird.

  • bereich ist eine positive reelle Zahl, mit der die Größe der gewünschten Umgebung angegeben wird. Für bereich sind große Werte zu empfehlen, wenn sich die Daten über verschiedenen Bereichen von x sehr unterschiedlich verhalten. Allgemein ist bereich = 0,75 als Standardwert gut geeignet.

  • x ist der Wert der unabhängigen Variable, an der die Regressionskurve ausgewertet werden soll.

Hinweise:

  • loess erweist sich als sinnvoll, wenn Sie verschiedene gemessene y-Werte haben, die x-Werten entsprechen, und ein einzelnes Polynom beliebiger Ordnung an diese y-Werte angepasst werden soll.

  • Immer, wenn Sie die Funktion loess verwendet haben, sollten Sie die Funktion interp einsetzen.

  • Diese Funktion versucht, unterschiedliche Polynome zweiten Grades in Abhängigkeit davon, wo Sie sich auf der Kurve befinden, anzupassen. Dies erfolgt, indem die Daten in einer engen Umgebung des Punktes, der von Interesse ist, geprüft werden. Die Größe dieser Umgebung legen Sie über das Argument bereich fest. Wenn bereich größer wird, entspricht loess der Funktion regress mit n=2.

  • Wenn Sie eine Fläche an die Daten x, y und z anpassen sollen, verwenden Sie für die multivariable Polynomregression die Funktion loess.


Algorithmus der Funktion "nullstellen"

Standardmäßig ermittelt die Funktion nullstellen Wurzeln anhand einer LaGuerreschen Formel. Falls gewünscht, können stattdessen die Begleitmatrixmethode verwenden wie folgt:

  1. Klicken Sie mit der rechten Maustaste auf die Funktion nullstellen.

  2. Wählen Sie im Kontextmenü die Option Begleitmatrix.


Kontextmenü

Das Menü, das erscheint, wenn Sie mit der rechten Maustaste auf einen Bereich klicken, den Sie zuvor durch Klicken mit der linken Maustaste markiert haben.


Standardabweichung für Population

qwbspv(A, B, C, ...) Übergibt die Quadratwurzel der Varianz der Werte A, B, C, ...

Argumente:

A, B, C, ... sind Felder oder Skalare.

Hinweis:

Die Funktion qwbspv dividiert zur Berechnung der Varianz durch n (die Gesamtzahl der Werte), und nicht durch n-1. Sie können die Standardabweichung, die dem Nenner n-1 entspricht, dadurch berechnen, dass Sie das Ergebnis dieser Funktion mit der Quadratwurzel von n/(n-1) multiplizieren.

Beispiele:

Weitere Funktionen für die Datenanalyse...


var, Funktion (Populationsvarianz)

var (Populationsvarianz)

Argumente:

A, B, C, ... sind Skalare oder Felder mit mxn Elementen.

Diese Funktion dividiert zur Berechnung der Varianz durch t, also durch die Gesamtzahl der Werte, und nicht durch t -1. Sie können die Varianz, die dem Nenner t-1 entspricht, dadurch berechnen, dass Sie das Ergebnis dieser Funktion mit t/(t-1) multiplizieren.

Weitere Funktionen für die Datenanalyse...


Position

Die Position gibt an, ob der Text auf der Grundlinie bleibt oder hoch- bzw. tiefgestellt wird.


Postfix-Notation

Mit der Suffix-Notation kann ein einstelliger Operator angezeigt werden. Bei der Suffix-Notation erscheint der Operator nach dem Operanden. Beispiel:


Leistungs- und Phasenspektrum von FFTs

Die Funktionen fft und cfft geben den Real- und den Imaginärteil der Fourier-Transformation zurück. Mit dem Operator "Vektorisieren" können Sie daraus das Leistungsspektrum und das Phasenspektrum wie folgt ermitteln:

Das Leistungsspektrum, die Frequenzverteilung der Leistung, gegeben durch

und das Phasenspektrum, die Frequenzverteilung der Phase, gegeben durch

können in Mathcad auf folgende Weise effizient berechnet werden:

Zum Verwenden des Operators "Vektorisieren" gehen Sie wie folgt vor:

  • Setzen Sie den gesamten Ausdruck zwischen Bearbeitungslinien.

  • Drücken Sie Strg+-

Der Operator "Vektorisieren" bewirkt, dass der Operator "Betrag" den absoluten Wert jedes Elements in v, und nicht den absoluten Wert des Vektors v selbst, zurückgibt.


Potenzregression

potanp(vx,vy,vg) Übergibt einen Vektor mit den Koeffizienten einer Potenzkurve der Form a*xb+c, die die Daten in vx und vy am besten darstellt. vg enthält Schätzwerte für die drei Koeffizienten.

Argumente:

  • vx ist ein Vektor aus reellen Datenwerten. Die Werte in vx entsprechen den x-Werten.

  • vy ist ein Vektor aus reellen Datenwerten. Die Werte in vy entsprechen den y-Werten.

  • vg ist ein dreidimensionaler Vektor mit reellen Schätzwerten für die Parameter a, b und c in der Potenzgleichung:

Hinweis:

vx und vy müssen jeweils die gleiche Anzahl von Elementen enthalten.


Genauigkeit in Datendateien

PRNPRECISION (Standard = 4)

Diese Konstante stellt die Anzahl der signifikanten Ziffern beim Schreiben in eine Datei mit der Funktion PRNSCHREIBEN dar.

Um dies zu ändern, wählen Sie im Menü Extras den Befehl Arbeitsblattoptionen und klicken Sie im Dialogfeld auf die Registerkarte "Vordefinierte Variablen".


Dialogfeld "Einstellungen" - Registerkarte "Allgemein"

Auf der Registerkarte "Allgemein" des Dialogfelds "Einstellungen" finden Sie die folgenden Optionen:

Mathcad-Tipps beim Programmstart anzeigen

Wenn diese Option aktiviert ist, erscheint bei jedem Starten von Mathcad das Dialogfeld "Tipps und Tricks".

Standardmäßige Windows-Tastaturbefehle

Wenn diese Option aktiviert ist, gelten für bestimmte Operationen, wie z. B. für das Drucken und das Rückgängigmachen, die von den Standard-Windows-Anwendungen her bekannten Tastaturbefehle. Ist diese Option nicht aktiviert, gelten die Tastaturbefehle weiter, die von früheren Mathcad-Versionen her bekannt sind. Die jeweils gültigen Tastaturbefehle werden direkt neben den Menübefehlen in der Menüleiste angezeigt.

Kontextspezifische Gleichheitszeichen

Ermöglicht das Einfügen des Gleichheitszeichens über die Taste "=", wenn sich der Cursor hinter einer definierten Variablen befindet, bzw. das Einfügen eines Definitionssymbols (:=), wenn er sich hinter einer nicht definierten Variable befindet.

Standardmäßiger Speicherort des Arbeitsblattes

Legt fest, auf welches Verzeichnis die Dialogfelder Öffnen und Speichern unter verweisen, wenn sie nach dem Starten der Anwendung erstmalig aufgerufen werden.

Zuletzt verwendete Dateien

Bestimmt, wie viele vor Kurzem geöffnete Arbeitslätter im Menü Datei angezeigt werden. Der Standardwert ist 4 Arbeitsblätter.

Verlauf rückgängig machen

Legt fest, wie viele Aktionen Sie rückgängig machen können. Zulässig ist jede beliebige Zahl zwischen 20 und 200, der Standardwert ist 100.


Dialogfeld "Einstellungen" - Registerkarte "HTML-Optionen"

Mithilfe der Registerkarte "HTML-Optionen" können Sie festlegen, wie Mathcad Dokumente in das HTML-Format exportiert. Mathcad-Dokumente können als HTML-Dateien mit Bildern für die mathematischen Bereiche oder als HTML-Dateien mit integrierten MatML-Präsentationsbereichen gespeichert werden. In beiden Fällen können als HTML-Dateien gespeicherte Dokumente ohne Funktionalitätseinbußen wieder in Mathcad importiert werden (siehe Hinweise unten). Diese Optionen können auch für jedes Dokument einzeln eingerichtet werden, wenn Sie den Befehl "Als Web-Seite speichern..." verwenden.

Auf der Registerkarte HTML-Optionen des Dialogfelds Einstellungen finden Sie die folgenden Optionen:

Gleichungen speichern unter:

Bilder: Bei Auswahl von "Bilder" werden alle Gleichungsbereiche als PNG- oder JPEG-Dateien, je nach Auswahl unten, angezeigt. Für die Anzeige in einem Browser ist bei dieser Option keine zusätzliche Software erforderlich.

MathML: Bei Auswahl von MathML können Sie den MathML-Style aus dem Dropdown-Menü "Anzeigen mit" wählen. Inline-MathML wird in Browsern wiedergegeben, die MathML unterstützen. Für die anderen Optionen ist in der Regel ein Browser-Plug-in oder eine Active-X-Komponente erforderlich. Informationen zu den aktuellen Darstellungsoptionen finden Sie unter www.mathcad.com.

Bilder speichern als:

PNG: PNG ist ein verlustfreies Format, d. h., es gehen keine Daten verloren, aber die so gespeicherten Dateien sind größer.

JPEG: Bei Auswahl von JPEG können Sie außerdem die Qualität der Kompression festlegen. Je höher Sie diesen Wert einstellen, desto weniger werden die Bilder komprimiert und desto größer sind die so gespeicherten Bilddateien.

Bei reiner HTML-Ausgabe werden alle Rechenbereiche mit dem ausgewählten Bildformat exportiert. Bei MathML-Ausgabe werden nur Diagramme, Tabellen und Komponenten als Bilder ausgegeben.

Layout speichern als:

Fest: Bei der Einstellung "Fest" kommen absolute Tags für die Styles zum Einsatz, so dass das Mathcad-Layout nachempfunden wird.

Relativ: Bei der Einstellung "Relativ" wird der Inhalt des Mathcad-Arbeitsblatts in eine HTML-Tabelle exportiert. Für die Verwendung von HTML-Exportvorlagen muss die relative Positionierung gewählt werden.

Web-Seitenvorlage:

Wählen Sie, falls gewünscht, eine Vorlagendatei. Vorlagen gestalten Mathcad-Dokumente mit zusätzlicher HTML-Ausgabe und können nur verwendet werden, wenn für das Layout "Relativ" ausgewählt wurde. Sie lassen sich gut zur Erzielung eines einheitlichen Aussehens und für die Navigation zu zahlreichen Matchcad-Dokumenten verwenden und können zur Erstellung großer Websites eingesetzt werden. Weitere Anweisungen finden Sie in der Author's Reference (Autorenreferenz) im Menü Hilfe.

Hinweise:

Alle mit Mathcad gespeicherten HTML-Dokumente weisen in die Code-Tags integrierten MathML-Inhalt auf. In der vorliegenden Version von MathML kann ein Dokument erneut in Mathcad eingelesen werden. Davon ausgenommen sind nur geschützte Dokumente, die keinen MathML-Inhalt erstellen, um die Sicherheitsoptionen zu beachten.


Dialogfeld "Einstellungen" - Registerkarte "Sprache"

Auf der Registerkarte "Sprache" können Sie einstellen, wie Mathcad mit sprach- und länderspezifischen Einstellungen, etwa dem Dialekt der Rechtschreibprüfung, der Anzeige der Menüs und Dialogfelder sowie der Namen von Funktionen und Einheiten, umgehen soll.

Auf der Registerkarte "Sprache" des Dialogfelds "Einstellungen" finden Sie die folgenden Optionen und Schaltflächen:

Pulldown-Menü "Rechtschreibprüfung - Dialekt"

Ermöglicht die Auswahl des Dialekts, den die Rechtschreibprüfung verwenden soll. Zur Auswahl stehen zum Beispiel "American English", "British English (-ise)" und "British English (-ize)" für verschiedene Varianten des Englischen. Mit "British English (-ise)" werden Schreibweisen wie "realise" zugelassen, mit "British English (-ize)" Schreibweisen wie "realize".


Dialogfeld "Einstellungen" - Registerkarte "Skriptsicherheit"

Mithilfe der Registerkarte Skript-Sicherheit können Sie festlegen, wie Mathcad skriptfähige Komponenten behandeln soll. Skriptfähige Komponenten können zur Steuerung der Interaktion zwischen Mathcad und der zugrunde liegenden Anwendung eine Skriptsprache, wie z.[nbsp]B. VBScript oder JScript, verwenden und unter Umständen auch gefährlichen Code enthalten.

Auf der Registerkarte Skriptsicherheit des Dialogfelds Einstellungen finden Sie die folgenden Optionen:

Hohe Sicherheit

Deaktiviert automatisch alle skriptfähigen Komponenten im Arbeitsblatt, wenn das Arbeitsblatt geöffnet wird. Wenn Sie eine Komponente aktivieren bzw. wieder deaktivieren möchten, klicken Sie mit der rechten Maustaste auf die Komponente, und wählen Sie dann Auswertung aktivieren.

Mittlere Sicherheit

Sie werden beim Öffnen von Arbeitsblättern, die eine skriptfähige Komponente enthalten, gefragt, ob die skriptfähigen Komponenten deaktiviert werden sollen. Durch Klicken auf Ja werden alle skriptfähigen Komponenten im Arbeitsblatt deaktiviert.

Geringe Sicherheit

Öffnet das Arbeitsblatt ohne jeden Schutz vor möglicherweise gefährlichen skriptfähigen Komponenten.


Präfix-Notation

Mit der Präfix-Notation kann ein einstelliger Operator angezeigt werden. Bei der Präfix-Notation erscheint der Operator vor dem Operanden. Beispiel:


Gegenwärtiger Wert

gw(zsatz, nper, zrate, [[zw], [typ]]) Übergibt den gegenwärtigen Wert für eine Kapitalanlage oder ein Darlehen auf der Basis regelmäßiger konstanter Zahlungen über eine gegebene Zahl von Verzinsungsperioden mit einem festen Zinssatz und festgelegten Zahlungsraten.

Argumente:

zsatz ist der feste Zinssatz einer Kapitalanlage pro Verzinsungsperiode. zsatz muss ein Skalar sein. zsatz kann als Dezimalzahl (z.B. 0,0825) oder als Prozentsatz (z.B. 8,25%) ausgedrückt werden.

Hinweis: Gegebenenfalls müssen Sie den Zinssatz für die jeweilige Verzinsungsperiode berechnen. Für die Berechnung des monatlichen Zinssatzes aus dem jährlichen Zinssatz zum Beispiel gilt die Formel zsatz = jährl_zsatz /12.

nper ist die Gesamtzahl der Verzinsungsperioden pro Jahr. nper ist eine positive ganze Zahl.

zrate ist die Zahlung, die pro Periode entrichtet oder eingenommen wird. Sie umfasst in der Regel Tilgungs- und Zinszahlungen, jedoch keine weiteren Abgaben und Gebühren.

zw (optional) ist der zukünftige Wert. Werden keine Angaben gemacht, so wird zw = 0 gesetzt.

typ (optional) beträgt bei Zahlungen, die am Ende der Periode vorgenommen wurden, 0, bei Zahlungen zu Beginn der Periode 1. Falls keine Angabe gemacht wird, gilt typ = 0.

Hinweise:

  • Zahlungen, die Sie leisten, zum Beispiel Einlagen in einem Sparkonto oder Rückzahlungen bei einem Darlehen, müssen als negative Zahlen eingegeben werden. Zahlungen, die Sie einnehmen, zum Beispiel Dividenden, müssen als positive Zahlen eingegeben werden.

Beispiel:

Aus einer Rentenpolice, in der € 50.000 angelegt wurden, werden zehn Jahre lang zu Beginn jedes Monats € 500 ausgezahlt, wobei die eingezahlten Prämien eine Rendite von 8 Prozent erwirtschaften. Um den gegenwärtigen Wert der Rentenversicherung zu berechnen, geben Sie folgendes ein:

gw((0,08/12), (12*10), 500, 0, 1) = -41485,48

Das Ergebnis ist negativ, da es als ein Betrag angegeben wird, den Sie zahlen müssten.


Vorherige

Zeigt die vorhergehende Seite Ihres Arbeitsblatts in der Seitenansicht an. Wenn diese Option abgeblendet dargestellt ist, verfügt Ihr Arbeitsblatt über keine vorhergehenden Seiten.


Hauptwert

Allgemein gibt es für jede Zahl n n-te Wurzeln. Für die Zahl 4 gibt es beispielsweise zwei gleichermaßen gültige Quadratwurzeln, nämlich 2 und -2.

Da aber nur einer dieser Werte zurückgegeben werden kann, muss es eine Möglichkeit geben zu wählen, welcher Wert zurückgegeben werden soll. Dazu wird der Hauptwert genommen, also der Wert mit dem kleinsten komplexen Argument. Da das Argument von 2 den Wert 0 ist und das von -2 den Wert [image] /2 hat, ist das Ergebnis 2. Dies ist zufällig auch die reelle Wurzel.


Hauptwert 0,5+.866i

Der Wert 0,5 + .866i ist der Hauptwert, da er einen Winkel von lediglich 60 Grad von der positiven reellen Achse aus bildet. Die Zahl -1 befindet sich dagegen genau auf der anderen Seite, 180 Grad von der positiven reellen Achse.


Drucken

Druckt Ihr Arbeitsblatt.


Drucken (Dialogfeld)

Im Dialogfeld "Drucken" finden Sie die folgenden Optionen und Schaltflächen:

Name

In diesem Feld können Sie festlegen, welcher Drucker verwendet werden soll. Standardmäßig sendet Mathcad den Druckauftrag an den von Ihnen als Standarddrucker festgelegten Drucker. Klicken Sie auf "Eigenschaften", wenn die Ausgabe auf einem anderen Drucker erfolgen soll.

Schaltfläche "Eigenschaften"

Wenn Sie hier klicken, wird ein Dialogfeld geöffnet, in dem Sie aus den bei Ihnen installierten Druckern einen Drucker auswählen sowie die Papiergröße, die Papierzufuhrquelle und die Ausrichtung (Quer- oder Hochformat) festlegen können. Weitere Informationen dazu finden Sie in der Dokumentation Ihres Betriebssystems.

Ausdruck in Datei

Gibt Ihr Arbeitsblatt direkt als Datei aus, statt es an einen Drucker zu senden.

Alles

Es werden alle Seiten des Arbeitsblatts gedruckt.

Seiten

Es wird ein bestimmter Seitenbereich gedruckt. Geben Sie in den Feldern "Von" und "Bis" den gewünschten Seitenbereich ein. Wenn Sie als Ausgabegerät einen Plotter festgelegt haben, können Sie immer nur eine Seite drucken.

Auswahl

Es werden nur die ausgewählten (markierten) Bereiche gedruckt. Falls die Option abgeblendet dargestellt ist, haben Sie keine Bereiche ausgewählt.

Aktuelle Seite drucken

Es wird nur die aktive Seite gedruckt. Die aktive Seite ist die Seite, auf der sich der Cursor befindet. Dies wird in der Statusleiste angezeigt. Dabei muss es sich nicht unbedingt um die Seite handeln, die gerade im Fenster angezeigt wird.

Exemplare

Mit dieser Option legen Sie fest, wie viele Exemplare des Arbeitsblatts gedruckt werden sollen. Wenn diese Option abgeblendet dargestellt ist, unterstützt Ihr Drucker diese Option wahrscheinlich nicht. Überprüfen Sie die Druckereinrichtung in Windows.


Optionen im Fenster "Seitenansicht"

Klicken Sie auf die verschiedenen Teile der folgenden Illustration, um Informationen zu deren Funktion zu erhalten:


Drucken leerer Seiten

Es folgt ein Beispiel für ein Arbeitsblatt, bei dem eine leere Seite gedruckt werden würde.


Drucken einer hervorgehobenen Gleichung

Wenn Sie ein Arbeitsblatt ausdrucken, das hervorgehobene Gleichungen enthält, hängt es vom jeweils verwendeten Drucker ab, wie die Hervorhebung dargestellt wird. Bei einigen Druckern werden farbige Passagen schwarz gedruckt, sodass hervorgehobene Gleichungen nicht mehr erkennbar sind. Andere Drucker wiederum geben die gleiche Farbe in einer solchen Graustufe aus, dass die hervorgehobene Gleichung nicht unkenntlich wird. Auf einem Farbdrucker sollte die Gleichung in der gewählten Farbe gedruckt werden.


Drucken aus dem Hilfesystem

Zum Drucken eines Themas aus dem Hilfesystem gehen Sie vor wie folgt:

  • Suchen Sie das Thema heraus, sodass es im Hilfefenster angezeigt wird, und klicken Sie auf die Schaltfläche [image].

ODER

  • Klicken Sie mit der rechten Maustaste auf das Thema im Inhaltsverzeichnis, und wählen Sie den Befehl Drucken aus dem Kontextmenü.

Hinweis:

Sollen alle Themen gedruckt werden, die mit einem bestimmten Thema verknüpft sind, so wählen Sie unten im Dialogfeld "Drucken" die Option "Alle durch Links verbundenen Dokumente drucken".


Drucken breiter Arbeitsblätter

Arbeitsblätter in Mathcad können breiter als ein Blatt Papier sein. Beim horizontalen Scrollen erscheint eine gestrichelte, vertikale Linie auf dem Bildschirm, die den rechten Rand anzeigt. Die Teile von Arbeitsblättern, die jenseits des rechten Randes liegen, werden auf zusätzlichen Seiten gedruckt. Beim Drucken von Arbeitsblättern, bei denen nur auf einigen Seiten der rechte Rand überschritten wird, werden Ihnen möglicherweise leere Seiten angezeigt.

Um das Ausdrucken aller über den rechten Rand hinausgehenden Bereiche zu unterdrücken, gehen Sie wie folgt vor:

  1. Wählen Sie im Menü "Datei" den Befehl "Seite einrichten".

  2. Aktivieren Sie die Option "Breite einer Seite drucken".

  3. Klicken Sie auf "OK".


Wahrscheinlichkeitsdichte

Gibt die Wahrscheinlichkeit an, mit der eine Zufallsvariable einen bestimmten Wert annimmt.


Verarbeiten von Arbeitsblättern mit Fehlern

Mathematische Ausdrücke, die Fehler enthalten, werden vom Arbeitsblatt nicht verarbeitet. Dies kann dazu führen, dass weitere Fehler auftreten, falls an anderer Stelle im Arbeitsblatt auf die problematische Variable bzw. das Ergebnis Bezug genommen wird.

Wenn der beanstandete Ausdruck beispielsweise eine Definition ist, bleibt die von ihm zu definierende Variable oder Funktion undefiniert. Dies kann dazu führen, dass alle Ausdrücke, die auf diese Variable oder Funktion zurückgreifen, ebenfalls undefiniert sind.


Produkt mit Bereichsvariablen

Tastaturbefehl: #

Gibt das Produkt des Ausdrucks X über den Bereich i zurück.

Operanden:

i muss ein Bereich ganzer Zahlen sein.

X ist ein beliebiger Ausdruck.

Wenn X mehrere Glieder hat, müssen Sie diese in Klammern einschließen, um sie innerhalb des Operators zu halten.

Die Bereichsvariable i ist vor der Verwendung dieses Operators zu definieren. Beispiel:


Produkt ohne Bereichsvariablen

Tastaturbefehl: Strg+Umschalt+3

Gibt das Produkt zurück, wobei i von m bis n des Ausdrucks X reicht.

Operanden:

i muss eine ganze Zahl sein.

X ist ein beliebiger Ausdruck.

m und n müssen ganze Zahlen sein und es muss gelten: m < n.

Wenn X mehrere Glieder hat, müssen Sie diese in Klammern einschließen, um sie innerhalb des Operators zu halten.

Hinweis:

Die Variable i ist nur innerhalb dieses Operators definiert und steht daher in keinerlei Zusammenhang mit Variablendefinitionen außerhalb des Operators "Produkt".


Programmierung

Programme erleichtern die Durchführung von Aufgaben, die manuell zu aufwendig oder undurchführbar wären. Der Vorteil von Programmen liegt in den Attributen der Programmiersprachen, die die Arbeit flexibel gestalten (z. B. bedingte Verzweigungen, Schleifenfunktionen, lokale Variablendefinitionen und Fehlerbehebung) sowie ihrer Fähigkeit, sich selbst rekursiv aufzurufen.

Was ist ein Programm?

Definieren von Programmen

Bedingungsanweisungen

Programmschleifen

Unterbrechungsanweisungen

Steuern von Iterationen in einer Schleife

Ausgeben eines Werts

Erkennen von Fehlern

Rekursion

Symbolisches Auswerten eines Programms


Programmierbeispiele

Die Programmierleiste von Mathcad kommt mit nur zehn Schaltflächen aus. Dementsprechend einfach ist die Programmierumgebung zu bedienen. Dennoch versteckt sich hinter diesem Minimalismus eine große Leistungsfähigkeit. In Kombination mit der umfangreichen numerischen Funktionalität von Mathcad und den abstrakten Datenstrukturen, die durch die verschachtelten Datenfelder in Mathcad verfügbar werden, haben Sie mit diesen zehn Programmieroperatoren die Möglichkeit, anspruchsvolle Programme in Mathcad zu schreiben.

In Mathcad stehen Ihnen mehrere QuickSheets zur Verfügung, in denen komplexere Programmierverfahren mit Subroutineaufrufen und Rekursionen erläutert werden. Sie können über die Verknüpfung unten darauf zugreifen.


Programmieroperatoren

+ 1 Zeile

local assignment

if

otherwise

for

while

break

continue

return

on error


Programmierleiste

Die Programmierleiste bietet schnellen Zugriff auf die Operatoren, die bei der Programmierung benötigt werden. Sie können sehen, wozu die einzelnen Schaltflächen dienen, wenn Sie den Cursor im Haupt-Arbeitsblattfenster über die Schaltfläche setzen, bis Folgendes passiert:

  • Ein QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche wird angezeigt.

  • In der Meldungszeile der Statusleiste wird eine Beschreibung ihrer Funktion angezeigt.


Dialogfeld "Eigenschaften"

Im Dialogfeld Eigenschaften können Sie die Anzeige und Interaktion ausgewählter Bereiche innerhalb des Arbeitsblattes über die Registerkarten "Region", "Berechnung", "Anzeige", "Schützen" und Text steuern. Sie können die Eigenschaften für mehrere Bereiche einrichten, indem Sie diese markieren und das Dialogfeld "Eigenschaften" öffnen. Es stehen aber nur die Registerkarten zur Verfügung, die für alle ausgewählten Bereiche gültig sind.

Dialogfeld "Eigenschaften": Registerkarte "Region"

Mit der Registerkarte Region wird die Anzeige gesperrter oder ausblendbarer Regionsbegrenzungslinien gesteuert. Sie enthält die folgenden Optionen:

Regionsname

Geben Sie einen Namen für die Region ein. Dieser wird auf der Grenze der Region angezeigt.

Linie

Wenn diese Option aktiviert ist, wird jede Region mit einer Begrenzungslinie versehen.

Symbol

Wenn diese Option aktiviert ist, erscheint links der Regionsgrenzen ein Symbol.

Name

Wenn diese Option aktiviert ist, wird der in das Textfeld "Regionsname" eingegebene Name auf der Grenze der Region angezeigt.

Zeitmarkierung (wenn Region gesperrt ist)

Wenn diese Option aktiviert ist, wird auf der Grenze der Region angegeben, wann (Datum und Uhrzeit) die Region gesperrt wurde.

Dialogfeld "Eigenschaften" - Registerkarte "Berechnung"

Die Registerkarte Berechnung ermöglicht es Ihnen, die Auswertung eines ausgewählten Bereichs in einem gewissen Grad zu steuern. Sie enthält die folgenden Optionen:

Auswertung deaktivieren

Deaktiviert einen Bereich, sodass er nicht verarbeitet wird. Neben dem Bereich, für den die Auswertung deaktiviert wurde, erscheint ein schwarzes Kästchen.

Optimierung deaktivieren

Aktiviert bzw. deaktiviert die Optimierung für einen ausgewählten Ausdruck. Durch die Optimierung kann der symbolische Prozessor einen Ausdruck vereinfachen, bevor dieser von dem numerischen Prozessor berechnet wird.

Dialogfeld "Eigenschaften" - Registerkarte "Anzeige"

Mit der Registerkarte Anzeige können Sie festlegen, wie ein Bereich im Arbeitsblatt angezeigt wird. Sie enthält die folgenden Optionen:

Bereich hervorheben

Markiert einen Bereich mit einer Farbe, sodass dieser hervorgehoben wird.

Farbe auswählen

Hiermit können Sie die Farbe auswählen, die zum Hervorheben des ausgewählten Bereichs verwendet werden soll, wenn die Option "Bereich hervorheben" aktiviert wird. Um eine Hervorhebungsfarbe für sämtliche Arbeitsblattbereiche zu bestimmen, wählen Sie aus dem Menü Format die Option Farbe Þ Hervorhebung.

Rahmen anzeigen

Versieht das markierte Bild oder die markierte Bitmap mit einem Rahmen.

In Originalgröße anzeigen

Zeigt das Bild bzw. die Bitmap in der Originalgröße an.

Tag

Sie können dem markierten Bereich einen Namen zuweisen. Wenn mehrere Bereiche ausgewählt sind, ist die Option grau unterlegt. Mit Tags können Sie Hyperlinks zu bestimmten Bereichen in einem Arbeitsblatt erstellen.

Dialogfeld "Eigenschaften" - Registerkarte "Schützen"

Auf der Registerkarte Schützen können Sie den markierten Bereich kennzeichnen, sodass er geschützt wird, wenn Sie im Menü Extras die Option Arbeitsblatt schützen auswählen. Sie enthält die folgenden Optionen:

Bereich vor Bearbeitung schützen

Wenn Sie Bereiche schützen, hat dies keinerlei Auswirkungen, sofern das Arbeitsblatt nicht geschützt ist. Sobald das Arbeitsblatt auf Inhalts- oder Bearbeitungsebene geschützt ist, können Bereiche, für die dieses Kontrollkästchen markiert ist, nicht mehr bearbeitet werden.

Dialogfeld "Eigenschaften" - Registerkarte "Text"

Die Registerkarte Text bestimmt, wie der angegebene Text mit anderen Bereichen in dem Arbeitsblatt interagiert. Sie enthält die folgenden Optionen:

Seitenbreite verwenden

Mit dieser Option legen Sie fest, dass ein Textbereich die gesamte Seitenbreite einnehmen soll.

Bereiche bei Eingabe nach unten verschieben

Mit dieser Option legen Sie fest, dass dann, wenn ein Textbereich so groß wird, dass er andere zu überlappen droht, diese nach unten verschoben werden.


Dialogfeld "Arbeitsblatt schützen"

Im Dialogfeld Arbeitsblatt schützen finden Sie die folgenden Optionen und Schaltflächen:

Datei

Beim Schutz auf Dateiebene kann das Arbeitsblatt nur als Datei des Typs Mathcad 2001i oder höher, RTF, Mathcad-Vorlage (MCT) oder als statische HTML-Datei gespeichert werden. Für die Bereiche werden keine Einschränkungen auferlegt.

Inhalt

Beim Schutz auf Inhaltsebene kann das Arbeitsblatt nur als Datei des Typs Mathcad 2001i oder höher, RTF, Mathcad-Vorlage (MCT) oder als statische HTML-Datei gespeichert werden. Die vorhandenen Bereiche sind standardmäßig geschützt und lassen sich nicht ändern. Es ist möglich, neue Bereiche zu erstellen und geschützte Bereiche zu kopieren.

Bearbeiten

Beim Schutz auf Bearbeitungsebene kann das Arbeitsblatt nur als Datei des Typs Mathcad 2001i oder höher, RTF, Mathcad-Vorlage (MCT) oder als statische HTML-Datei gespeichert werden. Die vorhandenen Bereiche sind standardmäßig geschützt und lassen sich nicht ändern. Geschützte Bereiche können nicht bearbeitet oder kopiert werden. Im Arbeitsblatt können keine neuen Bereiche angelegt werden.

Kennwort

Durch Eingabe eines Kennworts können Sie festlegen, dass nur diejenigen Personen den Schutz Ihres Arbeitsblattes aufheben dürfen, die das entsprechende Kennwort kennen. Damit Sie Ihr Arbeitsblatt mit einem Kennwort schützen können, müssen Sie es zweimal korrekt in das Dialogfeld eingeben. Die Eingabe eines Kennworts ist optional.


QR-Zerlegung

qr(A) Gibt eine Matrix zurück, deren erste n Spalten die quadratische, orthonormale Matrix Q enthalten und deren restliche Spalten die obere Dreiecksmatrix R enthalten. Mit der Funktion "submatrix" können Sie diese kleineren Matrizen extrahieren.

Die Matrizen Q und R erfüllen die Gleichung [image].

Argumente:

  • A muss ein Vektor oder eine Matrix sein.

  • Die Elemente von A müssen reell sein.


Quadratisch

Diese Option ist nur verfügbar, wenn das Erweiterungspaket Solving and Optimization (Expert Solver) installiert ist.

Wählen Sie diese Option, wenn Sie ein quadratisches Programm lösen und eine quadratische Programmierungsmethode zuweisen wollen.

Hinweise:

  • Unter einem quadratischen Programm versteht man ein Programm, in dem die Zielfunktion lineare und quadratische Glieder, z. B. in der Form a*x2 or c*x*y, enthält.

  • Wenn Sie die Option Quadratisch wählen, müssen im Lösungsblock Schätzwerte enthalten sein. Die Schätzwerte sind jedoch immateriell, sodass sie sich nicht auf die Lösung auswirken, es sei denn, es wird nach einem Matrix- oder Vektorergebnis aufgelöst. In diesem Fall gibt der Schätzwert für den Vektor bzw. die Matrix die Größe des zu suchenden Vektors bzw. der zu suchenden Matrix an.

  • Die Option Quadratisch greift bei der Lösung nicht auf die vordefinierte Variable TOL zurück.

Weitere Informationen zum Arbeiten mit der Option "Quadratisch" finden Sie unter "Referenzmaterial zu den Lösungsalgorithmen".


Lösen mit der Quasi-Newton-Methode

Die Quasi-Newton-Methode ist ein nichtlineares Verfahren, das bei den Funktionen suchen, minfehl, minimieren und maximieren verwendet werden kann.

Weitere Informationen zur Quasi-Newton-Methode finden Sie unter Referenzmaterial zu den Lösungsalgorithmen.


QuickPlots

2D QuickPlots

Um in Mathcad ein 2D-Diagramm erstellen zu können, müssen Sie zuvor die Variablen in dem darzustellenden Ausdruck definiert haben. Quickplots können jedoch gezeichnet werden, ohne vorher Variablen zu definieren.

Wenn Sie z. B. x gegen x^2 darstellen möchten, müssen Sie x zuvor als eine Bereichsvariable definiert haben. Zum Erstellen eines Quickplots stellen Sie einfach x gegen x^2 dar. Es wird ein geeigneter Bereich für x gewählt und ein Diagramm erstellt.

3D QuickPlots

Wenn Sie eine Funktion oder einen Satz von Funktionen definieren und zu einem Graphen umsetzen, erstellen Sie ein QuickPlot.


QuickSheets

Quicksheets sind Mathcad-Arbeitsblätter, die eine Vielzahl von Berechnungen demonstrieren. Wählen Sie zum Öffnen von QuickSheets im Menü Hilfe die Option QuickSheets. Sie können die Quicksheets nach einer bestimmten Funktion oder einem bestimmten Operator durchsuchen lassen. Dazu steht Ihnen die Schaltfläche "Suchen" in der Symbolleiste am oberen Rand des Fensters zur Verfügung.


Bereichsvariablen und die Wertefolgen, die sie annehmen können

Beispiele:

1,2..20 ergibt 1, 2, 3 ...20

20,19,..1 ergibt 20, 19, 18 ...1

1,1.1..5 ergibt 1, 1.1, 1.2 ...5

5,3..-7 ergibt 5, 3, 1, -1 ...-7

Um den zweifachen Punkt (..) zu erhalten, geben Sie immer einen Strichpunkt (;) ein.


Rang einer Matrix

rang(A) Gibt den Rang von A zurück.

Argumente:

  • A muss ein Vektor oder eine Matrix sein.

  • Die Elemente von A sollten reell sein.


Lesen von Daten aus einer Datendatei (Funktion LESEN)

Einlesen von Daten aus einer Datendatei

LESEN("datei") Gibt einen einzelnen Eintrag aus der Datei datei zurück.

Argumente:

datei ist der Pfad zu einer ASCII-Datei.

datei wird als Zeichenfolge eingegeben.

datei muss Zahlen enthalten, die in Spalten angeordnet und durch Tabulator- oder Leerzeichen getrennt sind.

LESEN wird im Normalfall zusammen mit einer Bereichsvariable verwendet, wie z. B.:

i := 1 .. N

:= LESEN(“datei.dat”)

Damit wird ein Feld erstellt, das die Zahlen in der Datei "datei.dat" enthält.

Die zu lesende Datei muss eine ASCII-Datei sein, die eine Liste aus durch Tabulator- oder Leerzeichen voneinander getrennten Dezimalzahlen enthält. Die Exponentialschreibweise, wie in

16E-2-16.125E-15

ist zulässig.

WARNUNG:Diese Funktion dient lediglich zur Sicherstellung der Kompatibilität mit älteren Mathcad-Versionen. Die Funktion ist jedoch veraltet und sollte nicht mehr verwendet werden. Verwenden Sie zum Schreiben von Daten in eine Datendatei stattdessen die Funktion PRNLESEN.

Verwandte Themen: Dateizugriffsfunktionen.


Dateinamenargument in Lesefunktionen

Dies ist der Name einer ASCII-Datei (im aktuellen Arbeitsverzeichnis), der als Zeichenfolge (durch Drücken von ") eingegeben wird. Beispiel:

PRNLESEN ("höhe.prn") liest aus der Datei "höhe.prn" im aktuellen Arbeitsverzeichnis.

Wenn Sie Ein-/Ausgabevorgänge mit einer Datei durchführen möchten, die sich nicht im aktuellen Standardverzeichnis befindet, müssen Sie den Pfadnamen für die Datei als Zeichenfolge eingeben. Beispiel:

PRNLESEN("c:\windows\höhe.prn") liest aus der Datei "höhe.prn" im Verzeichnis "c:\windows\data".


Lesen einer BMP-Datei als Farbbild

Lesen einer Datei als Farbbild

RGBLESEN(“datei”) Gibt ein Feld mit drei Submatrizen mit nxn Elementen zurück. Jedes Element ist eine ganze Zahl zwischen 0 und 255. Die ersten n/3 Spalten stehen für den roten Farbanteil in der datei. Die zweite und dritte Folge von n/3 Spalten steht für den Grün- und den Blauanteil desselben Bildes. Die drei zusammengehörigen Matrixelemente bestimmen jeweils die Farbe des Pixels.

Argumente:

datei ist der Pfad zu einer BMP-, GIF-, JPG-, PCX- oder TGA-Datei.

datei wird als Zeichenfolge eingegeben.

Die Aufteilung des Bildes in drei Gruppen aus jeweils n/3 Spalten erleichtert die Änderung des Bildes vor dessen Ausgabe auf dem Bildschirm. Vor der Anzeige sollten Sie das Bild jedoch in drei voneinander getrennte Matrizen mit jeweils n Spalten aufteilen, die Sie dann, durch Kommas getrennt, in den Platzhalter eingeben können.

Nach dem Einlesen einer Datei in Mathcad können Sie sich diese in einem Bildbereich anzeigen lassen.


Lesen einer BMP-Datei als Graustufenbild

BMPLESEN("datei") Gibt ein Feld ganzer Zahlen zwischen 0 (schwarz) und 255 (weiß) zurück, das eine Graustufenversion des Bildes in datei darstellt.

Argumente:

datei ist der Pfad zu einer BMP-Datei.

datei wird als Zeichenfolge eingegeben.

Nach dem Einlesen einer Datei in Mathcad können Sie sich diese in einem Bildbereich anzeigen lassen.


Lesen und Schreiben komplexer Daten in ASCII-Datendateien

Generell empfiehlt es sich, den Realteil und den Imaginärteil einer komplexen Zahl jeweils in eigene Dateien zu schreiben.

Angenommen, Z sei eine komplexe Matrix. Befehlsbeispiel:

PRNSCHREIBEN(“z_real.prn”) := Re(Z)

PRNSCHREIBEN("z_imag.prn") := Im(Z)

Um die auf diese Weise gespeicherten Daten einzulesen, geben Sie Folgendes ein:

Z := PRNLESEN(“z_real.prn”) + 1i * PRNLESEN(“z_imag.prn”)


Lesen einzelner Werte aus einer Datendatei

Wenn Sie mithilfe der Komponente Dateieingabe Daten aus einer Datendatei lesen lassen, liest Mathcad standardmäßig die gesamte Datendatei. Sie können jedoch auch einzelne Zeilen oder Spalten lesen lassen. Gehen Sie dazu wie folgt vor:

  1. Fügen Sie die Komponente "Dateieingabe" ein, sodass Daten aus einer Datendatei gelesen werden.

  2. Klicken Sie einmal auf die Komponente, damit sie ausgewählt wird.

  3. Wählen Sie den Befehl Eigenschaften aus dem Kontextmenü, um das Dialogfeld "Eigenschaften" zu öffnen.

  4. Legen Sie in diesem Dialogfeld fest, an welchen Zeilen und Spalten mit dem Lesen begonnen und aufgehört werden soll.


Einlesen von Daten aus einer Datei (Definition)

EINLESEN VON DATEN AUS EINER DATEI

Der Vorgang, bei dem Daten aus einer externen Datendatei durch das Herstellen einer Verbindung zu dieser Datendatei in ein Mathcad-Arbeitsblatt übertragen werden. Wenn sich die Datendatei ändert, werden die Daten im Mathcad-Arbeitsblatt automatisch aktualisiert.


Lesen aus einer anderen Datei und Schreiben in eine andere Datei

Bei der Verwendung der Komponenten "Dateieingabe" und "Dateiausgabe" legen Sie die Datei fest, aus der gelesen wird bzw. in die geschrieben wird. Wenn Sie dazu später eine andere Datei oder einen anderen Dateityp verwenden möchten, gehen Sie wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf die Komponente und wählen Sie aus dem Kontextmenü den Eintrag Eigenschaften. Hierdurch wird das Dialogfeld "Komponenteneigenschaften" geöffnet.

  2. Wählen Sie auf der Registerkarte "Dateioptionen" den Dateityp aus der Dropdown-Liste unterstützter Datentypen aus und blättern Sie zum Namen der Datei, die Sie öffnen möchten.

  3. Auf der Registerkarte "Datenbereich" können Sie außerdem die Einstellungen für den Datenbereich überprüfen und gegebenenfalls neue Anfangs- und Endwerte festlegen.


Einlesen des Bildes in eine Matrix

Als erster Schritt bei der Bildverarbeitung muss das Bild zur Verfügung gestellt werden, das verarbeitet werden soll. Dazu können Sie z.[nbsp]B. das Bild in eine Matrix einlesen, wie Sie dies auch mit jeder anderen Datendatei machen würden.

Dazu stehen Ihnen Dateizugriffunktionen zur Verfügung, mit denen Sie Dateien auf zweierlei Art und Weise einlesen können:

  • Erstellen Sie mit RGBLESEN oder einer anderen Einlesefunktion eine Matrix, die einer Datei entspricht. Beispiel:

    M     := RGBLESEN(”datei”)

  • Erstellen Sie mit BMPLESEN oder einer anderen Einlesefunktion eine Matrix, die der Graustufendarstellung einer konkreten Datei entspricht. Beispiel:

    M     := BMPLESEN(”datei”)

Beachten Sie, dass die Funktionen in GROSSBUCHSTABEN angegeben werden müssen.


Reelle Fourier-Transformation

fft(v) Gibt die Fourier-Transformation eines Vektors zurück. Das Ergebnis ist ein aus [image] -Elementen bestehender Vektor, dessen k-tes Element gegeben ist durch:

Dabei gibt n die Anzahl von Elementen in v an, und i ist die imaginäre Einheit.

Argumente:

  • v muss [image] Elemente (m>2) haben.

  • Alle Elemente in v sind reell.

Hinweise:

  • Diese Funktion arbeitet mit einem hocheffizienten Algorithmus für die schnelle Fourier-Transformation. Damit dies auch möglich ist, muss der von Ihnen mit fft verwendete Vektor [image] Elemente haben. Für Vektoren mit komplexen Werten oder einer beliebigen anderen Anzahl von Elementen sollten Sie stattdessen cfft verwenden.

  • Bei zweidimensionalen Fourier-Transformationen sollten Sie ebenfalls stattdessen cfft verwenden.

  • Wenn Sie fft verwenden, um zum Frequenzbereich zu gelangen, können Sie nur mit ifft zum Zeitbereich zurückkehren.

  • Die Elemente in v müssen reell sein, weil das Funktionspaar fft/ifft den Umstand nutzt, dass bei reellen Daten die zweite Hälfte der Transformation einfach gleich der konjugierten ersten Hälfte ist. Mathcad ignoriert die zweite Hälfte des Ergebnisvektors und spart dadurch Zeit und Speicherplatz.


Rekursion

Rekursion ist eine Programmiersprache, in der eine Variable auf sich selbst bezogen definiert wird, wie im folgenden Beispiel gezeigt:

Rekursive Funktionsdefinitionen müssen immer mindestens zwei Teile enthalten:

  • Eine Initiierungsbedingung, die verhindert, dass die Rekursion in einer Endlosschleife endet.

  • Eine Definition der Funktion bezogen auf einen früheren Wert.

Das Konzept ähnelt der zugrunde liegenden mathematischen Induktion: Wenn Sie f(n+1) aus f(n) erhalten können und f(0) kennen, wissen Sie alles über f.

Beachten Sie jedoch, dass rekursive Funktionsdefinitionen trotz ihrer Benutzerfreundlichkeit und Prägnanz nicht immer die am effektivsten zu verarbeitenden Definitionen sind. Möglicherweise erfolgt durch eine entsprechende Definition mit einer der Iterationsschleifen eine schnellere Auswertung.


Neudefinieren von integrierten Konstanten

Neudefinieren von integrierten mathematischen Konstanten

Sie können den Wert folgender Konstanten ändern:

Unendlichkeit

p

e

i

j

%

Hierzu setzen Sie ":=" in Ihrem Arbeitsblatt auf die gleiche Weise ein wie eine Variable.

Verwandte Themen: Neudefinieren von integrierten Systemkonstanten.


Neudefinieren von integrierten Systemkonstanten

Sie können den Wert folgender Konstanten ändern:

ORIGIN

PRNPRECISION

TOL

CTOL

PRNCOLWIDTH

Dazu stehen zwei Vorgehensweisen zur Verfügung:

  • Neudefinieren der Konstanten mit ":=" im Arbeitsblatt

  • Wählen Sie den Befehl Arbeitsblattoptionen im Menü Extras, und klicken Sie im Dialogfeld auf die Registerkarte "Vordefinierte Variablen".

Verwandte Themen: Neudefinieren von integrierten mathematischen Konstanten.


Arbeitsblatt, auf das verwiesen wird

Dabei muss es sich um ein Arbeitsblatt handeln, das entweder auf einem Ihrer Laufwerke oder im Internet gespeichert ist. Um z. B. auf eine Datei namens CONFORM.MCD zu verweisen, die sich im Mathcad-Ordner befindet, müssen Sie Folgendes eingeben:

c:\Programme\mathsoft\Mathcad\conform.mcd

Für einen Verweis auf eine Datei, die im World Wide Web gespeichert ist, können Sie z. B. Folgendes eingeben:

http://www.mathsoft.com/coeffs.mcd

Sobald Sie einen Verweis auf das Arbeitsblatt eingefügt haben, sollte es nicht mehr in ein anderes Verzeichnis verschoben werden. Verschieben Sie es, wird der Verweis ungültig. Wenn Sie das Mathcad-Arbeitsblatt, das den Verweis enthält, und das Arbeitsblatt, auf das verwiesen wird, zusammen verschieben wollen, ist darauf zu achten, dass die relative Verzeichnisstruktur zwischen den beiden Dokumenten erhalten bleibt und dass ein relativer Pfad definiert und verwendet wird.


Referenzmaterial zu den Lösungsalgorithmen

Weitere Informationen zu den einzelnen Lösungmethoden, die beim Lösungsprozess der Funktionen suchen, minfehl, minimieren und maximieren zum Einsatz kommen, finden Sie in:

Press, W. H, W. T. Flannery, S. A.Teukolsky und B. P. Vetterling.
Numerical Recipes in C.
Cambridge University Press, New York, 1992.

Polak, E. Optimization – Algorithms and Consistent Approximations. New York: Springer-Verlag, 1997.

Winston, W. Operations Research: Applications and Algorithms. Belmont: Wadsworth, 1994.


Bereich

Alles, was Sie in Ihr Arbeitsblatt einfügen, befindet sich in einem Bereich. Die Schritte zum Markieren, Löschen und Verschieben von Bereichen sind stets dieselben, egal, was sich im Bereich befindet.

Wenn Sie auf einen Bereich klicken, sehen Sie in mathematischen Bereichen zwei blaue Bearbeitungslinien, für Textbereiche eine rote Texteinfügemarke. Wenn Sie außerhalb eines Bereichs klicken, wird ein kleines Fadenkreuz angezeigt. Es gibt auch Diagramm- und Bildbereiche.


Beziehung zu hyperbolischen Funktionen

Definitionen für hyperbolische Funktionen


Beziehung zwischen trigonometrischen und hyperbolischen Funktionen

Beziehung zwischen trigonometrischen Funktionen


Relativer Pfad zu einer verknüpften Datei

Relativer Pfad

Geben Sie einen relativen Pfad an, wenn der Pfad der verknüpften Datei relativ zum Mathcad-Arbeitsblatt angegeben werden soll, das die Verknüpfung enthält. Dadurch bleibt die Verknüpfung auch dann noch gültig, wenn Sie die verknüpfte Datei und das Hauptarbeitsblatt zusammen verschieben und die Verzeichnisstruktur zwischen den beiden Dateien beibehalten. Damit Sie einen relativen Pfad angeben können, müssen sich die beiden Arbeitsblätter auf demselben lokalen Laufwerk bzw. demselben Netzlaufwerk befinden.

Wenn Sie einen relativen Pfad angeben, kann es vorkommen, dass er als absoluter Pfad angezeigt wird. Mathcad arbeitet intern trotzdem mit dem relativen Pfad.


Relativer Pfad zu einer referenzierten Datei

Mithilfe eines relativen Pfades können Sie den Speicherort der Datei, auf die verwiesen wird, relativ zum Mathcad-Arbeitsblatt festlegen, das den Verweis enthält. Auf diese Weise bleibt der Verweis auch dann gültig, wenn Sie die Datei, auf die verwiesen wird, und das Haupt-Arbeitsblatt verschieben, ohne dabei die relative Verzeichnisstruktur zwischen den beiden zu verändern. Damit Sie einen relativen Pfad angeben können, müssen sich die beiden Arbeitsblätter auf demselben lokalen Laufwerk bzw. demselben Netzlaufwerk befinden.

Wenn Sie einen relativen Pfad angeben, zeigt Mathcad am Ende des Pfads zum Verweis in Ihrem Arbeitsblatt ein großes "R" in Klammern an.


Wiederholtes Auswerten eines Ausdrucks mithilfe von Bereichsvariablen

Verwenden Sie Bereichsvariablen, um einen Ausdruck wiederholt über einen Variablenbereich auszuwerten (siehe unten). Mathcad wertet den Ausdruck genau einmal für jeden Wert der Bereichsvariable aus.

Wenn Sie in einer Gleichung mehrere Bereichsvariablen verwenden, berechnet Mathcad die Gleichung einmal für jede Bereichsvariable. Dies ist bei der Definition von Matrizen von Vorteil:


Dialogfeld "Ersetzen"

Das Dialogfeld "Ersetzen" enthält folgende Elemente:

Suchen nach

Geben Sie das bzw. die gesuchten Zeichen ein.

Ersetzen durch

Geben Sie die Zeichen ein, die die Zeichen im Feld "Suchen nach" ersetzen sollen.

Nur ganzes Wort suchen

Markieren Sie dieses Kontrollkästchen, wenn die Zeichen im Feld "Suchen nach" nur als ganzes Wort und nicht als Bestandteil längerer Wörter gesucht werden sollen.

Groß-/Kleinschreibung beachten

Markieren Sie dieses Kontrollkästchen, wenn die Zeichen genau der Groß-/Kleinschreibung entsprechen sollen, die Sie im Textfeld "Suchen nach" eingeben.

In Textbereichen suchen

Markieren Sie dieses Kontrollkästchen, wenn die Zeichen nur in den Textbereichen gesucht werden sollen.

In Rechenbereichen suchen

Markieren Sie dieses Kontrollkästchen, wenn die Zeichen nur in den Rechenbereichen (Gleichungen und Diagrammen) gesucht werden sollen.

Weitersuchen

Sucht die nächste bzw. vorangegangene Stelle, an der das bzw. die Zeichen aus dem Textfeld "Suchen nach" vorkommen.

Ersetzen

Ersetzt die derzeit ausgewählten Zeichen durch die Zeichen im Textfeld "Ersetzen durch:".

Alle ersetzen

Ersetzt die Zeichen im Feld "Suchen nach" überall im Suchbereich durch die Zeichen im Textfeld "Ersetzen durch:".


Ändern der Größe einer Komponente

Zum Vergrößern bzw. Verkleinern einer Komponente gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf die Komponente, um sie zu aktivieren.

  2. Positionieren Sie den Mauszeiger über einem der Haltepunkte. Der Mauszeiger verwandelt sich in einen Doppelpfeil.

  3. Drücken Sie die Maustaste, und halten Sie sie gedrückt.

  4. Ziehen Sie den Haltepunkt der Komponente mit der Maus auf die gewünschte Größe.


Ändern der Größe von Diagrammen

Zum Ändern der Länge und der Breite eines Diagramms gehen Sie wie folgt vor:

  1. Klicken Sie in das Diagramm, damit es ausgewählt wird. Dadurch wird er in ein Markierungsrechteck eingeschlossen. Drei Haltepunkte werden eingeblendet.

  2. Setzen Sie den Zeiger auf einen der Haltepunkte am unteren oder rechten Rand des Bereichs. Die Form des Cursors ändert sich zu einem Doppelpfeil.

  3. Verschieben Sie die Maus bei gedrückter Maustaste. Das Diagramm wird in Richtung der Mausbewegung erweitert.

  4. Lassen Sie die Maustaste los, wenn das Diagramm die gewünschte Größe hat.


Ändern der Größe von Ausgabetabellen mit Bildlaufleiste

Zum Ändern der Größe einer Ausgabetabelle gehen Sie wie folgt vor:

  1. Klicken Sie auf die Ausgabetabelle. Um die Tabelle sollte ein Auswahlfeld mit Ankern an den Seiten angezeigt werden.

  2. Setzen Sie den Cursor so auf einen Anker, dass er die Form eines doppelseitigen Pfeils annimmt.

  3. Halten Sie die Maustaste gedrückt, und verschieben Sie die Maus. Die Ausgabetabelle wird in die Richtung gedehnt, in die Sie die Maus schieben.

  4. Wenn die Ausgabetabelle die gewünschte Größe hat, lassen Sie die Maustaste los.


Ändern der Fenstergröße

Positionieren Sie den Mauszeiger auf den Rand des Fensters, drücken Sie die Maustaste, und ziehen Sie den Rand mit der Maus. Sobald das Fenster die gewünschte Größe hat, können Sie die Maustaste loslassen.


Wiederherstellen der ursprünglichen Version des elektronischen Buchs

Sie können den derzeit offenen Abschnitt wie folgt durch den ursprünglichen Abschnitt aus dem nicht veränderten Original des elektronischen Buchs ersetzen:

  • Wählen Sie Abschnitt wiederherstellen aus dem Kontextmenü"Bücher" im Fenster "Informationszentrum/Elektronisches Buch".

Sie können das derzeit offene elektronische Buch wie folgt durch die ursprüngliche, nicht veränderte Version des elektronischen Buchs ersetzen:

  • Wählen Sie Alle wiederherstellenaus dem Kontextmenü Bücher.

Zu beachten ist, dass diese Befehle bewirken, dass sämtliche je am derzeit offenen Abschnitt bzw. Buch vorgenommenen Änderungen verlorengehen.


Beschränkungen links von "="

Alle links vom Gleichheitszeichen stehenden Variablen oder Funktionen müssen bereits definiert worden sein.

Wenn Sie beispielsweise "x + 1 =" eingeben, und Sie haben "x" noch nicht definiert, erhalten Sie keine Antwort. In diesem Fall wird eine entsprechende Fehlermeldung angezeigt.

Für bestimmte symbolische Funktionen ist in Mathcad keine normale Auswertung definiert, nur eine symbolische Auswertung. Dies führt zu Fehlern, wenn sie in Verbindung mit "=" verwendet werden.


Beschränkungen links von ":="

Es ist nicht möglich, eine Zahl oder einen Ausdruck links von ":=" einzufügen.

Links von ":=" muss ein einfacher Variablenname, eine tiefgestellte Variable, eine Matrix von Variablennamen oder ein Funktionsname stehen.


Beschränkungen rechts von "="

Es ist nicht möglich, Zeichen rechts vom "=" direkt zu bearbeiten. Sie können jedoch das Format oder die Einheit ändern, indem die Zahlen angezeigt werden.


Beschränkungen rechts von ":="

Alle Variablen oder Funktionen rechts vom Gleichheitszeichen müssen bereits definiert worden sein.

Wenn Sie zum Beispiel "y := x + 1 =" eingeben und "x" noch nicht definiert ist, kann y keine Zahl zugewiesen werden. In diesem Fall wird eine entsprechende Fehlermeldung angezeigt.


Beschränkungen bei Variablen- und Funktionsnamen

Namen dürfen nicht mit den Ziffern 0 bis 9, einem Unterstrich ( _ ), einem negativen Apostroph `, oder einem Prozentzeichen (%) beginnen.

Das Unendlichkeitssymbol kann nur als erstes Zeichen in einem Namen vorkommen.

Alle Zeichen in einem Namen müssen dieselbe Schriftart, Punktgröße und denselben Stil aufweisen.

Das Arbeitsblatt unterscheidet nicht zwischen Variablennamen und Funktionsnamen. Wenn Sie also f(x) definieren und später die Variable f festlegen, sehen Sie, dass Sie f(x) an keiner Stelle unter der Definition von f verwenden können.

Bestimmte Namen werden in Mathcad für vordefinierte Konstanten, Einheiten und Funktionen verwendet. Sie können diese Namen zwar neu definieren, sollten jedoch bedenken, dass nach der Definition ihre vordefinierte Bedeutung nicht mehr vorhanden ist. Wenn Sie zum Beispiel eine Variable namens mittelwert erstellen, steht die vordefinierte Funktion mittelwert(v) nicht mehr zur Verfügung.

Das Arbeitsblatt unterscheidet zwischen Groß- und Kleinschreibung. Zum Beispiel ist die Variable diam nicht mit DIAM identisch.

Das Arbeitsblatt unterscheidet zwischen verschiedenen Schriftarten. Zum Beispiel ist BEREICH nicht mit BEREICH identisch.


Dialogfeld "Ergebnisformat" - Registerkarte "Anzeige-Optionen"

Auf der Registerkarte Anzeige-Optionen des Dialogfelds Ergebnisformat finden Sie folgende Optionen und Funktionen:

Matrix-Anzeigeformat

Gibt an, ob ein Feld in einer Ausgabetabelle oder in Matrixform angezeigt wird.

  • Wählen Sie "Matrix", wenn das Ergebnis in Matrixform angezeigt werden soll.

  • Wählen Sie "Tabelle", wenn das Feld als Ausgabetabelle erscheinen soll.

  • Wählen Sie "Automatisch", wenn das Feld, je nach Größe, als Tabelle oder als Matrix ausgegeben werden soll. Hat das Feld mehr als 10 Zeilen oder Spalten, erscheint eine Tabelle. Andernfalls erfolgt die Ausgabe als Matrix.

Die Standardeinstellung ist "Automatisch".

Verschachtelte Matrizen erweitern

Wenn Sie diese Option aktivieren, werden Felder innerhalb von Feldern ebenfalls vollständig angezeigt. Beispiel:

Standardmäßig ist die Option deaktiviert.

Wird ein verschachtelts Feld als Tabelle angezeigt, können Sie ein Element vorübergehend einblenden, indem Sie mit der rechten Maustaste auf die Tabelle klicken und Eine Ebene nach unten im Kontextmenü wählen.

Wert für Imaginärteil

Mit dieser Option können Sie festlegen, ob die berechneten Ergebnisse, die einen Imaginärteil enthalten, mit 'i' oder mit 'j' dargestellt werden.

Diese Einstellung steuert nur die Anzeige von berechneten Ergebnissen. Sie können weiterhin entweder 'i' oder 'j' verwenden, wenn Sie eine imaginäre Zahl eingeben.

Sie können diese Einstellung nur vornehmen, wenn kein bestimmtes Ergebnis markiert ist. Klicken Sie auf eine leere Stelle in Ihrem Arbeitsblatt, und wählen Sie dann Ergebnis im Menü Format, um das Dialogfeld zu öffnen und den imaginären Wert einzustellen.

Der Standardwert ist 'i'.

Radix

Mit dieser Option legen Sie fest, ob eine Nummer als binäre Zahl (Basis 2), oktale Zahl (Basis 8), hexadezimale Zahl (Basis 16) oder Dezimalzahl (Basis 10) dargestellt wird. Der Standardwert ist "Dezimalzahl".

Hinter binären, hexadezimalen und oktalen Zahlen erscheint der Buchstabe "b", "h" bzw. "o", um eine Verwechslung mit Dezimalzahlen auszuschließen. (Mathcad kann hexadezimale oder oktale Zahlen, die größer als 2^31 sind, nicht präzise anzeigen.)


Dialogfeld "Ergebnisformat" - Registerkarte "Zahlenformat"

Auf der Registerkarte Zahlenformat des Dialogfelds Ergebnisformat stehen die folgenden Optionen und Funktionen zur Verfügung:

Format

Gibt das Formatschema an:

Allgemein: Sie bestimmen das Zahlenformat durch die Angabe eines Werts für "Anzahl Dezimalstellen" und "Exponentialschwelle". Ergebnisse werden in Exponentialschreibweise angegeben, sobald die Exponentialschwelle überschritten ist.

(Exponentialschwelle ist 3.)

Dezimal: Sie bestimmen das Zahlenformat durch die Angabe eines Werts für "Anzahl Dezimalstellen". Die Ergebnisse werden nie in Exponentialschreibweise angegeben.

Befinden sich links neben dem Dezimalzeichen mehr als 15 Ziffern, so zeigt Mathcad für die restlichen Ziffern Nullen an. Bitte beachten Sie, dass nur die ersten 15 Ziffern korrekt sind. Beispiel:

12345678901234567890 = 12345678901234568000

Wissenschaftlich: Sie bestimmen das Zahlenformat durch die Angabe eines Werts für "Anzahl Dezimalstellen". Das Ergebnis wird immer in Exponentialschreibweise angegeben.

Ingenieurtechnisch: Sie bestimmen das Zahlenformat durch die Angabe eines Werts für "Anzahl Dezimalstellen". Das Ergebnis wird immer in Exponentialschreibweise angegeben. Die Exponenten sind Vielfache von 3.

Bruch: Die Ergebnisse werden als Bruch angezeigt. Sie können festlegen, ob gemischte Zahlen verwendet werden sollen.

Die Standardeinstellung ist "Allgemein".

Anzahl Dezimalstellen

Bestimmt die Anzahl der angezeigten Stellen rechts neben dem Dezimaltrennzeichen. Die Anzahl entspricht dem kleineren der beiden Werte "Angezeigte Genauigkeit" und [16 minus die Anzahl der Stellen, die vor dem Dezimaltrennzeichen angezeigt werden]. Dies wirkt sich nur auf die Anzeige aus. Die Berechnungen werden mit der vollen Genauigkeit (bis zu 16 Ziffern) durchgeführt, unabhängig davon, für welche Ergebnisanzeige Sie sich entscheiden.

So wird z. B. die Zahl .000125 wie folgt angezeigt:

Anzahl Dezimalstellen | Ergebnis im Dezimalformat
2 | 0
3 | 0
4 | .0001
5 | .00013
6 | .000124

Die Anzahl der Dezimalstellen muss zwischen 0 und 15 liegen. Der Standardwert ist 3.

Nachfolgende Nullen anzeigen

Legt fest, ob Ergebnisse rechts vom Dezimalzeichen mit Nullen aufgefüllt werden sollen, um den unter "Angezeigte Genauigkeit" festgelegten Wert zu erreichen.

Wenn "Anzahl Dezimalstellen" zum Beispiel 3 beträgt, gilt folgendes:

1.5 | "Mit Nullen auffüllen" ist deaktiviert. | Wird als 1,5 angezeigt.
1.5 | "Nachfolgende Nullen anzeigen" ist aktiviert. | Wird als 1,500 angezeigt.

Weist ein Ergebnis insgesamt mehr als 15 Stellen auf, und ist "Nachfolgende Nullen anzeigen" aktiviert, zeigt Mathcad 15 Ziffern an, gefolgt Nullen, bis sich rechts des Dezimaltrennzeichens so viele Stellen befinden, wie unter "Anzahl Dezimalstellen" angegeben. Dieser Regel gilt allerdings nicht, wenn als Formatschema das Format "Allgemein" gewählt wurde. Ist "Allgemein" gewählt, und ist "Mit Nullen auffüllen" aktiviert, zeigt Mathcad nach den insgesamt 15 Ziffern keine weiteren Nullen mehr an, unabhängig vom Wert für "Anzahl Dezimalstellen". Beispiel:

Nummer | Formatschema | Einstellungen | Ergebnis bei Aktivierung von "Mit Nullen auffüllen"
1234567890123.456 | general | Angezeigte Genauigkeit = 3 | 1234567890123.46
1234567890123.456 | Dezimal | Anzahl Dezimalstellen = 3 | 1234567890123.460
12 | Wissenschaftlich | Anzahl Dezimalstellen = 3 | 1.200
1.234 | Ingenieurtechnisch | Anzahl Dezimalstellen = 4 | 1.2340 x 100

Standardmäßig ist "Mit Nullen auffüllen" deaktiviert.

Exponentialschwelle

Bestimmt, sofern das Format "Allgemein" ausgewählt ist, ob eine Zahl in Exponentialschreibweise angezeigt wird. Ergebnisse mit einem Betrag größer als 10n oder kleiner als 10-n (wobei n die Exponentialschwelle repräsentiert), werden in Exponentialschreibweise angezeigt.

Beispiele:

Der Wert für "Exponentialschwelle" muss zwischen 0 und 15 liegen. Der Standardwert ist "6". Dies bedeutet, dass alle Zahlen außerhalb der Intervalle [.001, 1000] und [-1000,-.001] in Exponentialschreibweise angezeigt werden.

Exponent als E±000 anzeigen

Wenn das Format "Wissenschaftlich" oder "Ingenieurtechnisch" ausgewählt ist und diese Option aktiviert ist, wird das Ergebnis in Exponentialschreibweise angezeigt. Beispiel:

Standardmäßig ist "Exponent als E±000 anzeigen" deaktiviert.

Gemischtes Zahlenformat verwenden

Wenn als Format "Bruch" festgelegt und diese Option aktiviert ist, wird das Ergebnis als gemischte Zahl angezeigt. Beispiel:

Standardmäßig ist "Gemischtes Zahlenformat verwenden" deaktiviert.

Genauigkeitsgrad

Wenn als Format "Bruch" ausgewählt ist, wird mit dieser Einstellung gesteuert, wie stark sich der Bruch dem Dezimalwert annähert. Je höher die Genauigkeit, desto stärker ist die Annäherung. Der Standardwert ist "12".


Dialogfeld "Ergebnisformat" - Registerkarte "Toleranz"

Auf der Registerkarte Toleranz des Dialogfelds Ergebnisformat finden Sie die folgenden Optionen und Schaltflächen:

Komplexe Schwelle

Hiermit wird festgelegt, um wieviel größer der reelle oder imaginäre Teil einer Zahl sein muss, bevor die Anzeige des kleineren Teils unterdrückt wird.

So wird die Zahl 1+0.002i bei unterschiedlichen Werten für "Komplexe Schwelle" wie folgt angezeigt:

Komplexe Schwelle | Ergebnis
2 | 1
3 | 1+.002i
4 | 1+.002i

Der Wert für "Komplexe Schwelle" muss eine ganze Zahl zwischen 0 und 63 sein. Der Standardwert ist "10". Das bedeutet, dass z als reine reelle Zahl angezeigt wird, wenn gilt:

z wird als reine imaginäre Zahl dargestellt, wenn gilt:

Nullschwelle

Mit dieser Option legen Sie fest, wie nah ein Ergebnis an Null liegen muss, bevor es als Null angezeigt wird. So wird die Zahl 0.0001215 mit unterschiedlichen Werten für die Null-Toleranz wie folgt angezeigt:

Null-Toleranz | Angezeigtes Ergebnis
2 | 0
3 | 0
4 | .000125
5 | .000125

Der Wert für "Null-Toleranz" muss zwischen "0" und "307" liegen. Der Standardwert ist "15". Das bedeutet, dass Zahlen kleiner als [image] als Null dargestellt werden.

Sie können diese Einstellung nur vornehmen, wenn kein bestimmtes Ergebnis markiert ist. Klicken Sie zum Festlegen der Nullschwelle auf eine leere Stelle in Ihrem Arbeitsblatt, und wählen Sie dann Ergebnis im Menü Format, um das Dialogfeld zu öffnen.


Dialogfeld "Ergebnisformat" - Registerkarte "Einheiten"

Auf der Registerkarte Einheiten des Dialogfelds Ergebnisformat finden Sie folgende Optionen und Schaltlflächen:

Einheiten formatieren

Wenn Sie diese Option aktivieren, wird die Anzeige der Einheiten so formatiert, dass sie eher der gebräuchlichen Schreibweise entspricht. Beispiel: Aus "sec-1 " wird "1/sec". Diese Option ist standardmäßig aktiviert.

Einheiten wenn möglich vereinfachen

Mit dieser Option können Sie dafür sorgen, dass die einfachste Einheit verwendet wird. Beispiel: Aus "kg*m/sec2" wird durch die Vereinfachung "N" (Newton). Diese Option ist standardmäßig aktiviert.


Wiederaufnahme unterbrochener Berechnungen

Gelegentlich kann das Berechnen einer Gleichung sehr lange dauern. Anstatt zu warten, bis die Gleichung berechnet wird, können Sie [Esc] drücken, um die Berechnung anzuhalten. In diesem Fall hört Mathcad mit der Berechnung auf und kennzeichnet den Bereich, den es gerade berechnet hat, mit der Fehlermeldung:

"Sie haben einen Rechenvorgang unterbrochen. Um fortzufahren, klicken Sie hier und drücken "F9".

Um die gekennzeichnete Gleichung neu zu berechnen, setzen Sie den Cursor auf die Gleichung und wählen im Menü Extras den Befehl Berechnen ÞJetzt berechen, oder drücken Sie [F9].

Um das gesamte Arbeitsblatt neu zu berechnen, setzen Sie den Cursor in das Arbeitsblatt und drücken [Strg]+F9.

Wenn Sie feststellen, dass Sie beim Bearbeiten Ihres Arbeitsblatts häufig die Berechnungen unterbrechen, weil diese Ihnen zu lange daueren, empfiehlt es sich, in den manuellen Modus zu wechseln, indem Sie im Menü "Extras" die Option "Berechnung" deaktivieren.


Umkehrdarstellung

Diese Gleichung wird in Umkehrdarstellung hervorgehoben.

Sie können alles in Umkehrdarstellung hervorheben, indem Sie die Maustaste gedrückt halten und den Cursor entsprechend ziehen.


Riemannsche Zetafunktion


Pfeil-nach-rechts

In leeren Bereichen

Verschiebt das Fadenkreuz eine Stelle nach rechts. Wenn sich ein anderer Bereich rechts daneben befindet, erscheint das Fadenkreuz in diesem Bereich und wird entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen

Verschiebt die Einfügelinie um ein Zeichen nach rechts. Befindet sie sich bereits am Ende eines Ausdrucks, so werden die Bearbeitungslinien aus dem Text herausgenommen und als Fadenkreuz in den leeren Bereich rechts daneben gesetzt.

In Textbereichen

Verschiebt die Einfügemarke um ein Zeichen nach rechts. Befindet sie sich bereits am Ende des Textes, so wird die Einfügemarke aus dem Text herausgenommen und als Fadenkreuz in den leeren Bereich rechts daneben gesetzt.

Bereiche verschieben

Verschiebt den/die ausgewählten Bereich(e) nach rechts. Bei dauerhaft gedrückter Taste wird schneller nach rechts verschoben.


Rechter Rand

Der rechte Rand wird als durchgehende vertikale Linie in Ihrem Fenster dargestellt. Eventuell müssen Sie sich mithilfe der Bildlaufleiste in Ihrem Fenster nach rechts bewegen, um diese Linie sehen zu können.

Verwechseln Sie diese Linie (den rechten Rand) nicht mit der gepunkteten vertikalen Linie am rechten Rand. Diese gepunktete vertikale Linie zeigt den rechten Rand des Papierblatts an. Wo sich diese gepunktete Linie befindet, hängt davon ab, welchen Standarddrucker Sie in Ihrem Betriebssystem festgelegt haben.


Rechte Randlinien

Der rechte Rand wird durch eine vertikale grüne Linie im Arbeitsblatt angezeigt. Ihr Dokument kann zwei solcher Linien enthalten:

  • eine gepunktete vertikale Linie, deren Position davon abhängt, welchen Drucker Sie auswählen

  • eine durchgehende vertikale Linie, deren Position Sie über den Befehl Seite einrichten im Menü Datei festlegen können.

Während der Eingabe von Text in den Textbereich vergrößert dieser sich so lange, bis er auf eine dieser beiden senkrechten Linien stößt.


"Rkadapt" für sich langsam ändernde Lösungen

Wenn sich die Lösung nicht schnell ändert, kann Rkadapt die Schrittweite anpassen, damit keine Verarbeitungszeit verlorengeht.


Integration nach der Romberg-Methode

Mathcad berechnet bestimmte Integrale mit einem Romberg-Algorithmus numerisch. Mit der Romberg-Methode werden die Annäherungswertfolge und die entsprechenden Teilintervallweiten extrapoliert, sodass die Konvergenz einer Folge von einfachen Trapez- oder Mittelpunktannäherungen an das Integral schneller vonstatten geht.

Mit der Romberg-Methode erfolgt eine schrittweise Annäherung an den Wert des Integrals, und es wird ein Wert zurückgegeben, sobald die Differenz der beiden letzten Annäherungswerte geringer ist als der Wert der vordefinierten Variable TOL.

Zur Berechnung des Integrals f(x) von a nach b führt Mathcad folgende Schritte durch:

  1. Berechnen einer Trapezformel

  2. Anpassen eines Polynoms an die Folge der bisher berechneten Trapez-Annäherungswerte und der entsprechenden Teilintervallweiten. Extrapolieren dieses Polynoms auf Nullweite zur Erzeugung einer Romberg-Annäherung für das Integral

  3. Vergleichen der beiden letzten Romberg-Annäherungen nach folgendem Test:

  4. Stimmen die beiden letzten Annäherungen nach diesem Test überein, wird geprüft, ob auch Annäherungen n-1 und n-2 übereinstimmen. Ist dies der Fall, wird die letzte Romberg-Annäherung als Wert des Integrals ausgegeben. Ist dies nicht der Fall, wird die Zahl der Teilintervalle verdoppelt, und die Prozedur wird erneut ab Schritt 1 durchgeführt.

Mathcad begrenzt die Zahl der Durchgänge für diese Prozedur. Erreicht die Routine die Begrenzung, ohne dass eine Konvergenz gegeben ist, oder weist die Integrandfunktion an einem oder beiden Endpunkten Singularität auf, geht Mathcad zu einer offenen Romberg-Methode über. Erreicht Mathcad bei der Routine die festgelegte Begrenzung, ohne dass eine Antwort ausgegeben wird, wird die fehlgeschlagene Konvergenz am Integral als Fehler angezeigt.

Hinweise zum Algorithmus:

  • Bei kleinen TOL-Werten kann die Konvergenz auch dann fehlschlagen, wenn das Integral einen endlichen Wert aufweist.

  • Mathcad kann allgemein keine Funktionen integrieren, bei denen im Inneren des Integrationsintervalls Singularität auftritt. Funktionen wie Schritt- und Sägezahnfunktionen mit zahlreichen endlichen Unstetigkeiten können ebenfalls zu nichtkonvergierenden Intervallen führen. Wenn Sie wissen, wo Singularitäten im Integranden auftreten, können Sie eine richtige numerische Berechnung oft dadurch erzielen, dass Sie das Integral in eine Summe von Integralen aufspalten, die diese Punkte als Grenzwerte enthalten. +Ein Diagramm des Integranden kann bei der Suche der Problemstellen oft weiterhelfen.


Vier Subintervalle

Da das Intervall bei der Rombergschen Integrationsmethode in vier Teilintervalle unterteilt wird, wonach die Anzahl der Punkte verdoppelt wird, kann es bei periodischen Funktionen mit Perioden vom 1/(2^n)-Fachen der Intervalllänge zu fehlerhaften Ergebnissen kommen.

Um dies zu vermeiden, sollten Sie das Intervall in zwei Teilintervalle unterschiedlicher Größe aufteilen und die Integration über jedes Teilintervall einzeln durchführen.


Algorithmus der Wurzelfunktion

Die Funktion wurzel arbeitet mit einer Sekans / Müller-Methode, sofern das dritte und das vierte Argument nicht angegeben werden. Sind die Klammer-Argumente jedoch enthalten, werden die Verfahren nach Ridder und Brent verwendet.


Das Ridder- und das Brent-Verfahren für die Suche nach Wurzeln

Wenn das optionale dritte und vierte Argument der Funktion wurzel enthalten ist, wird die Wurzel nach dem Ridder-Verfahren ermittelt. Schlägt dieses Verfahren fehl, wird das Brent-Verfahren verwendet.

Weitere Informationen zu den Verfahren nach Ridder und Brent finden Sie im Fachbuch Numerical Recipes in C, Cambridge University Press (1992).


Drehen eines Bilds


Rotieren oder Drehen von 3D-Diagrammen

Zum Drehen eines 3D-Diagramms mit der Maus gehen Sie folgendermaßen vor:

  1. Klicken Sie in das Diagramm.

  2. Halten Sie die Maustaste gedrückt.

  3. Ziehen Sie die Maus in die gewünschte Richtung.

  4. Wenn sich das Diagramm an der gewünschten Position befindet, lassen Sie die Maustaste los.

Zum Drehen eines 3D-Diagramms um einen bestimmten Faktor gehen Sie folgendermaßen vor:

  1. Klicken Sie mit der rechten Maustaste auf das Diagramm.

  2. Wählen Sie im Kontextmenü den Befehl Format.

  3. Klicken Sie auf die Registerkarte "Allgemein" im Dialogfeld, um die Seite "Allgemein" anzuzeigen.

  4. Nehmen Sie Änderungen an Rotation, Neigung und Verdrehung vor, und klicken Sie dann auf "OK" oder "Übernehmen".

Zum fortlaufenden Drehen eines 3D-Diagramm gehen Sie folgendermaßen vor:

  1. Klicken Sie in das Diagramm.

  2. Halten Sie die Umschalttaste und die Maustaste gedrückt.

  3. Ziehen Sie die Maus in die gewünschte Richtung.

  4. Wenn sich das Diagramm an der gewünschten Position befindet, lassen Sie die Maustaste los.

Das Diagramm wird fortlaufend in die angegebene Richtung gedreht, auch wenn Sie Änderungen am Arbeitsblatt vornehmen. Wenn das Diagramm nicht weiter gedreht werden soll, klicken Sie in das Diagramm.

Hinweis:

Wenn Sie Änderungen an Gleichungen vornehmen, die sich auf das Diagramm auswirken, wird während der Drehung eine Neuberechnung durchgeführt.


Runden einer Zahl

rund(z, n) Gibt z gerundet auf n (optional) Dezimalstellen zurück. Wenn n nicht angegeben wird, wird z, gerundet auf die nächste ganze Zahl, zurückgegeben. (n wird dabei 0 gesetzt.) Wenn n<0, wird z, gerundet auf n Stellen links des Dezimalzeichens, zurückgegeben.

Rund(z, y) Gibt rund(z/y)*y zurück.

Argumente:

z ist eine komplexe Zahl.

n muss eine ganze Zahl sein.

y ist eine reelle Zahl. Wenn z über Einheiten verfügt, muss y in der Funktion "Rund" ebenfalls über Einheiten verfügen. Für die Funktion "rund" darf z keine Einheiten aufweisen.

Beispiele:


Zeilenreduzierte Echelon-Form einer Matrix

zref(A) Gibt die zeilenreduzierte Echelon-Form von A zurück.

Argumente:

  • A muss ein Vektor oder eine Matrix sein.

  • Die Elemente von A sollten reell sein.


(Zeilen - 1) muss Potenz von 2 sein.

(Zeilen - 1) muss eine Potenz von 2 sein.

Diese Matrix muss 2^n Zeilen aufweisen.


Reihen- und Spaltenbild einfügen


RTF (Rich Text Format)

Dieses Dateiformat wird von einer zunehmenden Anzahl von Textverarbeitungsprogrammen und anderen Anwendungen erkannt. In RTF-Dateien können nicht nur einfacher Text, sondern auch Grafiken, Gleichungen, Schriftarten und Informationen zum Layout des Dokuments, wie z. B. zu Seitenumbrüchen, Randeinstellungen und Absatzformaten, gespeichert werden.


Die Funktion "medgltt"

Die Auswertung der Funktion medgltt(vy,n) beginnt mit dem gleitenden Mittelwert des Eingabevektors vy. Dieser soll vy' genannt werden. Das i-te Element ist gegeben durch:

Anschließend berechnet die Funktion die Reste: vr=vy - vy`

Der Restvektor, vr, wird mit dem in Schritt 1 beschriebenen Verfahren geglättet. Dadurch entsteht der geglättete Restvektor vr`.

Die Funktion medgltt gibt die Summe dieser beiden geglätteten Vektoren zurück:

medgltt(vy,n) = vy` + vr`.

Hinweis: Bei medgltt bleiben der erste und der letzte (n-1)/2 Punkt unverändert. In der Praxis muss die Länge des Glättungsfensters, n, im Vergleich zur Länge des Datensatzes klein sein.


S-PLUS-Graphtypen

Mit der Komponente "S-PLUS-Graph" können Sie eine Vielzahl von Diagrammtypen erstellen. Um auf die verschiedenen Graphtypen für die Komponente zugreifen zu können, ist wie folgt vorzugehen:

  1. Klicken Sie mit der rechten Maustaste auf die Komponente, und wählen Sie den Befehl Eigenschaften aus dem Kontextmenü.

  2. Wählen Sie eine der folgenden Optionen aus: "Liniendiagramm", "GUI-Diagramm" oder "Graphskript aufrufen".

  3. Geben Sie in den Komponenten-Platzhalter für die Eingabevariable die entsprechenden Felder ein. Nähere Angaben zur Anzahl und der Art der Felder, die für die einzelnen Graphtypen erforderlich sind, finden Sie in der S-PLUS-Dokumentation.

Liniendiagramm: Bei diesem Standard-Graphtyp können pro Graph 1 bis 4 Spuren dargestellt werden. Jede Eingabe wird als Matrix mit einer Spalte (als y-Werte interpretiert, für die die entsprechenden x-Werte gezeichnet werden sollen) oder als Matrix mit zwei Spalten (als x- und y-Werte interpretiert) ausgewertet.

GUI-Diagramm: Dieser Graphtyp unterstützt alle S-PLUS-Diagramme, die über die grafische Benutzeroberfläche (GUI) von S-PLUS verfügbar sind. Bei dieser Komponente werden die Eingaben als Matrizen interpretiert, die gebündelt wurden, um die an die Grapherstellungsroutinen gesendeten Datenspalten zu erhalten. Der jeweils zu verwendende Graphtyp kann über die Felder "Achsentyp" und "Diagrammtyp" festgelegt werden. Klicken Sie auf "Achsen-/Diagrammtyp auswählen", um das S-PLUS-Dialogfeld aufzurufen, in dem Sie die Diagrammtypen auswählen und sich die verschiedenen Typen anhand von Miniaturansichten ansehen können.

Hinweis: Bei GUI-Diagrammen können bestimmte Eingaben als Bedingungsvariablen behandelt werden, um Trellis-Diagramme (mit Bedingungen versehene, aus mehreren Bereichen bestehende Diagramme) zu erhalten. Klicken Sie dazu auf die Kontrollkästchen auf der Registerkarte "Eingabevariablen" des Dialogfelds "Eigenschaften".

"Graphskript aufrufen": Dieser Graphtyp unterstützt alle Befehle, mit denen S-PLUS-Graphen nach Art der Version 3.3 generiert werden können. Zur Eingabe von Befehlen müssen Sie den Skripteditor öffnen. Wählen Sie dazu den Befehl "Skript bearbeiten" im Kontextmenü der Komponente. Das Skript kann jeden beliebigen S-PLUS-Code mit Aufrufen von plot(), points() usw. zur Erstellung eines oder mehrerer Graphen enthalten. Zur Festlegung der Ein- und Ausgaben sowie der statischen Variablen stehen Ihnen wie im Falle der Komponente "S-PLUS-Skript" (siehe weiter unten) die Registerkarten "Eingabevariablen" und "Ausgabevariablen" des Dialogfelds "Eigenschaften" zur Verfügung. Wenn das Skript vollkommen leer ist, wird es standardmäßig als plot(in0) definiert. Auf die Variable graphsheet.name kann von innerhalb des Skripts zugegriffen werden, um den Namen des Graphblattes zu erhalten. Wenn Sie mit der Bearbeitung des Skripts fertig sind, wählen Sie den Befehl Schließen und Zurückkehren aus dem Menü Datei des Skripteditors.

Hinweis: Im Normalfall wird das Diagramm vor jedem Aufruf eines Skripts zur Aktualisierung des Graphs gelöscht. Sie können dies jedoch verhindern, indem Sie die Option "Diagramm vor jedem Aufruf löschen" auf der Registerkarte "Graphtyp" des Dialogfelds "Eigenschaften" deaktivieren. Auf diese Weise können Sie mehrere Diagramme auf unterschiedlichen Seiten zusammenfassen.


Die DAC-Komponente (Data Acquisition Control, Datenerfassung)

Dieses Beispiel zeigt die Benutzeroberfläche der DAC-Komponente, wie Sie in Ihrem Mathcad-Arbeitsblatt angezeigt werden kann. In diesem Beispiel werden mithilfe eines PCI-MIO-16E-4 1000 Punkte Wellenformdaten bei einer Abtastrate von 10000 Abtastungen/Sekunde erfasst. Die Komponente wurde so eingestellt, dass sie mit der Datenerfassung erst bei Eintritt eines auslösenden Ereignisses beginnt, für das die unten gezeigten folgenden Parameter gelten. Die Daten werden an zwei Ausgabevariablen übergeben: v und Dt.

Abbildung 1: Benutzeroberfläche der DAC-Komponente


Standardabweichung bei Stichproben

Qwbspv(A, B, C, ...) Übergibt die Quadratwurzel der Varianz der Werte A, B, C, ...

Argumente:

A, B, C, ... sind Felder oder Skalare.

Weitere Funktionen für die Datenanalyse...


Varianz bei Stichproben

Argumente:

A, B, C, ... sind Felder oder Skalare.

Durch die Division der ins Quadrat gesetzten Abweichungen durch den Wert "Beispielgröße minus eins" anstatt einfach durch die Beispielgröße entsteht ein Schätzwert, der der tatsächlichen Populationsvarianz genauer entspricht.

Weitere Funktionen für die Datenanalyse...


Optionen für die Speicherung als Web-Seite

Das Dialogfeld Optionen für die Speicherung als Web-Seite enthält die folgenden Optionen, mit denen die Ausgabe von HTML-Dateien festgelegt werden kann, wenn Sie im Menü File den Befehl Als Web-Seite speichern verwenden:

Auf der Registerkarte HTML-Optionen des Dialogfelds Einstellungen finden Sie die folgenden Optionen:

Gleichungen speichern unter:

Bilder: Bei Auswahl von "Bilder" werden alle Gleichungsbereiche als PNG- oder JPEG-Dateien, je nach Auswahl unten, angezeigt. Für die Anzeige in einem Browser ist bei dieser Option keine zusätzliche Software erforderlich.

MathML: Bei Auswahl von MathML können Sie den MathML-Style aus dem Dropdown-Menü "Anzeigen mit" wählen. Inline-MathML wird in Browsern wiedergegeben, die MathML unterstützen. Für die anderen Optionen ist in der Regel ein Browser-Plug-in oder eine Active-X-Komponente erforderlich. Informationen zu den aktuellen Darstellungsoptionen finden Sie unter www.mathcad.com.

Bilder speichern als

PNG: PNG ist ein verlustfreies Format, d. h., es gehen keine Daten verloren, aber die so gespeicherten Dateien sind größer.

JPEG: Bei Auswahl von JPEG können Sie außerdem die Qualität der Kompression festlegen. Je höher Sie diesen Wert einstellen, desto weniger werden die Bilder komprimiert und desto größer sind die so gespeicherten Bilddateien.

Bei reiner HTML-Ausgabe werden alle Rechenbereiche mit dem ausgewählten Bildformat exportiert. Bei MathML-Ausgabe werden nur Diagramme, Tabellen und Komponenten als Bilder ausgegeben.

Layout speichern unter:

Fest: Bei der Einstellung "Fest" kommen absolute Tags für die Styles zum Einsatz, so dass das Mathcad-Layout nachempfunden wird.

Relativ: Bei der Einstellung "Relativ" wird der Inhalt des Mathcad-Arbeitsblatts in eine HTML-Tabelle exportiert. Für die Verwendung von HTML-Exportvorlagen muss die relative Positionierung gewählt werden.

Web-Seitenvorlage:

Wählen Sie, falls gewünscht, eine Vorlagendatei. Vorlagen gestalten Mathcad-Dokumente mit zusätzlicher HTML-Ausgabe und können nur verwendet werden, wenn für das Layout "Relativ" ausgewählt wurde. Sie lassen sich gut zur Erzielung eines einheitlichen Aussehens und für die Navigation zu zahlreichen Matchcad-Dokumenten verwenden und können zur Erstellung großer Websites eingesetzt werden. Weitere Anweisungen finden Sie in der Author's Reference (Autorenreferenz) im Menü Hilfe.

Titel:

Geben Sie ein HTML-Titel-Tag für die Seite ein, das beim Öffnen der Datei in der Titelleiste des Browsers angezeigt wird.

Gespeicherte Seite im Browser anzeigen:

Nach dem Speichern wird die Datei im Standardbrowser des Systems geöffnet.

Hinweise:

Alle mit Mathcad gespeicherten HTML-Dokumente weisen in die Code-Tags integrierten MathML-Inhalt auf. In der vorliegenden Version von MathML kann ein Dokument erneut in Mathcad eingelesen werden. Die einzige Ausnahme sind geschützte Dokumente, die nur im einfachen HTML-Format gespeichert werden können, um die Sicherheitsoptionen zu berücksichtigen.

Mit Ausnahme des Feldes Titel und des Kontrollkästchens Gespeicherte Seite im Browser anzeigen entsprechen die Optionen in diesem Dialogfeld denen auf der Registerkarte HTML-Optionen im Dialogfeld Einstellungen. Im Gegensatz zu diesen Optionen wird das Dialogfeld Optionen für die Speicherung als Web-Seite jedoch für einzelne Dateien eingerichtet und hat Vorrang vor den im Dialogfeld "Einstellungen" gewählten Optionen.


Speichern eines Graustufenbilds

Zum Speichern eines Graustufenbilds in eine Datei verwenden Sie die Funktion BMPSCHREIBEN wie folgt:

  1. Stellen Sie sicher, dass die Matrix, die das Bild enthält, das richtige Format aufweist.

  2. Geben Sie Folgendes ein, und geben Sie dabei den Matrixnamen und den Namen der Datei an, in die Sie schreiben:

    BMPSCHREIBEN(“Datei”) := M

Hinweis:

Die Funktionen müssen in GROSSBUCHSTABEN angegeben werden.


Speichern eines Arbeitsblatts zur Verwendung in einer vorherigen Version

Normalerweise sind Mathcad-Arbeitsblätter nur aufwärtskompatibel, Sie können ein Arbeitsblatt aber auch so speichern, dass es in einer vorherigen Version geöffnet werden kann.

Zum Speichern eines Arbeitsblatts, sodass es auch in einer vorherigen Version geöffnet werden kann, gehen Sie wie folgt vor:

  1. Wählen Sie im Menü Datei den Befehl Speichenr oder Speichern unter.

  2. Wählen Sie unter "Dateityp" das gewünschte Dateiformat aus (z. B. "Mathcad 7-Dateien"), und geben Sie einen Dateinamen ein.

  3. Klicken Sie auf "Speichern". Unter Umständen wird eine Meldung ausgegeben, in der Sie gewarnt werden, dass einige Programmfunktionen in einer der vorherigen Versionen nicht zur Verfügung stehen.

Auch wenn Sie ein Arbeitsblatt öffnen, das Sie in einer vorherigen Version gespeichert haben, kann eine Warnmeldung erscheinen, die Sie darauf aufmerksam macht, dass bestimmte Funktionen nicht unterstützt werden. Funktionen, die nur in der Version verfügbar sind, in der das Arbeitsblatt erstellt wurde, erscheinen in der vorherigen Version als Bitmaps. Alle Bereiche, die von diesen Funktionen abhängig sind, geben Fehlermeldungen aus. Zu solchen Funktionen können QuickPlots gehören.


Speichern eines Arbeitsblatt als HTML-Datei

Um ein Arbeitsblatt im HTML/MathML-Format zu speichern, müssen Sie zunächst die "HTML-Optionen" unter "Einstellungen" einichten. Nachdem Sie die Bild-, Daten- und Layoutformate ausgewählt haben, gehen Sie folgendermaßen vor:

  1. Wählen Sie im Menü Datei den Befehl Speichern unter.

  2. Wählen Sie in der Dropdown-Liste "Dateityp" die Option "HTML/MathML-Dateien", und geben Sie einen Dateinamen ein.

  3. Klicken Sie auf "Speichern".

Die Datei wird als HTML-Datei mit integriertem MathML-Inhalt gespeichert, sodass sie nach wie vor in Mathcad berechnet werden kann. Text wird als Text mit HTML-Code gespeichert. Die Vorgaben im Dialogfeld Einstellungen bestimmen, ob Gleichungen mit einem Plug-in zum Anzeigen von MathML oder als Bilder angezeigt werden. Alle Diagramme und sonstigen Bereiche, die nicht in MathML wiedergegeben werden können, werden im Format JPEG oder PNG gespeichert.

Wenn Sie Ihre Arbeitsblätter im HTML/MathML-Format speichern , können Sie sie ohne Verlust von Informationen wieder in Mathcad einlesen. Alle Bereiche werden in Mathcad so angezeigt und berechnet, als wäre das Dokument im üblichen Format gespeichert worden. Eine Ausnahme gilt nur geschützte Arbeitsblätter, die nur im statischen HTML-Format gespeichert werden können.

Wenn Sie unter "Einstellungen" eine HTML-Vorlage angegeben haben, sind die Vorlagenbereiche nur im Browserfenster sichtbar. HTML/Mathcad-Dateien, die wieder in Mathcad eingelesen werden, zeigen nur die ursprünglichen Mathcad-Bereiche. Alle Vorlageninformationen werden ignoriert.

Hinweise:

  • Wenn Sie ein Arbeitsblatt im HTML/MathML-Format speichern, wird ein Unterverzeichnis mit dem Namen “(dateiname)_images” erstellt, das die zugehörigen JPEG- und PNG-Dateien enthält.
  • Sie können Arbeitsblätter auch im HTML/MathML-Format speichern, indem Sie im Menü Datei den Befehl Als Web-Seite speichern wählen. Daraufhin wird ein zweites Dialogfeld aufgerufen, in dem Sie die Ausgabeeinstellungen vor dem Speichern ändern können.


Speichern eines Bilds in Farbe

Zum Speichern eines Farbbilds in einer Datei verwenden Sie die Funktion RGBSCHREIBEN oder eine andere Funktion wie folgt:

  1. Stellen Sie sicher, dass die Matrix, die das Bild enthält, das richtige Format aufweist.

  2. Geben Sie Folgendes ein, und geben Sie dabei den Matrixnamen und den Namen der Datei an, in die Sie schreiben:

    RGBSCHREIBEN("datei"):=A

Hinweis:

Die Funktionen müssen in GROSSBUCHSTABEN angegeben werden.


Speichern von Änderungen im elektronischen Buch

Wenn Sie Änderungen an einem elektronischen Buch speichern, haben Sie folgende Möglichkeiten:

  • Sie können Änderungen am Abschnitt speichern, der gerade geöffnet ist, oder

  • Sie können alle in beliebigen Abschnitten vorgenommenen Änderungen speichern.

Um nur die Änderungen im derzeit offenen Abschnitt zu speichern, gehen Sie folgendermaßen vor:

  • Wählen Sie Abschnitt speichern aus dem Kontextmenü
    „Bücher“ im Fenster „Informationszentrum/Elektronisches Buch“.

Um alle in beliebigen Abschnitten vorgenommenen Änderungen zu speichern, gehen Sie folgendermaßen vor:

  • Wählen Sie Alle Änderungen speichern aus dem Kontextmenü „Bücher“ im Fenster „Informationszentrum/Elektronisches Buch“.

Nachdem Sie eine Änderung an einem Abschnitt eines elektronischen Buchs gespeichert haben, wird ein Sternchen (*) in der Titelleiste angezeigt, wenn dieser Abschnitt geöffnet ist.


Speichern von Bildern

Das umgewandelte Bild liegt in der Regel in einer Matrix vor. Um es anderen Anwendungen verfügbar zu machen, müssen Sie es als Datei speichern. Hierfür gibt es zwei Verfahren.

  • So speichern Sie das Bld in Farbe...

  • So speichern Sie nur Graustufen...


Speichern von Dateien mithilfe von Microsoft SharePoint

Mathcad unterstützt neben dem Speichern von Dateien in eigenständigen Formaten auch das Speichern von Dateien in einem SharePoint-Datenspeicher. SharePoint bietet Versionen- und Zugriffsverwaltung für Mathcad-Arbeitsblätter.

Wenn Sie einen SharePoint-Datenspeicher öffnen, können Sie die Datei auschecken oder schreibgeschützt öffnen. Wenn Sie die Änderungen an einem ausgecheckten Arbeitsblatt beibehalten wollen, checken Sie die Datei wieder ein. So wird sie erneut im Datenspeicher gespeichert. Dateien, die schreibgeschützt geöffnet wurden, können nicht wieder im Datenspeicher gespeichert werden. Allerdings können Sie sie anderweitig, z. B. auf der Festplatte, speichern.

Wenn das Arbeitsblatt nicht öffentlich zugänglich gemacht wurde, können Sie es beim Einchecken öffentlich zugänglich machen. Wenn Sie eine Datei in SharePoint öffentlich zugänglich machen, ist sie nun für Benutzer mit Schreibrechten sichtbar. Zuvor ist sie für solche Benutzer nicht sichtbar.

Weitere Informationen zu SharePoint finden Sie auf der Web-Seite zum Programm unter http://www.microsoft.com/sharepoint/.

Hinweis:

Mathcad kann Dateien nicht von Anfang an im SharePoint-Datenspeicher speichern. Wenn Sie eine Datei zum Datenspeicher hinzufügen möchten, müssen Sie dies manuell tun. Gehen Sie im Web-Browser auf die Seite der Dokumentbibliothek für den Datenspeicher und klicken Sie auf die Verknüpfung Add Document, um das Arbeitsblatt oder die Datendatei hinzuzufügen.


Skalar (Definition)

SKALAR

Ein Skalar ist eine einzelne Zahl, z. B. 2 oder 34+2i. Alles, was kein Skalar ist, ist gewöhnlich ein Vektor oder eine Matrix.

Wenn etwas skalarwertig ist, wird ein Skalar als Ergebnis zurückgegeben. Beispielsweise ist cos(0) skalarwertig, da es die einzelne Zahl 1 zurückgibt. einheit(3) gibt jedoch eine 3x3-Matrix zurück. Diese Funktion ist daher nicht skalar-, sondern matrixwertig.


Skripteditor

Der Skripteditor zeigt die Grundstruktur eines Skripts und drei Subroutinen zum Einfügen von Skript-Code. Die Argumente Inputs und Outputs für die Subroutine "Exec" entsprechen den Feldern mit Ein- und Ausgabedaten, mit denen das Objekt arbeitet; mit der Angabe Inputs(0) und Outputs(1) im Hauptteil der Subroutine wird auf die erste Eingabe- und die zweite Ausgabe verwiesen. Die Befehle in den einzelnen Abschnitten werden bei jeder Berechnung des Mathcad-Arbeitsblatts nacheinander ausgeführt.


Modell für die Skriptobjekt-Komponente

Mit der Skriptobjekt-Komponente werden Objekte, Eigenschaften und Methoden vordefiniert, mit deren Hilfe Sie sie als Komponente in Mathcad nutzen können.

Collections

DataValue-Objekte

Globale Methoden


Eigenschaften der Skriptobjekt-Komponente: Skripterstellung

Die Registerkarte "Skripterstellung" des Dialogfeldes "Eigenschaften" dient dazu, festzulegen, wie viele Eingaben und Ausgaben die The Scripting tab of the Properties dialog box is used to specify the number of inputs and outputs the Skriptobjekt-Komponente annimmt und bereitstellt. Darüber hinaus können Sie auch den Namen des Objekts bestimmen, zu dem ein Skript erstellt werden soll.

Mit Skript bearbeiten öffnen Sie den Skripteditor, in dem Sie das Objektskript erstellen.


Beispiel für ein Skript-Objekt

Beispiel-Skript

Dieses Skript-Objekt akzeptiert zwei Eingabewerte und sendet zwei Ausgabewerte. Die Eingabewerte bestimmen, ob ein lächelndes oder ein blinzelndes Gesicht dargestellt wird. Das Skripteditor-Fenster zeigt einen Teil des zum Konfigurieren des Objekts verwendeten VBScript-Codes.


Erstellen eines Skripts für ein Objekt

Zum Erstellen eines Skripts für ein Objekt gehen Sie folgendermaßen vor:

  1. Fügen Sie die Skriptobjekt-Komponente ein.

  2. Klicken Sie einmal auf die Komponente, damit sie ausgewählt wird.

  3. Wählen Sie Skript im Kontextmenü. Dadurch wird der Skripteditor geöffnet.

  4. Wählen Sie Schließen und Zurückkehren im Menü Datei des Skripteditors, wenn Sie das Skript fertiggestellt haben und mit der Arbeit im Mathcad-Arbeitsblatt fortfahren möchten.

Hinweis: Sie können den Namen des Skriptobjekts bearbeiten, wenn Sie mit der rechten Maustaste auf die Skriptobjekt-Komponente klicken und im Kontextmenü den Befehl Eigenschaften wählen.

Das Skriptobjekt wird im Arbeitsblatt angezeigt.


Sekansmethode für die Suche nach Wurzeln

Sekans-/Müllermethode für die Suche nach Wurzeln

Die Sekans- und die Müllermethode finden bei der Funktion wurzel Anwendung, wenn lediglich zwei Argumente vorhanden sind (die optionalen 3. und 4. Argumente wurden nicht angegeben). Zunächst wird die Sekansmethode wie folgt abgearbeitet:

Zur Berechnung von wurzel(f(x),x) setzt Mathcad x als Anfangsschätzwert ein, um die Wurzel von f(x) herauszufinden. Dabei gilt folgende Schrittfolge:

  1. Ist |f(x)| < TOL, so ist x bereits die Wurzel, und x wird als Ergebnis ausgegeben.

  2. Es sei n=1. Ist x ungleich 0, so sei h=TOL*x, andernfalls sei h=TOL. Folgende Definitionen werden durchgeführt

  3. Erhöhen von n um eins. Dann Berechnung der Geraden, mit der der Punkt verbunden wird

  4. Es sei x sub n gleich dem Punkt, an dem die Gerade die Nullachse schneidet.

  5. Ist

  6. Sonst zurückkehren zu Schritt 3.

Schlägt die Sekansmethode zur Ermittlung der Wurzel fehl, wird die Müllermethode verwendet. Die Müllermethode ist eine modifzierte Version der Sekansmethode.

Wenn keine Wurzel ermittelt werden kann

Mathcad begrenzt die Zahl der Berechnungen, die Mathcad für eine Lösung der Funktion wurzel durchführt. Erreicht Mathcad bei der Routine die festgelegte Begrenzung, ohne dass eine Antwort ausgegeben wird, wird die Funktion wurzel als Fehler markiert.

Der Fehler kann folgende Ursachen haben:

Der Ausdruck enthält keine Wurzel.

Die Wurzel des Ausdrucks unterscheidet sich zu stark vom Anfangsschätzwert.

Im Ausdruck befinden sich zwischen dem ersten Schätzwert und der Wurzel lokale Höchst- oder Tiefstwerte.

Der Ausdruck weist zwischen dem Anfangsschätzwert und der Wurzel Unstetigkeiten auf.

Der Ausdruck weist eine komplexe Wurzel auf, während der Anfangsschätzwert aus einer reellen Zahl bestand (oder umgekehrt).

Damit die Funktion wurzel konvergiert, sollten Sie den Ausdruck als Diagramm darstellen, damit Sie feststellen können, ob und gegebenenfalls wo er ungefähr die x-Achse schneidet. Ändern Sie dann den Schätzwert entsprechend ab. Sie können auch den Wert von TOL ändern.


Sekans-/Müllermethode für die Suche nach Wurzeln

Die Sekans- und die Müllermethode finden bei der Funktion wurzel Anwendung, wenn lediglich zwei Argumente vorhanden sind (die optionalen 3. und 4. Argumente wurden nicht angegeben). Zunächst wird die Sekansmethode wie folgt abgearbeitet:

Zur Berechnung von wurzel(f(x),x) setzt Mathcad x als Anfangsschätzwert ein, um die Wurzel von f(x) herauszufinden. Dabei gilt folgende Schrittfolge:

  • Ist |f(x)| < TOL, so ist x bereits die Wurzel, und x wird als Ergebnis ausgegeben.

  • Es sei n=1. Ist x ungleich 0, so sei h=TOL*x, andernfalls sei h=TOL. Folgende Definitionen werden durchgeführt:

  • Erhöhen von n um eins. Dann Berechnung der Geraden, mit der die Punkte verbunden werden.

Es sei x sub n gleich dem Punkt, an dem die Gerade die Nullachse schneidet.

  • Wenn

  • Sonst zurückkehren zu Schritt 3.

Schlägt die Sekansmethode zur Ermittlung der Wurzel fehl, wird die Müllermethode verwendet. Die Müllermethode ist eine modifzierte Version der Sekansmethode.

Wenn keine Wurzel ermittelt werden kann

Mathcad begrenzt die Zahl der Berechnungen, die Mathcad für eine Lösung der Funktion wurzel durchführt. Erreicht Mathcad bei der Routine die festgelegte Begrenzung, ohne dass eine Antwort ausgegeben wird, wird die Funktion wurzel als Fehler markiert.

Der Fehler kann folgende Ursachen haben:

  • Der Ausdruck enthält keine Wurzel.

  • Die Wurzel des Ausdrucks unterscheidet sich zu stark vom Anfangsschätzwert.

  • Im Ausdruck befinden sich zwischen dem ersten Schätzwert und der Wurzel lokale Höchst- oder Tiefstwerte.

  • Der Ausdruck weist zwischen dem Anfangsschätzwert und der Wurzel Unstetigkeiten auf.

  • Der Ausdruck weist eine komplexe Wurzel auf, während der Anfangsschätzwert aus einer reellen Zahl bestand (oder umgekehrt).

Damit die Funktion wurzel konvergiert, sollten Sie den Ausdruck als Diagramm darstellen, damit Sie feststellen können, ob und gegebenenfalls wo er ungefähr die x-Achse schneidet. Ändern Sie dann den Schätzwert entsprechend ab. Sie können auch den Wert von TOL ändern.


Rekursivwert

Der Zufallszahlengenerator-Rekursivwert kann auf zwei Arten eingestellt werden. Sie können aus dem Menü Extras die Arbeitsblattoptionen auswählen und den Wert am Anfang des Arbeitsblatts in der Registerkarte "Vordefinierte Variablen" ändern, oder Sie ändern den Wert im Haupttext des Arbeitsblatts mit der Funktion Rekursivwert.

Rekursivwert(x) Setzt den Wert von Rekursivwert zu x zurück und gibt den vorherigen Wert zurück.

Argumente:

In jeden Fall, außer anders hingewiesen:

x ist eine dimensionslose, ganze Zahl zwischen 1 und 2147483647.

Mit jedem Rekursivwert erhalten Sie eine einmalige Folge aus gleichmäßig verteilten Zufallszahlen.

Hinweise:

Wird Rekursivwert vor einer Zufallszahlgenerator-Funktion aufgerufen, wird der ausgegebene Wert der gleiche, wie der in den Arbeitsblattoptionen eingestellte Wert sein. Wird "Rekursivwert" nach einer Zufallszahlgenerator-Funktion aufgerufen, wird der ausgegebene Wert der darauf folgende Wert sein, der für die Berechnung der nächsten Zahl in der Reihenfolge verwendet wurde.


Auswahl einer Variable

Zur Auswahl einer Variable klicken Sie auf die Variable, damit die Bearbeitungslinien in den Variablennamen gesetzt werden.


Vollständiges bzw. teilweises Auswählen eines Ausdrucks

Wie signifikant das ist, was Sie jeweils auswählen, hängt davon ab, welchen Menübefehl Sie wählen. Meistens wird nur das transformiert, was sich zwischen den Bearbeitungslinien befindet. In bestimmten Fällen transformieren Sie den gesamten Ausdruck; allerdings erfährt das, was Sie auswählen, stets eine besondere Behandlung. Wenn Sie zum Beispiel über Operatoren ableiten, bilden Sie die Ableitung des gesamten Ausdrucks über die ausgewählten Elemente.


Auswählen eines Ausdrucks

Sie wählen einen Ausdruck aus, indem Sie auf ihn klicken und die Leertaste so lange drücken, bis er sich zwischen den Bearbeitungslinien befindet.

Zur Auswahl eines Teilausdrucks müssen Sie diesen in runde Klammern setzen, bevor Sie ihn auswählen können.


Markieren aller Bereiche zwischen zwei Bereichen

Zum Markieren aller Bereiche zwischen zwei Bereichen gehen Sie wie folgt vor:

  1. Markieren Sie den ersten Bereich, indem Sie auf ihn klicken.

  2. Setzen Sie den Zeiger auf den letzten Bereich.

  3. Drücken Sie die Umschalttaste, und klicken Sie mit der Maus.

Beim Klicken mit der Maus müssen Sie unbedingt die Umschalttaste gedrückt halten. Andernfalls wird die Markierung der anderen zuvor markierten Bereiche wieder aufgehoben.


Zeichenweises Auswählen von Text

  • Positionieren Sie die Einfügemarke an einem Ende des auszuwählenden Textes.

  • Drücken Sie die Umschalttaste und eine Pfeiltaste.

Mathcad markiert die Zeichen des Textes entsprechend der Richtung des Pfeils auf der gedrückten Pfeiltaste.


Zeilenweises Auswählen von Text

  • Positionieren Sie die Einfügemarke an einem Ende des auszuwählenden Textes.

  • Drücken Sie Strg+Umschalt und die Pfeil-nach-oben bzw. Pfeil-nach-unten-Taste.

Mathcad markiert den Text von der Einfügemarke bis zum Beginn oder Ende einer Zeile.


Auswählen von Textbereichen

Gehen Sie zum Auswählen eines ganzen Textbereichs zum Verschieben folgendermaßen vor:

  1. Klicken Sie in den Textbereich. Der Textbereich wird daraufhin von einem Rechteck mit Haltepunkten umschlossen.

  2. Setzen Sie den Mauszeiger auf den Rahmen des Rechtecks, sodass er die Form einer kleinen Hand annimmt.

  3. Drücken Sie die Maustaste, und halten Sie sie gedrückt. Verschieben Sie die Maus bei gedrückter Maustaste. Der Umriss des Textbereich-Rechtecks folgt dem Mauszeiger.

  4. Sobald sich der Umriss an der gewünschten Position befindet, lassen Sie die Maustaste los.

Sollen mehrere Textbereiche ausgewählt werden, ziehen Sie das gestrichelte Auswahlrechteck mit der Maus, bis es alle auszuwählenden Bereiche umfasst.


Wortweises Auswählen von Text

  • Positionieren Sie die Einfügemarke an einem Ende des auszuwählenden Textes.

  • Drücken Sie Strg+Umschalt und die linke oder rechte Pfeiltaste.

Mathcad markiert den Text von der Einfügemarke bis zum Beginn des aktuellen bzw. nächsten Wortes in der Richtung des Pfeils auf der gedrückten Taste.


Auswählen von Werten aus einer Ausgabetabelle

Zum Auswählen aller Werte in einer Ausgabetabelle gehen Sie wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf die Tabelle.

  2. Wählen Sie Alles markieren im Kontextmenü.

Zum Auswählen einer Gruppe von Werten aus einer Ausgabetabelle gehen Sie wie folgt vor:

  1. Klicken Sie auf die erste Zahl, die kopiert werden soll.

  2. Halten Sie die Maustaste gedrückt, und ziehen Sie die Maus in die Richtung der anderen Werte, die kopiert werden sollen.

Auswählen aller Werte in einer Zeile oder Spalte:

  1. Klicken Sie auf die Zeilen- oder Spaltenzahl, die links neben der Zeile oder oben in der Spalte angezeigt wird.

  2. Nebeneinander liegende Zeilen oder Spalten wählen Sie aus, indem Sie den Mauszeiger bei gedrückter Maustaste über die Zeilen- bzw. Spaltenindizes ziehen.

Die ausgewählten Werte werden andersfarbig unterlegt, um anzuzeigen, dass sie ausgewählt wurden.


Übertragen von Daten aus Mathcad an Excel

Sie können in Mathcad gespeicherte Daten an Excel übertragen.

Wie möchten Sie die Daten übertragen?

  • Nur einmal, über Kopieren und Einfügen

  • Nur einmal, aus einem Feld

  • Ich möchte eine dynamische Verknüpfung zur Excel-Datei anlegen, damit eventuelle Änderungen in Mathcad automatisch von Excel übernommen werden.

Nur einmal, über Kopieren und Einfügen

Diese Methode bietet sich an, wenn Sie nur eine kleine Datenmenge aus Mathcad in ein Excel-Arbeitsblatt einfügen möchten. Zum Kopieren von Daten aus Mathcad und Einfügen in Excel befolgen Sie die Anweisungen zum Kopieren von Daten in die Zwischenablage.

Nur einmal, über eine Datendatei

Sie können Daten aus Mathcad in ein Excel-Arbeitsblatt exportieren. Folgen Sie hierzu den Anweisungen unter Exportieren von Daten in eine Datendatei.

Ich möchte eine dynamische Verknüpfung zur Excel-Datei anlegen, damit eventuelle Änderungen in Mathcad automatisch von Excel übernommen werden.

Wenn ein Feld in Mathcad Daten enthält, können Sie die Daten in ein Excel-Arbeitsblatt schreiben, indem Sie die Komponente "Dateien lesen/schreiben" einfügen. Die Komponente schreibt die Daten aus Mathcad in eine externe Datendatei. Außerdem stellt sie eine dynamische Verbindung zwischen Mathcad und der Datei her. Wenn sich die Daten in Mathcad ändern, werden die Änderungen dann automatisch in die Datendatei übertragen. Zum Schreiben von Daten in ein Excel-Arbeitsblatt mit dieser Methode befolgen Sie die Anweisungen über das Schreiben von Daten in eine Datendatei.


Entwickeln eines Ausdrucks in eine Reihe

Zum Entwickeln eines Ausdrucks in eine Taylor- oder Laurent-Reihe um 0 gehen Sie wie folgt vor:

  1. Wählen Sie die Variable aus, um die herum entwickelt werden soll.

  2. Wählen Sie Variable / Reihenentwicklung... im Menü Symbolik.

  3. Sie werden aufgefordert, die Ordnung der Reihenentwicklung anzugeben. Wählen Sie eine Ordnung aus (die Standardvorgabe ist 6, der Höchstwert ist 99). Klicken Sie dann auf "OK".

Die entwickelte Reihe enthält am Ende ein Glied wie z. B. O(x^6). Gelingt es dem symbolischen Prozessor nicht, eine Reihe um 0 herum abzuleiten, wird die Funktion zurückgegeben, ohne dass irgendwelche Änderungen vorgenommen wurden. Zur Ableitung einer Reihe, deren Mittelpunkt nicht gleich Null ist, müssen Sie die Variable nur verschieben.

Zu beachten ist, dass die Taylorsche Reihe für eine Funktion möglicherweise nur in einen kleinen Intervall um den Mittelpunkt konvergiert. Hinzu kommt, dass Funktionen wie sin oder exp Reihen mit unbegrenzt vielen Gliedern haben (die genaue Anzahl hängt von der von Ihnen festgelegten Ordnung ab). Daher gilt für Annäherungen einer Funktion durch das von Reihenentwicklung zurückgegebene Polynom, dass die Annäherung in der Nähe des Mittelpunkts ausreichend genau ist, mit steigender Entfernung vom Mittelpunkt aber immer ungenauer werden kann.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle das Schlüsselwort "Reihenentwicklung" und die aktive symbolische Berechnung.


Ausdrücke in einer Reihenentwicklung

Ein Ausdruck wie O(x^6) weist darauf hin, dass der Fehler bei der Verwendung der gegebenen Terme der Reihe als Näherungswert bei der Annäherung von x an 0 durch die Konstante mal x ^6 begrenzt ist.


Umschalt + Pfeil-nach-unten

In leeren Bereichen...

Verschiebt das Fadenkreuz nach unten. Wenn sich ein anderer Bereich unmittelbar darunter befindet, erscheint das Fadenkreuz in diesem Bereich und wird entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen...

Die Bearbeitungslinien erscheinen außerhalb und direkt unter dem Ausdruck als Fadenkreuz.

In Textbereichen...

Verschiebt die Einfügemarke um eine Zeile nach unten und markiert den gesamten Text zwischen der alten und der neuen Position der Einfügemarke.


Umschalt + Pfeil-nach-links

In leeren Bereichen...

Verschiebt das Fadenkreuz um eine Stelle nach links. Wenn sich ein anderer Bereich links daneben befindet, erscheint das Fadenkreuz in diesem Bereich und wird entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen...

Erweitert den Auswahlbereich im Ausdruck links neben der vertikalen Bearbeitungslinie.

In Textbereichen...

Markiert das links neben der Einfügemarke befindliche Zeichen.


Umschalt + Pfeil-nach-rechts

In leeren Bereichen...

Verschiebt das Fadenkreuz eine Stelle nach rechts. Wenn sich ein anderer Bereich rechts daneben befindet, erscheint das Fadenkreuz in diesem Bereich und wird entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen...

Erweitert den Auswahlbereich im Ausdruck rechts neben der vertikalen Bearbeitungslinie.

In Textbereichen...

Markiert das rechts neben der Einfügemarke befindliche Zeichen.


Umschalt + Tabulator

In leeren Bereichen...

Inaktiv.

In Rechenbereichen...

Springt zum vorhergehenden Platzhalter. Ist kein weiterer Platzhalter vorhanden, springen die Bearbeitungslinien aus dem Ausdruck heraus und erscheinen als Fadenkreuz im links davon befindlichen leeren Bereich.

In Textbereichen...

Fügt ein Leerzeichen ein.


Umschalt + Pfeil-nach-oben

In leeren Bereichen...

Verschiebt das Fadenkreuz nach oben. Wenn sich ein anderer Bereich unmittelbar darüber befindet, erscheint das Fadenkreuz in diesem Bereich und wird entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen...

Die Bearbeitungslinien erscheinen außerhalb und direkt unter dem Ausdruck als Fadenkreuz.

In Textbereichen...

Verschiebt die Einfügemarke um eine Zeile nach oben und markiert den gesamten Text zwischen der alten und der neuen Position der Einfügemarke.


Säulenanordnung "Nebeneinander"

Wenn diese Option aktiviert ist, werden alle Säulen, die Werte aus ein und derselben Spalte der Matrix darstellen, nebeneinander zusammengefasst dargestellt.


Signumfunktion (reell)


Signumfunktion für reelle und komplexe Ausdrücke


Vorzeichen einer komplexen Zahl

csgn(z) Gibt 0 zurück, wenn z=0. Ist Re(z)>0 oder (Re(z)=0 und Im(z)>0), wird 1 zurückgegeben, in allen anderen Fällen -1.

signum(z) Gibt 1 zurück, wenn z=0, andernfalls wird z/|z| zurückgegeben.

Argumente:

z ist eine reelle, imaginäre oder komplexe Zahl.


Vorzeichen einer reellen Zahl

sign(x) Gibt 0 zurück, wenn x=0. Ist x>0, wird 1 zurückgegeben, in allen anderen Fällen -1.

Argumente:

x ist eine reelle Zahl.


Symbolik / Vereinfachen

Vereinfacht den markierten Ausdruck arithmetisch durch Kürzen von gemeinsamen Faktoren und mithilfe von grundlegenden trigonometrischen Regeln und Umkehrfunktionen.


Symbolisches Vereinfachen von Ausdrücken

Zum algebraischen Vereinfachen eines Ausdrucks oder Teilausdrucks gehen Sie folgendermaßen vor:

  1. Setzen Sie den zu vereinfachenden Ausdruck (oder Teilausdruck) zwischen die Bearbeitungslinien.

  2. Wählen Sie Vereinfachen aus dem Menü Symbolik.

Durch den Befehl Vereinfachen werden arithmetische Berechnungen durchgeführt, gemeinsame Faktoren gekürzt, einfache trigonometrische und inverse Funktionsidentitäten angewendet und Quadratwurzeln und Potenzen vereinfacht. Kann der Ausdruck nicht weiter vereinfacht werden, so wird er durch den Befehl Vereinfachen unverändert zurückgegeben.

Hinweise:

  • Enthält der zu vereinfachende Ausdruck Funktionen mit mehreren Zweigen, zum Beispiel eine Quadratwurzel oder inverse trigonometrische Funktionen, gibt der symbolische Prozessor möglicherweise ein Ergebnis aus, dessen numerisches Verhalten vom Ausgangsterminus abweicht.

  • Zu beachten ist, dass der symbolische Prozessor bei der Eingabe von Zahlen mit Dezimalkomma (im Mathcad-Arbeitsblatt: Dezimalpunkt) alle Ergebnisse hinter dem Komma (Punkt) rundet.

  • Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


Vereinfachen angezeigter Einheiten

Zum Vereinfachen einer Gruppe von Einheiten zu einer Einheit (falls möglich) gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf die Einheit, um das Dialogfeld "Ergebnisformat" zu öffnen.

  2. Klicken Sie auf die Option "Einheiten wenn möglich vereinfachen", um sie zu aktivieren.

  3. Klicken Sie auf "OK".

Beispiel:

wird folgendermaßen vereinfacht:

Hinweis: Soll Mathcad automatisch versuchen, alle Einheiten in einem Arbeitsblatt zu vereinfachen, klicken Sie im Dialogfeld "Ergebnisformat" zuerst auf "Als Standard", bevor Sie auf "Einheiten wenn möglich vereinfachen" klicken.


Simultane Definitionen

Sie können mit Feldern mehrere Variablen gleichzeitig definieren. Gehen Sie hierzu folgendermaßen vor:

  1. Erstellen Sie einen Vektor oder eine Matrix.

  2. Geben Sie für die Elementplatzhalter Variablennamen ein.

  3. Geben Sie ":" ein, um einen Platzhalter zu erstellen.

  4. Erstellen Sie einen Vektor oder eine Matrix mit der gleichen Anzahl an Zeilen und Spalten wie der Vektor oder die Matrix auf der linken Seite.

  5. Geben Sie in den Platzhaltern Definitionen für die Variablen ein.

Mathcad wertet alle Elemente auf der rechten Seite aus, bevor die Zuweisungen auf der linken Seite vorgenommen werden. Daraus ergibt sich Folgendes:

  • Kein Element auf der rechten Seite eines Ausdrucks kann von Elementen auf der linken Seite abhängig sein.

  • Jede Variable kann höchstens einmal auf der linken Seite vorkommen.


Sinusintegral


Singuläre und nichtsinguläre Matrix

Eine Matrix gilt als singulär, wenn ihre Determinante gleich null ist. Eine Matrix ist nichtsingulär, wenn ihre Zeilen linear unabhängig sind. Mit anderen Worten: Keine Zeile darf eine lineare Kombination einer der anderen Zeilen sein.

Es kann vorkommen, dass eine Matrix fast singulär ist. In diesem Fall gibt es eine lineare Kombination der anderen Zeilen, die in einem sehr großen Maße eine der Zeilen reproduziert. Dies kann zu größeren Schwierigkeiten bei der numerischen Berechnung der Inversion der Matrix führen. Eine Matrix ist annähernd singulär, wenn sie eine hohe Bedingungszahl aufweist.


Singulärwertzerlegung

svd(A) Gibt genau eine Matrix mit den gestapelten Matrizen U und V zurück. Mit der Funktion "submatrix" können Sie diese kleineren Matrizen extrahieren.

Die Matrizen U und V erfüllen die Gleichung [image],

wobei s für den Vektor steht, der von svda(A) zurückgegeben wird.

Argumente:

  • A muss ein aus m x n Elementen bestehendes Feld sein, wobei m [image] n ist.

  • Die Elemente von A müssen reell sein.


Singulärwerte

Die Matrix darf weder singulär noch fast singulär sein.

Eine Matrix gilt als singulär, wenn ihre Determinante gleich null ist. Eine Matrix ist annähernd singulär, wenn sie eine hohe Bedingungszahl aufweist.


Singulärtwertfunktion

svds(A) Gibt einen Vektor mit singulären Werten von A zurück.

Argumente:

A muss ein aus m x n Elementen bestehendes Feld sein, wobei m [image] n ist.

Die Elemente von A müssen reell sein.

Die Ergebnisse dieser Funktion können verwendet werden, um die Singulärwertzerlegung einer Matrix durchzuführen.


Regression der Sinusfunktion

sinanp(vx,vy,vg) Übergibt einen Vektor mit den Koeffizienten einer Sinuskurve der Form a*sin(x+b)+c, die die Daten in vx und vy am besten darstellt. vg enthält Schätzwerte für die drei Koeffizienten.

Argumente:

  • vx ist ein Vektor aus reellen Datenwerten. Die Werte in vx entsprechen den x-Werten.

  • vy ist ein Vektor aus reellen Datenwerten. Die Werte in vy entsprechen den y-Werten.

  • vg ist ein dreidimensionaler Vektor mit reellen Schätzwerten für die Parameter a, b und c in der Sinusgleichung.

Hinweis:

vx und vy müssen jeweils die gleiche Anzahl von Elementen enthalten.


Schriftgrad

Der Schriftgrad bezeichnet die Größe der Zeichen in Punkten.


Schiefe

Argumente:

A, B, C, ... sind Felder oder Skalare. Ein aus den Funktionsargumenten erstelltes Feld M muss mindestens drei Elemente enthalten.

Die Standardabweichung von M muss ungleich 0 sein.

Hinweise:

  • Die Schiefe von Werten gibt die Asymmetrie über dem Mittelwert an. skew(M)=0 bedeutet, dass eine Verteilung über dem Mittelwert symmetrisch ist. skew(M)>0 bedeutet, dass sich der größte Teil der Verteilung nahe des Ursprungs befindet und sich der "Schwanz" zu den positiven Werten hin erstreckt. skew(M)<0 bedeutet, dass der "Schwanz" sich zu den negativen Werten hin erstreckt.

  • skew(M)=0 steht für die Normalverteilung.

Weitere Funktionen für die Datenanalyse...


Schieberegler im Dialogfeld "Playback"

Den Regler können Sie mit der Maus nach links oder rechts ziehen, um in der Animation vorwärts oder rückwärts zu gehen.


Schieberegler für die Wiedergabe von aufeinander folgenden Bildern

Verwenden Sie diesen Schieberegler wie eine Bildlaufleiste. Mit diesem Regler können Sie um ein Bild oder mehrere Bilder vorwärts- oder rückwärts blättern.


Neigung und Achsenabschnitt

neigung(vx,vy) Steigung der Linie, die am ehesten den Daten in vx und vy entspricht.

achsenabschn(vx,vy) Achsenabschnitt der Linie, die am ehesten den Daten in vx und vy entspricht.

Argumente:

vx ist ein Vektor aus reellen Datenwerten. Für die Funktion "neigung" ist vx ein Vektor aus reellen Datenwerten. Die Werte in vx entsprechen den x-Werten.

vy ist ein Vektor aus reellen Datenwerten. Diese entsprechen den y-Werten. Die Anzahl der Elemente entspricht der von vx.

Hinweise:

  • Die Funktionen neigung und achsenabschn sind nicht nur für vom Ursprung her lineare Daten, sondern auch für exponentielle Daten geeignet.

  • Die Gleichung für die Linie, die am ehesten Ihren Daten in vx und vy entspricht, ist y=m.x+b, wobei m das Ergebnis der Funktion neigung und b das Ergebnis der Funktion achsenabschn ist.

Im Beispiel unten wird gezeigt, wie Sie mithilfe der Funktionen neigung und achsenabschn eine lineare Regression durchführen können: Wenn Sie eine Schnellfunktion vorziehen, verwenden Sie stattdessen line oder medanp.


Kleiner Handzeiger

Wenn der Handzeiger sichtbar ist, können Sie die Bereiche, die Sie markiert haben, mit der Maus an eine andere Stelle im Arbeitsblatt ziehen. Sie erhalten diesen Zeiger folgendermaßen:

  • Wählen Sie einen oder mehrere Bereiche aus.

  • Setzen Sie den Pfeilzeiger an den Rand eines ausgewählten Bereichs. Dadurch wird der Pfeilzeiger als Hand angezeigt.

Wenn Sie nun das Handsymbol ziehen, verschieben sich die ausgewählten Bereiche mit.


SmartSketch-Registerkarte "Eingaben/Ausgaben"

Eingaben in SmartSketch

Jede Eingabe ist ein Wert in Mathcad, der an SmartSketch übertragen wird. In diesem Bereich werden die Dimensionen, Variablen und Symbole in der SmartSketch-Zeichnung beschrieben, die von der Eingabe bestimmt werden.

Ausgaben aus SmartSketch

Jede Ausgabe ist ein Wert, der von SmartSketch an Mathcad übertragen wird. In diesem Bereich werden die Dimensionen, Variablen und Symbole in der SmartSketch-Zeichnung beschrieben, die eine Ausgabe zurückgeben.

Automatisches Ändern der Größe

Markieren Sie dieses Kontrollkästchen, wenn die Größe einer umfangreicheren Zeichnung an das Komponentenfenster im Mathcad-Arbeitsblatt angepasst werden soll.


Stetige Systeme

Stetige Systeme von gewöhnlichen Differentialgleichungen

Bulstoer(y, x1, x2, npunkte, D)

Gibt eine Matrix zurück, in der: (1) die erste Spalte die Punkte enthält, an denen die Lösung der gewöhnlichen Differentialgleichung ausgewertet wird, und (2) die anderen Spalten die entsprechenden Werte der Lösung sowie die ersten n-1 Ableitungen enthalten.

Argumente:

  • y muss ein Vektor aus n Anfangswerten bzw. ein Skalar sein.

  • x1, x2 sind Endpunkte des Intervalls, an dem die Lösung für Differentialgleichungen ausgewertet wird. Anfangswerte in y sind die Werte bei x1.

  • npunkte ist die Anzahl der Punkte hinter dem Anfangspunkt, an denen die Lösung angenähert werden soll. Hiermit wird die Anzahl der Zeilen
    (1 + npunkte) in der Matrix bestimmt, die von Bulstoer zurückgegeben wird.

  • D ist eine vektorwertige Funktion mit n Elementen, die erste Ableitungen der unbekannten Funktionen enthält.

Hinweise:

  • Bulstoer verwendet das Bulirsch-Stoer-Verfahren, das etwas genauer ist als das von rkfixed verwendete Runge-Kuttasche-Verfahren.

  • Wenn Sie wissen, dass die Lösung stetig ist, verwenden Sie die Funktion Bulstoer an Stelle von rkfixed.


Glätten von Daten mithilfe eines Gaußschen Kerns

kgltt(vx,vy,b) Gibt einen aus m Elementen bestehenden Vektor zurück, der durch Glättung mithilfe eines Gaußschen Kerns entsteht. Bei den zurückgegebenen Werten handelt es sich um die gewichteten Mittel der Elemente in vy.

Argumente:

  • vx ist ein aus m Elementen bestehender Vektor aus reellen Zahlen. Bei strgltt müssen die Elemente von vx in aufsteigender Reihenfolge geordnet sein.

  • vy ist ein aus m Elementen bestehender Vektor aus reellen Zahlen.

  • b ist die Bandbreite des Glättungsfensters. Der Wert sollte einige Male größer als der Abstand zwischen x Datenpunkten sein.

Hinweise:

  • Diese Funktion ist vor allem für die Fälle geeignet, in denen die Daten entlang eines Bandes mit relativ konstanter Breite liegen.


Glätten von Daten mithilfe eines adaptiven Verfahrens

strgltt(vx,vy) Gibt einen aus m Elementen bestehenden Vektor zurück, der durch die stückweise Ausführung eines symmetrischen linearen MKQ-Anpassungsverfahrens unter Berücksichtigung des k am nächsten stehenden Nachbarn entsteht, wobei k der jeweiligen Situation angepasst wird.

Argumente:

  • vx ist ein aus m Elementen bestehender Vektor aus reellen Zahlen in aufsteigender Reihenfolge.

  • vy ist ein aus m Elementen bestehender Vektor aus reellen Zahlen.

Hinweise:

  • Dieses adaptive Glättungsverfahren eignet sich vor allem dann, wenn die Daten über ein Band verstreut liegen, dessen Breite stark veränderlich ist.


Glätten von Daten mit gleitenden Mittelwerten

medgltt(vy,n) Gibt einen aus m Elementen bestehenden Vektor zurück, der durch die Glättung von vy mit gleitenden Mittelwerten entsteht.

Argumente:

  • vy ist ein aus m Elementen bestehender Vektor aus reellen Zahlen.

  • n ist die Breite des Fensters, in dem eine Glättung stattfinden soll. n muss eine ungerade Anzahl von Elementen sein, die kleiner als die der Elemente in vy ist.

Hinweise:

  • Diese Funktion ist die robusteste Anpassungsfunktion, da sie am wenigsten von störenden Datenpunkten beeinträchtigt werden kann.


Automatische Seitenumbrüche

Ein automatischer Seitenumbruch wird auf dem Arbeitsblatt als gepunktete Linie dargestellt. Alles, was sich unter dieser Linie befindet, wird auf der nächsten Seite gedruckt.

Automatische Seitenumbrüche werden automatisch durch den verwendeten Drucker eingefügt. Änderungen an diesen können Sie nur vornehmen, wenn Sie einen anderen Drucker wählen.

Wenn Sie bestimmen wollen, wo eine neue Seite beginnen soll, fügen Sie manuelle Seitenumbrüche ein.


Lösung mit adaptiven Schrittweiten

Gewöhnliche Differentialgleichungen mit langsam und schnell variierenden Bereichen

Rkadapt(y, x1, x2, npunkte, D)

Gibt eine Matrix zurück, in der: (1) die erste Spalte die Punkte enthält, an denen die Lösung der gewöhnlichen Differentialgleichung ausgewertet wird, und (2) die anderen Spalten die entsprechenden Werte der Lösung sowie die ersten n-1 Ableitungen enthalten.

Argumente:

y muss entweder ein Vektor aus n Anfangswerten oder ein Skalar sein.

x1, x2 sind Endpunkte des Intervalls, an dem die Lösung für Differentialgleichungen ausgewertet wird. Anfangswerte in y sind die Werte bei x1.

npunkte ist die Anzahl der Punkte hinter dem Anfangspunkt, an denen die Lösung angenähert werden soll. Hiermit wird die Anzahl der Zeilen (1 + npunkte) in der Matrix bestimmt, die von Rkadapt zurückgegeben wird.

D ist eine vektorwertige Funktion mit n Elementen, die erste Ableitungen der unbekannten Funktionen enthält.

Hinweise:

  • Anders als die Funktion rkfest, die in Schritten mit gleicher Weite integriert, um eine Lösung zu finden, untersucht Rkadapt, wie schnell sich eine Lösung ändert, und verändert die Schrittweite dementsprechend. Rkadapt verwendet beim Lösen der Differentialgleichung intern ungleichmäßige Schrittweiten, gibt die Lösung jedoch an Punkten mit gleichem Abstand zurück.


Lösungsblock

Unter einem Lösungsblock versteht man eine Gruppe von Schritten, die zum Auflösen eines Gleichungssystems, eines Optimierungsproblems oder eines linearen Programmierungsproblems ausgeführt werden. Diese Lösungsschritte unterscheiden sich zwar geringfügig, gleich ist aber allen, dass sie das Wort Vorgabe, bestimmte Nebenbedingungen und eine Lösungsfunktion beinhalten. Zusammengenommen ergibt das einen Lösungsblock.

Ein Lösungsblock setzt sich aus den folgenden Teilen zusammen:

  1. Wort Vorgabe. Dieses Wort muss als Variable in einem leeren Teil des Arbeitsblatts eingegeben werden.

  2. Nebenbedingungen (bis zu 200). Die Gleichungen und Ungleichungen müssen mithilfe der Booleschen Operatoren, mit Ausnahme von Strg+3 ("ungleich"), eingegeben werden.

  3. Eine der folgenden Lösungsfunktionen:

  • suchen oder minfehl zum Lösen eines Gleichungssystems.

  • maximieren oder minimieren zum Optimieren einer Funktion.

  • Gdglösen zum Lösen von gewöhnlichen Differentialgleichungssystemen.

  • Pdglösen zum Lösen von partiellen Differentialgleichungssystemen.

Folgendes sollte in Lösungsblöcken nicht enthalten sein:

  • Bereichsvariablen

  • Nebenbedingungen mit dem Ungleich-Operator (Strg+3)

  • Andere Lösungsblöcke. Jeder Lösungsblock darf nur einmal das Wort "Vorgabe" und nur eine Lösungsfunktion enthalten. Sie können jedoch am Ende des Lösungsblocks eine Funktion wie f(x):=Suchen(x) definieren und diese Funktion in einem anderen Lösungsblock verwenden.

  • Zuweisungen durch einen Zuweisungs-Operator. Zum Eingeben eines Gleichheitszeichens in Lösungsblöcken verwenden Sie Strg+=.

Beachten Sie, dass beim numerischen Lösen von Gleichungen möglicherweise andere Schritte vor dem Verwenden eines Lösungsblocks vorhanden sein müssen:

  • Schätzwert für möglicherweise unbekannte Variablen.

  • Bei den Funktionen Maximieren und Minimieren muss die zu optimierende Funktion definiert sein.


Lösungsprozess

Wenn Sie die Mathcad-Funktionen suchen, minfehl, minimieren und maximieren verwenden, analysiert die Mathcad-Funktion Autom. Auswahl automatisch die Art des zu lösenden Problems und probiert geeignete Lösungsalgorithmen aus, um eine gültige Lösung zu erhalten. Um herauszufinden, welcher Algorithmus verwendet wurde, gehen Sie wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf die Funktion. Daraufhin wird das Kontextmenü eingeblendet.

  2. Autom. Auswahl sowie eine der folgenden Methoden sind mit einem Häkchen versehen:

Linear
Nichtlinear / Konjugierte Gradienten
Nichtlinear / Quasi-Newton
Nichtlinear / Levenberg-Marquardt
Quadratisch

Autom. Auswahl wird stets standardmäßig verwendet. Damit wird Mathcad angewiesen, den entsprechenden Lösungsprozess zu verwenden, um eine gültige Lösung zu finden. Handelt es sich um ein lineares Problem, wird die Methode "Linear" angewendet. Handelt es sich um ein quadratisches Problem, wird die Methode "Quadratisch" angewendet. Wird für das Problem ein nichtlinearer Lösungsalgorithmus benötigt, kommt das Verfahren konjugierter Gradienten zum Einsatz. Kommt keine Annäherung an das Ergebnis zustande, wird das Levenberg-Marquadt-Verfahren verwendet. Ist auch damit kein Ergebnis zu erzielen, wird auf das Quasi-Newton-Verfahren zurückgegriffen.

Obwohl es sich zumeist empfiehlt, Autom. Auswahl aktiviert zu haben, ist es möglich, mithilfe des Kontextmenüs manuell eine bestimmte Methode auszuwählen, sollte dies erforderlich sein.

Hinweise:

  • Um festzustellen, ob eine Lösung gültig ist, verwenden die meisten Lösungsalgorithmen die Werte der vordefinierten Variablen "TOL" und "CTOL". CTOL legt fest, wie genau Nebenbedingungen erfüllt werden müssen, damit eine Lösung als gültig angesehen werden kann. TOL legt fest, wie genau die Lösung sein muss. Falls nötig, können Sie die Werte von "CTOL" und "TOL" anpassen.

  • Sie können mit Mathcad nichtlineare Systeme von bis zu 250 Variablen, lineare Systeme von bis zu 1000 Variablen und quadratische Systeme von bis zu 1000 Variablen lösen.

  • Mit der gemischten Ganzzahlenprogrammierung können Sie ganze oder binäre Zahlen als Lösungen erzwingen.

  • Sollte es bei der Suche nach einer Lösung Schwierigkeiten geben, gehen Sie wie folgt vor:

    • Legen Sie für TOL oder CTOL größere Werte fest.

    • Probieren Sie verschiedene Schätzwerte aus, oder fügen Sie eine Ungleichung hinzu. Beachten Sie, dass komplexe Lösungen nur gefunden werden können, wenn auch ein komplexer Schätzwert vorgegeben wurde.

    • Verwenden Sie die Funktion minfehl anstelle von suchen, wenn Sie eine angenäherte Lösung haben wollen.

    • Verändern Sie im Falle einer nichtlinearen Lösungsmethode die Einstellungen unter "Erweiterte Optionen".


Symbolisches Lösen von Gleichungssystemen

Zum symbolischen Lösen eines Gleichungssystems gehen Sie wie folgt vor:

  1. Geben Sie das Wort Vorgabe ein.

  2. Geben Sie unterhalb von Vorgabe die Gleichungen und Ungleichungen ein.

  3. Geben Sie die Funktion Suchen ein, wobei als Argumente die Unbekannten zu verwenden sind.

  4. Drücken Sie [Strg]. (gefolgt von einem Punkt). In Ihrem Dokument erscheint ein nach rechts zeigender Pfeil (symbolisches Gleichheitszeichen).

  5. Klicken Sie auf eine Stelle außerhalb der Funktion Suchen. Mathcad gibt das Ergebnis in einem Vektor an. Die Ergebnisse haben dieselbe Reihenfolge wie die Argumente der Funktion Suchen.

Beispiel:


Extension Pack "Solving and Optimization"

Extension Pack "Solving and Optimization" (Expert Solver)

Das Mathcad Extension Pack "Solving and Optimization" (Expert Solver) von Mathsoft steht Nutzern von Mathcad zur Verfügung, die für das Lösen von Gleichungen und Optimieren von Funktionen umfangreichere Analysemöglichkeiten benötigen. Dieses Erweiterungspaket ersetzt den einfachen Lösungsalgorithmus, der in Mathcad enthalten ist.

Mit dem Extension Pack "Solving and Optimization" erhalten Sie erweiterte Lösungsfunktionen wie zum Beispiel:

  • Unterstützung für quadratisches Programmieren

  • Unterstützung für gemischte Ganzzahlenprogrammierung

  • Bessere Leistung bei linearen und nichtlinearen Lösungsmodulen

  • Lösung umfangreicherer, numerischer Probleme. Sie können jetzt Probleme mit bis zu 500 nichtlinearen oder 1.000 linearen Variablen verarbeiten.

  • Berichtgenerierung

Weitere Informationen und Bezugsnachweise für das Extension Pack "Solving and Optimization" (Expert Solver) erhalten Sie direkt bei MathSoft.


Lösen von Gleichungssystemen

suchen(var1, var2, ...) Gibt die Werte von var1, var2... zurück, die die Gleichungen und Ungleichungen in einem Lösungsblock erfüllen. Wenn Sie nach n Variablen lösen, muss der Lösungsblock n Gleichungen enthalten.

Argumente:

var1, var2,... sind skalare Variablen im Gleichungssystem.

Verwenden Sie die Funktion wie folgt:

Zum Lösen eines Gleichungssystems mit der Funktion suchen gehen Sie wie folgt vor:

  1. Definieren Sie Schätzwerte für die unbekannten Variablen.

  2. Geben Sie das Wort Vorgabe ein, um das Gleichungssystem zu starten.

  3. Geben Sie unter Vorgabe mithilfe Boolescher Operatoren Gleichungen und Ungleichungen als Teil des Lösungsblocks ein.

  4. Verwenden Sie die Funktion suchen.

Hinweise:

  • Bei einer unbekannten Variablen ist die Lösung ein Skalar. Andernfalls gibt die Funktion einen Vektor zurück, dessen erstes Element var1, dessen zweites Element var2 usw. ist.

  • Der Algorithmus der Funktion suchen beinhaltet einen speziellen Lösungsprozess, bei dem aus mehreren verfügbaren Methoden eine geeignete Methode ausgewählt wird.

  • Sie können die Funktion suchen auf die gleiche Weise verwenden wie jede andere Funktion. Sie können zum Beispiel eine andere Funktion mit suchen definieren. Dadurch können Sie von einem Lösungsblock aus andere Lösungsblöcke aufrufen oder einige der Parameter oder Konstanten in Ihrem Gleichungssystem variieren.

Beispiel:

Lösen eines Systems nichtlinearer Gleichungen


Es liegt ein Fehler im Lösungsblock vor

Es liegt ein Fehler in dem Lösungsblock vor, mit dem diese Funktion definiert wird. Möglicherweise ist ein Schätzwert erforderlich.

Diese Fehlermeldung erscheint, wenn Sie eine Benutzerfunktion auswerten, die in Abhängigkeit von einem Lösungsblock definiert ist, der einen Fehler enthält.

Um den Fehler zu beheben, müssen Sie den Lösungsblock korrigieren. Wenn Sie den Lösungsblock direkt auswerten, statt eine Funktion damit zu definieren, wird eine spezifischere Fehlermeldung angezeigt.


Sortierfunktionen

Mathcad verfügt über drei Funktionen zum Sortieren von Feldern und über eine Funktion, mit der die Reihenfolge der Elemente von Feldern umgekehrt werden kann:

sort(v)

Gibt einen Vektor mit den in aufsteigender Reihenfolge sortierten Werten in v zurück. Wenn v komplexe Elemente enthält, wird der Imaginärteil ignoriert.

spsort(A,n)

Gibt ein Feld zurück, das dadurch gebildet wird, dass die Zeilen von A so umgestellt werden, dass die Spalte n in aufsteigender Reihenfolge sortiert ist. Wenn A komplexe Elemente enthält, wird der Imaginärteil ignoriert.

zsort(A,n)

Gibt ein Feld zurück, das dadurch gebildet wird, dass die Spalten von A so umgestellt werden, dass die Zeile n in aufsteigender Reihenfolge sortiert ist. Wenn A komplexe Elemente enthält, wird der Imaginärteil ignoriert.

umkehren(v)

Gibt einen Vektor zurück, in dem die Elemente von v in umgekehrter Reihenfolge sortiert sind. Wenn v komplexe Elemente enthält, wird der Imaginärteil ignoriert.


Leertaste

In leeren Bereichen...

Verschiebt das Fadenkreuz eine Stelle nach rechts.

In Rechenbereichen...

Verlängert die Bearbeitungslinien so, dass ein größerer Teil des Ausdrucks zwischen den Bearbeitungslinien liegt. Enthält der Rechenbereich jedoch keine Operatoren, wird er dadurch in einen Textbereich umgewandelt.

In Textbereichen...

Fügt ein Leerzeichen ein.


Abstand

Dieser Wert bestimmt, wie weit die einzelnen Säulen voneinander entfernt sein sollen. Der von Ihnen eingegebene Wert gibt an, wieviel Prozent des Gitters durch den Säulenabstand beansprucht werden. Je größer der Wert ist, den Sie hier eingeben, desto dünner werden die einzelnen Säulen.


Spezielle Funktionen

Tcheb(n,x)

Tschebyscheff-Polynom vom Grad n der ersten Art

Ucheb(n,x)

Tschebyscheff-Polynom vom Grad n der zweiten Art

Her(n,x)

Hermite-Polynom vom Grad n

Jac(n,a,b,x)

Jacobi-Polynom vom Grad n mit den Parametern a und b

Lag(n,x)

Laguerre-Polynom vom Grad n

Leg(n,x)

Legendre-Polynom vom Grad n

fhyper(a,b,c,x)

Gaußsche hypergeometrische Funktion

mhyper(a,b,x)

Konfluente hypergeometrische Funktion

ibeta(a,x,y)

Unvollständige Beta-Funktion von x und y mit dem Parameter a

G( z)

Eulersche Gammafunktion

G( a,x)

Unvollständige Gammafunktion des Grades a


Besondere Funktionen und Syntax für symbolische Ergebnisse

In manchen Fällen verwenden symbolische Ergebnisse besondere Funktionen und Syntax. Beim Auswerten von symbolischen Ausdrücken entweder mithilfe des Menüs Symbolik oder der aktliven symbolischen Berechnung werden möglicherweise spezielle Operatoren und Funktionen angezeigt, die nur unter symbolischer Auswertung eine Bedeutung haben. Antworten, die diese Operatoren enthalten, können nicht mit = ausgewertet werden, aber sie können mit dem symbolischen Auswertungsoperator oder den Auswahlmöglichkeiten im Menü Symbolik ausgewertet werden.

Spezielle numerische Funktionen

arcsec, arccosec, arccot, arcosech, arcscsh, arccoth

g

Catalansche Konstante

Chi(x)

Ci(x)

csgn(x)

dilog(x)

D(x)

Ei(x)

FresnelC(x)

FresnelS(x)

G(z)

hypergeom(n1, n2..., d1, d2..., z)

Psi(n,x)

Psi(x)

Shi(x)

Si(x)

signum(x)

W(x)

W(n,x)

Zeta(s)

Da es sich bei den speziellen Funktionen nicht um vordefinierte Funktionen handelt, können Sie sie nicht direkt durch Drücken von = berechnen. Um einen numerischen Wert für eine dieser Funktionen herauszufinden, klicken Sie oben auf den Funktionsnamen, oder gehen Sie das folgende QuickSheet-Beispiel durch.


Spezielle Funktionen zum Einlesen von Bilddateien

Mit den unten aufgeführten speziellen Funktionen werden Bilder folgender Formate eingelesen: BMP, JPG, GIF, TGA und PCX.

BILD_LESEN("datei") Erstellt ein Feld, das eine Graustufendarstellung der Bilddatei enthält.

HLS_LESEN("datei") Erstellt ein Feld, das die Farbinformationen in der Datei durch entsprechende Werte für Farbton, Helligkeit und Sättigung wiedergibt.

HSV_LESEN(“datei”) Erstellt ein Feld, das die Farbinformationen in der Datei durch entsprechende Werte für Farbton, Sättigung und Wert wiedergibt.

ROT_LESEN("datei") Extrahiert aus einem Farbbild ausschließlich den Rotanteil.

GRÜN_LESEN("datei") Extrahiert aus einem Farbbild ausschließlich den Grünanteil.

BLAU_LESEN("datei") Extrahiert aus einem Farbbild ausschließlich den Blauanteil.

HLS_TON_LESEN ("datei") Extrahiert aus einem Farbbild ausschließlich die Farbtonkomponente.

HLS_HELL_LESEN("datei") Extrahiert aus einem Farbbild ausschließlich die Helligkeitskomponente.

HLS_SAT_LESEN("datei") Extrahiert aus einem Farbbild ausschließlich die Sättigungskomponente.

HSV_TON_LESEN ("datei") Extrahiert aus einem Farbbild ausschließlich die Farbtonkomponente.

HSV_SAT_LESEN("datei") Extrahiert aus einem Farbbild ausschließlich die Sättigungskomponente.

HSV_WERT_LESEN("datei") Extrahiert aus einem Farbbild ausschließlich die Wertkomponente.

Argumente:

  • datei ist der Pfad zu einer BMP-, JPG-, GIF-, TGA- oder PCX-Datei.

  • datei wird als Zeichenfolge eingegeben.

Diese Funktionen werden auf die gleiche Weise verwendet wie die Funktion BMPLESEN zum Einlesen einer Datei.


Spezielle Funktionen zum Schreiben von Bilddateien

HLS_SCHREIBEN("datei") Erstellt eine Farb-Bitmap-Datei aus einer Matrix, die das Bild im HLS-Format enthält.

HSV_SCHREIBEN("datei") Erstellt eine Farb-Bitmap-Datei aus einer Matrix, die das Bild im HSV-Format enthält.

Argumente:

  • datei ist der Pfad zu einer BMP-Datei.

  • datei wird als Zeichenfolge eingegeben.

Mit den oben aufgeführten speziellen Funktionen können Sie Dateien mit farbigen Bitmaps aus Matrizen erstellen, in denen das Bild im HLS- oder HSV-Format gespeichert ist.

Diese Funktionen werden auf die gleiche Weise verwendet wie die Funktion BMPSCHREIBEN zum Schreiben in eine Datei.


Festlegen der Lösungsmethode

In bestimmten Situationen möchten Sie die automatische Lösungsmethode möglicherweise hinter einer der Lösungsfunktionen außer Kraft setzen: suchen, minfehl, minimieren oder maximieren. So ist es z. B. denkbar, dass Sie sich im Rahmen einer Tiefenanalyse auch das Ergebnis anzeigen lassen möchten, dass mittels einer anderen Methode als der Standardmethode ermittelt wird. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie mit der rechten Maustaste auf den Funktionsnamen. Daraufhin erscheint das Kontextmenü.

  2. Wählen Sie eine der folgenden Methoden, sofern sie verfügbar ist:


Glanzlicht

Glanzlicht strahlt aus einer bestimmten Richtung und wird in einer bestimmten Richtung von der Oberfläche reflektiert. Durch ein Glanzlicht entsteht normalerweise ein heller Punkt auf einem Objekt. Ein Scheinwerfer ist ein gutes Beispiel.

Glanzlicht hat keine größere Wirkung auf die Darstellungsweise eines Diagramms. Es ist jedoch zu empfehlen, wenn ein Diagramm glänzende Bereiche erhalten soll. Zum Beispiel kann ein Flächendiagramm, das auf der Seite "Darstellung" im Dialogfeld "3D-Diagrammformat" mit nur einem darauf strahlenden weißen Glanzlicht erstellt wurde, sich extrem verändern, wenn Sie den Glanz auf der Seite "Erweitert" ändern.


Vordefinierte Funktion "sph2xyz"

sph2xyz ist eine vordefinierte Funktion, die sphärische Koordinaten in kartesische Koordinaten umwandelt. Beispiel:

Sie können sph2xyz als fabb-Argument von ErstellenGitter oder ErstellenRaum verwenden.


Operator "Quadratwurzel"

Quadratwurzel

Tastaturbefehl: \

Gibt die positive Quadratwurzel von x zurück.

Operanden:

x muss ein Skalar sein.

Bei negativem oder komplexem x wird die Quadratwurzel mit dem kleinsten Argument zurückgegeben.


Säulenanordnung "Übereinander"

Wenn diese Option aktiviert ist, werden alle Säulen, die Werte aus ein und derselben Spalte der Matrix darstellen, übereinander angeordnet.


Gestapelte Matrizen der Funktion "svd"


Stapeln von Arbeitsblattfenstern

Wählen Sie den Befehl Überlappend im Menü Fenster. Dadurch wird das aktive Fenster so über alle anderen Fenster gelegt, dass die Titelleisten aller anderen Fenster noch sichtbar sind.


Standardfehler

stdfehl(vx,vy) Gibt den Standardfehler einer einfachen linearen Regression für die in vx und vy beschriebenen Punkte zurück. Die Funktion misst, wie eng die Datenpunkte über der Regressionslinie verteilt sind.

Argumente:

vx ist ein Vektor mit bekannten x-Werten. Er muss mindestens drei Zeilen haben.

vy ist ein Vektor mit bekannten y-Werten. Er muss mindestens drei Zeilen haben.

Weitere Funktionen für die Datenanalyse...


Statische Variablen

Statische Variablen in der Komponente "S-PLUS-Skript" sind die Variablen, deren Werte bei den verschiedenen Aufrufen des Skripts erhalten bleiben.

Zum Deklarieren von statischen Variablen ist folgendermaßen vorzugehen:

  • Fügen Sie dem Feld "Statische Variablennamen" auf der Registerkarte "Eingabevariablen" des Dialogfelds "Eigenschaften" der Komponente die Namen der Variablen hinzu (durch Kommas voneinander getrennt).

Zu beachten ist dabei, dass alle statischen Variablen zurückgesetzt werden, sobald das Skript selbst geändert wird.


Einzelschritte bei der Levenberg-Marquardt-Methode

Bei der Levenberg-Marquardt-Methode handelt es sich um eine Quasi-Newtonsche Näherungsmethode (also um eine Variante der Gradientenmethode). Bei jedem Schritt schätzt Mathcad die ersten Teilableitungen der Fehler in Bezug auf die aufzulösenden Variablen, sodass eine Jacobi-Matrix (Funktionsmatrix) erstellt wird. Normalerweise kann Mathcad den nächsten Schätzwert durch Berechnung des Gauß-Newtonschen Schritts s für jede Variable bestimmen. In der Matrixnotation löst Mathcad die Matrixgleichung:

In dieser Gleichung steht J für die Jacobi-Matrix, s für den durchzuführenden Schritt und x für den Vektor der aktuellen Schätzwerte für unbekannte Variablen. Beim ersten Schritt bildet x den Vektor für die Schätzwerte; bei jedem folgenden Schritt ist das neue x definiert als die Summe aus x plus s (dem Schrittvektor). Beachten Sie, dass bei der Berechnung dieses Schritts die Funktionsmatrix J umgekehrt wird.

Dieser Schritt kann nicht immer berechnet werden. Die Berechnung schlägt fehl, wenn die Funktionsmatrix nicht invertiert werden kann oder wenn die Zahl der Nebenbedingungen die der zu lösenden Variablen übersteigt. In diesen Fällen gibt Mathcad die zusätzliche Bedingung vor, dass die folgende Menge auf ein Minimum reduziert wird:

Hier ist D der Vektor von Gewichtungsfaktoren, die aus den Normen der Spalten in der Jacobi-Matrix berechnet werden. In diesen Fällen wird s so berechnet, dass es die Minimierungskriterien erfüllt und gleichzeitig die Newtonsche Gleichung innerhalb der Funktionsmatrix auflöst.

Die Levenberg-Marquardt-Methode funktioniert nicht, wenn weniger Nebenbedingungen als Variablen vorhanden sind. In einem solchen Fall gibt Mathcad einen Fehler aus.


Steife Systeme

Steife Systeme von gewöhnlichen Differentialgleichungen

Stiffb(y, x1, x2, npunkte, D, J)
Stiffr(Y, x1, x2, npunkte, D, J)
Radau(y, x1, x2, npunkte, D)

Jede dieser Funktionen gibt eine Matrix zurück in der: (1) die erste Spalte die Punkte enthält, an denen die Lösung der gewöhnlichen Differentialgleichung ausgewertet wird, und (2) die anderen Spalten die entsprechenden Werte der Lösung sowie die ersten n-1 Ableitungen enthalten.

Argumente:

Y muss entweder ein Vektor aus n Anfangswerten oder ein einzelner Anfangswert sein.

x1, x2 sind Endpunkte des Intervalls, an dem die Lösung für Differentialgleichungen ausgewertet wird. Anfangswerte in y sind die Werte bei x1.

npunkte ist die Anzahl der Punkte hinter dem Anfangspunkt, an denen die Lösung angenähert werden soll. Hiermit wird die Anzahl der Zeilen (1 + npunkte) in der Matrix bestimmt, die von Stiffb, Stiffr oder Radau zurückgegeben wird.

D ist eine vektorwertige Funktion mit n Elementen, die erste Ableitungen der unbekannten Funktionen enthält.

J ist eine Funktion, die eine aus n x (n+1) Elementen bestehende Matrix zurückgibt, deren erste Spalte Ableitungen enthält und deren andere Zeilen und Spalten die Jacobische Matrix für das System der Differentialgleichungen bilden.

Hinweise:

  • Stiffb benutzt die Bulirsch-Stoer-Verfahren für steife Systeme. Stiffr benutzt die Rosenbrock-Verfahren. Radau benutzt die RADAU5-Verfahren.

  • Der Vorteil bei der Benutzung von Radau liegt darin, dass keine symbolische Jacobian-Eingabe gebraucht wird. Das ist ein Nachteil, wenn J bereits vorhanden ist, weil J dazu tendiert, die Genauigkeit zu erhöhen.


Steife Systeme (Definition)

Steife Systeme

Ein System ist steif, wenn es in folgender Form ausgedrückt ist:

y=A x

Die Matrix A ist beinahe singulär.

Unter diesen Bedingungen oszilliert rkfest unter Umständen oder ist instabil.


Zeichenfolge

Als Zeichenfolge gilt eine Reihe von Zeichen, die zwischen zwei Anführungszeichen steht. Sie hat keinen numerischen Wert. Für Zeichenfolgen gelten keine Längenbegrenzungen. Sie werden stets als einzelne Textzeile im Arbeitsblatt wiedergegeben.

Als Zahlenzeichenfolge wird eine Zeichenfolge mit Zeichen beschrieben, die eine reelle, komplexe, negative oder positive Zahl, eine Gleitkommazahl oder eine Zahl in Exponentialschreibweise ergibt. Leerzeichen in Zahlenzeichenfolgen werden ignoriert.


Der Zeichensatz enthält eine falsche Zeichenanzahl oder die falsche Art von Zeichen.

Wenn Sie mit gemischter Ganzzahlenprogrammierung arbeiten (wodurch ein ganzzahliger oder binärer Wert als Ergebnis erzwungen wird), muss die Anzahl der Zeichen im Zeichensatzargument der Anzahl der Variablen entsprechen, die gelöst werden sollen. Zulässig sind nur die Zeichen "I" für ganze Zahlen, "B" für Binärzahlen und "C" für stetige reelle Zahlen.


Diese Operation kann für eine Zeichenfolge nicht ausgeführt werden.

Diese Operation kann nicht für ein string-Argument ausgeführt werden.


Strukturierte Datendatei

Eine Datei, in der die Daten in Zeilen und Spalten angeordnet und durch Leerzeichen und Tabulatorschritte voneinander getrennt sind. Beispiel:

2 2 3

2 8 6

3 6 9

Ein Textvorsatz ist zulässig am Dateianfang. Sobald die Funktion PRNLESEN jedoch auf eine Zahl stößt, geht sie davon aus, dass der Datenbereich erreicht wurde. Der Textvorsatz darf also keine Zahlen wie Datumsangaben usw. enthalten.

Datendateien können Zahlen im E-Format enthalten. Beispiel:

16E-2 -16.125E-15 200 50

sind jeweils gültige Zahlen in der Datendatei.

Hexadezimale, oktale oder binäre Daten werden nicht unterstützt.


t-Verteilung

Studentsche T-Verteilung

Verteilungen, die sich auf die Studentsche T-Gleichung beziehen:

dt(x,d) Gibt die Wahrscheinlichkeitsdichte for für die t-Verteilung zurück.

pt(x,d) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qt(p,d) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rt(m,d) Gibt einen Vektor aus m Zufallszahlen zurück, die die t-Verteilung aufweisen.


Stil

Schriftschnitt

Stil bezeichnet das momentane Aussehen innerhalb der Schriftfamilie. Beispiele sind fett, kursiv und unterstrichen.


Ersetzen

Zum Ersetzen einer Variable im gesamten Arbeitsblatt durch eine andere Variable, einen Ausdruck oder eine Zahl gehen Sie folgendermaßen vor:

  1. Wählen Sie aus, was durch die Variable ersetzt werden soll, und wählen Sie Kopieren im Menü Bearbeiten.

  2. Wählen Sie die Variable aus, die ersetzt werden soll.

  3. Wählen Sie Variable / Ersetzen im Menü Symbolik.

Diese Operation kann einen unübersichtlichen Ausdruck ergeben. Sie können das Ergebnis vereinfachen, indem Sie es markieren und Vereinfachen im Menü Symbolik wählen.

Beachten Sie, dass dieser Befehl nur funktioniert, wenn Sie eine Variable durch einen Ausdruck ersetzen wollen. Dieser Befehl kann nicht verwendet werden, um einen Ausdruck durch einen anderen Ausdruck zu ersetzen. Zum Ersetzen von Ausdrücken durch andere Ausdrücke müssen Sie die Befehle Ausschneiden und Einfügen aus dem Menü Bearbeiten verwenden.


Operator "Subtraktion"

Subtraktion

Tastaturbefehl: -

x - y

Subtrahiert y von x.

Ist der Ausdruck so lang, dass er über den rechten Bildschirmrand hinausgeht, sollten Sie stattdessen y negieren und Strg+Eingabe drücken. Daraufhin wird Folgendes eingefügt:

Operanden:

x und y sind Skalare.

x und y müssen dieselbe Dimension haben.


Summe der Vektorelemente

Tastaturbefehl: Strg+4

v

Gibt die Summe aller Elemente im Vektor v zurück.

Operanden:

  • v ist ein Vektor.


Summation mit Bereichsvariablen

Tastaturbefehl: $

Gibt die Summe des Ausdrucks X über den Bereich i zurück.

Operanden:

  • i muss ein Bereich ganzer Zahlen sein.

  • X ist ein beliebiger Ausdruck.

Definieren Sie zunächst die Bereichsvariable i, und setzen Sie erst dann den Operator ein. Beispiel:

Zur Summierung mit einer variablen oberen Grenze der Summenbildung gehen Sie wie im folgenden Beispiel vor:

Wenn der Summand mehrere Glieder hat, müssen Sie diese in Klammern einschließen, um sie innerhalb des Operators zu halten.


Summation ohne Bereichsvariablen

Tastaturbefehl: Strg+Umschalt+4

Gibt die Summe über i zurück, wobei i von m bis n des Ausdrucks X reicht.

Operanden:

  • i muss eine ganze Zahl sein.

  • X ist ein beliebiger Ausdruck.

  • m und n müssen ganze Zahlen sein.

Wenn der Summand mehrere Glieder hat, müssen Sie diese in Klammern einschließen, um sie innerhalb des Operators zu halten.

Hinweis:

Die Variable i ist nur innerhalb dieses Operators definiert und steht daher in keinerlei Zusammenhang mit Variablendefinitionen außerhalb des Operators "Produkt".


Operator "Hochgestellter Index"

Tastaturbefehl: Strg+6. Oder klicken Sie auf die Schaltfläche Hochgestellt in der Symbolleiste Formatierung.

Gibt die n-te Spalte des Feldes M zurück. Wenn M keine n-te Spalte hat, erscheint eine entsprechende Fehlermeldung.

Operanden:

M muss ein Feld sein.

v ist ein Vektor. Darf nicht komplex sein.

Denken Sie daran, dass alle Felder standardmäßig bei 0 und nicht bei 1 beginnen. Für eine Matrix mit 10 Spalten muss n zwischen 1 und 10 liegen. Um dies zu ändern, wählen Sie Arbeitsblattoptionen aus dem Menü Extras, und ändern Sie in der Registerkarte "Vordefinierte Variablen" den Wert für ORIGIN.

Beispiel:

Um eine Zeile aus einer Matrix zu erhalten, verwenden Sie den Operator "Hochgestellter Index" zusammen mit dem Operator "Transponieren". Um z. B. die erste Zeile einer Matrix M zu erhalten, geben Sie M Strg+1 Strg+6 1 ein.


Ändern der Auswertungsreihenfolge

Wenn Sie etwas unterhalb und/oder rechts von der Position definieren möchten, an der Sie es verwenden, müssen Sie das Symbol für eine globale Definition verwenden. Zum Einfügen des Gleichheitszeichens für globale Definitionen drücken Sie ~ (Tilde). Es erscheint als Dreier-Gleichheitszeichen (bzw. als =, wenn Sie die Darstellung des Operators ändern).

Tatsächlich werden zwei Durchläufe in Ihrem Arbeitsblatt vorgenommen:

  1. Beim ersten Durchlauf werden alle Zuordnungen vorgenommen, die das Gleichheitszeichen für globale Definitionen beinhalten. Ausdrücke, in denen ein Gleichheitszeichen für globale Definitionen vorkommt, von oben nach unten und von links nach rechts ausgewertet.

  2. Beim zweiten Durchlauf werden alle Zuordnungen vorgenommen, die ':=' beinhalten, und es werden Ergebnisse und Diagramme angezeigt. Beim zweiten Durchlauf werden alle Zuordnungen ausgewertet (auch die globalen Zuordnungen).

Hinweis:

  • Bei den globalen Zuordnungen werden keine Zuordungen mit ':=' verwendet. Ist eine Variable mit ':=' über einer globalen Zuordnung definiert, wird sie von der globalen Zuordnung ignoriert. Klicken Sie hier, um sich ein Beispiel anzeigen zu lassen.


Unterstützte Datentypen

Mathcad unterstützt die folgenden Datendateitypen (Lesen und Schreiben):

  • Formatierter Text (*.prn)

  • Text mit Tabulatoren als Trennzeichen (*.dat, *.txt)

  • Durch Komma getrennte Werte (*.csv)

  • MATLAB MAT-Dateien (*.mat)

  • Excel-Dateien (*.xls)

  • Lotus 1-2-3-Dateien (*.wks, *.wk1, *.wk*)

  • Quattro Pro-Dateien (*.wq?, *.wb?)

  • dbase-Dateien (*.dbf)

  • S-Plus-Dateien

  • Textdateien mit Komma als Dezimaltrennzeichen

Hinweis: Um Textdateien zu lesen oder zu schreiben, bei denen das Komma als Dezimaltrennzeichen dient, müssen Sie dafür sorgen, dass das Komma auch im Betriebssystem Ihres Rechners als Dezimaltrennzeichen festgelegt ist. Klicken Sie dann beim Wählen des Dateityps auf die Dialogfeldoption "Komma als Dezimaltrennzeichen verwenden".


Unterstützte Skript-Sprachen

Beispiele für unterstützte Skript-Sprachen sind die neuesten Versionen von Microsoft JScript (JavaScript) und Microsoft VBScript (Visual Basic Scripting Edition). Weitere Informationen zu diesen Skript-Sprachen finden Sie auf der Microsoft-Website unter http://msdn.microsoft.com/scripting. Von dort können Sie sich auch die neuesten Versionen dieser Sprachen herunterladen.


Symbolische Differentiation

Zum Differenzieren einer Funktion in Bezug auf eine Variable gehen Sie folgendermaßen vor:

  1. Drücken Sie die Taste ?, um den Ableitungsoperator einzufügen.

  2. Geben Sie den zu differenzierenden Ausdruck und die Variable für die Differenzierung in die Platzhalter ein.

  3. Drücken Sie so lange die Leertaste, bis sich der gesamte Ausdruck zwischen den Bearbeitungslinien befindet.

  4. Wählen Sie Vereinfachen aus dem Menü Symbolik.

Zum Berechnen von Ableitungen höherer Ordnung drücken Sie Strg+Umschalt+?, damit der Operator für die Ableitung höherer Ordnung erstellt wird. Folgen Sie dann obigen Anweisungen.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


Symbolisches Anzeigeformat

Wählen Sie den Befehl Auswertungsformat im Menü Symbolik, um festzulegen, wo die symbolischen Ergebnisse erscheinen sollen. Folgende Möglichkeiten stehen zur Auswahl:

  • Die Option "Vertikal mit Einfügen von Zeilen" sorgt dafür, dass die Ergebnisse untereinander angezeigt werden, wobei zwischen den einzelnen Schritten eine Leerzeile über die Breite des gesamten Arbeitsblatts eingefügt wird.

  • Die Option "Vertikal ohne Einfügen von Zeilen" sorgt dafür, dass die Ergebnisse untereinander angezeigt werden, wobei aber benachbarte Bereiche zusammen bleiben, sodass Sie getrennte Berechnungen nebeneinander anstellen können

  • Die Option "Horizontal" sorgt dafür, dass die Ergebnisse rechts vom Ausgangsausdruck erscheinen.

Aktivieren Sie die Option "Kommentare anzeigen", um vor jedem Ergebnis einen entsprechenden Kommentar automatisch einfügen zu lassen. Sie können diese automatisch generierten Kommentare ebenso bearbeiten wie jeden anderen Textbereich.

Aktivieren Sie die Option "An Stelle auswerten", um den ursprünglichen Ausdruck durch die symbolische Antwort zu ersetzen. Diese Option ist vor allem dann praktisch, wenn Sie nur einen Teil eines längeren Ausdrucks transformieren möchten.


Symbolisches Gleichheitszeichen

Symbolisches Gleichheitszeichen (Strg+.)

Zum Vereinfachen eines Ausdrucks mithilfe des symbolischen Gleichheitszeichens gehen Sie wie folgt vor:

  1. Geben Sie den zu vereinfachenden Ausdruck ein.

  2. Drücken Sie Strg+. (Punkt). Es erscheint das symbolische Gleichheitszeichen, das die Form eines nach rechts zeigenden Pfeils hat.

  3. Klicken Sie auf eine Stelle außerhalb des Ausdrucks, oder drücken Sie die Eingabetaste. Rechts vom symbolischen Gleichheitszeichen erscheint daraufhin der transformierte Ausdruck.

Weitere Einzelheiten zum symbolischen Gleichheitszeichen:

  • Es ist ein aktiver Operator. Wenn Sie also im Arbeitsblatt etwas vor dem Zeichen (oberhalb oder links davon) verändern, aktualisiert Mathcad das Ergebnis automatisch.

  • Es nimmt bereits definierte Funktionen und Variablen zur Kenntnis und verwendet sie entsprechend. Sie können das symbolische Gleichheitszeichen jedoch anweisen, bestehende Definitionen zu ignorieren.

  • Es gilt für einen ganzen Ausdruck. Sie können mit dem symbolischen Gleichheitszeichen zum Beispiel nicht lediglich einen Teil eines Ausdrucks transformieren.


Symbolische Integration

Zum Berechnen eines unbestimmten Integrals gehen Sie folgendermaßen vor:

  1. Drücken Sie Strg+I zur Erstellung des Operators für das unbestimmte Integral.

  2. Füllen Sie die Platzhalter für den Integranden und die Integrationsvariable aus.

  3. Drücken Sie so lange die Leertaste, bis sich das gesamte Integral zwischen den Bearbeitungslinien befindet.

  4. Wählen Sie Auswertung Þ Symbolisch aus dem Menü Symbolik.

Soll stattdessen ein bestimmtes Integral berechnet werden, drücken Sie & zur Erstellung des bestimmten Integraloperators, und befolgen Sie dann die Anweisungen oben. Der symbolische Prozessor von Mathcad sucht dann ein unbestimmtes Integral und subtrahiert seinen Wert am unteren Grenzwert der Integration vom Wert am oberen Grenzwert. Wenn Sie im Integranden oder in den Grenzwerten der Integration mit Dezimalzahlen arbeiten, wird eine numerische Annäherung von 20 Stellen angezeigt, soweit verfügbar.

Verfügt ein Integral nicht über einen Ausdruck in geschlossener Form, wird eine entsprechende Fehlermeldung angezeigt. Wenn Sie nur eine numerische Annäherung an ein bestimmtes Integral benötigen, sollten Sie stattdessen das Integral numerisch berechnen.

Zu beachten ist, dass die Antwort auf ein Integrationsproblem bei der Berechnung eines unbestimmten Integrals nicht eindeutig ist. Wenn f(x) ein Integral einer vorgegebenen Funktion ist, gilt dies auch für f(x) + C bei einer Konstante C.

Hinweis:

  • Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


Symbolisches Ermitteln der Matrixdeterminante

Zum Ermitteln der Determinante einer quadratischen Matrix gehen Sie wie folgt vor:

  1. Klicken Sie auf die quadratische Matrix, und drücken Sie so oft die Leertaste, bis sich die Matrix zwischen den Bearbeitungslinien befindet.

  2. Wählen Sie Matrix / Determinante im Menü Symbolik.

Beachten Sie dabei, dass Sie die gesamte Matrix auswählen müssen, um diesen Befehl verwenden zu können. Das Definieren einer Variable als Matrix und das anschließende Auswählen dieser Variable ist nicht möglich.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


Symbolisches Invertieren von Matrizen

Zum Ermitteln der Inversen einer quadratischen Matrix gehen Sie wie folgt vor:

  1. Klicken Sie auf die quadratische Matrix, und drücken Sie so oft die Leertaste, bis sich die Matrix zwischen den Bearbeitungslinien befindet.

  2. Wählen Sie den Befehl Matrix / Invertieren im Menü Symbolik.

Beachten Sie dabei, dass Sie die gesamte Matrix auswählen müssen, um diesen Befehl verwenden zu können. Das Definieren einer Variable als Matrix und das anschließende Auswählen dieser Variable ist nicht möglich.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


Symbolische Matrixoperationen

Sie haben die Möglichkeit, Matrixausdrücke mit Operatoren symbolisch auszuwerten. Die meisten Matrixfunktionen werden auch symbolisch vereinfacht, wenn dies sinnvoll ist. Um einen Ausdruck mit Matrizen und Matrixoperatoren bzw. -funktionen symbolisch auszuwerten, gehen Sie wie folgt vor:

  1. Klicken Sie auf den Ausdruck, und drücken Sie so oft die Leertaste, bis das zu berechnende Element sich vollständig zwischen den Bearbeitungslinien befindet.

  2. Wählen Sie Vereinfachen aus dem Menü Symbolik.

Zu beachten ist, dass viele dieser Transformationen nicht für die Matrix als Ganzes gelten. Um z. B. die Ausdrücke in einer Matrix zu vereinfachen, müssen Sie den Befehl Vereinfachen für jedes Element einzeln wählen.


Symbolisches Transponieren von Matrizen

Zum Ermitteln der Transponierten einer Matrix gehen Sie wie folgt vor:

  1. Klicken Sie auf die Matrix, und drücken Sie so oft die Leertaste, bis sich die Matrix zwischen den Bearbeitungslinien befindet.

  2. Wählen Sie den Befehl Matrix / Transponieren im Menü Symbolik.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


Nur symbolischer Operator. Drücken Sie [Strg] [Punkt].

Sie müssen diesen Operator symbolisch auswerten. Drücken Sie [Strg] [Punkt].

Sie haben versucht, einen Ausdruck numerisch auszuwerten, der symbolisch ausgewertet werden muss. Wenn Sie mit Operatoren wie "Unbestimmtes Integral" und "Grenzwert" arbeiten, müssen Sie den Ausdruck auswählen und Vereinfachen im Menü Symbolik wählen.


Zu lange symbolische Ergebnisse

Wenn Sie einen Befehl im Menü "Symbolik" wählen und das symbolische Ergebnis so platzraubend ausfällt, dass es im Arbeitsblatt nicht mehr problemlos angezeigt werden kann, werden Sie in einem Dialogfeld gefragt, ob das Ergebnis in die Zwischenablage gesetzt werden soll. Solche zu langen Ergebnisse entstehen häufig bei den folgenden Operationen:

  • Integrieren oder Differenzieren komplexer Ausdrücke

  • Symbolisches Ermitteln der Wurzeln von Polynomen

  • Symbolisches Auswerten von Funktionen, die ein sehr großes ganzzahliges Ergebnis haben

Wenn Sie eine umfangreiche Antwort in die Zwischenablage verlagern, können Sie das Ergebnis überprüfen, indem Sie die Zwischenablage öffnen. Symbolische Ergebnisse erscheinen in der Zwischenablage in einer Syntax, die etwa der einer Tabellenkalkulation entspricht.

Sie können dieses Ergebnis drucken, indem Sie es in ein Dokument einer Textverarbeitung einfügen. Sie können die Antwortzeichenfolge jedoch auch als Textbereich direkt in das Arbeitsblatt einfügen.


Symbolische Vereinfachung

Beispiel für symbolisches Rechnen:

3x - 2x

wird vereinfacht zu: x

Für die gleiche Aufgabe werden beim numerischen Rechnen (also nach der Eingabe eines Gleichheitszeichens) folgende Ergebnisse angezeigt:

  • Eine Fehlermeldung, falls x undefiniert ist, oder

  • der Wert von x, wenn x definiert ist.


Symbolische Summen und Produkte

Zum symbolischen Auswerten von Summen und Produkten gehen Sie wie folgt vor:

  1. Drücken Sie die Tastenkombination Strg+Umschalt+4 bzw. Strg+Umschalt+3, um den Summations- bzw. den Produktoperator zu erstellen. Geben Sie einen Ausdruck und einen Bereich ein.

  2. Geben Sie einen Ausdruck und einen Bereich ein.

  3. Wählen Sie Vereinfachen aus dem Menü Symbolik.

Wenn der symbolische Prozessor keine geschlossene Form für die Summe oder das Produkt findet, geschieht Folgendes:

  • Es wird eine explizite Summe oder ein explizites Produkt zurückgegeben, oder

  • eine Meldung angezeigt, wonach keine geschlossene Form für die Summe oder das Produkt gefunden wurde.

Hinweis:

Wenn Sie symbolische Befehle wie Vereinfachen verwenden, "weiß" der symbolische Prozessor nichts über Variablendefinitionen in Ihrem Arbeitsblatt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


Die Schaltflächenleiste "Symbolik"

Anstatt ein Schlüsselwort über die Tastatur einzugeben, können Sie auch auf die Schlüsselwortschaltfläche in der Schaltflächenleiste "Symbolik" klicken. Klicken Sie auf die Schaltfläche [image] in der Rechenpalette, um die Schaltflächenleiste "Symbolik" zu öffnen:

Mit den Schaltflächen auf der Symbolleiste "Symbolik" können Sie das symbolische Gleichheitszeichen und die symbolischen Schlüsselwörter einfügen. Löschen Sie die Platzhalter der optionalen Argumente, die Sie nicht verwenden möchten. Klicken Sie auf die Schaltfläche "Modifiers". Daraufhin wird die Symbolleiste "Modifikator" eingeblendet.

Welche Funktionen die einzelnen Schaltflächen haben, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • ein QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche erscheint, und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


Symbolik / Zusammenfassen

Hierdurch werden im ausgewählten Teilausdruck die Terme gleicher Potenz zusammengefasst. Der Teilausdruck kann aus einer einzigen Variable oder aus einer Funktion und ihrem Argument bestehen. Das Ergebnis ist ein Polynom im gewählten Teilausdruck.


Symbolik / Auswerten / Komplex

Führt die symbolische Auswertung durch und gibt das Ergebnis, soweit möglich, in komplexer Form wieder.


Symbolik / Auswerten / Gleitkomma...

Führt die symbolische Auswertung durch und gibt das Ergebnis, soweit möglich, als Zahl aus. Das Dialogfeld "Gleitkommaauswertung" wird angezeigt, in dem Sie die Zahl der signifikanten Ziffern angeben können, die das Ergebnis enthalten soll.


Symbolik / Auswerten / Symbolisch

Wertet bestimmte Integrale, Ableitungen, Summationen (Additionen), Produkte, Funktionen und andere algebraische und Matrizenausdrücke symbolisch aus.


Symbolik / Auswertungsformat...

Legt fest, wo Symbolergebnisse angegeben werden. Sie haben folgende Möglichkeiten:

  • Das Ergebnis kann mit oder ohne Kommentar unter den ausgewählten Ausdruck gesetzt werden.

  • Das Ergebnis kann mit oder ohne Kommentar rechts neben den ausgewählten Ausdruck gesetzt werden.

  • Der ausgewählte Ausdruck kann durch das Ergebnis ersetzt werden.


Symbolik / Matrix / Determinante

Gibt die Determinante der ausgewählten quadratischen Matrix aus.


Symbolik / Matrix / Invertieren

Gibt die reziproke Matrix der ausgewählten quadratischen Matrix aus.


Symbolik / Matrix / Transponieren

Vertauscht in der ausgewählten Matrix die Zeilen und Spalten.


Symbolik / Polynom-Koeffizienten

Ermittelt Koeffizienten eines Ausdrucks, falls dieser in einem gewählten Teilausdruck zu einem Polynom umgewandelt wurde.


Symbolik / Transformation / Fourier

Berechnet die Fourier-Transformation für einen Ausdruck in Bezug auf die im Ausdruck markierte Variable.


Symbolik / Transformation / Fourier invers

Berechnet die reziproke Fourier-Transformation für einen Ausdruck in Bezug auf die im Ausdruck markierte Variable.


Symbolik / Transformation / Laplace invers

Berechnet die reziproke Laplace-Transformation eines Ausdrucks in Bezug auf die im Ausdruck markierte Variable.


Symbolik / Transformation / Z invers

Berechnet die reziproke Z-Transformation eines Ausdrucks in Bezug auf die im Ausdruck markierte Variable.


Symbolik / Transformation / Laplace

Berechnet die Laplace-Transformation eines Ausdrucks in Bezug auf die im Ausdruck markierte Variable.


Symbolik / Transformation / Z

Berechnet die Z-Transformation eines Ausdrucks in Bezug auf die im Ausdruck markierte Variable.


Symbolik / Variable / Partialbruchzerlegung

Generiert eine Partialbruchzerlegung für einen Ausdruck. Wird eine solche Zerlegung gefunden, so sind die Nenner in der ausgewählten Variable linear oder Zweierpotenzen.


Symbolik / Variable / Differenzieren

Differenziert den gesamten Ausdruck in Bezug auf die ausgewählte Variable. Alle anderen Variablen werden als Konstanten behandelt.


Symbolik / Variable / Reihenentwicklung

Leitet eine Potenzreihe für einen Ausdruck in Bezug auf eine Variable ab, die Sie im Ausdruck markieren. In einem Dialogfeld können Sie die Reihenfolge der Reihe bestimmen.


Symbolik / Variable / Integrieren

Integriert den gesamten Ausdruck in Bezug auf die ausgewählte Variable.


Symbolik / Variable / Auflösen

Ermittelt den Wert der ausgewählten Variable, durch den der Ausdruck, der die Variable enthält, insgesamt Null ergibt.

Wenn Sie eine Variable in einer Gleichung oder Ungleichung auswählen, löst dieser Befehl die Gleichung bzw. Ungleichung nach der gewählten Variable auf.


Symbolik / Variable / Ersetzen

Ersetzt die ausgewählte Variable überall durch den Inhalt der Zwischenablage.

Dieser Befehl wird folgendermaßen gehandhabt:

  1. Schneiden Sie den Ausdruck, der anstelle der Variable erscheinen soll, aus bzw. kopieren Sie ihn.

  2. Klicken Sie auf die Variable, die ersetzt werden soll, und wählen Sie diesen Menübefehl.


Menü "Symbolik"

Auswerten / Symbolisch

Auswerten / Gleitkomma...

Auswerten / Komplex

Vereinfachen

Entwickeln

Faktorisieren

Zusammenfassen

Polynom-Koeffizienten

Variable / Auflösen

Variable / Ersetzen

Variable / Differenzieren

Variable / Integrieren

Variable/ Reihenentwicklung...

Variable / Partialbruchzerlegung

Matrix / Transponieren

Matrix / Invertieren

Matrix / Determinante

Transformation / Fourier

Transformation / Fourier invers

Transformation / Laplace

Transformation / Laplace invers

Transformation / Z

Transformation - Z invers

Auswertungsformat...


Syntaxfehler

Für gewöhnlich die Folge einer symbolischen Operation, die auf einen ungeeigneten oder falsch geschriebenen Ausdruck angewendet wurde. Diese Fehlermeldung erscheint auch bei der symbolischen Auswertung von Ausdrücken, die Einheiten enthalten.


Differenzengleichungssysteme

Das folgende Beispiel zeigt, wie mehrere gekoppelte Differenzengleichungen erstellt werden:


Systeme von gewöhnlichen Differentialgleichungen

rkfest(y, x1, x2, npunkte, D)

Gibt eine Matrix zurück, in der die erste Spalte die Punkte enthält, an denen die Lösung ausgewertet wird, und die anderen Spalten die entsprechenden Werte der Lösung sowie die ersten n-1 Ableitungen enthalten. Ein Runge-Kuttasche Verfahren vierter Ordnung wird verwendet.

Argumente:

  • y muss entweder ein Vektor aus n Anfangswerten oder ein einzelner Anfangswert sein.

  • x1, x2 sind Endpunkte des Intervalls, an dem die Lösung für Differentialgleichungen ausgewertet wird. Anfangswerte in y sind die Werte bei x1.

  • npunkte ist die Anzahl der Punkte hinter dem Anfangspunkt, an denen die Lösung angenähert werden soll. Hiermit wird die Anzahl der Zeilen (1 + npunkte) in der Matrix bestimmt, die von rkfest zurückgegeben wird.

  • D ist eine vektorwertige Funktion mit n Elementen, die die ersten Ableitungen der unbekannten Funktionen enthält.

Hinweise:

  • Mit der Funktion rkfest können Sie sowohl eine einzelne Differentialgleichung als auch ein System von Differentialgleichungen lösen.


Tabulatortaste

In leeren Bereichen...

Verschiebt das Fadenkreuz nach rechts zum nächsten Tabulatorsymbol.

In Rechenbereichen...

Springt zum nächsten Platzhalter. Ist kein weiterer Platzhalter vorhanden, springen die Bearbeitungslinien aus dem Ausdruck heraus und erscheinen als Fadenkreuz im rechts davon befindlichen leeren Bereich.

In Textbereichen...

Verschiebt die Bearbeitungslinien nach rechts zum nächsten Tabulatorsymbol. Jeglicher Text, der sich rechts von den Bearbeitungslinien befindet, wird dementsprechend verschoben. Wenn sich die Bearbeitungslinien am Ende des Textbereichs befinden, wird der Bereich bis zum nächsten Tabulatorsymbol erweitert.


Setzen von Tabulatoren

Um das Dialogfeld Absatzformat zum Setzen der Tabulatoren zu verwenden, gehen Sie wie folgt vor:

  1. Markieren Sie Text innerhalb der Absätze.

  2. Wählen Sie Absatz im Menü Format.

  3. Klicken Sie auf die Schaltfläche "Tabulatoren", um das Dialogfeld "Tabulatoren" zu öffnen.

  4. Geben Sie im Textfeld "Tabulator-Position" Zahlen ein.

  5. Klicken Sie für jeden Tabulator auf die Schaltfläche "Festlegen". Die Zahl erscheint jetzt in dem Feld unter dem Textfeld "Tabulator-Position".

  6. Um einen Tabulator zu entfernen, markieren Sie ihn im Dialogfeld "Tabulatoren", und klicken Sie auf "Löschen".


Taylorsche oder Laurentsche Reihen

  • Taylorsche Reihen (Reihen in nichtnegativen Potenzen der Variable) werden auf Funktionen, die bei 0 einen Pol unendlicher Ordnung haben, angewendet.

  • Laurentsche Reihen werden auf Funktionen angewendet, die bei 0 einen Pol endlicher Ordnung haben.


Vorlage

Datei, auf deren Grundlage ein Mathcad-Arbeitsblatt erstellt werden kann. Eine Vorlage enthält benutzerdefinierte Angaben zum Layout und zur Formatierung des Arbeitsblatts. Die standardmäßige Dateierweiterung für Vorlagen ist “*.mct” und Sie können neue Vorlagen mit dem Befehl Speichern unter im Menü Datei erstellen.

Beachten Sie, dass sich Mathcad-Arbeitsblattvorlagen von Mathcad-HTML-Vorlagen unterscheiden.


Vorlagendefinitionen

Eine Vorlage legt Folgendes fest:

  • Standard-Texteigenschaften

  • Definitionen für alle Formatvorlagen

  • Definitionen für alle Textformatvorlagen

  • Kopf- und Fußzeilen

  • Randbereiche für das Drucken

  • Numerische Ergebnisformate

  • Werte für die vordefinierten Mathcad-Variablen

  • Namen der Grundeinheiten in Mathcad

  • Standardeinheitensystem

  • Standardberechnungsmodus


Abbruchkriterien

Die Levenberg-Marquardt-Methode wird beendet, wenn eines der folgenden Abbruchkriterien erfüllt ist:

  • Wenn es nicht mehr möglich ist, die Norm des Fehlers weiter signifikant zu reduzieren. In diesem Zusammenhang bedeutet "signifikant" um mehr als den größeren Wert von TOL und TOL*|err_vector|. Durch dieses Kriterium wird der Integrallöser angehalten, wenn keine weitere Fehlerreduzierung mehr möglich ist.

  • Wenn sich s relativ stark an Null annähert. Bei dieser Methode steht "relativ stark" für eine Norm, die kleiner als der größere Wert von TOL und TOL*|v| ist. Durch dieses Kriterium wird der Integrallöser angehalten, wenn für die Fortschreibung der Schätzwerte keine Richtung mehr vorgegeben ist.

Ist eine dieser Abbruchbedingungen erreicht, prüft Mathcad den Betrag des Fehlervektors und gibt eine Antwort aus:

  • Ist der Betrag des Fehlervektors kleiner oder gleich TOL, gibt Mathcad die Variablenwerte als Lösung aus.

  • Endet das Gleichungssystem mit der Funktion suchen und ist der Betrag des Fehlervektors größer als TOL, markiert Mathcad die Suchfunktion mit einem Fehler.

  • Endet das Gleichungssystem mit der Funktion minfehl und ist der Betrag des Fehlervektors größer als TOL, gibt Mathcad die Lösung aus, obwohl der Fehlervektor sich nicht an Null angenähert hat. Mathcad definiert als Wert für die Variable FEHL den Betrag des Fehlervektors.

Mathcad begrenzt die Zahl der Berechnungen, die Mathcad für eine Lösung des Gleichungssystems durchführt. Erreicht Mathcad die festgelegte Begrenzung, ohne dass eine Antwort ausgegeben wird, wird die Funktion suchen oder minfehl als Fehler markiert.

Mathcad gibt die Fehlermeldung aus, dass keine Lösung gefunden wurde, wenn die Differenz zwischen aufeinander folgenden Annäherungen an die Lösung größer ist als TOL und eine der folgenden Bedingungen eintritt:

  • Der Integrallöser kann den Fehler nicht weiter reduzieren. Versuchen Sie, für TOL einen größeren Wert festzulegen. Überprüfen Sie, ob Sie für die Suche einer komplexen Lösung die erforderlichen komplexen Schätzwerte angegeben haben.

  • Der Integrallöser befindet sich an einem Punkt, an dem es keine vorzuziehende Richtung gibt. Probieren Sie verschiedene Schätzwerte aus, oder fügen Sie eine Ungleichung hinzu.

  • Der Integrallöser erreicht die Grenze seiner Rechengenauigkeit. Aufgrund von Rundungsfehlern ist es unwahrscheinlich, dass weitere Berechnungen zu genaueren Lösungen führen. Dieser Fall tritt häufig ein, wenn Sie für TOL einen Wert unter 10^15 einstellen.


Textfeld

Dies ist das Rechteck, das um einen Textbereich gelegt wird, wenn sich die Einfügemarke im Bereich befindet. Wenn Sie auf eine Stelle außerhalb des Textbereichs klicken, wird das Textfeld wieder ausgeblendet.


Texteinfügemarke

Wo kann sie erscheinen?

Wie kann sie angezeigt werden?

Wie wird sie verschoben?

Was ist ihre Funktion?


Textbereich

Rechteckiger Bereich, der für die Eingabe von Text reserviert ist. Textbereiche können beliebig breit sein und sich an jeder beliebigen Stelle des Dokuments befinden.


Eigenschaften von Textbereichen

Breite eines Textbereichs festlegen

Verhalten der Bereiche rechts bzw. unterhalb von Textbereichen bei Eingabe von Text festlegen


Textformatvolagen (Definition)

Textformatvorlagen

Eine Textformatvorlage ist ein Attribut, mit dem Text Schriftarten und Absatzeigenschaften zugewiesen werden können. Standardmäßig wird für Text das standardmäßige "normale" Textformat mit speziellen Text- und Absatzeigenschaften verwendet.


Dialogfeld "Textformatvorlagen"


Die Werte in diesem Vektor müssen in aufsteigender Reihenfolge sein.

Die Werte in diesem Vektor müssen aufsteigend sein.

Die Werte in diesem Vektor müssen aufsteigend angeordnet sein. Geben Sie den Namen des Vektors ein, und drücken Sie "=", um zu überprüfen, welche Werte im Vektor enthalten sind.

Das erste Argument von lspline, pspline, kspline, linterp und hist sowie das zweite Argument von interp muss ein Vektor sein, dessen Elemente durchgehend aufsteigend geordnet sind.


Der Fehlervektor

Der MINPACK-Algorithmus versucht, die Nullwerte eines Funktionsvektors zu finden oder im schlimmsten Fall die Zahl der Werte des Vektors, der senkrecht zu den Werten bestimmter Variablen stehen (also die Nullwerte), so gering wie möglich zu halten. Der von Mathcad eingesetzte Funktionsvektor ist ein Fehlervektor, dessen Elemente für die Fehler in den Nebenbedingungen stehen. Diese Fehler werden wie folgt definiert:
  • Für Gleichheitsnebenbedingungen (Nebenbedingungen mit “=”):

  • Für Ungleichheitsnebenbedingungen:

falls Ungleichheit gegeben ist, andernfalls:

Unter Mathcad wird der Levenberg-Marquardt-Algorithmus als Algorithmus über reelle Variablen behandelt. Wenn Sie nach einer komplexen Variable auflösen, behandelt Mathcad den Real- und den Imaginärteil im Algorithmus jeweils als getrennte Variablen. Wenn Sie eine Gleichheitsbedingung auflösen, erstellt Mathcad zwei reelle Nebenbedingungen für den Algorithmus, also einen für den Realteil und einen für den Imaginärteil.


Dieser Ausdruck ist unvollständig. Sie müssen einen Operator bereitstellen.

Sie haben den Operatorplatzhalter (ein leeres Feld) nicht ausgefüllt, der zwischen zwei Operanden vorhanden sein muss. Das passiert, wenn Sie einen Operator gelöscht haben.

Sie müssen in den Operatorplatzhalter einen Operator eingeben. Gehen Sie hierzu folgendermaßen vor:

  1. Setzen Sie die Einfügelinie links neben den Operatorplatzhalter.

  2. Geben Sie einen Operator über dessen Tastaturbefehl ein, oder klicken Sie auf eine der Operator-Schaltflächen in einer Symbolleiste.

Hinweis: Wenn Sie einen Operator und dessen Operanden löschen möchten, löschen Sie erst den Operanden vollständig und dann erst den Operator. Auf diese Weise wird der Operatorplatzhalter nicht angezeigt.


Ausdruck links kann nicht definiert werden

Der Ausdruck links von dem Gleichheitszeichen kann nicht definiert werden.

Die linke Seite dieser Definition enthält etwas anderes als einen hier gültigen Ausdruck. Auf der linken Seite einer Definition können die folgenden Elemente eingefügt werden:

  • Variablenname.

  • Variablennamen mit tiefgestelltem Index

  • Variablennamen mit hochgestelltem Index

  • Explizite Vektoren oder Matrizen, die mit dem Befehl Martix im Menü Einfügen erstellt wurden. Der Vektor bzw. die Matrix darf nur Variablennamen oder indizierte Variablennamen enthalten.

  • Funktionsname mit Argumenten: f(x,y).

Jeder andere Ausdruck ist unzulässig. Wenn Sie ein Ergebnis berechnen möchten, anstatt eine Variable zu definieren, müssen Sie anstelle eines Doppelpunkts das Gleichheitszeichen "=" eingeben.


Der erste Trapez-Annäherungswert:

Der erste Trapez-Annäherungswert lautet:

Beim zweiten Trapez-Annäherungswert wird die Zahl der Teilintervalle verdoppelt, wobei zwei Teilintervalle jeweils mit der Weite b-a/2 verwendet werden. Der Algorithmus beginnt mit der Berechnung der ersten drei Annäherungen und der Aufteilung des Intervalls jeweils in ein, zwei und vier Teilintervalle.


Diese Funktion hat zu viele Argumente.

Der angezeigte Ausdruck enthält eine Funktion mit einer größeren Anzahl von Argumenten als benötigt werden.

Bei vordefinierten Funktionen klicken Sie auf den Funktionsnamen, und drücken Sie F1, um die richtige Anzahl und Art der Argumente einzusehen. Bei von Ihnen selbst definierten Funktionen müssen Sie die Definition überprüfen.


Die Matrixdimensionen sind inkompatibel.

Die Anzahl Zeilen oder Spalten stimmt nicht überein.

Mit dieser Meldung werden Funktionen oder Operatoren gekennzeichnet, für die zwei Matrizen mit einer bestimmten Anzahl von Zeilen und Spalten erforderlich sind. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, Umschalt + F1, und klicken Sie auf den Funktionsnamen, um festzulegen, welche Größe die Matrizen haben müssen.


Die Anzahl der Bits pro Pixel muss 8 oder 16 sein.

Sie haben ein ungültiges Argument für Typ eingegeben, als Sie eine binäre Datendatei geschrieben oder gelesen haben. Überprüfen Sie, ob das von Ihnen eingegebene Argument zulässig ist.


Die Anzahl Zeilen und/oder Spalten stehen in Konflikt

Die Anzahl Zeilen und/oder Spalten in den Feldern ist nicht identisch.

Sie haben versucht, eine Vektor- oder Matrixoperation an Feldern ungeeigneter Größe auszuführen. So ist es z. B. unzulässig, zwei ungleich große Matrizen zu addieren. Matrixmultiplikation erfordert, dass die Anzahl der Spalten in der ersten Matrix mit der Anzahl der Zeilen in der zweiten Matrix übereinstimmt.


Die Romberg-Annäherung

Der Variablenname "Estimate" (mit tiefgestellter laufender Nummer) repräsentiert die internen Annäherungen an die Antwort. Nur der letzte Annäherungswert, also der Wert, der den Toleranztest von Mathcad besteht, steht dem Benutzer zur Verfügung.


Standardformat für Differentialgleichungen

Der wichtigste Schritt bei der Vorbereitung einer Differentialgleichung für die Lösung durch Mathcad besteht darin, sie in die Standardform zu bringen, die für Mathcad-Lösungsalgorithmen erforderlich ist. Dabei werden aus einer Differentialgleichung alle Ableitungen höherer Ordnung entfernt, und es bleiben nur erste Ableitungen übrig. Ihre Differentialgleichung ist dann ein System von Differentialgleichungen erster Ordnung.

Zum Beispiel enthält die Differentialgleichung:

eine zweite Ableitung, die als erste Ableitung geschrieben werden kann:

Definieren Sie die beiden Funktionen als:

Nun enthält die Differentialgleichung zwei Funktionen und ist im Wesentlichen ein System mit zwei Differentialgleichungen:

Der nächste Schritt ist die Erfassung dieser Daten in einer einzelnen vektorwertigen Funktion D für die Verwendung mit den Lösungsalgorithmen für Differentialgleichungen in Mathcad:


In den Einheitenplatzhalter können nur reelle...

In den Einheitenplatzhalter können nur reelle Skalare ungleich null eingegeben werden.

Sie haben einen ungültigen Ausdruck in den Platzhalter am Ende einer Berechnungsgleichung eingegeben. Dieser Platzhalter erfordert reelle Werte, Werte ungleich null oder Skalarwerte.


Die Einheiten dieses Ausdrucks stimmen nicht überein.

Diese Fehlermeldung hat zwei wahrscheinliche Ursachen:

  • Sie addieren bzw. subtrahieren zwei Terme mit unterschiedlichen Einheiten.

  • Sie haben eine Matrix erstellt, deren Einheiten nicht alle über dieselben Einheiten verfügen.

  • Sie versuchen, ein Gleichungssystem nach unbekannten Variablen mit unterschiedlichen Einheiten aufzulösen. Hier ein Beispiel mit der korrekten Vorgehensweise:


Die Werte in der Matrix

Die Werte in der Matrix sind die Werte von z. Die Zeilen- und Spaltenindizes sind die entsprechenden Werte von x und y. Die definierte Matrix muss mindestens zwei Zeilen oder zwei Spalten aufweisen.


Diese Variable bzw. Funktion ist oben nicht definiert.

Diese Variable bzw. Funktion ist oben nicht definiert. (Name rot markiert)

Diese Variable oder Funktion ist nicht definiert. Um sie zu definieren, geben Sie den Variablen- bzw. Funktionsnamen und dahinter einen Doppelpunkt (:) sowie einen Ausdruck oder eine Zahl zu seiner Definition ein. Definieren Sie den Variablen- oder Funktionsnamen unbedingt oberhalb der Anweisungen, in denen Sie ihn verwenden möchten.

Die Meldung erscheint auch bei falscher Verwendung einer Variable in einer globalen Definition. Wenn Sie eine Variable auf der rechten Seite einer globalen Definition angeben, muss die Variable über der Definition, in der sie verwendet wird, global definiert worden sein. Wenn Sie eine lokal definierte Variable oder eine Variable verwenden, deren globale Definition unter der Position der Anwendung erfolgt, markiert Mathcad die Variable als nicht definiert.

HINWEIS: Die Fehlermeldung "Nicht definiert" deutet häufig darauf hin, dass eine andere Gleichung an früherer Stelle im Arbeitsblatt fehlerhaft ist. In dem Fall werden alle Ausdrücke, die den fehlerhaften Ausdruck enthalten, rot angezeigt.


Dieser Ausdruck enthält ein überflüssiges Komma.

Kommas können benutzt werden, um Folgendes zu trennen:

  • Die Argumente einer Funktion.

  • Die ersten beiden Elemente eines Bereichs in der Definition einer Bereichsvariable.

  • Ausdrücke in einem Diagramm.

  • Elemente in einer Datentabelle.

  • Tiefgestellte Indizes in einer Matrix.

Jede andere Verwendung von Kommas löst diese Fehlermeldung aus. Zum Beispiel dürfen Zahlen weder durch Punkte noch durch Kommas unterteilt werden (wie im englischen Sprachgebrauch üblich). Geben Sie also statt 4.000 oder 4,000 für die Zahl Viertausend einfach 4000 ein.


Es müssen mehr als drei Datenpunkte vorhanden sein.

Für diese Funktion ist ein Vektor mit mindestens 4 Elementen erforderlich.


Dieses Feld muss mehr als eine Zeile bzw. Spalte haben.

Sie haben eine Operation ausgeführt, die eine Matrix erfordert. So muss z. B. beim Erstellen von Flächen- oder Umrissdiagrammen das dargestellte Feld eine Matrix sein, d. h. ein Feld mit mindestens zwei Zeilen oder Spalten. Bestimmte vordefinierte Funktionen erfordern ebenfalls Matrixargumente.


Dieser Ausdruck enthält nur eine "(", aber keine ")".

Dieser Ausdruck enthält nicht dieselbe Anzahl von ( und ).


Dieser Ausdruck ist unvollständig. Sie müssen Platzhalter eingeben.

Sie haben die markierten Platzhalter nicht ausgefüllt. Sie müssen Zahlen oder Ausdrücke in diese Platzhalter eingeben.


Dieser Ausdruck ist zu kompliziert.

Dieser Ausdruck ist zu kompliziert. Versuchen Sie, ihn in kleineren Einheiten zu definieren.

Dieser Ausdruck ist zu kompliziert für die Auswertung. Lösen Sie die Gleichung in zwei oder mehr kleinere Ausdrücke auf.


Diese Funktion ist an mindestens einem der von Ihnen angegebenen Punkte nicht definiert.

Sie haben versucht, einen Operator oder eine Funktion für einen ungeeigneten Wert auszuwerten. Zum Beispiel wird dieser Fehler durch ln(0) ausgegeben. Dasselbe gilt für -3!, da Fakultät für negative Zahlen nicht definiert ist.


Diese Funktion benötigt mehr Argumente.

Dieser Ausdruck enthält eine Funktion mit weniger als der erforderlichen Anzahl von Argumenten.

Bei vordefinierten Funktionen klicken Sie auf den Funktionsnamen, und drücken Sie F1, um die richtige Anzahl und Art der Argumente einzusehen. Bei von Ihnen selbst definierten Funktionen müssen Sie die Definition überprüfen.


Dies ist ungültig. Wenn Sie in einem Mathcad-Programm Bedingungsanweisungen verwenden...

Dies ist ungültig. Wenn Sie in einem Mathcad-Programm Bedingungsanweisungen verwenden, müssen diese stets nachvollziehbar sein.

Das Programm unten zum Beispiel ist nur gültig, wenn x den Wert 4 oder 5 annimmt. Nimmt x einen anderen Wert an, ist im Programm der weitere Ablauf nicht mehr definiert.

Diesen Fehler können Sie durch eine zusätzliche "Otherwise"-Anweisung beheben:


Innerhalb eines Lösungsblocks nicht erlaubt.

Innerhalb eines Lösungsblocks nicht erlaubt. Zum Beispiel sind innerhalb eines Lösungsblocks keine Definitionen erlaubt.

Möglicherweise wird eine Definitionsanweisung unter einem "Vorgabe" angezeigt. Sie haben zwei "Vorgaben" hintereinander ohne eine Funktion "Suchen" oder "Minfehl" dazwischen festgelegt. Ein Lösungsblock kann nicht ein anderes beinhalten. Sie haben auch die Möglichkeit, eine Funktion als Lösungsblock zu definieren und in einem anderen Lösungsblock zu verwenden. In vielen Fällen bleibt die Wirkung gleich.


Diese Liste enthält zu viele Einträge.

Sie haben zu viele durch Kommas getrennte Elemente in eine Liste eingegeben. Dies passiert normalerweise, wenn Sie versuchen, zu viele Ausdrücke auf einer Diagrammachse anzuordnen.


Diese Matrix muss quadratisch sein

Diese Matrix muss quadratisch sein. Sie sollte die gleiche Anzahl Zeilen wie Spalten haben.

Für einige der in Mathcad vordefinierten Funktionen sind Quadratmatrizen erforderlich. Weitere Informationen erhalten Sie, wenn Sie auf den Funktionsnamen klicken und dann F1 drücken.


Dies muss eine ganze Zahl sein.

Dies muss eine ganze Zahl sein. Der verwendete Ausdruck enthält eventuell einen Bruch.

Dieser Ausdruck enthält einen nicht ganzzahligen Ausdruck, obwohl eine ganze Zahl benötigt wird. Der Ausdruck beinhaltet u. U. einen Bruch.

Mögliche Fehlerursachen sind:

  • Hoch- und tiefgestellte Indizes

  • Argumente bestimmter Funktionen, wie z. B. der Funktion einheit oder der Funktion submatrix.

Zu beachten ist, dass Sie zwar Bereichsvariablen mit Bruchwerten definieren, diese aber nicht als tief- oder hochgestellte Indizes verwenden können.


Dies muss der Name einer Funktion bzw. Variable sein.

Sie haben eine Zahl oder eine andere Kombination von Symbolen verwendet, wo ein Name erforderlich gewesen wäre, zum Beispiel als zweites Argument der wurzel-Funktion.


Dies muss der Name einer Zuordnungsfunktion sein

Dieses Argument von ErstellenGitter oder ErstellenRaum muss der Name einer Zuordnungsfunktion sein, die das Koordinatensystem bestimmt. Die folgenden Funktionen zum Beispiel sind geeignete Funktionen für Zuordnungsfunktionen für ErstellenRaum:

Das Argument von ErstellenRaum ist name fabb.


Diese Operation kann nur für eine Funktion ausgeführt werden.

Dieses Argument muss eine Funktion sein. Wenn Sie weitere Informationen beim Arbeiten mit einer vordefinierten Funktion benötigen, klicken Sie auf den Funktionsnamen, und drücken Sie F1.


Diese Operation kann nur für eine Zahl oder ein Feld ausgeführt werden.

Für die verwendete Funktion bzw. den verwendeten Operator ist eine einzelne Konstante, eine Matrix oder ein Vektor erforderlich.


Diese Operation kann nur für eine Zeichenfolge ausgeführt werden.

Für die von Ihnen verwendete Funktion bzw. den Operator ist ein Zeichenfolgenargument erforderlich. Zum Beispiel wird für Zeichenfolgefunktionen normalerweise mindestens ein Zeichenfolgenargument benötigt.


Diese Operation kann nur für ein Feld ausgeführt werden

Diese Operation kann nur für ein Feld ausgeführt werden. Sie kann nicht auf eine Nummer angewendet werden.

Sie haben eine Operation, die ein Feld erfordert, auf einen Skalar angewendet. Diese Fehlermeldung wird z. B. angezeigt, wenn Sie eine hochgestellte Variable als Skalar definieren. Da eine hochgestellte Variable eine Spalte einer Matrix darstellt, müssen Sie sie als Vektor definieren.

Bei Flächen- oder Umrissdiagrammen muss das dargestellte Feld mindestens zwei Zeilen oder zwei Spalten haben.


Dieser tiefgestellte Index ist zu groß.

Sie haben versucht, einen tief- oder hochgestellten Index zu verwenden, dessen Größe über der Obergrenze von 8 Millionen liegt.


Dieses Gleichungssystem weist mehr...

Dieses Gleichungssystem weist mehr Unbekannte auf, als es Gleichungen gibt.

Diese Fehlermeldung erscheint bei Lösungsblöcken, bei denen die Anzahl von Nebenbedingungen kleiner ist als die Zahl der zu lösenden Variablen. Fügen Sie "Dummy"-Nebenbedingungen hinzu, oder verringern Sie die Anzahl der Variablen, nach denen aufgelöst werden soll.


Dieser Wert muss eine Matrix sein.

Sie versuchen, eine Matrixoperation an einer Nicht-Matrix auszuführen. Eine Matrix ist ein Feld, das aus mehr als einer Spalte besteht.


Dieser Wert muss ein Vektor sein.

Dieser Wert muss ein Vektor sein. Er kann weder eine Matrix noch ein Skalar sein.

Diese Fehlermeldung betrifft eine Matrix oder einen Skalar in einer Operation, die einen Vektor (ein Feld mit einer Spalte) erfordert. Ein Beispiel ist der Operator "Vektorsumme".


Dieser Wert muss kleiner oder gleich 10000 sein.

Wenn Sie weitere Informationen beim Arbeiten mit einer vordefinierten Funktion benötigen, klicken Sie auf den Funktionsnamen und drücken Sie F1.


Dieser Wert muss reell sein.

Dieser Wert muss reell sein. Der Imaginärteil muss null sein.

Dieser Ausdruck enthält einen imaginär- oder komplexwertigen Ausdruck, der an dieser Stelle nicht zulässig ist.

Beispiele dafür sind Indizes, Lösungsalgorithmen für Differentialgleichungen, mod und winkel.


Diese Variable muss eine Bereichsvariable sein.

Dieser Ausdruck erfordert eine Bereichsvariable.

Wenn der Ausdruck eine Summation oder ein iteriertes Produkt enthält, stellen Sie sicher, dass der Index wirklich eine Bereichsvariable ist. Der Index steht unmittelbar unter dem Sigma bzw. Pi. Er müsste in einer vorherigen Anweisung definiert worden sein.


Dieser Vektor hat die falsche Anzahl von Elementen.

Diese Fehlermeldung betrifft eine Fourier-Transformation, deren Argument die falsche Anzahl von Elementen enthält.

  • fft benötigt einen Vektor mit 2^n Elementen.

  • ifft benötigt einen Argumentvektor mit 2^n+1 Elementen, wobei n eine ganze Zahl größer als 0 ist.

Verwenden Sie cfft und icfft für Felder und Vektoren beliebiger Größe.


Dieser Vektor muss weniger als fünf Spalten haben.

Das erste Argument der Funktion loess sollte eine reelle Matrix mit maximal 4 Spalten sein, in denen sich jeweils die Daten befinden, die einem bestimmten Faktor entsprechen.


Dieser Vektor sollte mehr Elemente haben.

Diese Fehlermeldung weist auf eine Fourier-Transformation, kubische Spline- oder lineare Interpolationsfunktion hin, die auf einen Vektor mit zu wenigen Elementen angewendet wurde.

Splines und lineare Interpolationen benötigen Vektoren mit mindestens zwei Elementen. Fourier-Transformationen und deren Inverse benötigen mindestens vier Elemente.


Kacheln von Arbeitsblattfenstern

Wählen Sie entweder Untereinander oder Nebeneinander aus dem Menü Fenster.


Berechnen eines Ausdrucks

Klicken Sie in den Ausdruck, und drücken Sie =.

Sie können Ausdrücke auch symbolisch auswerten, indem Sie [Strg]. (Punkt) für den symbolischen Auswerungsoperator drücken.


Es kann keine Lösung gefunden werden. Zu viele Iterationen aufgetreten..

Die Funktion hat bei der Suche nach einer Lösung die höchstmögliche Anzahl von Wiederholungen durchgeführt. Wenn diese Meldung bei der Verwendung der Funktion nullstellen angezeigt wird, kann der Grad des Polynoms hoch sein. Versuchen Sie, stattdessen symbolische Auflösungen für die Wurzeln vorzunehmen.


Dialogfeld "Symbolleiste anpassen"

Im Dialogfeld "Symbolleiste anpassen" finden Sie die folgenden Optionen und Schaltflächen:

Verfügbare Schaltflächen

Zeigt die Schaltflächen an, die der Symbolleiste hinzugefügt werden können.

Schaltflächen der Symbolleiste

Zeigt die Schaltflächen in der Symbolleiste im aktiven Fenster in der Reihenfolge ihres Erscheinens (von links nach rechts) an.

Hinzufügen

Fügt die in der Liste "Verfügbare Schaltflächen" markierte Schaltfläche in die Liste "Schaltflächen der Symbolleiste" ein. Sie können die Schaltfläche stattdessen auch direkt aus der Liste "Schaltflächen der Symbolleiste" in die Liste "Verfügbare Schaltflächen" ziehen.

Entfernen

Verschiebt die in der Liste "Schaltflächen der Symbolleiste" markierte Schaltfläche in die Liste "Verfügbare Schaltflächen". Sie können die Schaltfläche stattdessen auch direkt aus der Liste "Schaltflächen der Symbolleiste" in die Liste "Verfügbare Schaltflächen" ziehen.

Nach oben

Verschiebt die markierte Schaltfläche eine Zeile nach oben. Auf der Symbolleiste rückt die Schaltfläche eine Position nach links. Sie können die Schaltfläche stattdessen auch mit der Maus nach unten ziehen.

Nach unten

Verschiebt die markierte Schaltfläche eine Zeile nach unten. Auf der Symbolleiste rückt die Schaltfläche eine Position nach rechts. Sie können die Schaltfläche stattdessen auch mit der Maus nach unten ziehen.

Zurücksetzen

Stellt den ursprünglichen Zustand des Dialogfelds wieder her.


Fettdruck

Klicken Sie auf diese Schaltfläche, um allen Text in dieser Art Bereich auf Fettdruck umzustellen.

Falls Sie bereits Text markiert haben und auf diese Schaltfläche klicken, erscheint der Text fettgedruckt.


Zentrierter Text

Klicken Sie auf diese Schaltfläche, um alle Zeilen eines Textbereichs zentriert auszurichten.


Liste der Schriftarten

Diese Auswahlliste zeigt den Schriftartnamen für den Text- oder Rechenbereich, in dem der Cursor gerade steht.

Um eine andere Schriftart anzugeben, blättern Sie durch die Liste der verfügbaren Schriftartfamilien. Wählen Sie die gewünschten Schriftart aus, und lassen Sie die Maustaste los.


Symbolleiste "Formatierung"

Auf der Symbolleiste "Formatierung" finden Sie Listenfelder und Schaltflächen, mit deren Hilfe Sie die Schriftmerkmale in Gleichungen und Text festlegen können. Welche Funktionen die einzelnen Schaltflächen haben, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • eine QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche erscheint, und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.

Informationen dazu, wie die einzelnen Schaltflächen zu verwenden sind, erhalten Sie auch, wenn Sie auf einen der folgenden Schaltflächennamen klicken.

Schriftschnitt

Schriftart

Schriftgröße

Fettgedruckter Text

Kursiv geschriebener Text

Unterstrichener Text

Linksbündiger Text

Rechtsbündiger Text

Zentrierter Text

Aufzählungszeichen

Numerierungen

Hoch- und tiefgestellte Indizes

Um die Formatierungssymbolleiste anzupassen, klicken Sie dazu mit der rechten Maustaste auf die Symbolleiste, und wählen Sie den Befehl Anpassen aus dem Kontextmenü.


Kursivschrift

Klicken Sie auf diese Schaltfläche, um allen Text in dieser Bereichsart auf Kursivschrift umzustellen.

Falls Sie bereits Text markiert haben und auf diese Schaltfläche klicken, erscheint der Text kursiv.


Links ausgerichteter Text

Klicken Sie auf diese Schaltfläche, um alle Zeilen eines Textbereichs linksbündig auszurichten.


Rechts ausgerichteter Text

Klicken Sie auf diese Schaltfläche, um alle Zeilen eines Textbereichs rechtsbündig auszurichten.


Standard-Symbolleiste

Über die auf der Standard-Symbolleiste befindlichen Schaltflächen haben Sie schnellen Zugriff auf viele Menübefehle. Welche Funktionen die einzelnen Schaltflächen haben, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • eine QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche erscheint, und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.

Klicken Sie zum Anpassen der Standard-Symbolleiste mit der rechten Maustaste und wählen Sie Anpassen aus dem Dialogfeld. Die aktuelle Gruppe zusätzlicher Schaltflächen wird unten angezeigt.


Formatvorlage

Wenn sich der Cursor in einem Rechenbereich befindet, also zwischen Zahlen oder Variablen, wird in diesem Fenster die Gleichungsformatvorlage für diesen Rechenbereich angezeigt. Bei der Rechenformatvorlage handelt es sich um eine mathematische Variable, eine mathematische Konstante oder eine von Ihnen definierte Rechenformatvorlage.

Wenn sich der Cursor in einem Textbereich befindet, wird in diesem Fenster die Textformatvorlage angezeigt, die mit diesem Textbereich verknüpft ist. Im Fenster Schriftgrad werden die technischen Angaben zum betreffenden Textbereich wiedergegeben.


Hochgestellter und tiefgestellter Index

Klicken Sie auf diese Schaltflächen, um Text- oder Rechenbereichen hoch- oder tiefgestellte Indizes hinzuzufügen. Beachten Sie, dass der tiefgestellte Index ein tiefgestellter Literalindex ist und nicht ein tiefgestellter Feldoperator.

Falls Sie bereits Text markiert haben und auf diese Schaltflächen klicken, wird der Text hoch- oder tiefgestellt.

Hinweis: Das erneute Drücken der Schaltfläche "Hochgestellter Index" oder "Tiefgestellter Index" in einem Rechenbereich wiederholt den Vorgang. In einem Textbereich bewirkt das erneute Drücken einer der Schaltflächen, dass die folgenden Zeichen wieder normal angezeigt werden.


Schriftgrad

Diese Auswahlliste zeigt den Schriftgrad des Text- bzw. Rechenbereichs, in dem der Cursor gerade steht.

Um einen neuen Schriftgrad auszuwählen, blättern Sie durch die Liste der verfügbaren Schriftgrade. Wählen Sie den gewünschten Schriftgrad, und lassen Sie die Maustaste los.


Unterstrichener Text

Klicken Sie auf diese Schaltfläche, um allen Text in dieser Bereichsart unterstreichen zu lassen.

Falls Sie bereits Text markiert haben und auf diese Schaltfläche klicken, erscheint der Text unterstrichen.


Steuerleiste

Symbolleiste "Steuerelemente"

Die Symbolleiste Steuerelemente und das korrespondierende Untermenü Einfügen/Steuerelement vereinfachen das Einbeziehen von Windows-ähnlichen Steuerelementen in Ihren Arbeitsblättern.

Mathcad unterstützt sechs verschiedene Windows-ähnliche Steuerelemente: Kontrollkästchen, Optionsschaltfläche, Schaltfläche, Textfeld, Listenfeld und Schieberegler.

Weitere Informationen über das Verwenden der Steuerelemente in Ihren Arbeitsblättern finden Sie in der Developer's Reference (Entwickler-Referenz). Im Menü Hilfe unter QuickSheets finden Sie auch Dateien mit Beispielsteuerelementen.


Symbolleiste "Ressourcen"

Mit der Symbolleiste "Ressourcen" wird der Zugriff auf Mathcad-Lernprogramme, QuickSheets und Referenztabellen gesteuert, anhand derer Anfänger und Experten schnell Informationen finden können. Alle E-Books und Erweiterungspakete, die Sie installieren, werden ebenfalls hier angezeigt.


Extras - Auswertung aktivieren/deaktivieren

Bestimmt, ob eine Gleichung in Ihrem Arbeitsblatt ausgewertet wird oder nicht. Wenn Sie eine Definition deaktivieren, verursachen Sie einen Fehler in jedem Bereich, der davon abhängt.

Die Menüoption wird je nachdem, ob Sie eine Gleichung schon deaktiviert haben oder nicht, unterschiedlich angezeigt. Alle Gleichungen sind standardmäßig aktiviert, es sei denn, sie wurden speziell deaktiviert.


Extras - Optimieren - Optimierung anzeigen

Zeigt ein kleines Fenster an, das die optimierte Form der ausgewählten Gleichung enthält. Mathcad verwendet diese optimierte Form, wenn ein Ergebnis, das eine Gleichung einbezieht, berechnet wird.

Optimierung anzeigen ist nur dann aktiviert, wenn eine optimierte Form einer Gleichung existiert.


Extras - Fehler zurückverfolgen

Zeigt das Dialogfeld "Fehler zurückverfolgen" an, mit dem Sie Fehler finden können, die in Bereichen, die für Ihre Auswertung wichtig sind, Ihren Ursprung haben.


Menü "Extras"

Rechschreibprüfung...

Animation/Aufzeichnen...

Animation/Wiedergeben...

Arbeitsblatt schützen...

Berechnen/Jetzt berechnen

Berechnen/Arbeitsblatt berechnen

Berechnen/Automatische Berechnung

Optimieren/Gleichung optimieren

Arbeitsblattoptionen...

Einstellungen


Oberer Rand

Dabei handelt es sich um den Abstand zwischen dem oberen Rand des Papierblatts und dem oberen Rand des Druckbereichs. Wenn Ihr Arbeitsblatt mit einer Kopfzeile versehen ist, erscheint diese innerhalb des Randbereichs an dessen unterer Grenze.


Spur einer Matrix

sp(M) Gibt die Summe der Elemente entlang der Diagonale von M zurück.

Argumente:

  • M muss eine Quadratmatrix sein.


Spureinstellungen (Kreisdiagramme)

Spureinstellungen in Kreisdiagrammen

Zum Auswählen der Eigenschaften einer Spur gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf ein Diagramm, oder wählen Sie Diagramm / Kreisdiagramm im Menü Format, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte Spuren.

  3. Klicken Sie auf den Namen der Spur in der Spalte "Legendenname" der Liste in der Mitte des Dialogfelds. Die dieser Spur zugeordneten Eigenschaften erscheinen in den sechs Textfeldern unter den folgenden Spalten: Diese sind:

    Legendenname

    Symbol

    Linie

    Farbe

    Typ

    Stärke

  4. Sie können diese Eigenschaften ändern, wenn Sie durch Klicken auf den Pfeil neben dem entsprechenden Textfeld eine Dropdown-Liste mit Optionen aufrufen.

  5. Sie können die Eigenschaften für eine andere Spur ändern, indem Sie in der Liste in der Mitte des Dialogfelds auf ihren Namen klicken. Ordnen Sie dann die Eigenschaften wie oben beschrieben zu.

  6. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


Spureinstellungen (X-Y-Diagramme)

Zum Auswählen der Eigenschaften einer Spur gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf ein Diagramm, oder wählen Sie Diagramm / XY-Diagramm im Menü Format, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte Spuren.

  3. Klicken Sie auf den Namen der Spur in der Spalte "Legendenname" der Liste in der Mitte des Dialogfelds. Die dieser Spur zugeordneten Eigenschaften erscheinen in den sechs Textfeldern unter den folgenden Spalten: Diese sind:

    Legendenname

    Symbol

    Linie

    Farbe

    Typ

    Stärke

  4. Sie können diese Eigenschaften ändern, wenn Sie durch Klicken auf den Pfeil neben dem entsprechenden Textfeld eine Dropdown-Liste mit Optionen aufrufen.

  5. Sie können die Eigenschaften für eine andere Spur ändern, indem Sie in der Liste in der Mitte des Dialogfelds auf ihren Namen klicken. Ordnen Sie dann die Eigenschaften wie oben beschrieben zu.

  6. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


Registerkarte "Spuren" für Kreisdiagramme

Auf der Registerkarte "Spuren" des Dialogfelds "Gerade markiertes Kreisdiagramm wird formatiert" finden Sie die folgenden Optionen und Schaltflächen:

Legendenname

Dies ist der Name der Spur, der in der Legende erscheint.

Symbol

Hiermit können Sie festlegen, ob jeder Punkt auf der Kurve durch ein Symbol gekennzeichnet werden soll. Wenn das Diagramm eine Vielzahl von Punkten enthält, die sehr eng beieinander liegen, ist es u. U. ratsam, die Option "Kein" zu wählen.

Linie

Hiermit können Sie festlegen, wie die Linie angezeigt werden soll. Die Linie kann durchgezogen, gepunktet oder gestrichelt sein. Auch eine Strich-Punkt-Linie ist möglich. Verschiedene Linienarten sind zur Unterscheidung unmarkierter Kurven in Schwarzweißdruck nützlich.

Farbe

Hiermit legen Sie die Farbe der jeweils ausgewählten Spur fest. Zur Wahl stehen die Farben rot, blau, grün, magenta, zyan (hellblau), braun, schwarz und weiß. Bei einfarbiger Anzeige wird diese Einstellung ignoriert.

Typ

Hiermit legen Sie fest, ob die ausgewählte Spur als Kurve, als Säulendiagramm, als Fehlersäulen, als Stufenkurve oder als Zweigdiagramm dargestellt werden soll.

Stärke

Hiermit können Sie festlegen, mit welcher Dicke die Kurve dargestellt wird. Verwenden Sie 1 für dünne und 9 für dicke Kurven. Geben Sie "p" ein, um eine sehr dünne Kurve (einen Pixel breit) darzustellen. Beachten Sie jedoch, dass eine "p"-Kurve unter Umständen auf Druckern ohne entsprechende Auflösung nicht adäquat gedruckt wird. Mit dieser Option wird außerdem die Größe der Symbole festgelegt, mit denen die einzelnen Datenpunkte gekennzeichnet werden, falls zuvor unter "Symbol" eine andere Option als "Kein" ausgewählt wurde. Wenn Sie sich für spurartige Punkte entschieden haben, wird mit diesem Feld festgelegt, mit welcher Stärke die Punkte zur Kennzeichnung der einzelnen Datenpunkte gedruckt werden.

Argumente ausblenden

Aktivieren Sie dieses Feld, wenn Sie die mathematischen Ausdrücke ausblenden möchten, die Sie im mittleren Platzhalter jeder Achse eingegeben haben.

Legende ausblenden

Aktivieren Sie dieses Feld, um die Legende auszublenden, die unter dem Diagramm angezeigt wird.


Registerkarte "Spuren" für X-Y-Diagramme

Die folgenden Optionen stehen Ihnen auf der Registerkarte "Spuren" des Dialogfelds "Momentan ausgewähltes X-Y-Diagramm formatieren" zur Verfügung:

Legendenname

Dies ist der Name der Spur, der in der Legende erscheint.

Symbol

Hiermit können Sie festlegen, ob jeder Punkt auf der Kurve durch ein Symbol gekennzeichnet werden soll.

Wenn das Diagramm eine Vielzahl von Punkten enthält, die sehr eng beieinander liegen, ist es u. U. ratsam, die Option "Kein" zu wählen.

Linie

Hiermit können Sie festlegen, wie die Linie angezeigt werden soll. Die Linie kann durchgezogen, gepunktet oder gestrichelt sein. Auch eine Strich-Punkt-Linie ist möglich. Verschiedene Linienarten sind zur Unterscheidung unmarkierter Kurven in Schwarzweißdruck nützlich.

Farbe

Hiermit legen Sie die Farbe der jeweils ausgewählten Spur fest. Zur Wahl stehen die Farben rot, blau, grün, magenta, zyan (hellblau), braun, schwarz und weiß. Bei einfarbiger Anzeige wird diese Einstellung ignoriert.

Typ

Hiermit legen Sie fest, ob die ausgewählte Spur als Kurve, als Symbole/Punkte, als Fehlerbalken, als Säulendiagramm, als Stufenkurve, als Zweigdiagramm oder als gefülltes Säulendiagramm dargestellt werden soll.

Stärke

Hiermit können Sie festlegen, mit welcher Dicke die Kurve dargestellt wird. Verwenden Sie 1 für dünne und 9 für dicke Kurven. Geben Sie "p" ein, um eine sehr dünne Kurve (einen Pixel breit) darzustellen. Beachten Sie jedoch, dass eine "p"-Kurve unter Umständen auf Druckern ohne entsprechende Auflösung nicht adäquat gedruckt wird. Mit dieser Option wird außerdem die Größe der Symbole festgelegt, mit denen die einzelnen Datenpunkte gekennzeichnet werden, falls zuvor unter "Symbol" eine andere Option als "Kein" ausgewählt wurde. Wenn Sie sich für spurartige Punkte entschieden haben, wird mit diesem Feld festgelegt, mit welcher Stärke die Punkte zur Kennzeichnung der einzelnen Datenpunkte gedruckt werden.

Argumente ausblenden

Aktivieren Sie dieses Feld, wenn Sie die mathematischen Ausdrücke ausblenden möchten, die Sie im mittleren Platzhalter jeder Achse eingegeben haben.

Legende ausblenden

Aktivieren Sie dieses Feld, um die Legende auszublenden, die unter dem Diagramm angezeigt wird.


Zurückverfolgen von Fehlern

Enthält ein Mathcad-Arbeitsblatt einen Ausdruck, der von vorangegangenen Definitionen abhängt, können Fehler im Ausdruck aus einer Definition weiter oben im Arbeitsblatt stammen. Hierzu ein Beispiel:

Der Fehler erscheint im fünften Bereich, p(0). p(x) basiert jedoch auf der Definition von f(x). Wenn x gleich Null ist, ist p(x) nicht definiert, sodass Mathcad einen Fehler meldet.

In diesem Fall ist die Fehlerquelle offenkundig. In komplexeren Arbeitsblättern oder Programmen mit wiederholten Berechnungen ist dies jedoch nicht immer der Fall. Die Fehlerverfolgung finden die Quelle eines Fehlers. So verfolgen Sie einen Fehler:

  1. Klicken Sie mit der rechten Maustaste auf den Bereich, in dem der Fehler aufgereten ist, und wählen Sie aus dem Kontextmenü die Option Fehler zurückverfolgen. Klicken Sie alternativ dazu auf Fehler zurückverfolgen im Menü Extras. Das Dialogfeld Fehler zurückverfolgen wird geöffnet.

  2. Navigieren Sie mit den Schaltflächen im Dialogfeld zwischen den Bereichen, die mit dem Fehler zusammenhängen. Folgende Schaltflächen stehen zur Verfügung:

  • Vorheriger - Wechselt zum vorhergehenden Bereich, der mit dem gemeldeten Fehler zusammenhängt.

  • Nächster -Wechselt zum nächsten Bereich, der mit dem gemeldeten Fehler zusammenhängt.

  • Erster - Wechselt zum ersten Bereich, der mit dem gemeldeten Fehler zusammenhängt.

  • Letzter - Wechselt zum letzten Bereich, der mit dem gemeldeten Fehler zusammenhängt (also zu dem Bereich, in dem der Fehler gemeldet wurde).

  • Schließen - Schließt das Dialogfeld.

Hinweise:

  • Befindet sich der Fehler in einem ausgeblendeten Bereich, wird die Fehlerrückverfolgung abgebrochen, und es erscheint eine entsprechende Fehlermeldung.

  • Die Funktion "Fehler zurückverfolgen" ist nicht in der Lage, einen Fehler in einem Lösungsblock zu finden.


Nur Datenpunkte

Normalerweise springt der Fadenkreuz-Cursor entlang einer Spur von einem Datenpunkt zum nächsten. Wenn sich der Fadenkreuz-Cursor überall im Diagramm mit dem Zeiger verschieben soll, müssen Sie das Kontrollkästchen "Nur Datenpunkte" deaktivieren.


Operator "Transponieren"

Transponieren

Tastaturbefehl: Strg+1

Gibt ein aus n x m Elementen bestehendes Feld zurück, das durch Vertauschen der Zeilen und Spalten eines aus m x n Elementen bestehenden Feldes gebildet wird.

Operanden:

  • M ist ein aus m x n Elementen bestehendes Feld.

Statt der numerischen Matrixtransponierung können Sie die Transponierte der Matrix auch symbolisch bestimmen.


Baum-Notation

Die Baum-Notation ist eine weitere Art, Binäroperatoren anzuzeigen. Bei der Baum-Notation werden der Operator und die mit ihm verknüpften Operanden in einer Baumstruktur, wie unten dargestellt, angeordnet.


Komplexe Argumente und Ergebnisse in trigonometrischen Funktionen

Komplexe Argumente und Ergebnisse werden mithilfe der folgenden Identitäten berechnet:


Trigonometrische Funktionen

sin(z) cos(z)

tan(z) cosec(z)

sec(z) cot(z)

sinc(z) = sin(x)/x

sinc ist eine spezielle Funktion, die sin(x)/x = 1 in den Begrenzungen richtig auswertet während x gegen 0 geht.

Argumente:

z muss in Radiant angegeben werden.

z muss ein Skalar sein (reell, komplex oder imaginär).


Numerische Probleme bei trigonometrischen Funktionen

Da die trigonometrischen Funktionen unter Verwendung von Gleitkommazahlen mit doppelter Genauigkeit ausgewertet werden, kommt es unweigerlich zu Rundungsfehlern, die sich auf die Berechnungen auswirken. Dies gilt vor allem dann, wenn das Argument der Funktion extreme Werte annimmt.

Rundungsfehler bei trigonometrischen Funktionen treten in den folgenden Fällen auf:

Große Argumente

Bei reellen Argumenten, deren Betrag sich 109 nähert, beginnen diese Funktionen, ihre Genauigkeit zu verlieren. In diesem Fall erscheint eine Fehlermeldung, die auf den Genauigkeitsverlust hinweist.

Singularitäten

Die Tangensfunktion ist bei ganzzahligen Vielfachen von p/2 nicht definiert. Argumente, die sich in der Nähe dieser Singularität befinden, werden ungenau berechnet.

Vielfache von p

Da der von Computern verwendete Wert von p nur ein Näherungswert sein kann, ist sin(p) zwar 0 sehr nahe, aber nicht gleich. tan(p/2) ist nicht undefiniert, gibt aber eine sehr große Zahl zurück.

Wenn Sie genauere Werte benötigen, sollten Sie mit der symbolischen Auswertung arbeiten und dabei Dezimalbrüche verwenden, um Gleitkommaberechnungen zu erzwingen.

Sin(x)/x im Grenzwert während sich x 0 nähert

Sin(x)/x während x sich 0 nähert, hat den Wert 1. Mathcad gibt diesen Wert zurück, wenn x als Argument für sin und als gesamter Nenner im Bruch verwendet wird, oder wenn die gleiche Funktion f(x)=0 als Argument und gleicher Nenner verwendet wird. Wenn g(x)=sin(x) und f(x)=x, gibt g(x)/f(x) den Wert 0 zurück, gemäß den normalen Mathcad-Regeln für den 0/0-Bruch. Wenn Sie sicher gehen wollen, dass die richtige Reaktion erfolgt, verwenden Sie sinc(x).


Abbruch- und Rundungsfunktionen

floor(z) Gibt die größte Ganzzahl ≤ z zurück

Floor(z, y) Gibt das größte Vielfache von y ≤ z zurück

ceil(z) Gibt die kleinste Ganzzahl ≥ z zurück

Ceil(z, y) Gibt das kleinste Vielfache von y ≥ z zurück

rund(z) Gibt floor(z) zurück, wenn der dezimale Teil kleiner als 0.5 ist, andernfalls ceil(z).

Rund(z, y) Rundet z ≥ auf oder ab das nächste Vielfache von z.

trunc(z) Gibt den ganzzahligen Teil von z zurück. Der Bruchteil wird entfernt.

Trunc(z, y) Gibt trunc(z/y)*y zurück.

Argumente:

  • z ist eine komplexe Zahl.

  • z muss dimensionslos für floor, ceil, trunc und rund sein.

  • y must reel und ungleich Null sein.

  • Für Floor, Ceil, Trunc und Rund müssen z und y beide entweder dimensioniert oder dimensionslos sein.

Hinweis:

Die Funktionen floor und trunc geben bei positiven Werten von x denselben Wert zurück. Bei negativen Werten von x unterscheiden sich die Ergebnisse. So ist floor(-2.6)=-3, aber trunc(-2.6)=-2.

Des Weiteren führen floor und ceil zu unterschiedlichen Ergebnissen bei symbolischer Auswertung komplexer Argumente, da Maple eine andere Definition verwendet, die reelle und komplexe Teile eines Arguments gleichzeitig behandelt.


Zweidimensionales Vektorfeld

In einem Vektorfeld gehört zu jedem Punkt (x, y) ein Vektor. In einem Vektorfelddiagramm wird dieser Vektor als kleiner Pfeil dargestellt, der von jedem Punkt ausgeht. Die Länge und die Richtung des Pfeils entsprechen dem Betrag und der Richtung dieses zugehörigen Vektors.


Zwei Arten von Minuszeichen

Es gibt zwei Arten von Minuszeichen. Hier hat es die Funktion in einem Ausdruck wie:

"-1" oder "-(x + z)"

Die andere Funktion ist die zwischen Zahlen wie z. B.:

"(x - z)"

Sie gehen beim Löschen dieser Art von Minuszeichen ebenso vor wie beim Löschen eines Pluszeichens.


Zwei Seiten / Eine Seite

Schaltflächen, mit denen Sie zwischen den Optionen "Zwei Seiten" und "Eine Seite" hin- und herschalten können. Klicken Sie auf "Zwei Seiten", um zwei Seiten Ihres Arbeitsblatts gleichzeitig anzeigen zu lassen. Klicken Sie auf "Eine Seite", um sich nur eine Seite anzeigen zu lassen.


Zweipunkt-Randwertprobleme

Um ein Anfangswertproblem vom Grad n zu lösen, müssen Sie den Wert der Funktion sowie die ersten n-1 Ableitungen am Anfang des Integrationsintervalls kennen. Wenn Sie diese nicht kennen, jedoch

  • einige der Werte der Lösung und der Ableitungen am Anfang des Integrationsintervalls sowie

  • einige Werte der Lösung und der Ableitungen an anderer Stelle im Integrationsintervall kennen und

  • Sie zusammen n bekannte Werte haben,

können Sie nach den unbekannten Werten am Anfang des Integrationsintervalls auflösen und das Randwertproblem in ein Anfangswertproblem umwandeln, das mit rkfest und den anderen Lösungsalgorithmen für Differentialgleichungen gelöst werden kann.

  • Wenn Sie die Werte am Endpunkt des Integrationsintervalls kennen, verwenden Sie sgrw.

  • Wenn Sie die Werte in der Mitte des Integrationsintervalls kennen, verwenden Sie grwanp.

Beispiele

Einzelheiten zur Funktion sgrw

Verwenden der Funktion grwanp


Geben Sie "TOL=" ein, um die Toleranz zu überprüfen.

TOL sollte größer als 0 und kleiner oder gleich 1 sein. Definieren Sie neu, falls erforderlich.

Die vordefinierte Konstante TOL liegt außerhalb des zulässigen Bereichs.

Beheben Sie den Fehler, indem Sie für TOL einen Wert, der

  • größer als (aber nicht gleich) 0 und...

  • kleiner oder gleich 1 ist,

über dem angegebenen Ausdruck definieren.


Eingeben von Symbolen in einem Namen

Wenn Sie ein Symbol wie "$" eingeben, mit dem ein Mathcad-Operator erstellt wird, erhalten Sie normalerweise den Operator und nicht das eigentliche Symbol ($).

Zum Eingeben des eigentlichen Symbols anstelle des Operators in einem Variablen- oder Funktionsnamen gehen Sie vor wie folgt:

  1. Geben Sie als erstes Zeichen des Namens einen Buchstaben oder eine Ziffer ein.

  2. Geben Sie Strg+Umschalt+K ein, damit ein spezieller Textmodus aktiviert wird.

  3. Geben Sie ein oder mehrere Symbole wie $ ein. Die Bearbeitungslinien werden rot. Dadurch wird angezeigt, dass Sie sich im speziellen Textmodus befinden.

  4. Geben Sie Strg+Umschalt+K erneut ein, um in den gewöhnlichen Rechenmodus zurückzukehren.

Beispiel:

Sie können Variablendefinitionen folgender Art erstellen:

x@3:00 := 20

sowie

a+b := 3.24 - 5


Einstelliger Operator

Ein Operator mit einem Operanden. Beispielsweise ist der Operator für die Fakultät, "!", ein einstelliger Operator, da er nach dem Muster "n!" verwendet wird. Hier ist n der Operand.

Die Quadratwurzel und die konjugiert komplexe Zahl sind weitere Beispiele für einen einstelligen Operator.


Unterlauf

Aufgrund der Beschränkungen der Darstellung von Zahlen in einem Computer können zu kleine Zahlen nicht wiedergegeben werden. Wenn ein Ausdruck eine solche Zahl enthält, wird diese Fehlermeldung angezeigt.

Speziell in komplizierten Berechnungen können Zwischenergebnisse zu klein für die Darstellung sein.


Gleichmäßige Verteilung

Verteilungen, die sich auf Gleichverteilung beziehen

dunif(x,a,b) Gibt die Wahrscheinlichkeitsdichte zurück.

punif(x,a,b) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qunif(p,a,b) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rnd(x) Gibt eine gleichmäßig verteilte Zufallszahl zwischen 0 und x zurück.

runif(m,a,b) Gibt einen Vektor aus m Zufallszahlen zurück, die die gleichmäßige Verteilung aufweisen.


Einheitliche Polyeder (Definition)

Einheitliche Polyeder

Einheitliche Polyeder sind regelmäßige Polyeder mit kongruenten Scheitelpunkten. Mit jedem ist ein Name, eine Zahl, ein Dual (der Name eines anderen Polyeders) und ein Wythoff-Symbol verknüpft.

Im Folgenden werden einige einheitliche Polyeder aufgeführt:

Name | Zahlencode | Wythoff-Symbol | Dualname
Fünfeckiges Prisma | 1 | 2 5|2 | Fünfeckige Dipyramide
Ikosaeder | 27 | 5|2 3 | Dodekaeder
Würfel | 11 | 3|2 4 | Oktaeder

Zum Abbilden eines einheitlichen Polyeders können Sie die Funktion Polyhedron verwenden. Um den Namen, das Wythoff-Symbol und den dualen Namen abzurufen, verwenden Sie die Funktion PolyInfo.

Ausführlichere Angaben zu einheitlichen Polyedern finden Sie in anderen Quellen.


Einheitenplatzhalter

Wenn Sie auf ein numerisches Ergebnis klicken, erscheint rechts vom Ergebnis ein kleines schwarzes Kästchen. Dieses Kästchen ist der Einheitenplatzhalter.

Um diesen Platzhalter auszufüllen, klicken Sie auf ihn, und geben Sie den Namen einer Einheit ein.


Funktion "EinhVon"

Funktion "EinhVon"(z) Gibt die Einheit von z zurück. Übergibt 1, wenn für z keine Einheit definiert ist.

Argumente:

z ist ein beliebiger Wert oder ein Feld.

Beispiel:

Hinweise:

Sie können einen Wert durch die Funktion EinhVon dividieren, um seine Einheit zu entfernen. Dies ist zum Beispiel für einige vordefinierte Funktionen wie ln erforderlich, die Argumente ohne Einheit verlangen. Wenn für ein Argument von ln eine Einheit definiert ist, können sie es durch EinhVon dividieren, um die Einheit zu entfernen:


Freigeben einer ausgeblendeten Region

Zum Freigeben einer ausgeblendeten Region ist folgendermaßen vorzugehen:

  1. Klicken Sie zwischen die Grenzen der Region, die Sie freigeben wollen.

  2. Wählen Sie den Befehl Region / Freigeben im Menü Format. Sollte ein Kennwort erforderlich sein, werden Sie danach gefragt.

Hinweis: Sie müssen eine ausgeblendete Region zuerst freigeben, bevor Sie sie wiederherstellen können.


Freigeben einer gesperrten Region

Zum Freigeben einer gesperrten Region gehen Sie wie folgt vor:

  1. Klicken Sie zwischen die Grenzen der Region, die freigegeben werden soll.

  2. Wählen Sie den Befehl Region / Freigeben im Menü Format. Falls zuvor ein Kennwort für die Region festgelegt wurde, werden Sie aufgefordert, dieses einzugeben.


Erfolglose symbolische Transformation

Es gibt eine Reihe von Gründen dafür, dass bestimmte symbolische Transformationen nicht erfolgreich verlaufen. Sie haben möglicherweise versucht, einen Ausdruck zu faktorisieren, bei dem dies nicht möglich ist, oder einen Ausdruck zu vereinfachen, der nicht sinnvoll vereinfacht werden kann.


Die Funktion "bis" und die Bereichsvariable

Die Funktion bis darf nicht in Gleichungen verwendet werden, in denen es mehr als eine Bereichsvariable gibt (z. B. bei Mehrfachsummationen). Mathcad stoppt alle Iterationen für alle Bereichsvariablen, sobald das erste Argument von bis zum ersten Mal negativ ist. Dadurch erhalten Sie im Normfall nicht das gewünschte Ergebnis.


Die Funktion "bis"

Funktion für die Iteration

bis(x, y) Mit dieser Funktion können Sie einen iterativen Prozess auf der Grundlage einer Bedingung anhalten. Gibt y zurück, bis x negativ ist.

Argumente:

x ist ein Testausdruck (der normalerweise eine Negative enthält), die Funktion bis hält die Iteration an.

y ist der durch die Funktion bis bei jedem Iterationsschritt zurückgegebene Wert.


Unbenanntes Arbeitsblatt

Von hier aus können Sie ein neues Mathcad-Arbeitsblatt erstellen und Daten eingeben. Das Erscheinungsbild eines unbenannten Arbeitsblatts wird durch die Vorlagendatei NORMAL.MCT bestimmt.

Wenn Sie ein bereits gespeichertes Arbeitsblatt öffnen wollen, wählen Sie den Befehl Öffnen aus dem Menü Datei.


Pfeil-nach-oben

In leeren Bereichen

Verschiebt das Fadenkreuz nach oben. Wenn sich ein anderer Bereich unmittelbar darüber befindet, erscheint das Fadenkreuz in diesem Bereich und wird entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen

Verschiebt die Bearbeitungslinien nach oben. Wenn sie sich bereits ganz oben im Ausdruck befinden, werden sie ganz aus dem Ausdruck entfernt und im leeren Bereich unmittelbar darüber zu einem Fadenkreuz umgewandelt.

In Textbereichen

Verschiebt die Texteinfügemarke in die vorhergehende Zeile. Ist dies bereits die erste Zeile, wird sie ganz aus dem Text entfernt und als Fadenkreuz-Cursor unmittelbar darüber angezeigt.

Bereiche verschieben

Verschiebt den/die ausgewählten Bereich(e) nach oben. Bei dauerhaft gedrückter Taste wird schneller nach oben verschoben.


Aktualisieren der Ergebnisse im manuellen Modus

Zum Aktualisieren der Anzeige im Fenster:

  • Wählen Sie den Befehl Berechnen aus dem Menü Extras.

Mathcad führt die Berechnungen durch, die zum Aktualisieren aller im Arbeitsblattfenster enthaltenen Ergebnisse erforderlich sind. Wenn Sie nach unten blättern, um mehr vom Arbeitsblatt anzeigen zu lassen, müssen Sie eine Neuberechnung durchführen, um die aktuellen Ergebnisse anzuzeigen.

Alle Ergebnisse im Arbeitsblatt aktualisieren:

  • Wählen Sie den Befehl Arbeitsblatt berechnen aus dem Menü Extras.


Aufwärts kompatibel

Mathcad-Arbeitsblätter sind aufwärts kompatibel. Das heißt, dass ein Arbeitsblatt, das in einer früheren Mathcad-Version erstellt wurde, auch in höheren Versionen geöffnet werden kann.


URL

URL (Universal Resource Locator)

Dies ist der Pfadname (die Adresse) für eine bestimmte Datei im Internet. Der URL für die Mathsoft-Homepage im WWW lautet "http://www.mathsoft.com".


Benutzerdefinierte Gleichungsformatvorlagen

Statt die Schriftart eines Namens bzw. einer Zahl direkt zu ändern, können Sie eine neue Gleichungsformatvorlage definieren, die Sie den Namen und Zahlen zuweisen.

Zum Definieren einer neuen Gleichungsformatvorlage gehen Sie wie folgt vor:

  1. Wählen Sie Gleichung aus dem Menü Format.

  2. Wählen Sie eine noch nicht verwendete Formatvorlage, zum Beispiel "Benutzer 1".

  3. Geben Sie im Feld "Neuer Name der Vorlage" einen Namen für die neue Gleichungsformatvorlage ein.

  4. Klicken Sie auf die Schaltfläche "Eigenschaften", und wählen Sie die Schriftart, die Größe und den Stil für die Formatvorlage aus.

  5. Klicken Sie auf "OK".

Zum Zuweisen dieser Gleichungsformatvorlage zu einem bestimmten Namen bzw. zu einer Zahl gehen Sie wie folgt vor:

  1. Klicken Sie auf den Namen bzw. die Zahl.

  2. Wählen Sie Gleichung aus dem Menü Format.

  3. Wählen Sie aus der Dropdown-Liste im Dialogfeld eine Gleichungsformatvorlage aus.

  4. Klicken Sie auf "OK", um die ausgewählte Formatvorlage dem ausgewählten Namen zuzuweisen.


Verwenden von benutzerdefinierten Binäroperatoren

Um einen von Ihnen bereits definierten Binäroperator einzufügen, klicken Sie an der Stelle, an der Sie den Operator einfügen möchten, und gehen Sie wie folgt vor:

  1. Öffnen Sie die Symbolleiste für Auswertung, die die Schaltflächen für die benutzerdefinierte Operatoren-Notation enthält.

  2. Klicken Sie auf [image] für die "Infix"-Notation oder auf [image] für die "Baum"-Notation..
    Sie werden Folgendes bemerken:

  3. Geben Sie den Namen des Operators in den mittleren Platzhalter ein. Beispiele:

  4. Geben Sie in den anderen zwei Platzhaltern die Operanden ein. Beispiele:


Verwenden von benutzerdefinierten einstelligen Operatoren

Um einen von Ihnen bereits definierten einstelligen Operator einzufügen, klicken Sie an der Stelle, an der Sie den Operator einfügen möchten, und gehen Sie wie folgt vor:

  1. Öffnen Sie die Symbolleiste für Auswertung, die die Schaltflächen für die benutzerdefinierte Operatoren-Notation enthält.

  2. Klicken Sie auf [image] für die Suffix-Notation oder auf [image] für die Präfix-Notation. Sie werden Folgendes bemerken:

  3. Für eine Präfix-Notation geben Sie den Namen des Operators in den linken Platzhalter ein. Für eine Suffix-Notation geben Sie ihn in den rechten Platzhalter ein. Beispiel:

  4. Geben Sie in den anderen Platzhalter den Operanden ein. Beispiel:


Verändern der Größe von Textbereichen mit der Maus

Zum Ändern der Breite eines Textbereichs mithilfe der Maus gehen Sie wie folgt vor:

  1. Markieren Sie den Textbereich.

  2. Setzen Sie den Cursor auf einen Markierungspunkt an der Seite des Bereichs. Die Form des Cursors ändert sich zu einem Doppelpfeil.

  3. Ziehen Sie die Maus nach rechts oder links. Der Textbereich verändert seine Größe, während Sie die Maus ziehen.

  4. Wenn der Textbereich die gewünschte Größe hat, lassen Sie die Maustaste los.


Verwenden von Endwerten zum Ableiten von Anfangsbedingungen

sgrw(v, x1, x2, D, lad, entspr) Gibt einen Vektor zurück, der die Anfangswerte enthält, die bei x1 nicht definiert wurden.

Argumente:

v ist ein Vektor aus Schätzwerten für die bei x1 undefinierten Anfangswerte.

x1, x2 sind Endpunkte des Intervalls, an dem die Lösung für Differentialgleichungen ausgewertet wird.

D ist eine vektorwertige Funktion mit n Elementen, die die ersten Ableitungen der unbekannten Funktionen enthält.

lad ist eine vektorwertige Funktion, deren n Elemente den Werten der n unbekannten Funktionen bei x1 entsprechen. Einige der Werte sind Konstanten, die durch Ihre Anfangsbedingungen bestimmt sind. Andere sind zu Anfang unbekannt, werden jedoch durch sgrw gefunden. Wenn ein Wert unbekannt ist, verwenden Sie den entsprechenden Schätzwert von v.

entspr ist eine vektorwertige Funktion mit derselben Anzahl von Elementen wie v. Jedes Element ist die Differenz zwischen einer Anfangsbedingung bei x2, wie ursprünglich definiert, und dem entsprechenden Schätzwert aus der Lösung. Der Vektor entspr misst, wie nah eine erwartete Lösung den Anfangsbedingungen bei x2 entspricht. Der Wert 0 für jedes Element bedeutet exakte Übereinstimmung.

Hinweise:

  • sgrw löst ein Zweipunktrandwertproblem, indem von den Endpunkten ausgegangen wird und die Trajektorien der Lösung sowie der Ableitungen am Zwischenpunkt verglichen werden.

  • sgrw berechnet die Anfangswerte, die die Lösung haben muss, damit sie den von Ihnen angegebenen Endwerten entspricht. Sie müssen dann die von sgrw zurückgegebenen Anfangswerte nehmen und das resultierende Anfangswertproblem lösen.

  • Wenn Sie die Lösung bei x1 und x2 kennen und n bekannte Werte haben, verwenden Sie sgrw zum Auswerten der fehlenden Anfangswerte bei x1. Sobald Sie über diese fehlenden Anfangswerte verfügen, haben Sie an Stelle eines Zweipunktrandwertproblems ein Anfangswertproblem.


Verwenden der Gleitkommaauswertung

Verwenden Sie den Befehl "Gleitkomma" im Menü Symbolik zum Auswerten von Konstanten wie Pi. Geben Sie die Anzahl der Ziffern rechts vom Dezimalzeichen in dem Dialogfeld an, das durch diesen Befehl aufgerufen wird. Der Standardwert ist 20.


Verwenden von Zwischenwerten zum Ableiten von Anfangsbedingungen

grwanp(v1, v2, x1, x2, xf, D, lad1, lad2, entspr)

Gibt einen Vektor zurück, der die Anfangswerte enthält, die bei x1 nicht definiert wurden.

Argumente:

v1 ist ein Vektor von Schätzwerten für die bei x1 undefinierten Anfangswerte. v2 ist ein Vektor aus Schätzwerten für die bei x2 undefinierten Anfangswerte.

x1, x2 sind Endpunkte des Intervalls, an dem die Lösung für Differentialgleichungen ausgewertet wird.

xf ist ein Punkt zwischen x1 und x2, an dem die Trajektorien der Lösungen, die bei x1 beginnen, und die Trajektorien der Lösungen, die bei x2 beginnen, gleich sein müssen.

D ist eine vektorwertige Funktion mit n Elementen, die die ersten Ableitungen der unbekannten Funktionen enthält.

lad1 ist eine vektorwertige Funktion, deren n Elemente den Werten der n unbekannten Funktionen bei x1 entsprechen. Einige der Werte sind Konstanten, die durch Ihre Anfangsbedingungen bestimmt sind. Wenn ein Wert unbekannt ist, verwenden Sie den entsprechenden Schätzwert von v1.

lad2 entspricht der Funktion lad1, nur mit dem Unterschied, dass deren n Elemente den Werten der n unbekannten Funktionen bei x2 entsprechen.

entspr ist eine vektorwertige Funktion, mit der festgelegt wird, auf welche Art und Weise die Lösungen bei xf übereinstimmen sollen. Gewöhnlich definieren Sie entspr(xf, y) := y, damit die Lösungen für alle unbekannten Funktionen bei xf übereinstimmen.

Hinweise:

  • grwanp löst ein Zweipunktrandwertproblem, indem von den Endpunkten ausgegangen wird und die Trajektorien der Lösung sowie der Ableitungen an den Zwischenpunkten verglichen werden. Dieses Verfahren ist dann sehr nützlich, wenn die Ableitung im Integrationsintervall über eine Unstetigkeit verfügt.

Beispiel:

Verwenden der Funktion "grwanp"


Verwenden von QuickSheets zum Einfügen von Operatornamen

Obwohl ein benutzerdefinierter Operator jeden beliebigen Namen haben kann, bestehen Operatornamen häufig aus mathematischen Symbolen, die nicht direkt über die Tastatur verfügbar sind. Diese Symbole können auf folgende einfache Art und Weise aus einem QuickSheet-Fenster gezogen werden:

  1. Öffnen Sie die QuickSheets im Menü "Hilfe".

  2. Klicken Sie auf "Mathematische Symbole". Es werden verschiedene mathematische Symbole angezeigt, die nicht direkt über die Tastatur zu erhalten sind.

  3. Ziehen Sie das gewünschte mathematische Symbol auf Ihr Arbeitsblatt.

Sie können auch ein Symbol aus einer anderen Anwendung einfügen oder ein Zeichen über seinen ANSI-Code einfügen, soweit bekannt. Halten Sie dazu die Alt-Taste gedrückt, und geben Sie den ANSI-Code auf dem numerischen Tastenfeld ein.

Auf der Rückseite des Mathcad-Benutzerhandbuchs oder Unter "Start", "Programme", "Zubehör", "Systemprogramme", Zeichentabelle finden Sie Codes für Spezialsymbole.


Arbeiten mit mehreren Schlüsselwörtern

Um das Ergebnis eines vorangegangenen Schlüsselworts weiter auszuwerten, können Sie mehrere Schlüsselwörter aneinander reihen. Hierzu stehen Ihnen zwei Möglichkeiten offen. Mit der ersten Methode werden die Zwischenergebnisse aus jedem der Schlüsselwörter angezeigt. Mit der zweiten Methode wird nur das Endergebnis nach der Anwendung aller Schlüsselwörter gezeigt.

Um Zwischenergebnisse anzuzeigen, gehen Sie folgendermaßen vor:

  1. Geben Sie den Ausdruck ein, der symbolisch ausgewertet werden soll, und drücken Sie Strg +Umschalt +Punkt. Geben Sie ein Schlüsselwort in den Platzhalter ein.

  2. Drücken Sie die Eingabetaste, um sich das Ergebnis dieses Schlüsselworts anzeigen zu lassen.

  3. Drücken Sie Strg +Umschalt +Punkt, und geben Sie ein weiteres Schlüsselwort ein.

  4. Drücken Sie Strg +Punkt und dann die Eingabetaste, um sich das Endergebnis anzeigen zu lassen.

Um mehrere Schlüsselwörter anzuwenden, aber nur das Endergebnis anzuzeigen, gehen Sie folgendermaßen vor:

  1. Geben Sie den Ausdruck ein, der symbolisch ausgewertet werden soll, und drücken Sie Strg +Umschalt +Punkt. Geben Sie ein Schlüsselwort in den Platzhalter ein.

  2. Drücken Sie Strg + Umschalt + Punkt, um einen vertikalen Strich und einen Platzhalter einzufügen.

    Geben Sie ein weiteres Schlüsselwort in den Platzhalter ein.

  3. Drücken Sie entweder erneut Strg + Umschalt + Punkt, um ein weiteres Schlüsselwort einzugeben, oder drücken Sie die Eingabetaste, um sich das Endergebnis anzeigen zu lassen.


Using the bvalfit function

Verwenden der Funktion "grwanp"


Verwenden des Fadenkreuz-Cursors

Der als nächstes eingegebene Rechen- oder Textbereich beginnt an der Position des Fadenkreuz-Cursors.

Wenn Sie mit der Eingabe beginnen, wird der Cursor als Paar von Bearbeitungslinien oder als Texteinfügemarke angezeigt.


Verwenden der Bearbeitungslinien

Mit den Bearbeitungslinien wählen Sie Teile des mathematischen Ausdrucks aus. Wenn Sie einen Teil eines Ausdrucks zwischen die Bearbeitungslinien setzen, ist dies mit dem Einfassen in unsichtbare Klammern zu vergleichen. Die Bearbeitungslinien bestehen aus zwei Teilen:

  • Dem Unterstrich, also der horizontalen Bearbeitungslinie

  • Der Einfügelinie, also der vertikalen Bearbeitungslinie.

Zum Positionieren eines Ausdrucks zwischen den Bearbeitungslinien (siehe Beschreibung oben) gehen Sie wie folgt vor:

  1. Klicken Sie mit der Maus auf den Ausdruck.

  2. Falls erforderlich, verschieben Sie die Bearbeitungslinien mit den Richtungstasten.

  3. Falls erforderlich, können Sie die Bearbeitungslinien durch Drücken der Leertaste verlängern, bis sie den gesamten Ausdruck enthalten. Sie können auch auf verschiedene Teile des Ausdrucks klicken und so den Inhalt der Bearbeitungslinien verändern.

Im Allgemeinen gilt:

All das, was unterstrichen ist und links der Einfügelinie steht, wird zum ersten Operator des eingegebenen Ausdrucks.


Verändern der Größe von Textbereichen mit der Tastatur

Zum Ändern der Breite eines Textbereichs mithilfe der Tastatur gehen Sie wie folgt vor:

  1. Klicken Sie in den Textbereich, und verschieben Sie die Einfügemarke an die Stelle, an der die Zeilen des Textbereichs umgebrochen werden sollen.

  2. Drücken Sie Strg+Eingabe.

Beachten Sie, dass dieses Verfahren nur dazu verwendet werden kann, einen Textbereich schmaler zu machen. Wenn Sie einen Textbereich breiter machen wollen, müssen Sie die Maus verwenden.


Verwenden der Funktion "sgrw"


Verwenden der Leertaste

Mit der Leertaste können Sie verschiedene Teile eines mathematischen Ausdrucks auswählen. Was Sie auswählen, hängt davon ab, wo sich die Bearbeitungslinien anfangs befinden. Beispiel:


Arbeiten mit dem symbolischen Gleichheitszeichen bzw. den Menübefehlen

Verwenden Sie entweder die symbolischen Gleichheitszeichen (in Form eines nach rechts zeigenden Pfeils) oder die Menübefehle im Menü Symbolik.

Arbeiten mit dem symbolischen Gleichheitszeichen

Das Arbeiten mit dem symbolischen Gleichheitszeichen erfolgt in Mathcad, genau wie bei numerischen Berechnungen, "aktiv". Das heißt, dass Mathcad alle Variablen und Funktionen des Ausdrucks, der ausgewertet werden soll, daraufhin überprüft, ob sie bereits im Arbeitsblatt definiert worden sind. Findet Mathcad eine Definition, wird diese auch vom Programm verwendet. Alle anderen Variablen und Funktionen werden symbolisch ausgewertet. Nehmen Sie dann später Änderungen an Ihrem Arbeitsblatt vor, werden die Ergebnisse automatisch aktualisiert. Als nützlich erweist sich dies vor allem dann, wenn die symbolischen und numerischen Gleichungen des Arbeitsblatts miteinander verbunden sind.

Arbeiten mit den Menübefehlen im Menü "Symbolik"

Im Unterschied zur numerischen Bearbeitung und dem symbolischen Gleichheitszeichen handelt es sich bei den Menübefehlen im Menü Symbolik nicht um aktive Befehle. Das heißt, Sie können diese Befehle nur immer wieder einzeln auf ausgewählte Ausdrücke anwenden. Die Befehle "kennen" keine vorher eingegebenen Definitionen, und sie nehmen auch keine automatischen Aktualisierungen vor. Es empfiehlt sich daher, diese Menübefehle nur zu verwenden, wenn die symbolische Berechnung relativ separat vom Rest des Arbeitsblatts erfolgen soll und keine vorher vorgenommenen Definitionen eingebunden werden müssen.


Verwenden der Texteinfügemarke

Sie können mit der Einfügemarke Zeichen ebenso einfügen und löschen wie in den gängigen Textverarbeitungsprogrammen.

Das als nächstes eingegebene Zeichen wird an der Einfügemarke angezeigt. Durch Drücken der Rück- oder der Entf-Taste wird das Zeichen links bzw. rechts von der Einfügemarke gelöscht.


Verwenden von RGBSCHREIBEN zum Schreiben von Daten in eine Datei

Dies ist der Name der Bitmap-Datei, in die RGSCHREIBEN die Daten einfügt. Ist bereits eine Datei dieses Namens vorhanden, so wird sie von RGBSCHREIBEN überschrieben.

RGBSCHREIBEN geht davon aus, dass sich diese Datei im Standardverzeichnis befindet. Soll die Datei in ein anderes Verzeichnis geschrieben werden, müssen Sie den vollständigen Pfad zu der betreffenden Datei eingeben.


Der Wert des tief- bzw. hochgestellten Indexes ist zu groß (oder zu klein) für dieses Feld.

Bei diesem Ausdruck wird ein tiefgestellter oder hochgestellter Index verwendet, der sich auf ein nicht vorhandenes Feldelement bezieht.

Der tiefgestellte oder hochgestellte Index sollte nicht kleiner sein als der ORIGIN. Geben Sie "ORIGIN=" ein, damit angezeigt wird, wie ORIGIN festgelegt ist.


Beschränkungen bei Variablen- und Funktionsnamen

  • Namen dürfen nicht mit den Ziffern 0 bis 9, einem Unterstrich ( _ ), einem negativen Apostroph `, oder einem Prozentzeichen (%) beginnen.

  • Das Symbol für Unendlich kann nur als erstes Zeichen in einem Namen vorkommen.

  • Alle Zeichen in einem Namen müssen dieselbe Schriftart, Punktgröße und denselben Stil aufweisen.

  • Mathcad unterscheidet nicht zwischen Variablennamen und Funktionsnamen. Wenn Sie also f(x) definieren und später die Variable f festlegen, sehen Sie, dass Sie f(x) an keiner Stelle unter der Definition von f verwenden können.

  • Bestimmte Namen werden in Mathcad für vordefinierte Konstanten, Einheiten und Funktionen verwendet. Sie können diese Namen zwar neu definieren, sollten jedoch bedenken, dass nach der Definition ihre vordefinierte Bedeutung nicht mehr vorhanden ist. Wenn Sie zum Beispiel eine Variable namens mittelwert erstellen, steht die vordefinierte Funktion mittelwert(v) nicht mehr zur Verfügung.

  • Mathcad unterscheidet zwischen Groß- und Kleinbuchstaben. Zum Beispiel ist die Variable diam nicht mit DIAM identisch.

  • Mathcad unterscheidet Namen voneinander, die in verschiedenen Schriftarten gesetzt sind. Zum Beispiel ist BEREICH nicht mit BEREICH (kursiv geschrieben) identisch.


Variablenformat

Dies ist die standardmäßige Gleichungsformatvorlage, die jedem Variablen- oder Funktionsnamen zugewiesen wird, den Sie im Arbeitsblatt eingeben.


VBScript

Microsoft VBScript ist ein Bestandteil der Sprache Visual Basic für Applikationen, die in Microsoft Excel, Project, Access und dem Entwicklungssystem Visual Basic 4.0 zum Einsatz kommt. VBScript ist als kleine und leichte interpretierte Sprache konzipiert; sie setzt also keine reinen Typen ein (nur Varianten). Da VBScript außerdem als sicherer Bestandteil der Sprache konzipiert ist, beinhaltet es keine Datei-Ein-/Ausgabe und keinen direkten Zugriff auf das zugrundeliegende Betriebssystem.


Vektor (Definition)

Als Vektor wird ein Feld oder eine Matrix bezeichnet, die aus genau einer Zahlenspalte besteht.


Die Elemente im Vektor dürfen nicht alle gleich sein.

Die Elemente in diesem Vektor müssen verschieden sein. Klicken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, auf den Funktionsnamen, und drücken Sie dann F1, um zu sehen, ob Sie die Funktion korrekt verwenden.


Operator "Vektorbetrag"

Vektorbetrag

Tastaturbefehl: |

| v |

Gibt den Betrag des Vektors v zurück.Dies ist die Quadratwurzel der Summe des ins Quadrat gesetzten Betrages der Elemente in v.

Operanden:

  • v ist ein Vektor.

Zum Ermitteln des Betrages der einzelnen Elemente in einem Vektor gehen Sie wie folgt vor:

  1. Setzen Sie | v | zwischen die Bearbeitungslinien.

  2. Wenden Sie den Operator "Vektorisieren" an (Strg+-).


Von kspline zurückgegebener Vektor

Die ersten drei von kspline, lspline und pspline ausgegebenen Werte werden von der Funktion "interp" verwendet. Die übrigen Elemente sind Koeffizienten zweiter Ableitung. Wenn Sie nur auf die Ableitungen zweiter Ordnung zugreifen möchten, verwenden Sie die Funktion "submatrix".


Von regress zurückgegebener Vektor

Die Funktion regress gibt einen Vektor zurück, dessen erste drei Elemente Werte sind, die von der Funktion interp verwendet werden. Die restlichen Elemente sind die Koeffizienten des am besten eingepassten Polynoms k-ter Ordnung.


Operator "Vektorisieren"

Tastaturbefehl: Strg+-

Ändert die Bedeutung der Operatoren und Funktionen so, dass sie für jedes Element eines Feldes gelten. Dadurch können Sie Berechnungen gleichzeitig ausführen.

Operanden:

A und B sind Felder mit derselben Anzahl von Zeilen und Spalten.

Zum Vektorisieren eines Ausdrucks gehen Sie wie folgt vor:

  1. Setzen Sie den Ausdruck zwischen die Bearbeitungslinien.

  2. Drücken Sie Strg+-.

Beispiele:

Zur Ausführung einer Matrixmultiplikation von A und B würde Folgendes angezeigt werden:

Zum Multiplizieren jedes Elements von A mit dem entsprechenden Element in B:

Hinweis:

Viele Funktionen und Operatoren führen automatisch Operationen an den Elementen eines Feldes aus, sodass nicht immer der Operator "Vektorisieren" verwendet werden muss. Setzen Sie den Operator "Vektorisieren" vor allem dann ein, wenn eine Funktion oder ein Operator eine spezielle Bedeutung für Felder hat. Im Beispiel oben hat die Multiplikation z. B. eine spezielle Bedeutung, wenn Sie auf Felder angewendet wird, und diese Bedeutung wird standardmäßig verwendet. Der Operator "Vektorisieren" muss verwendet werden, um eine elementweise Multiplikation zu erzwingen.


Symbolisches Vektorisieren

Mit dem Vektorisierungsoperator wenden Sie eine vordefinierte Funktion auf alle Elemente einer Matrix an, wie unten gezeigt. Zur Anwendung des Vektorisierungsoperators markieren Sie den gesamten Ausdruck (Funktion und Matrixargument), und drücken Sie Strg+ -. Wählen Sie dann Vereinfachen im Menü Symbolik.


Extras - Animation - Aufnehmen

Öffnet ein Dialogfeld, in dem Sie eine Animation erstellen können. Hierzu müssen Sie folgendes tun:

  1. Erstellen Sie ein Element, das von der Variable FRAME abhängt. In der Regel ist dies ein Ausdruck oder ein Diagramm mit der Variable FRAME.

  2. Wählen Sie diesen Menübefehl.

  3. Legen Sie den Arbeitsbereich, der animiert werden soll, durch Ziehen mit der Maus fest.

  4. Legen Sie im Dialogfeld den Anfangs- und den Endwert für FRAME fest.

  5. Klicken Sie auf "Animieren".

Nach der Erstellung der Animation wird ein neues Fenster angezeigt, in dem Sie die Animation wiedergeben können.


Extras - Animation - Wiedergeben

Öffnet das folgende Fenster, in dem vorhandene Animationsclips abgespielt werden:


Extras - Einstellungen

Das Dialogfeld "Einstellungen" mit den Registerkarten "Allgemein", "HTML-Optionen", "Skript-Sicherheit" und "Sprache" wird angezeigt.

Verwenden Sie die Registerkarte Allgemein, um Elemente der Mathcad-Benutzeroberfläche anzupassen, wie z. B. Tastaturkürzel und Starteinstellungen.

Verwenden Sie die Registerkarte HTML-Optionen, um festzulegen, wie Dokumente in HTML/MathML exportiert werden.

Verwenden Sie die Registerkarte Skriptsicherheit, um das Niveau der Dokumentsicherheit festzulegen.

Verwenden Sie die Registerkarte Sprache, um sprachspezifische Funktionen in Mathcad anzupassen, wie z. B. Sprache für die Rechtschreibung und Menüsprache.


Ansicht / Aktualisieren

Baut den Bildschirm neu auf.


Ansicht / Bereiche

Zeigt alle Bereiche in der Standard-Hintergrundfarbe, wobei der Rest des Arbeitsblatts grau belassen wird. Der kleine Punkt auf der linken Seite jedes Bereichs ist der Ankerpunkt des Bereichs. Der Ankerpunkt zeigt den tatsächlichen Speicherbereich an, der beim Berechnen der Arbeitsblätter verwendet wird.

Um die normale Arbeitsblattansicht wiederherzustellen, wählen Sie den Befehl erneut.


Ansicht / Lineal

Blendet das Arbeitsblatt-/Textlineal ein oder aus:

Wenn Sie auf eine leere Stelle in einem Arbeitsblatt klicken, können Sie mit dem Arbeitsblattlineal Tabulatoren für das Arbeitsblatt setzen oder Ausrichtungshilfslinien einfügen, um die vertikale Ausrichtung der Bereiche zu erleichtern.

Wenn Sie in einen Textbereich klicken, wird statt des Arbeitsblattlineals das Textlineal aktiviert. Es hat dieselbe Größe wie der Textbereich. Mit dem Textlineal können Sie Tabulatoren setzen und Einzüge im Text festlegen.


Ansicht / Statusleite

Die Statusleiste befindet sich unmittelbar unterhalb der horizontalen Bildlaufleiste am unteren Rand des Haupt-Arbeitsblattfensters. Hier finden Sie eine Reihe von mitunter wichtigen Informationen:

  • Wenn Sie eine Gleichung bearbeiten, finden Sie in der Meldungszeile der Statusleiste Hinweise, was Sie als nächstes tun sollten.

  • Bleibt der Mauszeiger einen Moment über einer Symbolleisten-Schaltfläche stehen, wird in der Meldungszeile der Statusleiste eine Beschreibung dieser Schaltfläche angezeigt.

  • Rechts unten in der Statusleiste können Sie ablesen, auf welcher Seite Sie sich befinden.

  • Steht in der Statuszeile "Auto", bedeutet dies, dass sich das Arbeitsblatt im automatischen Modus befindet.

  • "Rech F9" bedeutet, dass das Arbeitsblatt sich im manuellen Modus befindet. In diesem Fall müssen Sie die Taste F9 drücken, um die Berechnung zu starten und die Ergebnisse anzeigen zu lassen.


Ansicht / Symbolleisten

Blendet folgende Symbolleisten ein bzw. aus:

Standard-Symbolleiste

Symbolleiste "Formatierung"

Symbolleiste "Rechnen"

Steuerung

Ressourcen

Symbolleiste "Taschenrechner"

Symbolleiste "Diagramm"

Matrix

Symbolleiste "Auswertung"

Symbolleiste "Differential/Integral"

Symbolleiste "Boolesche Operatoren"

Symbolleiste "Programmierung"

Symbolleiste "Griechisch"

Symbolleiste "Symbolik"

Symbolleiste "Modifikator"

Welche Funktion die jeweiligen Schaltflächen einer Symbolleiste haben, sehen Sie, wenn Sie mit dem Cursor auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der entsprechenden Schaltfläche verweilen lassen bis:

  • eine QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche erscheint, und

  • in der Meldungszeile der Statusleiste eine Beschreibung der Schaltfläche angezeigt wird.


Ansicht / Zoom...

Vergrößert einen Bildbereich zu einer Detailansicht, wenn Sie einen Wert von mehr als 100 % einstellen.

Wenn Teile eines Arbeitsblatts angezeigt werden sollen, die derzeit außerhalb des Bildschirmbereiches liegen, oder wenn das gesamte Arbeitsblatt angezeigt werden soll, wählen Sie einen Zoom-Wert unter 100 %.


Menü "Ansicht"

Symbolleisten

Lineal

S tatusleiste

Kopf- und Fußzeile...

Bereiche

Aktualisieren

Zoom...


Einsehen der ursprünglichen Version des Elektronischen Buchs

Sie können den derzeit offenen Abschnitt aus dem nicht veränderten Exemplar des Elektronischen Buchs wie folgt vorübergehend einsehen:

  • Wählen Sie den Befehl Originalabschnitt einsehen im Menü Buch.

Rückkehr zur geänderten Version des derzeit offenen Abschnitts:

  • Wählen Sie den Befehl Geänderten Abschnitt einsehen im Menü Buch.


WAV-Zugriffsfunktionen

READWAV(datei) Erstellt eine Matrix, die Signalamplituden in datei enthält. Jede Spalte steht für einen separaten Datenkanal. Jede Zeile entspricht einem Zeitpunkt.

WRITEWAV(datei,s,b) Erstellt eine WAV-Signaldatei aus einer Matrix. Wird wie folgt verwendet:

WRITEWAV( datei,s,b) := M

Die Funktion muss allein auf der linken Seite einer Definition stehen. Wenn für die Bitauflösung b 1-8 festgelegt ist, werden die Daten als Bytezeichen ohne Vorzeichen in die Datei geschrieben. Der Bereich für Bytedaten ohne Vorzeichen liegt zwischen 0 und 256. Wenn für die Bitauflösung b 9-16 festgelegt ist, werden Wortdaten (2-Byte-Daten) in die Datei geschrieben. Der Bereich für Wortdaten liegt zwischen -32768 und 32767.

GETWAVINFO(datei) Erstellt einen Vektor mit vier Elementen, die Informationen zu datei enthalten. Die Elemente entsprechen der Anzahl der Kanäle, der Abtastfrequenz, der Anzahl der Bits pro Abtastung (Auflösung) und der durchschnittlichen Anzahl von Bytes pro Sekunde.

Argumente:

  • datei ist eine Zeichenfolgevariable, die dem PCM (Pulse Code Modulated) Microsoft WAV-Dateinamen bzw. -pfad entspricht.

  • s ist eine ganzzahlige Abtastfrequenz.

  • b ist die Bitauflösung.

  • M ist eine ganzzahlige Matrix.


Wavelet-Transformationen

wave(v) Gibt die Wavelet-Transformation der Daten in v über den Daubechies-4-Koeffizienten-Wavelet-Filter zurück.

iwave(u) Gibt die zu wave inverse diskrete Wavelet-Transformation für die Daten in u zurück.

Argumente:

  • v und u müssen 2m Elemente haben, wobei m eine ganze Zahl ist.

  • Alle Elemente von v müssen reell sein.


Web-Browser-Schaltfläche in der Symbolleiste des Informationszentrums


Weibull-Verteilung

Verteilungen, die sich auf die Weibull-Verteilung beziehen:

dweibull(x,s) Gibt die Wahrscheinlichkeitsdichte für die Weibull-Verteilung zurück.

pweibull(x,s) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qweibull(p,s) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rweibull(m,s) Gibt einen Vektor aus m Zufallszahlen zurück, die die Weibull-Verteilung aufweisen.


Willkommen in Mathcad!

Mathcad ist die Industriestandard-Rechensoftware für Techniker und Ingenieure, Fachlehrer und Studenten. Mathcad ist so vielseitig und leistungsstark wie eine Programmiersprache, aber so leicht zu erlernen wie der Umgang mit Kalkulationstabellen. Außerdem ist es vollständig vernetzt, sodass Sie die Vorzüge des Internet und die Vorteile von anderen Anwendungen, mit denen Sie täglich arbeiten, voll nutzen können.


Was ist eine Komponente?

Bei einer Komponente handelt es sich um ein spezialisiertes OLE-Objekt, das Sie in ein Mathcad-Arbeitsblatt einfügen können, um auf diese Weise eine Verbindung zwischen dem Arbeitsblatt und einer Datenquelle bzw. einer anderer Anwendung, die Daten enthält, herzustellen. Zum Einfügen einer Komponente wählen Sie den Befehl "Komponente" im Menü "Einfügen". Die folgenden Komponenten sind verfügbar:

  • Axum: Mit dieser Komponente können Sie in einem Mathcad-Arbeitsblatt Axum-Graphen erstellen.

  • Dateien lesen/schreiben: Diese Komponente ermöglicht das Lesen und Schreiben von Datendateien in einer Vielzahl von Formaten. Wählen Sie den Befehl Komponente aus dem Menü Einfügen.

  • Datenerfassung: Mit dieser Komponente können Sie Daten zu einem Messgerät senden bzw. von diesem empfangen.

  • Excel: Mit dieser Komponente lässt sich eine Verknüpfung zwischen einem Mathcad-Arbeitsblatt und einer Excel-Datei herstellen.

  • Eingabetabelle: Diese Komponente dient zum Eingeben von Daten in eine tabellenkalkulationsartige Tabelle.

  • MathSoft-Steuerelement: Diese Komponente dient zum Erstellen von Steuerelementen, wie Schaltflächen, Schiebereglern und Textfelder, über die die Benutzer mit Ihrem Mathcad-Arbeitsblatt interagieren können. Wählen Sie den Befehl Komponente aus dem Menü Einfügen.

  • MATLAB: Mit dieser Komponente können Sie eine Verknüpfung zwischen einem Mathcad-Arbeitsblatt und einer MATLAB-Datei einfügen.

  • ODBC lesen: Diese Komponente dient zum Abrufen von Informationen aus einer SQL-unterstützten ODBC-Datenbank.

  • Skriptobjekt: Hiermit und mithilfe einer Skript-Sprache lässt sich eine benutzerdefinierte Komponente einfügen.

  • S-PLUS-Graph und S-PLUS-Skript: Mit diesen Komponenten können Sie in einem Mathcad-Arbeitsblatt S-PLUS-Graphen erstellen und S-PLUS-Skripts ausführen.


Einschränkung auf letzten Punkt

Wenn Sie an den Zwischenwerten der Lösung nicht interessiert sind, können Sie Verarbeitungszeit sowie Arbeitsspeicher sparen, indem Sie eine der folgenden Funktionen verwenden.

radau, stiffb und stiffr für stiff-Systeme.

rkadapt für sich langsam ändernde Systeme.

bulstoer für stetige Systeme.

Anders als bei den Funktionen, die mit Großbuchstaben geschrieben werden, geben Sie hier nicht die Anzahl der Punkte im Ergebnis an. Stattdessen müssen Sie den Genauigkeitsgrad angeben. Die Funktionen generieren dann eine Lösung mit der benötigten Anzahl von Elementen.


Mögliche Positionen des Fadenkreuz-Cursors

Der Fadenkreuz-Cursor kann nur außerhalb eines mathematischen Bereichs oder Textbereichs angezeigt werden.

Dies ist der einzige Cursor, der sich auf einer leeren Stelle in Ihrem Dokument befinden kann.


Mögliche Positionen der Bearbeitungslinien

Bearbeitungslinien können nur in einem mathematischen Ausdruck angezeigt werden.


Mögliche Positionen der Texteinfügemarke

Die Texteinfügemarke kann nur in einem Textbereich angezeigt werden.


While-Loops

Verwenden Sie eine "while"-Schleife, wenn Sie möchten, dass eine Gruppe von Anweisungen so lange ausgeführt wird, bis eine Bedingung erfüllt ist. Stellen Sie sicher, dass eine Anweisung vorhanden ist, aufgrund derer die Bedingung nicht erfüllt wird. Andernfalls wird die Schleife unendlich lange ausgeführt, und Sie müssen sie durch Drücken von Esc stoppen.

Zum Einfügen einer "while"-Schleife gehen Sie wie folgt vor:

  1. Klicken Sie auf den Platzhalter, in den Sie die "while"-Schleife eingeben möchten.

  2. Klicken Sie auf [image] auf der Symbolleiste "Rechnen", um die Symbolleiste "Programmierung" zu öffnen, die die Programmierungsoperatoren enthält.

  3. Klicken Sie auf die Schaltfläche while, oder drücken Sie [Strg]+ ]. Geben Sie nicht einfach "while" ein.

  4. Geben Sie in den Platzhalter rechts neben "while" einen Booleschen Ausdruck ein. Klicken Sie gegebenenfalls in der Symbolleiste "Programmierung" auf die Schaltfläche "+1 Zeile", um Platzhalter für zusätzliche Anweisungen einzufügen.

  5. Geben Sie in den Platzhalter unter "while" die Anweisung ein, die wiederholt ausgeführt werden soll. Fügen Sie mit der Schaltfläche + 1 Zeile gegebenenfalls Platzhalter für weitere Anweisungen ein.

"While"-Schleifen sind dann nützlich, wenn Sie die Ausführung bei Eintreten einer Bedingung stoppen möchten und Sie nicht genau wissen, wann diese Bedingung eintritt. Wenn Sie genau wissen, wie viele Wiederholungen Sie benötigen, verwenden Sie stattdessen eine "for"-Schleife.


Fenster / Symbole anordnen

Arrangiert die Titelleisten aller minimierten Arbeitsblätter, die in der linken unteren Ecke des Anwendungsfensters erscheinen, sodass diese ein sauberes Bild ergeben.


Fenster - Überlappend

Blendet inaktive Arbeitsblattfenster hinter aktiven Fenster aus, ohne die Titelleisten auszublenden.


Fenster - Liste offener Arbeitsblätter

Alle geöffneten Arbeitsblätter werden im Menü "Fenster" angezeigt. Das Arbeitsblatt mit dem Häkchen ist das aktive Arbeitsblatt. Klicken Sie auf eines der anderen aufgeführten Arbeitsblätter, um es zum aktiven Arbeitsblatt zu machen.


Fenster - Weitere Fenster

Zeigt ein Dialogfeld mit einer Liste aller geöffnetere Arbeitsblätter an. Dieses Menüelement ist nur dann verfügbar, wenn Sie mehr als 10 Arbeitsblätter geöffnet haben. Klicken Sie auf eines der aufgeführten Arbeitsblätter, um es zum aktiven Arbeitsblatt zu machen.


Fenster - Untereinander

Ordnet alle Arbeitsblätter so an, dass sie:

  • vollständig das Anwendungsfenster überdecken

  • eins über dem anderen angeordnet liegen


Fenster - Nebeneinander

Ordnet alle Arbeitsblätter so an, dass sie:

  • vollständig das Anwendungsfenster überdecken

  • Seite an Seite liegen


Menü "Fenster"

Überlappend

Untereinander

Nebeneinander

Liste offener Arbeitsblätter

Weitere Fenster


Arbeiten mit einem Bild

Verwenden der Bild-Symbolleiste

Es gibt viele Möglichkeiten, mit einem Bild zu arbeiten. Sie können die Ausrichtung, die Ansicht (Zoom- und Schwenkfaktoren), die Helligkeit, den Kontrast und die Grauskala eines Bilds in Ihrem Arbeitsblatt verändern, indem Sie die Bild-Symbolleiste verwenden. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie auf das Bild, bis der Bildrahmen wie gezeigt markiert ist.

  2. Die Bild-Symbolleiste wird angezeigt. Bewegen Sie kurz die Maus darüber, um die Quickinfo dazu anzuzeigen und herauszufinden, was jedes Werkzeug bewirkt.

Um ein Bild zu vergrößern, klicken Sie beispielsweise auf [image] auf der Bild-Symbolleiste, und klicken Sie mehrmals auf das Bild, bis es die gewünschte Auflösung hat. Sie können mit jeweils [image], [image] oder [image] verkleinern, auf Fenstergröße vergrößern oder den Vergrößerungsfaktor zurücksetzen.

Die Werkzeuge der Bild-Symbolleiste können auch mit einem Rechtsklick auf das Bild verwendet werden.

Verwenden des Dialogfelds "Eigenschaften"

Im Dialogfeld "Eigenschaften" können Sie das Farbmodell oder die Ausgabeoption auswählen. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie mit der rechten Maustaste auf das Bild, und wählen Sie im Kontextmenü den Befehl Eigenschaften.

  2. Führen Sie Ihre Änderungen in den Registerkarten "Eingabe" und "Ausgabe" in den jeweiligen Felder durch, und klicken Sie auf "OK".

Sie können beispielsweise die Farbinformationen eines ausgewählten Rechtecks eines Bildes an eine Variable Ihres Arbeitsblatts senden. Das ist nützlich, wenn Sie ein anderes Bild erstellen wollen, das nur einen Teil des ganzen Bildes darstellen soll. Aktivieren Sie die Option "Ausgewählte Matrix ausgeben" im Ausgabefeld des Dialogfelds "Eigenschaften", und wählen Sie eine Farboption. Wenn Sie auf "OK" klicken, müssen Sie einen Variablennamen im Platzhalter auf der linken Seite des Bildbereichs eingeben.

Hinweise:

  • Es gibt zwei Dialogfelder "Eigenschaften" für den Bildbereich. Eines steuert die Eigenschaften des Bereichs einschließlich der Anzeige einer Grenze, Hervorheben des Bereichs und Deaktivieren der Berechnung eines Bereichs. Das andere steuert die Eigenschaften des Bildes, die, wie oben bereits erwähnt, in dem Bereich angezeigt werden.

  • Wenn Sie das Erweiterungspaket für Bildbearbeitung oder das Communication System Designt (CSD)-Paket haben, verfügen Sie bereits über eine Image Viewer-Komponente, die sich ähnlich eines Bildbereichs verhält. Sowohl in der Image Viewer-Komponente als auch im Bildbereich können Sie Bilddateien importieren und mit speziellen Symbolleistenoptionen verändern.


Arbeiten mit Graden

Die trigonometrischen Funktionen gehen alle davon aus, dass das Argument in Radianten angegeben ist. Sie können Ihre eigenen trigonometrischen Funktionen definieren, um Grade als Argument zu akzeptieren. Das unten angezeigte Beispiel zeigt diesen Vorgang.

Siehe Umwandlung in Grad.


Arbeiten mit Mathcad und Excel

Wenn Sie sowohl Mathcad als auch Excel verwenden, können Sie die beiden Anwendungen problemlos miteinander kombinieren: Sie können Daten aus der einen Anwendung kopieren und in die andere einfügen, Objekte in die jeweils andere Anwendung aufnehmen oder Berechnungen aus einer Anwendung in die andere übernehmen.

Was möchten Sie jetzt tun?

  • Daten aus Excel in Mathcad übernehmen

  • Daten aus Mathcad an Excel übertragen

  • Excel-Objekte in Mathcad einfügen

  • Mathcad-Objekte in Excel einfügen

  • Excel-Berechnungen in ein Mathcad-Arbeitsblatt übernehmen

  • Mathcad-Berechnungen in ein Excel-Arbeitsblatt übernehmen


Arbeitsblattlineal

Das Arbeitsblattlineal ist ein nützliches Hilfsmittel zur Ausrichtung von Bereichen in einem Arbeitsblatt.

Zum Anzeigen des Arbeitsblattlineals gehen Sie wie folgt vor:

  1. Klicken Sie auf eine leere Stelle im Arbeitsblatt oder in einem Rechenbereich.

  2. Wählen Sie Lineal im Menü Ansicht aus.

Jetzt wird das Arbeitsplatzlineal oben im Fenster angezeigt.

Sie können die Ausrichtungshilfslinien am Lineal wie folgt einstellen:

  1. Klicken Sie an den Stellen auf das Lineal, an denen die Ausrichtungshilfslinien erscheinen sollen. Auf dem Lineal erscheint ein Tabulatorsymbol.

  2. Klicken Sie mit der rechten Maustaste auf den Tabulator, und wählen Sie Hilfslinie einblenden im Kontextmenü. Neben dem Befehl erscheint ein Häkchen.

  3. Sie können auch Hilfslinien und Tabulatoren mit dem Befehl Tabulatoren aus dem Menü Format einstellen.

Die Ausrichtungshilfslinie wird als grüne, vertikale Linie angezeigt. Wählen Sie Bereiche neben der Hilfslinie aus, und verschieben Sie sie.

Um eine Ausrichtungshilfslinie zu entfernen, klicken Sie auf das Lineal mit der rechten Maustaste an der Stelle, wo sich die Hilfslinie befindet, und wählen Sie Hilfslinie anzeigen aus dem Menü aus, um sie zu deaktivieren.

Hinweise:

  • Die Tabulatoren, die Sie auf dem Lineal einfügen, bestimmen, wohin der Cursor verschoben wird, wenn Sie die Tabulatortaste drücken. Um einen Tabulator zu entfernen, klicken Sie auf sein Symbol, halten Sie die Maustaste gedrückt, und ziehen Sie den Cursor vom Lineal weg.

  • Sie können die Maßeinheit im Lineal ändern, indem Sie mit der rechten Maustaste auf das Lineal klicken und Zoll, Zentimeter, Punkte oder Pica im Kontextmenü wählen.

  • Die Anzeigeoptionen für das Lineal und die Maßeinheiten werden gespeichert, wenn Sie eine Vorlage erstellen. Sollen die Lineal- und Maßeinheitenoptionen für alle Dokumente geändert werden, nehmen Sie die Änderung am besten in der Vorlagendatei NORMAL.MCT vor.


Funktion SCHREIBEN

Schreiben von Dateien auf Festplatte

SCHREIBEN("datei") Schreibt eine Zahl in die Datei datei.

Argumente:

datei ist entweder der Pfad zu einer ASCII-Datei.

datei wird als Zeichenfolge eingegeben.

Die Funktion SCHREIBEN wird normalerweise zusammen mit einem Vektor und einer Bereichsvariable verwendet, wie z. B. in:

i := 1..N

SCHREIBEN("datei.dat") :=

Im Beispiel oben wird die Liste der Zahlen im Vektor v in die Datei datei.dat geschrieben.

WARNUNG: Diese Funktion dient lediglich zur Sicherstellung der Kompatibilität mit älteren Mathcad-Versionen. Die Funktion ist jedoch veraltet und sollte nicht mehr verwendet werden. Verwenden Sie zum Schreiben von Daten aus einer Datendatei stattdessen die Funktion PRNSCHREIBEN.


Exportieren von Daten in eine Datei

Der Vorgang, bei dem Daten aus einem Mathcad-Arbeitsblatt mit einem Mal in eine externe Datendatei übertragen werden. Wenn sich die Daten im Mathcad-Arbeitsblatt ändern, werden die Daten in der Datendatei automatisch aktualisiert.


Wenn zwischen x und y die folgende Beziehung besteht:

Wenn zwischen x und y die folgende Beziehung besteht:

y = A*exp(k*x)

können Sie die Funktionen neigung und achsenabschn auf den Logarithmus Ihrer Datenwerte anwenden und dabei Folgendes nutzen:

ln(y) = ln(A) + k*x

In diesem Fall gilt:

A = exp(achsenabschn(vx,ln(vy)) und k = neigung(vx,ln(vy))

Die sich ergebende Anpassung gewichtet die Fehler anders als eine Kleinste-Quadrate-Exponentialanpassung, stellt aber im Normalfall eine gute Annäherung dar.


Sie versuchen, ein Feld oder einen Bereich als Skalar zu verwenden.

Sie versuchen, ein Feld oder einen Bereich als Skalar zu verwenden. Drücken Sie F1, um die Hilfe aufzurufen.

Sie haben einen Vektor oder einen Ausdruck mit einem Bereich bzw. einen anderen Ausdruck verwendet, für den ein Skalar erforderlich ist.


Sie haben einen Rechenvorgang unterbrochen. Um fortzufahren,...

Sie haben einen Rechenvorgang unterbrochen. Um fortzufahren, klicken Sie hier und drücken "F9".

Sie haben zum Stoppen einer Berechnung [Esc] gedrückt. Sie können die markierte Gleichung neu berechnen, indem Sie den Cursor in die Gleichung setzen und BerechnenÞ Jetzt berechnen im Menü Extras wählen, oder [F9] drücken.

Wenn Sie die Berechnung für das ganze Arbeitsblatt wieder aufnehmen wollen, wählen Sie stattdessen Arbeitsblatt berechnen oder drücken Sie [Strg] F9.

Wenn Sie feststellen, dass Sie häufig die Berechnungen unterbrechen, um nicht jedes Mal warten zu müssen, bis Mathcad die Berechnung des Arbeitsblatts beendet hat, empfiehlt es sich, in den manuellen Modus zu wechseln.


Z-Transformation

Zur Auswertung der z-Transformation einer Funktion gehen Sie wie folgt vor:

  1. Geben Sie den zu transformierenden Ausdruck ein.

  2. Klicken Sie auf die Transformationsvariable.

  3. Wählen Sie Transformation / z- im Menü Symbolik.

Mathcad gibt bei z-Transformationen eine Funktion in der Variable z zurück. Wenn der zu transformierende Ausdruck bereits ein z enthält, wird stattdessen eine Funktion in der Variable zz zurückgegeben. Mit dem Befehl Variable / Ersetzen können Sie z durch eine andere Variable oder einen Ausdruck ersetzen.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie das Schlüsselwort "ztrans" in Verbindung mit der aktiven symbolischen Auswertung.


Faktor oder Zähler gleich Null

Zugunsten der Effizienz nimmt Mathcad stets an, dass für jeden gegebenen Ausdruck x Folgendes gilt:

0*x=0

sowie

0/x = 0

Stößt Mathcad auf eine Berechnung dieses Typs, wird x daher nicht berechnet. Dies hat folgende Konsequenzen:

Mathcad legt sofort den Nullwert als Ergebnis für solche Ausdrücke fest, selbst wenn für x eine zeitaufwendige Berechnung wie ein Integral oder eine Summierung erforderlich wäre.

Würde die Berechnung von x zu einem Fehler führen, bleibt dies unentdeckt, da Mathcad ohne eine Berechnung den Wert Null als Ergebnis ausgibt. In bestimmten Fällen ist dies wünschenswert, in anderen eher störend.

Mathcad gibt als Ergebnis für 0/0 anstelle eines Fehler Null aus.


Vergrößern

Vergrößert einen Teil Ihres Arbeitsblatts. Es gibt insgesamt zwei Vergrößerungsstufen.


Verkleinern

Macht alle Vergrößerungen rückgängig, sodass Sie Ihr Arbeitsblatt wieder in der von der Option "Seitenansicht" verwendeten normalen Größe sehen.


Zoom-Cursor

Vergrößert den Teil Ihres Arbeitsblatts, über dem sich der Cursor befindet, wenn Sie mit der rechten Maustaste klicken. Um Ihr Arbeitsblatt in noch höherer Vergrößerung anzeigen zu lassen, können Sie nochmals mit der Maus klicken. Wenn Sie die maximale Vergrößerung erreicht haben und wiederum auf das Arbeitsblatt klicken, wird die Vergrößerung Ihres Arbeitsblatts wieder rückgängig gemacht.


Vergrößern eines 3D-Diagramms

Zum Vergrößern eines 3D-Diagramms gehen Sie folgendermaßen vor:

  1. Klicken Sie in das Diagramm.

  2. Halten Sie STRG und die Maustaste gedrückt.

  3. Ziehen Sie die Maus.

  4. Lassen Sie die Maustaste los, wenn der Vergrößerungsfaktor korrekt ist.

Zum Vergrößern eines 3D-Diagramms um einen bestimmten Betrag gehen Sie folgendermaßen vor:

  1. Klicken Sie mit der rechten Maustaste auf das Diagramm.

  2. Wählen Sie Eigenschaften im Popup-Menü.

  3. Klicken Sie im Dialogfeld auf die Registerkarte "Allgemein".

  4. Ändern Sie den Wert im Textfeld "Zoom".

Hinweis:

Wenn Sie mit einer IntelliMouse-kompatiblen Maus mit Mittelrad arbeiten, können Sie das Rad zum Vergrößern oder Verkleinern eines dreidimensionalen Diagramms drehen.


Vergrößern eines Kreisdiagramms

Zum Vergrößern eines Teils eines Diagramms gehen Sie folgendermaßen vor:

  1. Klicken Sie in das Kreisdiagramm, um es auszuwählen, und wählen Sie dann Diagramm / Zoom im Menü Format, damit das Dialogfeld "Kreis-Zoom" aufgerufen wird.

  2. Setzen Sie den Zeiger in den Diagrammbereich, drücken Sie die Maustaste, und halten Sie sie gedrückt. Ziehen Sie die Maus, bis der gestrichelte Auswahlkreis den zu vergrößernden Bereich gerade umschließt.

  3. Lassen Sie die Maustaste los. Der Radius des ausgewählten Bereichs wird im Feld "Radius" des Dialogfelds "Kreis-Zoom" aufgeführt.

  4. Wählen Sie die Schaltfläche "Zoom", damit das Diagramm wieder angezeigt wird. Die Achsenbegrenzungen werden vorübergehend auf die im Dialogfeld "Kreis-Zoom" angegebenen Koordinaten festgelegt. Um diese Achsenbegrenzungen permanent anzuwenden, klicken Sie auf "OK."

  5. Wählen Sie "Zurück", wenn Sie den Zustand des Diagramms vor dem Vergrößern/Verkleinern wiederherstellen möchten. Falls Sie mehrmals Ausschnitte des Kreisdiagramms vergrößert haben, klicken Sie auf "Original", um das ursprüngliche Diagramm wiederherzustellen.


Vergrößern eines X-Y-Diagramms

Zum Vergrößern eines Teils eines Diagramms gehen Sie folgendermaßen vor:

  1. Klicken Sie in das Diagramm, damit es ausgewählt wird.

  2. Wählen Sie den Befehl Diagramm / Zoom aus dem Menü Format. Daraufhin wird das Dialogfeld "Zoom" geöffnet.

  3. Setzen Sie im Diagrammbereich den Zeiger auf eine Ecke des zu vergrößernden Bereichs, drücken Sie die Maustaste, und halten Sie sie gedrückt.

  4. Ziehen Sie die Maus so, dass der zu vergrößernde Bereich von einem gestrichelten Auswahlrahmen eingeschlossen wird.

  5. Klicken Sie auf "Zoom", damit das Diagramm neu angezeigt wird.

Wenn Sie auf "Zoom" klicken, werden als Achsenbegrenzungen vorübergehend die im Dialogfeld "Zoom" angegebenen Koordinaten festgelegt. Um diese Achsenbegrenzungen permanent anzuwenden, klicken Sie auf "OK."